Projectiondesign Action one mk III User`s guide

an introduction to the processors,
use and set up
user’s guide
Multi
Image
Processing
System
Designed and manufactured in Fredrikstad, Norway.
www.projectiondesign.com
english
Multi image processor User’s Guide – Introduction
2
english
1 Introduction
1.1 Thank you
Thank you for purchasing a Multi image processing system processor.
The Multi image processing systems WB2560 and WB1920 are state-of-the-art image
processing engines for the combination and setup of multiple projectors in order to create
one, large, seamless image. By combining multiple projectors, images with unprecedented
resolution and fidelity can be created.
The multi image processing system processors feature unique functionality and unmatched
compatibility, and are perfectly tailored to working with projectiondesign projectors for use in
multi-image environments.
1.1 Features
• Geometry correction
• Blending and overlap
• 2560x1600, and 1920x1200 models available
• User selectable algorithm setups
• 4x4 Lanczos scaling
• Bi-linear scaling
• B-cubic scaling
• Project onto any surface
• Zero, or near zero latency, depending on set up and configuration
• 3D stereo compatible, up to 1920x1200 on WB2560, and 1280x800 on WB1920
• Patented Black Level Matching for uniform black levels
• Per-pixel Colour-, Uniformity-, and brightness matching
• 12-bit internal resolution
• Dual-Link DVI-D in / out
• All control through Ethernet
• Built-in power supply for easy power management in large racks
• Integrates seamlessly with projectiondesign ProNet multi image processing system
software setup suite
• Rack mount, ½ width, 1U height
• Unlimited scalability and channel count
• Fully transparent to source, no special software or source requirements
3
www.projectiondesign.com
english
Contents of this User’s Guide
1Introduction
3
1.1 Thank you
1.1Features
2SAFETY
7
2.1 GENERAL WARNINGS
2.2 WEEE INFORMATION
2.3 WARNING ABOUT SUBSTANCES
2.3.1
WARNING SYMBOLS
3
What’s in the box?
9
3.1 The multi image processing system comes with the following:
4
Installation and setup
11
4.1 System requirements
4.2 System overview
4.3Connectors
4.4 LED indicators / Front button
4.5 Network settings
4.6 Firewall settings
4.7Software
4.8 Mounting the multi image processing system processor in rack
5
Getting to know the GUI
15
5.1ProNet.site
5.2 WB Calibrator – Device View
5.2.1
Creating and saving a multi image processing system setup project
5.2.2
Backing up and restoring calibration
5.2.3
Adding multi image processing system units to a project
5.2.4
Using the Device View Toolbar, DVT
5.2.5
Clearing calibration
5.2.6
Notifications and advanced network settings
5.2.7
Performing software upgrades
5.2.8
Controlling EDID information
5.3 WB calibrator – Calibration View
5.3.1
Using the Calibration View Toolbar (CVT)
5.3.2
Selecting/deselecting multi image processing system units
5.3.3
Using the Calibration Panel Toolbar (CPT)
Multi image processor User’s Guide – Introduction
4
6
Geometry correction
english
5.4 Multi image processing operational states
5.4.1
Bypass states
5.4.2
Calibration state
5.4.3
Online state
5.4.4
Auto state
27
6.1 Warping algorithms
6.1.1Perspective
6.1.2
Mesh Warp Transform
6.1.3
Mesh Warp Bezier
6.2 Warping user interface
6.3 Scaling filters
6.3.1
Lanczos filter
6.3.2
B-spline filter
6.3.3
C-spline filter
6.3.4
Linear interpolation filter
6.4 Working with the perspective algorithm
6.5 Working with the Mesh Transform algorithm
6.6 Working with Mesh Bezier algorithm
6.7 Fine tuning control points
6.8 Real Time Warp
7
Edge blending
35
7.1Introduction
7.2 Edge blending algorithms
7.2.1
Basic edge blending
7.2.2
Advanced edge blending
7.2.3
User interface for basic edge blending
7.2.4
User interface for advanced edge blending
7.2.5
Adjusting the shape of advanced edge blending zones
7.2.6
Adjusting the advanced blend drop-off curve
8
Test patterns
8.1
8.2
8.3
8.4
5
41
Circle test pattern
Grid (Pixel) test pattern
Grid (Angle) test pattern
Turning test patterns on and off
www.projectiondesign.com
english
9
Black Level Management
45
9.1 Creating adjustment zones
9.2 Removing BLM zones
9.3 Adjusting black level in a defined zone
10Masking
49
10.1Adding areas to clip
10.2Removing clip areas
11
Storing and recalling data
53
11.1Storing/recalling calibration to/from the multi image processor unit
11.2Storing/recalling data to/from the control PC
11.2.1
Restoring calbration files
11.3Accept calibration
12
Technical specifications
57
12.1Electrical
12.2Mechanical
Multi image processor User’s Guide – Introduction
6
This device complies with safety regulations for Information Technology Equipment intended
to operate in “normal” environments (offices and homes). Before using the device for the first
time, please read the safety instructions thoroughly.
english
2 SAFETY
2.1 GENERAL WARNINGS
Use only the cables and cords supplied with the device or original replacement cables. Using
other cables or cords may lead to malfunction and permanent damage of the device.
Always use 3-prong / grounded power cord to ensure proper grounding of the device. Never
use 2-prong power cords, as this is dangerous and could lead to electrical shock.
Never open the device. The device contains no user serviceable parts. Refer all repairs to
qualified personnel only. Make sure that no objects enter into the vents and openings of the
set.
Do not spill any liquids on the device or into the vents or openings of the device.
Always remove protective plastic covering the device before operating the device.
Only place the device on a stable surface, or mount it securely in a rack.
Do not drop the device.
The device can be used as desktop or rack mounted with the certification labels facing
down. Any other mounting directions are not allowed. When rack mounted, care must
be taken to keep ventilation on back and front sides open. Operating the device in other
positions may lead to overheating, resulting in malfunctioning.
Always allow ample airflow through the device. Never block any of the air vents. Never
cover the device in any way while running. Allow for sufficient distance to walls and other
obstructions to avoid overheating.
Minimum safety distance to front or rear of the device is 20 cm (8”) to rear and 5 cm (2”) to
front.
The device is designed for indoor use only. Never operate the device outdoors.
Do not operate the device outside its temperature and humidity specifications, as this may
result in overheating and malfunctioning.
Only connect the device to signal sources and voltages as described in the technical
specification. Connecting to unspecified signal sources or voltages may lead to malfunction
and permanent damage of the device.
2.1 WEEE INFORMATION
This product conforms to all requirements of the EU Directive on waste electrical and
electronic equipment (WEEE). This product should be recycled properly. It can be
disassembled to facilitate proper recycling of the individual parts.
Consult your dealer or relevant public authority regarding drop-off points for collection of
WEEE.
7
www.projectiondesign.com
english
2.1 WARNING ABOUT SUBSTANCES
This product contains chemicals, including lead, known to the State of California to cause
birth defects or other reproductive harm. Recycle properly, do not dispose of in ordinary
waste!.
2.1.1 WARNING SYMBOLS
READ USER GUIDE Attention! Read the user guide for further information!
RECYCLE Warning! Recycle properly, do not dispose of in ordinary waste!
NO TELEPHONE Warning! Do not connect to telephone lines!
Multi image processor User’s Guide – Safety instructions
8
3.1 The multi image processing system comes with the following:
english
3 What’s in the box?
Multi image processing system unit
Power Cable (Country Dependant)
2x Dual Link DVI cables
CD with software
Network cable
User Documentation
Please verify that you have all compoents upon unpacking the unit, and its contents.
Please save packaging materials for future use, should it be necessary to ship the unit.
9
www.projectiondesign.com
english
Multi image processor User’s Guide - What’s in the Box?
10
The following section outlines the general requirements to supporting equipment in order to
run the ProNet Calibrator and successfully setting up a multi image based projection system.
english
4 Installation and setup
4.1 System requirements
ProNet 2.0 – required to set up and operate multi image processing system processors,
works with Microsoft Windows® operating systems only. The following versions are supported:
• Windows XP (32-bit only), SP xx or
• Windows Vista (32- or 64-bit)
• Windows 7 (32- or 64-bit)
In addition, Microsoft .NET Framework 3.5 or later must be installed.
Any standard computer capable of running the above operating systems should work, but for
best performance, the computer running ProNet 2.0 should have at least:
• Intel® Dual Core™ architecture or similar.
• 2 GB of RAM
• 200 MB of free disk space
• 1.0 Gigabit Ethernet interface
Note! For the ProNet application to be displayed correctly, 96 DPI must be used (Windows
Default).
11
www.projectiondesign.com
english
4.2 System overview
A multi image processing system contains the following main components:
• An Image Generator (IG) with one or more channels (outputs) (not provided by
projectiondesign).
• One multi image unit per channel
• One projector per channel
• A PC for setup and control
• Optional CAD tool for designing systems (not provided by projectiondesign)
Figure 4-1 shows a complete system overview of a multi image processing setup.
PROCESSOR
PROCESSOR
PROCESSOR
Figure 4-1. Multi image processing system overview
4.3 Connectors
Connector Panel:
• Power connector/switch
• 2 x DVI-connectors
• LAN-connector
• RS232-connector (for service only - do not use)
• Kensington Lock slot
Figure 4-2. Connector panel
Multi image processor User’s Guide – Installation and setup
12
The front button and the Power and Status LED-indicators on the processor front panel have
the following functions:
Front button:
Push 1 time:
Show info on screen
(visual ID/IP/present serial no.)
Push 3 times:
Reboot
Press and hold
5 seconds:
Network reset
Press and hold
15 seconds:
Factory reset
Power LED:
Status LED:
BLUE: ON
GREEN: ON
BLUE: Blinking
• Booting up
GREEN: Blinking
• DVI IN not valid and/or
• Network not OK
YELLOW: Blinking
• Upgrading software
RED: ON
• Temperature too high
english
4.4 LED indicators / Front button
Figure 4-3. Front button and LED-indicators
4.5 Network settings
For optimum performance during calibration, a 1.0 Gbps Ethernet connection is
recommended. 100 Mbps will also give adequate performance.
The communication between the control PC and multi image processing system units is
based on a bidirectional XML protocol. We recommend that any firewall between Control PC
and multi image processing system units should be disabled.
Multi image processing system processors support DHCP in a network environment. Static
IP addresses can be set if there is no DHCP server available. Processors also support Zero
configuration networking (zeroconf).
Note! It is recommended that the multi image processing system processors and the
ProNet Control PC are run in a dedicated network environment.
13
www.projectiondesign.com
english
4.6 Firewall settings
The multi image processing system processor communicates extensively on the network. In
order for it to communicate freely with the ProNet application, the following ports must be
open in the firewall:
• 22 outbound (SSH)
• 1900 inbound (UPnP open for AutoDiscovery of multi image processing system
processors)
• 30000 outbound (dedicated multi image processing instruction command set)
• 40400 outbound (dedicated ASCII command set)
• 49500 - 49600 inbound (configurational range; one port number per multi image unit)
Note! The firewall must not filter Ping on LAN (ICMP Type 8 (ICMP Echo Request)).
4.7 Software
To the use multi image processing system, ProNet.site must be installed on a control PC.
The latest version of the software can be found at www.projectiondesign.com
A license key is required to use the software. The key can be acquired by contacting an
authorised projectiondesign representative.
4.8 Mounting the multi image processing system processor in rack
Each multi image processing system processor is half-width, 1U standard size, so two
channels can be combined in a single standard 19” 1RU rack mounting plate, available from
projectiondesign. Remove the upper and lower screws on each side of the multi image processing system processor, position the mounting plate and reenter the screws as shown in
Figure 4-4 and Figure 4-5.
Figure 4-4. Rack mount plate
Figure 4-5. Rack mounted
Multi image processor User’s Guide – Installation and setup
14
5.1 ProNet.site
english
5 Getting to know the GUI
Figure 5-1 gives an overview of ProNet.site. The application has four main areas of interest:
• The File menu located in the top-left corner.
• The “Site Devices” overview on the left hand side of the GUI.
• Control, status, monitoring and timed operations overviews for one or more selected
devices on the right hand side.
• Status messaging window at the bottom.
Figure 5-1. Overview of ProNet.site
To start the multi image processing system calibrator (referred to as WB - warp & blend in
menus) plugin, select “Control Panels” > “Predefined” > “WB calibrator”.
Licence key required to see more than one device (see section “4.7 Software”)
Enter lisence key: File menu <Help> license key. Enter key and other information as per
provided key.
15
www.projectiondesign.com
english
5.2 WB Calibrator – Device View
Figure 5-1 shows the “Device View” window that is displayed when the “WB Calibrator”
plugin is started. The “Device View” window contains the following areas:
• The File menu located in the top-left corner
• The Device Pool window in the lower left corner.
• A multi image processing system information window in the lower right corner.
• A dedicated toolbar on the left hand side.
• A Device View Desktop that is displayed in the centre of the ProNet application window.
All multi image processing system units added to a project are shown here along with
their arrangement.
Figure 5-1. WB calibrator, Device View.
5.2.1 Creating and saving a multi image processing system setup project
When starting the multi image processing system calibrator, a new project will be started
automatically. In the Device View, a project contains the multi image processing units added,
and their arrangement in the Device View desktop. Projects can be saved and opened on the
control PC. This is done from the File menu. See Figure 5-1.
Note! Project files are saved as XML files. Project files are saved on the control PC, not in
the multi image processing unit itself.
5.2.2 Backing up and restoring calibration
Calibration files for each multi image processing unit in a project can be backed up or
restored from the File menu.
Backup files are stored on the control PC, not in the multi image processing unit itself.
Multi image processor User’s Guide – Getting to know the GUI
16
english
Figure 5-1. File menu, Device View.
5.2.3 Adding multi image processing system units to a project
To enable and add multi image processing system units to a project, simply drag and drop
units from the tree view in the Device Pool (Figure 5-1) to the Device View Desktop. The
multi image processing system units in the Device Pool are detected using ProNet’s built-in
universal plug-n-play capability.
Figure 5-1. The Device Tree in the Device Pool.
Multi image processing system units can also be added or deleted from the Device View
Desktop by using the
17
and
icons in the toolbar.
www.projectiondesign.com
english
5.2.4 Using the Device View Toolbar, DVT
The Device View Desktop window has a toolbar on the left hand side, known as the Device
View Toolbar. The toolbar can be shown with or without help texts, see Figure 5-1. Figure 5-1. Toolbars, shown with and without help texts.
Using the toolbar you can:
• Add or remove multi image processing system units from a project.
• Select or deselect all multi image processing system units on the Desktop.
• Show an information window for a selected unit. The information window shows system
status (temperature, fan operation, DVI signal detection in/out) and system versions for
software, hardware, FPGA, and more.
• Using the Configuration tool, Visual ID (on screen identification) and custom notes are
configured. System latency is also set up from this menu.
• The Basic Blend page sets the number of overlapping pixels for the selected channel(s).
The blend drop-off curve is also configured here.
• Identify is used to configure display of visual ID information, and identify units on the
Desktop. Extended visual ID mode will, in addition to showing your custom Visual ID,
show network information and serial number of the unit.
• Bypass sets the unit in bypass mode. No processing occurs.
• Online. This switches the processor to full processing mode. The signal on the DVI input
will be processed according to set calibration and passed to the DVI output connector.
• Mute or unmute more units
Most of the features accessed from the toolbar menu are also available by right-clicking a
selected unit, and choosing it from the context sensitive menu that shows up.
Multi image processor User’s Guide – Getting to know the GUI
18
To clear calibration from selected multi image processing system units, select Edit > Clear
Calibration from the File menu. Under Clear Calibration, one can select to clear all or just
parts of the calibration. See Figure 5-1.
english
5.2.5 Clearing calibration
Figure 5-1. Clearing calibration
5.2.6 Notifications and advanced network settings
Under Settings > Application Settings, message notification levels and advanced network
settings are configured, see Figure 5-1.
Figure 5-1. Application and Network settings.
5.2.7 Performing software upgrades
All multi image processing system units can easily be upgraded via the ProNet 2.0 user
interface. System software is available from www.projectiondesign.com. Select Maintenance
> Multi Image Processor Software Update. The window shown in Figure 5-1 appears. Locate
the system update file(s), typically mips-system-008.0001.02.00.tgz, and click “Select..”.
After the file has loaded successfully into the update application, click “Start”.
IMPORTANT: This is just the first step in the upgrade process. When the progress bar
has reached 100%, the unit will start to reconfigure itself for the new software.
This configuration can take up to 15 minutes.
IMPORTANT: Do not unplug the power during this process!
19
www.projectiondesign.com
english
The software update process is complete when the power status LED on the unit is showing
a steady blue light.
Figure 5-1. Multi image processing software upgrade window.
5.2.8 Controlling EDID information
The unit defaults to giving the image generator either WUXGA or WQXGA EDID data
depending on the version of the multi image processing system unit that is in use. EDID
data can also be configured manually, or the unit can pass EDID data information from the
projector directly to the image generator (referred to as “EDID sink”).
To manipulate EDID setting, select Maintenance > EDID Administrator. Select the EDID file
you want to use and click “Activate”. Verify that the selected EDID is applied, see bottom
of window Active EDID. For passing the EDID data directly from the projector to the image
generator, select edid_sink.bin. The EDID Administration window is shown in Figure 5-1.
Figure 5-1. EDID Administration.
Multi image processor User’s Guide – Getting to know the GUI
20
When all multi image processing system units are added to the project in the Device View,
switch WB Calibrator to “Calibration View”. This is done by clicking the “Calibration View”
button in the top-left corner. Clicking the same button in Calibration View mode will bring you
back to Device View. See Figure 5-1.
english
5.3 WB calibrator – Calibration View
Figure 5-1. Switching views from Calibrator view to Device view and back.
5.3.1 Using the Calibration View Toolbar (CVT)
Like in Device View, Calibration View has its own toolbar on the left hand side of the screen.
This is called the Calibration View Toolbar, CVT. The toolbar can be shown with or without
help texts, Figure 5-1. To enable the help texts, click the question mark.
Figure 5-1. Calibration toolbar, without and with help texts.
21
www.projectiondesign.com
english
5.3.2 Selecting/deselecting multi image processing system units
The WB Navigator is a window used to select multi image processing system units in a
project, Figure 5-12. In this window, WB units can be selected or deselected either by
clicking on them or using the assigned short cut key combination.
Figure 5-1. WB Navigator
Similar selection capabilities can be found in the top toolbar, Figure 5-1. In this toolbar
automatic arrangement of open windows can also be done.
Figure 5-1. Top toolbar window navigation
Multi image processor User’s Guide – Getting to know the GUI
22
The calibration panel has a set of tools on the left hand side of the window. This toolbar can
be shown with or without help texts, “Figure 5-1. Calibration Panel Toolbar, without and with
help texts.”
english
5.3.3 Using the Calibration Panel Toolbar (CPT)
Figure 5-1. Calibration Panel Toolbar, without and with help texts.
23
www.projectiondesign.com
english
The Calibration Panel Toolbar has these main functions:
• Zoom. Scale the work area in the calibration panel.
• Image Orientation. Change the orientation of the calibration panel to match the physical
orientation of the projector (e.g. rear/ceiling or portrait).
• Set Colors. Set the color for background, lines, control points and internal test patterns,
see Figure 5-1.
Figure 5-1. Set colors control box
• Layers. Calibration layers for warping, blending, test patterns and other can be turned on
and off for easier setup.
• Hide Inactive. Hide inactive controls. Only active points will be visible on the WB output
display.
• Active Guide Points. When using Mesh Bezier Warp or Bezier lines in clipping (masking)
or black level management feature, the Bezier functionality (control points) can be turned
off. The Selected line will have a linear behaviour.
• Show Point Setup. Show Control Point Setup when a control point is selected. Location
specifies the x and y position of the current control point. In Bezier Guide Point Configuration the control point can be configured to be symmetric, corner or smooth.
- Symmetric. Corresponding guide points will have identical strength and angle.
- Corners. Guide points will be independent in both strength and angle.
- Smooth. Corresponding guide points will have identical angle.
Figure 5-1. Control point setup
Multi image processor User’s Guide – Getting to know the GUI
24
• Bezier Fixed Length/Angle. Specify the bezier guide point behaviour. Off allow adjustment of both length and angle. Fixed length allows the user to change angle, but not the
length. Fixed 1/3 length will fix the length to 1/3 when the control point is moved. Fixed
angle allow the user to change the length while the angle is fixed.
english
• Show info labels. Show extra info for selected control point.
Figure 5-1. Bezier point settings
• Straighten Line. Can be used to straighten selected Bezier lines (short cut key: Ctrl + L).
• Control Point. Up, down, left and right arrows. Use to move between control points or
move a control panel one or 1/10 of a pixel.
5.4 Multi image processing operational states
Multi image processing system can operate in 4 different states: Bypass, Calibration, Online
or Auto. Switch between the different states using the action toolbar.
5.4.1 Bypass states
The DVI input signal is bypassed through the system and passed to the DVI output.
5.4.2 Calibration state
Calibration mode is used to configure the system. Different test patterns will be shown
depending on what type of calibration is being performed (warp, blend, masking etc.). The
Multi image processing system unit will automatically enter calibration state upon clicking on
any of the calibration tools in the actions toolbar.
5.4.3 Online state
In online state the DVI input signal is processed according to the calibration and sent to the
DVI output.
5.4.4 Auto state
When a calibration is completed and the accepted calibration is stored in multi image
processing system unit auto state will be used upon power up of the unit. If the multi image
processing system find a stored calibration that matches the input resolution, it will enter
online state (image processing enabled). If no calibration is found, the unit will be in bypass
state.
25
www.projectiondesign.com
english
Multi image processor User’s Guide – Getting to know the GUI
26
Image Geometry Correction (often referred to as Image Warping) is the process of digitally
manipulating image data so that the image’s projection precisely matches a specific
projection surface or shape. Image Geometry Correction compensates for the distortion
created by off-axis projection or screen placement or non-flat screen surfaces by applying a
compensating inverse distortion to the image in the digital domain. Usually, Image Geometry
Correction is applied so that areas of the projection surface are perceived by the viewer to
map to the corresponding areas in the source image.
english
6 Geometry correction
6.1 Warping algorithms
The multi image processing system supports 3 different warping algorithms: Perspective,
Mesh Warp Transform, Mesh Warp Bezier. The best way to understand how they work is to
test the different algorithms in an actual system setup. One projector and one multi image
processing system unit is enough to learn how they work.
Note! Image Geometry Correction is not applied until operational mode is changed to
“online”, which enable you to see the result.
6.1.1 Perspective
This is advanced keystone. Only the four corners of the image can be manipulated.
6.1.2 Mesh Warp Transform
This is recommended for use on simple, slightly curved screens. The number of control
points can be dynamically added. Start off with a few control points and increase the grid
size as needed. When the grid is increased, the position of any added point in the finer grid
mask will be given a correct position automatically. Maximum grid size is 16x16.
6.1.3 Mesh Warp Bezier
This is a very powerful tool where you can manipulate not only the control points of the grid,
but also the tangent vectors connected to every control point. The control points of the
tangent vectors are called Bezier control points.
Bezier patch meshes are superior to meshes of triangles as a representation of smooth
surfaces, since they are much more compact, easier to manipulate, and have much better
continuity properties. In addition, other common parametric surfaces such as spheres and
cylinders can be well approximated by relatively small numbers of cubic Bezier patches.
Maximum grid size is 16x16, but the flexibility of this algorithm usually allows for correct
geometric distortion with very few control points.
27
www.projectiondesign.com
english
6.2 Warping user interface
To apply warping to an image, select “Warp” from the left hand toolbar. The window in Figure
6-1 will appear.
Figure 6-1. Warping algorithm setup
Algorithms can be added or removed. If the perspective transform is added first, Mesh Warp
Transform can be used in addition. If Mesh Warp Transform or Mesh Warp Bezier is added
first, a combination of algorithms is not allowed.
In this window, grid size is also configured. For the control points of an algorithm to be
visible, the grid size must be at least 1x1.
Increasing grid size during calibration is very convenient. This enable for rough calibration
with few control points, and fine tuning with increased grid size as needed.
Decreasing grid size during calibration is not recommended as you may lose fine tuning data
you have already added to the grid.
Multi image processor User’s Guide – Geometry Correction
28
Regardless of the warping algorithms selected, a scaling filter will be applied. Scaling filters
are configured using the Algorithm Setup window. Select the tab “Filter”, Figure 6-2, and
select your desired filter. Four different scaling filters are supported:
english
6.3 Scaling filters
• Lanczos, B-spline, C-spline, Linear
Figure 6-2. Scaling filters
6.3.1 Lanczos filter
The Lanczos filter is using a 4x4 kernel. This filter is recommended for use with images that
contains large amounts of fine detail, for example text with small fonts. On thin, diagonal or
curved lines, some ripple may be encountered.
6.3.2 B-spline filter
The B-spline filter available in multi image processing system is of the type Cubic B-spline.
This filter is slightly softer than the Lanczos filter, but has better quality on curved and straight
lines. In many cases, this filer will give the best image quality and is therefore the default
selection.
6.3.3 C-spline filter
The C-spline filter is short for Cubic Hermite spline interpolation. It is a filter of third-degree
spline with each polynomial of the spline in Hermite form (Named in the honour of Charles
Hermite). This filter gives a good combination of smoothness, detail and average ripple on
lines.
6.3.4 Linear interpolation filter
This filter is also a polynomial filter, but is based on linear interpolation for curve fitting.
In modern systems, it will give an unnecessarily low quality image scaling, but some
applications may still require the use of this filter.
29
www.projectiondesign.com
english
6.4 Working with the perspective algorithm
To start working with the perspective algorithm, click the “Warp” icon, add the perspective
algorithm and set grid size to 1x1. In order to map the geometry to the surface being
projected on, drag the control points with the mouse. Figure 6-3 shows basic usage of the
Perspective algorithm.
Figure 6-3. Working with the perspective transform
Multi image processor User’s Guide – Geometry Correction
30
To start working with Mesh Transform algorithm, click the “Warp” icon, add the Mesh
Transform algorithm and start with setting the grid size to 1x1. First map the four corners to
their desired location. As required, increase the grid size. This will add more rows, columns
and control points to the mesh and enable the possibility to map the grid correctly onto the
surface. Figure 6-4 is showing a simple 3x3 grid using the Mesh Transform algorithm. Even
though the lines between the control points are not smoothly curved in the user interface,
they will be in the multi image processing system unit and hence on the screen.
english
6.5 Working with the Mesh Transform algorithm
Figure 6-4. Working with the Mesh Transform algorithm
31
www.projectiondesign.com
english
6.6 Working with Mesh Bezier algorithm
To start working with Mesh Bezier algorithm, click the “Warp” icon, add the Mesh Bezier
algorithm and start with setting the grid size to 1x1. The grid you see now will contain four
control points – one in each corner. In addition all control point will have 2-4 additional, white
control points for controlling the Bezier vectors in a given point, Figure 6-5.
Figure 6-5. Mesh Bezier with 1x1 grid
First map the four control points (orange) to their desired location. Then move the Bezier
control point to curve the lines between to control points to map the screen geometry (Figure
6-6). When using this algorithm, geometry mapping to cylinders, spheres and other well
defined surfaces can be done with very few control points. Like with the Mesh Transform
algorithms, the grid size can be increased as much as needed to get the required accuracy
for a given surface. A 1x1 grid should regardless of the projection surface be used as a
starting point.
Multi image processor User’s Guide – Geometry Correction
32
english
Figure 6-6. Working with Mesh Bezier, simple mapping
6.7 Fine tuning control points
To fine tune the position of a warping control point, first click on the control point.
Then press and hold Ctrl while using the arrow keys on the keyboard to move the control
point.
6.8 Real Time Warp
Real Time Warp state can be turned off and on in the Calibration View Toolbar, see Figure
6-7. When Real Time Warp state is Off, the grid will be on display and in the user interface.
When Real Time Warp is On, the image from the IG will be shown on the display, while the
grid is shown in the user interface.
Figure 6-7. Real time warp state
33
www.projectiondesign.com
english
When Real Time Warp is On, only the active control point will be added to the image from the
IG if Show active is selected. Show active can be enabled in the Calibration Panel Toolbar
see Figure 6-8.
Figure 6-8. Calibration panel guide points
NOTE! When working on a warp in Real Time mode, the displayed, warped image will be
generated using a linear approximation. When going online the selected algorithm will be
used to calculate the online image. There could be a small difference between the image in
Real Time warp mode and in online mode.
Multi image processor User’s Guide – Geometry Correction
34
english
7 Edge blending
7.1 Introduction
Edge Blending is a companion feature to Image Geometry Correction. Edge Blending enables the seamless projection of a large image using several overlapping projectors. Since
geometry correction for projection on non-flat surfaces is a built-in requirement in almost all
Edge Blending systems, the pairing of Edge Blending and Image Geometry Correction in the
same video signal processor is a natural one.
7.2 Edge blending algorithms
Multi image processing system support two different types of edge blending: Basic and
Advanced
7.2.1 Basic edge blending
Basic edge blending is used for simple and slightly curved surfaces. A percentage or a
defined number of overlapping pixels is specified. The overlapping region of each side (top,
bottom, left, right) of the image is then geometry corrected with the warping that is being applied to the image.
7.2.2 Advanced edge blending
Advanced edge blending is used for more complex surfaces like a dome (spherical). With
advanced edge blending, warping and blending is completely disconnected. After correct
geometry correction has been applied, multiple blend areas are defined to create the seamless image.
7.2.3 User interface for basic edge blending
To apply basic edge blending to an image, select “Blend” from the left hand toolbar, and
select Basic Blend Setup. The window in Figure 7-1 will appear.
Note! Overlap (= shared pixels between two channels) must be applied on the IG.
35
www.projectiondesign.com
english
Figure 7-1. Basic edge blending.
In the Basic Blend setup window, overlapping pixels (or percent) can be specified. The blend
drop-off curve of can also be tuned. Tuning the blend drop off curve is also possible when
the unit is in Online state, for a visual fine tuning of the curve.
Multi image processor User’s Guide – Edge Blending
36
To apply advanced edge blending to an image, select “Blend” from the actions toolbar, and
select Advanced Blend Setup. All blend zones will now have to be added manually. Click
“Add zone” and select a default location for the blend zone, see Figure 7-2.
english
7.2.4 User interface for advanced edge blending
Figure 7-2. Adding a blend zone.
37
www.projectiondesign.com
english
The “Add Blend Zone” window in Figure 7-3 will appear. Configure the initial parameters for
the blend zone and click “Add Blend Zone” to add it to the UI. “White” means the location of
the full on side of the blend zone (white line). “Black” means the location of the full off side of
the blend zone (black line). These blend zone will be completely disconnected from the warping and should hence be applied after the geometry correction is complete.
Figure 7-3. Add blend zone window.
7.2.5 Adjusting the shape of advanced edge blending zones
Working with the advanced edge blending zones is very similar to the controls of Mesh Warp
Bezier. All control points and Bezier points can be used to create the correct shape for the
blend zones. Figure 7-4 shows two blend zone, top and left, where adjustments for perfect fit
have been done.
Figure 7-4. Working with advanced edge blending.
Multi image processor User’s Guide – Edge Blending
38
The drop-off curves can be configured individually for advanced blend. Click on a control
point in the blend zone you would like to adjust, or select multiple points or blend zones with
by dragging a selection rectangle over the areas of interest. Then select “Drop-off Curve” in
the Calibration panel toolbar. Adjust the drop-off curve with the vertical and horizontal sliders,
as illustrated in Figure 7-5.
english
7.2.6 Adjusting the advanced blend drop-off curve
Figure 7-5. Adjusting the blend drop off curve.
39
www.projectiondesign.com
english
Go to custom if you need to change the selected curve or enter a new manually, as seen in
Figure 7-6.
Figure 7-6. Drop-off curve setup
Multi image processor User’s Guide – Edge Blending
40
The multi image processor has several built-in test patterns for easier setup. This tool can
be used to tune the geometry (warping) in a setup to match reference points, aspect ratio,
ensure visual correctness and to configure 3D image generators for shapes like cylinders and
domes. The test patterns are:
english
8 Test patterns
• Circles. Add circle to your calibration view to visually configure for aspect ratio.
• Grid (Pixel). Specify a grid with height and width (in pixels) of all cells in the grid.
• Grid (Angle). Specify a grid with horizontal and vertical degrees for setup in domes or
cylinders.
Multiple test patterns can be used simultaneously.
Figure 8-1. Adding test patterns
To add a test patterns to the calibration view, click “Test Images” in the actions toolbar. See
Figure 8-1. The window in Figure 8-2 will appear.
Figure 8-2. Test Image Setup window
41
www.projectiondesign.com
english
8.1 Circle test pattern
Circles can be added to calibration area to ease the setup. The position (x, y pixel
coordinates) and the radius (pixels) can be specified. Figure 8-3 shows the Test Image Setup
window with two circles added.
Figure 8-3. Circle test patterns
Multi image processor User’s Guide – Test patterns
42
A grid with much smaller cells than the calibration grid can be really convenient for setup.
Especially when using the Mesh Bezier Warp where the calibration can be done with very few
control point.
english
8.2 Grid (Pixel) test pattern
To add a Grid (Pixel) select the “Grid (Pixel)” tab and specify your parameters (). The
parameters are: offset (x, y in pixels for top, left corner) and height and width of the cells in
the grid. Use the offset function to make grids in multiple image processor units to overlap.
See Figure 8-4.
Figure 8-4. Grid (Pixel) test pattern
43
www.projectiondesign.com
english
8.3 Grid (Angle) test pattern
The last test pattern available in the processor unit is the Grid (Angle) test pattern. This is
used to create a reference grid in a dome or a cylinder.
Parameters to specify for this grid are ‘to’ and ‘from’ angles (in degrees) in horizontal and
vertical direction. The frequency of the reference points can also be specified, as seen in
Figure 8-5.
Figure 8-5. Grid (Angle) test pattern
8.4 Turning test patterns on and off
When using a test pattern it can be convenient to disable the warp calibration grid. Select
“Layers” in the Calibration Panel toolbar and disable Warp, Figure 8-6.
Figure 8-6. Disabling the warp grid
Multi image processor User’s Guide – Test patterns
44
Black Level Management (BLM) is a feature patented by projectiondesign for adjusting offset
(brightness) in selected areas to compensate for non-perfect black levels in projectors. This
enables the possibility to have seamless images in all the gradients of all colors.
english
9 Black Level Management
To start the black level management tool, click on “Black Level” in the Calibration View
Toolbar, Figure 9-1.
Figure 9-1. Start BLM tool.
9.1 Creating adjustment zones
Start with clicking
(Add) in the Calibration Panel Toolbar. This will create the first line in
the area to black level correct, Figure 9-1.
45
www.projectiondesign.com
english
Figure 9-1. Adding Black Level Management lines.
Figure 9-1. Multiple Black Level Management lines added.
To create the next side in the zone, click on one of the control points in the first line created
(not the Bezier points) and then click
(Add) again (Figure 9-1). This will add other line to
the calibration panel. Continue to add lines as needed. All these lines have the same controls
as Bezier lines in the Mesh Bezier Warp and the Advanced Edge Blending.
Multi image processor User’s Guide – Black Level Management
46
english
Important! To add the last line connecting the first and last control point, it is important
to select both of the control points required to encapsulate the calibration area (Figure
9-1). To select multiple points, either press and hold Ctrl while using the mouse point
to select points or drag and drop a selection rectangle over the points. Finally click
(Add) again to add the last line.
9.1 Removing BLM zones
To remove a BLM zone, select a complete zone by performing a drag and drop selection
over a given zone. Individual points can also be select by pressing and holding Ctrl while
selecting with mouse pointer.
Click “Remove” in the Calibration Panel Toolbar to remove the zone(s) selected. Individual
lines in a zone can also be selected and removed.
9.1 Adjusting black level in a defined zone
To adjust the black level of a zone, select the zone or any control points in the zone. Click
“Black Level” in the Calibration Panel Toolbar. The window appears in Figure 9-1. Adjust the
8 bit value (256 steps) as needed. You must enter online mode to see the results.
Figure 9-1. Adjusting black level.
47
www.projectiondesign.com
english
Multi image processor User’s Guide – Black Level Management
48
Masking (also called clipping) is used to cut out areas of the image which should be blanked
out. An example of this is overshooting of the image in a dome.
english
10Masking
To start the masking tool, click “Clip” in the Calibration View Toolbar (Figure 10-1).
Figure 10-1. Starting the clip tool
49
www.projectiondesign.com
english
10.1 Adding areas to clip
Start with clicking
(Add) in the Calibration View Toolbar. This will create the first line in the
area to mask out (Figure 10-2).
Figure 10-2. Adding the first line in a clip area.
Multi image processor User’s Guide – Masking
50
english
To create the next side in the zone, click on one of the control points in the first line created
(not the Bezier points) and then click
(Add) again (Figure 10-3). This will add other line to
the calibration panel. Continue to add lines as needed. All these lines have the same controls
as Bezier lines in the Mesh Bezier Warp and the Advanced Edge Blending.
Figure 10-3. Adding multiple side in a clip area.
51
www.projectiondesign.com
english
Note! To add the last line connecting the first and last control point, it is important select
both of the control points required to encapsulate the calibration area (Figure 10-4). To
select multiple points, either press and hold Ctrl while using the mouse point to select
points or drag and drop a selection rectangle over the points. Finally click
(Add) again
to add the last line.
Figure 10-4. Clipping area complete.
Finally, go to online mode to see the results.
10.2 Removing clip areas
To remove a masked (clipped) area, select a complete area by performing a drag and drop
selection over a given area. Individual points can also be select by pressing and holding Ctrl
while selecting with mouse pointer.
Click “Remove” in the Calibration Panel Toolbar to remove the area(s) selected. Individual
lines in an area can also be selected and removed.
Multi image processor User’s Guide – Masking
52
The multi image processor system has powerful and flexible features for storing and recalling
calibration data. When a calibration is stored, the user can recall all calibration parameters at
any given time or on any given control PC. Calibration can be stored:
english
11 Storing and recalling data
• In the multi image processor unit
• On the control PC. This is a copy of the data stored in the multi image processor unit
• Both
When a calibration has been completed, the calibration must be accepted in the menu.
Accepting a calibration means the binary data is stored in the unit and will be used
automatically when the unit is powered on.
11.1 Storing/recalling calibration to/from the multi image processor unit
When storing calibration to the multi image processor unit, it will be saved in the internal
memory of the unit. Should the multi image processor unit or the control PC loose power
during calibration, the data can easily be recalled. To save the calibration to the multi image
processor unit click “Save Calibration” in the Calibration view toolbar, press Ctrl+S or select
“Save Calibration” from the file menu (Figure 11-1). Any calibration already stored in the multi
image processor unit will be overwritten.
Figure 11-1. Save current calibration to the multi image processor unit
If you want to recall your last saved calibration, click “Load Calibration” in the Calibration view
toolbar (Figure 5-1).
53
www.projectiondesign.com
english
11.2 Storing/recalling data to/from the control PC
Before you can save a calibration to the control PC, you first have to save your calibration to
the multi image processor unit. When performing a backup to the control PC, the last data
stored in the multi image processor unit will be copied to the control PC. To backup your
data, select “Backup Calibration files..” from the file menu (Figure 11-3). The window in Figure
11-3 will appear.
Figure 11-2. Backup up calibration data.
Figure 11-3. Selecting folder for backup
Multi image processor User’s Guide – Storing and recalling data
54
11.2.1Restoring calbration files
english
If you create a target top folder, multiple units can be backed up in the same operation.
Select the target folder to which the data should be saved and press “Start”. When all files
are copied to the control PC, click “Done”. Each unit the system will have to be upgraded
separately. For revision tracking of the calibration data, each new backup folder should contain the date and time of the backup.
To restore the calibration files to the multi image processor unit, select “Restore Calibration
files..” from the file menu. The window in appears.
Figure 11-4. Restore calibration from control PC
Locate the calibration to be restored, and press “Start”. All calibration files from the selected
backup folder will be copied to the multi image processor unit.
If you have backed up all units in a ”top folder” you can select the top folder and all units will
automatically be restored (based on serial number)
55
www.projectiondesign.com
english
11.3 Accept calibration
After a calibration has been completed and the result verified in online state, the calibration
must be accepted.
When a calibration is accepted for one resolution the binary data is stored in the WB unit and
will be loaded automatically every time the unit starts up or the resolution is changed to current. The calibration must be accepted in each resolution.
If no accepted file is available for the actual resolution the unit will go to bypass state when it
starts up.
It is only possible to activate an accepted file if it is generated for the correct resolution.
See Figure 11-5 for administration of accepted files.
- Select “Accept” to accept the current configuration.
- Select “Accept as” to save it to another name.
- Select “Check Auto State” to activate the current accepted file and verify the start up
behaviour.
- “Accepted Files Adminitration” allows the user to copy, rename, delete and activate
accepted files.
Figure 11-5. Accept calibration
Multi image processor User’s Guide – Storing and recalling data
56
12.1 Electrical
versions
101-0301-00 (WB2560)
101-0302-00 (WB1920)
functionality
Geometry Correction, Blending,
Uniformity Correction and matching
scalability
Unlimited channels
latency
Zero with simple blended set up,
rotation dependent with geometry
correction
internal colour depth
12 bits per colour
I/O
Dual Link DVI in / out
Ethernet (control)
IEC power connector
RS232
black level correction
Patented Pixel Level Matching;
individual RGB channel on pixel
level
maximum resolution
2560 x 1600 (WB2560)
1920 x 1200 (WB1920)
3D stereographic
1920 x 1200@ 120 Hz on WB2560
1280 x 800 @ 120 Hz on WB1920
setup and control
ProNet™ setup and calibration tool
Automatic Camera setup (tba.)
filtering and scaling options
– user selectable
4x4 Lanzcos algorithm
Bi-cubic interpolation
Bi-linear interpolation
installation
1/2 width. 1RU rack mount.
Rack mounting kit available
conformances
FCC Class A, CE, CUL
power requirements
100 - 120VAC, 200 - 240 VAC,
50/60 Hz, < 30W
size ( H x W x D)
43.5 x 216 x 275.5 mm
english
12Technical specifications
All specifications are subject to change without prior notice.
57
www.projectiondesign.com
english
12.2 Mechanical
Multi image processor User’s Guide - Technical specifications
58
59
Figure 4-1. Multi image processing system overview
12
Figure 4-2. Connector panel
12
Figure 4-3. Front button and LED-indicators
13
Figure 4-4. Rack mount plate
14
Figure 4-5. Rack mounted
14
Figure 5-1. Overview of ProNet.site
15
Figure 5-1. WB calibrator, Device View.
16
Figure 5-1. File menu, Device View.
17
Figure 5-1. The Device Tree in the Device Pool.
17
Figure 5-1. Toolbars, shown with and without help texts.
18
Figure 5-1. Clearing calibration
19
Figure 5-1. Application and Network settings.
19
Figure 5-1. Multi image processing software upgrade window.
20
Figure 5-1. EDID Administration.
20
Figure 5-1. Switching views from Calibrator view to Device view and back.
21
Figure 5-1. Calibration toolbar, without and with help texts.
21
Figure 5-1. WB Navigator
22
Figure 5-1. Top toolbar window navigation
22
Figure 5-1. Calibration Panel Toolbar, without and with help texts.
23
Figure 5-1. Set colors control box
24
Figure 5-1. Control point setup
24
Figure 5-1. Bezier point settings
25
Figure 6-1. Warping algorithm setup
28
Figure 6-2. Scaling filters
29
Figure 6-3. Working with the perspective transform
30
Figure 6-4. Working with the Mesh Transform algorithm
31
Figure 6-5. Mesh Bezier with 1x1 grid
32
Figure 6-6. Working with Mesh Bezier, simple mapping
33
Figure 6-7. Real time warp state
33
Figure 6-8. Calibration panel guide points
34
Figure 7-1. Basic edge blending.
36
Figure 7-2. Adding a blend zone.
37
Figure 7-3. Add blend zone window.
38
Figure 7-4. Working with advanced edge blending.
38
Figure 7-5. Adjusting the blend drop off curve.
39
Figure 7-6. Drop-off curve setup
40
Figure 8-1. Adding test patterns
41
Figure 8-2. Test Image Setup window
41
Figure 8-3. Circle test patterns
42
Figure 8-4. Grid (Pixel) test pattern
43
Figure 8-5. Grid (Angle) test pattern
44
Figure 8-6. Disabling the warp grid
44
Figure 9-1. Start BLM tool.
45
Figure 9-1. Adding Black Level Management lines.
46
Figure 9-1. Multiple Black Level Management lines added.
46
Figure 9-1. Adjusting black level.
47
Figure 10-1. Starting the clip tool
49
Figure 10-2. Adding the first line in a clip area.
50
Figure 10-3. Adding multiple side in a clip area.
51
Figure 10-4. Clipping area complete.
52
english
13Table of figures
www.projectiondesign.com
english
Figure 11-1. Save current calibration to the multi image processor unit
53
Figure 11-2. Backup up calibration data.
54
Figure 11-3. Selecting folder for backup
54
Figure 11-4. Restore calibration from control PC
55
Figure 11-5. Accept calibration
56
Multi image processor User’s Guide - Table of figures
60
projectiondesign locations
head office
regional offices
regional contacts
projectiondesign as
Habornveien 53
N-1630 Gamle Fredrikstad,
Norway
ph +47 69 30 45 50 fx +47 69 30 45 80
sales@projectiondesign.com
New York - Americas
projectiondesign LLC
295 North Street,
Teterboro, NJ 07608,
USA
ph +1 888 588 1024 fx +1 201 288 1034
sales@projectiondesign.com
Panama – Central and South America
ph +507 69 800 555 fx +47 69 30 45 80
sales@projectiondesign.com
Amsterdam - EMEA
De Boelelaan 28
1083 HJ Amsterdam, The Netherlands
ph +31 (0) 203301188 fx +31 (0) 204221962
sales@projectiondesign.com
Beijing - China
ph + 86 0 65 63 75 07 fx + 86 10 65 63 76 46
sales@projectiondesign.com
Cape Town – Africa, Israel
ph + 27 21 79 00 018 fx +47 69 30 45 80
sales@projectiondesign.com
Mumbai – SAARC Region
ph +91 98 20 61 06 70 fx +47 69 30 45 80
sales@projectiondesign.com
Dubai - UAE and Middle East
ph +9714 (4) 8872525 fx +47 69 30 45 80
sales@projectiondesign.com
Wickfield - UK & Ireland
ph +44 (0)844 8099 577 fx +47 69 30 45 80
sales@projectiondesign.com
Düsseldorf – Germany, Austria, Swtizerland
ph +49 (0) 211 22059 544 fx +49 (0) 211 22059 110
sales@projectiondesign.com
Moscow - Russia & CIS
ph +7 (495) 967 7904 fx +7 (495) 967 7600
sales@projectiondesign.com
Choszczno – Central and Eastern Europe
ph +48 883 388 035 fx +47 69 30 45 80
sales@projectiondesign.com
Sydney - Australia & New Zealand
ph +61 407976181
sales@projectiondesign.com
Singapore - South East Asia
ph +65 9621 7421 fx +47 69 30 45 80
sales@projectiondesign.com
Paris - France
ph +33 153307933 fx +47 69 30 45 80
sales@projectiondesign.com
sales@projectiondesign.com
601-0206-02
www.projectiondesign.com
601-207-01
Scan to learn more
©2010 projectiondesign AS. All rights reserved. All brands and trade names are the property of their respective owners. Specifications subject to
change without prior notice. All values are typical and may vary. Please visit our website for latest specifications and product offerings.
www.projectiondesign.com