Yamaha VL Visual Editor Owner`s manual

(1) Important Notice
The VL v2 Visual Editor/Beta 1.0 (VL Visual Editor : VVE) is a Beta test version of the
program which has been released for use free of charge.
Yamaha cannot provide technical support for this software, so please read the manual
carefully before use. Also please be sure to make regular backups of important data to
minimize the possibility of accidental data loss. The VL Visual Editor is designed to run on a
Macintosh computer, but has not been fully tested with all machine/operating system
combinations. It may not function properly with some combinations. Since AppleTalk conflicts
with MIDI processing in many cases, it is a good idea to turn AppleTalk off when using the VL
Visual Editor.
The VL Visual Editor provides an easy, intuitive way to create, edit, and save basic voices for
Yamaha VL Version 2: specifically the VL1 Version 2, VL1-m Version 2, and VL7 Version 2. The
full potential of VL Version 2 can only be realized, however, with a thorough understanding of
the VL system. We therefore recommend that users who want to create high-quality voices
carefully read the manuals provided with the VL Version 2 instruments themselves.
Copyright Notice
• All rights reserved by Yamaha Corporation. No part of this software or manual may be
reproduced or altered by any means without prior written permission from Yamaha
Corporation.
* The name "Apple", the Apple logo, "Macintosh", "AppleTalk", and "PatchBay" are either
registered trademarks or trademarks of Apple Computer.
* "MS-DOS" is a registered trademark of Microsoft Corporation.
(2) System Requirements
•
•
•
•
Macintosh system 7.1 or higher.
At least 3 megabytes of free RAM.
At least 3 megabytes of free hard disk space.
A MIDI interface.
-1-
The VL Visual Editor has not been tested on all Macintosh models and system combinations.
The software may not run properly on some machines and machine/system combinations.
This software can be used on a black & white display system, but 256 or more greys or colors
is preferable. At least 16 colors or greys is recommended.
(3) Connection
The VL Visual Editor is designed to run on a Macintosh using the Apple MIDI Manager and
PatchBay, allowing transfer of MIDI data via a MIDI interface connected to either the
Macintosh modem or printer port. Connect the MIDI OUT terminal of the MIDI interface to the
MIDI IN terminal of the VL instrument.
If none of the above software is installed, the VL Visual Editor is capable of transferring
MIDI data via the modem port on its own.
(4) Basic Operation
1. Launching the Application
Double-click the VVE application icon to launch the VL Visual Editor program. The VL Visual
Editor "Synthesis" window will appear after the introductory screen.
-2-
2. PatchBay Settings
If you're using the MIDI Manager, open PatchBay and check the VVE and Macintosh serial
output connections. These settings are normally saved and will be automatically recalled the
next time you start the VL Visual Editor. The PatchBay parameters may have to be reset if one
of your MIDI applications is aborted abnormally or any other MIDI setting is changed.
VL1-m Users:
For VL1-m users, Yamaha recommends using an external MIDI merger unit to merge the MIDI
output from the Macintosh computer and the controlling keyboard (or other controller) to be
sent to the VL1-m MIDI input. If no hardware MIDI merger is available, use the Apple PatchBay
application to route both the keyboard MIDI output and VL Visual Editor MIDI output to the
VL1-m MIDI input. The latter "software merge" setup should work on most systems, but is
likely to be less reliable than the recommended "hardware merge" approach.
3. MIDI Settings
Pull down the "Window" menu from the menu bar and select the "MIDI …" item. In the pop-up
window enter the MIDI channel and device number used by your VL instrument.
4. Synthesis
Click on any of the "DRIVER" options to the left of the window to select it (the selected
driver will be outlined in red). Next click on one of the PIPE/STRINGS options to the right of
the window — the selected PIPE/STRINGS option will be outlined in red. A composite image
representing the selected DRIVER and PIPE/STRINGS options will appear in the "PREVIEW"
window.
-3-
If one of the "VARIATION" buttons in the lower part of the window is now clicked, the
corresponding voice data will be transmitted to, and can be played via, the connected VL
instrument. The transmitted voice will sound briefly when the data has been successfully
transmitted.
If the "Voice List" window (described later) is open and you want to access the "Synthesis"
window, select the "Synthesis" item from the "Window" menu to open the "Synthesis" window
or bring it to the front.
(a) The DRIVER Options
The VL Visual Editor provides 6 DRIVER options. This is the part of the instrument which
generates the energy which will be converted into sound and subsequently "shaped" by the
PIPE/STRINGS section.
• Single Reed
A single-reed woodwind mouthpiece like the type used on a saxophone or clarinet.
• Double Reed
A double-reed woodwind mouthpiece like the type used on an oboe or bassoon. The "grass
flute" also works on this principle.
-4-
• Lip Reed
In a trumpet, the player's lips are pressed against a specially-shaped mouthpiece and forced
to vibrate in response to the player's breath pressure. The trombone, horn, tuba, and most other
brass instruments work on this principle.
• Jet Reed
The flute, pan pipes and shakuhachi all work on the "jet reed" principle: i.e. sound is generated
by the air turbulence produced by blowing across a solid edge.
• Bow
A bow drawn across a string causes the string to vibrate, thereby generating sound: violin,
cello, contrabass, etc.
• Pluck
Guitar, mandolin, and harp are all plucked string instruments. "Pizzicato" is plucked violin,
viola, etc. This driver corresponds to plucking a string to produce sound.
* When the "Pluck" driver is selected polyphonic performance becomes possible — except on
the VL7 which uses a single element.
(b) The PIPE/STRINGS Options
The pipe or string is the section of the instrument that amplifies and adds distinctive tonal
-5-
characteristics to the sound energy generated by the driver.
• Conical (large)
This option simulates the type of conical horn used in instruments like the saxophone — a
small entrance aperture, gradually expanding to a relatively large bell.
• Conical (small)
This conical pipe has a much smaller taper than the above, more like the type of pipe used in
an oboe.
• Straight (single-ended)
Similar to a clarinet pipe — driven from one end and essentially straight right up to the flare
at the other end. In physical modelling terminology, this type of pipe is considered to be
"single-ended".
• Straight (double-ended)
A flute pipe, for example, is essentially straight along its length, but is driven at a point
somewhere between its two ends. This type of pipe is "double-ended".
• Flare
This is the type of pipe found on the trumpet and other brass instruments. Although it
depends on the type of DRIVER selected, this type of pipe generally produces a relatively
bright sound.
* If the Pluck driver is combined with the Flare pipe, the resultant pitch can be unpredictable.
This is because the Flare pipe is inherently ambiguous — e.g. a trumpet player can vary the
pitch of his instrument over a wide range simply by adjusting his embouchure (the way he uses
-6-
his lips).
• String
A taught string, like the type used on a violin or guitar. The final result depends on the driver
selected, but the string generally has a relatively long decay.
(c) The VARIATION Options
Depending on the DRIVER and PIPE/STRINGS combination selected, two or more VARIATIONs
corresponding to different instrument sizes and characteristics may be available. If the
DRIVER and PIPE/STRINGS combination is a standard one (e.g. Lip Reed with Flare), the
corresponding instrument names will appear in the VARIATION buttons (e.g. Trumpet,
Trombone, etc.).
You can also select VARIATION by double clicking, and it takes you to Edit window
automatically.
5. Edit
Press the [Edit ->] button in the lower right corner of the "Synthesis" window to go to the
"Edit" window. This window allows further editing of the basic voice created in the
"Synthesis" window. The "Patch" window which appears to the left of the "Edit" window will be
described below.
-7-
If the "Patch Palette" or "Voice List" window (described later) is open and you want to access
the "Edit" window, select the "Edit" item from the "Window" menu to open the "Edit" window or
bring it to the front.
The labelled "menu tabs" in the lower section of the "Edit" window provide access to
corresponding edit pages. Before describing these pages let's take a look at the "Patch
Palette".
(a) The Patch Palette
When the "Edit" window is selected, a smaller floating window labelled "Pickup" will appear
to its left. This is the "Patch Palette".
When open the "Patch" window will always appear in front of any other open windows, but,
like any other window, it can be closed by clicking on its close button. Once closed it can be
re-opened by selecting "Show Mdf/Fx Palette" from the "Window" menu.
Click on the left and right facing arrows at the top of the window to switch menus as
required. The following 8 menus are available:
Pickup / Filter / Resonator / Modulation FX-1
Modulation FX-2 / Delay FX / Reverberation / Combination
Double-clicking on any of the items in the "Patch" window called "Patch Palette" causes that
item to appear in the "Edit" window patch holder, and the corresponding effect will be applied
to the current voice. The items in the "Patch Palette" menu items can also be moved to the
patch holder by clicking and dragging.
-8-
If one or more icons already exist in the patch holder, subsequent additions will be placed in
the next unoccupied position to the right. The only exceptions are the Pickup icons, which will
always be placed in the leftmost position. A Filter icon will appear to the right of a Pickup
icon, unless no Pickup icon is selected, in which case the Filter icon will appear in the
leftmost position. Multiple Pickup, Filter, or Resonator icons cannot be selected. If one of
these icons is selected while a previous icon of the same type exists in the patch holder, the
new selection will replace the previous selection. If all six patch holder positions are full, no
more icons can be selected by double-clicking. It is possible, however, to click and drag an
icon on top of an existing icon, this will delete the original icon and replace it with the newly
placed icon.
Also please note that in some combinations, not all of the Modulation FX-1/2, Delay FX,
Reverberation, and Combination effects will be active. Unfortunately, the possible
combinations are too numerous to describe here. Effect priority is from right to left in the
patch holder. In other words the rightmost effect icon has the highest priority, etc.
To remove a patch icon from the patch holder chain, simply click and drag it to the trash can
icon. If you want to remove all patch icons and start from scratch, click on the "Clear" button.
Please note that when "Clear" is executed the other "Edit" page parameters — "Envelope",
"Control" and "Tweak", to be described later — are also cleared.
The various patches are described briefly below.
<1> Pickup
Changing pickups is like changing pickups on a guitar or changing the position of a pickup on a
brass or woodwind instrument. The VL Visual Editor provides 8 pickup types.
• Single
A simulation of a "single-coil" electric guitar pickup.
-9-
• Humbucking
A simulation of a "double-coil" humbucking electric guitar pickup.
• Mouthpiece
The effect produced by attaching a pickup to the mouthpiece of a wind instrument.
• BreathNoiseAmp
This pickup picks up the amplitude of the noise components of the breath noise.
• FlowRate
The saturation component of the air-flow within the instrument's mouthpiece is converted to
sound and amplified.
• Beatin'
The beating or "buzzing" of the mouthpiece reed is selectively amplified.
• Slit/Friction
The variation in the gap between the reed and mouthpiece is converted to sound and
amplified. When the "Bow" driver is selected this pickup amplifies the friction of the bow.
- 10 -
• Reed Aperture
The flexing of the reed is converted to sound and amplified.
<2> Filter
The sound can be shaped with basic low-pass filters. The frequency and resonance of the
filter can be adjusted via the "Tweak" edit page, described later.
<3> Resonator
These patches add, for example, the resonance of a violin or guitar body to the sound.
<4> Modulation FX
As the name implies, these patches produce modulation type effects such as phasing, vibrato,
and distortion.
- 11 -
<5> Delay FX
The Delay FX patches provide a range of delay effects.
<6> Reverberation
The Reverberation effect patches provide a range of ambience-enhancing reverberation
effects.
<7> Combination
A range of effect combinations are provided for use with different types of music.
(b) The Suggestion Page
Clicking on the "Suggestion" tab in the lower part of the "Edit" window will bring the
Suggestion page to the front. The Suggestion page provides notes on the current voice and the
selected patches.
(c) Envelope
- 12 -
Click on the "Envelope" tab to access the Attack Rate, Delay, and Release envelope
parameters. The Decay parameter is only available when the Pluck driver is selected. Each of
these parameters can be adjusted from -16 to +16 (33 steps). The higher the value the faster
the rate. A value other than "0" must be selected to produce any effect. With some DRIVER and
PIPE/STRINGS combinations, however, only positive or negative values can be selected. Also,
some envelope settings will produce no audible effect with some DRIVER and PIPE/STRINGS
combinations.
(d) Control
Click on the "Control" tab to access parameters that allows adjustment of Breath Controller
operation. The "Control depth" parameter can be adjusted from 0 (no control) to 127 (maximum
depth), and the "Control curve" parameter can be adjusted from -16 to +16 (33 steps). Positive
values produce a softer curve while negative values produce a harder curve. The "Breath/No
Breath" parameter selects the breath control source: "Breath" for the Breath Controller, or "No
Breath" for touch EG control (i.e. keyboard velocity and aftertouch response).
(e) Tweak
The "Tweak 1" and "Tweak 2" tabs access a range of parameters that can be adjusted from
-16 through +16 (33 steps). Additional parameters may also appear according to the selected
patches.
- 13 -
NOTE
• In some cases you might want to change the DRIVER, PIPE/STRINGS and/or VARIATION
settings without affecting the "Edit" page settings. If you switch from the "Edit" window to
the "Synthesis" window to do this, and then return to the "Edit" window, the patch settings
will be retained but the "Envelope", "Controller", and "Tweak" settings will be initialized. If
you want to start again from scratch all patch settings can also be cleared by clicking the
"Clear" button.
7. Voice List
A Voice List window is automatically created the first time the "Edit" window is selected,
and it can be opened by selecting "Voice List" from the "Window" menu. A newly created voice
is automatically added to the Voice List each time the "Edit ->" button in the "Synthesis"
window is clicked.
(a) Audition
When a voice name in the Voice List is clicked, the data for that voice is transmitted to the
connected VL instrument, and the selected voice can be played via the VL instrument. Voice
data transmitted to the VL instrument can be stored to the instrument's memory as required —
refer to the VL owner's manual for details.
(b) Edit
Commands in the "Edit" window can be used to edit Voice List items as in all standard
Macintosh applications. Copied voices can be pasted to a new location, or selected voices can
be cleared as required.
A "block" including multiple items can be copied, pasted, or cleared. If a selected paste area
is smaller than the number of items copied, however, only the number of items that will fit in
- 14 -
the paste area will be copied. On the other hand, if the number of items copied is smaller than
the selected paste area, the copied items will all be pasted and the extra paste locations will
remain unaffected.
(c) File Management
The Voice List can be saved in the same way as any other Macintosh file. Select "Save" from
the "File" menu to save the current Voice List. Select "Save as …" to specify a different save
file name. The folder/file name dialog box will also appear the first time the "Save" option is
selected for a Voice List. Subsequent uses of the "Save" option simply overwrite the previous
file of the same name … be careful not to accidentally overwrite a file you want to keep.
Select "Open" from the "File" menu in order to open a previously saved Voice List. Use the
standard Macintosh dialog box to select the folder and file you want to open. This ability to
save and open Voice Lists makes it possible to compare different voices created at different
times, and create an unlimited library of original voices.
Select "New" from the "File" menu to create a new Voice List.
NOTES
• When a new or existing file is opened and a new voice is created (specifically, when the
"Edit ->" button in the "Synthesis" window is clicked), the new voice will be placed in the
Voice List.
• Multiple Voice Lists cannot be opened at the same time. Voice copied from one list using the
"Edit" menu "Copy" function can be pasted to a different Voice List to allow voice management
between multiple Voice Lists.
• For more detailed voice editing use the VL Expert Editor application program, available
separately. Voices can be copied and pasted between the VL Expert Editor and the VL Visual
Editor programs.
• A new Voice List contains 128 blank voice locations, none of which contain data which can
be transmitted to a VL instrument. As voices are created they are placed in the Voice List in
the order of creation, and are automatically saved up to the last existing voice location when
the Voice List is saved.
• After these "Library Edit": When a new voice is synthesized, the existing voice in the Voice
List may be overwritten.
(d) Comments & Voice Names
The Voice Name window can be selected by double-clicking on a voice in the Voice List while
holding the [command] keys. A voice name of up to 10 characters can be entered as required.
- 15 -
The Comment window can be selected by double-clicking on a voice in the Voice List while
holding the [control] and [command] keys. The total number of characters that can be entered in
the Comment window is shown next to "Capacity" in the lower left corner of the window.
8. Quitting the Application
Select "Quit" from the "File" menu to quit the VL Visual Editor application. A dialog box
asking you to confirm whether you want to save the current Voice List will appear — select
the appropriate response to quit the program.
9. Creating a Loadable Disk for the VL instruments
A voice file created or edited using the VL Visual Editor and saved to an MS-DOS 1.4
megabyte disk via Apple File Exchange or a similar format translation program can be directly
loaded by any of the VL, as long as the created file has an ".AVC" file name extension. The
standard MS-DOS file name and character restrictions apply.
===========================================================
- 16 -