Casio NX-6000 User`s guide

The connect
DD-Link for Windows
Version 1.04
User’s Guide
Welcome to DD-Link Software
The Main Program Features
• The DD-Link program allows sending data to a PC, and sending them back to CASIO®, so data can be
stored in floppy or hard disk, they can be printed, and this program makes entering new data items and
modifying existing data items much easier.
• In DD-Link one can display, edit and print the data items by the aid of the accentuated CASIO character
set.
• CASIO <=> PC connection with all CASIO manager calculators and pocket viewers:
SF-4300(x), SF-4400, SF-4600(x), SF-4700(x), SF-4900(x), SF-4980(x), SF-4985ER, SF-4990,
SF-5100, SF-5300(x), SF-5500(x), SF-5600, SF-6300, SF-6990, SF-7000, SF-7500, SF-7600,
SF-7900(x), SF-7990, SF-8000, SF-8300,SF-8350(x), SF-8500, SF-8900, SF-9000, SF-9300,
SF-9350, SF-9500, SF-9600, SF-9700, SF-M10, SF-R10, SF-R20
CSF-4450(x), CSF-4650(x), CSF-4950(x), CSF-4970, CSF-5350, CSF-5550, CSF-5750,
CSF-7950, CSF-8950, NX-4000, NX-6000
SF-5580, SF-5780, SF-5980, SF-5590SY, SF-5790SY, SF-5990SY, SF-6500SY, SF-6700SY,
SF-6900SY, SF-7100SY, SF-7200SY, PV-100, PV-200(x), PV-250X, PV-S250, PV-400A,
PV-450X, PV-S450, PV-S460, PV-S660, PV-750, PV-750P, PV-S1600
New unit models are being built in this software continuously. (x)=any character
• Data Communication:
• Can be transmitted one at a time or more data item, register or the all CASIO registers. In case of SY
or PV types the DD-Link supports the PC Sync direct synchronize function. By use of the MSS
(Multiple Synchronization System) in case of PV types can be keep the unit in of sync with more PC
dossier at the same time .
• Filtering or - in PC Sync case - deleting double entries.
• Harmonizing the database of both unit according to „keyfields” with the Update function, or with
attention of similarity (by preventing from doubling) with the normal Synchronize function by all
calculator types. Harmonizing with chaining data items of one unit to data items of another unit using
by Direct synchronize (PC Sync). The DD-Link supports the synchronization of the more units to the
one PC dossier. These units can be different subtypes. The full PV unit or only one register of it can be
keep in of sync with more different PC dossier by the MSS (Multiple Synchronization System).
• Automatic PC Sync start on PC by pushing Synchronize button of calculator or Start button on cradle.
• Automatic COM port control and cable recognition.
• Support the USB port handling in case of the newer PV types.
• The program interface and its handling is similar to those of Editor programs (File Edit Search … menu
commands)
• Menus are similar to that of Windows, and the application has a windowed structure.
• Editing data items by the aid of an integrated editor using standard keyboard assignment. Edition can be
performed either in the width of the CASIO display or in a variably wide window. Clipboard operations
are supported.
• Data exchange with other programs, by keeping the accentuated characters of the code tables CWI, 852
and Windows ANSI. (Excel®, Word®, Outlook®, Outl. Express®, Lotus Organizer®...etc.)
• Support for all the registers, i.e. modes of the Unit model: Telephone, Business Card, Memo, Quick
Memo (Sketch), Calendar, Schedule, Reminder, To do, Free File, Expense, Calculator
• Text search and replace functions.
• Filter function with, combined filtering criteria (e.g. listing all the people named John and living in
Vienna).
• Sorting data by several criteria.
• Selecting data items and performing operations with selected items. (delete, copy, move, print, send to
CASIO®, export in file to other applications, ...etc.)
• Copy from one register into another (e.g. Telephone Business Card).
• These functions add extra data arranging functions to the features of the CASIO® equipment.
Data Save and Retrieving (hard and floppy disks)
• Database files can be stored on hard disk, floppy disk, or other writable drive, or work in network
environment (e.g. Novell).
• The structure of the file is database where 200.000 pcs data items can be stored in.
• This is a multiuser database that means several users can access the database at the same time. The same
data can be read or written simultaneously using several PCs and DD-Links in network environment.
• The modifyed data items are immediately being written into the database so you don’t need to save at
the end of the work or load at the beginning. Opening or closing takes zero time.
• Database can be protected with password, preventing from unauthorized users.
• Exporting to and Importing from Excel, Dbase, Foxpro, Access, Text, CSV, Tab, and other delimited
DOS and Windows files by the aid of CWI, 852, Windows Ansi code tables.
• Data exchange between DD-Link <=> Windows Write®, Word®, Excel®, Access®, Lotus Organizer®,
Outlook®, Schedule+®, Outlook Express® ..etc.
• Loading documents and descriptions by splitting them to the size of the CASIO® data unit.
Printing
• Printing in 8 different and variable base format:
• Detailed list: in CASIO style, full print from first character of the data item to last.
• Quick list: one data item printed in only one row (as far as there is room).
• Table: one data item printed in only one row, and the fields in columns.
• Label: one data item printed to defined size label, with custom field placing.
• Phone list: The name, employer, and phone number fields (if exists) printed in table format.
• Calendar: traditional calendar printing with marked days and marks of scheduled items.
• Date diary: schedule, reminder, todo, expense of one defined period printed.
• Expense list: creating expense report of one defined period (if exists expense register).
Hardware requirements, operating systems
• The program runs in PC with 486DX2 or any faster processor, but above 100 MHz (chiefly to PCSync) is
recommended. The memory requirement is 4 MB, and hard disk capacity needed is 20 MB.
• Runs under Windows 3.1, 3.11, 95, 98, 2000, NT, MN, XP.
• The program can be used in Novell or other networks.
• The DD-Link can be used with any CASIO® compatible serial data communication cable or cradle.
The 2.5 Jack plug cable be needed to the traditional CASIO® SF-..., CSF-..., NX-... type units, and the 3.5
Jack plug cable be needed to the CASIO® SF-...SY units. Special plug cable or cradle be needed to the
PV type units. The 2.5 Jack plug cable it is necessary that include the electronic circuit. This electronic
circuit convert the level of signal from one unit to another. The 3.5 Jack plug cable also can be included
electronic circuit, because the signal level of the SF-...SY units smaller than of PC (3V<12V) and
because of this the communication not work in all PC without electronic circuit. The 3.5 DD-Link cable
include the electronic circuit.
Packing list
• Data communication cable: special DD-Link cable with electronic circuit is integrated in the connector
(Each items are packed after controlling with a test program simulating heavy load), or original CASIO
cable in package of calculator. “Only Software” kit in plastic bag doesn’t include cable.
" F loppy disk with the DD-Link software.
• 2 pcs 3½
• User’s Guide.
• Registration card. The user becomes registered user after sending back this card. New versions will be
provided for her/him only for the reproduction and posting costs, or gratis from Internet:
http://web.interware.hu/pclink. Make your registration yourself in E-Mail to ddlink@freemail.hu
address, you will immediately be informed of upgrade!
• 12 months full warranty, service for at least 10 years, spare part provision, software updates.
Using the program (Getting started):
1. Installation, starting
• The DD-Link software package can be installed on the hard disk by means of the Setup.exe file of the
supplemented floppy disk number one. The same software package at the same time cannot be installed
and
used
on
additional
PC.
(You can install and use this package on an additional PC if you by the license of “Partner Copy” at a
low price, see on web page: http://web.interware.hu/pclink, or send E-mail to ddlink@freemail.hu !)
• If you download or upgrade DD-Link software from the Internet then you can start the installation with
DD-Link.exe packed file in your download folder, then give the finalizer "reply code" or select the "Trial
version installation" menuitem. (You can get the "reply code", if buying the license and sending the
"random code" by E-mail from the window of setup software.)
• In setup software can be given the destination driver\folder – place of DD-Link software –, and the
database file folder – place of created DD-Link database files. This database file folder can be created to
network drive as well, if you give the suitable network drive letter.
• If you have Win 95, 98, 2000, NT, MN, XP start DD-Link from the desktop or the DD-Link folder by
clicking the Shortcut icon DD-Link, or use DD-Link menuitems in the Start menu Programs menu, or
maybe the Start menu Run… menuitem.
• DD-Link can be started from under the Win 3.1, 3.11 operating system with the DD-Link shortcut icon in
DD-Link window of the Program Manager, or in menu: Program Manager File Run Browse
DDLINK.EXE.
Programs menu, or
• Remove the installation by "Uninstall DD-Link" menuitem in Start menu
UnIns.exe program from DD-Link folder.
2. Getting acquainted with the program
New dossier menuitem (Alt-F, N), select the Your
• To create new dossier (database) with the File
CASIO unit type and give the security level and password of dossier.
• Discover the program:
• Menu system of the program: active menu shortcuts can be highlighted by pressing Alt key. Submenus
can be opened by pushing the proper key combinations: Alt-F, Alt-E, Alt-S, Alt-V, Alt-C, Alt-O, AltW, Alt-H.
• Editor: Enter key : editing the actual data item, Insert key : editing the new data item, Ctrl-Enter key :
finishing the edition and fixing the item, Esc key : discarding the edited item. Standard editing keys.
• Data Item Viewer: 〈  key: viewing data items, ⇓ ◊ key: register selection, A...Z key: quick search,
Shift-〈  key: highlighting.
3. Communication CASIO=>PC Receive
• The CASIO contents can be copied in an empty database by using menu commands File New dossier
(Alt-F, N). Give the CASIO unit type in the New dossier window. In case of existing dossier the unit type
can be modified in the Options Unit type window (Alt-O,U).
• If CASIO containing secret items , you can set the database to secret mode in the New dossier window, or
for existing dossier you can convert to secret mode in Options Unit type window (Alt-O,U).
Communication parameters window (Alt-O,
• Set the data communication parameters in the Options
C). (Case in CASIO SF-... set to same with Data Comm. Set Hardware parameters settings of Unit.)
• Go to the Receive window by the menu point Communication Receive (Alt-C, Enter), and then select
the mode of data receiving, and set up options.
• Connect the cable to the COM (serial) port of the PC.
• Start receive on PC with OK button, or Enter key.
• Do the things listed in Receive… window, that is start sending in CASIO.
• When reception is finished, you can start again the receiving and can send another register or data items
or finish data communication.
4. Communication PC=>CASIO Send
• When starting DD-Link the program loads the recently used database by default. If you want to upload
another database into DD-Link, do it with the function File Open (Alt-F, O).
Communication parameters window (Alt-O,
• Set the data communication parameters in the Options
C). (Case in CASIO SF-... set to same with Data Comm. Set Hardware parameters settings of Unit.)
Send (Alt-C, S), then select the scope of
• Go to the Send window in the menu point Communication
send, that is transmit one item or one or more registers. Other options of sending can be set then select to
transmit the secret or open data area.
• Connect the cable, and start sending on PC with OK button, or Enter key.
• Do the things listed in Send… window, that is start receiving on CASIO.
5. Communication PC<=>CASIO Synchronize
• The data items of the uploaded database are compared to CASIO's contents, and missing data items (PC
or CASIO) can be copied to the other side.
Synchronize (Alt-C, Y), and select
• Go to the Synchronize window in the menu point Communication
the scope of synchronize whether to compare one or more registers or full databases.
Synchronize (Alt-C, Y), and select
• Go to the Synchronize window in the menu point Communication
the scope of synchronize to compare one or more registers or full databases. Other options of send or
receive can be set and select to compare the secret or open data area.
• Connect the cable, and start receiving on PC with OK button, or Enter key.
• After the PC has received the data items and compared them with the other data items, you should do all
that are listed in the Send… window to PC=>CASIO Send.
6. Direct Synchronize (PC Sync)
• If PC Sync function available in your unit, the database of the actual dossier and the unit can be
harmonized with the Communication
Direct synchronize menutiem. (Alt-C, D). Set up in Options
Communication parameters window to start the direct synchronize in PC automatically by pressing the
Shift-Synchronize keys of unit, or – in case of PV – the Start button of cradle (without touching PC).
• Set up in pop-up window of Direct Synchronize the Conflict Solution Method and other options, then
start receive with OK button.
• Connect the cable, and start synchronization on CASIO. (Shift-Synchronize, or Start button by cradle.)
• In case of first synchronization give the name of the synchron table, and the mode of first harmonizing.
7. File (database) save
• The DD-Link stores the data items in database file saved in hard or floppy disk.
• Modifications in the database (e.g. received data from CASIO, created new data items, modifyed …etc.)
are saved immediately by DD-Link at the moment of modification. So when leaving DD-Link you won’t
need to save the file or load it at starting only close or open the dossier.
• Opening or closing the dossier requires no time at all even if having many data items. Maximum 200.000
pcs data items can be created and stored in one register. (In theory 500 thousand pcs in the Memo
register, and 8 million pcs in others registers, but tested only with 200 thousand pcs.)
8. Export, import
• The database can be saved (exported) to different file type by using the menu point File Export (CtrlE) or (Alt-F, E).
• Files being saved with Export function can be loaded into another software where you can view it or
continue working with it. E.g: the data items of dossier can be transferred to Excel.
• Data items of different file types can be loaded or reloaded to the actual dossier with the the File
Import menuitem (Ctrl-I) or (Alt-F, I).
• The export, import file type can be:
• DD-Link: own file format, to old DD-Link for DOS (CASIO⇔PC) software.
• ZQ-Link: own file format, to old ZQ-Link for DOS (SHARP⇔PC) software.
• Text: jointless text, to text editor e.g. MS Word®, MS Write®.
• Tab: separated text with tabulators, to text editors or spreadsheet managers.
• CSV: separated text with semicolon, to spreadsheet managers e.g. MS Excel®.
• DBF : Dbase®, Foxpro® files to database editors.
• MS Excel: Excel type file, to the MS Excel® and other spreadsheet managers.
• MS Access: Access type file, to the MS Access® database editor and the MS Visual Basic® softwares.
• Paradox: Paradox type file, to spreadsheet managers and the Delphi® or Pascal softwares.
• Outlook: to data change with MS Outlook®, MS Outlook Express® softwares.
• Lotus Org.: to data change with Lotus Organizer® software.
• Other: any delimited text file, delimited characters can be given in window.
9. Dossier (database file) open, new and empty dossier
• Starting DD-Link the program opens the database that has been used for the last time.
Open (Alt-F, O). Here
• If you would like to use another database you can select it in the window File
you can choose drive, directory (or folder).
• New, empty dossier (database) can be created by using the menu point File New file (Alt-F, N), where
you can give immediately the CASIO unit type and the dossier type to be secret or open. If you would
like to modify the unit type or secret mode later you can do it in the Options Unit type window (Alt-O,
Enter) or the Options Secret mode window (Alt-O, S).
10. Dossier (database file) printing
•
•
•
•
The Dossier can be printed by using the menu point File Print (Alt-F, P or Ctrl-P).
8 different and variable base format can be selected. You can print color, graphic, with icons.
With the Printer... button you can select the required printer unit, and here you can set up.
The Options... button calls the Options window, which adjust the margin, header, footer, title of printing,
width of data items, font type, and other parameters in.
• The fields to be printed can be selected by using the Fields... button.
• Before printing you can view the final result on the display by using the Preview... button.
11. Dossier (database) rename, merge, copy, archive
• The opened dossier (database) can be renamed by using the function File Rename (Alt-F, R)
Merge (Alt-F,
• Merging data items of another dossier (database) to the opened use the function File
M). The mode of merge can be selected in the Action menu that data items to Append to dossier, or to
Overwrite the full dossier with the registers of another one. You can choose Write in , too when data
items are beeing written to the original registers of actual dossier and overwrite the contents of that. The
contents of opened dossier can be refreshed corresponding to the selected „keyfields” of both dossiers
using Action Update.
• The File Copy function (Alt-F, Y) can be used to copy the data items of opened dossier (database) into
another – even not existing – dossier by selecting transaction in Action menu. Data items of actual
dossier can be copied into equivalent registers of destination dossier by Action
Append keeping the
originals unchanged . Selecting Action Overwrite the full destination dossier will be overwritten with
the registers of the actual dossier. In case of Action
Write in only the source data items of the
destination dossier will be overwritten. The contents of destination dossier can be refreshed
corresponding to the selected „keyfields” of both dossiers using Action Update.
• Old date data items can be moved to archival dossier by using the menu point File Archive (Alt-F, A).
12. Deleting, Clearing, Regenerating dossier, getting Information
• You can delete the full opened dossier permanently (database) from fixed disk or floppy disk by using
the menu point File Delete (Alt-F, D).
• You can empty the full opened dossier (database), or only some registers by using the menu point File
Clear (Alt-F, L). In this case data items are deleted only the dossier itself not.
• If the database has been damaged or you want to reduce the file size you can refresh, resort by using the
menu point File Regenerate (Alt-F, R).
• Status of the opened dossier can be seen in the File Information window (Alt-F, F): file name, date of
data communication and edition, sorting, users, and all number of the data items in dossier, or one by one
in registers of dossier.
13.Viewing, Searching, Replacing, Filtering
• The data items can be reviewed in the List panel in the left side of the dossier, while details of the actual
data item can be seen on the right in Editor panel (〈  , PgUp, PgDn, Home.End).
• You can jump to another side (panel) by using the Tab, Shift-Tab keys, or clicking to panel with mouse.
The active side is the one having the register name framed on top of. E.g. Telephone .
• Other registers can be chosen by using the register tabs (Telephone, Memo, …etc. ), or left, right (⇓ ◊ )
keys.
• The required data item can be found by entering the initial letters.
• You can search by any fragment of the text, in the window Search Search... (Ctrl-F or Alt-S, S) by the
specified parameters (e.g. Search in register or Search in full database, Case sensitive, Match whole
words, Non stop search, Search in selected, Search by selecting …etc.).
Find next (F3 or
• You can continue searching the actual data item on by using the menu point Search
Alt-S, N) according to the parameters entered in the Search window.
• Any text part of the database can be replaced by another text by using the window Search Search and
replace... (Ctrl-R or Alt-S, R).
• The required data items can be filtered by one or more text parts with the aid of the function Search
Filter (F9 or Alt-S, F). The data items corresponding to the filtering criteria will be displayed in this case.
• Sorting can be set by using the menu View Sort (F7 or Alt-V, S).
14. Select, Copy, Cut, Paste, Delete, Make to secret/opened, Mark
• The required data items can be selected for an operation (Copy, Delete, etc.) by means of the mouse
(Shift-Left or Right button) or the keyboard (Shift-〈  ).
• If no data items are selected, the operation (Copy, Delete, etc.) will be performed on the actual data item.
• Selected data items can be copied to the Clipboard by Edit Copy to clipboard (Ctrl-Insert or Ctrl-C).
Cut to
• Selected data items can be cut and copied to clipboard deleting from the database by Edit
clipboard (Shift-Del or Ctrl-X).
Paste from clipboard (Shift-Insert or Ctrl-V). (The
• The clipboard contents can be copied by Edit
Clipboard holds the items until quitting the program.)
• The selected data items can be deleted by Edit Delete (Delete).
• The selected items can be copied or moved from one register into another by using Edit Copy/Move to
another register (Alt-E, T, / Alt-E, H).
• The selected data items can be set as secret or open by Edit Make to secret/opened (Alt-Del).
• The selected data items can be marked by using Edit Mark (Alt-*).
• The selected data items can be saved in another file: File Copy (Alt-F,Y) or File Export (Ctrl-E)
 Only the selected.
Send window (Alt-C, S) 
• The selected data items can be sent to the CASIO Unit: Communication
Only the selected.
• The selected data items can be printed: File Print (Alt-F,P)  Only the selected.
• All the data items can be deleted from the register by File Clear (Ctrl-T) Aktual (A) menutitem.
• The actual data item can be duplicated by using Edit Duplicate dataitem (Alt-E, P).
15. Editing data item, new data item
• The data item found (〈  ) in the one side of dossier, i.e. in the List panel, can be edited in the another
side, i.e. in the Editor panel. The editor can be activated by pressing Enter key when a data item is
selected, or a double mouse click on it or clicking on the Editor panel.
• New data item can be created either in the List panel or Editor window by Alt-Insert shortcut, or one new
item can be inserted among the items by Insert key in the List panel, or using the menu points: Edit
New dataitem (Alt-E, N), Edit Insert new dataitem (Alt-E, I).
• In the Editor window, activated in the above way, the required line and position can be selected by
moving the cursor there (〈  ⇓ ◊ ) (PgUp/PgDn) (Home/End). The cursor can be positioned by means of
mouse as well. A field can be selected directly with the shortcuts Tab/Shift-Tab or Ctrl-〈  ⇓ ◊ .
• Text can be written at the cursor position: in insert cursor mode the text is inserted by pushing the
following texts forward. In overwrite cursor mode the character at the cursor will be replaced by the
entered one. The cursor mode can be changed by the aid of (Insert) key.
• Character deletion: at the cursor position: Delete, deleting character before the cursor position:
⇓ BackSpace.
• New line or line feed can be requested with character (↵) by Enter key.
• Text part can be selected for clipboard operations (Copy, Delete, etc.) even through several fields, by the
aid of mouse (Shift-Left Button), or keyboard (Shift-〈  ⇓ ◊ ), (Shift-PgUp/PgDn), (Shift-Home/End).
Copy to clipboard (Ctrl-Insert or Ctrl• The selected text parts can be copied to the clipboard by Edit
C).
Cut to
• The selected text parts can be cut, i.e. deleted from the text and put in the clipboard by Edit
clipboard (Shift-Del or Ctrl-X).
Paste from clipboard (Shift-Insert or Ctrl-V). (The
• The clipboard contents can be copied by Edit
clipboard keeps its last content until quitting the program).
Copy
Paste method. E.g. the text
• Text parts can be moved in any register or window by Select
copied in the Editor can be copied in the window Search (Ctrl-F), and so it should not be written once
more and can be searched directly.
• The selected text can be deleted by the Edit Delete (Delete) function.
Search (Ctrl-F or Alt-S, S)
• Text can be searched in the editor window as well by using Search
function and search can be continued: Search Find next (F3 or Alt-S, N).
• One text can be replaced by another: Search Search and replace (Ctrl-R or Alt-S, R).
• Finally save changes of data item by using the Ctrl-Enter or click to  button in the right-top corner of
editor panel.
16. Dossier (database) information
• The information window can be activated by the menu command File Information (Ctrl-H).
• Status of the opened dossier can be seen: file name, date of data communication and edition, file type,
sorting and number of the data items.
17. Options
• Type of manager calculator assigned to dossier can be changed in the window Options Unit type (AltO, Enter).
Communication
• Parameters of the data communications can be entered, seen in the window Options
parameters. (Alt-O, C)
Direct
• The actual direct synchronization (PCsync) table can be selected in list by using the Options
sync. tables (PCsync) (Alt-O, T) menuitem.
• Date diary window look can be customized by the Options Date diary (Alt-O, D) menuitem.
Regional settings
• Local date, time, currency format can be entered, changed in the window Options
(Alt-O, G).
• Names of registers and fields can be modified in the window Options Registers, Fields (Alt-O, R). In
the same place you can create new registers, fields, design the self customized dossier independently
from calculator type. The not exist fields in calculator certainly don’t take part in data communication.
• Names of the payment type, schedule type and priority can be modified in the windows Payment type
names (Alt-O, P) and Other type names (Alt-O, O).
• Decryption of full dossier or only some data items can be turned on and off and the password can be
changed in the window Options Secret (Alt-O, S).
• Username and password can be given to be used in multiuser and/or network environment by Options
User menuitem. Anything will do to the name, e.g. your name.
• If more users use the same installed DD-Link, or one user uses several kinds of configuration in the same
DD-Link, then you should save setup to different file (....CFG) because of the individual configuration.
You have two alternatives:
• Create one shortcut icon with different working (beginning) folder to each users. The working
(beginning) folder can be given in Property window (clicking Right button of mouse to icon). In this
case not needed to log in, and everyone uses his own private DDLINK.CFG file.
• Everybody uses different name configuration files (....CFG) with the same working (beginning) folder.
In this case needed to log in with entering password assigned to user , that DD-Link to load the
individual configuration file of the user. This configuration file (.....CFG) automatically gets a name
(generated from user name by default) that can be changed.
The actual user can be changed by logging in with other name using the Browse button.
(The ....CFG configuration file includes the last opened dossiers, and their window position, size or other
program settings: color, font type, date format, and last parameters of file export, import, copy, merge,
text search, etc. windows.)
18. Dossier views
• The view of right and left dossier side (panel) can be changed in the actual register with the buttonpad
on the left edge of its window, or just the actual side by first menuitems (Ctrl-F1..F5) of View menu.
• Following panels can be selected:
• List: reviewing data items. (Data items are below each other.)
• Editor: viewing, editing one full data item.
• Calendar: browsing dates in registers provided with date.
• Date diary: reviewing, editing schedules, reminders.
• Required type data items (marked/unmarked, secret/open, performed/not performed etc.) can be made
visible or hide by bottom buttonpad on the left edge of window, by filtering visible data items.
19. Accessories
• The Pocket calendar window can be activated by using calendar button in upper buttonpad of DD-Link,
or from Editor panel at date field editing. Calendar window helps choosing the required date, and
Schedule or Reminder marking can be checked for dates (〈  ⇓ ◊ , PgUp/PgDn, Home/End keys, year
and month selection with keys <<, >> and mouse).
• The Time handler window can be activated from Editor panel at time field editing.
• The calculator window can be activated by using calculator button in upper buttonpad of DD-Link, or
from Editor panel at amount field editing.
• The Sketch drawer window can be activated by using paint button in upper buttonpad of DD-Link, or
from Editor panel at sketch field editing.
Frequent problems:
1. There is no free COM serial port connector available on the PC
•
•
•
•
The PC must have one free serial port for connecting the cable: COM 1...8. The COM port is also called as standard
serial port. This port is used by the old mouse, external modem and other devices and programs communicating
across a serial line. So does the DD-Link as well.
COM (serial) port of the computer is a 25 or 9 pole big D letter formed socket on the back wall of the computer,
connected to a communication card inside the machine.
If you have no free COM port, then remove modem cable or connector of another equipment from the port being
engaged. You can employ another serial communication (COM) card.
If there is only USB port (Universal Serial Bus) in your PC, it is necessary to employ the serial communication
(COM) card. If you have a notebook, then in addition you can employ an USB to COM converter only, or PCMCACOM card.
2. The computer cannot find the cable
◊
◊
•
•
•
•
•
•
•
•
•
The program requests DD-Link cable after starting menu points Communication
Receive, Send,
Synchronize, Backup save, Restore.
The text DD-Link or CASIO is not written to any of the COM ports after cable detection in the window
Options Communication parameters (Free, None, Reserved, Internal device, etc.).
If the Your unit is PV type, the CASIO text only in case will be visible at the COM port in the Communication
parameters window, if you click to the ”Cable detection” button!
Connect the cable to the COM (Serial) port, and check the connection. If there is another COM port on the PC,
connect the cable there.
If the words "None" or "Error" are displayed at the COM ports, they should be enabled at the communication
board. This can be performed in the Bios Setup program in case of ports integrated in the base board (Bios Setup can
be approached by pressing Del key during the starting procedure of PC). The older, separate boards can be enabled
by rejumpering, supposing there is a description on the communication board.
Under Windows 95, 98, 2000, NT, MN look the COM and LPT ports menuitem up in Start icon
Settings
Control panel System window, and check whether exclamation mark exists next to the COM port. If visible, then
examine this COM port (click on it), and clear the problem indicated.
If the words "Internal device" or "Reserved or None" are displayed at the COM ports, probably the port is
reserved by some other internal device, therefore such devices have to be installed and setup that if possible keep
the COM1, COM3 port with IRQ4 IT, or COM2, COM4 port with IRQ3 IT. It is practical the card device to be
jumpered to IRQ5 or IRQ7 interrupt and the COM3 or COM4 port.
If there was a device installed to the COM port before DD-Link e.g. mouse, modem or other link cable (Nokia
phone, handled PC, PDA), then driver of this equipment must be removed: write the word REM before the driver
program in the files Autoexec.bat or Config.sys - e.g. REM mouse.sys and restart the machine. Under Windows 95
or latter version look for small icon in the right corner of Taskbar, and if the above COM driver program exists, it
must be removed by right button click of mouse to the icon, and select the close or other remover menuitem. For
final removing the Start icon Settings Control panel Add/Remove programs utility can be used.
If the word "Free" appears at the COM ports, it means that the cable connecting the (not ATX) motherboard (or
communication card) and the back wall connector is broken or is connected inversely to motherboard or the bindingin system of this cable different from the motherboard connector or maybe the link cable connector is not connected
properly.
If the Your cable is 3.5 Jack plug and not include electronic circuit (that is not DD-Link 3.5 Jack cable), can be
happened that the PC not find the CASIO because of different signal level. The signal level of the SF-...SY units
smaller than of PC (3V < 12V) and because of this the signal of CASIO die away in the insensitive PC. The only
resort for this problem the use of DD-Link 3.5 Jack cable, which include electronic circuit.
(http://web.interware.hu/pclink/addlkab.html).
If the problem cannot be solved in no way, try the DD-Link or other PC-link cable and cradle with another PC.
3. An error message is issued in PC or CASIO after starting data communication
◊
Though the PC finds the cable (the words „DD-Link” or „Casio” are displayed beside one of the COM ports
in the window Options Data communication parameters), the data communication does not work.
◊
The CASIO issues Transmit Error, Communication Error , or the PC issues a Data communication error
message.
• Turn CASIO on and set it at receiving or sending only after the window Receive…, Send…, Synchronize…, Backup
save… or Restore… is started in the PC.
• Make sure the Jack connector put in the CASIO SF-... is connected well. Repeated problem, that this connector is not
put to totally clash, because it get stuck in the final 1 mm, with a sort of totally connection feeling. Although still
stands out about 1 mm. In this case you have to turn over the SF-… unit to come the connector into better view, then
must be push with bigger power, while the clearance/gap fully disappears between the root of the connector and the
unit.
• Under Windows 95, 98, 2000, NT, MN look the COM and LPT ports menuitem up in Start icon
Settings
Control panel System window, and check whether exclamation mark exists next to the COM port. If visible, then
examine this COM port (click on it), and clear the problem indicated.
• Make sure there are no resident programs (aggressor mouse or other driver) loaded in the files Config.sys and
Autoexec.bat and Win.ini, or in Registry database, that may disturb DD-Link, or very slow down or keep down the
PC. Under Windows 95 or latter version look for small icon in the right corner of Taskbar, and if the above COM
driver program exists it must be removed by right button click of mouse to the icon, and select the close or other
remover menuitem. For final removing the Start icon
Settings
Control panel
Add/Remove programs utility
can be used.
• If the Your cable is 3.5 Jack plug and not include electronic circuit (that is not DD-Link 3.5 Jack cable), can be
happened that the communication not work with your PC because of different signal level. The signal level of the
SF-...SY units smaller than of PC (0...+3V < ±12V) and because of this the signal of CASIO die away in the
insensitive PC. The only resort for these problems the use of DD-Link 3.5 Jack cable, which include electronic
circuit (http://web.interware.hu/pclink/addlkab.html).
• If the problem cannot be solved in no way, try the DD-Link or other PC-link cable and cradle with another PC.
• Have your cable checked at the local CASIO service or send it to the Babos Software: Hungary H-1239 Budapest,
Szikes utca 2. We will replace even the correct cables. If you don’t use DD-Link cable, replace it with the special
DD-Link cable.
• Try performing things above before visiting or calling us, for 9 of 10 people comes to us unnecessarily. Their cables
and PCs are correct, only the operating system settings cause problems.
If you have any question, you can send E-Mail message in English to the ddlink@freemail.hu address. You
can send SMS message in English for the program author, whose phone number is (+36) 30 358 6303.
Advice can be requested here vocally in Hungarian language too. Web: http://web.interware.hu/pclink
The system developer and manufacturer Zoltán Babos wishes successful utilisation of the
program!
Copyright © 1992-2003 by Babos, Zoltán. All Rights Reserved.
Trademarks in the software, user’s guide, carton:
CASIO is a registered trademark of CASIO COMPUTER CO., LTD. Japan,
MS-DOS, MS-Windows, MS-Write, MS-Word, MS-Excel, MS-Outlook, MS-Schedule+ is a registered trademark of
Microsoft Corp. USA.