Avaya Solution & Interoperability Test Lab
Configuring Avaya
 IP Office Server and Cisco Call
Manager IP Trunks with H.323 Signaling – Issue 1.1
Abstract
These Application Notes describe a simple configuration of H.323 IP Trunks between an
Avaya IP406 Office Server and Cisco Call Manager.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
1 of 26
ipo-callmanager.doc
1. Introduction
The sample configuration, depicted in Figure 1 illustrates an Avaya IP406 Office Server and
Cisco Call Manager operating in different subnets and Virtual LANs (VLANs) connected by an
802.1Q trunk. IP406 Server is configured with extensions within the range 10000 to 19999,
while Cisco Call Manager is configured with extensions within the 20000 to 29999 range. All IP
endpoints are provisioned statically.
Avaya 4600
Series
IP Telephone
x10201
Avaya IP Office
Manager
/PC Endpoint1
IP Telephone Cisco 7960
x20000
1 2 3
4 5 6
7 8 9
* 8 #
1 2 3
.198
4 5 6
7 8 9
* 8 #
.197
.101
Avaya P333PWR Switch
802.1Q trunk
Management
PC
Cisco
Catalyst
4224
Avaya TM
IP406 Server
.171
.175
Avaya
Digital
Telephone
x11201
Cisco Call
Manger
VLAN 200
192.16.200.0/24
VLAN 50
192.16.50.0/24
Figure 1: IP Office to Cisco Call Manager Sample Configuration
2. Equipment and Software Validated
The following equipment and software were used for the sample configuration provided:
Equipment
Avaya™ IP Office 406 Server
Avaya™ Cajun P333-PWR Switch
Avaya™ 4612 IP Telephone
Avaya™ 6406D+ Digital Telephone
Cisco Call Manager
Cisco 7960 IP Telephone
Cisco Catalyst 4224
WJR; Reviewed:
WCH 9/17/2003
Software
1.4(15)
3.12.1
1.73
N/A
3.3
3.1(12.1)
IOS 12.2(13T)
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
2 of 26
ipo-callmanager.doc
3. Configure the Avaya™ IP Office Server
The steps that follow assume that the IP Office Management program is installed and running on
a PC that is networked to the IP406 Server. The IP406 Server has been “opened” from the
Manager program and the system password has been entered. Before any changes made in the
Manager Program take effect, they must be communicated to the IP406 Office Server by
selecting Save from the File menu item.
Step 1
From the Manager Configuration Tree, select System and then the LAN1 tab to
view the IP Office IP address. This is the address that will be used in the Call Manager
Gateway Configuration of Section 4.4. As shown in Figure 2, disable the IP Office DHCP
server.
Figure 2: IP Office System-LAN1 tab
Select the Gatekeeper tab. Check to ensure that Auto-create Extn Enable is checked. Autocreate Extn allows the IP406 Server to automatically provision an IP Phone when it registers to
the IP406 Server. This capability will be used in Step 8.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
3 of 26
ipo-callmanager.doc
Step 2
From the IP406 Server Configuration tree, select Line and then, from the right
hand pane, right-click the mouse to select New to create the VPN line (H.323 trunk) that will
be used for calls to and from the Cisco Call Manger as shown in Figure 3.
• Assign a unique Line number and Incoming Group ID and Outgoing Group ID.
• The number of channels should be adjusted to meet intersystem communication needs
within the capacity of the network.
Figure 3: IP Office VPN line-Line tab
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
4 of 26
ipo-callmanager.doc
Step 3
Select the VoIP tab to enter the Gateway IP Address of the Cisco Call Manager as
shown in Figure 4.
• Select Enable Faststart, Local Hold Music, Local tones, Out of Band DTMF and Allow
Direct Media Path. Note: If calls may tandem through this system to another H.323
system, it may be necessary to disable the “Allow Direct Media Path” setting.
• Set H.450 Support to None.
• Press OK to complete the step.
Figure 4: VPN Line VoIP tab
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
5 of 26
ipo-callmanager.doc
Step 4
Select Shortcode from the configuration tree and, in the right hand pane click
New with the right hand mouse button to create a short code.
• Enter 2xxxx as Short Code to represent the Call Manager extension range of 20000 to
29999.
• Enter “.” as Telephone Number to forward all dialed digits on the outgoing call and
enter the Line Group ID of 2, corresponding to the Outgoing Group ID of 2 for the
H.323 VPN line to the Cisco Call Manager.
Figure 5: Short Code
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
6 of 26
ipo-callmanager.doc
Step 5
From the Manager Configuration Tree, select Extension and then the extension
ID corresponding to the station that will become x11201.
• Select that extension and update its Extension value as shown in Figure 6.
• Select OK to enter the form.
Figure 6: Extension 11201
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
7 of 26
ipo-callmanager.doc
Step 6
From the Manager Configuration Tree, select User and then modify an available
user for extension 11201 as shown in Figure 7.
• Select OK to enter the form.
Figure 7: User Form
Step 7
At the Avaya 4600 Series IP Phone, press the buttons Mute A,D,D,R and enter the
values from Table 1.
Prompt
Value
Phone
192.16.200.105
CallSv
192.16.200.175
CallSvPort
1719
Router
192.16.200.71
Mask
255.255.255.0
FileSv
192.16.200.197
802.1Q
Off
VLAN ID
0
Save New Values?
Yes
Table 1: 4600 Series Phone Values
•
After the phone goes through its restart procedure, at the Extn= prompt, enter 10201
with a blank password.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
8 of 26
ipo-callmanager.doc
4. Configure the Cisco Call Manager
4.1. Access the Call Manager Administration
Step 1
In the Internet Explorer address box, enter the IP address of the Call Manager and
“/CCMAdmin” (e.g., 192.16.50.171/CCMAdmin)
Step 2
Enter the correct login and password and click “OK”. The Call Manager will
present the main screen shown in Figure 8.
Figure 8: Call Manager Administration
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
9 of 26
ipo-callmanager.doc
4.2. System Settings
Step 1
From the Main Menu, select System -->Server and select the Server of interest as
shown in Figure 9. To add a new Call Manager Server, select Add a New Server and set
the IP Address of the Server that IP Office is to connect to and a description, then press
Update. The IP Address of this form is used in the IP Office line configuration of Figure 4
as the Gateway IP Address.
Figure 9: Call Manager Server Configuration
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
10 of 26
ipo-callmanager.doc
Step 2
Select System-->Call Manager and the select the Call Manager to configure as
shown in Figure 10.
• Ensure that Auto Registration is enabled for IP Phones and set the range of directory
numbers to be assigned for these phones (for this configuration, Cisco IP phones will be
allowed to auto register).
Figure 10: Call Manager Form
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
11 of 26
ipo-callmanager.doc
Step 3
Select System-->Region and ensure that there is a region available that will be
appropriate for communication with the IP Office as shown in Figure 11. If not,
• Select Add a New Region, enter a region name and the codec to be used within this
region, as well as a codec to use for calls between this region and the existing regions.
• Press Update and then Restart Devices to effect this change.
Figure 11: Region Configuration
Step 4
Select System-->Location to define a location for the IP406 Server.
• Select Add a New Location and add a unique Location Name.
• Bandwidth for this configuration is 100,000 kbps as the systems are LAN connected.
Figure 12: Location Configuration
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
12 of 26
ipo-callmanager.doc
4.3. Calling Search Space and Partitions
Step 1
From the Call Manager main menu, select Route-->Partition
•
Press Find to list all the system Partitions.
•
If there is not an available partition, select Add a New Partition to add a
partition for the IP406 server as shown in Figure 13.
Figure 13: Partition Configuration
Step 2
Select Update and Restart Devices as prompted to create the new Partition.
Step 3
Select Route-->Calling Search Space to create or update a calling search space to
include the partition associated with the IP406 server.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
13 of 26
ipo-callmanager.doc
Figure 14: Call Search Space Configuration
Step 4
Space.
Press Update and then Restart Devices to affect the updated Calling Search
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
14 of 26
ipo-callmanager.doc
4.4. Adding in an IP Office H.323 Gateway
Step 1
From the Call Manager main menu, select Device-->Gateway
• Select Add a New Gateway
• Set the Gateway type to “H.323 Gateway” and the Device Protocol to “H.225” as shown
in Figure 15 and press Next.
Figure 15: Add a New Gateway
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
15 of 26
ipo-callmanager.doc
Step 2
Set the Gateway items as shown in Figure 16. The Device Name is the IP address
of the IP406 server, the Location and Calling Search Space should correspond to those
created for the IP406 Server earlier.
Figure 16: Gateway Configuration
Step 3
Press Insert and Reset the gateway to have the changes take effect.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
16 of 26
ipo-callmanager.doc
4.5. Adding a Route Pattern
Step 1
From the Call Manager Main menu, select Route-->Route Pattern and then select
Add a New Route Pattern to create a route pattern for calls to IP Office.
Step 2
Set the Route Pattern to 1XXXX so this pattern applies to all calls in the 10000 to
19999 range.
• Set the Partition to be part of the IP Office-175 partition created earlier, and the
Gateway to the Gateway 192.16.200.175 created in Section 4.4.
Figure 17: Route Pattern
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
17 of 26
ipo-callmanager.doc
4.6. Configuring a Cisco IP Phone
Step 1
Connect the Cisco IP phone to the Catalyst 4224 port with in-line powering
enabled, as shown in Section 5, or with a local power supply.
• Press “**#” to unlock the configuration.
• Press Settings and then Network Configuration. Press Select.
• Set the values as shown in Table 2.
Setting
Value
DHCP Enabled No
IP Address
192.16.50.110
Subnet Mask
255.255.255.0
TFTP Server 1
192.16.50.171
Default Router 1 192.16.50.71
CallManager 1 192.16.50.171
Admin. Vlan ID 50
Table 2: Cisco IP Phone Settings
•
Save the settings and exit to the default screen.
Step 2
At the Call Manager Main Menu, select Device-Phone and press Find to list the
system phones.
• Select the phone whose device name or IP address matches the phone that was added.
• Configure the phone as shown in Figure 18. Set the Calling Search Space to the
General Calling Search Space that was created in Section 4.3 which includes the IP
Office Partition.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
18 of 26
ipo-callmanager.doc
Figure 18: Phone Configuration
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
19 of 26
ipo-callmanager.doc
Figure 18: Phone Configuration, continued
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
20 of 26
ipo-callmanager.doc
Step 3
Select Add a New Directory Number to assign a Line and Number to the phone
and ensure that the Calling Search Space is set to General.
Figure 19: IP Phone Directory Number
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
21 of 26
ipo-callmanager.doc
Figure 19: IP Phone Directory Number, continued
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
22 of 26
ipo-callmanager.doc
5. Configuring the Cisco Catalyst 4224
Table 3 shows the Cisco Catalyst 4224 configuration, abbreviated to focus on the most relevant
items for these Application Notes.
Configuration
Comments
interface FastEthernet5/1
description trunktoipoffice
no ip address
duplex auto
speed auto
switchport trunk native vlan 200
switchport mode trunk
!
FastEthernet port 5/1 is the trunk to
the P333T-PWR (VLAN 200). As a
trunk, the packets passed are tagged
with the VLAN identifier and a
priority marking.
i
interface FastEthernet5/9
description callmanager
no ip address
duplex auto
speed auto
switchport access vlan 50
!
interface FastEthernet5/10
description ciscophone20000
no ip address
duplex auto
speed auto
switchport mode trunk
switchport voice vlan 50
!
!
interface Vlan 50
ip address 192.16.50.71 255.255.255.0
ip mroute-cache
!
interface Vlan 200
ip address 192.16.200.71 255.255.255.0
ip mroute-cache
h323-gateway voip bind srcaddr
192.16.200.71
!
ip classless
no ip route static inter-vrf
no ip http server
!
FastEthernet 5/9 is the Call Manager
port. The port is assigned to the “call
manager VLAN” (VLAN 50).
FastEthernet 5/10 is for the Cisco IP
phone. In-line power is supplied by
default. The port and phone are
configured for tagged packets and for
the “voice” VLAN as 50.
VLAN 50 is established as the Call
Manager VLAN with an interface to
the router at 192.16.50.71
VLAN 200 is the IP Office VLAN
with an interface to the router at
192.16.200.71
Table 3: Cisco Catalyst Configuration
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
23 of 26
ipo-callmanager.doc
6. Configuring the Avaya P333T-PWR
Table 4 shows the Avaya Cajun P333T-PWR configuration, abbreviated to focus on the most
relevant items for these notes. The key steps are in bold.
Configuration Steps
Comments
set
set
set
set
set
set
set
set
set
set
set
port negotiation 1/1 enable
port flowcontrol all 1/1 off
port level 1/1 7
trunk 1/1 off
port vlan 200 1/1
port name 1/1 "ipphone"
port trap 1/1 enable
port classification 1/1 regular
port enable 1/1
port powerinline 1/1 1
port powerinline priority 1/1 2
set
set
set
set
set
set
set
set
set
set
set
port negotiation 1/5 enable
port flowcontrol all 1/5 off
port level 1/5 5
trunk 1/5 off
port vlan 200 1/5
port name 1/5 "ManagementPC"
port trap 1/5 enable
port classification 1/5 regular
port enable 1/5
port powerinline 1/5 1
port powerinline priority 1/5 3
set
set
set
set
set
set
set
set
set
set
set
port negotiation 1/12 enable
port flowcontrol all 1/12 off
port level 1/12 0
trunk 1/12 dot1q
port vlan 200 1/12
port name 1/12 "cisco4224"
port trap 1/12 enable
port classification 1/12 regular
port enable 1/12
port powerinline 1/12 1
port powerinline priority 1/12 3
set
set
set
set
set
set
set
set
port disable 1/24
port negotiation 1/24 enable
port flowcontrol all 1/24 off
port level 1/24 7
trunk 1/24 off
port vlan 200 1/24
port name 1/24 "ipoffice"
port trap 1/24 enable
WJR; Reviewed:
WCH 9/17/2003
Port 1 is the Avaya 4612 IP Phone. Set the
layer 2 priority level to 7, the highest level.
Set the port to be a member of the IP Office
VLAN (VLAN 200).
Set the port to be enabled.
Set the Management PC port to be a member
of VLAN 200.
Set the Cisco 4224 802.1Q trunk port to use
VLAN tagging via the 802.1Q protocol. Set the
port to be a member of VLAN 200.
Set the IP Office 406 Server port to the highest
priority level (7). Assign the port to VLAN
200.
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
24 of 26
ipo-callmanager.doc
set
set
set
set
port
port
port
port
classification 1/24 regular
enable 1/24
powerinline 1/24 1
powerinline priority 1/24 3
Table 4: P33T-PWR Configuration
7. Verification Steps
• As always, perform basic network level verification (e.g., pings).
• Run the IP Office System Monitor with Settings-->H.323 set as shown in Figure 20 to
monitor the H.323 exchanges with Cisco.
Figure 20: H323 Monitor Options
• Use Cisco Call Manager “Trace” (Application-->Call Manager Serviceability)
capabilities to create files similar to IP Office System Monitor files to follow call
progress.
8. Conclusion
By following the steps of these Application Notes, the reader will have successfully integrated an
Avaya IP406 Office Server and Cisco Call Manager. These Application Notes can also be used
as a basis to create more complex configurations, including those with WAN networks and
dynamic IP address plans.
9. Additional References
Similar Application Notes can be found at http://www.avaya.com/.
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
25 of 26
ipo-callmanager.doc
©2003
Avaya Inc. All Rights Reserved.
Avaya and the Avaya Logo are trademarks of Avaya Inc. All trademarks identified by ® and ™
are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the
property of their respective owners. The information provided in these Application Notes is
subject to change without notice. The configurations, technical data, and recommendations
provided in these Application Notes are believed to be accurate and dependable, but are
presented without express or implied warranty. Users are responsible for their application of any
products specified in these Application Notes.
Please e-mail any questions or comments pertaining to these Application Notes along with the
full title name and filename, located in the lower right corner, directly to the Avaya Solution &
Interoperability Test Lab at interoplabnotes@list.avaya.com
WJR; Reviewed:
WCH 9/17/2003
Solution & Interoperability Test Lab Application Notes
©2003 Avaya Inc. All Rights Reserved.
26 of 26
ipo-callmanager.doc