AirLink Communications Raven X HSDPA User guide

Using a Sierra Wireless AirLink Raven X
or Raven-E with a Cisco Router
Application Note
Cisco routers deliver the performance, availability, and reliability required for scaling mission-critical business applications in the most demanding enterprise environments.
• Network Management
Many Cisco routers are designed to support a modular platform with a broad range of interface
options and up to 112 10/100 Mbps switch ports with optional Power over Ethernet (PoE), for
providing DC power to network devices such as IP phones. Additionally, support for wireless
LAN standards 802.11a/b/g and support for a Small Form-Factor Pluggable (SFP) port for
Gigabit Ethernet is also built into many of the router models.
• Internet or WAN Connectivity
Cisco routers have up to two 10/100/1000 Mbps built-in routed ports which can be configured
to connect to an outside network, either the Internet or a WAN.
• Security
The Cisco routers have built-in security and up to 2500 VPN tunnels. Cisco Router and Security
Device Manager (SDM) offers simplified management.
• VOIP
Cisco CallManager Express call-processing supports up to 240 Cisco IP phone users. Cisco Survivable Remote Site Telephony (SRST) offers support for up to 720 Cisco IP phone users,
allowing the router to provide call-processing functionality to keep voice service in operation
should the connection to Cisco CME be lost.
The Sierra Wireless Airlink Raven X and Raven-E provide a cellular solution for primary or
backup connectivity providing an unparalleled flexibility of location. The rugged design of AirLink
modems makes them practical for any location, including industrial installations.
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
FIGURE 1.
Backup Network Connectivity with a Raven X
• Flexible Location
A router connected to a Raven X or Raven-E can be placed in a spot which cannot be or is not
cost effective to be connected to a wired Internet solution.
• Quick Deployment
Since the Raven X and Raven-E use a cellular network connection, there is no need to plan
Ethernet wire “drops”. As soon as the modem is activated, it can connect to the cellular network
and the router can provide Internet connectivity to the internal network.
• Versatility
The Raven X or Raven-E can be used as the primary Internet access or, using routing configurations, as a fail-over for those times when a wired solution fails.
• Rugged Construction
With a hardened case and an operating temperature range of -30 degrees C to +60 degrees C,
the Sierra Wireless AirLink Raven X or Raven-E is suitable for industrial environments.
• Software Tools
Enhanced with ALEOS intelligence, all AirLink modems come with a variety of industry leading software tools for remote monitoring, configuration, and trouble-shooting.
• Dynamic DNS
One of the features of ALEOS is the ability to configure the Raven X or Raven-E to work with
a dynamic DNS server. Even without a static IP, the AirLink modem can be contacted from
anywhere on the Internet.
Easy Configuration
The step by step configuration outlined in this guide is only a basic configuration for the Sierra
Wireless AirLink Raven X or Raven-E to be used with a Cisco router. Complex routing, two router
fail-over configurations, NAT setup, proxy server, DHCP in the router, etc., are not covered.
Note: A 3600 series router running IOS 12.2 (12a) was tested with this configura-
tion; however, other Cisco routers with a similar configuration will also work.
Sierra Wireless AirLink Solutions
January 2009
2
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
Attention: This document is intended to provide suggestions for communications
setup only, and in no way commits Sierra Wireless to provide consulting, integration, or technical support for any Cisco router or the integration of such with any
Sierra Wireless product. The assembly and integration of the Sierra Wireless AirLink Raven X or Raven-E modem and the Cisco Router is the responsibility of a
technology solutions integrator or end-customer, as neither Sierra Wireless nor
Cisco sell or support such an integrated solution.
Before You Start
Your Sierra Wireless AirLink modem will only do one-to-one routing, passing messages from the
cellular network directly to a single device, such as the Cisco router, connected to it. It cannot be
configured to act as a router for more than that one device.
Before you start your configuration, you will need to decide if you want your modem to pass the IP
address it receives to the router (Public Mode) or if you want the modem and the router to be on a
local network with a static IP which is not Internet routable (Private Mode).
If you choose Private Mode, you will need IP addresses for both the router and the modem. The IP
addresses will need to be on the same subnet and local to each other. Generally, you will want to
use a 192.168.x.x address for both. The third octet (set of numbers) will need to be the same and
the last will need to be different.
• Example Private Mode IP address for the Raven X or Raven-E: 192.168.13.31
• Example Private Mode IP address for the Cisco router: 192.168.13.30
Caution: If the modem and the router are going to be on a hub which is connected
to a local network, you will need to be sure the addresses you select are not used by
any other device on the network. Consult with your network administrator if you
are unsure.
Software Required
• AirLink Wireless Ace - Graphical interface for configuring Sierra Wireless AirLink modems.
If you don’t already have Wireless Ace, you can download the utility from the AirLink website:
http://www.airlink.com.
• Terminal application - A terminal or terminal emulation application, such as Windows HyperTerminal, to communicate with the Cisco router.
Software Recommended
• AceView - Status and connection monitor for your Sierra Wireless AirLink modem. You can
download AceView from the AirLink website: http://www.airlink.com.
• AceNet - Multiple modem configuration and monitoring utility for all Sierra Wireless AirLink
modems. With AceNet, you can save a working configuration in Wireless Ace and then load it
into several modems concurrently saving time and ensuring all the modems are configured the
same. AceNet is available for separate purchase from your Sierra Wireless representative.
Hardware Required
• Ethernet Cable - A cross-over or straight through Ethernet cable.
Sierra Wireless AirLink Solutions
January 2009
3
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
If you have a Raven X or if your computer is equipped with an auto-sensing Ethernet port, you
have the option of using a straight-through Ethernet cable.
• Power supplies and a power source - You will need a power supply and power source for both
the modem and the router.
• PC or Laptop - To configure the modem, you will need a computer with an available Ethernet
port.
Cellular Account Required
• Cellular Account - To use this guide you need to already have an active account with a cellular
provider and to have activated your modem with that provider. Sierra Wireless AirLink
modems are certified to work with a variety of cellular providers.
If you need to activate your modem, you can use the Setup Wizard for your cellular provider
which you can obtain from the AirLink website: http://www.airlink.com.
Important Information about Cellular Networks
• Port blocking - Many cellular providers and other ISPs block ports below 1024 which are commonly used for many server protocols, including the SSH server (port 22 by default). If your
provider blocks these ports, you will need to configure ports you can access, if you need remote
access.
• Upload Speed - The 2G and early 3G cellular technologies (CDMA, GPRS, EDGE, iDEN,
and EV-DO Rev0) have a much lower upload (transmit) speed than download. In addition,
many cellular providers also “throttle” the upload speeds of devices connected to their networks. Even with good signal, it is not uncommon to see upload speeds of only 60 to 100kbps
while you have download speeds in excess of 600kbps (2G) or 1000kbps (3G).
• Upload Speed for Cellular “Broadband” using the Raven X - One of the advantages of a
Raven X vs. the Raven-E is the ability to connect at EV-DO Rev A or HSDPA speeds.
EV-DO Rev A is an enhancement to EV-DO Rev 0 and not only improves the download speeds,
3.1Mbps maximum (1Mbps+ typically), but greatly increases the upload speed as well,
1.8Mbps maximum (300-400kbps typically). In areas without EV-DO Rev A coverage, the
Raven X will fallback to EV-DO Rev 0, if it is available, or 1x.
HSDPA is a huge speed increase over EDGE with download speed in excess of 1Mbps maximum (500-800kbps typically) and upload speed in of nearly 400kbps maximum (200-300kbps
typically). In areas without HSDPA, the Raven X will fallback to UMTS, if it is available,
EDGE, or GPRS.
• Signal Strength and Quality - The upload performance of your modem will also be heavily
influenced by the signal strength and signal quality of the cellular connection in the installed
location. If you do not have optimal signal, the upload speed can be greatly reduced. Sierra
Wireless AirLink Solutions recommends an RSSI of -60 to -80 or better for optimal signal.
However, even with a strong signal, if the modem is connecting to a particular cell site that has
heavy data traffic to share the total available bandwidth to the cellular provider’s network, the
quality of the signal may be lower which can also impact the camera’s remote performance.
These two aspects are also referred to as the coverage and capacity for a specific location. Your
cellular carrier’s representative or your Sierra Wireless representative may be able to help you
determine what is best for your installation.
Sierra Wireless AirLink Solutions
January 2009
4
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
Configuring the Raven X or Raven-E
1.
Connect your Raven X or Raven-E directly to the Ethernet port on your computer and to power.
2.
Start Wireless Ace and connect to your Raven X or Raven-E.
Start > All Programs > AirLink Communications > Wireless Ace 3G > Wireless Ace 3G
a. Click on Connect.
b. Select UDP.
c. Type in the modem’s local IP address (default is 192.168.13.31).
d. Type in the modem’s password (default 12345).
FIGURE 2.
Wireless Ace: Connect
If you don’t know the IP of your modem, you can connect to it using the Ethernet
option for “Connect to Modem”. Your modem should be automatically detected.
3.
Select PPP/Ethernet from the menu on the left side of Wireless Ace (under “Groups”).
Private Mode
In this mode, the Raven X or Raven-E communicates with the Cisco router via a static local IP
address.
a. Set the *HOSTPRIVMODE to 1.
b. Set the *HOSTPRIVIP to the IP address for the router (in the example, 192.168.13.30).
c. Verify the *HOSTPEERIP is the local IP address of the modem (in the example this is
192.168.13.31).
d. Set the *HOSTNETMASK to the Subnet Mask (generally 255.255.255.0).
Sierra Wireless AirLink Solutions
January 2009
5
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
FIGURE 3.
Wireless Ace: PPP/Ethernet
1 - Use Private IP
192.168.13.30
192.168.13.31
255.255.255.0
Public Mode
In this mode, the Raven X or Raven-E assigns the Cisco router the IP address it has received from
your cellular provider.
Set the *HOSTPRIVMODE to 0.
FIGURE 4.
Wireless Ace: PPP/Ethernet
0 - Use Public IP
Raven X and Raven-E DHCP Server
If the Raven X or Raven-E is going to be placed on a network which has a DHCP server, the internal DHCP server of the modem can be disabled.
Set *DHCPSERVER to 2 - Enabled if no other DHCP server is detected.
FIGURE 5.
Wireless Ace: DHCP
If you want to completely disable the DHCP server in the Raven X or Raven-E,
you can only do so by using a terminal application to connect to the modem and
using the *DHCPSERVER command to set it to 0. You cannot completely disable
the DHCP server in Wireless Ace.
4.
Sierra Wireless AirLink Solutions
When you have finished configuring the Ethernet settings, click the Write button on the tool bar
of Wireless Ace and wait for the message “Write Successful” to appear in the status bar.
January 2009
6
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
FIGURE 6.
5.
Wireless Ace: Write
Disconnect the Raven X or Raven-E from your computer.
Configuring the Cisco Router
The Cisco router has a few different configuration interfaces. This guide just provides the commands for the IOS command line interface. It is assumed your router is configured with the basic
configuration. This guide only covers a basic connection with the AirLink Raven X or Raven-E
and setting the modem up for the simplest of fail-overs.
1.
Connect the Raven X or Raven-E to the Cisco Router. You may need to use a twisted pair cable.
2.
Configure the routed Ethernet port(s).
If there are two Ethernet ports on the router, you may need to configure both of them.
Caution: If you have a router with two Ethernet ports, one of them may already be
configured as your wired Internet connection. If so, do not change that configuration, only change the configuration for the port which will be used with the Raven
X or Raven-E.
Specify an IP address for a static route if you want by using “ip address 1.2.3.4” or set the interfaces to use DHCP (as shown in the example).
Example:
interface FastEthernet1/0
ip address dhcp
duplex auto
speed auto
interface FastEthernet1/1
ip address dhcp
duplex auto
speed auto
3.
Ensure IP routing is enabled. If the configuration file says “no ip routing” then use “ip routing” to
configure it.
4.
Ensure the ethernet port(s) is getting an IP address. Use “show ip route”.
Sierra Wireless AirLink Solutions
January 2009
7
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
Test the Configuration
Testing the configuration assures that the network behind the router can access the Internet with the
Raven X or Raven-E.
Two Routed Ethernet ports (fail-over)
With a wired Internet connection to one of your router’s Ethernet ports and the modem on the other
Ethernet port, disconnect the cable from the Ethernet port connected to the wired connection.
Attempt to reach an Internet location with a ping, browsing a web page, etc., with a computers connected to the router. The router should continue to route traffic to the outside.
One Routed Ethernet port (cellular Internet or WAN connectivity)
With the modem connected to the router’s Ethernet port, attempt to reach an Internet location with
a ping, browsing a web page, etc., with a computers connected to the router.
Sample Basic Configuration File
This is a sample configuration file for a simple Fail-over configuration on a 3600 series router running IOS 12.2 (12a).
Using 716 out of 30712 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3600
!
enable secret 5 XXX
enable password XXX
!
ip subnet-zero
!
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet1/0
ip address dhcp
speed auto
half-duplex
!
interface Serial1/0
no ip address
shutdown
clockrate 2000000
Sierra Wireless AirLink Solutions
January 2009
!
interface FastEthernet1/1
ip address dhcp
duplex auto
speed auto
!
interface Serial1/1
no ip address
shutdown
shutdown
!
interface Serial1/2
no ip address
shutdown
clockrate 2000000
!
ip classless
ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
password virtual
login
!
end
8
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
Sample Basic GRE Tunnel Configuration Files
These are a sample configuration files for a simple GRE tunnel configuration. The Host router and
the Remote router both need to be configured.
Host
interface FastEthernet0/1
description connected to EVDO modem WWAN backup
ip address 192.168.X.X 255.255.255.255
duplex auto
speed auto
!
interface Tunnel1
description backup tunnel to Remote
ip unnumbered FastEthernet0/0 (local LAN interface)
ip access-group wwan_backup out
load-interval 30
tunnel source FastEthernet0/1
tunnel destination 192.168.X.X
!
interface Tunnel2
description backup tunnel to Remote 2
ip unnumbered FastEthernet0/0 (local LAN interface)
ip access-group wwan_backup out
load-interval 30
tunnel source FastEthernet0/1
tunnel destination 192.168.X.X
!
router eirp 100
passive-interface tunnel1
passive-interface tunnel2
!
ip route 192.168.X.X 255.255.255.255 FastEthernet0/1 (tunnel destination to remote)
ip route 192.10.X.X 255.255.255.0 Tunnel1 200
ip route 192.168.X.X 255.255.255.255 FastEthernet0/1 (tunnel destination remote 2)
ip route 192.10.X.X 255.255.255.0 Tunnel2 200
!
! (only permits: icmp, smtp, IMAP, POP3, FTP & Telnet)
ip access-list extended wwan_backup
permit tcp any any eq 25
permit tcp any any eq 143
permit tcp any any eq 110
permit tcp any any eq 21
permit tcp any any eq 20
permit tcp any any eq 23
permit icmp any any
Remote
interface FastEthernet0/1
description connected to EVDO modem WWAN backup
ip address 192.168.X.X 255.255.255.255
duplex auto
speed auto
!
interface Tunnel1
description backup tunnel to Host
ip unnumbered FastEthernet0/0 (local LAN interface)
ip access-group wwan_backup out
load-interval 30
tunnel source FastEthernet0/1
tunnel destination 192.168.X.X
!
router eirp 100
passive-interface tunnel1
!
Sierra Wireless AirLink Solutions
January 2009
9
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
ip route 192.168.X.X 255.255.255.255 FastEthernet0/1 (tunnel destination to Host)
ip route 192.10.X.X 255.255.255.0 Tunnel1 200
ip route 192.10.X.X 255.255.255.0 Tunnel1 200
ip route 0.0.0.0 0.0.0.0 Tunnel1 200
!
! (only permits: icmp, smtp, IMAP, POP3, FTP & Telnet)
ip access-list extended wwan_backup
permit tcp any any eq 25
permit tcp any any eq 143
permit tcp any any eq 110
permit tcp any any eq 21
permit tcp any any eq 20
permit tcp any any eq 23
permit icmp any any
Additional Cisco Sample Configuration Scripts
You may be able to find additional sample scripts for different configuration types on the Cisco
website: http://www.cisco.com.
AirLink Solutions Technical Support
If you encounter problems with operation of your Host RJ-11 IP Gateway or Raven-E (as applicable), Sierra Wireless product, the support staff of Sierra Wireless AirLink Solutions can help. RJ11 IP Gateway ou Raven-E,
Caution: The configuration suggestions offered in this guide are not supported nor is any equip-
ment other than Sierra Wireless products. Only the operation of the modem or software obtained
directly from Sierra Wireless is supported.
Refer to the User Guide for your modem or the Sierra Wireless AirLink Solutions website for
Sierra Wireless product warranties.
Sierra Wireless AirLink Solutions Support Web Site
The web site is updated frequently with Setup Wizards, Utilities, How-To Guides, and other documentation: http://www.airlink.com/support.
Documentation and Guides
• User Guides - These guides are specific to your modem type, cellular provider, and cellular
technology and contain comprehensive information about the operation of the modem and its
features.
• Quick Start guides - These guides are also specific to the modem type, cellular provider, and
cellular technology and are a step by step guide to activating the modem using the Setup Wizard or other steps as applicable.
• Utility Guides - These guides focus on the features of one of the modem utilities: Wireless
Ace, AceView, AceNet, Modem Doctor, etc.
Sierra Wireless AirLink Solutions
January 2009
10
Using a Sierra Wireless AirLink Raven X or Raven-E with a
Cisco Router
• Application Notes and How-To Guides - These guides detail configuring the modem to work
with a specific feature set or how the modem can be set up to work with a specific 3rd party
(non-Sierra Wireless) device.
• Data Sheets and White Papers - These are technology based information documents.
Contacting Technical Support
For support assistance please email support@sierrawireless.com or call (877) 231-1144 Monday
through Friday 5 AM to 5 PM Pacific Time (8 AM to 8 PM Eastern Time). Support is not available
weekends or holidays. (877) 231-1144
Information in this document is subject to change without notice.
©Copyright Sierra Wireless AirLink Solutions, Inc., 1993-2007. All rights reserved.
Sierra Wireless AirLink Solutions
January 2009
11