Apple DVD Studio Pro User guide

1
2
Contents
Guide Introduction
4
General System Requirements
The DVD Creation Workflow
Compressor Mini-Guide
7
Understanding DVDs
10
DVD Disc Standards
DVD Disc Capacity
Video Definitions
Aspect Ratio & Correction
Targetting Your Audience
Choosing Your Content
Determining Encoding Rates
Storyboarding Your Project
Gathering Your Assets
Choosing a Configuration
Project Tab
General Tab
Menu Tab
Track Tab
Allignment Tab
Text Tab
Colors Tab
Simulator Tab
Destinations Tab
Encoding Tab
DVDSP Toolbar
Assets Window
Graphical Tab
Outline Tab
Inspector Window
Palette Window
Viewer Window
Menu Editor
Timeline
Planning a DVD
5
6
11
Setting Up DVD Studio Pro
12
DVD Studio Pro Preferences
12
The DVD Studio Pro Interface
Creating a DVD
23
Graphical Chart Example
DVD Authoring Terminology
16
27
28
3
Welcome to Polk County Instructional Television’s DVD Studio Pro Quick Reference Guide, Summer
2008 Edition. This guide seeks to cover the basics of DVD Studio Pro and Compressor, its complement program, as well as provide training in more advanced uses of the application.
In order to appreciate an application like DVD Studio Pro, you must first appreciate the end result of
any DVD Studio Pro project: a DVD. Perhaps the main distinction between DVDs and VHS tapes, besides the
difference in video and sound quality, is the manner in which they are operated. The content on a VHS tape can
only be played back in the order in which it was recorded to the tape, allowing no user input, configuration, or
customization of their viewing experience. A DVD is quite different. First of all, DVDs can potentially store
much higher quality media than a VHS tape. Also, DVDs can hold multiple videos, pictures, and music, which
may be watched in whatever order the viewer likes. Finally, a DVD can include multiple playback settings, allowing the viewer to select the settings most appropriate for their system.
While many of these differences between VHS and DVD were impressive when DVDs were first released, the novelty of the DVD’s features has worn off. Most viewers probably take for granted the interactive
elements included on most every DVD. However, as you might already know, or at least are about to find out,
all of the special elements such as playback settings, bonus content, high-quality video, and interactivity don’t
just happen. Everything you experience when watching and controlling a professional DVD has been designed
and programmed into it. This is where DVD Studio Pro comes in.
DVD Studio Pro (DVDSP) allows you to create professional-quality DVD discs for playback on any
standard DVD Player or on a computer that can read DVD discs. You can use one of DVDSP’s many highquality pre-designed templates or start from scratch and create your own menus, transitions, buttons, etc. Out
of the many programs included in Apple’s Final Cut Studio, DVD Studio Pro requires the most knowledge of
all the applications, especially if you intend on creating a totally customized DVD. One DVD project might include videos from Final Cut Pro, sound effects and music from Soundtrack Pro, menu animations from Motion
or After Effects, and menu designs from Photoshop.
However, even if you don’t intend on creating an entire project from scratch, you’ll still be able to
develop quality DVD projects using the many built-in templates, all of which can be customized to meet your
liking. Throughout this guide you will learn the layout of DVDSP and how to use its most common functions,
as well as some of its more advanced features. By the time you finish this book, you will be able to design and
burn a DVD from scratch.
Compressor, an encoding software that complements DVD Studio Pro, will be an essential tool during
the DVD creation process. A DVD disc does not use regular Quick Time or .AVI movie files, but instead needs
specific types of compressed video and audio files. Compressor allows you to quickly and easily create these
specialized files before you begin working on a DVD project, which saves time during the DVD creation process and improves the quality of the final product.
Further information on encoding, planning, creating, and burning DVDs can be found in the Compressor and DVD Studio Pro Help manuals that come pre-installed with the applications. There are also multiple
resources online that highlight DVD creation techniques and tips. A few of these sites are listed in
the back of this guide.
4
General System Requirements
Minimum System Requirements
A Macintosh computer with a 733 megahertz (MHz) or faster PowerPC G4 or G5 processor (G5 required for
HD authoring and playback)
* 8 megabytes (MB) of video memory (32 MB recommended)
* 512 MB of RAM (1 GB required for HD)
* AGP Quartz Extreme graphics card
* For application installation: DVD drive, 10 gigabytes (GB) of disk space
* For writing finished projects to disc: Apple SuperDrive or other DVD recorder
* For writing finished projects to a double-layer disc: a double-layer compatible recorder and double-layer
media
* For transporting projects on tape to a replicator (suggested for DVD-9 projects): DLT drive
* For transporting projects on disc that contain copy-protection or dual-layer features to a replicator:
authoring DVD drive
Minimum Software Requirements
* Mac OS X v10.3.9 or later
* QuickTime 7.0 or later
Source Material Requirements
* Edited video files in MPEG-1, MPEG-2, HDV, HD DVD-compliant H.264, or QuickTime format
* Edited audio files in PCM, AIFF, MPEG-1 Layer 2, AC-3, DTS, or QuickTime format
* Video creation or editing software, such as Final Cut Pro and Motion, or any video and audio editing
programs that support QuickTime
5
6
Compressor
After mapping out a plan for your DVD and moving all of the files you’re
going to need into your DVD project folder, the next step is to prepare your movies and audio files for use in DVD Studio Pro. The only files that can be written
to a DVD-Video are MPEG-1 or MPEG-2 video files and AIFF or Dolby Digital
audio files. Also, all movies, when imported to a DVD project, must be separated
into individual files, a video file (MPEG-2) and an audio file (Dolby Digital).
While this may sound like a tremendous task, the process is quite simple
thanks to Compressor. In just a few steps, Compressor will create new, DVDready files from your movies. The following steps cover the basic importing and
converting of files in Compressor.
Add File
Batch Window
History
Button
Settings Window
Inspector
Button
Preview
Button
Inspector Window
Batch
Monitor
Preview Window
History Window
Step 1 - Click the Add File button at the top of the Batch Window.
Step 2 - Select the files you wish to convert and hit Open. The selected files are imported and place in the Batch Window.
Step 3 - In the Settings Window, select the encoding preset you
wish to use for the file. Select Apple > DVD > DVD: Best Quality 90 Minutes.
7
Step 6 - Set a destination where the encoded files will be saved. Compressor automatically saves the encoded files in the same
folder as their original counterparts. However, it is always a
good idea to create a separate folder where you can store your
encoded files.
Once you have created this folder within your main project folder, you’ll need to set the destination of your clips. Highlight the clips by clicking on their picture in the Batch Window.
From the Menu Bar at the top of the application, select Target >
Destination > Other. In the dialogue box, select the newly created folder and hit Open.
Step 7 - Name the files. Compressor automatically names the
files using the original file name followed by the new file type. For example, a file named “Daily Show” would result in two
files, a video file (“Daily Show-MPEG-2 6.2Mbps 2-pass.m2v)
and an audio file (“Daily Show-Dolby Digital Professional
2.0.ac3). Notice how the encoding settings determine the default
file name. You can change the name of the encoded files by typing in new names in the File Name area of the Batch Window.
Step 8 - Submit the files for encoding. Now that the files have
been given the proper encoding settings and set to the right destination, it is time to submit them for compression, the process that
converts them from their original format to the DVD-compatible
format. To submit the files in the Batch Window for compression, click the Submit button in the bottom right-hand corner of
the window.
A dialogue appears with Batch options. If you plan on
rendering multiple batches of videos at once, you may want to
name the batch something that will distinguish it from other
batches. Otherwise, make sure your setting match those to the
left, then hit Submit.
Information
8
Stop
Pause
The batch you submitted will be rendered in the background, allowing you to work on other projects until the files are
completed. To see the progress of the rendering, you can open
the Batch Monitor application by clicking on the Batch Monitor
button in the main Compressor Toolbar.
Batch Monitor shows the current progress of the batch,
and lists the status of each encoding job within each batch. You
can pause or stop individual files, or an entire batch, from rendering by clicking the pause or stop button beside the track you wish
to stop.
Compressor comes packed with several encoding
presets. These are predetermined qualities of encoding based
on the output you desire. For instance, since we are creating
a DVD, we want to use Apple’s DVD encoding presets. In
the DVD list are multiple options, including combinations
of Best Quality (takes longer, but better picture quality and
smaller files), Fastest Encode (less time to complete, larger
files, less picture quality), and time (90 - 150 minutes, depending on how much time you wish to fit on your project). The more you include, the higher the compression rate in
order to fit everything in, thus lower video quality).
Notice that each preset folder contains two presets
inside it: a Dolby Digital audio preset and a MPEG-2 video
preset. You can use just one (if you have pure audio or video
files that need converting or a file with both audio and video
in which you only require one of the two to be encoded) or
you can use them both.
Step 4 - To apply an encoding preset to a file in the
Batch Window, click and drag the preset from the Settings
Windows to the Batch Window and release it on top of the
file you wish to convert.
Note: If you want to apply both presets in a folder, you can
click and drag the folder to add both encoders at once.
Audio Encode
File Destination
Encoded File Name
Play Head Divider
Video Encode
Step 5 - Use the Preview Window to ensure that
the encode quality is acceptable. Click the video encode
file in the Batch Window. The clip appears in the Preview
Window, which is now split with a white line. The left side
shows the original video, while the right side shows a preview of the video after it has been encoded. Dragging the
play head at the top left or right changes more of the frame
to display either the original or the encoded quality. Make
sure you are satisfied with the encoded picture before moving on to the next step.
Original
Video
Encoded
Video
9
Understanding DVDs
DVD Disc Standards
If you’ve ever tried to purchase DVDs for the purpose of burning your projects on them, you’ll have
probably noticed the many different formats of DVD disc that are available. While most DVD burners are
capable of burning to many if not all of the formats available, some formats operate better in DVD players than
others. Generally the best DVD discs for burning are DVD-R, as they are capatable with the largest range of
DVD burners and players.
DVD Disc Capacity
An important aspect to understand about DVDs, especially when it comes to authoring your own DVD
project, is how they store and playback information. DVDs, unlike tapes, do not play back information in the
order of which it was recorded, and while they do have a limit to the amount of data that they can hold, that
limit is not measured in minutes or hours, but rather in bytes. A topic of much frustration and confusion when
creating DVDs is why a disc that is advertised to hold 4.7GB can not actually store that much information. This
is because gigabytes on a disc are measured using the “1000 bytes equals a kilobyte” system, while gigabytes
on a computer are measured as “1024 bytes equals a kilobyte.” So, when planning your project, keep in mind
that a typical “4.7GB” DVD can only store about 4.38GB of computer data.
Video Definition
One of the most commonly misinterpreted facts about DVDs is that all DVD content is high-definition. While DVD video is markedly improved over VHS, it is still considered standard definition. True high-definition footage contains a greater amount of pixels than standard definition and also requires a different type of
disc in order to be played back in most DVD players. Another common misconception is that 16:9 (widescreen)
video is in some way a superior quality to 4:3 (standard box) video. This is also inaccurate. Both contain the
same amount of information (pixels), only the aspect ratio is different.
Aspect ratio & Correction
Aspect ratio is the ratio of the width of the visible area of the video frame to the height of the visible
area. The most basic aspect ratios are 4:3 and 16:9. DVDs have various ways of dealing with the different
aspect ratios. If you are creating a DVD with all 16:9 footage, you’ll want to create a 16:9 DVD. This is fine if
your target audience will be viewing the DVD on a widescreen television, but what if they dont? In this case,
we must decide how we want them to view the footage on the DVD. There are three options:
The first option is to simply insert 16:9 footage into a 4:3 track and give the viewer the option to play it
back that way. However, this stretches the picture vertically and produces an awkward result. The next option
is to display the video within a letterbox, where black bars fill the top and bottom portions of the screen and the
aspect ratio is unchanged. The final option is to display the video in “pan-scan” mode. In this mode, the video
is enlarged until it fills the screen, meaning the sides of the video are cropped. Advanced users can even define
what area of the frame should be visible while in pan-scan mode. The choice between pan-scan and
letterbox is primarily stylistic. Both options will be covered later in this guide.
10
Planning a DVD
Targeting Your Audience
The first step to creating any DVD is determining the audience that will be watching your project. For
instance, will the viewer need extensive playback control, such as customizing languages, subtitles, etc., or will
the DVD need to simply play a movie the moment it is inserted?
Also, how will your audience be viewing your project? Will they primarily use a standard set-top DVD
player or a computer for viewing? With a DVD player, they’ll navigate using a remote, but on a computer,
they’ll probably use a mouse and click the buttons, which means you must make it clear where they should
click. Also, some older DVD players and slower computers cannot play DVDs with too high a bit rate, which
means you’ll have to lower the quality of your video files to ensure that they’ll play correctly.
Choosing Your Content
Unlike a VHS or DV tape where storage is measured in minutes, DVD storage is measured in bytes of
information. A standard DVD can contain up to 4.37 GB of computer data, whether it be video, audio, still
pictures, etc. This includes any menus, transitions, and special features in your project, because they all take up
room on your DVD.
It is important that you know what content, or assets, you plan using before you begin your project. An
asset is any video, audio, or still picture file that you use or plan on using in your DVD. If you think you might
go over a standard DVD’s capacity, consider cutting out elements that are not crucial, splitting your project into
2 separate DVDs, or designing a dual-layer or double-sided DVD. In your planing it is also important to account for features such as subtitles, languages, chapter markers, etc. Adding features and options into your project after it is already complete takes up time that could have been saved with the right amount of preparation.
Determining Encoding Rates
A DVD uses special video files that have been compressed to fit onto the limited storage space of the
disc. By knowing about how many minutes of video will be included in your project, you can determine the
amount of compression you’ll need to use to make your content fits. The process of compressing assets to make
them fit onto a DVD is called encoding. A good formula to use is 560/x = bit rate. Where “x” represents minutes of video and bit rate is measured is megabits-per-second (Mbps). If you plan on using uncompressed audio
files in your project, you’ll need to subtract 1.5 Mbps from the bit rate determined in the formula above to leave
room for the larger audio files. For more information about encoding, see Encoding Assets on page xx.
Storyboarding Your Project
Once you have a list of all the content and features you want to include on your DVD, you need to storyboard your project. What is the first thing the viewer will see when they insert the disc? An animated logo? A menu? A movie? After the first element plays, what, if anything, will the viewer see next? How many menus
will you need and what options will be on each menu? How many different ways can viewers access a particular video or feature, or can they access it at all? Has a connection been made to every asset in your project?
After asking these questions, get a sheet of paper and physically draw out the look of your project and also the
connections in your project. Planing out the connections between the different menus, assets, transitions, and
other features of your DVD will increase efficiency and decrease mistakes during the creation process.
Gathering Your Assets
Every file you intend to use in your DVD project should be collected and organized into a project folder
before beginning your work in DVDSP or Compressor. This includes video and audio files, still pictures, Photoshop menus, animations, music, etc. It is in this folder that you should save your DVD
11
project when you first create it in DVDSP.
Setting Up DVD Studio Pro
The first time you open DVD Studio Pro, a dialogue appears where you choose the user interface configuration, the video standard, the DVD standard, and the default language to use. Refer to the image below for
the correct settings for steps 2-4. When opened after this, DVD Studio Pro uses the same settings as when it
was last open.
Figure 1
Choosing a Configuration
DVD Studio Pro comes with 3 standard interface layouts, each catering to a different level of user expertise and project requirements. Of the 3 layouts, the Advanced is the best choice for those learning DVD Studio
Pro. It allows you to view all of the most important windows in DVD Studio Pro, giving you a full spectrum of
tools to learn and experiment with. With time you will discover which windows you use most often, and then
you can create a custom configuration that suits your needs best.
DVD Studio Pro Preferences
It is always important to select the correct preferences before beginning a new DVD project. While
some are mandatory, many can be changed as you grow more experienced with the program and wish to adapt
its functions to your liking. Also note that some settings are “defaults” meaning that within the project these
settings can be changed per element. The following snapshots show the recommended settings. To open DVD
Studio Pro Preferences, click the DVD Studio Pro menu button and selecting Preferences.
Project (Tab 1)
The Project tab contains basic settings for any new projects.
• DVD Standard - Unless you’re creating a high-definition and have the capability of burning on,
leave the DVD Standard set to SD DVD.
• Video Standard - This should always be set to NTSC.
• Default Language - Sets the default language of the DVD project.
12
General (Tab 2)
• Default Slide Length - sets the default time that each slide in a slideshow is displayed.
• Background Color - sets the color that is visible behind the slides.
• SD DVD Menus, Tracks, and Subtitles - sets the default display mode for all Standard Definition
(SD) assets in the project. See the section on Aspect Ratios for more information.
• Thumbnail Size - dicates the size of the element previes in the palette and slideshow windows.
• Subtitle Settings - controls the default length of fade-in/out, and onscreen times for subtitles
Menu (Tab 3)
• Motion Duration - sets the default length of menus which contain moving assets such a video backgrounds.
• Auto Assign Button Navigation - dictates how DVDSP configures the default navigation controls of
the buttons on your menus.
• Final Rendering - determines how the menus and transitions of your DVD project are rendered
once the DVD is complete. While Hardware based rendering will provide faster results, those
results will be based on your computer’s video card capabilities, and thus might not be as excellent
that of a better card, and the results will vary from computer to computer. For guaranteed good
rendering quality, choose Software based. Rendering will take longer, but the results will be consistent.
• Drop Palette Delay - sets the amount of time before the Drop Palette menu appears
when dragging assets from other windows onto the main design area.
13
• Video Background Color - sets the default color for the background of menus.
Track (Tab 4)
• Marker Prefix (Root) Name - The name that all new markers use as their prefix. “Check for unique
name” ensures that you will not have two markers with the same name within a track.
• Generate Marker Names - controls whether each marker is followed by a timecode value or a number. “Automatically” generates a number that increments each time you add a new marker. This
is useful as it shows how many markers have been created in track, however it does not distinguish
between whether markers have been deleted or not, and when markers are deleted, the numbers on
the rest of the markers are unaffected. “Timecode based” inserts the timecode where the marker
is positioned after the marker name. With “Auto update” enabled, as you move a timecode based
marker, the name will change to reflect the new timecode position.
• Thumbnail Offset - determines the amount of time into a video at which a thumbnail preview of
that video is created. Because most videos begin with black and fade up, setting the time for a few
seconds in allows for a better chance of capturing a frame that best represents the track.
• Default Language - determines the default language assigned to audio and subtitle tracks.
Allignment (Tab 5)
The Allignment tab contains controls for the rulers, unit measurements, and guide settings for DVDSP.
These settings should generally be left to their default positions.
Text (Tab 6)
The Text tab contains controls for the text settings of subtitles, menu text, and menu buttons. These
settings are also adjustable within the operation of DVDSP and will be covered later in this guide.
Colors (Tab 7)
The Colors tab contains the color mapping settings for the Menu and Subtitle Editors. These controls
are also located in the inspector window and will be covered later in this guide.
Simulator (Tab 8)
The Simulator tab contains the simulator preferences used to test your DVD project, including Video
Playback device, Audio Playback device, Resolution, and Display Mode. These settings will depend
on your setup and on your project. Generally, Video Playback should be set to “Simulator” and Audio
Playback to “Build-in Line Output”, Resulution to “SD” and Display Mode to “4:9” or “16:9” depending on your project.
14
Destinations (Tab 9)
• Show - Choose the process whose path you want to configure.
• Encoding: Specifies the location for the video and audio files that are created by DVDSP when
it is used as the encoder of video files imported into the project. These files should be kept in
your project folder, and within that, in a specific folder for encoded versions of your video files. Choose “Specified Folder/Fallback Folder” and select the appropriate folder.
• Image Encoding: Specifies the location for the MPEG files that are created when you use nonMPEG still images in your menues, slideshows, and within a track. Once again, this should be
set to a specific folder within your project folder.
• MPEG Parsing: This should also be set to a specific folder with your project folder.
• Build/Format: Contains the default location to which the AUDIO_TS and VIDEO_TS folders,
created during the build process, are saved. A specific folder should be created within the project
folder for the build files.
Encoding (Tab 10)
Final Cut Studio supplies an excellent encoder with Compressor, which is the recommended software
for encoding any assets used in your DVD project. For more information on encoding, see the Compressor section of this guide. The following settings are those that might not be specifically covered in
the Compressor section.
• Aspect Ratio: Select the correct aspect ratio depending on the assets that are being encoded.
• Start: Sets the starting timecode of the encoded MPEG stream. This should be set to 00:00:00;00
and “Drop Frame” should be selected.
• Motion Estimation: This setting controls how much time is spent determining the motion between
video frames. The higher the setting, the better the encoding quality, but the slower the encoding
process.
15
The DVD Studio Pro Interface
DVD Studio Pro Layout
Disc
Open
Add
Meter
Add
Inspector
Add Language
Add Layered
Slideshow
Script
Format
Open Palette
Palette
Build
Simulate
Menu
Add Story
Add
Window
Window
Track
Burn
Add Menu
Build/Format
Import
Asset
Outline
View
Menu
Track
Viewer Tab
Graphical View
Asset Window
Slide Show, Story, Script Editors
Connections
Tab
Menu Editor
Track Timeline
Window
Inspector
Window
DVDSP Toolbar (Advanced Configuration)
• Import Asset: Opens the Import Asset dialog, allowing you to select assets to import into the project.
• Add Menu: Adds a new standard menu to the project.
• Add Layered Menu: Adds a new layered menu to the project.
• Add Track: Adds a new track to the project.
• Add Slideshow: Adds a new slideshow to the project.
• Add Story: Adds a story to the currently selected track (or the first one, if none is currently selected).
• Add Script: Adds a new script to the project.
• Add Language: Adds a new menu language to teh project.
• Simulate: Opens the project Simulator, allowsing you to try out your project before acutally buidling it.
• Burn: Builds the video title set and writes it to your DVD burner using the current Disc Inspector
settings.
• Build: Compiles your project and creates a video title set (VIDEO_TS folder) of your project.
• Format: Writes the video title set to a DVD drive or as a disk image to a hard disk.
16
DVDSP Toolbar (Advanced Configuration) - continued
• Build/Format: First builds the video title set, then writes it to a DVD drive or as a disk image to a
hard disk.
• Disc Meter: A progress bar that shows both the amount of disc space used and what is still available (based on the Disc Media you select in the Disc/Volume tab in the Disc Inspector). The number underneath the progress bar shows the amount of space used.
• Open Palette Window: Displays the Palette in its last configuration.
Create
Remove
New Folder
• Open Inspector: Displays the Inspector.
Asset
Assets
Assets Window
Tab
Every element imported into a
DVD Studio Pro project is referered to as
Import
an asset. The Assets tab is a central locaAssets
tion for managing the assets used in your
Folder
project. It displays extensive information
Expanded
about each asset in columns that you can
Folder
configure to see just the information you
want. You can also create folders and sub- Video Icon
folders within the Asset window to help
Audio Icon
organize them when you’re working on
large projects.
NOTE: Adding and removing files from
the Asset window does not affect the
original files, so by removing a file, it is
not deleted from the computer, it just is no
longer listed in the Asset list.
Still Image
Icon
NOTE: Before importing any asset, make
sure it is in your project folder first.
Graphical Tab
The Graphical tab provides a tilebased view of all elements in your project. You are able to arrange the tiles and
display lines indicating how they connect
to each other. This makes it possible to
create a flowchart of your project, which
can be printed and used for project planning and approvals.
Zoom to Fit: Zooms the graphical view
out until all elements are visible.
Show Macro View: The Macro view is
similar to the Navigator in Photoshop
and allows you to see a small map of
the graphical view which you can move
around on to highlight different areas in
the larger view.
Hide
Stories
Status
Indicator
Hide
Hide
Slideshows Scripts
Encoding
Use
Progress
Indicator
Zoom to
Show Macro
Fit
View
Lock Tile
Positions
Hide
Menus
Hide
Tracks
First Play
Indicator
Connection
Indicator
Menu
Video
Track
Script
17
Outline Tab
The Outline tab provides an orgainized list of all project elements. Each
element is grouped by type, such as Menus
or Tracks, in sections that function a bit
like folders. Next to each section name
is a triangle that expands or collapses the
folder.
Like in the graphical tab, the outline tab
allows you to rearrange the elements.
Simply drag and drop the elements of your
project into whatever order you wish. You
can also rename elements by selecting
the element and then either clicking on its
name or pressing Return. Then type in
the desired name and press Return to save
the changes. You can also delete elements
from this menu by selecting an element
and then pressing Delete. Finally, to
duplicate an element, select the element,
and then either right-click (ctrl-click) and
select Duplicate or use the shortcut ⌘D.
Inspector Window (Menu Layout)
The Inspector is a window that
displays the properties of the elemtent
you are currently working with. In some
cases, it contains multiple tabs, with the
properties grouped by type and function.
The Inspector window is the
central hub of information for your DVD
project. While the arranging of the DVD
might be performed in the Menu editor,
the real work is completed within the
Inspector. This is where elements are connected to other elements, menus are given
their background and motion duration
times, tracks are given their end jumps,
etc. Because of the vast nature of elements that can be manipulated in DVDSP,
it would be impossible to list all the different configurations of the Inspector window. So instead, its uses will be explained
as needed. For information on the more
advanced features of the Inspector, see the
DVDSP User Guide by selecting Help >
DVD Studio Pro User Guide
from the program menu.
18
Outline
Tab
DVD
Title
Menu
Track
Menus
Folder
Tracks
Folder
Slideshows
Folder
Script
Scripts
Folder
Background
Asset
General Tab
Languages
Folder
Element
Title
Menu Tab
Transition
Tab
Colors
Tab
Advanced
Tab
Palette Window
The Palette prives easy access to
the templates, styles, and shapes used to
create menus. Additionally, the Palette
includes three media tabs that connect to
the Audio, Still Image, and Video folders
in your User Folder of Macintosh HD.
While these shortcuts are convenient, it
is recommended that any media that you
wish to use from these folders be copied
into your project folder and imported from
there.
The Palette also allows you to save
your own templates, buttons, text settings,
etc. By selecting the “Create” button at
the bottom of the window, you can save
your custom creation for use later on in
the current or a future project. Unless
you’re creating your own DVD menus
from scratch, the Palette is the place to
begin when designing your DVD.
Templates
Tab
Video
Tab
Styles
Tab
Stills
Tab
Shapes
Tab
Audio
Tab
Menu
Templates
Viewer Window
The viewer window, although
not as complex as the viewer and canvas windows in Final Cut Pro, serves the
same general purpose: allowing you to see
what’s on your track. The viewer window
is a live preview of whatever elements
are on your track, video, audio, subtitles,
etc. The viewer window is automatically
brought to the front (if it is open) whenever a track is opened in the timeline.
Not only does the viewer window show
the video from the track, it also has some
built-in features that assist in the DVD
design process. The first is its Title and
Action Safe Area guides. These guides,
Action
Play
Safe Guide
which are visible in the picture to the
right, provide a final check to ensure that
Title Safe
all elements of the picture are within
Guide
their respective boundaries. These can be
turned on and off using the settings dropdown menu from the viewer window.
Stop
Step
Backward
Step
Forward
Viewer
Settings
19
Menu Editor Window
Menu
Selection
Menu
Window
Settings
Action
Safe Guide
Selected
Button
Status
Title Safe
Guide
Normal
Button
Status
Video
Asset in
Drop Zone
Button
Outlines
Rulers
Empty
Dropzone
Text
Guides
Send to
Back
Send to
Front
Start/Stop
Motion
Menu
Send
Backward
Send
Forward
Create New
Submenu
Create New
Slideshow
Create New
Track
Selected
Button State
Normal
Button State
Show/HideButton
Outlines
Show/Hide
Guides
Activated
Button State
The Menu Editor window is the primary design area for creating the connections of your DVD. In
this window you can add buttons, drop zones, overlays, text, and more. The Menu Editor also contains useful guides and rulers to help organize your DVD Menu creations. Finally, the Menu Editor allows you to see
exactly how your menu will look when it’s in motion on your DVD.
Another useful feature of the Menu Editor is the Drop Palette.
The Drop Palette appears in the Menu Editor when you drag an asset
or project element to it. Once you stop moving the pointer, the Drop
Palette appears, allowing you to choose how to use the asset within
the menu. The contents of the Drop Palette vary, depending on the
asset or element type, how many assets you drag, and whether you
have dragged to an existing button. For example, to the right, a video
asset has been dragged to the Menu Editor, and without depressing the
mouse, the Drop Palette appears. It allows you to set the video as the
background, create a new track and a button that links to it, just create
a new button, create a new drop zone, or if the video has
multiple chapters, create a chapter index and a button that
20
links to it.
Drop Palette
Menu
The following items are listen in counter-clockwise order beginning with Menu Selection.
• Menu Selection: Choose the menu you want to open in the Menu Editor from this pop-up menu. This is an
alternative way to selecting the menu in the Outline or Graphical tab.
• Action Safe/Title Safe Guides: Shaded area around the outside edge of the menu, indicating portions of the
menu that may not be visible on most consumer monitors. The title safe area is most crucial. Nothing that
the viewer must see, such as text or buttons, should be placed outside of the title safe zone. The action safe
zone is for items that you would like the viewer to see, but that do not have to be seen.
• Rulers: Rulers run along the top and left side of the menu editor and assist in alligning items and distributing
them correctly in the menu.
• Send to Back: An arrange button that sends the selected item to the back of all other items on the menu.
• Sent to Front:An arrange button that sends the selected item to the front of all other items on the menu.
• Send Backward: An arrange button that sends the selected item back one step in relation to the other items
on the menu.
• Send Forward: An arrange button that sends the selected item forward one step in relation to the other items
on the menu.
• Create New Submenu: Creates a new menu using the same template as the current menu, and places a button
on the current menu that links to the new one.
• Create New Slideshow: Creates an empty slideshow and places a button on the current menu that links to the
slideshow.
• Create New Track: Creates a new track and places a button on the current menu that links to the track.
• Normal Button State: Shows the normal state of all buttons on the menu.
• Selected Button State: Shows the selected state of any selected buttons on the menu.
• Activated Button State: Shows the activated state of any selected buttons on the menu.
• Show/Hide Button Outlines: Toggles button outlines on/off.
• Show/Hide Guides: Toggles guides on/off.
• Start/Stop Motion Menu: For menus with a motion duration, this button toggles the motion preview on/off.
• Guides: These assist in alligning and distributing items on the Menu Editor.
• Dropzone: An area of the menu that an image or moving video asset can be assigned to.
• Button Outlines: Boxes around each button that display the name of the button and its area on the menu.
• Menu Window Settings: Drop-down menu with controls for the Menu Editor, such as toggling Title/Action
Safe Guides, Displaying a composite view of the menu, just the background, or just the overlays, and other
features.
21
Timeline Window
Track View
Menu
Stream
Height
Playhead
Timecode
Timeline
Zoom
Zoom
Handles
Audio
Stream 1
Subtitle
Stream
Chapter
Marker
Playhead
Video
Stream 1
Audio
Stream 2
The Timeline window works in conjunction with the viewer to allow you to move through the video,
audio, and subtitle streams. As you drag the playhead, the viewer gives you a live preview of what the user will
see when viewing your DVD. The timeline window also works with the Inspector. As you click on the different elements of the timeline, such as a video stream or subtitle, that element will show up in the Inspector,
where you can view its properties and make adjustments.
22
Creating a DVD
The following section will walk you through the process of creating a simple DVD in DVD Studio Pro.
You will need to have an endcoded video ready, complete with audio. For instructions on how to encode video
properly for a DVD, see the Compressor section earlier in this guide. Have these files ready inside your project
folder before you begin.
New Blank
Menu
New Blank
Track
Step 1 - Create a New Project. When you open DVD Studio Pro, a new project is automatically created.
Save the new project by selecting File > Save, and store the file in your project folder.
Step 2 - Import Assets. The first step is to import all the files you intend on using in your DVD. This
includes encoded video and audio files, pictures, music, Photoshop Menus, etc. All of these elements should be
organized in a project folder before you import them. For this simple DVD, we just need an encoded video and
audio asset.
To import an asset, click the Import Asset button on the menu bar at the top of the DVD Studio Pro layout. All assets show up in the Asset Window at the bottom left-hand corner of the screen.
Step 3 - Create a New Track. Let’s assume that our new DVD only needs one video track and a main
menu linking to that track. We first need to create the video track. When you start a new project, DVD Studio
Pro automatically creates a track and a menu. To view the contents of a track, select the track from the graphical or outline view, then select the Track Tab in the Track Timeline Window.
23
To insert video or audio onto a track, drag the video and audio files from the Asset Window onto the
timeline. You can drag both at the same time, and DVD Studio Pro will place the files on the appropriate tracks.
See Figure 6.
Step 4 - Set the Track Properties. The Inspector Window displays item properties and allows you to
define numerous settings for the various elements of your DVD. You need to name the track you just created.
Select the track from the Graphical View. Notice that the track’s properties are now displayed in the Inspector
Window (See Figure 7). Type the name of the track over the default “Track 1” in the Name dialogue box.
Step 5 - Create a Menu. Now that all track elements have been created, it is time to create menus to
link the tracks together. For this DVD, we will only need one menu. Notice that DVD Studio Pro has already
created one blank menu. Select this menu from the Graphical View, and select the Menu tab from the center
window.
DVD Studio Pro comes
pre-loaded with several highquality menu templates. Navigate to these templates in the
Palette window by selecting
Templates > Apple. For this
project, we are interested in
creating a main menu with only
one button that will play the
track. To apple a template to a
menu, drag and drop the template from the Palette Window
to the Menu viewer, or doubleclick on the Template. Let’s
select the template
“Frames Cover.”
24
Step 6 - Design the Menu. Each
template provides several elements, such
as buttons, drop zones (areas where you
can place video to play in the menu) and
text boxes. The Frames Cover menu
contains eight buttons, but you only need
one.
Change the first button to say “Play
Movie”. Click once on “Button One” to
select it, click again to edit the text. Type
in “Play Movie”.
Step 7 - Create a Button. Now you
need to adjust the button’s properties.
Select the button by clicking on it in the
Menu viewer. The button’s properties
are displayed in the Inspector Window.
Change the button name to “Play Movie”
(the button name is not the same as the
text that the button displays. It is important to name the buttons in the Inspector
Window.
Finally, you must set the target of the button, which
is where it will take them when it is selected. Using the
Target drop-down menu in the Inspector Window, select
Tracks and Stories > [Name of Track] > Track.
Step 8 - Edit the Menu. Because we only need one
button, the other seven can be deleted. To delete a button,
click on the button in the Menu viewer, and press Delete
on your keyboard. Do this for the remaining seven buttons. Menu templates usually come with one or more text
boxes. On this menu, change the main title to the name of
your movie, and either edit or delete the subtitle.
You can also set an asset to this drop zone region
in the menu. Simply drag the video clip from the
asset menu (the one with the .m2v extension) and
put it on top of the drop zone area, then release the
mouse. The picture to the right includes the video.
25
Step 9 - Set Connections. In a
DVD, a connection is a link from one
element to another. In this project, we
need two connections. One is the button,
which takes the viewer from the menu to
the track. The other is a connection from
the track to the menu. Once the track is
finished playing, you need to define what
the viewer sees next. Otherwise, the
DVD will simply stop.
Select the track from the Graphical
view. In the End Jump drop-down menu
of the Inspector Window, select Menus >
Menu 1 > [Menu]
Step 10 - Test the Project. During
and following the design of a DVD, it is
crucial that you test your project. Using
the Simulator feature, you can view the
DVD almost exactly as it will play on a
standard DVD player.
Click the Simulator button from
the menu bar. The Simulator window appears and begins to play the first element
of your DVD, which is
the main menu. Using
the navigator buttons on
the left, navigate through
the DVD, ensuring that
everything works as you
intended it to.
Step 11 - Burn the
DVD. Once you have
made sure that everything is working correctly, you are ready to burn
the DVD. Insert a blank
DVD-R 4.7 GB disc into
your computer, then click
the Burn button on the
menu bar.
26
For more information about DVD Studio Pro, the User Guide, which can
be accessed by selecting Help > DVD Studio Pro User Guide, is a great resource. The guide includes sections on all of the topics covered here, as well as many more
easy-to-understand topics, and fuller glossary of DVD terminology.
Graphical View
Below is an example of a graphical outline of a DVD project. This outline, created in DVDSP, gives a
visual overview of the connections between the various assets included in the project.
A
B
F
H
G
E
H
C
H
D
D
E
F
H
D
D
D
E
F
H
H
E
E
F
F
F
A First Play - ITV Logo
F Video Tracks & Stories
B Introduction Movie to Menu
G Special Hidden Features
C Main Menu
H Scripts (Determine Hidden Menu Access)
D Transition Tracks
E Category Menus
27
DVD Authoring Terminology
Assets - Any audio, video, still image files, or LiveType graphics which are a part of your DVD Studio Pro project. Be sure to move these files or copies of these files into your DVD Studio Pro project folder before importing.
Audio_TS Folder - One of two folder required on DVD-Video discs. Reserved for used on DVD-Audio titles,
and is always created but left empty when building projects with DVDSP.
Authorize - The process of creating a DVD. DVD Studio Pro is one program that allows you to author DVDs.
Background Image - All menus and menu buttons are placed over a background image. This background image can be a still picture or a motion video.
Bit Rate - The number of bits per second that makes up a digital video or audio asset. The higher the bit rate,
the better the quality. However, higher bit rates result in larger file sizes, which means you may have to lower
the bit rate if you are trying to fit a lot of content onto one DVD. It’s good practice to not exceed a maximum bit
rate of 9bps.
Build - To compile the contents of a DVD in their completed forms into the two necessary DVD folders (Video_TS & Audio_TS) and save the folders on your hard drive.
Burn - A process that builds the project and immediately formats and writes it to a DVD-R. While this is a simpler method of creating the final disc, DVDSP will have to rebuild the disc whenever you want to burn it again.
Button - Each DVD menu has at least 1 and as many as 36 buttons that the viewer can activate to access areas
within the DVD. You can also place buttons over a video track. You can connect buttons to a wide variety of
project elements, including buttons on other menus, tracks, stories, and slideshows.
Chapter - Specific places in a track where the user can directly connect to. Commonly used to mark scenes in a
longer track, such as a film.
Constant Bit Rate (CBR) Encoding - A video MPEG encoding method that uses the same bit rate for the
entire video file. Its primary advantage is that you can reliably predict the resulting file size. Its disadvantage
is that all video scenes, whether still or with a lot of motion, are treated with the exact same bit rate (creating
larger file sizes).
Dolby Digital - Also called AC-3. Multichannel surround-sound audio encoding, used for cinemas and the
home. Supports one to five full-range channels, plus a Low-Frequency Effects (LFE) channel for carrying low
bass sounds. The five channels are Front Left, Front Center, Front Right, Left Surround, and Right Surround.
Full surround-sound Dolby Digital is referred to as “5.1,” for these five channels plus “.1” for the low-frequency
channel. DVD-Video discs for NTSC are required to provide at least one Dolby Digital or PCM audio track.
Drop Zone - An element you can add to a menu’s background. You can assign a still image or moving video asset to the drop zone. You can size, position, and rotate the drop zone. When you build the DVD, the drop zone is
merged with the background. Drop zones cannot be linked to other elements in the project.
28
DVD@ccess - A feature in DVDSP that allows you to direct the user to a website when viewing the
disc on a computer with internet access.
DVD-ROM - A DVD with files in addition to those included on a standard DVD-Video disc. These files can be
accessed when the disc is played on a computer.
Elements - The parts of a DVD project, such as menus, tracks, stories, and slideshows. Authoring a project
involves creating the elements and connecting them together.
Encoding - The process of converting audio or video to a different format. For DVD projects, this means converting the video to an MPEG-2 file, and the audio to one of several DVD-compliant formats.
End Jump - The element of a DVD (menu, track, story, etc) that a track or menu jumps to when it has finished
playing.
General Purpose Register Memories (GPRMs) – DVD Players contain memory registers that are set aside for
use by DVDs while they play. Used by scripts.
First Play - The first element a viewer sees when they insert the DVD. You can assign any of your project’s elements as the First Play.
Format – The process of writing build files to a DVD.
Layered Menu - A multi-layered menu created in Photoshop that defines the normal, activated, and selected
states of buttons.
Letterbox - A method of displaying 16:9 video on a 4:3 monitor. The entire frame is visible, with black bars
filling the top and bottom of the screen.
Menu - An element in a project that provides buttons for the purpose of connecting to other elements in your
project, such as tracks and slideshows. A menu can have a still or full motion background, and can include audio.
Motion Button - Button shapes that can display a thumbnail image of an assigned asset. The asset can be a still
image or a video clip.
Motion Menu - A menu that contains moving video content, either as the background, a motion button, or a
drop zone.
MPEG - Acronym for Moving Pictures Encoding Group. All DVDs require encoding vdeo and audio to the
MPEG-2 format.
Multiplexing - The process of combining multiple streams, such as video streams, audio streams, and subtitle
streams, into one, single stream. This occurs when you build your DVD and create DVD-compatible streams.
See also Build.
Overlay - A still graphic that provides the highlight information for buttons when creating menus or buttons
over video. Overlays can be simple, using a single color on a white background, or advanced, using up to four
predefined colors. You use color mapping to assign highlght colors to those used in the overlay, setting different
colors for each button state (normal, selected, and activated).
Pan-Scan - A method for displaying 16:9 video on a 4:3 monitor. Content is cropped at each end so
that the frame completely fills the 4:3 viewing area.
29
Scripts - Programs within a DVD that allow the DVD to access specialized information from the DVD Player,
and to perform advanced functions, such as playing all tracks randomly.
Story - An element in a project that is specific to a particular track, allowing you to create a customized version
of that track. For example, you can use stories to create alternate versions of a track that just plays the track’s
highlights.
Target - The element of a DVD (menu, track, story, etc) that a button directs the user to when activated. Buttons can even target other buttons.
Track - The element of a DVDSP project that contains the audio, video, and subtitle streams that provide the
primary content of the DVD. Each project can have a combination of up to 99 tracks, stories, and slideshows.
Variable Bit Rate (VBR) Encoding - A video MPEG encoding method that varies the bit rate based on the
video content.
One-Pass VBR – encodes video with a variable bit rate without first examining the video content. Faster,
lower quality.
Two-Pass VBR – performs a first pass through the video to examine it, then performs a second pass to
encode it. Slower, better quality.
Video_TS Folder – One of two folder required on DVD-Video discs. Contains all of the video, audio, subtitle,
menu, and navigation files that make up your DVD-Video title.
30