LEHRERHANDREICHUNG

EL-9900G
Grafikrechner
LEHRERHANDREICHUNG
Einsatz von Vernier LabPro im interdisziplinären Unterricht
Messdatenerfassung und Auswertung mit den Grafikrechnern
1. Einführung........................................................................................... 2
2. Aufbau des Vernier LabPro mit dem Sharp EL-9900 ................. 3
2.1.
2.2.
2.3.
Benötigte Hardware und Software ....................................................................................3
Installation der Hardware und Software............................................................................3
Sensoren-Programme auf den EL-9900G laden................................................................4
3. Messwerte erfassen und analysieren ........................................... 6
3.1.
3.2.
Messungen durchführen .....................................................................................................6
Messdaten weiterverarbeiten..............................................................................................7
4. Programme für Sensoren erstellen und ändern ......................... 8
4.1.
4.2.
Eigene Programme auf den Grafikrechner übertragen ....................................................8
Erklärung des Sensoren-Programms ..................................................................................9
5. Anhang............................................................................................... 16
5.1.
5.2.
5.3.
5.4.
Technische Einführung in das Vernier LabPro .................................................................16
LabPro Hardware...............................................................................................................16
Anschluss des EL-9900 an das LabPro ............................................................................16
Kommunikation zwischen EL-9900 und LabPro ............................................................17
Befehle ...............................................................................................................................17
Messungen durchführen ..................................................................................................19
Überprüfen der Funktionalität des Vernier LabPro .........................................................21
Programme mit dem CE-LK2 auf den EL-9900G laden .................................................22
Aufbau Website www.sharp-in-der-schule.de................................................................24
Hinweis:
Alle in dieser Handreichung genannten Unternehmens- oder Produktnamen sind Marken und/oder
eingetragene Marken der jeweiligen Rechteinhaber.
Seite 1
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
1. Einführung
Der Sharp Grafikrechner EL-9900G kann jetzt fächerübergreifend auch in den
Naturwissenschaften eingesetzt werden, um Messdaten zu erfassen. Das Erfassungsgerät lässt
sich direkt an die Grafikrechner anschließen und ermöglicht den Schülern, Versuche
anschaulich durchzuführen und praxisnah zu verstehen.
Im Biologieunterricht kann die Lichtintensität, in der Chemie die Temperatur oder im
Physikunterricht die Spannung gemessen werden. Der Schüler muss jetzt nicht mehr die
Messergebnisse an Geräten, wie z.B. dem Voltmeter, ablesen, sondern bekommt die
Ergebnisse nach Beendigung des Versuchs auf seinen Sharp EL-9900 überspielt, um die
Ergebnisse direkt im Grafikrechner zu analysieren.
Der Grafikrechner arbeitet mit dem folgenden Messwertsystem und dessen Sensoren:
Messwertsystem
Unterstützte Sensoren* Artikelnummer der Sensoren
#
Licht
LS-BTA
Vernier LabPro
Bewegung (Ultraschall)
MD-BTD
TMP-BTA
http://www.vernier.com/ Temperatur
Spannung
VP-BTA
downloads/
Mikrofon
MCA-BTA
Doppelstreckenkraft
DFS-BTA
Magnetische Feldstärke
MG-BTA
Geringe Beschleunigung
LGA-BTA
*
#
Stand Mai 2007
Das Vernier CLB bzw. CLB 2 kann nicht verwendet werden, da diese Systeme nur mit den Texas
Instruments
Grafikrechnern
zusammenarbeiten,
die
automatisch
erkannt
werden.
Siehe hierzu auch das LabPro Handbuch und weitere Informationen im Download-Bereich der
englischen Website von Vernier.
Wenn Sie die Unterstützung weiterer Sensoren benötigen, wenden Sie sich bitte an das
Schulrechner-Team: Schule@seeg.sharp-eu.com
Die Programme für die Sensoren können kostenlos von der Sharp Website heruntergeladen
werden:
www.sharp-in-der-schule.de, „Schulinfo / Schulrechner“ auswählen, dann das Feld
„Materialien für Lehrer“ und dort „Messwertsysteme“.
Viel Spaß beim Experimentieren.
Ihr Sharp-Team
Warnhinweise
Bitte beachten Sie bei der Nutzung des Messgerätes von Vernier LabPro die Hinweise in der Bedienungsanleitung.
Bitte informieren Sie sich auch in der Bedienungsanleitung des Sharp EL-9900 über eventuelle Warnhinweise.
Bitte bedienen Sie die Geräte nur wie beschrieben und verwenden Sie nur die vorgeschriebenen Batterien.
Die Spezifikationen und das Design der Geräte kann jederzeit ohne vorherige Ankündigung geändert werden.
Seite 2
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
2. Aufbau des Vernier LabPro mit dem Sharp EL-9900
2.1. Benötigte Hardware und Software
Hardware
Vernier LabPro
Sensoren von Vernier
Im Schulfachhandel erhältlich
Im Schulfachhandel erhältlich
(siehe Liste Seite 2)
Software /
Treiber
Sharp EL-9900
Sharp PC-Link-Programm
EL-GRAFIKLINK99 (deutsch)
oder CE-LK2 (englisch)
(Software und Kabel)
Sensoren-Programme
Im Schulfachhandel erhältlich
Im Schulfachhandel oder über
Sharp direkt erhältlich
Von www.sharp-in-derschule.de / Schulrechner /
Materialien für Lehrer /
Messwertsysteme kostenlos
herunterladen
2.2. Installation der Hardware und Software
Achtung:
• Um eine korrekte Benutzung sicherzustellen, wird die Benutzung des Netzadapters für das
Vernier LabPro empfohlen, Batteriebetrieb kann Probleme verursachen.
• Um den Grafikrechner EL-9900 mit dem LabPro zu verbinden, wird ein Adapterkabel
benötigt, um die serielle Steckverbindung des EL-9900 PC-Link-Kabels mit der seriellen
Schnittstelle des LabPro (IOIO) zu verbinden. Sollte dieser sog. Macintosh-Adapter nicht
dem LabPro-Kit beiliegen, wenden Sie sich bitte an das Sharp Schulteam:
schule@seeg.sharp-eu.com.
• Wird das PC-Link-Kabel des EL-9900 über einen Seriell-USB-Adapter an den Computer
angeschlossen, müssen die Anschlüsse COM1 bis COM4 im Geräte-Manager gewählt
werden. Die PC-Link-Programme EL-GRAFIKLINK99 und CE-LK2 unterstützen nur COM1
bis COM4.
Das LabPro Messgerät mit dem Grafikrechner EL-9900 verbinden
1. Schließen Sie den Macintosh-Adapter aus dem LabPro-Kit (kurzes Kabel „PS/2 auf Seriell“)
an die serielle Schnittstelle des LabPro (IOIO).
2. Verbinden Sie den seriellen Anschluss des Adapters mit dem PC-Link-Kabel des EL-9900.
3. Stecken Sie den freien Anschluss des PC-Link-Kabels fest in die Kommunikationsschnittstelle des Grafikrechners.
Seite 3
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
PC-LinkKabel
LabPro
EL-9900
Adapter
2.3. Sensoren-Programme auf den EL-9900G laden
Um die LabPro Sensoren anzusteuern, müssen zunächst die Programme für die Sensoren auf
dem Grafikrechner EL-9900 installiert werden.
Ö Bitte verwenden Sie für Sensoren nur das Programm, das Sie kostenlos von
unserer Schulwebsite herunterladen können.
Laden Sie die Programme für die Sensoren so herunter:
www.sharp-in-der-schule.de, „Schulinfo / Schulrechner“ auswählen, dann das Feld
„Materialien für Lehrer“ und dort „Messwertsysteme“.
Das Sensorenprogramm „LABPRODEU“ oder die Programme für einzelne Sensoren
herunterladen.
9 Das Sensorenprogramm „LABPRODEU“ (für EL-GRAFIKLINK99, deutsch) oder LABRPO (für
CE-LK2, englisch) unterstützen folgende Sensoren:
¾ Licht LS-BTA
¾ Ultraschallbewegung MD-BTD
¾ Temperatur TMP-BTA
¾ Spannung VP-BTA
¾ Mikrofon MCA-BTA
¾ Doppelstreckenkraft DFS-BTA
¾ Magnetische Feldstärke MG-BTA
¾ Beschleunigung LGA-BTA
9 Installieren Sie die PC-Link-Software EL-GRAFIKLINK99 oder CE-LK2 auf Ihrem Computer.
9 Schließen Sie den Grafikrechner mit dem PC-Link-Kabel an der seriellen Schnittstelle Ihres
Computers an bzw. verwenden Sie zusätzlich den USB-Adapter für den Anschluss an den
PC.
9 Schalten Sie den Grafikrechner ein.
9 Starten Sie die PC-Link-Software. Der angeschlossene Grafikrechner sollte automatisch
erkannt werden. Wenn nicht, überprüfen Sie die Steckverbindungen zwischen EL-9900
und Link-Kabel bzw. dem Computer-Anschluss.
Seite 4
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Die folgenden Erläuterungen beziehen sich auf die Benutzung des PC-Link-Programms ELGRAFIKLINK99.
9 Aktivieren Sie das Menü „Programme“ n.
9 Wählen Sie in der Menüleiste „Datei“ und im Untermenü „Datei importieren“ o aus.
o
n
9 Wählen Sie das Sensoren-Programm „LABPRODEU“ aus bzw. die Programme für die
einzelnen Sensoren und klicken Sie auf ‚Öffnen’, um es/sie in die EL-GRAFIKLINK Software
zu laden.
9 Die ausgewählten Programme werden nun im Fenster unter Programme gelistet. Wählen
Sie ein Programm aus und ziehen es per drag & drop auf die linke Seite in den „ProgrammOrdner“.
Seite 5
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Ö Das Programm wird nun auf den Grafikrechner übertragen.
Ö Sollten Sie die Programme für die einzelnen Sensoren verwenden, wiederholen Sie den
Vorgang, bis Sie alle Sensoren-Programme übertragen haben.
3. Messwerte erfassen und analysieren
3.1. Messungen durchführen
Schalten Sie den Grafikrechner aus und schließen Sie ihn an das Messgerät an, wie im zweiten
Kapitel beschrieben. Verbinden Sie den oder die gewählten Sensor/en mit dem Messgerät.
Hinweis: Sie können mehrere Sensoren gleichzeitig an das LabPro anschließen und damit
Messungen durchführen. Der Bewegungssensor MD-BTD kann nur einzeln benutzt werden.
Schalten Sie nun die Geräte in folgender Reihenfolge ein:
a) Grafikrechner
b) Messgerät LabPro (START-Knopf drücken)
Nun können Sie Ihre Messreihen beginnen.
Taste
„Programm“
und mit ENTER-Taste
des Grafikrechners.
auf dem Grafikrechner drücken, Sensor-Programm auswählen
bestätigen. Folgen Sie den Anweisungen auf dem Bildschirm
Hinweis: Der GTR EL-9900 hängt sich auf, wenn die Verbindung zwischen dem GTR und dem
LabPro nicht korrekt hergestellt wurde. Bitte einen RESET durchführen, wie im
Bedienungshandbuch des GTR beschrieben, und die Kabel korrekt verbinden.
Seite 6
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Die Messergebnisse finden Sie im Grafikrechner in der/den am Ende des Sensor-Programms
angegebenen Liste/Listen. Bitte beachten Sie, dass bei einer sofortigen Messwiederholung die
ersten Ergebnisse überschrieben werden. Wenn Sie mehrere Messungen in Folge machen
wollen, kopieren Sie die Messergebnisse vorher bitte immer in eine andere Liste, damit sie
nicht verloren gehen.
Um die Messtabelle auf dem Grafikrechner anzuzeigen, die
Taste drücken
dann mit ENTER bestätigen.
In L1 werden die Anzahl der Messungen und in L2 die Messergebnisse angezeigt.
und
Die Ergebnisse können Sie mit den verschiedenen Möglichkeiten der Listen-Bearbeitung
auswerten bzw. auf den PC überspielen.
3.2. Messdaten weiterverarbeiten
a) Grafikrechner mit dem PC-Link-Kabel an den Computer anschließen. Den Grafikrechner
anschalten.
b) Das Programm EL-GRAFIKLINK starten und den Programm-Ordner LISTEN auf der linken
Seite öffnen.
c) Ziehen Sie die gewünschte Liste mit Drag&Drop in das Listen-Fenster.
d) Messwerte exportieren: Die Listen-Werte im „Vorschau-Fenster“ kopieren und in ein
anderes Programm einfügen, z.B. MS Excel.
Kopieren (rechte
Maustaste!) und mit
Einfügen z.B. in MS
Excel einfügen.
Seite 7
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Wenn ein Screenshot der Messtabellen im Grafikrechner benötigt wird (z.B. für die
Unterrichtsvorbereitung), gehen Sie folgendermaßen vor:
a) Grafikrechner mit dem PC-Link-Kabel an den Computer anschließen. Den Grafikrechner
anschalten.
b) Das Programm EL-GRAFIKLINK starten und die Funktion „Screenshot“ starten.
c) Den Screenshot über das Menü „Datei“ => „Speichern unter...“ als .BMP exportieren.
4. Programme für Sensoren erstellen und ändern
4.1. Eigene Programme auf den Grafikrechner übertragen
Um ein Sensoren-Programm auf den Grafikrechner zu übertragen, gibt es folgende
Möglichkeiten:
Ö Übertragung Grafikrechner zu Grafikrechner, ohne Computer-Anbindung:
Verbinden Sie zwei Grafikrechner EL-9900 mit dem Verbindungskabel Gerät-Gerät (CE451L). Drücken Sie die Tasten ‚2ndF’ und ‚OPTION’; wählen Sie den Unterpunkt ‚D-Link’
aus. Bei dem empfangenden Taschenrechner wählen Sie Punkt ‚RECEIVE’, beim sendenden
‚SEND’ aus, dann die zu sendende Datei.
Ö Übertragung eines .TXT-Programms mit dem EL-GRAFIKLINK99:
Sie haben Ihr Programm mit dem Editor Ihres PCs erstellt und als ‚.txt’ Datei gespeichert.
Übertragen Sie das Programm auf den Grafikrechner wie in Kapitel 2.3. beschrieben.
Ö Übertragung eines .g4p-Programms mit der Software CE-LK2
Sie haben das Programm mit der Software CE-LK2 geschrieben und als „.g4p“ Datei
gespeichert. Siehe hierzu Kapitel 5.3..
Seite 8
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Die wichtigsten Symbole, wie sie im jeweiligen Editor dargestellt werden:
Darstellung
im Grafikrechner
Darstellung
im Editor
Erläuterung
@=>@
im Grafikrechner durch Drücken auf ‚STO’
__
@-@
negatives Vorzeichen
≠
@not_=@
ungleich
4.2. Erklärung des Sensoren-Programms
Rem FOR LABPRO
0@=>@H
0@=>@P
Rem -- MAIN MENU -Label MAINMENU
ClrT
Print "OPERATION AUSSUCHEN
"
Print " 1: AUSWAHL DER VERSUCHE"
"
Print " 2: DATEN SAMMELN
Print " 3: ENDE
"
Print "NUMMER EINGEBEN:
"
Label MMENU
Key M
If M=1 Goto SETUPMENU
If M=2 Goto COLLECT
If M@not_=@3 Goto MMENU
ClrT
{0}@=>@L5
Send L5,2
Wait 2
Print "ENDE"
End
Rem *******************
Rem * SET UP PROBES *
Rem *******************
Rem -- SELECTION MENU -Label SETUPMENU
0@=>@H
0@=>@P
ClrT
Print "ANZAHL"
Print "VERSUCHE"
Print " 1:EINE
"
Print " 2:ZWEI
"
Print " 3:DREI
"
Programm-Name
Variablen auf 0 setzen
Hauptmenü
Auswahl der Messungsart
Untermenü, in dem die Auswahl verarbeitet und das
entsprechende Programm gestartet wird.
Ende des Programms
Unterprogramm, in dem die Anzahl der parallel
durchgeführten Messungen ausgewählt wird.
Seite 9
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Print "BITTE ZAHL EINGEBEN:
Label HMENU
Key H
If H=3 Goto PSMENU2
If H=2 Goto PSMENU2
If H@not_=@1 Goto HMENU
Aufruf des entsprechenden Unterprogramms.
Rem -- PROBE SELECTION MENU 1 -Label PSMENU1
ClrT
Print "SENSOR AUSWAEHLEN
"
Print " 1:SPANNUNG 7:BEWEGUNG "
Print " 2:LICHT
"
Print " 3:TEMPERATUR
"
Print " 4:MIKROPHON
"
Print " 5:KRAFT
"
Print " 6:MAGNETFELD
"
Print "ZAHL EINGEBEN:
Label PMENU
Key P
If P < 1 Goto PMENU
If P > 7 Goto PMENU
If P=7
Then
0@=>@A
Else
1@=>@A
EndIf
0@=>@B
Gosub SETPROB
Goto MAINMENU
Unterprogramm, in dem festgelegt wird, welche
Einzel-Messungen durchgeführt werden.
Rem -- PROBE SELECTION MENU 2 -Label PSMENU2
H@=>@N
Label QMENU0
ClrT
Print "SENSOR AUSWAEHLEN"
Print " 1:SPANNUNG
"
Print " 2:LICHT
"
Print " 3:TEMPERATUR
"
Print " 4:MIKROPHON
"
Print " 5:KRAFT
"
Print " 6:MAGNETFELD
"
Print "ZAHL EINGEBEN:
Label QMENU
Key Q
If Q < 1 Goto QMENU
If Q > 6 Goto QMENU
N-1@=>@N
H-N@=>@A
N@=>@B
Gosub SETPROB
If N@not_=@0 Goto QMENU0
Goto MAINMENU
Unterprogramm, das festgelegt, welche
Parallelmessungen (2 oder 3) durchgeführt werden sollen.
Seite 10
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Rem --------------------Rem - SETTING OF PROBES Rem --------------------Label SETPROB
ClrT
Print "DEN SENSOR BITTE IN"
If A=3 Goto CH3
If A=2 Goto CH2
If A=1 Goto CH1
Print "SONIC 1.
"
Goto CHEND
Label CH1
Print "CHANNEL 1.
"
Goto CHEND
Label CH2
Print "CHANNEL 2.
"
Goto CHEND
Label CH3
Print "CHANNEL 3.
"
Label CHEND
Print "EINSTECKEN"
Print " "
Print "BITTE EINE TASTE
Print "DRUECKEN.
"
Wait
If B=0
Then
ClrT
Print "DRUECKEN SIE
"
Print "QUICK SETUP
"
Print "DES LABPRO."
Print " "
Print "BITTE EINE TASTE "
Print "DRUECKEN.
"
Wait
EndIf
Return
Rem ******************
Rem * COLLECT DATA *
Rem ******************
Label COLLECT
If H@not_=@0 Goto SETPORT
ClrT
rint "MIT MENUE 1 STARTEN:"
Print "(AUSWAHL DER VERSUCHE)"
Print " "
Wait
Goto MAINMENU
Vorbereitung der Messungen
Am LabPro leuchtet die rote LED, wenn kein Sensor
angeschlossen ist.
Messungen durchführen
Als Erstes muss die Versuchsart ausgewählt werden.
Rem -- INITIALIZATION OF PORT-Label SETPORT
Gosub INITIAL
{102,@-@2}@=>@L1
Wait 1
Send L1,2
Seite 11
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Wait 1
ClrT
Print "BITTE WARTEN...."
If P=7 Goto DIGINI
Rem <ANALOG PORT>
1@=>@A
Gosub CHECK1
If H=1 Goto TRIGER
Wait 1
2@=>@A
Gosub CHECK1
If H=2 Goto TRIGER
Wait 1
3@=>@A
Gosub CHECK1
Goto TRIGER
Rem <SONIC PORT>
Label DIGINI
11@=>@A
Gosub CHECK1
Rem -- TRIGGER SELECTION MENU -Label TRIGER
ClrT
Print "START AUSWAEHLEN"
Print " 1:MANUELL
"
Print " 2:AUTO
"
Print "BITTE ZAHL
"
Print "EINGEBEN:
"
Label TMENU
Key T
If (T@not_=@1) and (T@not_=@2) Goto TMENU
Messung automatisch oder manuell durchführen
Rem -- INPUT SAMPLING SETTING -ClrT
Input "INTERVALLAENGE=",S
Input "ZAHL DER MESSUNGEN=",N
Rem -- START COLLECTION -If T=1
Then
Rem <MANUAL START>
{3,S,N,1}@=>@L1
Gosub CHECK2
Gosub PUSH
Else
Rem <AUTOMATIC START>
{3,S,N,0}@=>@L1
Gosub CHECK2
EndIf
Seite 12
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Rem -- COLLECT DATA -ClrT
Print "MESSE......"
Label LOOP
Gosub JUDGE
If L2(14)@not_=@4 Goto LOOP
Rem -- GET DATA FROM LABPRO -ClrT
Print "WERTE AUSLESEN....."
If P=7 Goto DIGGET
Rem <ANALOG PORT>
{5, 1, 0} @=>@L1
Send L1, 2
Get L2, 2
If H=1 Goto GETTIME
{5, 2, 0} @=>@L1
Send L1, 2
Get L3, 2
If H=2 Goto GETTIME
{5, 3, 0} @=>@L1
Send L1, 2
Get L4, 2
Goto GETTIME
Rem <SONIC PORT>
Label DIGGET
{5, 11, 0} @=>@L1
Send L1, 2
Get L2, 2
Rem <TIME>
Label GETTIME
{5, @-@1, 0} @=>@L1
Send L1, 2
Get L1, 2
ClrT
Print "FERTIG. DIE ERGEBNISSE"
Print "SIND IN L1 BIS L2"
Print "GESPEICHERT.“
Print "VOR NEUER MESSUNG“
Print "ERGEBNIS SICHERN!“
Print "BITTE EINE TASTE “
Print "DRUECKEN."
Wait
Goto MAINMENU
Rem ---------------------------Rem - INITIALIZATION OF LABPRO Rem ---------------------------Label INITIAL
ClrT
Print "BITTE WARTEN...."
Label REINI
{0}@=>@L1
Initialisierung des LabPro
Seite 13
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Send L1,2
Wait 3
Gosub JUDGE
If L2(14)=1 Goto INIEND
Goto REINI
Label INIEND
Return
Rem -----------------------------Rem - CHECK A SETTING OF CHANNEL Rem -----------------------------Label CHECK1
{1,A,1,0,0}@=>@L1
Send L1,2
Wait 2
Label RECHECK1
Gosub JUDGE
If L2(14)=1 Goto CHKEND1
Goto RECHECK1
Label CHKEND1
Return
Rem -------------------------Rem - CHECK A TRIGGER SETTING Rem -------------------------Label CHECK2
ClrT
Print "BITTE WARTEN...."
Send L1,2
1@=>@A
Wait 1
Label RECHECK2
Gosub JUDGE
If L2(14)=2 Goto GOBACK
If A>3 Goto AGAIN
A+1@=>@A
Goto RECHECK2
Label GOBACK
Return
Rem ------------------------Rem - WAIT THE START BUTTON Rem ------------------------Label PUSH
ClrT
Print "START-KNOPF DES
Print "LABPRO DRUECKEN."
Print " "
Label BUTTON
Gosub JUDGE
If L2(14)=2 Goto BUTTON
Return
Rem ----------------------Rem - JUDGE LABPRO STATUS Rem -----------------------
LabPro-Anschluss überprüfen
Prüfen, welche Startart gewählt wurde:
manuell oder automatisch
LabPro starten
LabPro-Status überprüfen
Seite 14
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Label JUDGE
{7}@=>@L2
Send L2,2
Wait 1
Get L2,2
If L2(2)@not_=@0 Goto STRANGE
If L2(3)@not_=@0 Goto LOWBAT
If L2(14) < 32 Goto JUDGE0
L2(14)-32@=>@L2(14)
Label JUDGE0
Rem Print L2(14)
Return
Rem ------------------------Rem - LABPRO IS LOW BATTERY Rem ------------------------Label LOWBAT
ClrT
Print "FEHLER!"
Print " "
Print "DIE BATTERIEN DES "
Print "LABPRO SIND LEER."
End
Rem ---------------------------Rem - LABPRO IS STRANGE STATUS Rem ---------------------------Label STRANGE
0@=>@H
0@=>@P
ClrT
Print "FEHLER!"
Print " "
Print "AUSWAHL DER VERSUCHE"
Print "WIEDERHOLEN“
Print "EINE TASTE DRUECKEN."
Wait
Goto MAINMENU
Rem --------------Rem - DO IT AGAIN Rem --------------Label AGAIN
0@=>@H
0@=>@P
ClrT
Print "FEHLER"
Print " "
Print "BITTE WIEDERHOLEN.."
Print "BITTE NUTZEN SIE DEN"
Print "NETZADAPTER, FALLS"
Print "SIE DIES NICHT TUN."
Print " "
Print "TASTE DRUECKEN."
Wait
Goto MAINMENU
Batterieleistung nicht ausreichend
Fehler am LabPro aufgetreten
Wiederholen der Messungen
Seite 15
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
5. Anhang
5.1. Technische Einführung in das Vernier LabPro
LabPro Hardware
(1) Sensoren-Verbindungs-Anschlüsse:
a. Vier analoge Ausgänge (von CH1 bis CH4)
Zum Anschluss der meisten Sensoren wie für Temperatur, Licht, Spannung usw. Es ist auch möglich,
zwei oder mehr Sensoren zur gleichen Zeit anzuschließen.
b. Zwei Ausgänge für Schallwellen und Digital (von CH 11 bis CH 12)
Zum Anschluss der Bewegungssensoren.
(2) RS232C Ausgang
Ein Ausgang, um den Grafikrechner EL-9900 oder einen PC anzuschließen.
(3) USB Ausgang
Ein Ausgang für den PC-Anschluss.
(4) LED
Bestimmte Zustände vom LabPro werden durch rote, orange-farbige und grüne LEDs angezeigt.
Rot:
Leuchtet auf bei einem Fehler
Orange: Leuchtet auf, wenn die Einstellung beendet ist
Grün:
Leuchtet auf während der Durchführung einer Messung
(5) Funktionstasten
¾ TRANSFER:
Zum Senden von Messwerten (nicht unterstützt bei EL-9900).
¾ QUICK SETUP
Gedrückt halten beim Anschluss eines Sensors. Sensor wird automatisch erkannt. Sollte gedrückt
gehalten werden, wenn ein anderer Sensor verbunden wird oder vor Gebrauch eines Sensors, da so ein
Reset ausgeführt wird.
Leuchtet ein orange-farbiges LED, zeigt dieses an, dass ein Sensor angeschlossen ist, der automatisch
identifiziert werden kann. Leuchtet ein rotes LED, zeigt dieses an, dass der Sensor nicht automatisch
identifiziert werden kann oder dass ein anderer Fehler vorliegt.
¾ START/STOP
Dieser Button startet oder stoppt Messungen.
(6) BEEP
Verschiedene Arten von Pieptönen zeigen unterschiedliche Zustände des LabPro an. Der Sound kann
individuell eingestellt werden. (Die Einstellung wird hier nicht erläutert.)
(7) Stromversorgung
Mit vier AA Batterien oder mit Netzteil. Vorzugsweise sollte ein AC Adapter eingesetzt werden, da er
gleichmäßiger arbeitet als Batterien.
Besonders beim Einsatz eines Bewegungssensors sollte mit AC-Adapter gearbeitet werden.
Anschluss des EL-9900 an das LabPro
Es wird ein PC-LINK-Kabel benötigt (3-Pin- auf 9-Pin-Kabel) und eine 9-Pin Konvertierungsverbindung um EL9900 und LabPro zu verbinden.
Seite 16
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Kommunikation zwischen EL-9900 und LabPro
Die Kommunikation zwischen EL-9900 und LabPro kann nur durch ein Programm ausgeführt werden.
Benutzen Sie den Befehl „send/get“, um Befehle oder in einer Liste gespeicherte Daten zu senden /
empfangen. Die Übertragungsgeschwindigkeit beträgt 38,400 bps.
Befehlsformat:
¾ send Listenname, Optionsnummer
¾ get
Listenname, Optionsnummer
In den Listen L1 bis L6 werden verschiedene Befehle bzw. die Messwerte gespeichert. Optionsnummern
sind abhängig von dem eingesetzten Datensammelgerät:
1: TI-CBL (nicht unterstützt für EL-9900),
2: LabPro
Befehle
Befehle bestehen aus festgesetzten Formaten, abhängig von der Nummer, mit der jeder beginnt. Die
Hauptbefehle werden unten beschrieben. (Hier werden nicht alle Befehle beschrieben, sondern nur die
wichtigsten und diejenigen, die problemlos mit dem EL-9900 benutzt werden können):
Command {0} Um Reset durchzuführen. Außer des FlashSpeichers werden alle Speicher gelöscht.
Command {1} Um eine Einstellung eines Sensors vorzunehmen.
{1, 0}
Einstellung für alle Kanäle löschen.
{1, channel, 0} Einen bestimmten Kanal abschalten. [Channel] 1, 2, 3, 4, 11 oder 12
{1, channel, type of a sensor, 0, with or without conversion formula}
Um Einstellungen an Sensoren mit analogen Verbindungen vorzunehmen.
Wenn der Sensor automatisch erkannt wird, ist das Setzen von ON und weiterer
Parameter nicht nötig.
[Channel] 1, 2, 3 oder 4
[Type of sensor]
1: 0-5V sensor (AutoID: Automatische Identifikation)
2: + oder - 10V
3: + oder - 10A
4: Widerstand
10: TI stainless temperature sensor (Celsius)
11: TI stainless temperature sensor (Fahrenheit)
12: TI illuminance sensor
14: 0-5V [With or without conversion formula] (Nicht nötig, wenn automatisch
identifiziert)
0: Ohne
1: Mit (Formel muss definiert werden mit dem Befehl {4})
{1, 11, measuring unit, 0, with or without conversion formula}
Wird benötigt, wenn ein Bewegungssensor mit einem Schallwellenkanal verbunden ist.
Seite 17
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Command {3} Um Parameter für Messungen einzustellen.
{3, sample time, number of measurement times, type of trigger}
[Sample time]
0<S<=16,000
[Number of measurement times] 1<=N<=12,287
[Type of trigger]
0: Messung wird sofort nach Erhalt des Befehls gestartet.
1: Manuell (Messung wird gestartet wenn der START -Taste gedrückt wird.)
Command {4} Um Koeffizienten in einer Formel für einen vom Sensor gemessenen Wert festzulegen, der
mit einem bestimmten Kanal verbunden ist und nicht automatisch identifiziert werden kann.
Energieumsetzung, Protokoll u.a. können auch als Typ der Konvertierungsformel bestimmt werden.
{4, channel. 1, number of coefficients, coefficient….}
Um den Koeffizienten festzulegen in k0+k1*X+k2*X^2+…..+kn*X^n.
[Channel]
1, 2, 3 or 4
[Number of coefficients]
Von 1 bis 9
[Coefficient]
Eingabe von vorgegebenen Koeffizientenzahlen, ohne
Beschränkungen
{4, channel, type of formula, k0, k1}
[Channel]
1, 2, 3 or 4
[Type of formula]
Von 3 bis 12
3: Power transformation
k0*X^k1
5: log
k0+k1* log(X)
etc.
Command {5} Um die Daten, die LabPro zum EL-9900 überträgt, zwischen Messergebnis und Messzeit
umzustellen.
{5, channel, 0}
[Channel]
-1: Messzeit
1, 2, 3 oder 4: Messergebnis von jedem Kanal
Command {7} Um 17 Werte zu prüfen, die den Zustand von LabPro anzeigen. LabPro gibt 17 Werte nach
Erhalt des Befehls zurück. Die wichtigsten Werte sind:
Der dritte Wert: Batteriezustand (0: OK, andere als 0: niedrig)
Der zehnte Wert: Anzahl der Muster
Der fünfzehnte Wert: Erste gemessene Daten
Der sechzehnte Wert: Letzte gemessene Daten
Command {102} Stromversorgungskontrolle der Ausgänge der Sensoranschlüsse. Es ist ratsam diese
einzustellen, wenn LabPro mit Batterie läuft.
{102, power setting}
[Power setting] -1: Immer ON. Wird jedoch automatisch gespeichert, wenn LabPro mit
Batterien läuft.
0: Stromsparmodus (Voreinstellung)
1 - 999: Stromversorgung, bevor die Messungen starten und erwartet
spezifizierte Sekundendauer.
Seite 18
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Messungen durchführen
5a. Messungen manuell starten durch Knopfdruck
(1) Initialisieren mit einem Befehl {0}. Alle Daten, die gespeichert sind, löschen.
Beispiel:
{0}=>(STO)L1
Send L1,2
(2) Stromversorgung einstellen {102}.
Nicht nötig, wenn mit Netzteil gearbeitet wird. Nötig nur bei Batteriebetrieb.
Beispiel:
{102, 1}=>(STO) L1
Send L1,2
(3) Befehl {1} eingeben, um Sensor zu identifizieren.
Die Parametereinstellungen sind unterschiedlich abhängig vom Sensor, können aber auch die
gleichen für Sensoren sein, die mit AutoID identifiziert wurden.
Beispiel:
AutoID (Temperatur-, TI-Licht-, Spannungssensor usw.){1,1,1,0,0}=>(STO)
L1Send L1,2
Motion sensor
{1,11,2,0,0}=>(STO)L1
Send L1,2
(4) Messinterval bestimmen mit dem Befehl {3}.
Beispiel:
10-malige Messung in 0,5-Sekundenintervall:
{3, 0.5, 10, 0}=>(STO)L1
Send L1, 2
(5) START -Knopf des LabPro drücken.
Sicherstellen, dass das orange-farbige LED leuchtet. Dann START -Knopf drücken.
(6) Warten, bis Messungen erfolgt sind.
Das grüne LED blinkt, die Messungen beginnen.
Das orange-farbige LED leuchtet für einen Moment auf, wenn die Messungen abgeschlossen sind.
ENTER -Taste des EL-9900 drücken, wenn sicher ist, dass das orange-farbige LED aufleuchtet.
Beispiel :
Wait
(7) Erhalt von Messergebnissen.
LabPro veranlassen, Messergebnisse an EL-9900 zu schicken und in einer Liste zu speichern:
Beipiel :
Get L2, 2
(8) Einstellung, um die Messzeit zu erhalten.
Änderung von Daten, die LabPro zur Zeitmessung sendet.
Beispiel :
{5, -1, 0}=>(STO)L1
Send L1, 2
(9) Empfangen der Messzeit.
Beispiel :
Get L1, 2
5b. Messungen automatisch starten
(1) Mit dem Befehl {0} initialisieren.
Alle gespeicherten Daten löschen.
Beispiel:
{0}=>(STO)L1
Send L1,2
(2) Einstellen der Stromversorgung mit dem Befehl {102}.
Nicht nötig, wenn der AC-Adapter benutzt wird, jedoch erforderlich bei Batteriegebrauch.
Beispiel:
{102, 1}=>(STO)L1
Send L1,2
(3) Befehl {1} eingeben, um einen Sensor zu identifizieren.
Parameter des Sensors eingeben.
Es können jedoch die gleichen sein für Sensoren, die mit AutoID identifiziert werden.
Beispiel:
AutoID (Temperatursensor, TI-Lichtsensor, Spannungssensor usw.)
Seite 19
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
{1,1,1,0,0}=>(STO)L1
Send L1,2
Motion Sensor
{1,11,2,0,0}=>(STO)L1
Send L1,2
(4) Bestimmung des Messintervalls durch den Befehl {3}.
Beispiel:
10-malige Messung in 0,5 Sekundenintervall
{3, 0.5, 10, 1}=>(STO)L1
Send L1, 2
(5) Warten, bis die Messung abgeschlossen ist.
Das grüne LED blinkt, wenn die Messung beginnt.
Das orange-farbige LED leuchtet für einen Moment auf, wenn die Messung abgeschlossen ist.
Beispiel (a):
Dauer einer Messzeit abwarten.
(S: Messinterval, N: Anzahl der Messzeiten)
int (S×N)+1 =>A
While A≠0
Wait 1
A-A => A
Beispiel (b):
WEnd
Abwarten, bis die beabsichtigte Anzahl der Messzeiten erfolgt ist.
Label LOOP
{7}=>L2
Send L2, 2
Wait 1
Get L3, 2
If L3(16)=0 Goto LOOP
L3(16)-L3(15)+1=>A
If A≠L3(10) Goto LOOP
1 Empfangen gemessener Ergebnisse. LabPro veranlassen, Messergebnisse an EL-9900 zu senden und in
einer Liste zu speichern:
Beispiel :
Get L2, 2
2 Einstellung, um die Messzeit zu erhalten. Änderung von Daten, die LabPro zur Zeitmessung sendet.
Beispiel:
{5, -1, 0}=>(STO)L1
Send L1, 2
3 Empfangen der Messzeit.
Beispiel:
Get L1, 2
Seite 20
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
5.2. Überprüfen der Funktionalität des Vernier LabPro
1. Das Programm LabProTest von Sharp Website auf den
PC herunter laden.
2. Vernier LabPro an den PC anschließen.
3. Den Start-Knopf [START/STOP] am LabPro drücken,
bis alle LEDs (rot/gelb/grün) leuchten. Sollten nicht alle
LEDs leuchten, ist die Spannung zu gering oder das
LabPro defekt.
4. Das Programm "LabProTest.exe" auf dem PC
starten.
Voreingestellt ist COM1 als Schnittstelle. Wenn das
LabPro an einer anderen Schnittstelle
angeschlossen ist, entsprechende COMSchnittstelle im Testprogramm einstellen.
5. “Test Start” drücken.
6. Die Versionsnummer des LabPro wird angezeigt.
Sollte die Versionsnummer nicht angezeigt werden, überprüfen Sie die Kabelverbindung
und die Auswahl der Schnittstelle.
Wird die Versionsnummer immer noch nicht angezeigt, ist das LabPro wahrscheinlich
defekt.
Seite 21
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
5.3. Programme mit dem CE-LK2 auf den EL-9900G laden
Alternativ zum PC-Link-Programm EL-GRAFIKLINK99 gibt es das Programm Sharp CELK2. Während Programme für EL-GRAFIKLINK99 im „.TXT“ Format vorliegen müssen,
erstellt CE-LK2 diese im Format „.G4P“.
Auch mit dieser Software können Sensoren-Programme erstellt und auf den EL-9900G
überspielt werden. Dafür gibt es drei Möglichkeiten:
1.
2.
3.
Laden Sie das entsprechende Sensoren-Programm von der Sharp Website
www.sharp.de / Produkte / Schulrechner / EL-9900 / Downloads herunter.
Schreiben Sie das Programm im Editor des CE-LK2 und speichern es im
.g4p Format.
Wandeln Sie mit Hilfe des CE-LK2 ein Programm aus dem .txt in das .g4p
Format um.
Zum Erstellen eines Programms öffnen Sie das CE-LK2 und klicken im File-Menü auf
„New“. Vergeben Sie einen Programmnamen und schreiben Sie anschließend das
Programm. Zum Speichern klicken Sie im File-Menü auf „Save As…“ und speichern es
wie gewohnt im Ordner Ihrer Wahl.
Um ein Programm aus dem .txt in das .g4p Format zu konvertieren, laden Sie zunächst
das Programm. Dann klicken Sie im File-Menü auf „Save as…“. Wählen Sie hierfür bitte
als Dateityp .g4p.
Seite 22
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Überspielen der Programme vom PC auf den EL-9900G:
•
•
•
•
•
•
Installieren Sie die Software
des CE-LK2 und starten Sie
diese.
Verbinden Sie den EL9900G mit dem PC.
Schalten Sie den EL-9900G
ein.
Klicken Sie im Link-Menü
auf „Send“.
Wählen Sie im sich
öffnenden Fenster das
Programm aus und klicken
auf Select.n
Wenn Sie alle Programme
ausgewählt haben, die
überspielt werden sollen,
klicken Sie auf OK. o
o
n
Überspielen der Programme vom EL-9900G auf den PC:
•
•
•
•
•
Starten Sie die Software und starten Sie den EL-9900G.
Klicken Sie im Link-Menü auf „Receive“.
Wählen Sie im sich öffnenden Fenster das Programm aus und klicken auf
„Select“. n
Wenn Sie alle Programme ausgewählt haben, die überspielt werden sollen,
klicken Sie auf OK. o
Das Programm wird in dem Ordner gespeichert, in dem Sie zuletzt Programme
gespeichert haben.
o
n
Seite 23
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
5.4. Aufbau Website www.sharp-in-der-schule.de
Auf der Sharp Website www.sharp-in-der-schule.de finden Sie alle Informationen und
Programme zum Download, um mit dem Vernier LabPro und dem Grafikrechner EL9900 zu arbeiten.
1. Öffnen Sie die Schulwebsite und wählen Sie „Schul-Infos / Schulrechner“.
n
2. Wählen Sie „Materialien für Lehrer“.
o
Seite 24
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
3. Öffnen Sie „Messwertsysteme“.
Z
4. Im Bereich „Messwertsysteme“ finden Sie Anleitungen und Treiber für die
Sensoren.
Seite 25
© Sharp Electronics (Europe) GmbH
Messdatenerfassung und Auswertung mit den Grafikrechnern
Notizen
Seite 26
© Sharp Electronics (Europe) GmbH
Messwertsysteme01
Sharp Electronics (Europe) GmbH
Sonninstraße 3, 20097 Hamburg
Tel.: +49 (0)40/23 76-0, Fax: -13 23
www.sharp.de
Die Anfertigung einer notwendigen Anzahl von Fotokopien für
den Einsatz in einer Klasse, einer Lehrerfortbildung oder einem
Seminar ist gestattet. Jede Verwertung in anderen als den genannten
oder den gesetzlich zulässigen Fällen ist ohne schriftliche
Zustimmung von Sharp nicht zulässig.
Bestellnummer: MESSWERTSYSTEME01
Weitere Informationen erhalten Sie auf: www.sharp-in-der-schule.de