Octatrack
Sample Manager
Table of Contents
1
Overview ..................................................................................... 4
1.1
1.2
1.3
1.4
1.5
2
Orders, Feature Requests and General .....................................................4
Disclaimer.............................................................................................4
Legal....................................................................................................4
Typographical Conventions .....................................................................5
Frequently Asked Questions ....................................................................6
Octatrack Settings ....................................................................... 8
2.1
2.2
3
Octatrack – Create an Empty Project........................................................8
Octatrack – Using the Empty Project ........................................................8
Main Window ............................................................................... 9
3.1
3.2
3.3
3.4
3.5
4
Project Browser .....................................................................................9
Project Manager ....................................................................................9
Audio Pool ............................................................................................9
Project Settings .....................................................................................9
Main Menu Options .............................................................................. 10
Project Browser ......................................................................... 11
4.1
4.2
5
Quick Access Options ........................................................................... 11
Error Checking .................................................................................... 12
Project Manager ........................................................................ 13
5.1
5.2
5.3
5.4
5.5
5.6
5.7
5.8
5.9
5.10
5.11
5.12
5.13
5.14
5.15
5.16
5.17
5.18
6
Overview ............................................................................................ 14
Import................................................................................................ 14
Rename File ........................................................................................ 15
Edit Mode ........................................................................................... 15
Assign… Flex to Static .......................................................................... 15
Assign… Static to Flex .......................................................................... 15
Assign… Flex then Static ....................................................................... 15
Assign… Static then Flex ....................................................................... 15
Space Time Continuum......................................................................... 16
Auto Play ............................................................................................ 16
Loop Mode .......................................................................................... 16
Cut .................................................................................................... 16
Copy .................................................................................................. 16
Paste.................................................................................................. 16
Delete ................................................................................................ 17
Refresh .............................................................................................. 17
Close Project ....................................................................................... 17
Save Project........................................................................................ 17
Audio Pool ................................................................................. 18
6.1
6.2
6.3
6.4
6.5
6.6
6.7
6.8
6.9
6.10
6.11
7
Add to Project ..................................................................................... 19
Import to Audio Pool ............................................................................ 19
Play Audio File ..................................................................................... 19
Copy .................................................................................................. 19
Paste.................................................................................................. 19
Rename Audio File ............................................................................... 20
Edit Mode ........................................................................................... 20
Auto Play ............................................................................................ 20
Loop Mode .......................................................................................... 20
Refresh Audio Pool ............................................................................... 21
Delete From Audio Pool ........................................................................ 21
Project Settings ......................................................................... 22
2
Octatrack Sample Manager
7.1
7.2
7.3
7.4
7.5
7.6
7.7
7.8
7.9
7.10
Project ............................................................................................... 22
Mixer.................................................................................................. 23
Midi Settings ....................................................................................... 23
Midi Channels...................................................................................... 24
Input.................................................................................................. 24
Sequencer .......................................................................................... 24
Midi Sequencer.................................................................................... 25
Memory .............................................................................................. 25
Metronome ......................................................................................... 25
State Data .......................................................................................... 26
Octatrack Sample Manager
3
1
Overview
The Octatrack Sample Manager is a standalone program for managing and manipulating
Elektron Octatrack Sets, Projects and Samples.
1.1
Orders, Feature Requests and General
Either email at Octatrack@Outlook.com or find me at http://www.elektronauts.com
1.2
Disclaimer
Whilst every care has been taken in the development of the Octatrack Sample Manager, I take
no responsibility for what you do with it, or the effects it has on your Octatrack, samples,
songs, projects, sets, or whatever else.
This includes totally fucking that awesome track you’ve been working on for the last two years,
destroying your hopes and dreams of playing main stage at <insert major festival here>,
totally bricking your Octatrack, or making you impotent.
1.3
Legal
The Octatrack Sample Manager is used in conjunction with third party hardware and
companion products, such as operating systems, and of course the Elektron Octatrack.
All other copyrights and trademarks are the property of their respective owners.
The Octatrack Sample Manager is distributed in the hope that it will be useful, but without any
warranty. It is provided "as is" without warranty of any kind, either expressed or implied,
including, but not limited to, the implied warranties of merchantability and fitness for a
particular purpose. The entire risk as to the quality and performance of the Octatrack Sample
Manager is with you.
Should the Octatrack Sample Manager prove defective, you assume the cost of all necessary
servicing, repair or correction to your Octatrack, computer, music, samples, anything and
everything else.
In no event unless required by applicable law the author will be liable to you for damages,
including any general, special, incidental or consequential damages arising out of the use or
inability to use the Octatrack Sample Manager (including but not limited to loss of data or data
being rendered inaccurate or losses sustained by you or third parties or a failure of the
program to operate with any other programs), even if the author has been advised of the
possibility of such damages.
All rights reserved.
The copyright of this document and the computer software described herein and provided
herewith are the property of Rusty O’Hara. No part of this publication or the computer software
may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into
any human or computer language, in any form or by any means or otherwise used without the
express written permission of Rusty O’Hara.
4
Octatrack Sample Manager
1.4
Typographical Conventions
To facilitate end user use of the Octatrack Sample Manager, and this User Guide, the following
typographical conventions have been utilised in this document:
Formatting Convention
Description
[WINDOW]
A Window is written in upper case, bold style, enclosed in
square brackets.
For instance, the ‘Audio Pool’ window is written as: [AUDIO
POOL]
Menu Option
A Menu Option is written in bold style.
For instance, the ‘Add to Project’ menu option in the Audio
Pool is written as: Add to Project
<User Action>
A User Action is written in italicised style, enclosed in greater
than / less than signs.
For instance, the user action of left clicking is written as
<Left-Click>
This symbol indicates information that you need to pay
attention to.
Octatrack Sample Manager
5
1.5
Frequently Asked Questions
Q: Supported Octatrack Versions?
A: OS 1.25 and OS 1.25B
Q: Supported Operating Systems?
A: Windows 7. Got something else? Try it and see.
Q: Will there be a Mac version?
A: Maybe. I am going to look at either porting over the code, or collaborating with a Mac coder
to build a Mac version. At present, and until release, the answer is no.
Q: Will there be a Linux / Unix / Raspberry Pi / Some other niche OS version?
A: No.
Q: Will the Octatrack Sample Manager be supported / updated / whatever…
A: Depends on how I feel.
Frankly a lot boils down to the changes that Elektron will make in the future to the Octatrack,
whether they actually provide any assistance whatsoever to me, or provide any of the file
formats, how many people buy this (I have cats to feed) or if I even own an Octatrack in the
future.
The intention is to build a v2 with full control over Patterns, Banks and Sample Assignments,
but I need the file formats from Elektron to be able to do that.
In saying that, the road to hell is paved with good intentions, so for the time being, it is what it
is and don’t expect any future updates or additional functionality.
Q: US$xx is too much for this!
A: I don’t give a flying fuck. You’re more then welcome to go build your own, or live without.
Q: Why isn’t it free?
Because my time, expertise and pain of having to figure it all out isn’t. And neither is yours, or
you’d have no need for this.
I don’t expect your time, skills sets and expertise for free, so why would you expect mine?
Q: Can I have a free version?
A: Is your name Daren Ager or Tyrone? Were you a Beta tester? Have you got a really good
reason why you should have a free version? No? Then no, you can’t.
Q: But I can’t afford it!
Yet you can afford an Octatrack?
Q: So, we figured that part out, how do I buy it?
A: Email me at Octatrack@Outlook.com and I’ll provide details.
6
Octatrack Sample Manager
Q: Languages other then English?
A: One day, but a low priority. Multi-lingual support is built in, and some nice people have
offered to translate into French, German, Spanish, Swedish and Japanese.
Q: I don’t understand what a Sample / Project / Set is...
A: RTFM. Seriously, it will save you heartache if you understand the way the internal structure
of the Octatrack works.
Q: Will audio editing of samples be available?
A: No. I have no intention of coding an audio editor, or licensing a third party editor to include
with the sample manager. Frankly everyone already has a good audio editor or DAW (or can
get a free one) and the ROI doesn’t justify the effort.
Q: Does the Octatrack sample Manager allow Pattern and/or Bank management?
A: No. The Octatrack Sample Manager does not contain any functionality for managing
Patterns, Banks, Scenes or the allocation of samples within patterns.
Primarily because the file formats are encrypted, Elektron will not provide any information
about them, and I have a lot better things to do with my spare time then decrypt and reverse
engineer file formats.
I suggest contacting these people and asking them for the file formats: info@elektron.se
Q: Can I directly access the Octatrack from the Sample Manager?
A: Yes. But I really don’t recommend it, and read Section 2 Octatrack Settings
My advice is to take a backup of ALL your data, Projects, Sets and Samples, before you start
using the Octatrack Sample Manager. And then work directly on your computer instead.
Whilst it “should” all work, I bear no responsibility for anything that happens to your songs,
live sets or Octatrack. Better to backup first, then be sorry later.
Q: I got an error message, had a bug, or something bad happened.
A: Screenshot it. Document what you were doing, and send it to me. If you can replicate it,
even better, as this makes finding and fixing the bug a lot easier.
Basic rule is: No screenshot, no documentation? No bug fixing.
Q: I have a feature request / I want to be able to do XYZ…
A: Email me or send me an message at Elektronauts. I’ll see what I can do, but keep it
realistic.
Q: My Octatrack Died! / My Song is Fucked! / My Live Set is Fucked!
A: Not
my problem.
Dead Octatrack? Contact Elektron.
Fucked Song? I’m sorry.
Fucked Live Set? I’m really sorry.
If you’re having Octatrack problems, I feel bad for you son, I got ninety nine problems but
yours ain’t one.
Octatrack Sample Manager
7
2 Octatrack Settings
When working with the Octatrack Sample Manager and your Octatrack, certain steps need to
be taken on the Octatrack to be able to modify the sample assignments.
Essentially the Octatrack stores information relating to the current Project in flash memory and
this is retained even when the Octatrack is powered off.
When loading or reloading a Project, the Octatrack checks against the information stored in
memory first before accessing the Compact Flash card.
In practice, what this means is that it is not possible to make any modifications against the
currently active Project of the Octatrack.
It is therefore required that when working with the Octatrack Sample Manager, the Octatrack
is currently referring to a different Project.
I recommend creating a “Dummy” Project whilst doing stuff.
2.1
Octatrack – Create an Empty Project
Load your set as per normal, then press the [Function] plus [Mixer] buttons to show the
“Set Menu”.
Scroll to the [Project] option on the left hand side, then to the [Project – Change] option
on the right hand side using the arrow keys and press the [Enter / Yes] button.
The “Choose Project” window will be displayed.
Scroll to the [<CREATE EMPTY PROJECT>] option using the arrow keys and press the
[Enter / Yes] button.
Use the [Function] and [Arrow] buttons and give it an obvious name, e.g. “Empty” or
“Dummy”; though that’s not much good if the project is a Portishead remix…
2.2
Octatrack – Using the Empty Project
At all points in time where you are transferring data back and forth from the computer, and
the Octatrack Sample Manager you need to refer back to either your “Dummy” project, or
another project then the one your are updating.
You will not see any changes made to the Project or the associated Samples and assignments
if you try and update the current project of the Octatrack.
Every time before you start using the Octatrack Sample Manager, switch over to your
“Dummy” project by pressing the [Function] plus [Mixer] buttons to show the “Set Menu”.
Scroll to the [Project] option on the left hand side, then to the [Project – Change] option
on the right hand side using the arrow keys and press the [Enter / Yes] button, then select
your “Dummy” Project.
Return to the “Set Menu”, then scroll to the [Project] option on the left hand side, then to the
[Project – Sync to Card] option on the right hand side using the arrow keys and press the
[Enter / Yes] button. After the Octatrack has finished, you can eject the card and transfer
over to your computer and the Octatrack Sample Manager.
8
Octatrack Sample Manager
3 Main Window
The Main Window of the Octatrack Sample Manager is divided into four separate windows as
follows:
Project Browser
Project Manager
Audio Pool
Project Settings
Project Browser
Project Manager
3.1
Audio Pool
Project Settings
Project Browser
The [PROJECT BROWSER] window allows the ability to navigate to a folder containing an
Octatrack Set, and therefore Projects contained within the Set.
3.2
Project Manager
The [PROJECT MANAGER] window is the main window for managing samples associated with
the Octatrack Project.
3.3
Audio Pool
The [AUDIO POOL] windows contains a list of all the samples currently contained within
the ..\Audio\ folder of the current Project selected in the [PROJECT MANAGER] window.
3.4
Project Settings
The [PROJECT SETTINGS] window contains the various settings that are available on the
Project level.
Octatrack Sample Manager
9
3.5
Main Menu Options
The following options are available from the drop-down menu bar.
Menu
Comment
File
Exit
Exits the Octatrack Sample Manager
Options
Audio Options\Project Auto Play
Sets the Project Auto Play mode on/off
Audio Options\Project Loop Mode
Sets the Project Loop mode on/off
Audio Options\Audio Pool Auto Play
Sets the Audio Pool Auto Play mode on/off
Audio Options\Audio Pool Loop Mode
Sets the Audio Pool Loop mode on/off
Edit Mode\Project
Sets the Project Edit mode on/off
Edit Mode\Audio Pool
Sets the Audio Pool Edit mode on/off
Language\English
Sets the Language to English.
Language\Français
Comment définir la langue Français.
Language\Deutsch
Legt die Sprache auf Deutsch.
Language\Español
Establece el idioma en Español.
Language\Svenska
Sets the Language to Swedish.
Language\Japanese
言語日本語に設定します。
Help
View Help
Displays Help for the Octatrack Sample Manager
About
Displays the ‘About’ splash screen.
10
Octatrack Sample Manager
4 Project Browser
The [PROJECT BROWSER] window allows the ability to either browse for an Octatrack Set
Folder, or select a Project from the currently selected Set.
It additionally provides for a number of Quick Access Options and Error Checking.
<Left-Clicking> on the Folder icon will open a standard Windows Folder Browser. Navigate to
the location on your computer where the Octatrack SET is located, and click Open.
The drop-down list to the right will be populated with the available Projects contained within
the Octatrack Set.
Selecting a Project from the drop-down list will perform one of two actions:
Open a new Project tab in the [PROJECT MANAGER] window.
or
Navigate to the selected Project tab in the [PROJECT MANAGER] window.
Note: You can only select one Octatrack Set at a time, but multiple Projects from
multiple Sets can be worked on concurrently.
4.1
Quick Access Options
Additionally contained within the [PROJECT BROWSER] window are six checkboxes, three for
Projects, and three for the Audio Pool.
These check boxes provide quick access options, allowing the ability to easily toggle the
various modes of the Octatrack Sample Manager as per the below table.
Checkbox
Description
Refer
Project Auto Play
Toggles the Project Auto Play status on/off.
Project Loop Mode
Toggles the Project Loop Mode status on/off.
Project Edit Mode
Toggles the Project Edit Mode status on/off.
Audio Pool Auto Play
Toggles the Audio Pool Auto Play status on/off.
Audio Pool Loop Mode
Toggles the Audio Pool Loop Mode status on/off.
Audio Pool Edit Mode
Toggles the Audio Pool Edit Mode status on/off.
Note: Refer to sections later in this document for a description of the function of
each of the Quick Access Options.
Octatrack Sample Manager
11
4.2
Error Checking
Additionally the [PROJECT BROWSER] window provides for error checking against the
currently selected set in the [PROJECT MANAGER] window, via an automated process.
Errors occur in one of two scenarios as per the below table.
Code
Description
Colour
Error
A sample is assigned to an illegal sample slot, usually 999
Red
Duplicate
Two or more samples share the same sample slot assignment.
Yellow
If errors exist in the current set, the number and type of errors will be displayed to the right
hand side of the Project Options area in the [PROJECT BROWSER] window, as show below.
Additionally, errors in the set are highlighted within the [PROJECT MANAGER] window.
Errors, such as where a sample has been assigned to an illegal slot, e.g. FLEX999, are
highlighted in Red.
Duplicates, where two or more samples have been assigned to the same sample slot, e.g.
FLEX003 are highlighted in Yellow.
For example, the below image shows an example of one Error, highlighted in Red, and two
Duplicates, highlighted in Yellow.
The Error row is due to the sample being assigned to sample slot FLEX999 which is an illegal
value, and should be changed.
The Duplicate rows are due to both samples being assigned to the same sample slot of
FLEX003, one of these should be changed to a different sample slot.
Note: It is not possible to save the set whilst either Errors or Duplicates exist.
12
Octatrack Sample Manager
5 Project Manager
The [PROJECT MANAGER] window allows the ability to either browse for an Octatrack Set
Folder, or select a Project from the currently selected Set.
The [PROJECT MANAGER] window displays multiple projects concurrently as different tabs,
and the name of the Project is displayed in the tab.
For example, the below image shows the [PROJECT MANAGER] window with two Projects
currently open.
To close a Project, simply press the X button on the Project tab.
Warning: Closing the tab does not save the Project. Please refer below for
instructions on how to save the Project.
<Left-Clicking> on the [PROJECT MANAGER] will perform various actions depending on the
options that have been configured. (Refer below)
<Left-Clicking> and <Dragging> whilst keeping the left mouse button held down will allow you
to drag a sample to another location in the [PROJECT MANAGER] window.
<Right-Clicking> on the [PROJECT MANAGER] will display the below context menu, the
details of which are outlined below.
Octatrack Sample Manager
13
5.1
Overview
Currently active Projects are displayed in the [PROJECT MANAGER] window in a columnar
view showing the samples associated with the Project, and in the [PROJECT SETTINGS]
window showing the settings of the Project.
The columns in the [PROJECT MANAGER] window are as follows:
Column
Description
Valid Values
Code
Internal system code used by the Octatrack Sample Manager.
Concatenation of Type and Slot.
Type
Type of Sample Slot
Flex / Static
Slot
Sample Slot number that the sample is
assigned to.
001 to 128
Sample Name
File Path and Name of the audio sample in
the Audio Pool. Read Note Below
Free text
characters
Length
Length of the sample as defined by the Octatrack.
TS Mode
The time stretch mode of the sample as
defined by the Octatrack.
Off / Auto / Normal / Beat
Loop
The Loop mode of the sample as defined
by the Octatrack.
Off / Auto / PIPO / On
Gain
The Audio Gain of the sample as defined by
the Octatrack.
0 to 3072
Quantise
The Trig Quantization of the sample as
defined by the Octatrack.
-1 to 127 (-1 is Off)
999 for unassigned samples
excluding
special
The Sample Name includes the full path of the sample within the Audio Pool of the
Set that the Project belongs to.
For example, a sample of “Kick.wav” that is contained in the “MyKicks” folder of the
Audio Pool would be dispalyed as: MyKicks/Kick
5.2
Import
Selecting Import will display a standard Windows file browser window, allowing the ability to
select one or more wav files.
By default, the browser will view the …\Audio\ folder of the current Project, however files from
any folder may be selected.
After selection, the selected wav files will be displayed at the bottom of the [PROJECT
MANAGER] window.
Additionally, the selected wav files will be transferred into the …\Audio\ folder of the current
Project, and displayed in the [AUDIO POOL] window.
Warning: This is a destructive process, so will overwrite any files that already exist
in the Audio Pool if the name is the same as the importing sample.
14
Octatrack Sample Manager
5.3
Rename File
Selecting Rename File will allow the ability to edit the name of the currently selected sample
in the [PROJECT MANAGER]
Upon entering the new name, the currently selected sample will be updated on the file system
in the …\Audio\ folder of the current Project.
Entering illegal special characters will cause the sample name to reset back to it’s
current name, special characters are:
"'@*&#[]%|/\^!$():;?=<>
5.4
Edit Mode
Note: This has the same effect as selecting Menu\Options\Edit Mode\Project or accessing
the Quick Access Option for Project – Edit Mode
Selecting Edit Mode will toggle the [PROJECT MANAGER] in, or out of Edit Mode.
Whilst in Edit Mode, Sample Slots, Sample Names, Gain and Quantise can be renamed by
simply typing directly into the [PROJECT MANAGER], bypassing the requirement to utilise
the singular Rename File function.
It is recommended to leave the [PROJECT MANAGER] in non Edit Mode, unless you
are specifically bulk maintaining / renaming samples.
5.5
Assign… Flex to Static
Selecting the Flex to Static function will change all sample slots in the current [PROJECT
MANAGER] window currently assigned as “Flex” sample slots to “Static” sample slots.
5.6
Assign… Static to Flex
Selecting the Static to Flex function will change all sample slots in the current [PROJECT
MANAGER] window currently assigned as “Static” sample slots to “Flex” sample slots.
5.7
Assign… Flex then Static
Selecting the Flex then Static function will automatically assign a Sample Type and Sample
Slot to all the samples in the current [PROJECT MANAGER] window, first assigning “Flex”
sample slots, then assigning “Static” sample slots.
5.8
Assign… Static then Flex
Selecting the Static then Flex function will automatically assign a Sample Type and Sample
Slot to all the samples in the current [PROJECT MANAGER] window, first assigning “Static”
sample slots, then assigning “Flex” sample slots.
Each of the Flex and Static Sample Types can have up to 128 Sample Slots.
When using the Flex then Static or Static then Flex functions, the slots are
assigned to the first type (Flex or Static) from 001 to 128, then to the first type (Flex
or Static) from 001 to 128.
Octatrack Sample Manager
15
5.9
Space Time Continuum
Selecting the Space Time Continuum function allows you to alter the very fabric of the space
time continuum itself.
Warning: Altering the space time continuum can have the very nasty side effect of
tearing the world asunder, so should be used with extreme caution, and only if you
possess a significantly high level of experience in warping time and space.
5.10 Auto Play
Note: This has the same effect as selecting Menu\Options\Audio Options \Project Auto
Play or accessing the Quick Access Option for Project – Auto Play
Selecting the Auto Play function will toggle the [PROJECT MANAGER] in, or out of Auto Play
Mode.
Whilst in Auto Play mode, samples are automatically played when they are selected within the
[PROJECT MANAGER], thus allowing for quick previewing of the samples.
5.11 Loop Mode
Note: This has the same effect as selecting Menu\Options\Audio Options \Project Loop
Mode or accessing the Quick Access Option for Project – Loop Mode
Selecting the Loop Mode function will toggle the [PROJECT MANAGER] in, or out of Loop
Mode.
Whilst in Loop Mode, samples played via either the Play Audio File function, or automatically
played when the [PROJECT MANAGER] is in Auto Play mode will loop indefinitely.
Note: Disabling Loop Mode does not stop the playback of the currently selected
sample, therefore after turning Loop Mode off, select another sample to play, to
stop the playback.
5.12 Cut
Selecting the Cut function will remove the currently selected sample from the [PROJECT
MANAGER] window and storing it in memory for pasting later.
5.13 Copy
Selecting the Copy function will copy the currently selected sample from the [PROJECT
MANAGER] window and storing it in memory for pasting later.
5.14 Paste
Selecting the Paste function will paste the currently selected sample from memory into the
[PROJECT MANAGER] window.
16
Octatrack Sample Manager
5.15 Delete
Selecting the Delete function will remove the currently selected sample from the [PROJECT
MANAGER] window.
Note: The Delete function removes the sample from the project, but does not
remove it from either the [AUDIO POOL] window or the ‘..\Audio\’ folder of the
Project’s Set.
5.16 Refresh
Selecting the Refresh function will refresh the [PROJECT MANAGER] window retrieving all
the original information of the current Project being worked on.
Note: Essentially this is a global reset for the Project, returning it to its last saved
state.
5.17 Close Project
Selecting the Save Project function closes the currently selected Project in the [PROJECT
MANAGER] window without saving.
Note: This is the same as pressing the X button on the tab.
5.18 Save Project
Selecting the Save Project function saves the currently selected Project in the [PROJECT
MANAGER] window, overwriting the existing Project on the computer.
Note: It is only possible to save the current Project if no Errors or Duplicates exist.
Refer to section 4.2 Error Checking for more information.
Octatrack Sample Manager
17
6 Audio Pool
The [AUDIO POOL] window contains the currently available samples stored within the ‘Audio’
folder of the Project currently selected in the Project Manager.
<Left-Clicking> on the [AUDIO POOL] will perform various actions depending on the options
that have been configured. (Refer below)
If the [AUDIO POOL] is NOT in Edit Mode, <Left-Clicking> and <Dragging> whilst keeping
the left mouse button held down will allow you to drag a sample from the [AUDIO POOL]
window to the [PROJECT MANAGER] window.
If the [AUDIO POOL] is in Edit Mode, it is possible to select multiple non-contiguous sample
ranges within the Audio Pool by <Left-Clicking> and utilising the Ctrl and Shift keys of your
keyboard.
<Right-Clicking> on the [AUDIO POOL] will display the below context menu, the details of
which are outlined below.
18
Octatrack Sample Manager
6.1
Add to Project
Selecting Add to Project will transfer the currently selected sample or samples from the
[AUDIO POOL] window to the currently selected Project in the [Project Manager] window.
Whether a single sample or multiple samples are copied depends on whether the Audio Pools
Edit Mode is currently enabled or not.
The sample, or samples will be appended to the bottom of the current Projects sample
collection in the [PROJECT MANAGER] window, and will be assigned default values.
6.2
Import to Audio Pool
Selecting Import to Audio Pool will display a standard Windows file browser window,
allowing the ability to select one or more wav files.
After selection, the selected wav files will be transferred into the …\Audio\ folder of the current
Project, and displayed in the [AUDIO POOL].
Warning: This is currently a destructive process, so will overwrite any files that
already exist in the Audio Pool if the name is the same as the importing sample.
For example, a sample called “Kick.wav” already exists in the Audio Pool. If you select Import
to Audio Pool and select another sample, also called “Kick.wav”, the original sample will be
overwritten with the newly imported sample.
6.3
Play Audio File
Selecting Play Audio File will play the currently selected sample in the [AUDIO POOL], in
effect a one-shot audio playback.
6.4
Copy
Selecting the Copy function copies either the selected sample, or the selected samples in the
[AUDIO POOL], once copied the sample or samples can be transferred to a different Projects
Audio Pool using the Paste function.
Whether a single sample or multiple samples are copied depends on whether the Audio Pools
Edit Mode is currently enabled or not.
When copy samples, the entire sub-path is also copied, as per the source Audio Pool.
6.5
Paste
Selecting the Paste function transfers the previously copied sample or samples from the
original Projects Audio Pool into the current Projects Audio Pool.
The current status of the Edit Mode, enabled or not, is irrelevant for this function.
When pasting samples, the entire sub-path is also transferred, as per the source Audio Pool.
Warning: This is a destructive process, so will overwrite any files that already exist
in the target Audio Pool if the name is the same as the copied sample or samples.
Octatrack Sample Manager
19
6.6
Rename Audio File
Selecting Rename Audio File will allow the ability to edit the name of the currently selected
sample in the [AUDIO POOL].
Upon entering the new name, the currently selected sample will also be updated on the file
system in the …\Audio\ folder of the current Project.
6.7
Edit Mode
Note: This has the same effect as selecting Menu\Options\Edit Mode\Audio Pool or
accessing the Quick Access Option for Audio Pool – Edit Mode
Selecting Edit Mode will toggle the [AUDIO POOL] in, or out of Edit Mode.
Whilst Edit Mode is disabled, samples can be dragged from the [AUDIO POOL] window to
the current [PROJECT MANAGER] window.
Whilst in Edit Mode, samples can be renamed by simply typing directly into the Audio Pool,
bypassing the requirement to utilise the singular Rename Audio File function.
Additionally, when Edit Mode is enabled, it allows the ability to multi select samples, to allow
bulk copying, bulk adding to project, and bulk deletion of samples.
6.8
Auto Play
Note: This has the same effect as selecting Menu\Options\Audio Options \Audio Pool
Auto Play or accessing the Quick Access Option for Audio Pool – Auto Play
Selecting the Auto Play function will toggle the [AUDIO POOL] in, or out of Auto Play Mode.
Whilst in Auto Play mode, samples are automatically played when they are selected within the
[AUDIO POOL], thus allowing for quick previewing of the samples.
6.9
Loop Mode
Note: This has the same effect as selecting Menu\Options\Audio Options \Audio Pool
Loop Mode or accessing the Quick Access Option for Audio Pool – Loop Mode
Selecting the Loop Mode function will toggle the [AUDIO POOL] in, or out of Loop Mode.
Whilst in Loop Mode, samples played via either the Play Audio File function, or automatically
played when the [AUDIO POOL] is in Auto Play mode will loop indefinitely.
Note: Disabling Loop Mode does not stop the playback of the currently selected
sample, therefore after turning Loop Mode off, select another sample to play, to
stop the playback.
20
Octatrack Sample Manager
6.10 Refresh Audio Pool
Selecting the Refresh Audio Pool function will refresh the [AUDIO POOL] retrieving all the
current samples from the …\Audio\ folder of the current Project being worked on.
Note: You should use this after copying files via Windows Explorer.
6.11 Delete From Audio Pool
Selecting the Delete function deletes either the currently selected sample, or the selected
samples in the [AUDIO POOL], and conveniently places it/them in the Recycle Bin for you.
Whether a single sample or multiple samples are deleted depends on whether the Audio Pools
Edit Mode is currently enabled or not.
Warning: Deleting sample(s) from the Audio Pool does not update any of the
Projects, therefore there is a risk that you will delete samples that are currently
referenced by one, or more Projects.
Octatrack Sample Manager
21
7 Project Settings
The [PROJECT SETTINGS] window stores information relating to the current Project
displayed in the [PROJECT MANAGER].
The information relating to the current project is stored into various sub-sections, and
generally are accessed via drop-down boxes, or can be manually typed in.
Note: Some options are greyed out, and thus unavailable to be changed.
These are displayed greyed out in the below tables.
7.1
Project
The Project section stores the information relevant to general Project settings as per the
below table.
Item
Comment
Project Path
The working path of the Project on your
computer, not your Octatrack.
Name
The Name of the Project
Version
Current Version of the Project
Operating System
Octatrack OS version the Project was saved on.
Write Protected?
Defines whether the project is Write Protected
or not.
True / False
Tempo
Provides Tempo to one decimal place.
30.0 to 300.0
Master Track Mode
Defines whether this project use Track 8 as a
Master track or not.
Normal / Master
Cue Configuration
Defines whether the cue outputs for this project
are set to Normal or Studio mode.
Normal / Studio
22
Octatrack Sample Manager
Valid Values
7.2
Mixer
The Mixer section stores the project information relevant to general Audio settings as per the
below table. These settings are accessed via the [Mixer] button on your Octatrack.
Item
Comment
Valid Values
Main Level
-64 to 63
Cue Level
-64 to 63
Main to Cue
-64 to 63
Phones Mix
-64 to 63
Dir A/B
0 to 127
Dir C/D
0 to 127
Gain A/B
0 to 127
Gain C/D
0 to 127
7.3
Midi Settings
The Midi Settings section stores the project information relevant to Midi synchronisation.
Item
Comment
Valid Values
Midi Clock Send
True / False
Midi Clock Receive
True / False
Midi Transport Send
True / False
Midi Transport Receive
True / False
Midi Program Change
Send
True / False
Midi Program Change
Send Channel
0 to 16
Midi Program Change
Receive
True / False
Midi Program Change
Receive Channel
0 to 16
Midi Audio Track CC In
True / False
Midi
Out
Int / Ext / Int +
Ext
Audio
Track
CC
0 = Auto
0 = Auto
Midi Audio Track Note
In
True / False
Midi Audio Track Note
Out
Int / Ext / Int +
Ext
Octatrack Sample Manager
23
7.4
Midi Channels
The Midi Channels section stores the project information relevant to the Midi Channels as per
the below table.
Item
Comment
Midi Auto Channel
Valid Values
0 to 16
0 = Auto
Midi Soft Thru Channel
0 to 16
0 = Auto
Midi Trig Channel 1
1 to 16
Midi Trig Channel 2
1 to 16
Midi Trig Channel 3
1 to 16
Midi Trig Channel 4
1 to 16
Midi Trig Channel 5
1 to 16
Midi Trig Channel 6
1 to 16
Midi Trig Channel 7
1 to 16
Midi Trig Channel 8
1 to 16
7.5
Input
The Input section stores the project information relevant to the Input settings used by the
Octatrack recorders as per the below table.
Item
Comment
Valid Values
Noise Gate A/B
-INF to 0db
Noise Gate C/D
-INF to 0db
Delay Compensate
True / False
7.6
Sequencer
The Sequencer section stores the project information relevant to the Octatrack behaviour
when changing patterns as per the below table.
Item
Comment
Valid Values
Chain After…
Pattern
Length
or sub settings.
Silence Tracks
True / False
LFO Auto Change
True / False
24
Octatrack Sample Manager
7.7
Midi Sequencer
The Midi Sequencer section stores the project information relevant to if the Octatrack utilises
the CC Direct Connect option to send Midi data as per the below table.
Item
Comment
CC Direct Connect
7.8
Valid Values
0 to 127
Memory
The Memory section stores the project information relevant to the Pickup Recorder buffers
used by the Octatrack as per the below table.
Item
Comment
Valid Values
Flex Format
16 Bit / 24 Bit
Dynamic Recorders
True / False
Record Format
16 Bit / 24 Bit
Reserve Recordings
0 to 8
Reserve Length
0 to 63
7.9
Metronome
The Metronome section stores the project information relevant to the Metronome as per the
below table.
Item
Comment
Valid Values
Metronome Enabled
True / False
Time Signature
1
to
16
Sixteenth Note
Time
Signature
Denominator
1
to
16
Sixteenth Note
Metronome Preroll Bars
1 to 16
Metronome
Volume
Cue
True / False
Metronome
Volume
Main
0 to 127
Metronome Tonal
0 to 127
Metronome Pitch
C5 to C7
Octatrack Sample Manager
25
7.10 State Data
The State Data section stores the project information relevant to various internal state
settings as per the below table.
Item
Comment
Bank
Pattern
Arrangement
Part
Track
Track Other Mode
Page
Scene A Mute
Scene B Mute
Track Cue Mask
Track Mute Mask
Track Solo Mask
Midi Track Mute Mask
Midi Track Solo Mask
26
Octatrack Sample Manager
Valid Values
Open as PDF
Similar pages