Basic Router Configuration

Basic Router Configuration
This module provides configuration procedures for Cisco 3900 series, 2900 series, and 1900 series
integrated services routers (ISRs). It also includes configuration examples and verification steps
whenever possible.
Note
See Appendix A, “Cisco IOS CLI for Initial Configuration” for information on how to perform the initial
configuration using the Cisco Internet Operating System (IOS) command line interface on Cisco 3900
series, 2900 series, and 1900 series integrated services routers.
Basic Configuration
•
Default Configuration, page 2
•
Configuring Global Parameters, page 3
Interface Configuration
•
Interface Ports, page 4
•
Configuring Gigabit Ethernet Interfaces, page 5
•
Configuring Wireless LAN Interfaces, page 5
•
Configuring Interface Card and Module Interfaces, page 5
•
Configuring a Loopback Interface, page 6
Routing Configuration
•
Configuring Command-Line Access, page 7
•
Configuring Static Routes, page 9
•
Configuring Dynamic Routes, page 10
Americas Headquarters:
Cisco Systems, Inc., 170 West Tasman Drive, San Jose, CA 95134-1706 USA
Basic Router Configuration
Default Configuration
Default Configuration
When you boot up your Cisco router for the first time, you will notice some basic configuration has
already been performed. Use the show running-config command to view the initial configuration, as
shown in the following example.
Router# show running-config
Building configuration...
Current configuration : 723 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
archive
log config
hidekeys
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
2
Basic Router Configuration
Configuring Global Parameters
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 3
login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end
Configuring Global Parameters
To configure the following global parameters for your router, perform these steps:
Step 1
Command
Purpose
configure terminal
Enters global configuration mode, when using the
console port.
Example:
Use the following to connect to the router with a
remote terminal:
Router> enable
Router# configure terminal
Router(config)#
Step 2
hostname name
telnet router name or address
Login: login id
Password: *********
Router> enable
Specifies the name for the router.
Example:
Router(config)# hostname Router
Router(config)#
Step 3
enable secret password
Specifies an encrypted password to prevent
unauthorized access to the router.
Example:
Router(config)# enable secret cr1ny5ho
Router(config)#
Step 4
no ip domain-lookup
Disables the router from translating unfamiliar
words (typos) into IP addresses.
Example:
Router(config)# no ip domain-lookup
Router(config)#
For complete information on global parameter commands, see the Cisco IOS Release configuration
guide documentation set.
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
OL-21850-01
3
Basic Router Configuration
Interface Ports
Interface Ports
Table 7 lists the interfaces that are supported on Cisco 3900 series, 2900 series, and 1900 series
integrated services routers.
Table 7
Interfaces by Cisco Router
Slots, Ports, Logical
Interface, Interfaces
29011
1941
Gi0/0,Gi0/1
2911 & 2921
Gi0/0,Gi0/1,GI0/2
2951 & 3925 & 3945
Gi0/0,Gi0/1,GI0/2
3925E & 3945E
Onboard GE ports
Gi0/0,Gi0/1
Gi0/0,Gi0/1,GI0/2,
GI0/3
Onboard WLAN
Wlan-ap0
not supported
not supported
not supported
not supported
Onboard WLAN GE
connection to
multi-gigabit fabric
(MGF)
Wlan-Gi0/0
not supported
not supported
not supported
not supported
Onboard ISM GE
service-module service-moduleinterface on the PCIe -name-ISM 0/0 name-ISM 0/0
service-modulename-ISM 0/0
service-modulename-ISM 0/0
not supported
Onboard ISM GE
connection to
multi-gigabit fabric
(MGF)
service-module service-module-name-ISM 0/1 name-ISM 0/1
service-modulename-ISM 0/1
service-modulename-ISM 0/1
not supported
USB
usbflash0,
usbflash1
usbflash0,
usbflash1
usbflash0,
usbflash1
usbflash0,
usbflash1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
usbtoken0,
usbtoken1
Interfaces on HWIC
and VWIC
interface0/0/
port
interface0/1/
port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
interface0/0/port
interface0/1/port
interface0/2/port
interface 0/3/port
<int>0/0/<port>
<int>0/1/<port>
<int>0/2/<port>
Interfaces on Double
Wide-HWIC
interface0/1
port
interface0/1/port
interface0/1/port
interface0/1/port
<int>0/1/<port>
interface0/3/port
interface0/3/port
interface0/3/port
usbflash0, usbflash1
usbtoken0,
usbtoken1
Interfaces on SM
not supported
not supported
interface1/port
interface1-2/port2
interface1-4/port3
interface1-2/port
interface1-4/port
Interfaces on Double
Wide-SM
not supported
not supported
not supported
interface 2/port4
interface4/port5
interface 2/port
interface 4/port
Interfaces HWIC on
SM
not supported
not supported
interface1wic-slot/ interface1-2/wicport
slot/port6
Interfaces VWIC on
SM
interface1-4/wicslot/port7
interface1-2/wicslot/port
interface1-4/wicslot/port
1. On the Cisco 2901 router, the numbering format for configuring an asynchronous interface is 0/slot/port. To configure the line associated with an
asynchronous interface, simply use the interface number to specify the async line. For example, line 0/1/0 specifies the line associated with interface
serial 0/1/0 on a WIC-2A/S in slot 1. Similarly, line 0/2/1 specifies the line associated with interface async 0/2/1 on a WIC-2AM in slot 2.
2. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
3. Applies only to Cisco 3945 and Cisco 3945E routers.
4. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
5. Applies only to Cisco 3945 and Cisco 3945E routers.
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
4
Basic Router Configuration
Configuring Gigabit Ethernet Interfaces
6. Applies only to Cisco 2951, Cisco 3925, and Cisco 3925E routers.
7. Applies only to Cisco 3945 and Cisco 3945E routers.
Configuring Gigabit Ethernet Interfaces
To manually define onboard Gigabit Ethernet (GE) interfaces perform the following steps, in global
configuration mode.
Step 1
Command
Purpose
interface gigabitethernet slot/port
Enters the configuration mode for a Gigabit
Ethernet interface on the router.
Example:
Router(config)# interface gigabitethernet 0/1
Router(config-if)#
Step 2
ip address ip-address mask
Sets the IP address and subnet mask for the
specified GE interface.
Example:
Router(config-if)# ip address 192.168.12.2
255.255.255.0
Router(config-if)#
Step 3
no shutdown
Enables the GE interface, changing its state
from administratively down to administratively
up.
Example:
Router(config-if)# no shutdown
Router(config-if)#
Step 4
exit
Exits configuration mode for the GE interface
and returns to global configuration mode.
Example:
Router(config-if)# exit
Router(config)#
Configuring Wireless LAN Interfaces
The wireless LAN interface on the Cisco 1941W router enables connection to the router through
interface wlan-ap0. For more information about configuring a wireless connection, see the
“Configuring the Wireless Device” module in this guide.
Configuring Interface Card and Module Interfaces
To configure interface cards and modules inserted in internal services module (ISM), enhanced
high-speed WAN interface card (EHWIC), Ethernet WAN interface card (EWIC), and service module
(SM) slots, see the appropriate interface card or module configuration documents on Cisco.com.
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
OL-21850-01
5
Basic Router Configuration
Configuring a Loopback Interface
Configuring a Loopback Interface
The loopback interface acts as a placeholder for the static IP address and provides default routing
information.
For complete information on the loopback commands, see the Cisco IOS Release configuration guide
documentation set.
To configure a loopback interface perform these steps, beginning in global configuration mode:
Step 1
Command
Purpose
interface type number
Enters configuration mode for the loopback
interface.
Example:
Router(config)# interface Loopback 0
Router(config-if)#
Step 2
ip address ip-address mask
Sets the IP address and subnet mask for the
loopback interface.
Example:
Router(config-if)# ip address 10.108.1.1
255.255.255.0
Router(config-if)#
Step 3
exit
Example:
Exits configuration mode for the loopback
interface and returns to global configuration
mode.
Router(config-if)# exit
Router(config)#
Example
The loopback interface in this sample configuration is used to support Network Address Translation
(NAT) on the virtual-template interface. This configuration example shows the loopback interface
configured on the gigabit ethernet interface with an IP address of 200.200.100.1/24, which acts as a static
IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address.
!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
Verifying Configuration
To verify that you have properly configured the loopback interface, enter the show interface loopback
command. You should see verification output similar to the following example.
Router# show interface loopback 0
Loopback0 is up, line protocol is up
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
6
Basic Router Configuration
Configuring Command-Line Access
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Another way to verify the loopback interface is to ping it:
Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Configuring Command-Line Access
To configure parameters to control access to the router perform these steps, beginning in global
configuration mode:
Step 1
Command
Purpose
line [aux | console | tty | vty] line-number
Enters line configuration mode, and specifies the
type of line.
Example:
This example specifies a console terminal for
access.
Router(config)# line console 0
Router(config-line)#
Step 2
password password
Specifies a unique password for the console
terminal line.
Example:
Router(config)# password 5dr4Hepw3
Router(config-line)#
Step 3
login
Enables password checking at terminal session
login.
Example:
Router(config-line)# login
Router(config-line)#
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
OL-21850-01
7
Basic Router Configuration
Configuring Command-Line Access
Step 4
Command
Purpose
exec-timeout minutes [seconds]
Sets the interval that the EXEC command
interpreter waits until user input is detected. The
default is 10 minutes. Optionally, add seconds to
the interval value.
Example:
Router(config-line)# exec-timeout 5 30
Router(config-line)#
Step 5
line [aux | console | tty | vty] line-number
This example shows a timeout of 5 minutes and
30 seconds. Entering a timeout of 0 0 specifies
never to time out.
Specifies a virtual terminal for remote console
access.
Example:
Router(config-line)# line vty 0 4
Router(config-line)#
Step 6
password password
Specifies a unique password for the virtual
terminal line.
Example:
Router(config-line)# password aldf2ad1
Router(config-line)#
Step 7
login
Enables password checking at the virtual terminal
session login.
Example:
Router(config-line)# login
Router(config-line)#
Step 8
end
Exits line configuration mode, and returns to
privileged EXEC mode.
Example:
Router(config-line)# end
Router#
Example
The following configuration shows the command-line access commands.
You do not need to input the commands marked “default.” These commands appear automatically in the
configuration file generated when you use the show running-config command.
!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
8
Basic Router Configuration
Configuring Static Routes
Configuring Static Routes
Static routes provide fixed routing paths through the network. They are manually configured on the
router. If the network topology changes, the static route must be updated with a new route. Static routes
are private routes unless they are redistributed by a routing protocol.
To configure static routes perform these steps, beginning in global configuration mode:
Step 1
Command
Purpose
ip route prefix mask {ip-address | interface-type
interface-number [ip-address]}
Specifies the static route for the IP packets.
Example:
Router(config)# ip route 192.168.1.0
255.255.0.0 10.10.10.2
Router(config)#
Step 2
end
For details about this command and about
additional parameters that can be set, see the Cisco
IOS IP Command Reference, Volume 2 of 4:
Routing Protocols, Release 12.3
Exits router configuration mode, and enters
privileged EXEC mode.
Example:
Router(config)# end
Router#
Example
In the following configuration example, the static route sends out all IP packets with a destination IP
address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Gigabit Ethernet interface to another
device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.
You do not need to enter the command marked “(default).” This command appears automatically in the
configuration file generated when you use the show running-config command.
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
Verifying Configuration
To verify that you have properly configured static routing, enter the show ip route command and look
for static routes signified by the “S.”
You should see verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
OL-21850-01
9
Basic Router Configuration
Configuring Dynamic Routes
C
10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
Configuring Dynamic Routes
In dynamic routing, the network protocol adjusts the path automatically, based on network traffic or
topology. Changes in dynamic routes are shared with other routers in the network.
The Cisco routers can use IP routing protocols, such as Routing Information Protocol (RIP) or Enhanced
Interior Gateway Routing Protocol (EIGRP), to learn routes dynamically. You can configure either of
these routing protocols on your router.
•
Configuring Routing Information Protocol
•
Configuring Enhanced Interior Gateway Routing Protocol
Configuring Routing Information Protocol
To configure the RIP routing protocol on the router perform these steps, beginning in global
configuration mode:
Step 1
Command
Task
router rip
Enters router configuration mode, and enables RIP
on the router.
Example:
Router> configure terminal
Router(config)# router rip
Router(config-router)#
Step 2
version {1 | 2}
Specifies use of RIP version 1 or 2.
Example:
Router(config-router)# version 2
Router(config-router)#
Step 3
network ip-address
Example:
Specifies a list of networks on which RIP is to be
applied, using the address of the network of each
directly connected network.
Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#
Step 4
no auto-summary
Example:
Router(config-router)# no auto-summary
Router(config-router)#
Step 5
end
Disables automatic summarization of subnet routes
into network-level routes. This allows subprefix
routing information to pass across classful network
boundaries.
Exits router configuration mode, and enters
privileged EXEC mode.
Example:
Router(config-router)# end
Router#
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
10
Basic Router Configuration
Configuring Dynamic Routes
Example
The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and
192.168.1.0.
To see this configuration, use the show running-config command from privileged EXEC mode.
!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
Verifying Configuration
To verify that you have properly configured RIP, enter the show ip route command and look for RIP
routes signified by “R.” You should see a verification output like the example shown below.
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
R
10.0.0.0/24 is subnetted, 1 subnets
10.108.1.0 is directly connected, Loopback0
3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
Configuring Enhanced Interior Gateway Routing Protocol
To configure Enhanced Interior Gateway Routing Protocol GRP (EGRP) perform these steps, beginning
in global configuration mode:
Step 1
Command
Purpose
router eigrp as-number
Enters router configuration mode, and enables
EIGRP on the router. The autonomous-system
number identifies the route to other EIGRP routers
and is used to tag the EIGRP information.
Example:
Router(config)# router eigrp 109
Router(config)#
Step 2
network ip-address
Specifies a list of networks on which EIGRP is to
be applied, using the IP address of the network of
directly connected networks.
Example:
Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
OL-21850-01
11
Basic Router Configuration
Configuring Dynamic Routes
Step 3
Command
Purpose
end
Exits router configuration mode, and enters
privileged EXEC mode.
Example:
Router(config-router)# end
Router#
Example
The following configuration example shows the EIGRP routing protocol enabled in IP networks
192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.
To see this configuration use the show running-config command, beginning in privileged EXEC mode.
!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
Verifying Configuration
To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for
EIGRP routes indicated by “D.” You should see verification output similar to the following:
Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
D
10.0.0.0/24 is subnetted, 1 subnets
10.108.1.0 is directly connected, Loopback0
3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0
CCDE, CCENT, CCSI, Cisco Eos, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase,
Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good,
Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks;
Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card,
and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA,
CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus,
Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast,
EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream,
Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV,
PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are
registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.
All other trademarks mentioned in this document or website are the property of their respective owners. The use of the word partner does not imply
a partnership relationship between Cisco and any other company. (0910R)
Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and
figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and
coincidental.
© 2009-2010 Cisco Systems, Inc. All rights reserved.
Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software
12
Open as PDF
Similar pages