Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer

APPENDIX
Tracking Time with
the Standalone
QuickBooks Pro Timer
F
C
opies of QuickBooks aren’t cheap, so the people who do your bookkeeping
are probably the only ones who have access to the program. But you may
have dozens of people who perform billable work and need a way to track
their time. Even if you run a one-person consulting shop, you may not want to run
QuickBooks just so you can time your work.
QuickBooks Pro Timer is a program that runs independently of QuickBooks. You can
send this program to others and track their time without buying more QuickBooks
licenses. With QuickBooks Pro Timer, people can track their time as they work (using
the program’s stopwatch mode) or enter their time after they finish working. They
then send the data captured by the program to you so you can load it into your
QuickBooks company file for billing or payroll.
NOTE For brevity’s sake, from here on, this appendix refers to QuickBooks Pro Timer simply as “Timer.”
Downloading Timer
Timer comes on the QuickBooks CD. But if you download your copy of QuickBooks,
you have to download Timer separately. Here’s how to do that:
1. In a web browser, head to http://support.quickbooks.intuit.com . In the
Search box at the webpage’s top right, type “install Pro Timer,” and then
press Enter.
A list of search results appears.
F-1
DISTRIBUTING
TIMER
2. Click the “Install, set up and use the QuickBooks Pro Timer” link.
It may be the first link in the list.
3. Below the “Install and Set up the QuickBooks Pro Timer” heading, click the
+ to the left of the “Download and install the Pro Timer” topic (you may
have to scroll down to see it). In the step-by-step list, click “Download the
QuickBooks Pro Timer install files.”
The Customer Downloads page appears.
4. Scroll down to the QuickBooks Timer section, and then click the zip file that
you want to download (QBTimer2013.zip is the most recent file.)
5. Use the dialog box that appears to save the file to a folder on your computer.
When you click Save, the zip file downloads to your computer.
The next section explains how to distribute Timer to others.
Distributing Timer
This section describes the tasks you have to complete to let other people use Timer.
(Remember, they don’t need to have QuickBooks installed in order to use Timer.)
Exporting Lists for Timer Users
Your QuickBooks company file includes all sorts of information that you need for
tracking time:
• The names of your customers and jobs
• The names of the people whose time you track
• The items that represent the work they do
• The classes you use to track income and expenses (if you use classes)
Timer needs all this information to function, so you have to send this info to people
who use it. After you’ve installed Timer (as explained on page F-4) on the computer
you use to run QuickBooks, QuickBooks includes a command to create the export
file with all the information that Timer needs. If you export the QuickBooks lists with
this info before you distribute Timer, you can include the export file along with the
installation software.
NOTE If your QuickBooks lists change, you have to send an updated export file to people who use Timer.
F-2
QUICKBOOKS 2015: THE MISSING MANUAL
Here’s how you export lists for Timer:
1. In QuickBooks, if your company file is in multi-user mode, choose File→
Switch to Single-user Mode.
DISTRIBUTING
TIMER
You have to be in single-user mode to export data.
2. Choose File→Utilities→Export→Timer Lists.
The first time you select this command, QuickBooks opens the “Export Lists
for Timer” dialog box, which includes a diagram of how data flows between
QuickBooks and Timer. Once you’ve seen this dialog box, you probably don’t
need to see it again, so before clicking OK to open the Export dialog box, turn
on the “Don’t display this message in the future” checkbox. That way, the next
time you export lists for Timer, QuickBooks immediately gets down to the business of creating the export file.
3. Click OK to open the Export dialog box, and then choose the folder where
you want to store your Timer lists.
QuickBooks opens the Export dialog box to the Company Files subfolder of
the Intuit\QuickBooks folder. Instead of that location, store the export file with
your other data in a folder that’s part of your backup plan and has a memorable
name like Shared Documents\Export Files\Timer Files. The next time you export Timer lists, QuickBooks opens the Export dialog box to the last folder you
selected, so you only have to navigate to your Timer list folder the first time
you export these lists.
4. In the “File name” box, type a name for the list file.
QuickBooks automatically fills in the “Save as type” box with “IIF Files (*.iif),”
which is what you want. Use the filename to identify the company and data
that the file contains. And, because you’ll need to send out updated export
files when your QuickBooks lists change, include a version number or date,
too. For example, for Double Trouble’s lists as of October 18, 2015, you could
use DT_TimerList151018.
5. Click Save.
QuickBooks displays an Information message box that tells you the export was
successful. When you click OK, the export file is ready to use with your copy of
Timer or to include with the version you send to others.
Giving Timer to Others
You can distribute Timer using any method you want. Emailing them the zip file
you downloaded (page F-1) or a zip file of the QuickBooks Timer folder from your
QuickBooks CD might be the easiest, but you can also pass a thumb drive around
to your colleagues in the office, send a CD to other recipients, or use an online filesharing service (like www.transferbigfiles.com or www.hightail.com) to send the
file to your colleagues.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-3
USING TIMER
TO TRACK TIME
NOTE The downloaded zip file is at least 4 megabytes, so you won’t be able to email it to recipients whose
ISPs limit the size of email attachments to less than that. Because of that, it’s a good idea to ask your recipients
if it’s OK to email a file that large.
Using Timer to Track Time
Now that you’ve distributed Timer, you need to know how people can track their own
time using the program and send the resulting records to you, the person running
QuickBooks. This section explains all that.
TIP Even if your computer has QuickBooks installed, replete with its built-in time-tracking features (page
164), you might prefer to track time using Timer. You can use its stopwatch and quickly switch among different
activities during the day—all without running QuickBooks.
Installing Timer
QuickBooks Pro Timer (a.k.a. Timer) uses an installation wizard, so the process for
installing it should be familiar. In case one of your employees isn’t as experienced
with a computer as you are, here are the steps:
1. In Windows Explorer, navigate to the CD, thumb drive, or folder containing the QuickBooks Pro Timer zip file, and then unzip it to a folder on your
computer.
2. Navigate to the folder where you unzipped the installation files, and then
double-click the Setup file (Setup.exe).
The installation wizard opens the QuickBooks Pro Timer Installation window and
displays a Welcome dialog box. Click Next to get to the good stuff.
3. In the “Destination folder for application” screen, click Browse to select
where you want to install Timer. After you choose the folder you want,
click OK.
The installation wizard chooses a folder such as C:\Program Files\Intuit\QuickBooks\QuickBooks Pro Timer, which is as good a place as any. But if you want to
keep the program in a different folder, click Browse and choose a folder under
Program Files, such as C:\Program Files\QBTimer.
4. On the “Destination folder for application” screen, click Install.
You see a screen with a progress bar and a few inconsequential messages, but
the installation takes less than a minute. When it’s finished, the “Installation
Wizard complete” screen appears.
F-4
QUICKBOOKS 2015: THE MISSING MANUAL
5. Click Finish.
The installation dialog box closes, and Timer joins the other programs on your
Start→All Programs or Start→Program Files menu, depending on how your
computer’s operating system is set up.
USING TIMER
TO TRACK TIME
6. Be sure to copy the export file of QuickBooks lists you received to a folder
on your computer.
The person who sent you the QuickBooks Pro Timer zip file should have also
sent an export file of QuickBooks lists. You have to import the lists in the export
file into Timer (as described in the next section) so you can assign customers
and items to the time you work.
Setting Up Timer
The first time you run Timer, you have to set it up:
1. In the Windows Start menu, navigate to the submenu that contains the Timer
program, and then choose QuickBooks Pro Timer.
The exact submenu depends on the program folder you specified during installation. For example, if you added the program to your QuickBooks folder, then
choose Start→All Programs→QuickBooks [edition]→QuickBooks Pro Timer,
where “[edition]” is the name of the QuickBooks edition you use, like Pro 2015
or Premier 2015. To keep the program within reach, drag the QuickBooks Pro
Timer menu entry onto the Windows taskbar (where its icon looks like a stopwatch) so you can start it with a single click.
The QuickBooks Pro Timer window opens, but so does the No Timer File Is
Open dialog box. That’s because you need to create a file to hold the time that
you track, as shown in Figure F-1.
FIGURE F-1
The program selects the
Create New Timer File
option automatically. If
you already have a Timer
file somewhere, select the
Open Existing Timer File
option instead, and then
click OK.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-5
USING TIMER
TO TRACK TIME
2. If you’ve never used Timer before, click OK to open the New Timer File
dialog box.
If you already have a Timer file somewhere, select the Open Existing Timer
File option instead and then click OK. In the Open Timer File dialog box that
appears, double-click the Timer file you want to open, and then jump to step 4.
3. In the New Timer File dialog box, navigate to the folder where you’d like
to store the database file that Timer creates, type a name for the file, and
then click OK to create the Timer database.
A message appears, which offers to show you how to import your lists into
QuickBooks. Click Yes to read the instructions.
If you’ve imported files before or if you prefer to skip the instructions, then click
No. The Timer window’s title bar now includes the name of the Timer database
file you created.
4. To import the QuickBooks lists from the export file you received, choose
File→Import QuickBooks Lists.
The Import QuickBooks Lists dialog box opens, which includes a diagram showing how data flows between Timer and QuickBooks.
5. Turn on the “Don’t show me this message again” checkbox, and then click
Continue.
The Open File For Import dialog box opens.
6. In the Open File For Import dialog box, double-click the folder where you
stored the QuickBooks lists export file (page F-3).
For example, if you copied the export file to the same folder as the Timer
software, the folder might be something like C:\Program Files (x86)\Intuit\
QuickBooks\QBTimer. The file is in .iif format.
7. After you open the folder containing the export file, double-click the export
file’s name to import the lists into Timer.
Click OK to dismiss the message box telling you that the import was successful.
The Timer window doesn’t look any different than it did before you imported
the lists, but you can now track time.
Setting Up an Activity
When you track time, you have to associate the time you work with the activities you
perform. The next step in setting up time tracking is to add one or more activities.
Activities in Timer share most of the fields you find in the Time/Enter Single Activity
dialog box (see page 172 in your copy of QuickBooks 2015: The Missing Manual), which
should come as no surprise if you expect to import Timer records into QuickBooks.
F-6
QUICKBOOKS 2015: THE MISSING MANUAL
USING TIMER
TO TRACK TIME
Here’s how to create an activity:
1. In the Timer window, click New Activity.
The New Activity dialog box opens with the Date box automatically set to today.
If you intend to use Timer as a stopwatch, the Date box has to contain today’s
date, but if you’re creating an activity for work you’ve already done, then choose
the date when you did the work.
2. In the Your Name drop-down list, choose your name.
This list sorts names in alphabetical order, jumbling employees, vendors, and
names from the Other Names List into one long alphabetical list.
NOTE If your name doesn’t appear in the Your Name drop-down list, you can’t add it to the list unless you’re
also the person who exported name lists from QuickBooks. Tell the person who sent Timer to you that your name is
missing from the QuickBooks company file and ask for a new export file of QuickBooks lists with your name in it.
3. In the New Activity dialog box, fill in the fields for the activity.
As you can see in Figure F-2, this step mostly involves choosing from drop-down
lists: Customer:Job, Service Item, and Class. If you don’t see the Service item
or class you want to use, ask for a new export file.
FIGURE F-2
Knowing which choice
is correct in some of the
lists may not be obvious
to people outside the
Accounting Department.
If you don’t know which
Customer:Job, Service
item, or class to choose,
ask the person who reviews your time records.
TIP You can export new customers you create in Timer along with your time. So if you perform work for a
customer who doesn’t appear in Timer’s lists, choose View→Customer:Job List. In the dialog box that opens,
click Add Customer; in the Contact Information dialog box, fill in at least the Customer box, and then click OK.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-7
USING TIMER
TO TRACK TIME
4. If the activity isn’t billable, turn off the Billable checkbox.
Timer automatically turns on this checkbox, so you have to change this setting
only when time isn’t billable.
5. If you want to describe the activity in more detail, type that info in the
Notes box.
QuickBooks imports these notes into the Notes field in its time records (page
173 in QuickBooks 2015: The Missing Manual).
6. Click Next to create another activity.
If you’re done creating activities, click OK to return to the Timer window.
Entering Time
After you’ve set up at least one activity, you can time your work or type in hours that
you’ve already worked. To record time either way, you first have to select an activity.
In the Timer window’s Current Activity drop-down list, activities appear under two
headings, as shown in Figure F-3. (The box on page F-10 explains how to alter this
behavior.) Here’s how to decide which activity to choose:
• Activity Templates. Every time you create a new activity (page F-7), Timer
adds it to the Activity Templates list. When you want to track time for that
activity, click its name under the Activity Templates heading, and the program
adds it under the Today’s Activities heading. Activity templates remain on the
Current Activity drop-down menu for the length of time you specify in Timer’s
preferences, as the box on page F-10 explains.
FIGURE F-3
The Timer window’s Current Activity drop-down
list displays the activities
you create under both
Today’s Activities and
Activity Templates headings. Today’s Activities
represent (not surprisingly) the activities you’re
working on today. Activity
Templates are activities
that you can choose when
you spend time on them.
• Today’s Activities. If you want to record time for an activity that you’ve already
worked on today, choose it under this heading.
F-8
QUICKBOOKS 2015: THE MISSING MANUAL
NOTE When you start Timer each day, your Today’s Activities list is empty and the Current Activity box
displays the text “Select an Activity Template from this list or click ‘New Activity.’” To work on an existing activity,
choose its name under the Activity Templates heading; Timer starts a new record for that activity with today’s
date and adds it under the Today’s Activities heading. If you’re starting an activity you’ve never worked on before,
click New Activity.
USING TIMER
TO TRACK TIME
STOPWATCH TIMING
In the Timer window, when you select an activity, you’ll see one of three buttons,
as shown in Figure F-4.
FIGURE F-4
Top: If you haven’t
recorded any time for
the current activity,
click the Start button. If
you choose an activity
that already has some
recorded time, the button
is labeled “Resume”
instead.
Middle: When you click
Start, the colon between
the hours and minutes
numbers begins blinking
and, in the Current
Activity box, “-Timing-”
appears at the end of
the line, as shown here.
(Because the elapsed
time shows only hours
and minutes, the initial
00:00 won’t change until
one minute has passed.)
Also, the Start button
changes to read “Stop”;
click it when you want to
pause timing or you’ve
completed the activity.
Bottom: If you clicked
Stop, you can continue
timing where you left off
by clicking Resume.
TIP You can also pause timing on an activity by choosing a different activity in the Current Activity drop-down
list. During a single workday, switching activities automatically pauses the current activity. To add more time to
an activity, select it in the Today’s Activities list, and then click Resume.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-9
USING TIMER
TO TRACK TIME
TYPING IN TIME
If you want to record time after the fact, in the Current Activity drop-down list, choose
an activity, and then click Edit Activity. In the Edit Activity dialog box’s Duration field,
type the hours and minutes you devoted to that project. (You can type the time as
hours and minutes or as a decimal.) Click OK to finish up.
TIP If you like Timer’s stopwatch feature but want the program’s window to be smaller, then click the button
with the two-window icon (it’s to the right of the Start/Stop/Resume button). When you do, the Timer window
shrinks to show only the elapsed time, the Edit button, the Start/Stop/Resume button, and the Window button.
Click the Window button again to bring back the full Timer window.
POWER USERS’ CLINIC
Customizing Timer
QuickBooks Pro Timer is relatively set in its ways, but you can
tweak a few preferences:
• The most helpful preference is Default Name, which lets
you set the name that the program automatically adds
to the Your Name box. In the Timer window, choose
File→Preferences→Default Name. In the Choose a
Default Name dialog box that opens, choose your name,
and then click OK.
• If you usually work on billable activities, then in the
Choose a Default Name dialog box, turn on the “Time
defaults to billable” checkbox. If you’re a staff person
who always works on overhead activities, leave this
checkbox turned off.
• To keep your list of activities manageable, you can set
the number of days that Timer keeps activity templates:
choose File→ Preferences→“Number of days to
remember activities.” For example, if you work on the
same task for several weeks, you might set the number
of days to 60. On the other hand, if you rarely work for
the same customer from day to day, choose a low number,
such as 5.
• The program automatically turns on the “Show time when
minimized” preference, which is a setting you’re unlikely
to change. With it turned on, when you minimize the Timer
window, the button in the Windows taskbar includes
the label “Timer” and the current elapsed time for the
activity being timed.
• Because it’s such a simple program, Timer’s one-time
messages (about stuff like how it transfers info between
its files and QuickBooks) are more annoying than they
are helpful. But if you want to see those messages
again, choose File→Preferences→“Turn on all one
time messages.”
Creating an Export File of Your Time
If you’re tracking time, the company you work for probably wants you to submit
your time records on a regular schedule. The most common reporting period is
weekly, but you might have to send in your time daily, every other week, or only
when you’ve completed an activity.
You want to be sure you’re exporting the correct information, particularly when your
paycheck depends on the time you’ve worked. In Timer, you can review, correct, and
export your time all from the same dialog box. Here’s how:
F-10
QUICKBOOKS 2015: THE MISSING MANUAL
1. In the Timer window, choose View→Time Activity Log.
The Time Activity Log window (Figure F-5) opens, where you can review and
correct your time. To review the time you plan to export, in the Dates drop-down
list, choose a date range, such as This Week. If you want to choose From and To
dates instead, then in the Dates drop-down list, choose Custom.
USING TIMER
TO TRACK TIME
FIGURE F-5
The Time Activity Log
window lists all the
activities for the selected
date range, and its Total
Time field shows the total
hours for all the activities
displayed. If an activity
is missing, click the New
button and then add the
activity and its time. To
correct an activity, select
it and then click Edit. To
remove an activity that
you added by mistake,
select it and then click
Delete.
2. Select the activities you want to export.
To select all the activities shown in the dialog box, click Select All. If you exported
time earlier today, choose the activities you’ve worked on since then. If you want
to select some of the activities, hold down the Ctrl key as you click each one in
the list. To select contiguous activities, hold down the Shift key while you click
the first and last activities.
3. Click Export.
If you see a window with one of those one-time messages showing how data
transfers back and forth, just click Continue. The Export Time Activities dialog
box appears.
4. In the Export Time Activities dialog box, choose the option for the time
you want to export.
If you selected activities in the Time Activity Log window, Timer automatically
chooses the “Selected activities” option. To export all activities through a
specific date, choose the “All unexported time activities through” option, and
then choose the date.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-11
IMPORTING
WORKERS’
TIME INTO
QUICKBOOKS
5. Click OK to open the Create Export File dialog box; navigate to the folder
where you want to save your time export file and then, in the “File name”
box, type a name for the file.
Save the export file in a folder reserved for time-export files. Include your name
and the export date in the filename.
6. Click OK.
When you see the message telling you that the export succeeded, click OK.
Back in the Time Activity Log window, the Export Status column now displays
the word “Exported” for all the activities that you included in the export file.
NOTE If you export activities during the day, Today’s Activities are still available for the rest of the day.
To keep your records straight, use Activity Templates to create new activities if you continue to work after the
export. That way, you can export again to export the additional time you worked.
7. Send the export file to the person who imports data into QuickBooks.
Time export files are usually quite small, so email is the easiest way to send them.
Importing Workers’ Time into QuickBooks
After you distribute Timer (and the lists needed to run it), you’ll begin receiving data
files containing the time people tracked with the program. Your mission: Move that
time data into your company file.
Importing the time files that people send you is easy, particularly if you store all
the time files in one folder on your computer. Here’s how to import time data as
efficiently as possible:
1. As you receive time files (by email or on a CD or USB thumb drive), copy
them into a folder you’ve created specifically for such files.
Create a folder for people’s exported time files where you store other company
data. For example, if you have a folder for your QuickBooks company file, create
a subfolder for time-related files there, such as \Shared Documents\Company
File\Timer Files.
2. Back up your company file (see page 495).
If you run into any problems while importing time data, you can restore the
backup copy and try again.
3. Choose File→Utilities→Import→Timer Activities.
If you see a diagram of the path that data takes between Timer and QuickBooks
in the “Import Activities from Timer” dialog box, turn on the “Don’t display this
message in the future” checkbox before you click OK to begin importing a file.
F-12
QUICKBOOKS 2015: THE MISSING MANUAL
4. In the Import dialog box, navigate to the folder with the time-related files.
The next time you import people’s time records, QuickBooks automatically
opens the Import dialog box to the folder you chose the previous time. So as
long as you continue to store time files in the same folder, you have to perform
this step only during the first import.
IMPORTING
WORKERS’
TIME INTO
QUICKBOOKS
5. Double-click the file you want to import (you can only import one at a time).
After QuickBooks imports the data, it displays the QB Pro Timer Import Summary, which shows how many activities it imported.
6. Click View Report to see the details of the imported transactions.
The report groups time transactions first by customer or job and then by Service
item. Each time entry in the report includes the date, person’s name, the date
imported, and the number of hours.
Although QuickBooks has already loaded the time records into your company
file, it’s a good idea to review the Timer Import Detail report. If you spot an
obvious typo such as 26 work hours in one day, you can correct the activity in
QuickBooks (see page 167 in the print edition of this book).
Also, keep watch for list changes your employees might have made—even if they
were made by mistake. For example, if an employee created a new customer,
QuickBooks imports those into the lists in your company file. If you find changes
like these, make sure the entries are correct or fill in missing information.
7. In the QB Pro Timer Import Summary dialog box, click Close.
You’re done!
After you import time, it looks the same as time entered in QuickBooks using the
Weekly Timesheet or Time/Enter Single Activity dialog boxes.
Appendix F: Tracking Time with the Standalone QuickBooks Pro Timer
F-13
Open as PDF
Similar pages