Lab 1.2.4 Converting RIP v1 to RIP v2 – 2500 Series

Lab 1.2.4 Converting RIP v1 to RIP v2 – 2500 Series
Objective
•
Configure RIP v1 on routers.
•
Convert to RIP v2 on routers.
Background/Preparation
Cable a network similar to the shown in the diagram. Any router that meets the interface
requirements displayed on the above diagram may be used. For example, router series 800, 1600,
1700, 2500 and 2600 or any such combination can be used. Please refer to the chart at the end of
the lab to correctly identify the interface identifiers to be used based on the equipment in the lab. The
configuration output used in this lab is produced from 1721 series routers. Any other router used may
produce slightly different output. Perform the following steps on each router unless specifically
instructed otherwise.
Start a HyperTerminal session as performed in the Establishing a HyperTerminal session lab.
Note: Go to the erase and reload instructions at the end of this lab. Perform those steps on all
routers in this lab assignment before continuing.
Step 1 Configure the routers
On the routers, configure the hostnames as well as the console, virtual terminal, and enable secret
passwords. Next configure the serial IP address and clock rate and the Fast Ethernet IP address
interfaces. Finally configure IP host names. If there are problems performing the basic configuration,
refer to the “Review of Basic Router Configuration with RIP” lab. Optional interface descriptions and
message of the day banners may also be configured. Be sure to save the configurations just created.
Router 1
Router>enable
Router#configure terminal
Router(config)#hostname GAD
29 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
GAD(config)#enable secret class
GAD(config)#line console 0
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#line vty 0 4
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#exit
GAD(config)#interface serial 0
GAD(config-if)#ip address 172.17.0.1 255.255.0.0
GAD(config-if)#clock rate 64000
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD(config)#interface ethernet 0
GAD(config-if)#ip address 172.16.0.1 255.255.0.0
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD(config)#ip host BMH 172.18.0.1 172.17.0.2
Router 2
Router>enable
Router#configure terminal
Router(config)#hostname BHM
BHM(config)#enable secret class
BHM(config)#line console 0
BHM(config-line)#password cisco
BHM(config-line)#login
BHM(config-line)#line vty 0 4
BHM(config-line)#password cisco
BHM(config-line)#login
BHM(config-line)#exit
BHM(config)#interface serial 0
BHM(config-if)#ip address 172.17.0.2 255.255.0.0
BHM(config-if)#no shutdown
BHM(config-if)#exit
BHM(config)#interface ethernet 0
BHM(config-if)#ip address 172.18.0.1 255.255.0.0
BHM(config-if)#no shutdown
BHM(config-if)#exit
BHM(config)#ip host GAD 172.16.0.1 172.17.0.1
Step 2 Configure the routing protocol on the GAD router
Go to the proper command mode and configure RIP routing on the GAD router according to the
chart.
GAD(config)#router rip
GAD(config-router)#network 172.16.0.0
GAD(config-router)#network 172.17.0.0
GAD(config-router)#exit
GAD(config)#exit
Step 3 Save the GAD router configuration
Any time that changes are correctly made to the running configuration, they should be saved to the
startup configuration. Otherwise, if the router is reloaded or power cycled, the changes that are not
saved in the startup configuration will be lost.
GAD#copy running-config startup-config
30 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Destination filename [startup-config]?[Enter]
Step 4 Configure the routing protocol on the BHM router
Go to the proper command mode and configure RIP routing on the BHM router according to the
chart.
BHM(config)#router rip
BHM(config-router)#network 172.18.0.0
BHM(config-router)#network 172.17.0.0
BHM(config-router)#exit
BHM(config)#exit
Step 5 Save the BHM router configuration
BHM#copy running-config startup-config
Destination filename [startup-config]?[Enter]
Step 6 Configure the hosts with the proper IP address, subnet mask, and default gateway
Host connected to
IP Address:
Subnet mask:
Default gateway:
router GAD
172.16.0.2
255.255.0.0
172.16.0.1
Host connected to
IP Address:
Subnet mask:
Default gateway:
router BHM
172.18.0.2
255.255.0.0
172.18.0.1
Step 7 Verify that the internetwork is functioning by pinging the FastEthernet interface of
the other router
a. From the host attached to GAD, ping the other host attached to the BHM router. Was the ping
successful? Yes
b. From the host attached to BHM, ping the other host attached to the GAD router. Was the ping
successful? Yes
a. If the answer is no for either question, troubleshoot the router configurations to find the error.
Then do the pings again until the answer to both questions is yes.
Step 8 Enable RIP version 2 routing
a.
Enable version 2 of the RIP routing protocol on both of the routers GAD and BHM.
GAD(config)#router rip
GAD(config-router)#version 2
GAD(config-router)#exit
GAD(config)#exit
BHM(config)#router rip
BHM(config-router)#version 2
BHM(config-router)#exit
BHM(config)#exit
Step 9 Ping all of the interfaces on the network from each host
a. Were all of the interfaces still able to be pinged? Yes
b. If not, troubleshoot the network and ping again.
31 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Once the previous steps are completed, logoff by typing exit, and turn the router off. Then remove
and store the cables and adapter.
32 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Erasing and reloading the router
Enter into the privileged EXEC mode by typing enable.
Router>enable
If prompted for a password, enter class. If that does not work, ask the instructor for assistance.
At the privileged EXEC mode, enter the command erase startup-config.
Router#erase startup-config
The responding line prompt will be:
Erasing the nvram filesystem will remove all files! Continue?
[confirm]
Press Enter to confirm.
The response should be:
Erase of nvram: complete
Now at the privileged EXEC mode, enter the command reload.
Router#reload
The responding line prompt will be:
System configuration has been modified. Save? [yes/no]:
Type n and then press Enter.
The responding line prompt will be:
Proceed with reload? [confirm]
Press Enter to confirm.
In the first line of the response will be:
Reload requested by console.
After the router has reloaded the line prompt will be:
Would you like to enter the initial configuration dialog? [yes/no]:
Type n and then press Enter.
The responding line prompt will be:
Press RETURN to get started!
Press Enter.
Now the router is ready for the assigned lab to be performed.
33 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Router Interface Summary
Ethernet
Ethernet
Serial
Serial
Interface #1
Interface #2
Interface #1
Interface #2
800 (806)
Ethernet 0 (E0)
Ethernet 1 (E1)
1600
Ethernet 0 (E0)
Ethernet 1 (E1)
Serial 0 (S0)
Serial 1 (S1)
1700
FastEthernet 0 (FA0)
FastEthernet 1 (FA1)
Serial 0 (S0)
Serial 1 (S1)
2500
Ethernet 0 (E0)
Ethernet 1 (E1)
Serial 0 (S0)
Serial 1 (S1)
FastEthernet 0/0
2600
FastEthernet 0/1 (FA0/1) Serial 0/0 (S0/0) Serial 0/1 (S0/1)
(FA0/0)
In order to find out exactly how the router is configured, look at the interfaces. This will identify what type and how
many interfaces the router has. There is no way to effectively list all of the combinations of configurations for
each router class. What is provided are the identifiers for the possible combinations of interfaces in the device.
This interface chart does not include any other type of interface even though a specific router may contain one.
An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in IOS command to represent the interface.
Router Model
34 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Lab 1.2.4 Converting RIP v1 to RIP v2 – 2600 Series
Objective
•
Configure RIP v1 on routers.
•
Convert to RIP v2 on routers.
Background/Preparation
Cable a network similar to the shown in the diagram. Any router that meets the interface
requirements displayed on the above diagram may be used. For example, router series 800, 1600,
1700, 2500 and 2600 or any such combination can be used. Please refer to the chart at the end of
the lab to correctly identify the interface identifiers to be used based on the equipment in the lab. The
configuration output used in this lab is produced from 1721 series routers. Any other router used may
produce slightly different output. Perform the following steps on each router unless specifically
instructed otherwise.
Start a HyperTerminal session as performed in the Establishing a HyperTerminal session lab.
Note: Go to the erase and reload instructions at the end of this lab. Perform those steps on all
routers in this lab assignment before continuing.
Step 1 Configure the routers
On the routers, configure the hostnames as well as the console, virtual terminal, and enable secret
passwords. Next configure the serial IP address and clock rate and the Fast Ethernet IP address
interfaces. Finally configure IP host names. If there are problems performing the basic configuration,
refer to the “Review of Basic Router Configuration with RIP” lab. Optional interface descriptions and
message of the day banners may also be configured. Be sure to save the configurations just created.
Router 1
Router>enable
Router#configure terminal
Router(config)#hostname GAD
35 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
GAD(config)#enable secret class
GAD(config)#line console 0
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#line vty 0 4
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#exit
GAD(config)#interface serial 0/0
GAD(config-if)#ip address 172.17.0.1 255.255.0.0
GAD(config-if)#clock rate 64000
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD(config)#interface fastEthernet 0/0
GAD(config-if)#ip address 172.16.0.1 255.255.0.0
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD(config)#ip host BMH 172.18.0.1 172.17.0.2
Router 2
Router>enable
Router#configure terminal
Router(config)#hostname BHM
BHM(config)#enable secret class
BHM(config)#line console 0
BHM(config-line)#password cisco
BHM(config-line)#login
BHM(config-line)#line vty 0 4
BHM(config-line)#password cisco
BHM(config-line)#login
BHM(config-line)#exit
BHM(config)#interface serial 0/0
BHM(config-if)#ip address 172.17.0.2 255.255.0.0
BHM(config-if)#no shutdown
BHM(config-if)#exit
BHM(config)#interface fastEthernet 0/0
BHM(config-if)#ip address 172.18.0.1 255.255.0.0
BHM(config-if)#no shutdown
BHM(config-if)#exit
BHM(config)#ip host GAD 172.16.0.1 172.17.0.1
Step 2 Configure the routing protocol on the GAD router
Go to the proper command mode and configure RIP routing on the GAD router according to the
chart.
GAD(config)#router rip
GAD(config-router)#network 172.16.0.0
GAD(config-router)#network 172.17.0.0
GAD(config-router)#exit
GAD(config)#exit
Step 3 Save the GAD router configuration
Any time that changes are correctly made to the running configuration, they should be saved to the
startup configuration. Otherwise, if the router is reloaded or power cycled, the changes that are not
saved in the startup configuration will be lost.
GAD#copy running-config startup-config
36 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Destination filename [startup-config]?[Enter]
Step 4 Configure the routing protocol on the BHM router
Go to the proper command mode and configure RIP routing on the BHM router according to the
chart.
BHM(config)#router rip
BHM(config-router)#network 172.18.0.0
BHM(config-router)#network 172.17.0.0
BHM(config-router)#exit
BHM(config)#exit
Step 5 Save the BHM router configuration
BHM#copy running-config startup-config
Destination filename [startup-config]?[Enter]
Step 6 Configure the hosts with the proper IP address, subnet mask, and default gateway
Host connected to
IP Address:
Subnet mask:
Default gateway:
router GAD
172.16.0.2
255.255.0.0
172.16.0.1
Host connected to
IP Address:
Subnet mask:
Default gateway:
router BHM
172.18.0.2
255.255.0.0
172.18.0.1
Step 7 Verify that the internetwork is functioning by pinging the FastEthernet interface of
the other router
a. From the host attached to GAD, ping the other host attached to the BHM router. Was the ping
successful? Yes
b. From the host attached to BHM, ping the other host attached to the GAD router. Was the ping
successful? Yes
c.
If the answer is no for either question, troubleshoot the router configurations to find the error.
Then do the pings again until the answer to both questions is yes.
Step 8 Enable RIP version 2 routing
a. Enable version 2 of the RIP routing protocol on both of the routers GAD and BHM.
GAD(config)#router rip
GAD(config-router)#version 2
GAD(config-router)#exit
GAD(config)#exit
BHM(config)#router rip
BHM(config-router)#version 2
BHM(config-router)#exit
BHM(config)#exit
Step 9 Ping all of the interfaces on the network from each host
a. Were all of the interfaces still able to be pinged? Yes
b. If not, troubleshoot the network and ping again.
37 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Once the previous steps are completed, logoff by typing exit, and turn the router off. Then remove
and store the cables and adapter.
38 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Erasing and reloading the router
Enter into the privileged EXEC mode by typing enable.
Router>enable
If prompted for a password, enter class. If that does not work, ask the instructor for assistance.
At the privileged EXEC mode, enter the command erase startup-config.
Router#erase startup-config
The responding line prompt will be:
Erasing the nvram filesystem will remove all files! Continue?
[confirm]
Press Enter to confirm.
The response should be:
Erase of nvram: complete
Now at the privileged EXEC mode, enter the command reload.
Router#reload
The responding line prompt will be:
System configuration has been modified. Save? [yes/no]:
Type n and then press Enter.
The responding line prompt will be:
Proceed with reload? [confirm]
Press Enter to confirm.
In the first line of the response will be:
Reload requested by console.
After the router has reloaded the line prompt will be:
Would you like to enter the initial configuration dialog? [yes/no]:
Type n and then press Enter.
The responding line prompt will be:
Press RETURN to get started!
Press Enter.
Now the router is ready for the assigned lab to be performed.
39 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Router Interface Summary
Ethernet
Ethernet
Serial
Serial
Interface #1
Interface #2
Interface #1
Interface #2
800 (806)
Ethernet 0 (E0)
Ethernet 1 (E1)
1600
Ethernet 0 (E0)
Ethernet 1 (E1)
Serial 0 (S0)
Serial 1 (S1)
1700
FastEthernet 0 (FA0)
FastEthernet 1 (FA1)
Serial 0 (S0)
Serial 1 (S1)
2500
Ethernet 0 (E0)
Ethernet 1 (E1)
Serial 0 (S0)
Serial 1 (S1)
FastEthernet 0/0
2600
FastEthernet 0/1 (FA0/1) Serial 0/0 (S0/0) Serial 0/1 (S0/1)
(FA0/0)
In order to find out exactly how the router is configured, look at the interfaces. This will identify what type and how
many interfaces the router has. There is no way to effectively list all of the combinations of configurations for
each router class. What is provided are the identifiers for the possible combinations of interfaces in the device.
This interface chart does not include any other type of interface even though a specific router may contain one.
An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in IOS command to represent the interface.
Router Model
40 - 577
CCNA 3: Switching Basics and Intermediate Routing v 3.1 - Lab 1.1.4
Copyright  2003, Cisco Systems, Inc.
Download PDF
Similar pages