Cisco 3640 Series Router-PBX Interoperability:
VIC 2BRI-NT/TE card to Alcatel 4400 PBX with
BRI ISDN QSIG Signaling
This document describes the interoperability and configuration of a Cisco 3640 series router with a VIC
2BRI-NT/TE card to an Alcatel 4400 PBX using BRI ISDN QSIG signaling. It includes the following
sections:
•
•
•
System Components
Configuration Tasks
Caveats
System Components
PBX Model
PBX Release
Telephony Signaling
Voice Gateway
Gateway Release
VoX Protocol
Alcatel 4400
R3.2
BRI ISDN QSIG
Cisco 3640 series router
Cisco IOS Release 12.2(1a)
H.323
Configuration Tasks
See the following sections for configuration tasks for this feature:
• Set Up
• Alcatel PBX Configuration
• Cisco 3640 Series Router Configuration
Page 1
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Set Up
This section includes the following information:
• Connectivity Diagrams
• Set Up Notes
Connectivity Diagrams
Figure 1: Test Configuration
Basic Call Setup End-to-End Configuration
PBX1: Alcatel 4400,
slot3
ISDN Type:
ISDN Type:
E1-QSIG
E1-QSIG
7206VXR_A
Phone A
x3001
PBX2: Alcatel 4400,
slot 4
7206VXR_B
Phone C
x3000
VoIP
PBX #1
PBX #2
Phone E
x N/A
Phone B
x3002
Phone F
x N/A
Phone D
x3003
Figure 1 represents the configuration used for testing: an Alcatel 4400PBX connected to a Cisco 3640
series router through an E1-QSIG connection.
Set Up Notes
The Cisco 3640 router with ISDN switch type setting of basic-qsig supports both protocol sides by using
the isdn protocol-emulate network/user command.
• The Alcatel 4400 supports both “USER” (slave) and “NETWORK” (master) protocol sides.
• The following options are of particular interest:
• Trunk interface type must be set to BRA2.
• Network/User options are set in the Board/Digital Access Options menu. Network mode must be
set to Yes for Master/Network or No for Slave/User.
• Access Type must be set to T0.
• Q931 signal variant is used to determine Protocol type. This option was set to ISDN ABC-F.
The Alcatel 4400 PBX configuration screen for the BRI trunk interface is reached using both Alcatel Board
and Board\Digital Access menus, setting the BRI physical layer parameters.
Page 2
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Alcatel PBX Configuration
Alcatel PBX Version Information
•
•
Software: Version R3.2
Hardware: BRA2, 3BA23076.
Version Information
\compidea\Node
Node Number (reserved)
Software Version
Version name
Patch No.
Notes
Object Identity
Node Number (reserved)
Ethernet Notes
Netmask
Local CPU
Name
IP Address
Twin Cpu
Name
IP Address
Main Cpu
Name
IP Address
StandBy Cpu
Name
IP Address
SL Notes
IP/X25 Tunnel Notes
Netmask
Local Node
Name
IP Address
1
R3.2
c1.712
5
1
x000000_tun
172.30.253.253
xm000000
10.253.253.3
255.255.0.0
x000000_tun
172.30.253.253
Alcatel PBX Sample Configuration
See the following sections for sample configuration information:
•
•
•
•
Trunk Cards Were Configured the Same
Digital Access Options
Trunk Group
Trunk Detail
Page 3
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Trunk Cards Were Configured the Same
Interface type must be set to BRA2.
\compidea\Shelf::0\Board::9
Board Address
Interface Type
Usage State
Operational State
Main/Standby State
Number Of Sets Being Connect.
Country Protocol Type
Incidents Teleservice
ISDN Board Layer 2 Parameters
Retransmission Timer
TEI Identity Check Timer
Polling Timer
Nb_Of_Retransmission
Max Frame Size (Bytes)
Window Size In Frames SAPI
Window Size In Frames SAPI
Window Size In Frames SAPI
Window Size In Frames SAPI
9
BRA2
Active
Enabled
Main (Master)
1
Default
YES
S
P
S
P
T0
T0
T2
T2
100
100
1000
3
260
1
3
7
7
Digital Access Options
Network mode must be set to Yes for Master/Network or No for Slave/User.
Access Type must be set to T0.
\compidea\Shelf::0\Board::9\Digital Access::2
T0/T2 Access No.
Access Type
Synchronisation Priority
Network Mode
Max Nb Of Used B Channels
Max_Nb_Of_Compressed_B_Channels
TieLine Mode
Access Type S0
Reserved1
Reserved2
Network Date Time Update
2
T0
255
NO
2
0
NO
NO
NO
NO
NO
Trunk Group
Q931 signal variant is used to determine Protocol type. ISDN ABC-F is Alcatel proprietary.
\compidea\Trunk Groups::8
Trunk Group Id
Trunk Group Type
Trunk Group Name
Node number
Transcom Trunk Group
Auto.reserv.by Attendant
Overflow trunk group No.
Tone on seizure
8
T0
BRI-ABC-F
1
False
False
-1
True
Page 4
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Private Trunk Group
Security Patrol
Q931 signal variant
Number Compatible With
Number Of Digits To Send
Remote Network
Shared Trunk Group
auto.DTMF dialing on outgoing call
Public Network Category
DDI transcoding
Special Services
Can support UUS in SETUP
False
False
ABC-F
-1
4
15
False
NO
0
False
Nothing
True
Trunk Detail
\compidea\Trunk Groups::8\Trunk Group::1
Instance (reserved)
Trunk Group Type
Public Network Ref.
Dialling end to end
DTMF end to end signal.
Trunk group used in DISA
DISA Secret Code
VG for non-existent No.
Routing To Executive
Trunk Category Id
Nb of digits unused (ISDN)
B Channel Choice
Channels Reserved By Attend.
Dissuasion For ACD
DTO joining
Enquiry Call On B Channel
Automated Attendant
Calling party Rights category
Entity Number
TS Overflow
Number To Be Added
Supervised by Routing
VPN Cost Limit for Incom.Calls
Immediat Trk Listening For VPNCall
VPN TS %
Csta Monitored
Max.% of trunks out CCD
Charge Calling And ADN Creation
Ratio analog.to ISDN tax
TS Distribution on Accesses
Use Split Acces
Heterogeneous Remote Network
Barring mode
ARS class of service
Quality profile for voice on IP
IP compression type
Use of volume in system
1
T0
NO
NO
NO
YES
NO
18
4
YES
0
NO
NO
NO
NO
0
0
YES
NO
0
YES
50
NO
0
NO
YES
NO
NO
Not barred
31
Profile #1
Default
YES
Page 5
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Cisco 3640 Series Router Configuration
The following is the configuration of the Cisco 3640 series router connected to the Alcatel 4400 ISDN BRI
ISDN QSIG signaling interface.
•
•
Cisco 3640 Series Router Version Information
Cisco 3640 Series Router Sample Configuration
Cisco 3640 Series Router Version Information
•
•
Cisco IOS™ (C3640-JS-M), Version 12.2(1a).
Cisco 3640 (R4700) processor (revision 0x00) with 59392K/6144K bytes of f memory.
3640_B#
3640_B#sho ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-JS-M), Version 12.2(1a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Sat 26-May-01 02:40 by pwade
Image text-base: 0x60008950, data-base: 0x61492000
ROM: System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT RELEASE SOFTWARE
(fc2)
3640_B uptime is 1 hour, 21 minutes
System returned to ROM by power-on
System image file is "flash:c3640-js-mz.122-1a.bin"
cisco 3640 (R4700) processor (revision 0x00) with 59392K/6144K bytes of memory.
Processor board ID 05247801
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.1.
Basic Rate ISDN software, Version 1.1.
2 Ethernet/IEEE 802.3 interface(s)
31 Serial network interface(s)
2 ISDN Basic Rate interface(s)
2 Channelized E1/PRI port(s)
2 Voice FXS interface(s)
4 Voice NT or TE BRI interface(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102
3640_B#
3640_B#
Cisco 3640 Series Router Sample Configuration
The following is a sample configuration of the Cisco 3640 series router directly connected to Alcatel 4400
PBX, slot 3 ISDN PRI interface.
3640_B#
3640_B#sho diag
Slot 0:
Combo 2E, 2W Port adapter, 4 ports
Port adapter is analyzed
Page 6
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.2
Board revision
Serial number
7687847
Part number
Test history
0x0
RMA number
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 1E 01 02 00 75 4E A7 50 04 93 04 00
0x30: 58 00 00 00 98 02 28 17 FF FF FF FF FF
00 00 00
FF FF FF
High Density Voice Port adapter
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware Revision
: 1.0
Top Assy. Part Number
: 800-03567-01
Board Revision
: A0
Deviation Number
: 0-0
Fab Version
: 02
PCB Serial Number
: JAB03350B9K
RMA Test History
: 00
RMA Number
: 0-0-0-0
RMA History
: 00
EEPROM format version 4
EEPROM contents (hex):
0x00: 04 FF 40 00 CC 41 01 00 C0 46 03
0x10: 42 41 30 80 00 00 00 00 02 02 C1
0x20: 33 33 35 30 42 39 4B 03 00 81 00
0x30: FF FF FF FF FF FF FF FF FF FF FF
0x40: FF FF FF FF FF FF FF FF FF FF FF
0x50: FF FF FF FF FF FF FF FF FF FF FF
0x60: FF FF FF FF FF FF FF FF FF FF FF
0x70: FF FF FF FF FF FF FF FF FF FF FF
0D
41
00
FF
FF
FF
FF
FF
B0
800-01171-04
00-00-00
Slot 1:
20
8B
00
FF
FF
FF
FF
FF
00
4A
00
FF
FF
FF
FF
FF
WIC Slot 0:
E1 (2 Port) Multi-Flex Trunk WAN Daughter Card
Hardware revision 1.0
Board revision
Serial number
18779824
Part number
Test history
0x0
RMA number
Connector type
PCI
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 23 01 00 01 1E 8E B0 50 11 7F 01 00
0x30: 58 00 00 00 00 02 25 00 FF FF FF FF FF
EF
42
04
FF
FF
FF
FF
FF
01
30
00
FF
FF
FF
FF
FF
B0
800-04479-01
00-00-00
00 00 00
FF FF FF
HDV firmware: Compiled Wed 04-Oct-00 20:58 by mani
HDV memory size 524280 heap free 180601
Slot 2:
4 PORT Voice PM for MARs Port adapter
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.1
Board revision
Serial number
15077168
Part number
Test history
0x0
RMA number
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 65 01 01 00 E6 0F 30 50 09 BB 02 00
0x30: 68 00 00 00 99 07 31 17 FF FF FF FF FF
WIC Slot 0:
FXS Voice daughter card (2 port)
Hardware revision 1.1
Board revision
Serial number
14674684
Part number
Test history
0x0
RMA number
Connector type
Wan Module
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 0E 01 01 00 DF EA FC 50 09 BD 01 00
0x30: 78 00 00 00 99 07 12 01 FF FF FF FF FF
D0
800-02491-02
00-00-00
00 00 00
FF FF FF
F0
800-02493-01
00-00-00
00 00 00
FF FF FF
Page 7
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
Slot 3:
4 PORT Voice PM for MARs Port adapter
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.1
Board revision
Serial number
25140072
Part number
Test history
0x0
RMA number
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 65 01 01 01 7F 9B 68 50 09 BB 02 00
0x30: 88 00 00 00 01 02 15 17 FF FF FF FF FF
WIC Slot 0:
NT or TE BRI Voice daughter card (2 port)
Hardware revision 1.255
Board revision
Serial number
4294967295
Part number
Test history
0xFF
RMA number
Connector type
PCI
EEPROM format version 1
EEPROM contents (hex):
0x20: 01 32 01 FF FF FF FF FF FF FF FF FF FF
0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF
H0
800-02491-02
00-00-00
00 00 00
FF FF FF
V7
800-11534335-255
255-255-255
FF FF FF
FF FF FF
3640_B#
3640_B#
3640_B#sho interfaces bri 3/0
BRI3/0 is up, line protocol is up (spoofing)
Hardware is Voice NT or TE BRI
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation VOICE, loopback not set
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 00:00:12
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 48 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
2 packets input, 8 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
3640_B#
3640_B#
3640_B#
3640_B#
3640_B#sho run
Building configuration...
Current configuration : 2259 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname 3640_B
!
boot system flash
logging rate-limit console 10 except errors
!
voice-card 1
Page 8
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
ip host whiz 171.69.1.162
ip host dirt 171.69.1.129
ip host danube 171.69.17.14
!
no ip dhcp-client network-discovery
isdn switch-type basic-qsig
call rsvp-sync
cns event-service server
!
!
!
!
!
!
!
controller E1 1/0
shutdown
framing NO-CRC4
ds0-group 1 timeslots 1 type r2-analog r2-compelled
cas-custom 1
!
controller E1 1/1
shutdown
pri-group timeslots 1-31
!
!
interface Tunnel1
no ip address
!
interface Ethernet0/0
ip address 100.100.100.2 255.255.255.0
no ip mroute-cache
half-duplex
no cdp enable
!
interface Ethernet0/1
ip address 171.69.231.23 255.255.255.0
no ip mroute-cache
half-duplex
no cdp enable
!
interface Serial1/1:15
no ip address
no logging event link-status
shutdown
isdn switch-type primary-net5
isdn overlap-receiving
isdn protocol-emulate network
isdn incoming-voice voice
no isdn T309-enable
isdn T203 30000
isdn T310 60000
isdn bchan-number-order ascending
no cdp enable
!
interface BRI3/0
no ip address
no ip route-cache
no ip mroute-cache
isdn switch-type basic-qsig
isdn overlap-receiving
isdn protocol-emulate network
isdn layer1-emulate network
isdn incoming-voice voice
isdn T310 40000
isdn skipsend-idverify
Page 9
Cisco 3640 Series Router-PBX Interoperability: VIC 2BRI-NT/TE card to Alcatel 4400 PBX with BRI ISDN QSIG Signaling
!
interface BRI3/1
no ip address
isdn switch-type basic-net3
isdn T310 120000
!
ip kerberos source-interface any
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
no cdp run
!
!
voice-port 1/0:1
!
voice-port 1/1:15
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 3/0/0
compand-type a-law
!
voice-port 3/0/1
!
dial-peer cor custom
!
!
!
dial-peer voice 2 pots
destination-pattern 4200
port 2/0/0
!
dial-peer voice 4 voip
destination-pattern 2...
session target ipv4:100.100.100.1
!
dial-peer voice 3 pots
destination-pattern 3...
direct-inward-dial
port 3/0/0
prefix 3
!
dial-peer voice 6 voip
destination-pattern 5...
session target ipv4:100.100.100.1
!
!
line con 0
transport input none
line aux 0
line vty 0 4
no login
!
end
3640_B#
3640_B#
Caveats
•
Calling/Called Number is not shown on Alcatel phone display (one line display phone show Name
only) due to limitation on one line display phone.
Page 10