Implementing IPv6 VPN Provider Edge Transport over MPLS

Implementing IPv6 VPN Provider Edge Transport
over MPLS on Cisco IOS XR Software
IPv6 VPN Provider Edge (6PE) uses the existing MPLS IPv4 core infrastructure for IPv6 transport. 6PE
enables IPv6 sites to communicate with each other over an MPLS IPv4 core network using MPLS label
switched paths (LSPs).
This feature relies heavily on multiprotocol Border Gateway Protocol (BGP) extensions in the IPv4
network configuration on the provider edge (PE) router to exchange IPv6 reachability information (in
addition to an MPLS label) for each IPv6 address prefix. Edge routers are configured as dual-stack,
running both IPv4 and IPv6, and use the IPv4 mapped IPv6 address for IPv6 prefix reachability
exchange.
For detailed information about the commands used to configure L2TP functionality, see Cisco IOS XR
Routing Command Reference.
Feature History for Implementing 6PE on Cisco IOS XR Software
Release
Modification
Release 3.5.0
This feature was introduced on the Cisco XR 12000 Series Router.
Release 3.6.0
No modification.
Release 3.7.0
Support was added for:
•
Cisco CRS-1
•
Inter-AS 6PE
Contents
•
Prerequisites for Implementing 6PE, page MPC-284
•
Information About 6PE, page MPC-284
•
How to Implement 6PE, page MPC-286
•
Configuration Examples for 6PE, page MPC-288
•
Additional References, page MPC-289
Cisco IOS XR MPLS Configuration Guide
OL-15850-02
MPC-283
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
Prerequisites for Implementing 6PE
Prerequisites for Implementing 6PE
The following prerequisites are required to implement 6PE:
•
You must be familiar with MPLS and BGP4 configuration and troubleshooting.
•
You must be in a user group associated with a task group that includes the proper task IDs for MPLS
6PE commands. For detailed information about user groups and task IDs, see the Configuring AAA
Services on Cisco IOS XR Software module of Cisco IOS XR System Security Configuration Guide.
Information About 6PE
To configure the 6PE feature, you should understand the following concepts, which are described in the
following sections:
•
Overview of 6PE, page MPC-284
•
Benefits of 6PE, page MPC-284
•
Deploying IPv6 over MPLS Backbones, page MPC-285
•
IPv6 on the Provider Edge and Customer Edge Routers, page MPC-285
•
IPv6 Provider Edge Multipath, page MPC-286
Overview of 6PE
Multiple techniques are available to integrate IPv6 services over service provider core backbones:
•
Dedicated IPv6 network running over various data link layers
•
Dual-stack IPv4-IPv6 backbone
•
Leveraging of an existing MPLS backbone
These solutions are deployed on service providers’ backbones when the amount of IPv6 traffic and the
revenue generated are in line with the necessary investments and the risks agreed to. Conditions are
favorable for the introduction of native IPv6 service, from the edge, in a scalable way, without any IPv6
addressing restrictions and without putting a well-controlled IPv4 backbone in jeopardy. Backbone
stability is key for service providers that recently stabilized their IPv4 infrastructure.
Service providers running an MPLS/IPv4 infrastructure follow the same trends, as several integration
scenarios are possible to offer IPv6 services on an MPLS network. Cisco Systems specially developed
Cisco 6PE, or, IPv6 Provider Edge Router over MPLS, to meet all of those requirements.
Inter-AS support for 6PE requires support of Border Gateway Protocol (BGP) to enable the address
families and to allocate and distribute the PE and ASBR labels.
Benefits of 6PE
Service providers that currently deploy MPLS will experience the following benefits of Cisco 6PE:
•
Minimal operational cost and risk—No impact on existing IPv4 and MPLS services.
•
Provider edge routers upgrade only—A 6PE router can be an existing PE router or a new one
dedicated to IPv6 traffic.
Cisco IOS XR MPLS Configuration Guide
MPC-284
OL-15850-02
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
Information About 6PE
•
No impact on IPv6 customer edge routers—The ISP can connect to any customer CE running Static,
IGP or EGP.
•
Ready for production services—An ISP can delegate IPv6 prefixes.
•
IPv6 introduction into an existing MPLS service—6PE routers can be added at any time.
•
It is possible to switch up to OC-192 speed in the core.
Deploying IPv6 over MPLS Backbones
Backbones enabled by 6PE (IPv6 over MPLS) allow IPv6 domains to communicate with each other over
an MPLS IPv4 core network. This implementation requires no backbone infrastructure upgrades and no
reconfiguration of core routers, because forwarding is based on labels rather than on the IP header itself.
This provides a very cost-effective strategy for IPv6 deployment.
Additionally, the inherent virtual private network (VPN) and traffic engineering (TE) services available
within an MPLS environment allow IPv6 networks to be combined into VPNs or extranets over an
infrastructure that supports IPv4 VPNs and MPLS-TE.
IPv6 on the Provider Edge and Customer Edge Routers
Service Provider Edge Routers
6PE is particularly applicable to service providers who currently run an MPLS network. One of its
advantages is that there is no need to upgrade the hardware, software, or configuration of the core
network, and it eliminates the impact on the operations and the revenues generated by the existing IPv4
traffic. MPLS is used by many service providers to deliver services to customers. MPLS as a multiservice
infrastructure technology is able to provide layer 3 VPN, QoS, traffic engineering, fast re-routing and
integration of ATM and IP switching.
Customer Edge Routers
Using tunnels on the CE routers is the simplest way to deploy IPv6 over MPLS networks. It has no
impact on the operation or infrastructure of MPLS and requires no changes to the P routers in the core
or to the PE routers. However, tunnel meshing is required as the number of CEs to connect increases,
and it is difficult to delegate a global IPv6 prefix for an ISP.
Figure 22 illustrates the network architecture using tunnels on the CE routers.
Cisco IOS XR MPLS Configuration Guide
OL-15850-02
MPC-285
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
How to Implement 6PE
Figure 22
IPv6 Using Tunnels on the CE Routers
Dual stack
IPv4-IPv6
CE routers
Dual stack
IPv4-IPv6
CE routers
IPv6 over IPv4 tunnels
v6
v6
IPv6
IPv6
PE
P
P
v4
v6
PE
IPv4
OC-48/192
IPv6
v6
v4
IPv6
PE
P
P
PE
IPv4
210608
v4
IPv4
IPv6 Provider Edge Multipath
Internal and external BGP multipath for IPv6 allows the IPv6 router to load balance between several
paths (for example, same neighboring autonomous system (AS) or sub-AS, or the same metric) to reach
its destination. The 6PE multipath feature uses multiprotocol internal BGP (MP-IBGP) to distribute IPv6
routes over the MPLS IPv4 core network and to attach an MPLS label to each route.
When MP-IBGP multipath is enabled on the 6PE router, all labeled paths are installed in the forwarding
table with MPLS information (label stack) when MPLS information is available. This functionality
enables 6PE to perform load balancing.
How to Implement 6PE
This section includes the following implementation procedure:
•
Configuring 6PE, page MPC-286
Configuring 6PE
This task describes how to configure 6PE on PE routers to transport the IPv6 prefixes across the IPv4
cloud.
Be sure to configure 6PE on PE routers participating in both the IPv4 cloud and IPv6 clouds.
Cisco IOS XR MPLS Configuration Guide
MPC-286
OL-15850-02
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
How to Implement 6PE
Note
To learn routes from both clouds, you can use all routing protocols supported on Cisco IOS XR software:
BGP, OSPF, IS-IS, EIGRP, RIP, and Static.
SUMMARY STEPS
1.
configure
2.
router bgp as-number
3.
neighbor ip-address
4.
address-family ipv6 labeled-unicast
5.
exit
6.
exit
7.
address-family ipv6 unicast
8.
allocate-label [all | route-policy policy_name]
9.
end
or
commit
DETAILED STEPS
Step 1
Command or Action
Purpose
configure
Enters global configuration mode.
Example:
RP/0/RP0/CPU0:router# configure
Step 2
router bgp as-number
Enters the number that identifies the autonomous system
(AS) in which the router resides.
Example:
Range for 2-byte numbers is 1 to 65535. Range for 4-byte
numbers is 1.0 to 65535.65535.
RP/0/RP0/CPU0:router(config)# router bgp 1
Step 3
neighbor ip-address
Enters neighbor configuration mode for configuring Border
Gateway Protocol (BGP) routing sessions.
Example:
RP/0/RP0/CPU0:router(config-bgp)# neighbor
1.1.1.1
Step 4
address-family ipv6 labeled-unicast
Specifies IPv6 labeled-unicast address prefixes.
Note
Example:
RP/0/RP0/CPU0:router(config-bgp-nbr)#
address-family ipv6 labeled-unicast
Step 5
exit
This option is also available in IPv6 neighbor
configuration mode and VRF neighbor
configuration mode.
Exits BGP address-family submode.
Example:
RP/0/RP0/CPU0:router(config-bgp-nbr-af)# exit
Cisco IOS XR MPLS Configuration Guide
OL-15850-02
MPC-287
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
Configuration Examples for 6PE
Step 6
Command or Action
Purpose
exit
Exits BGP neighbor submode.
Example:
RP/0/RP0/CPU0:router(config-bgp-nbr)# exit
Step 7
address-family ipv6 unicast
Specifies IPv6 unicast address prefixes.
Example:
RP/0/RP0/CPU0:router(config-bgp)#
address-family ipv6 unicast
Step 8
allocate-label [all | route-policy policy_name]
Allocates MPLS labels for specified IPv4 unicast routes.
Note
Example:
RP/0/RP0/CPU0:router(config-bgp-af)#
allocate-label all
Step 9
The route-policy keyword provides finer control to
filter out certain routes from being advertised to the
neighbor.
Saves configuration changes.
end
or
commit
When you issue the end command, the system prompts
you to commit changes:
Example:
Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
•
RP/0/RP0/CPU0:router(config-bgp-af)# end
or
– Entering yes saves configuration changes to the
RP/0/RP0/CPU0:router(config-bgp-af)# commit
running configuration file, exits the configuration
session, and returns the router to EXEC mode.
– Entering no exits the configuration session and
returns the router to EXEC mode without
committing the configuration changes.
– Entering cancel leaves the router in the current
configuration session without exiting or
committing the configuration changes.
•
Use the commit command to save the configuration
changes to the running configuration file and remain
within the configuration session.
Configuration Examples for 6PE
This section includes the following configuration example:
•
Configuring 6PE on a PE Router: Example, page MPC-288
Configuring 6PE on a PE Router: Example
The following sample configuration shows the configuration of 6PE on a PE router:
interface POS0/3/0/0
ipv6 address 2001::1/64
!
Cisco IOS XR MPLS Configuration Guide
MPC-288
OL-15850-02
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
Additional References
router isis ipv6-cloud
net 49.0000.0000.0001.00
address-family ipv6 unicast
single-topology
interface POS0/3/0/0
address-family ipv6 unicast
!
!
router bgp 55400
bgp router-id 54.6.1.1
address-family ipv4 unicast
!
address-family ipv6 unicast
network 55:5::/64
redistribute connected
redistribute isis ipv6-cloud
!
neighbor 34.4.3.3
remote-as 55400
address-family ipv4 unicast
!
address-family ipv6 labeled-unicast
Additional References
For additional information related to this feature, refer to the following references:
Related Document
Related Topic
Document Title
Cisco IOS XR L2VPN command reference document
MPLS Virtual Private Network Commands on Cisco IOS XR
Software module in Cisco IOS XR MPLS Command Reference
Cisco CRS-1 router getting started material
Cisco IOS XR Getting Started Guide
Information about user groups and task IDs
Configuring AAA Services on Cisco IOS XR Software module in
Cisco IOS XR System Security Configuration Guide
Standards
Standards1
Title
No new or modified standards are supported by this
feature, and support for existing standards has not been
modified by this feature.
—
1. Not all supported standards are listed.
Cisco IOS XR MPLS Configuration Guide
OL-15850-02
MPC-289
Implementing IPv6 VPN Provider Edge Transport over MPLS on Cisco IOS XR Software
Additional References
MIBs
MIBs
MIBs Link
—
To locate and download MIBs using Cisco IOS XR software, use the
Cisco MIB Locator found at the following URL and choose a
platform under the Cisco Access Products menu:
http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml
RFCs
RFCs
Title
—
—
Technical Assistance
Description
Link
http://www.cisco.com/techsupport
The Cisco Technical Support website contains
thousands of pages of searchable technical content,
including links to products, technologies, solutions,
technical tips, and tools. Registered Cisco.com users
can log in from this page to access even more content.
Cisco IOS XR MPLS Configuration Guide
MPC-290
OL-15850-02
Download PDF
Similar pages