LG 6830D-MGCP IP Phone Provisioning Guide Sylantro

LG 6830D-MGCP IP Phone Provisioning Guide
Sylantro-hosted Service Release 3.2.1
July 2007
Covad Confidential
LG IP Phone Turn-up Summary for New Installs*
Covad offers several stream-lined ways to provision LG IP phones on our network, depending upon the type of circuit.
Phone Location
1. Managed For
new/adds to
sites using DHCP
with broadband
connection to
Covad
Configuration
Document
LG IP Phone
Configuration
using DHCP
- see slides 3-8
Overview of
Local Configuration Steps
9 If phone is used, erase configuration
9 Plug phone in to network. 5 minute auto
load!
9 At “0000” invoke *51 procedure to bind
number to phone
Description of what happens to
phone
¾ Gets IP address via DHCP from CPE
router
¾ Gets VoIP settings, latest/current
firmware from new TFTP server at:
¾ 64.2.21.251 (Sunnyvale)
¾64.2.21.45 (San Jose)
¾68.165.105.181 (Sunnyvale2)
¾72.245.184.75 (DC)
¾ Extension bound to MAC address
2. Manual
Method. For
adds to existing
Managed sites
where DHCP not
implemented
LG IP Phone
Configuration –
Manual Method
- see slides 9-14
9 Configure phone IP settings via manual
configuration
¾ Gets IP address as manually
configured
9 Plug phone into network
¾ Gets basic VoIP settings,
latest/current firmware from new
TFTP server at:
9 At 0000, invoke *51 procedure to bind
number to phone
¾64.2.21.251 (Sunnyvale)
¾64.2.21.45 (San Jose)
¾68.165.105.181 (Sunnyvale2)
¾72.245.184.75 (DC)
¾Extension bound to MAC address
Unmanaged
Sites
Not a supported application with LG phones
*--Working phones must not have their TFTP server address changed (i.e., from 64.2.21.251 to 64.2.21.x) as this may impact
phone operation.
2
Covad Confidential
Switch configuration options (phone+PC)
ƒ
ƒ
ƒ
3
If you are using VLANs other than the default VLANs that Covad configures
(VLAN2 for voice, VLAN1 for data), please see the LG VLAN Guide on what you
need to do to setup the LG phones.
If you are using a dumb switch that does not support VLANs, please see the LG
VLAN Guide on what you need to do to setup the phone. In this scenario, you
would have separate switches for voice and data and multiple cable runs to
each desktop
The LG phones only support 802.3af-compatible POE switches (Cisco 3560,
3750). Any non-POE switch or Cisco Prestandard POE switches (3550-24PWR)
will require the wall AC Power Supply/Adapter (LIP-6899) for the LG 6800
series phones.
Covad Confidential
Switch configuration options (phone+PC)
ƒ
The following are two configurations for the LG phones that support PC-behind-the-phone on the Ethernet switch
(Catalyst 2950/2960/3550/3560/3750):
ƒ
Configuration 1
•
For the port that has the LG phone connected:
interface <port on switch that has phone with PC connected>
description < example:PC_behind_the_phone_1>
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
ƒ
Configuration 2
•
Globally for the switch:
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
•
For all the ports on the switch:
interface <port on switch>
description < example:PC_behind_the_phone_1>
switchport access vlan 2
switchport trunk encapsulation dot1q (note: command is not required on Cisco 2950s)
switchport mode trunk
switchport voice vlan 2
switchport priority extend cos 3
no ip address
spanning-tree portfast
4
Covad Confidential
Switch troubleshooting guide with LG phones
ƒ
5
In some cases, a brand new LG phone out of the box will not receive IP settings, firmware, or its
configuration. To fix this issue, follow the steps below:
ƒ
On the switch configuration, change the switchport that the LG phone is plugged into to access
mode only. To do this, remove the line switchport mode trunk.
ƒ
The configuration should appear as below:
ƒ
switchport access vlan 2
ƒ
switchport trunk encapsulation dot1q
ƒ
switchport voice vlan 2
ƒ
switchport priority extend cos 3
ƒ
no ip address
ƒ
Reboot the phone and allow it to receive the IP settings, firmware, and configuration. Change the
switchport that the LG phone is plugged into back into trunk mode by adding the line switchport
mode trunk.
ƒ
The configuration should appear as below:
ƒ
switchport access vlan 2
ƒ
switchport trunk encapsulation dot1q
ƒ
switchport mode trunk
ƒ
switchport voice vlan 2
ƒ
switchport priority extend cos 3
ƒ
no ip address
ƒ
Note: this is a one-time process for each brand new phone. The LG phone will now communicate
properly on every trunk or access mode switch port with VLAN2 enabled.
Covad Confidential
LG Phone templates
ƒ
In some cases, the LG phone templates have
already been created for tenants:
ƒ
LGE LIP-6830
ƒ
ƒ
ƒ
6
Note – the LGE-VOP-10C is an older
LG phone that has been replaced by
the LG 6830. This template should
not be used.
If the LG phone templates are missing, you can
create new phone templates from the “Services”
tab under the Admin portal
ƒ
From the “Services” tab, select “Phone
Templates”
ƒ
Click on “New”
ƒ
For the Phone Type, select LGE LIP 6830
ƒ
The Template name can be anything you
want (LG-6830D, LG6830)
ƒ
Click “Save”
You can then customize the LG templates and
assign them to users
Covad Confidential
LG IP Phone Configuration using DHCP
For installations using:
Managed circuits
Public or Private WAN IP addresses
DHCP addressing on LAN
LG 6830D MGCP IP phone
Configuring the Router and Switch for DHCP
ƒ
The appropriate CPE router and switch configurations must be applied to support DHCP. These steps
must be completed by Covad prior to configuring the phones.
ƒ
As part of router turn-up, add in configuration for DHCP support
ƒ
In addition to the standard configuration applied to the CPE router, the following items
must be configured to support DHCP for the phones. No other DHCP options should be
added.
service dhcp
no ip dhcp conflict logging
ip dhcp excluded-address x.x.x.a
Å x.x.x.a is the phone default gateway or
Ethernet interface address
ip dhcp pool phone
network x.x.x.x 255.255.255.y
Å x.x.x.x 255.255.255.y is the phone
network
default-router x.x.x.a
Å x.x.x.a is the phone default gateway
or Ethernet interface address
option 66 ascii “TFTP server”
Å 64.2.21.251 (SNVL), 64.2.21.45
(SNJS), 68.165.105.181 (SNVL2) or
72.245.184.75 (DC) is the address of
the TFTP server for this application
lease 7
If you do not know which TFTP server to use, please check with Covad
Provisioning or Support.
ƒ
On Layer 3 switches, such as the Cisco Catalyst 3560, DHCP must be disabled
ƒ
8
no service dhcp
Covad Confidential
LG IP Phone Configuration using DHCP
Covad must configure your on-site router to support DHCP. We normally
do this when the router is originally installed. Contact VoIP Support at
voipprovisioning@covad.com or 800-278-7114 if you need confirmation
your router is configured properly.
The following 7 steps are used to provision multiple LG IP phones in a batch mode.
1.
At least three days prior to the activation, contact your Covad Provisioning Coordinator and
provide/obtain the following information:
ƒ
The physical street address where the activation will take place.
ƒ
The tenant (customer) name the phone will be provisioned within.
ƒ
The date/time that the activation is scheduled to take place.
The Covad Provisioning Coordinator will then schedule an appointment with Covad
Provisioning on the date/time you have specified.
2.
9
In the ADMIN portal, create the employee and pre-build an LG phone template.
Covad Confidential
LG IP Phone Configuration using DHCP
3.
4.
If the phone has been configured before and you need to reset the phone to default
settings, press the Settings button on the phone, then the 6 button and finally the # button
Prepare to configure the phone by following these steps. Upon completion of this step, the
phone will begin to perform a software upgrade, reboot itself, and register with the Covad
switch, all of which should take about 5 minutes to complete.
ƒ
Connect the phone to the local network by plugging the Ethernet cable into the port labeled LAN
on the underside of the phone.
ƒ
Connect the power cord to the phone
ƒ
The initial boot process takes 2-3 minutes to complete. Do not interrupt power to the unit
during this time.
ƒ
ƒ
5.
10
The following items and messages should be observed on the phone’s LCD:
ƒ
DHCP Searching
ƒ
Configuration Trying to Download
ƒ
Software Trying to Download
ƒ
Covad Communications Connecting
If these steps fail, you might have to remove the phone from a trunk switchport. See
steps on slide 4.
A newly installed phone properly configured will display the following on its screen:
•
Time – upper right hand corner
•
0000 – (null extension) – upper left hand corner
•
[ReDL] [MSG] [PICK] – lower half of screen
Covad Confidential
LG IP Phone Configuration using DHCP
6.
To bind an extension to a phone, go off hook and enter the following digit string.
* 51 <Tenant Registration Code> * <Admin Registration Code> * <Admin Registration Password> *
<4-digit extension> #
Note: to unbind a number, enter 0000 as the 4-digit extension
Partners can find the Registration Codes and Password in the on-line Order Processing
System. Registration codes and password may be 4 or 5 digits in length. Contact
voipsupport@covad.com to get the Registration Code and Password.
7.
The LG phone LCD will now display the extension assigned to the phone. You can now go into
the ADMIN portal and station dashboard to program the function keys.
For instructions on how to use the phone, download the
LG 6830 User Guide found in the HELP tab of any dashboard.
11
Covad Confidential
LG IP Phone Configuration using Static IPs
For installations where DHCP is not used:
Managed circuits
Public or Private WAN IP addresses
Statically assigned addressing on LAN
LG 6830D MGCP IP phones
LG IP Phone Configuration – Manual Method
The following 17 steps are used to provision multiple LG IP phones in a batch
mode.
1.
At least three days prior to the activation, contact your Covad Provisioning Coordinator
and provide/obtain the following information:
ƒ
The physical street address where the activation will take place.
ƒ
The tenant (customer) name the phone will be provisioned within.
ƒ
The IP address reserved for the LG IP phone and the associated phone number.
ƒ
The date/time that the activation is scheduled to take place.
The Covad Provisioning Coordinator will then schedule an appointment with Covad
Provisioning on the date/time you have specified.
13
2.
In the ADMIN portal, create the employee and pre-build an LG phone template.
3.
If the phone has been configured before and you need to reset the phone to default
settings, press the Settings button on the phone, then the 6 button and finally the #
button
Covad Confidential
LG IP Phone Configuration – Manual Method
4.
5.
To configure the phone manually, the following information will be needed
ƒ
IP address for the LG phone
ƒ
Subnet Mask
ƒ
Default Gateway Address
ƒ
TFTP server IP address (64.2.21.251 SNVL, 64.2.21.45 SNJS, 68.165.105.181 SNVL2 or 72.245.184.75
DC)
ƒ
Call Server IP address (68.165.105.130 SNVL, 64.2.21.61 SNJS, 68.165.105.160 SNVL2 or
72.245.184.130 DC)
ƒ
NTP server IP address (64.2.21.49)
ƒ
If you don’t know your TFTP or Call Server IP address, please contact VoIP Support or Provisioning
Prepare to configure the phone by following these steps.
Connect the phone to the local network by plugging the Ethernet cable into the port labeled LAN on the
underside of the phone.
ƒ
6.
14
Connect the power cord to the phone
Configure the Network Mode to Static IP address by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (1) button, or move cursor to “1. Network Configuration” using [Next]/[Prev] soft keys, and
press the [OK ] soft key.
ƒ
Press the (1) button, or move cursor to “1. Network Mode” using [Next]/[Prev] soft keys, and press the
[OK ] soft key.
ƒ
Choose the Network Mode using [Next]/[Prev] soft keys, and press [OK ] soft key to save your selection.
Covad Confidential
LG IP Phone Configuration – Manual Method
7.
8.
15
Configure the IP address for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (1) button, or move cursor to “1. Network Configuration” using [Next]/[Prev] soft keys, and press
the [OK ] soft key.
ƒ
Press the (2) button, or move cursor to “2. IP Address”” using [Next]/[Prev] soft keys, and press the [OK ]
soft key.
ƒ
Input the IP address using the keypad
ƒ
- Press the asterisk (‘*’) button to input dot (‘.’).
ƒ
- Press [Clr ] soft key to delete all characters.
ƒ
- Press [ß] soft key to delete the character in front of cursor.
ƒ
- The IP address can be changed only under the ‘Static’ mode, and not in the ‘DHCP’ mode.
ƒ
Press the [OK] softkey
Configure the Subnet Mask for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (1) button, or move cursor to “1. Network Configuration” using [Next]/[Prev] soft keys, and press
the [OK ] soft key.
ƒ
Press the (3) button, or move cursor to “3. Subnet Mask” using [Next]/[Prev] soft keys, and press the [OK ]
soft key.
ƒ
Input the Subnet Mask using the keypad
ƒ
- Press the asterisk (‘*’) button to input dot (‘.’).
ƒ
- Press [Clr ] soft key to delete all characters.
ƒ
- Press [ß] soft key to delete the character in front of cursor.
ƒ
- The IP address can be changed only under the ‘Static’ mode, and not in the ‘DHCP’ mode.
ƒ
Press the [OK] softkey
Covad Confidential
LG IP Phone Configuration – Manual Method
9.
10.
16
Configure the Default Gateway address for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (1) button, or move cursor to “1. Network Configuration” using [Next]/[Prev] soft keys, and press
the [OK ] soft key.
ƒ
Press the (4) button, or move cursor to “4. Default Gateway”” using [Next]/[Prev] soft keys, and press the
[OK ] soft key.
ƒ
Input the Default Gateway address using the keypad
ƒ
- Press the asterisk (‘*’) button to input dot (‘.’).
ƒ
- Press [Clr ] soft key to delete all characters.
ƒ
- Press [ß] soft key to delete the character in front of cursor.
ƒ
- The Default Gateway can be changed only under the ‘Static’ mode, and not in the ‘DHCP’ mode.
ƒ
Press the [OK] softkey
Configure the Call Server Address for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (2) button, or move cursor to “2. VoIP Configuration” using [Next]/[Prev] soft keys, and press the
[OK ] soft key.
ƒ
Press the (1) button, or move cursor to “1. Call Server Address” using [Next]/[Prev] soft keys, and press
the [OK ] soft key.
ƒ
Input the Call Server address using the keypad
ƒ
- 68.165.105.130 (SNVL), 64.2.21.61 (SNJS) or 68.165.105.160 (SNVL2)
ƒ
- Press the asterisk (‘*’) button to input dot (‘.’).
ƒ
- Press [Clr ] soft key to delete all characters.
ƒ
- Press [ß] soft key to delete the character in front of cursor.
ƒ
Press the [OK] softkey
Covad Confidential
LG IP Phone Configuration – Manual Method
11.
Configure the TFTP Server address for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (5) button, or move cursor to “5. S/W Update” using [Next]/[Prev] soft keys, and press
the [OK ] soft key.
ƒ
Press the (1) button, or move cursor to “1. TFTP Server Address”” using [Next]/[Prev] soft keys,
and press the [OK ] soft key.
ƒ
Input the TFTP Server address using the keypad
ƒ
17
ƒ
64.2.21.251 (SNVL), 64.2.21.45 (SNJS), 68.165.105.181 (SNVL2) or 72.245.184.75 (DC)
ƒ
Press the asterisk (‘*’) button to input dot (‘.’).
ƒ
Press [Clr ] soft key to delete all characters.
ƒ
Press [Å] soft key to delete the character in front of cursor.
Press the # key when finished to save the configuration. If the new configuration is valid, the 6804
beeps once and exits from the configuration menu. If erroneous data is entered, the phone beeps
twice and exits the configuration menu.
Covad Confidential
LG IP Phone Configuration – Manual Method
12. Configure the NTP Server Address for the phone by using the following command sequence.
ƒ
Click the “Settings” button on the phone
ƒ
Press the (4) button, or move cursor to “4. Time Configuration” using [Next]/[Prev] soft keys, and
press the [OK ] soft key.
ƒ
Press the (1) button, or move cursor to “1. NTP Server Address” using [Next]/[Prev] soft keys, and
press the [OK ] soft key.
ƒ
Input the NTP Server address using the keypad
ƒ - 64.2.21.49
ƒ - Press the asterisk (‘*’) button to input dot (‘.’).
ƒ - Press [Clr ] soft key to delete all characters.
ƒ - Press [ß] soft key to delete the character in front of cursor.
ƒ - The [Mode] soft key, switches the keypad entry mode: number ([1]), upper case ([A]),
lower case ([a]) or special character ([S]) mode.
ƒ
Press the [OK] softkey
13. After entry of certain configuration settings, the LIP-6812 will require a reboot to move the
settings to active memory. These settings include the following:
ƒ
Network Configuration settings
ƒ
Call Server Address settings
ƒ
DSS Registration settings
ƒ
Software Update settings
ƒ
Default settings
18
Covad Confidential
LG IP Phone Configuration – Manual Method
14.
To reboot the phone, go through the following steps
ƒ
Press the “Settings” button
ƒ
Press the (0) button, or move cursor to “0. Reboot” using [Next]/[Prev] soft keys,
and press the [OK ] soft key.
ƒ
Press the [Yes] soft key to reboot the IP phone or press [No] soft key to cancel this
menu
15.
Configured properly, you’ll see 4 zeros next to the top right function button.
16.
To bind an extension to a phone, go off hook and enter the following digit string.
* 51 <Tenant Registration Code> * <Admin Registration Code> * <Admin Registration Password> *
<4-digit extension> #
Note: to unbind a number, enter 0000 as the 4-digit extension
Partners can find the Registration Codes and Password in the on-line Order Processing
System. Registration codes and password may be 4 or 5 digits in length. Contact
voipsupport@covad.com to get the Registration Code and Password.
17.
The LG phone LCD will now display the extension assigned to the phone. You can now go
into the ADMIN portal and station dashboard to program the function keys.
For instructions on how to use the phone, download the
LG 6812 User Guide found in the HELP tab of any dashboard.
19
Covad Confidential
LG 6830D Button overview
20
Covad Confidential
LG phone distributor
1st Priority
ƒ
Contact and ordering information
ƒ Phone: 800-831-9960 or 952472-6999
ƒ Fax : 952-472-6962
ƒ E-Mail: 1stpriority@mail.com
ƒ
Business hours
ƒ 1st Priority is staffed from 8 a.m.
to 4 p.m. (Central Time) Monday
through Friday.
ƒ Voice or fax messages will be
returned within two business
hours.
21
Covad Confidential