HPE Synergy 40Gb F8 Switch Module DHCP Configuration

HPE Synergy 40Gb F8 Switch Module
DHCP Configuration
Abstract
This document is intended for the person who configures HPE Synergy 40Gb F8 Switch Modules.
20140325-001
July 2017
Edition: 2
© Copyright 2016, 2017 Hewlett Packard Enterprise Development LP
The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the
express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett
Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein.
Links to third-party websites take you outside the Hewlett Packard Enterprise website. Hewlett Packard Enterprise has no control over and is not responsible for
information outside the Hewlett Packard Enterprise website.
Confidential computer software. Valid license from Hewlett Packard Enterprise required for possession, use or copying. Consistent with FAR 12.211 and 12.212,
Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under
vendor’s standard commercial license.
Contents
CHAPTER 1:
DHCP CONFIGURATION _________________________________________ 1 Abstract ------------------------------------------------------------------------------------------ 1 CHAPTER 2:
INTRODUCTION ________________________________________________ 6 PURPOSE AND SCOPE............................................................................................. 6 ACRONYMS ............................................................................................................ 6 REFERENCES ......................................................................................................... 6 DOCUMENT CONVENTIONS ...................................................................................... 6 GENERAL CONFIGURATIONS .................................................................................... 7 PROTOCOL DESCRIPTION ........................................................................................ 8 DHCP SERVER ...................................................................................................... 8 DHCP CLIENT ........................................................................................................ 8 DHCP RELAY AGENT ............................................................................................. 8 CHAPTER 3:
DHCP CONFIGURATIONS ________________________________________ 9 CONFIGURATION GUIDELINES .................................................................................. 9 DEFAULT CONFIGURATIONS .................................................................................. 10 RELEASING A DYNAMICALLY ACQUIRED IP ............................................................. 10 RENEWING A DYNAMICALLY ACQUIRED IP .............................................................. 11 CONFIGURING AN INTERFACE TO USE MANUAL IP .................................................. 12 ENABLING DEBUG TRACES FOR CLIENT ................................................................. 13 ACQUIRING IP FROM A SERVER RESIDING OUTSIDE THE CLIENT NETWORK ............. 13 CHAPTER 4:
SUPPORT AND OTHER RESOURCES _____________________________ 19 ACCESSING HEWLETT PACKARD ENTERPRISE SUPPORT ........................................ 19 Information to collect .......................................................................................... 19 ACCESSING UPDATES............................................................................................ 19 WEBSITES ............................................................................................................ 19 REMOTE SUPPORT ................................................................................................ 20 Figures
Figure 1 ....................................................................................................................................................... 9 Figure 2 ....................................................................................................................................................... 9 Tables
Table 1: Acronyms used in this document .................................................................................................... 6 Table 2: Document Conventions ................................................................................................................... 6 Table 3: General Configurations ................................................................................................................... 7 Table 4: Default Configurations ................................................................................................................... 10 Introduction
Note: Please see the HPE Synergy 40Gb F8 Switch Module Command Line (CLI) Guide for a list of
currently supported commands and additional detailed information.
Purpose and Scope
HPE DHCP is a portable implementation of the Dynamic Host configuration
protocol specification provided in RFC 2131. The product design supports
portability on a wide range of routers and gateways - from monolithic to
distributed-shared memory or message passing architectures. This document
describes the basic and advanced configuration tasks of HPE DHCP.
Acronyms
Table 1: Acronyms used in this document
Acronym
Expansion
CLI
Command Line Interface
DHCP
Dynamic Host Configuration Protocol
DNS
Domain Name Server
ICMP
Internet Control Message Protocol
IP
Internet Protocol
ICM
Interconnect Module
RAI
Relay Agent Information
SNMP
Simple Network Management Protocol
References
[1] HPE Synergy 40Gb F8 Switch Module Command Line Interface (CLI)
Guide
Document Conventions
Table 2: Document Conventions
Convention
Usage
Bold
CLI commands
Italics
User inputs for CLI commands
Courier New 10 Regular, blue color
CLI command outputs

Notes / Guidelines / Pre-requisites
Output areas specific to the configuration
General Configurations
The following table provides the access and exit methods to various general
configuration modes.
Table 3: General Configurations
Command Mode
Access Method
Prompt
Exit method
User EXEC
This is the initial mode to start a
session.
switch>
The logout method is used.
Privileged EXEC
The User EXEC mode
command enable, is used to
enter the Privileged EXEC
mode.
switch#
To return from the Privileged
EXEC mode to User EXEC
mode the disable command
is used.
Global
Configuration
The Privileged EXEC mode
command configure terminal,
is used to enter the Global
Configuration mode
switch(config
)#
To exit to the Global
Configuration mode the exit
command is used and to exit
to the Privileged EXEC mode
the end command is used.
Interface
Configuration
The Global Configuration mode
command interface
<interface-type><interfaceid> is used to enter the
Interface configuration mode.
switch(config
-if)#
To exit to the Global
Configuration mode the exit
command is used and to exit
to the Privileged EXEC mode
the end command is used.
DHCP Pool
Configuration
The Global configuration mode
command ip dhcp pool
<integer(1-2147483647)>
creates a DHCP server
address pool and places the
user in DHCP pool
configuration mode.
switch(dhcpconfig)#
To exit to the Global
Configuration mode the exit
command is used and to exit
to the Privileged EXEC mode
the end command is used.
Protocol Description
DHCP (Dynamic Host Configuration Protocol) allows dynamic configuration
of a host computer. When a DHCP client is turned on, it issues a broadcast
message to any DHCP server which is on the network. An exchange takes
place during which the DHCP server assigns an IP address to the client and
informs the client certain key network configuration parameters.
ISS DHCP implementation complies with RFC 2131.
DHCP Server
DHCP server maintains a configured set of IP address pools from which IP
addresses are allocated to the DHCP clients, whenever they request the
Server dynamically. Once the IP address is allocated, the Server will keep
this IP as reserved until the lease time for that IP expires. If the client does
not renew the IP before the lease time expiry, this will be returned into the
free pool and will be offered to new clients.
DHCP Client
DHCP client is the host which requests IP address for its interface. It also
configures the parameters like default router, DNS, subnet mask etc. offered
by the server. Refer to Figure 1.
DHCP Relay Agent
DHCP relay agent is used to forward the DHCP packets between client and
server when they are not in the same subnets. The relay receives packets
from the client and inserts certain information like the network in which the
packet is received and then forwards it to the server. The Server identifies
the client’s network from this information and allocates IP accordingly, then
sends the reply to the relay. The Relay then strips the information inserted
and broadcasts the packets into the client’s network. Refer to Figure 2.
DHCP Configurations
12.0.0.1
1
1
Switch 1 (DHCP SERVER)
Switch 2 (DHCP CLIENT)
Figure 1
Switch 2 (DHCP RELAY)
30.0.0.2
20.0.0.2
Port 1
Port 2
Vlan 2
Vlan 3
20.0.0.1
Port 1
Port 1
Switch 1 (DHCP SERVER)
Switch 3 (DHCP CLIENT)
Figure 2
Configuration Guidelines
Refer to the HPE Synergy 40Gb F8 Switch Module Command Line Interface
(CLI) Guide for the complete set of commands and the various options
available for configuring DHCP.
The following are the configuration guidelines:
DHCP Client

If the router interface was not assigned an IP address by the DHCP
server, the renew DHCP command fails and displays the following error
message:
Interface does not have a DHCP originated address
DHCP Relay Agent


DHCP Server must be disabled before enabling the DHCP Relay agent.
Only when enabled, the Relay Agent,
 becomes active
 forwards the packets from the client to a specific DHCP server
 does any processing related to Relay Agent Information Options -
like inserting the necessary options while relaying a packet from a
client to a server and examining/stripping of options when relaying a
packet from a server to a client
Default Configurations
Table 4: Default Configurations
Feature
Default Setting
ICMP echo
Disabled
Offer reuse time out
5 seconds
Boot file name
None
DHCP relay status
Disabled
RAI option
Disabled
DHCP relay debug level
None
DHCP client debug level
None
 This option will be offered to DHCP clients only when there is no Host specific option
and there is no pool specific option with this option code.

Releasing a Dynamically Acquired IP
Refer to DHCP Topology Figure 1 for the Topology Setup.
1. View the dynamic IP configured for vlan1 in Switch 2 using the following
command.
switch# show ip interface
cpu0 is up, line protocol is up
Internet Address is 0.0.0.0/0
Broadcast Address
255.255.255.255
2. View the client statistics using the following command.
switch# show ip dhcp client stats
3. Execute the following command in Switch 2 to release the dynamic IP
address of vlan1.
switch# release dhcp vlan 1
4. View the IP address configured in the Switch 2.
switch# show ip interface
cpu0 is up, line protocol is up
Internet Address is 0.0.0.0/0
Broadcast Address
255.255.255.255
5. View the client statistics.
switch# show ip dhcp client stats
Dhcp Client Statistics
-------------------------Interface
: vlan1
Client IP Address
: 12.0.0.2
Client Lease Time
: 3600
Client Remain Lease Time
: 0
Message Statistics
-----------------DHCP DISCOVER
: 1
DHCP REQUEST
: 1
DHCP DECLINE
: 0
DHCP RELEASE
: 1
DHCP INFORM
: 0
DHCP OFFER
: 1
 To release a dynamic IP, client must have a dynamic IP with valid lease.
Renewing a Dynamically Acquired IP
Refer to DHCP Topology Figure 1 for Topology Setup.
1. View the dynamic IP configured for vlan1 in Switch 2 using the following
commands.
switch# show ip interface
cpu0 is up, line protocol is up
Internet Address is 0.0.0.0/0
Broadcast Address 255.255.255.255
switch# show ip dhcp client stats
Dhcp Client Statistics
-------------------------Interface
: vlan1
Client IP Address
: 12.0.0.2
Client Lease Time
: 3600
Client Remain Lease Time
: 2925
Message Statistics
-----------------DHCP DISCOVER
: 1
DHCP REQUEST
: 1
DHCP DECLINE
: 0
DHCP RELEASE
: 0
DHCP INFORM
: 0
DHCP OFFER
: 1
2. Execute the following command in Switch 2 to renew the dynamic IP
address of vlan1 using the following command.
switch# renew dhcp vlan 1
3. View the IP address configured in the Switch 2 using the following
command.
switch# show ip interface
vlan1 is up, line protocol is up
Internet Address is 12.0.0.2/0
Broadcast Address
12.255.255.255
IP address allocation method is dynamic
IP address allocation protocol is dhcp
4. View the client statistics using the following command.
switch# show ip dhcp client stats
Dhcp Client Statistics
-------------------------Interface
: vlan1
Client IP Address
: 12.0.0.2
Client Lease Time
: 3600
Client Remain Lease Time
: 3598
Message Statistics
-----------------DHCP DISCOVER
: 1
DHCP REQUEST
: 2
DHCP DECLINE
: 0
DHCP RELEASE
: 0
DHCP INFORM
: 0
DHCP OFFER
: 1
Configuring an Interface to Use Manual IP
A Switch can be configured to stop running DHCP and to use manual IP
allocation method for an interface.
1. Execute the following command to configure an interface to use manual
IP.
 Enter into the Global configuration mode.
switch# configure terminal
 Enter into VLAN configuration mode for vlan 1.
switch(config)# interface vlan 1
 Change the IP allocation mode to manual.
switch(config-if)# no ip address
 Exit from the interface configuration mode.
switch(config-if)# end
2. View the current configuration mode using the following command.
switch# show ip interface
cpu0 is up, line protocol is up
Internet Address is 0.0.0.0/0
Broadcast Address 255.255.255.255
Enabling Debug Traces for Client
1. Execute the following command to enable debug trace for DHCP client.
Available options for trace logging are: events, packets, error and bind.
Option ‘all’ represents enabling all the trace options.
switch# debug ip dhcp client all
2. View the debug trace level using the following command.
switch# show debugging
The output in the Switch 1 is
DHCP Client :
DHCP Client event handling related debugging is on
DHCP Client packets debugging is on
DHCP Client errors debugging is on
DHCP Client binding debugging is on
Acquiring IP from a Server Residing Outside the Client
Network
Connect Port 1 of Switch 1 to Port 1 of Switch 2 and connect Port 2 of Switch
2 to Port 1 of Switch 3.
1. Create vlan2 in Switch 1 with Port 1 as member port. Then, add a route
to 30.0.0.0 network though 20.0.0.2 (Switch 2).
switch# configure terminal
switch(config)# vlan 2
switch(config-vlan)# ports TwentyGigE 0/1/1
switch(config-vlan)# exit
switch(config)# interface vlan 2
switch(config-if)# shutdown
switch(config-if)# ip address 20.0.0.1 255.0.0.0
switch(config-if)# no shutdown
switch(config-vlan)# exit
switch(config)# interface TwentyGigE 0/1/1
switch(config-if)# switchport pvid 2
switch(config-vlan)# exit
switch(config)# ip route 30.0.0.0 255.0.0.0 20.0.0.2
switch(config) # end
2. View the VLAN configurations and route configuration using the following
commands.
switch# show ip interface vlan 2
vlan2 is up, line protocol is up
Internet Address is 20.0.0.1/8
Broadcast Address
20.255.255.255
switch# show vlan id 2
Vlan database
------------Vlan ID
: 2
Member Ports
: Gi0/1
Untagged Ports
: None
Forbidden Ports
: None
Name
:
Status
: Permanent
------------------------------------------switch# show ip route
C 12.0.0.0/8
is directly connected, vlan1
C 20.0.0.0/8
is directly connected, vlan2
S 30.0.0.0/8
[1] via 20.0.0.2
3. Create vlan2 with port1 as member port and vlan3 with port2 as member
port in Switch 2.
switch# configure terminal
switch(config)# vlan 2
switch(config-vlan)# ports TwentyGigE 0/1/1
switch(config-vlan)# exit
switch(config)# interface vlan 2
switch(config-if)# shutdown
switch(config-if)# ip address 20.0.0.2 255.0.0.0
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface TwentyGigE 0/1/1
switch(config-if)# switchport pvid 2
switch(config-if)# exit
switch(config)# vlan 3
switch(config-vlan)# ports TwentyGigE 0/1/2
switch(config-vlan)# exit
switch(config)# interface vlan 3
switch(config-if)# shutdown
switch(config-if)# ip address 30.0.0.2 255.0.0.0
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface TwentyGigE 0/1/2
switch(config-if)# switchport pvid 3
switch(config-if)# no shutdown
switch(config-if)# end
4. View the configuration using the following commands
switch# show vlan id 2
Switch default
Vlan database
------------switch# show vlan id 3
Switch default
Vlan database
------------switch# show ip interface vlan 2
vlan2 is up, line protocol is up
Internet Address is 20.0.0.2/8
Broadcast Address
20.255.255.255
switch# show ip interface vlan 3
vlan3 is up, line protocol is up
Internet Address is 30.0.0.2/8
Broadcast Address
30.255.255.255
5. Enable DHCP server in Switch 1. Since the client is in Vlan3, an address
pool with 30.0.0.0 network needs to be configured in the Server.
switch# configure terminal
switch(config)# service dhcp-server
switch(config)# ip dhcp pool 1
switch(dhcp-config)# network 30.0.0.0
switch(dhcp-config)# lease 0 0 30
switch(dhcp-config)# end
6. View the configuration using the following commands.
switch# show ip dhcp server information
DHCP server status
: Enable
Send Ping Packets
: Disable
Debug level
: None
Server Address Reuse Timeout
: 5 secs
Next Server Adress
: 0.0.0.0
Boot file name
: None
switch# show ip dhcp server pools
Pool Id
: 1
---------------------------------Subnet
: 30.0.0.0
Subnet Mask
: 255.0.0.0
Lease time
: 1800 secs
Utilization threshold
: 75%
Start Ip
: 30.0.0.1
End Ip
: 30.255.255.255
7. Enable DHCP Relay in Switch 2, which connects the networks between
Client and Server.
switch# configure terminal
switch(config)# service dhcp-relay
switch(config)# end
8. View the configuration using the following commands.
switch# show ip dhcp relay information
Dhcp Relay
: Enabled
Dhcp Relay Servers only
: Disabled
DHCP server
: 0.0.0.0
Dhcp Relay RAI option
: Disabled
Debug Level
: 0x1
No of Packets inserted RAI option
: 0
No of Packets inserted circuit ID suboption
: 0
No of Packets inserted remote ID suboption
: 0
No of Packets inserted subnet mask suboption
: 0
No of Packets dropped
: 0
No of Packets which did not inserted RAI option : 0
9. Create vlan 3 in Switch 3 with port1 as member port and acquire IP
address through DHCP using the following commands.
switch# configure terminal
switch(config)# vlan 3
switch(config-vlan)# ports TwentyGigE 0/1/1
switch(config-vlan)# exit
switch(config)# interface TwentyGigE 0/1/1
switch(config-if)# switchport pvid 3
switch(config-if)# exit
switch(config)# interface vlan 3
switch(config-if)# no shutdown
switch(config-if)# ip address dhcp
switch(config-if)# end
10. Wait for 15-20 seconds for DHCP to acquire dynamic IP from the server.
11. View the IP address configured for vlan3 in Switch 3 using the following
commands.
switch# show ip interface vlan 3
vlan3 is up, line protocol is up
Internet Address is 30.0.0.1/8
Broadcast Address
30.255.255.255
IP address allocation method is dynamic
IP address allocation protocol is dhcp
switch# ping 30.0.0.2
Reply Received From :30.0.0.2, TimeTaken : 40 msecs
Reply Received From :30.0.0.2, TimeTaken : 40 msecs
Reply Received From :30.0.0.2, TimeTaken : 40 msecs
--- 30.0.0.2 Ping Statistics --3 Packets Transmitted, 3 Packets Received, 0% Packets
Loss
switch# show ip dhcp client stats
Dhcp Client Statistics
-------------------------Interface
: vlan3
Client IP Address
: 30.0.0.1
Client Lease Time
: 1800
Client Remain Lease Time
: 1277
Message Statistics
-----------------DHCP DISCOVER
: 1
DHCP REQUEST
: 1
DHCP DECLINE
: 0
DHCP RELEASE
: 0
DHCP INFORM
: 0
DHCP OFFER
: 1
switch# show ip dhcp server binding
Ip
Hw
Address
Type
Address
---------
-------
----------- ----------
30.0.0.1 Ethernet
16:59:06 2007
Hw
Binding
Expire
State
Time
---------
00:03:02:03:04:01 Assigned
Jan 7
Support and other resources
Accessing Hewlett Packard Enterprise Support

For live assistance, go to the Contact Hewlett Packard Enterprise Worldwide website
(http://www.hpe.com/assistance).

To access documentation and support services, go to the Hewlett Packard Enterprise Support Center
website (http://www.hpe.com/support/hpesc).
Information to collect

Technical support registration number (if applicable)

Product name, model or version, and serial number

Operating system name and version

Firmware version

Error messages

Product-specific reports and logs

Add-on products or components

Third-party products or components
Accessing updates

Some software products provide a mechanism for accessing software updates through the product
interface. Review your product documentation to identify the recommended software update method.

To download product updates, go to either of the following:
o Hewlett Packard Enterprise Support Center Get connected with updates page
(http://www.hpe.com/support/e-updates)
o Software Depot website (http://www.hpe.com/support/softwaredepot)

To view and update your entitlements, and to link your contracts and warranties with your profile, go
to the Hewlett Packard Enterprise Support Center More Information on Access to Support Materials
page (http://www.hpe.com/support/AccessToSupportMaterials).
IMPORTANT: Access to some updates might require product entitlement when accessed through the
Hewlett Packard Enterprise Support Center. You must have an HP Passport set up with relevant
entitlements.
Websites
Hewlett Packard Enterprise Information Library (http://www.hpe.com/info/enterprise/docs)
Hewlett Packard Enterprise Support Center (http://www.hpe.com/support/hpesc)
Contact Hewlett Packard Enterprise Worldwide (http://www.hpe.com/assistance)
Subscription Service/Support Alerts (http://www.hpe.com/support/e-updates)
Software Depot (http://www.hpe.com/support/softwaredepot)
Customer Self Repair (http://www.hpe.com/support/selfrepair)
Insight Remote Support (http://www.hpe.com/info/insightremotesupport/docs)
Serviceguard Solutions for HP-UX (http://www.hpe.com/info/hpux-serviceguard-docs)
Single Point of Connectivity Knowledge (SPOCK) Storage compatibility matrix
(http://www.hpe.com/storage/spock)
Storage white papers and analyst reports (http://www.hpe.com/storage/whitepapers)
Remote support
Remote support is available with supported devices as part of your warranty or contractual support
agreement. It provides intelligent event diagnosis, and automatic, secure submission of hardware event
notifications to Hewlett Packard Enterprise, which will initiate a fast and accurate resolution based on your
product’s service level. Hewlett Packard Enterprise strongly recommends that you register your device for
remote support.
For more information and device support details, go to the Insight Remote Support website
(http://www.hpe.com/info/insightremotesupport/docs).
Documentation feedback
Hewlett Packard Enterprise is committed to providing documentation that meets your needs. To help us
improve the documentation, send any errors, suggestions, or comments to Documentation Feedback
(mailto:docsfeedback@hpe.com). When submitting your feedback, include the document title, part
number, edition, and publication date located on the front cover of the document. For online help content,
include the product name, product version, help edition, and publication date located on the legal notices
page.
Download PDF
Similar pages