Document Generation Suite 1.3.3 Product View Builder

Autonomy Document Generation
Suite
Product View Builder
Installation and User
Guide
Version 1.3.3
Document Revision 0
18 November 2013
Copyright Notice
Notice
This documentation is a proprietary product of Hewlett-Packard Development Company, L.P. and is protected by copyright laws and international
treaty. Information in this documentation is subject to change without notice and does not represent a commitment on the part of Hewlett-Packard
Development Company, L.P. While reasonable efforts have been made to ensure the accuracy of the information contained herein,
Hewlett-Packard Development Company, L.P. assumes no liability for errors or omissions. No liability is assumed for direct, incidental, or
consequential damages resulting from the use of the information contained in this documentation.
The copyrighted software that accompanies this documentation is licensed to the End User for use only in strict accordance with the End User
License Agreement, which the Licensee should read carefully before commencing use of the software. No part of this publication may be
reproduced, transmitted, stored in a retrieval system, nor translated into any human or computer language, in any form or by any means,
electronic, mechanical, magnetic, optical, chemical, manual or otherwise, without the prior written permission of the copyright owner.
This documentation may use fictitious names for purposes of demonstration; references to actual persons, companies, or organizations are
strictly coincidental.
Trademarks and Copyrights
Copyright © 2013 Hewlett-Packard Development Company, L.P. Audit Center, Autonomy Consolidated Archive, Autonomy Express Search,
Autonomy iManage ConflictsManager, Autonomy iManage RecordsManager, Autonomy Interaction Control Element (ICE), Autonomy Message
Manager, Autonomy Notification Server, Autonomy Records Manager, Autonomy Windows Extension, DeskSite, Connected Backup, Digital
Safe, Digital Supervisor, EAS On-Demand, EAS, Enterprise Archive Solution, FileShare, FileSite, iManage WorkSite MP, iManage WorkSite,
iManage, Interwoven, Introspect, LiveVault, Meridio, OffSite, Scrittura, WorkDocs, WorkPortal, WorkRoute, WorkSite MP, WorkSite, WorkTeam,
Zantaz, and all related titles and logos are trademarks of Hewlett-Packard Development Company, L.P.
Microsoft is a registered trademark, and MS-DOS, Windows, Windows 95, Windows NT, SharePoint, and other Microsoft products referenced
herein are trademarks of Microsoft Corporation.
UNIX is a registered trademark of The Open Group.
AvantGo is a trademark of AvantGo, Inc.
Epicentric Foundation Server is a trademark of Epicentric, Inc.
Documentum and eRoom are trademarks of Documentum, a division of EMC Corp.
FileNet is a trademark of FileNet Corporation.
Lotus Notes is a trademark of Lotus Development Corporation.
mySAP Enterprise Portal is a trademark of SAP AG.
Oracle is a trademark of Oracle Corporation.
Adobe is a trademark of Adobe Systems Incorporated.
Novell is a trademark of Novell, Inc.
Stellent is a trademark of Stellent, Inc.
All other trademarks are the property of their respective owners.
Notice to Government End Users
If this product is acquired under the terms of a DoD contract: Use, duplication, or disclosure by the Government is subject to restrictions as set
forth in subparagraph (c)(1)(ii) of 252.227-7013. Civilian agency contract: Use, reproduction or disclosure is subject to 52.227-19 (a) through
(d) and restrictions set forth in the accompanying end user agreement. Unpublished-rights reserved under the copyright laws of the United States.
Autonomy, Inc., One Market Plaza, Spear Tower, Suite 1900, San Francisco, CA. 94105, US.
Acknowledgements
RSA Data Security, Inc. MD5 Message-Digest Algorithm; zlib general purpose compression library, Jean-loup Gailly and Mark Adler; Info-ZIP,
more information at ftp://ftp.info-zip.org/pub/infozip/license.html; HTML-to-RTF Pro DLL 1.8 © 2002-2007 SautinSoft.
16 December 2013
Contents
Figures ............................................................................................................................................. 5
About This Document ................................................................................................................ 7
Documentation Updates................................................................................................................ 7
Conventions .................................................................................................................................. 9
Notational Conventions .......................................................................................................... 9
Command-line Syntax Conventions ..................................................................................... 10
Notices ..................................................................................................................................11
Related Documentation................................................................................................................11
Autonomy Product References.....................................................................................................11
Autonomy Customer Support ...................................................................................................... 12
Contact Autonomy....................................................................................................................... 13
Chapter 1
Introduction to Product View Builder ............................................................................... 15
Overview of Autonomy Document Generation Suite ................................................................... 15
Overview of Product View Builder ............................................................................................... 17
Chapter 2
Install and Configure Product View Builder ................................................................... 19
Confirm System Requirements ................................................................................................... 19
Install Product View Builder ........................................................................................................ 20
Uninstall Product View Builder ............................................................................................. 21
Launch Product View Builder ..................................................................................................... 21
Configure Product View Builder................................................................................................... 22
Configure SSL Support .............................................................................................................. 22
Configure SSL Connectivity ................................................................................................. 23
Product View Builder Installation and User Guide
•
•
• 3
•
•
•
Contents
Chapter 3
Explore the Product View Builder Interface.................................................................... 25
General Layout ............................................................................................................................ 25
Menus.......................................................................................................................................... 26
File Menu ............................................................................................................................. 27
Edit Menu ............................................................................................................................. 27
Quick Access Menu ............................................................................................................. 28
Data Source Pane ....................................................................................................................... 29
Search in the Data Source Pane .......................................................................................... 30
Product View Pane ...................................................................................................................... 30
Search in the Product View Pane ......................................................................................... 31
Properties Pane........................................................................................................................... 32
String Variable ...................................................................................................................... 33
Date Variable ....................................................................................................................... 34
Number Variable .................................................................................................................. 35
Image Variable ..................................................................................................................... 36
Boolean Variable .................................................................................................................. 37
Group ................................................................................................................................... 38
Repeating Group .................................................................................................................. 38
Chapter 4
Create a Product View ............................................................................................................. 41
Load a Data Source .................................................................................................................... 41
Create a New Product View ........................................................................................................ 42
Set a Product View as Structured ............................................................................................... 43
Build and Maintain a Product View ............................................................................................. 44
Add Variables to a Group ..................................................................................................... 44
Add Variables Not Present in Product Definitions ................................................................. 45
Group the Variables ............................................................................................................. 45
Create Repeating Groups of Variables ................................................................................. 46
Edit Items In the Product View Pane .................................................................................... 48
Save the Product View ......................................................................................................... 49
•
•
4 ••
•
•
Product View Builder Installation and User Guide
Figures
Figure 1
Figure 2
Figure 3
Figure 4
Figure 5
Figure 6
Figure 7
Figure 8
Figure 9
Figure 10
Figure 11
Figure 12
Figure 13
Figure 14
The Complete Autonomy Document Generation Suite Solution................................ 16
Product View Builder User Interface Overview ......................................................... 26
Data Sources pane - Product Definition File (left) and XML File (right)..................... 29
Commands in the Product View Menu for a Group ................................................... 31
Properties Pane for a String Variable ........................................................................ 33
Properties Pane for a Date Variable .......................................................................... 34
Properties Pane for a Number Variable..................................................................... 35
Properties Pane for an Image Variable...................................................................... 36
Properties Pane for a Boolean Variable .................................................................... 37
Properties Pane for a Group...................................................................................... 38
Properties Pane for a Repeating Group .................................................................... 38
New Variable Created in the Product View................................................................ 44
New Variable Group Created in the Product View..................................................... 46
New Repeating Group of Variables ........................................................................... 47
Product View Builder Installation and User Guide
•
•
•
• 5
•
•
Figures
•
•
6 ••
•
•
Product View Builder Installation and User Guide
About This Document
This guide is for Autonomy Document Generation Suite Product View Builder
users and administrators. It is intended for readers who are responsible for setting
up, using, and maintaining a Product View Builder installation.

Documentation Updates

Conventions

Related Documentation

Autonomy Product References

Autonomy Customer Support

Contact Autonomy
Documentation Updates
The information in this guide is current as of Autonomy Document Generation
Suite version 1.3.3. The content was last modified 18 November 2013. You can
retrieve the latest available product documentation from Autonomy’s Knowledge
Base on the Customer Support Site:
https://customers.autonomy.com
A document in the Knowledge Base has a version number (for example, version
7.5) and may also have a revision number (for example, revision 3). The version
number applies to the product that the document describes. The revision number
applies to the document. The Knowledge Base contains the latest available
revision of any document.
Product View Builder Installation and User Guide
•
•
• 7
•
•
•
About This Document
To access Autonomy documentation
1. Go to the Autonomy Customer Support site at
https://customers.autonomy.com
2. Click Login.
3. Enter the login credentials that were given to you, and then click Submit.
The Knowledge Base Search page opens.
4. In the Search box, type a search term or phrase. To browse the Knowledge
Base using a navigation tree only, leave the Search box empty.
5. Ensure the Documentation check box is selected.
6. Click Search.
Documents that match the query display in a results list.
7. To refine the results list, select one or more of the categories in the Filter By
pane. You can restrict results by
 Product Group. Filters the list by product suite or division. For example,
you could retrieve documents related to the iManage, IDOL, Virage or
KeyView product suites.
 Product. Filters the list by product. For example, you could retrieve
documents related to IDOL Server, Virage Videologger, or KeyView Filter.
 Component. Filters the list by a product’s components. For example, you
could retrieve documents related to the Content or Category component in
IDOL.
 Version. Filters the list by product or component version number.
 Type. Filters the list by document format. For example, you could retrieve
documents in PDF or HTML format. Guides are typically provided in both
PDF and HTML format.
8. To open a document, click its title in the results list.
To download a PDF version of a guide, open the PDF version, click the Save icon
in the PDF reader, and save the PDF to another location.
•
•
8 ••
•
•
Product View Builder Installation and User Guide
Conventions
Conventions
The following conventions are used in this document.
Notational Conventions
This guide uses the following conventions.
Convention
Usage
Bold
User-interface elements such as a menu item or
button. For example:
Click Cancel to halt the operation.
Italics
Document titles and new terms. For example:
 For more information, see the IDOL Server
Administration Guide.
 An action command is a request, such as a query
or indexing instruction, sent to IDOL Server.
monospace font
File names, paths, and code. For example:
The FileSystemConnector.cfg file is installed in
C:\Autonomy\FileSystemConnector\
monospace bold
Data typed by the user. For example:
 Type run at the command prompt.
 In the User Name field, type Admin.
monospace italics
Replaceable strings in file paths and code. For
example:
user UserName
Product View Builder Installation and User Guide
•
•
• 9
•
•
•
About This Document
Command-line Syntax Conventions
This guide uses the following command-line syntax conventions.
Convention
Usage
[ optional ]
Brackets describe optional syntax. For example:
[ -create ]
|
Bars indicate “either | or” choices. For example:
[ option1 ] | [ option2 ]
In this example, you must choose between option1
and option2.
{ required }
Braces describe required syntax in which you have a
choice and that at least one choice is required. For
example:
{ [ option1 ] [ option2 ] }
In this example, you must choose option1,
option2, or both options.
required
Absence of braces or brackets indicates required
syntax in which there is no choice; you must type the
required syntax element.
variable
Italics specify items to be replaced by actual values.
For example:
<variable>
-merge filename1
(In some documents, angle brackets are used to
denote these items.)
...
Ellipses indicate repetition of the same pattern. For
example:
-merge filename1, filename2 [,
filename3 ... ]
where the ellipses specify, filename4, and so on.
The use of punctuation—such as single and double quotes, commas, periods—
indicates actual syntax; it is not part of the syntax definition.
•
•
10 ••
•
•
Product View Builder Installation and User Guide
Related Documentation
Notices
This guide uses the following notices:
CAUTION A caution indicates an action can result in the loss
of data.
IMPORTANT An important note provides information that is
essential to completing a task.
NOTE A note provides information that emphasizes or
supplements important points of the main text. A note supplies
information that may apply only in special cases—for example,
memory limitations, equipment configurations, or details that
apply to specific versions of the software.
TIP A tip provides additional information that makes a task
easier or more productive.
Related Documentation
The following documents provide more details on the Autonomy Document
Generation Suite:

Autonomy Document Generation Suite Administration Guide

Autonomy Document Generation Suite Template Manager Installation and
User Guide
Autonomy Product References
This document references the following Autonomy products:
 Autonomy Scrittura (Scrittura)
Product View Builder Installation and User Guide
•
•
• 11
•
•
•
About This Document

Autonomy Document Generation Suite (Document Generation Suite)

Autonomy Document Generation Suite Template Manager (Template
Manager)
Autonomy Customer Support
Autonomy Customer Support provides prompt and accurate support to help you
quickly and effectively resolve any issue you may encounter while using
Autonomy products. Support services include access to the Customer Support
Site (CSS) for online answers, expertise-based service by Autonomy support
engineers, and software maintenance to ensure you have the most up-to-date
technology.
To access the Customer Support Site, go to
https://customers.autonomy.com
The Customer Support Site includes:

Knowledge Base: The CSS contains an extensive library of end user
documentation, FAQs, and technical articles that is easy to navigate and
search.

Case Center: The Case Center is a central location to create, monitor, and
manage all your cases that are open with technical support.

Download Center: Products and product updates can be downloaded and
requested from the Download Center.

Resource Center: Other helpful resources appropriate for your product.
To contact Autonomy Customer Support by e-mail or phone, go to
http://www.autonomy.com/content/Services/Support/index.en.html
•
•
12 ••
•
•
Product View Builder Installation and User Guide
Contact Autonomy
Contact Autonomy
For general information about Autonomy, contact one of the following locations.
Europe and Worldwide
North and South America
E-mail: autonomyinfo@hp.com
E-mail: autonomyinfo@hp.com
Telephone: +44 (0) 1223 448 000
Fax: +44 (0) 1223 448 001
Telephone: 1 415 243 9955
Fax: 1 415 243 9984
Autonomy Corporation plc
Cambridge Business Park
Cowley Road
Cambridge CB4 0WZ
United Kingdom
Autonomy, Inc.
One Market Plaza
Spear Tower, Suite 1900
San Francisco CA 94105
USA
Product View Builder Installation and User Guide
•
•
• 13
•
•
•
About This Document
•
•
14 ••
•
•
Product View Builder Installation and User Guide
CHAPTER 1
Introduction to Product View
Builder
The topics in this section provide the following:

Overview of Autonomy Document Generation Suite

Overview of Product View Builder
Overview of Autonomy Document Generation Suite
The Autonomy Document Generation Suite can be used to generate documents.
It uses templates that are designed using Autonomy Document Generation Suite
Template Manager in Microsoft Word 2007 and 2010, and dynamic data feeds for
trades and other business operations.
Before running a production system, a design phase is necessary to define
templates and the data for use within templates.
The different servers and modules can be integrated with the Scrittura as the
application server and workflow.
Product View Builder Installation and User Guide
•
•
• 15
•
•
•
Chapter 1 Introduction to Product View Builder
The three main stages in the process are:

Product View design
Product Views are the data dictionaries used for template design.

Template design
Templates are document models containing text, logic, and data placeholders
that are evaluated and replaced with live data when documents are
generated.

Document generation
The Product Views, templates, and data from the live system are used to
create the document.
Figure 1 The Complete Autonomy Document Generation Suite Solution
•
•
16 ••
•
•
Product View Builder Installation and User Guide
Overview of Product View Builder
Overview of Product View Builder
Product View Builder is a product that lets you design Product Views from Product
Definitions.
A Product View is a structured view of all the variables required for the creation of
a Template, which is visible in a separate tab when using the Autonomy Template
Manager. It is a display of variables with formatting and hierarchy information,
making Template creation and production an easy and intuitive process.
The Product View Builder uses drag-and-drop functionality for building the
Product View for Template creation within Template Manager. Product View
Builder lets you create a Product View and drag/drop the variables of Data
Sources—such as XML files or Scrittura Product Definitions—onto the Product
View variables. Variables and other Template content controls, such as repeater
sections that are saved for re-use, can then be dragged directly from the Product
View and dropped onto the Template.
Data can easily be added from sources such as Scrittura Product Definition files
or custom XML files. Individual variables can be aggregated into meaningful
groups, even if the data source provides information in a flat structure. You can
also enter sample values for test display purposes.
Product Views can be stored locally on user machines, or directly in the Scrittura
DocManager.
Product View Builder Installation and User Guide
•
•
• 17
•
•
•
Chapter 1 Introduction to Product View Builder
•
•
18 ••
•
•
Product View Builder Installation and User Guide
CHAPTER 2
Install and Configure Product
View Builder
The topics in this section provide the installation instructions for Product View
Builder.

Confirm System Requirements

Install Product View Builder

Launch Product View Builder

Configure Product View Builder

Configure SSL Support
Confirm System Requirements
The following hardware, operating systems, and third-party software are required
to install and run Product View Builder.

Windows 2000, 2003, XP, or Windows 7 Operating Systems

.NET Framework 3.5 or higher
Product View Builder Installation and User Guide
•
•
• 19
•
•
•
Chapter 2 Install and Configure Product View Builder
Install Product View Builder
To install Product View Builder, you must run the installer on each machine that is
used for Product View creation.
To install Product View Builder
1. Double-click the installer package.
The Welcome dialog box opens.
2. Read the text and click Next.
The select Installation Folder dialog box opens.
3. Specify the directory where you want to install Product View Builder.
By default, the system is installed on C:\Program Files\Autonomy\
Product View Builder\, but you can click Browse to navigate to another
location.
Select whether the installation is for only yourself or for anyone who uses the
computer.
4. Click Next.
The Confirm Installation dialog box opens.
5. Click Next.
The program begins installing. When Product View Builder is installed
successfully, the Install Complete dialog box opens.
6. Click Close.
Product View Builder is installed.
•
•
20 ••
•
•
Product View Builder Installation and User Guide
Launch Product View Builder
Uninstall Product View Builder
In the event you should ever need to uninstall the Product View Builder, follow the
instructions provided:
To uninstall Product View Builder
1. From the Windows system tray, click Start.
The Start menu opens.
2. Click Settings and then Control Panel.
The Control Panel dialog opens.
Click Add or Remove Programs to display a list of all currently installed
programs.
3. Select Product View Builder and click Remove.
Product View Builder is uninstalled.
Launch Product View Builder
You may want to create a shortcut to Product View Builder on your desktop for
faster access.
To launch Product View Builder
1. Click the Windows Start button to access the Start menu.
2. Click Programs, and point to Autonomy.
3. Click Product View Builder to launch the Product View Builder application.
To create a shortcut
1. Repeat Steps 1 and 2 in the procedure to launch Product View Builder.
2. Right-click Product View Builder.
3. Select Create Shortcut in the drop-down command menu that opens.
The shortcut appears on your desktop.
Product View Builder Installation and User Guide
•
•
• 21
•
•
•
Chapter 2 Install and Configure Product View Builder
Configure Product View Builder
By default, Product View Builder saves your work to the Scrittura server. However,
if you want to, you can change the default settings. For example, you may prefer
the option to Work Offline, which lets you load Product Views from your computer
and save them on your computer.
Following are settings you can configure:

Connection. Lets you to decide whether to work on your Product Views from
your local computer or connect to the Scrittura server.

Variable Names. Lets you choose the type of variable to use for naming. A
visible name is the business name of the variable that make sense for you.
The internal name is the underlying technical name of the variable.

Server. Lets you type the details for the Scrittura server if you are saving your
work there.

Offline. Lets you set the filepath to the folder where your Product Views are
saved if you are working offline.

Sample Data. Lets you automatically pre-populate the Product View with data
contained in the source file. This is available only for XML sources.
To change the settings in Product View Builder
1. Select File > Settings.
The Settings dialog opens.
2. Edit the necessary settings.
3. Click OK to save the entries when you are finished.
Configure SSL Support
Configurations for Product View Builder are performed in the
ProductViewBuilder.exe.config file. It is a standard .NET application
configuration file in XML format and is located in the same directory where
Product View Builder is installed.
There are settings in the ProductViewBuilder.exe.config file that enable
Secure Sockets Layer (SSL) connectivity with Product View Builder.
•
•
22 ••
•
•
Product View Builder Installation and User Guide
Configure SSL Support
Configure SSL Connectivity
If you want to use SSL, it is necessary to configure the SSL connectivity settings
in the ProductViewBuilder.exe.config file.
To activate SSL connectivity
1. Open the ProductViewBuilder.exe.config file.
2. Configure the settings listed in the following table.
SSL connectivity is configured.
Table 1 SSL Connectivity Settings
Parameter
Description
dms
Set this value to docmanager to use
DocManager as your document management
system for storing product views.
usesecuresocketslayer
Set this value to true to use SSL in
communicating with DocManager servers.
This is configurable from the Settings dialog.
requiresecuresocketslayer
Set this value to true to require the use of SSL.
Note: Setting this value to true disables the user
interface option that determines whether to use
the secure sockets layer.
requiretrustedcertificateauthority
Set this value to true to require the certificates
from the DocManager servers to which you
connect to be issued from trusted certificate
authorities.
If your DocManager server uses a self-signed
certificate, set this value to false.
Product View Builder Installation and User Guide
•
•
• 23
•
•
•
Chapter 2 Install and Configure Product View Builder
•
•
24 ••
•
•
Product View Builder Installation and User Guide
CHAPTER 3
Explore the Product View
Builder Interface
The topics in this section describe the layout and use of the Product View Builder
user interface.

General Layout

Menus

Data Source Pane

Product View Pane

Properties Pane
General Layout
The general layout of Product View Builder is shown in Figure 2 on page 26.
Product View Builder Installation and User Guide
•
•
• 25
•
•
•
Chapter 3 Explore the Product View Builder Interface
Figure 2 Product View Builder User Interface Overview
The four main sections are highlighted in red:
A.“Menus” on page 26
B. “Data Source Pane” on page 29
C. “Product View Pane” on page 30
D. “Properties Pane” on page 32
Menus
The Menus are represented by section A inFigure 2.
The Product View Builder Main Menu section contains File tasks that let you
perform Product View Builder tasks, such as open/close, create new, import,
search, preview, and more. See “File Menu” on page 27 for more information.
The edit tasks let you perform tasks on variables and groups in Product Views,
such as add, delete, find, and more. See “Edit Menu” on page 27 for more
information.
There is also a Quick Access Menu Bar that has reduced steps for quickly
performing tasks on Product Views. See “Quick Access Menu” on page 28 for
more information.
•
•
26 ••
•
•
Product View Builder Installation and User Guide
Menus
File Menu
You can perform tasks such as open, create new, import, and preview for Product
Views.
To perform tasks related to Product Views
1. Click File menu option.
A list of commands displays.
 New. Create a new Product View file.
 Open. Open a Product View.
 Close. Close the current Product View.
 Save and Save As. Save the current Product View.
The default directory is set in the Settings menu.
 Import Source... Import a data source file.
This can be either a Scrittura Product Definition or a custom XML file.
 Preview. Display a preview of the generated Product View XML in your
web browser.
 Settings. Edit the default settings for Product View Builder.
 Work Offline. Work offline on your local system.
Working on line allows you to connect to the Scrittura Doc Manager.
 Exit. Close the application.
2. Select a command to perform.
A command-related dialog box opens.
3. Make appropriate entries.
4. Click Save to save your entries.
Edit Menu
You can perform edit-related tasks for variables and groups in Product Views.
To perform tasks for variables and groups
1. Click the Edit menu option.
A list of commands displays.
 Add Field From Source.... Add a variable to a group in the Product View
pane.
Product View Builder Installation and User Guide
•
•
• 27
•
•
•
Chapter 3 Explore the Product View Builder Interface
 Add Group. Add a group in the Product View pane. See “Group the
Variables” on page 45.
 Add Repeating Group. Add a repeating group in the Product View pane.
See “Create Repeating Groups of Variables” on page 46.
 Edit Properties. Edit the properties of a variable or group. See “Edit Items
In the Product View Pane” on page 48

Rename. Change the visible name of a variable or group.

Change Type. Change the type of the variable.

Change Format. Change the format of the variable.

Sample Data. Enter in sample data for a variable.
 Delete. Delete the group or variable.
 Find. Find a specific variable within the Product View pane.
2. Select a command to perform.
A command-related dialog box opens.
3. Make appropriate entries.
4. Click Save to save your entries.
Quick Access Menu
The Quick Access Menu consists of icons that typically let you perform Product
View tasks with fewer steps than the regular menu commands.
The following icons are visible in the quick access menu in Product View Builder:

Click to create a new Product View.

Click to open a Product View.

Click to save the current Product View.

Click to work offline.
Working offline lets you work from your local computer, rather than connect to
Scrittura Doc Manager.

Click to delete the highlighted item (and all children) in the Product View.

Click to search within the Product View.
Your cursor is taken to the search pane at the bottom of the Product View
pane where you can enter search information.
•
•
28 ••
•
•
Product View Builder Installation and User Guide
Data Source Pane
Data Source Pane
The Data Source pane is represented by section B in Figure 2.
The Data Source pane displays the raw data source variables that have been
pulled from a Scrittura Product Definition file or an XML example data source, as
shown in Figure 3.
When Product View Builder is using an XML example file as a data source, this is
an arbitrary XML file which serves as an example of variables and their structure.
The XML example data sources also provide sample data using the values of
elements in the XML example data source.
Figure 3 Data Sources pane - Product Definition File (left) and XML File (right)
All variables from a Scrittura Product Definition file are listed alphabetically in the
pane. For Product Definition files, all variables from Product Definition files that
are included in that file are also listed.
To view information about a selected variable
1. Click on a variable in a Product Definition file.
Information displays in the bottom section of the pane.
Product View Builder Installation and User Guide
•
•
• 29
•
•
•
Chapter 3 Explore the Product View Builder Interface
This information includes:
 Value Type. Value type of the variable, such as String, Double, OneOf.
 Internal Name. Internal name of the variable. This is prefixed with pi_ for
Product Definition variables and xm_ for XML example data sources.
 Visible Name. Visible “user-friendly” display name that is used.
More than one data source can be open.
2. To select between open data sources, use the Selected Data Source
drop-down menu:
Search in the Data Source Pane
There is a search bar at the bottom of the Data Source pane that you can use to
locate variables. You can use exact matches and wildcard searches (using * to
represent any letter or letters).
To search for a variable
1. Click in the Search text box at the bottom of the Data Source pane.
2. Type the name of the variable.
3. Press Enter or click
to the right of the text box to find the item.
Product View Pane
The Product View pane is represented by section C Figure 2.
The Product View pane displays the current hierarchical structure of the Product
View and provides options to manipulate this structure.
Groups are represented by
in the Product View.
Repeating groups are represented by
in the Product View.
To build and use the Product View
1. Do one of the following:
•
•
30 ••
•
•
Product View Builder Installation and User Guide
Product View Pane
 Drag variables from the Data Source pane to the correct position in the
hierarchy within the Product View pane.
 Use Edit > Add Field From Source to add the selected field in the data
source pane to the selected group in the product view pane.
2. Right-click a variable, group, or repeating group on any level of the Product
View.
A context menu such as the one shown in Figure 4 opens with a list of
commands.
Figure 4 Commands in the Product View Menu for a Group
3. Choose the option you want.
Search in the Product View Pane
In order to search for a specific variable in the Product View pane, use the search
box.
To search in the Product View pane
1. Do one of the following:
 Click
Find in the Quick Access Toolbar.
 Click Edit > Find, or click in the search text box at the bottom of the
Product View pane.
2. Type the name of the variable.
3. Press Enter or click
Product View pane.
Product View Builder Installation and User Guide
to the right of the text box to find the item in the
•
•
• 31
•
•
•
Chapter 3 Explore the Product View Builder Interface
Properties Pane
The Properties pane is represented by section D in Figure 2.
The Properties pane displays properties for the Product View variable that is
currently selected. Properties include display and formatting options for the
variables as well as count information for repeater sections within the Product
View.
In the Properties pane, the data in a variable can be changed, but it's mapping to
an internal product instance variable is set.
The Properties pane is divided into three sub-sections. Only some of the
displayed property values can be edited. Click on the labels for a sub-section to
display a description of that sub-section at the bottom of the pane.
The sub-sections provide the following information:

General. Visible label of the variable, group, or repeating group, and its type.
The type can be changed by selecting the type from the type list.

Mapping. Internal name of the variable, group or repeating group.
This cannot be edited.

Sample Data. A text box that lets you type sample data for a variable.
After any properties are changed, you must click Commit Changes at the bottom
of the Properties pane to save the changes. If you do not commit your changes, a
dialog box prompts you to commit or discard your changes.
The following sections provide examples of the various variables you can edit in
the Properties pane.
•
•
32 ••
•
•
Product View Builder Installation and User Guide
Properties Pane
String Variable
A string variable is any combination of one or more characters. Figure 5 shows an
example Properties pane for a string variable.
Figure 5 Properties Pane for a String Variable
The following fields can be edited for a string variable:

Text. Visible label for the variable.

SampleDataValue. Sample value for this variable.
Product View Builder Installation and User Guide
•
•
• 33
•
•
•
Chapter 3 Explore the Product View Builder Interface
Date Variable
Figure 6 shows an example Properties pane for a date variable.
Figure 6 Properties Pane for a Date Variable
The following fields can be edited for a date variable:

Text. Visible name for the variable.

Format. Date format for the variable.
You can select this format from the drop-down or manually enter it into the text
box.

•
•
34 ••
•
•
SampleDataValue. Sample value for this variable.
Product View Builder Installation and User Guide
Properties Pane
Number Variable
Figure 7 shows an example Properties pane for a number variable.
Figure 7 Properties Pane for a Number Variable
The following fields can be edited for a number variable:

Text. The visible name for the variable.

Format. The display format for the variable.You can select this format from the
drop-down or manually enter it into the text box.

SampleDataValue. A sample value for this variable.
Product View Builder Installation and User Guide
•
•
• 35
•
•
•
Chapter 3 Explore the Product View Builder Interface
Image Variable
Figure 8 shows an example Properties pane for an image variable.
Figure 8 Properties Pane for an Image Variable
The following fields can be edited for an image variable:

Text. Visible name for the variable.

SampleDataValue. Sample value for this variable.
If you click anywhere in this field, a file browser opens. You can use this to
browse to the location of the image on the file system and select it. The image
is inserted into the Product View file as binary data.
NOTE The JPG, GIF and BMP image formats are
supported. When reloading an existing Product View
file, the binary data in the XML is read and written to
unique temp files. The default location is the Temp
directory in the Product View Builder installation
directory.
The sample data field for the variable points to the temp
file to preserve the data on a reload or save. It is
possible to change the sample data to another file
before saving.
•
•
36 ••
•
•
Product View Builder Installation and User Guide
Properties Pane
Boolean Variable
Figure 9 shows the Properties pane for a Boolean variable.
Figure 9 Properties Pane for a Boolean Variable
The following fields can be edited for a Boolean variable:

Text. Visible name for the group variable.

SampleDataValue. Sample value for this variable.
A drop-down list is available with a choice of values True or False.
Product View Builder Installation and User Guide
•
•
• 37
•
•
•
Chapter 3 Explore the Product View Builder Interface
Group
Figure 10 shows the Properties pane for a group.
Figure 10 Properties Pane for a Group
The following fields can be edited for a group:

Text. The visible name for the group variable.
Repeating Group
Figure 11 shows the Properties pane for a repeating group.
Figure 11 Properties Pane for a Repeating Group
The following fields can be edited for a repeating group:
•
•
38 ••
•
•

Text. Visible name for the group variable.

SetCount. Number of instances of this set that are created for sample data.
Product View Builder Installation and User Guide
Properties Pane
Structured Properties
When the root of the Product View is set as structured, all child groups of the root
have additional property fields, which are shown beneath the other property fields.
For more information on structured Product Views, see “Set a Product View as
Structured” on page 43.

Role. Either Stub or Component.

Identifier. Number to identify the group.

Description. Text description for the group.
Product View Builder Installation and User Guide
•
•
• 39
•
•
•
Chapter 3 Explore the Product View Builder Interface
•
•
40 ••
•
•
Product View Builder Installation and User Guide
CHAPTER 4
Create a Product View
This section describes how to create a Product View using an existing Scrittura
Product Definition file, and save it to the local file system.

Load a Data Source

Create a New Product View

Build and Maintain a Product View
Load a Data Source
Data sources are lists of variables that can be added into the Product View. Data
sources cannot be modified in any way using Product View Builder.
Before a Product View can be built, a Product Definition or XML example data
source must be loaded into the Data Source pane in Product View Builder.
To load a Product View
1. Click
on the quick access menu.
The file browser opens.
2. Select the Product Definition file to load.
3. Click Open.
The Product View is loaded.
Product View Builder Installation and User Guide
•
•
• 41
•
•
•
Chapter 4 Create a Product View
To load a data source
1. Select file > Import Source.
The file browser opens.
2. Select the XML or Product View file to load.
3. Click Open.
The data source is loaded.
Create a New Product View
When you first open Product View Builder, a new Product View is created in the
Product View pane. This new Product View is called ProductInstance and
can be removed or renamed and used, You can also choose to load a saved
Product View. When a Product View is opened, its corresponding extract of the
Data Source is loaded. The Data Source is saved within the product view.
To create a new Product View
1. In the quick access menu, click
or click File > New.
A new Product View root group named ProductInstance is created in the
Product View pane.
2. Click on ProductInstance to show the details in the Properties pane.
3. Click on the name ProductInstance in the Properties pane and type a
name for the new Product View.
A new Product View is created.
To open an existing Product View
1. In the quick access menu, click
or click File > Open.
The file browser opens.
2. Select the Product View XML file to open.
3. Click Open.
The Product View opens.
•
•
42 ••
•
•
Product View Builder Installation and User Guide
Set a Product View as Structured
Set a Product View as Structured
By default the Product View is set as non-structured.
You may prefer to use the structured Product View, which is designed for
confirming a collection of component groups.
The structured Product View is used for structured Products. This means that the
top level of a structured Product View can contain only groups—no variables or
repeating groups. The root of the Product View can be set as structured.
Each of the direct child nodes of the root represents a component of the structure
or the stub itself.
To set the role of a child node of the root
1. Click on the node in the Product View pane
2. In the Properties pane, click Role.
3. Select either Stub or Component from the Role list.
NOTE There can be as many components as required
but a maximum of 1 stub. If there is a stub, it is always
the first child group. If a child is changed to a stub, it is
moved to the top position and any existing stub is
marked as a component.
Product View Builder Installation and User Guide
•
•
• 43
•
•
•
Chapter 4 Create a Product View
Build and Maintain a Product View
Once a Data Source has been loaded, a Product View can be built using different
types of variables.
Add Variables to a Group
You can add variables to a group.
Only non-indexed variables from the Product Definition file can be added in a flat
hierarchy.
If an indexed variable is added, a repeating group is automatically created with
the indexed variable available under it. An indexed variable can also be directly
dragged onto a previously created repeating group. You may add indexed
variables as a repeating group if you intend to access them as arrayed elements
within the Template.
To add variables into a group
1. Do one of the following:
 From the Data Source pane, click and drag the Product View variable
onto the group in the Product View pane.
 Select the desired variable in the Data Source pane and select the desired
node in the Product View pane.
Click Edit > Add Field from Source.... The selected variable is added to
the selected node.
The variable displays in the Product View structure under the group as shown
in Figure 12 example.
Figure 12 New Variable Created in the Product View
2. Click the variable in the Product View to display and edit the variable
properties.
3. In the Properties pane, edit the formatting and display information for added
variables.
•
•
44 ••
•
•
Product View Builder Installation and User Guide
Build and Maintain a Product View
Add Variables Not Present in Product Definitions
You may need to use a variable for Template creation that is not present in an
existing Scrittura Product Definition file. It is recommended that you add the
variable to the source Product Definition file, and then add this in the Product View
Builder.
For testing purposes, Product View Builder includes a utility XML file,
BuiltInVars.xml, for adding test variables to the Product View file. This is
located in your installation directory. It contains a sample CommonReferenceId
variable.
You can manipulate this file directly using a text or XML file editor. You can use all
data types that are supported by Scrittura Product Definition files. Variables in this
file are automatically added to the Data Source pane when it is loaded using a
Product Definition file.
Group the Variables
You can group variables together. For example, you may want to group all the
variables related to the “Counterparty” such as name, address, or phone number.
A group of variables lets you keep together similar elements within your Product
View. Keeping elements together makes navigating though the list of variables
easier when the Product View is used in Template Manager.
To group variables
1. In the Product View pane, right click the parent group and click Add Group or
click Edit > Add Group.
A new group is created with a default name.
2. Click the new group, or use the Properties pane to rename the group.
3. Do one of the following:
 From the Source pane, drag variables to the group in the Product View
pane.
 Select the desired variable in the Data Source pane and select the desired
node in the Product View pane
Click Edit > Add Field From Source.... The selected variable is added to
the selected node.
4. In the Properties pane, edit the formatting and display information for each of
these variables.
Product View Builder Installation and User Guide
•
•
• 45
•
•
•
Chapter 4 Create a Product View
NOTE To add a group to an existing group or repeating
group, right click the corresponding group in the Product
View into which the new group is added and follow the
procedure above.
The example in Figure 13 shows the new group that is created in the Product
Instance root.
Figure 13 New Variable Group Created in the Product View
Create Repeating Groups of Variables
You can create repeating groups of variables for re-use as collections in other
generated documents.
A repeating group is similar to a group except that it applies to collections of data
within the Product View (such as a schedule). A repeating group lets you keep
related collection elements together for a better navigability.
Repeating Groups let you insert collections of data into generated documents,
such as tables or repeated sections of document, with very little effort when
designing Templates. For more information on Repeating Groups, refer to the
Template Manager documentation.
To create a repeating group with the Add command
1. In the Product View pane, right click the parent group and click Add
Repeating Group.
A new group is created with a default name.
Click the new group, or use the Properties pane to rename the group.
2. Do one of the following:
 From the Source pane, drag variables to the new group in the Product
View pane.
 Select the desired variable in the Data Source pane and select the desired
node in the Product View pane
Click Edit > Add Field From Source.... The selected variable is added to
the selected node.
•
•
46 ••
•
•
Product View Builder Installation and User Guide
Build and Maintain a Product View
Both non-indexed and indexed variables can be added to this repeating group.
3. In the Properties pane, edit the formatting and display information for each of
these variables.
The repeating group is added.
NOTE To add a repeating group to an existing group or
repeating group, right click the corresponding group in the
Product View in which the new repeating group is added and
follow the procedure above.
The example in Figure 14 shows the application window that displays when the
Is Triggered repeating group is created under the ProductInstance root
section.
Figure 14 New Repeating Group of Variables
To create a repeating group by dragging an indexed variable
1. Do one of the following:
 Drag an indexed variable from the Data Sources pane to the Product
View hierarchy.
 Click Edit > Add Field From Source... to add the selected variable in the
data source pane to the selected node in the product view pane.
A new repeating group is created with a default name and the variable is
displayed beneath it in the hierarchy.
2. Click the newly created group, or use the Properties pane to rename the
repeating group.
You can edit the formatting and display information in the Properties pane for
each of these variables.
3. Drag additional variables from the Data Source pane to the group in the
Product View pane, if required.
You can edit the formatting and display information in the Properties pane for
each of these variables.
The repeating group is created.
Product View Builder Installation and User Guide
•
•
• 47
•
•
•
Chapter 4 Create a Product View
Both non-indexed and indexed variables can be added into this repeating group.
Edit Items In the Product View Pane
You can move, remove, or rename variables, groups, and repeating groups in the
Product View pane.
To move variables and groups within the Product View pane
1. Go to the Product View pane.
2. Right-click on the variable or group.
3. In the context menu, select Move Up or Move Down.
You can also click Ctrl+Up or Ctrl-Down to move highlighted items.
To remove a variable, group, or repeating group
1. Go to the Product View pane.
2. Right-click the variable, group, or repeating group.
3. Click Remove.
Alternatively you can do the following to remove a variable, group, or
repeating group:
a. Highlight it.
b. Press DELETE.
c. Click
in the quick access menu.
To rename a variable, group, or repeating group
1. Go to the Product View pane.
2. Click the variable, group, or repeating group.
3. In the Properties pane, change the name of the group by typing a new name
into the text box.
Alternatively, click Edit > Rename.
•
•
48 ••
•
•
Product View Builder Installation and User Guide
Build and Maintain a Product View
Save the Product View
When you save a Product View file, the contents are saved in the following order:

Group elements

Repeating groups
 All the variables directly under the root section
The order of the variables chosen within the groups, repeating groups, and single
variable sections are maintained
To save the Product View
1. From the Product View pane.
2. Click File > Save, File > Save As, or
.
A file browser opens.
3. Navigate to location on the file system where you want to save the Product
View.
4. Type the name of the Product View file and click Save.
Product View Builder Installation and User Guide
•
•
• 49
•
•
•
Chapter 4 Create a Product View
•
•
50 ••
•
•
Product View Builder Installation and User Guide
Download PDF
Similar pages