Pro-Des igner
Startup Guide
Preface
Thank you for purchasing Pro-face’s Pro-Designer software.This manual is a basic introduction to the
features and set up of Pro-Designer. For more detailed descriptions of advanced-level features, please refer
to this software’s online help.
Also, some of the images used in this manual may differ slightly from the screens used in the Pro-Designer
software.
Please read this and all related manuals carefully to ensure proper use of this product. We recommend that
you keep this and all related manuals handy for easy reference.
Important
1 A ll programs and manuals included with Pro-Des igner ("the product") are the copyright of Digital
Electronics Corporation. Digital Electronics Corporation grants the us er the licens e to us e thes e
materials under the Software Licens e A greement. A ny violation of the Software Licens e A greement
is prohibited under the laws and regulations of Japan and other countries .
2 This manual has been prepared with all due care. However, s hould you have any ques tions about
this manual, contact your local Digital Electronics Corporation s ales repres entative.
3 Regardles s of the above provis ions , Digital Electronics Corporation s hall not be res pons ible for
any damage or financial los s es accruing from the us e of the product or for any claim made by a
third party.
4 The product s upplied may differ s lightly from the operation and functions des cribed in this manual
due to product modifications . Information on any changes to the product is provided in a
s upplement to this publication provided in printed or electronic form. Pleas e refer to the
s upplement when us ing this manual.
5 Information recorded or dis played in this product may include content related to intangible
property or intellectual property owned by a third party. However, this does not imply that Digital
Electronics Corporation grants the us er or a third party any guarantee or licens e to us e s uch
property.
© 2002, Digital Electronics Corporation. All rights reserved.
Please refer to “Trademark Rights” for information on trademarks and trade names.
Pro-Designer Startup Guide
1
Preface
Documentation Conventions
In this manual the following warning symbols are used to indicate important points concerning safe and
proper operation of the PS-G unit. Prior to operating the PS-G unit, be sure to read these points carefully.
Warning Symbols
This manual’s warning symbols indicate the following levels of danger.
WARNING
Failure to fully comply with points indicated by this
symbol may result in death or serious injury.
CAUTION
Failure to fully comply with points indicated by this
symbol may result in injury or equipment damage.
Indicates actions or procedures that should NOT be
performed.
Indicates actions or procedures that MUST be
performed to ensure proper operation.
The following mark is also used in this manual.
Refers to related information or an additional explanation.
2
Pro-Designer Startup Guide
Preface
Trademark Rights
All company or product names used in this manual are the trade names, trademarks (including registered
trademarks), or service marks of their respective companies.
This product omits individual descriptions of each of these rights.
Trademark / Trade Name
Right Holder
Microsoft, MS, Windows, Windows
95, Windows 98, Windows NT,
Windows 2000, Windows XP,
Windows CE, Windows Explorer,
eMbedded Visual C++
Intel, Pentium
Microsoft Corporation, USA
Intel Corporation, USA
Pro-face
Digital Electronics Corporation
(in Japan and other countries)
IBM, VGA
International Business Machines
Corporation (IBM), USA
Adobe, Acrobat
Adobe Systems Incorporated
The following terms differ from the above mentioned formal trade names and trademarks.
Term used in this manual
Formal Trade Name or Trademark
Windows NT
Microsoft ® Windows ® NT Operating System
Windows 2000
Windows XP
Microsoft ® Windows ® 2000 Operating
System
Microsoft ® Windows ® XP Operating System
Windows CE
Microsoft ® Windows ® CE Operating System
Pentium
Acrobat Reader 5.0
Intel® Pentium® Processors
Pro-Designer Startup Guide
Adobe® Acrobat ® Reader 5.0
3
Preface
Target Machines
The following models are the target machines described in this manual:
Target Machine
Series Name
GP-2600 Series
Model Name
GP-2600T*1
GP-2500T*1
GP-2500 Series
GP-2500S*1
GP-2500L
GP-2400 Series
GP-2400T*1
GP-2300T
GP-2300 Series
GP2000 Series
GP-2601 Series
GP-2501 Series
GP-2401 Series
GP-2300L
GP-2601T
GP-2501T
GP-2501S
GP-2401T
GP-2301T
GP-2301 Series
GP-2301S
GP-2301L
GP2000H Series
GP-2301H Series
GP-2301HS
GP-2301HL
GP-2401H Series
GP-2401HT
GP37W3 Series
GP-37W3 Series
GP-37W3B
PS Series Type P
PS-500P Series
PS Series Type G
PS Series Type B
PS-400G Series
PS-600G Series
PS-2000B Series
PL-5900 Series
PL Series
*2
PL-X900 Series
PL-X920 Series
Factory Gateway
Factory Gateway
Windows® compatible PC
*2
*1 This software is compatible only with Revision “2” of these models. The revision number is indicated
on the GP unit’s rear face revision label.
An asterisk (*) here
indicates Revision 2.
*2 This software is compatible only with computers running Windows NT 4.0 (Service Pack 4 or higher),
Windows 2000 or Windows XP.
4
Pro-Designer Startup Guide
Preface
CD-ROM Contents
The following items are included in the CD-ROM.
Installation menu
Pro-Designer
Pro-Designer Runtime
Pro-eView
Function
Installs the development environment
required to create an application.
Installs an operating environment for a
Windows-compatible PC or a PL Series
device.
Installs a program that configures panels
created with Pro-Designer for display on
an intranet/internet browser.
• Acrobat Reader 5.0 can also be installed from this CD-ROM. Acrobat
Reader (as a self-expanding file) is the software required to view PDF
files. This software is contained in the CD-ROM’s [/Eng/Reader] folder.
• To install Pro-Designer Runtime in a device other than a PL series, a PS
series B-type or a Windows-compatible computer, please refer to that
software’s online help.
Pro-Designer Startup Guide
5
Preface
Essential Safety Precautions
General Operation:
WARNINGS
Touch panel switches should NOT be used for a device's Emergency Stop Switch. Generally speaking,
all industrial machinery/systems must be equipped with a mechanical, manually operated emergency
stop switch. Also, for other kinds of systems, similar mechanical switches must be provided to ensure
safe operation of those systems.
CD-ROM Handling:
CAUTIONS
Remove the CD-ROM before turning your PC’s power ON or OFF.
Do not remove the CD-ROM when the disc drive lamp is lit.
Do not touch the recording surface of the CD-ROM.
Do not expose the CD-ROM to extremely high or low temperatures, or excessive moisture or dust.
Do not turn your PC OFF while an application is running.
6
Pro-Designer Startup Guide
Preface
Tab
le of Contents
able
Preface ...................................................................................................................... 1
Documentation Conventions ..................................................................................... 2
Trademark Rights ...................................................................................................... 3
Target Machines ....................................................................................................... 4
CD-ROM Contents .................................................................................................... 5
Essential Safety Precautions .................................................................................... 6
Chapter 1
Introduction
1 About Pro-Designer ........................................................................................... 1-2
2 Features ............................................................................................................ 1-2
Multi-platform support ............................................................................................................. 1-2
Data exchange (between Pro-Designer and other Pro-Series software) ................................ 1-2
Data reusability ....................................................................................................................... 1-3
Connects to multiple PLCs ...................................................................................................... 1-3
Expanded range of features .................................................................................................... 1-3
Easy-to-create graphic screens .............................................................................................. 1-3
Advanced-level reports ........................................................................................................... 1-3
Multi-language support ........................................................................................................... 1-3
Data-sharing (viewing/browsing project variables) ................................................................. 1-4
Editing variables created with general applications ............................................................... 1-4
Data sharing API (exchanging data with general applications) .............................................. 1-4
3 Integrated Development Environment ............................................................... 1-5
3.1 Pro-Frame .............................................................................................................. 1-5
3.2 Tool Windows ......................................................................................................... 1-5
4 Development and Operation Environments ...................................................... 1-7
5 Application Development Steps ........................................................................ 1-8
6 System Design .................................................................................................. 1-9
Chapter 2
Installation
1 Before Installing the Software ........................................................................... 2-2
2 Installing the Software ....................................................................................... 2-3
3 Uninstalling the Software .................................................................................. 2-5
3.1 Removing the application ....................................................................................... 2-5
3.2 Deleting the folder .................................................................................................. 2-5
Chapter 3
Creating Screens & Entering Settings
1 Creating a Project ............................................................................................. 3-2
1.1 Overview ................................................................................................................ 3-2
2 Starting Pro-Designer ....................................................................................... 3-4
3 Basic Settings ................................................................................................... 3-5
Pro-Designer Startup Guide
7
Preface
3.1 Creating a project and setting up a target ............................................................... 3-5
3.2 Creating variables .................................................................................................. 3-7
4 Creating Screens .............................................................................................. 3-9
4.1 Creating Panel 1 ..................................................................................................... 3-9
4.1.1 Opening the panel ........................................................................................ 3-9
4.1.2 Creating a title for Panel 1 .......................................................................... 3-10
4.1.3 Creating numerical indicators ..................................................................... 3-11
4.1.4 Creating a lamp .......................................................................................... 3-13
4.1.5 Creating an alarm message ....................................................................... 3-14
4.1.6 Creating a panel selector switch ................................................................. 3-15
4.2 Creating Panel 2 ................................................................................................... 3-18
4.2.1 Creating a new panel ................................................................................. 3-18
4.2.2 Creating a title for Panel 2 .......................................................................... 3-19
4.2.3 Creating a tank ........................................................................................... 3-19
4.2.4 Creating a pipe ........................................................................................... 3-23
4.2.5 Creating a panel selector switch ................................................................. 3-26
4.3 Creating Panel 3 ................................................................................................... 3-26
4.3.1 Creating a new panel ................................................................................. 3-27
4.3.2 Creating a title for Panel 3 .......................................................................... 3-27
4.3.3 Creating a graph indicator .......................................................................... 3-27
4.3.4 Creating a panel selector switch ................................................................. 3-29
4.4 Creating Panel 10001 ........................................................................................... 3-30
4.4.1 Creating a pop-up window .......................................................................... 3-30
4.4.2 Creating an alarm summary ....................................................................... 3-31
4.4.3 Creating an alarm message ....................................................................... 3-32
4.4.4 Creating a panel closing switch .................................................................. 3-32
4.5 Creating a Panel Script ......................................................................................... 3-34
4.5.1 Creating the “Script1” panel script .............................................................. 3-34
4.5.2 Creating the “Script2” panel script .............................................................. 3-35
5 Saving the Project ........................................................................................... 3-36
Chapter 4
Data Transfer
1 Types of Data Transfer ....................................................................................... 4-2
2 Build Processing ............................................................................................... 4-2
3 Data Transfer Procedures .................................................................................. 4-3
Chapter 5
Running/Exiting Pro-Designer
1 Simulation ......................................................................................................... 5-2
2 Running the Project ........................................................................................... 5-3
3 Closing the Project ............................................................................................ 5-3
4 Exiting Pro-Designer ......................................................................................... 5-4
8
Pro-Designer Startup Guide
1
Introduction
1 About Pro-Designer
2 Features
3 Integrated Development Environment
3.1 Pro-Frame
3.2 Tool Windows
4 Development and Operation Environments
5 Application Development Steps
6 System Design
Pro-Designer Startup Guide
1-1
Chapter 1 Introduction
1
About Pr
o-Designer
Pro-Designer
Pro-Designer is screen creation software that can be used on a variety of User platforms.
Project files created with Pro-Designer can be run on various operating systems and platforms
according to the User’s needs and the panel’s installation environment. Pro-Designer can
exchange data with other software applications on devices running a Windows operating system.
Thus, a system created with Pro-Designer offers excellent expandability and can store and re-use
data from existing applications.
To run a project file created with Pro-Designer, use the Pro-Designer Runtime software. You can
install Pro-Designer Runtime from the Pro-Designer CD-ROM.
2
Features
Multi-platform support
Project files created with Pro-Designer can be run on the following units.
•
•
•
•
•
•
•
•
•
Windows-compatible computers
PL Series units
PS Series Type B unts
PS Series Type G units
PS Series Type P units
GP2000 Series units
GP2000H Series units
Factory Gateway units
GP37W3 units
Data exchange (between Pro-Designer and other Pro-Series software)
As one component of the Pro-Series family of software, Pro-Designer can easily share variables
with other Pro-Series software. This significantly reduces the number of project development
steps and allows you to create highly reliable systems.
Software PLC tool
(under development)
HMI
creation tool
File management tool
(under development)
Integrated database
environment
(under development)
1-2
Programless data
acquisition tool
(under development)
Web server tool
Pro-Designer Startup Guide
Chapter 1 Introduction
Data reusability
Data created with Pro-Designer can be divided into reusable units that can be stored in the
Toolchest. This makes for reuse. Registered data can be imported or exported in folders. This
function is useful for system development, for harmonizing screens among several users, and for
harmonizing all devices in use.
Connects to multiple PLCs
Pro-Designer uses built-in communication drivers to share data with a variety of communication
devices. As a result, it can be easily connected to various manufacturer PLCs, using simple
settings. Pro-Designer uses a single target machine to simultaneously communicate with several
PLCs.
Expanded range of features
With its advanced-level script function for creating program scripts, Pro-Designer provides
excellent expandability. Furthermore, all scripts can be easily reused.
Easy-to-create graphic screens
With its advanced-level animation features, Pro-Designer enables you to quickly and easily create
a dynamic screen-operation environment. Combine a variety of features in a single program, such
as on-screen object movements, enlarge/reduce, level indicators, ON/OFF indicators and touch
features. Pro-Designer’s new “Smart Parts” let you simply and easily create graphic screens.
Advanced-level reports
Pro-Designer has an advanced-level report function that simplifies the management of variables
assigned to screen animations or panels. Also, Pro-Designer can display all panel images at the
same time. These report features help you to create a smooth-running system and reduce the
number of steps needed to prepare screen specifications.
Multi-language support
Pro-Designer can use up to 20 different (registered) languages. While your project is running,
simply touch the screen to select the desired language used in your project’s text objects.
Pro-Designer Startup Guide
1-3
Chapter 1 Introduction
Data-sharing (viewing/browsing project variables)
With Pro-Designer, you can create several targets for a single project and Data-sharing allows
these targets to easily share data. Entering just a few, simple settings allows you to browse your
network and find values assigned to another target’s PLC.
(Note: Pro-Designer Runtime must be installed on each target machine.)
Ethernet
Pro-Designer
Runtime
Sharing enabled
PLC
Editing variables created with general applications
Pro-Designer can import or export variables in CSV files. For example, a variable list created with
a general application, such as a comment IO list for Excel or a PLC, can be imported into ProDesigner for use or editing with Pro-Designer. In addition, variables created with Pro-Designer
can be exported for use in general applications.
Data sharing API (exchanging data with general applications)
A data sharing API allows Pro-Designer to easily exchange data with other applications. With this
feature, variables created with Pro-Designer can be loaded into other applications (such as VB/
VC*1) for processing and calculation, with results assigned to Pro-Designer variables.
*1 Microsoft Visual Basic, Microsoft Visual C++ and eMbedded Visual C++
1-4
Pro-Designer Startup Guide
Chapter 1 Introduction
3
Integrated De
velopment En
vir
onment
Development
Envir
vironment
3.1 Pro-Frame
Pro-Frame is an integrated development environment for operating Pro-Series software. ProFrame allows for various operations – including creation of screens and control programs, data
acquisition setup, and HTML file setup – in a single on-screen frame. Multi-featured tool
windows allow you to quickly develop applications.
The Pro-Frame development environment provides standard Windows menus and tool bars,
ensuring that every user can quickly and easily learn to use it.
3.2 Tool Windows
Pro-Designer’s integrated development environment, features six panes, or "tools," that
collectively allow you to quickly and efficiently develop projects. Each tool displays information
about the current project/object. You can both change the size and placement of each tool’s pane,
and even hide a tool.
The Pro-Frame integrated development environment provides the following information. Simply
click on a tool icon to display or hide that tool.
Pro-Designer Startup Guide
1-5
Chapter 1 Introduction
Tool/Pane Name
Data List
Feedback Zone
Inspector
Toolchest
Navigator
InfoViewer
1-6
Description
Displays a list of all objects arranged on a panel, including
their names, indications, order, position and animation
settings. The object currently selected in the data list is
highlighted on the panel. For a group object, information about
the object and all objects belonging to the group is displayed
in a hierarchy format. To sort the displayed items, click
[Display Order], [Object Name], {Animation], [Variables], or
[Position] at the top of the window.
Displays the progress and results of the “Error check,” “Build”
and “Download” processes. If the specified process fails, the
system displays an error or alert message. Double-click the
displayed message to jump to the error position.
Displays the settings of a selected object. You can edit each
setting in this screen. If several objects have been selected,
only the setting common to all selected objects is displayed.
Used to register Smart Parts supplied by the manufacturer or
to register created objects, panels and scripts. You can place
registered parts on a panel by dragging and dropping them
from this tool. Since data registered in this tool can be
imported or exported in folders, it can be used for several
projects.
This tool is used primarily to create applications. Information
on each project displays in a hierarchical tree structure.
Displays online help and information when the report functions
are used.
Pro-Designer Startup Guide
Chapter 1 Introduction
4. De
velopment and Operation En
vir
onments
Development
Envir
vironments
Pro-Designer and Pro-Designer Runtime have the following system requirements.
Development Environment
(Pro-Designer)
Target
Devices
CPU
RAM
Memory
HDD/CF
Card
Memory
OS
Web
Browser
Operation Environment (Pro-Designer Runtime)
Windows
Windows
*2
compatible
compatible*2
PS Series
*1,2
*1,2
Type G
PL Series
PL Series
*2
*2
PS Series Type B
PS Series Type B
PS Series Type P
GP2000 Series *5
GP2000H Series
GP-37W3 Series *5
Factory Gateway
Intel® Pentium® II 400MHz or higher
128 MB or more
HDD: 200 MB or more
CF Card:
16 MB
or more
*3
Microsoft® Windows®NT 4.0
(Service Pack 4 or higher)*4
Microsoft® Windows®2000
Microsoft® Windows®XP*6 *7
Microsoft Internet
Explorer 5.0
or higher*4
*1 Only PL-X9*0 and PL-5900 Series units are compatible.
*2 Windows-compatible computers, PL Series units and PS Series Type B units can be used for
both development and operating environments.
*3 A CF Card is required to use certain PS Series Type P, GP2000 Series units and GP2000H
Series and features.
*4 Be sure to check your Service Pack and Internet Explorer browser version numbers.
*5 For compatibility information about GP2000 Series, GP2000H Series and GP-37W3 Series
units, refer to page 4 “Target Machines”.
*6 Only PL-6920 and PL-7920 Series units are compatible with Microsoft Windows® XP.
*7 Compatible with Microsoft Windows® XP Home and Windows® XP Professional.
Pro-Designer Startup Guide
1-7
Chapter 1 Introduction
5. Application De
velopment Steps
Development
Pro-Designer application development steps are as follows.
Install
Launch Pro-Designer
Perform basic setup
Create screens
Build
Download
1-8
Pro-Designer Startup Guide
Chapter 1 Introduction
6
System Design
Development Environment
Windows compatible unit
Running
Pro-Designer
Ethernet
Pro-Designer
Runtime
Windows®
compatible
unit
PS Series
P type
PL Series
PS Series
B type
PS Series
G type
GP2000 Series
PLC
Factory
Gateway
GP2000H Series
GP37W3 Series
Operation Environment
PLC
Pro-Designer Startup Guide
1-9
Chapter 1 Introduction
1-10
Pro-Designer Startup Guide
2
Installation
1 Before Installing the Software
2 Installing the Software
3 Uninstalling the Software
3.1 Removing the application
3.2 Deleting the folder
Pro-Designer Startup Guide
2-1
Chapter 2 Installation
This chapter describes the installation procedure when a Windows-compatible computer is used
for the development environment and operating environment. To install the software on different
target machines, please refer to the online help.
1
Bef
ore Installing the Software
Before
Before installing Pro-Designer (development environment) and Pro-Designer Runtime (operating
environment) from the CD-ROM onto the PC hard disk, be sure to read the following:
•
If you are upgrading from an earlier version of Pro-Designer, uninstall the earlier version
before installing the new version.
•
Before starting installation, quit all programs, including both standard and resident programs
(such as virus detection software).
•
When installing Pro-Designer and Pro-Designer Runtime on a system running Windows NT
4.0, Windows 2000 or Windows XP, do so only with administrator-level authorization.
•
Project files created/opened with this version of the software cannot be then opened with an
earlier version of Pro-Designer. As a result, if it is necessary to open an earlier project file with
this newer version, be sure to first use the earlier Pro-Designer software’s export feature to
make a backup copy of the original project file.
•
Read the Pro-Designer “Readme” file before using the software.
(Click on [Program] - [Pro-face] - [Pro-Series] - [Readme] in the [Start] menu.)
•
After installing Pro-Designer Runtime, you must enter the Pro-Designer Runtime license key
code before starting the program.*1
*1 Each target machine requires a single Pro-Designer Runtime license.
2-2
Pro-Designer Startup Guide
Chapter 2 Installation
2
Installing the Software
1.
Insert the CD-ROM in your PC’s CD-ROM drive. The Pro-Designer setup screen will appear
automatically.
If the setup screen does not appear, click on the [Start] button and then [Run]. Enter
"x:\Install.exe" and click on [OK]. (Substitute your CD-ROM drive character for "x".)
2.
Select the application you want to install (Pro-Designer or Pro-Designer Runtime).
Follow the instructions provided by the installer to complete the installation.
3.
Enter your user name, company name and product serial number. (The serial number is on
the Pro-Designer package.)
Pro-Designer Startup Guide
2-3
Chapter 2 Installation
4.
Enter the key code. (The key code is on the Pro-Designer package.)
5.
Specify the folder where you want to install the application.
6.
The selected application will install in the specified folder. After the installation is
completed, select [Exit].
• Individual application icons are provided in the Start menu’s [Program] [Pro-face] - [Pro-Series] .
• If you create a shortcut, the corresponding icon will appear on the
desktop.
2-4
Pro-Designer Startup Guide
Chapter 2 Installation
3
Uninstalling the Software
3.1 Removing the application
The uninstallation menu for each application is located in the Start menu’s [Program] - [Pro-face]
- [Pro-Series] or [Tools] menu. To unintall a program file, use that program’s uninstallation
menu.
• This procedure will not delete any files created after installation (such as
project files and files in the Toolchest).
• Before uninstalling the software, quit all other programs including
resident programs. Unless all programs are closed, some files may not
be uninstalled.
3.2 Deleting the folder
The previous procedure will not delete any files created after program installation. Therefore, to
delete all related files, after uninstalling the application, start Explorer and delete the folder where
the applications were installed.
• This procedure deletes all of a program’s project file data. If you wish to
save your project files before installing a new version of the software, do
not delete the folder.
Pro-Designer Startup Guide
2-5
Chapter 2 Installation
2-6
Pro-Designer Startup Guide
Creating Screens &
Entering Settings
3
1. Creating a Project
1.1 Overview
2. Starting Pro-Designer
3. Basic Settings
3.1 Creating a project and setting up a target
3.2 Creating variables
4. Creating Screens
4.1 Creating Panel 1
4.2 Creating Panel 2
4.3 Creating Panel 3
4.4 Creating Panel 10001
4.5 Creating a Panel Script
5. Saving the Project
Pro-Designer Startup Guide
3-1
Chapter 3 Creating Screens & Entering Settings
1
Creating a Pr
oject
Project
In this chapter you will create a project named Lesson 1. It consists of four panels that
demonstrate the use of the “numerical input”, “animation display”, “graph display” and “alarm
display” features.
Lesson 1 has been prepared as a project file, named [Manual], found in the following folder.
\Pro-face\Pro-Frame\Backup
• The [Manual] project file can be found in the [Pro-Manager] tab. Doubleclick on the project to open the project file.
• If the panel text appears in Japanese while you are viewing the [Manual]
project, click in the bottom left corner of the panel to display English text.
Click here
1.1 Overview
This section outlines the operation of the [Manual] project.
Click [Next] to call up the “Water Level Setting Screen.” This screen is used to define a target
value for the water level. If this setting is greater than 100, the lamp lights and a setting error
message and a pop-up window panel appear.
Click [Next] to call up the “Water Level Meter” screen. This screen is used to monitor changes in
the water level in the tank.
Click [Next] to call up the “Water Level Data Chart (Historical)” screen. This screen graphically
displays changing water levels.
Click in this area to
display the keypad.
3-2
Click in this area to
call up the “Water
Level Meter” screen.
Enter a value and press
the [Enter] key to register
the setting.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
When the v
alue entered thr
ough the ke
ypad
value
through
keypad
exceeds the setting rang
e (0 to 100)
range
The message indicating a
setting value error will
blink.
The lamp lights.
The pop-up window
panel appears.
The change in water level
is displayed graphically.
A change in water level
is displayed numerically.
The line indicating
water flow will
blink.
Changes in water level are
displayed graphically.
Click here to call up the
“Water Level Data Chart
(Historical)” screen.
Pro-Designer Startup Guide
Click here to change the
screen to the “Water Level
Setting Screen”.
3-3
Chapter 3 Creating Screens & Entering Settings
2
Star
ting Pr
o-Designer
Starting
Pro-Designer
To start Pro-Designer, select [Program] -> [Pro-face] -> [Pro-Series] -> [Pro-Designer] in the
[Start] menu.
Or, you can simply double-click the Pro-Designer icon on the desktop.
3-4
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
3
Basic Settings
This section describes the basic setup procedures performed prior to creating a screen. However,
the procedure described in this section does not include instructions on setting up external I/O.
Therefore, if you need to set up external I/O, refer to Pro-Designer’s online help.
3.1 Creating a project and setting up a target
A Pro-Designer “project” is simply a collection of information, i.e. a database. Inside a project,
target devices are set up and organized in a hierarchical structure. Each target indicates the
hardware environment where the project will be executed.
See “Target Machines” on page 4.
Use the following steps to create a project and set up a target:
1.
This dialog box appears when you start up Pro-Designer. Click [Next] to continue.
• If the above dialog box does not appear when you start up Pro-Designer,
select the [Pro-Manager] tab in the Navigator, right-click on [ProManager], and select [New Project].
Pro-Designer Startup Guide
3-5
Chapter 3 Creating Screens & Entering Settings
2.
After the [New Project] dialog box appears, enter a project name and click [OK]. (For this
example, enter “Lesson1”). For project naming conventions, refer to online help.
3.
After the [New Target] dialog box appears, select [PC/AT (PL Series)] and click [Finish].
4.
Now, a new target (Target1) is created. Also, that target’s panel folder, target script folder,
alarm, pop-up window folder, language folder, data files and connected devices are also
automatically created.
• To add another target to the project, right-click [Lesson1] and select
[New Target].
3-6
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
3.2 Creating variables
A variable is a location in memory for storing data that is given a name. Pro-Designer uses
variables to access PLC device addresses. You can also create Pro-Designer internal-use variables
that are used only by Pro-Designer. For details, refer to online help.
• This manual provides only a sample procedure for creating an internal
variable without connecting to a PLC. Thus, it is intended to illustrate only
the general flow and procedure of basic operations.
To use a PLC, refer to online help.
To create a new variable:
1.
Click the [Variables] tab in the Navigator pane.
2.
Right-click in the Navigator, highlight [New Variable], and select [Discrete].
[Variables] tab
Pro-Designer Startup Guide
3-7
Chapter 3 Creating Screens & Entering Settings
3.
Now that you have created a discrete variable, change the name of variable from
“Discrete01” to “alm”. Once it is created, the variable’s properties will appear in the
“Inspector”.
• You can also change the name of a variable using the [Name] property.
• For rules about variable naming, refer to online help.
4.
Repeat Steps 1 and 2 to create integer variables, named “sec” and “value”.
5.
You have now created a discrete variable and two integer variables.
Be sure to save your project file regularly .
See “5 Saving the Project”.
3-8
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4
Creating Screens
You can create any of the four screens that follow. The following sections describe the procedures
for creating individual panels. For detailed descriptions, refer to online help.
4.1 Creating Panel 1
Use this procedure to create the following screens.
4.1.1 Opening the panel
1.
Click the [Project] tab in the Navigator.
2.
Double-click [Graphical Panels] to open the folder.
3.
Click [1:Panel1] to open the panel.
4.
In the Inspector, set the [Background Color] property to “128,255,255”.
[Project] tab
Pro-Designer Startup Guide
3-9
Chapter 3 Creating Screens & Entering Settings
4.1.2 Creating a title for Panel 1
Create “Water Level Setting Screen” as the text object for the Panel 1 title.
1.
Click
(Text) on the drawing tool bar and define the area where the text frame will be
placed on the panel.
Drawing tool bar
• To change the size of the displayed panel, right-click the mouse on the
panel and select [Zoom].
3-10
2.
When the [Text Editor] dialog box appears, enter “Water Level Setting Screen”. Select
[Times New Roman (Western)] for the [Font], [36] for the [Font Size] and click [OK].
3.
Set the [Text Color] to “102,102,255”. Set the [Background Color] and [Line Color] to
“Transparent”.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.1.3 Creating numerical indicators
Create the text object “#”, which is used for entering numerical data, and the text object “Water
Level Setting Value”, which is used as a title.
• To add the numerical input feature to a text object, be sure to set up data
animation.
• Use only “#(single-byte)” text when setting up data animation.
• Be sure to not put a return (line break) after the “#” character. If a line
break is used, data animation settings will be disabled.
[Language]: 2: Language2
[Font]: Arial (Western)
[Style]: Bold
[Font Size]: 40
1.
Create the text object “#”. See Steps 1 and 2 of “4.1.2 Creating a title for Panel 1” and set up
the [Text Editor] dialog box properties as shown below:
2.
In the color screen:
- Set the [Text Color] and [Line Color] properties to “0,0,255.”
- Set the [Background Color] to “255,255,0” and the [Line Width] to “3”.
Pro-Designer Startup Guide
3-11
Chapter 3 Creating Screens & Entering Settings
3.
Click on the [Animation] property to display
. Click
.
4.
In the following [Animation Properties] dialog box, click the [Value] tab. Check the [Enable
Value Animation], [Keypad/Keyboard Input] and [Display Pop-up Keypad] check boxes.
[Value] tab
For numerical input,
add the animation
feature.
Next, click
, select the “value” variable, set [Display Digits] to “3.0” and click [OK].
• Simply double-click an object to display the [Animation Properties] dialog
box.
5.
Create the text object “Water Level Setting Value”. Set up individual properties in the [Text
Editor] dialog box as shown below:
See Steps 1 and 2 of “4.1.2 Creating a title for Panel 1”.
[Language]: 2: Language2
[Font]: Times New Roman (Western)
[Style]: Normal
[Font Size]: 26
6.
3-12
Set the [Text Color] property to “0,0,153.” Set the [Background Color] and [Line Color]
properties to “Transparent”.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.1.4 Creating a lamp
Smart Parts can be used to create a lamp that lights when a data entry error is detected. For a
detailed description of Smart Parts, refer to online help.
1.
Click on the Navigator’s [ToolChest] tab, and click on the [Lamps] folder’s [2 States] folder.
[ToolChest] tab
2.
Drag & drop [Lamp2St0_0015_01] onto the panel.
• To place any object on the panel, simply drag & drop it from the Tool
Chest.
Pro-Designer Startup Guide
3-13
Chapter 3 Creating Screens & Entering Settings
3.
Click on the [Variable] property to display
, and click
to select the variable “alm.”
4.1.5 Creating an alarm message
In this example you can create a text object that blinks when a data entry error is detected.
3-14
1.
Create the text object “Setting Alarm”. Enter individual settings in following [Text Editor]
dialog box.
See Steps 1 and 2 of “4.1.2 Creating a title for Panel 1”.
[Language]: 2: Language2
[Font]: Times New Roman (Western)
[Style]: Bold
[Font Size]: 16
2.
Set the [Text Color] property to “252,0,0”, and set the [Background Color] and [Line Color]
properties to “Transparent”.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
3.
When the [Animation Properties] dialog box appears:
- Click on the [Visib.] tab
- Check the [Enable Visibility Animation] and [Enable Blink Animation] check boxes.
- Click
and select the variable “alm”. Click [OK].
See Steps 3 and 4 of “4.1.3 Creating numerical indicators”.
[Visib.] tab
Add animation that
causes the message
to blink.
4.1.6 Creating a panel selector switch
Use Smart Parts to create a switch for changing Panel 1 to Panel 2.
1.
Click on the [ToolChest] tab in the Navigator. Click on the [Special Function Switches] folder
[ToolChest] tab
Pro-Designer Startup Guide
3-15
Chapter 3 Creating Screens & Entering Settings
2.
Drag and drop [SwSp0_0005_01] onto the panel.
3.
Set the [ID] to “2”.
Add a Change Panel
feature via the [Operation]
property.
In the [ID] property,
specify the panel’s ID
number.
4.
Click on the [Label] property, and click
each item as shown below.
to display the [Text Editor] dialog box. Set up
[Language]: Language2
[Font]: Times New Roman (Western)
[Style]: Bold
[Font Size]: 18
This will appear in Pro-Designer as “Label”.
3-16
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
Be sure to save your project file regularly .
See “5 Saving the Project”.
This completes the procedure for creating Panel 1.
Pro-Designer Startup Guide
3-17
Chapter 3 Creating Screens & Entering Settings
4.2 Creating Panel 2
This section describes how to create the following panel.
4.2.1 Creating a new panel
1.
Click on the [Project] tab in the Navigator. Right-click on [Graphical Panels] and select
[New Panel].
[Project] tab
2.
3-18
[2:Panel2] panel is created. Set the [Background Color] property to “255,255,153”.
See Step 4 of “4.1.1 Opening the panel”.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.2.2 Creating a title for Panel 2
Here we will create the text object “Water Level Meter” for the title of Panel 2.
1.
Create a text object “Water Level Meter”, using steps 1 and 2 of “4.1.2 Creating a title for
Panel 1”. Next, use the example below to enter that screen’s information in the [Text Editor].
[Language]: 2: Language2
[Font]: Times New Roman (Western)
[Style]: Normal
[Font Size]: 36
2.
Set the [Text Color] property to “255,153,0”. Select “Transparent” as the [Background
Color] and [Line Color] properties.
4.2.3 Creating a tank
In this section, create a tank with a water level change indicator.
1.
Click the drawing toolbar’s
Pro-Designer Startup Guide
icon and draw the following two rectangles.
3-19
Chapter 3 Creating Screens & Entering Settings
2.
For each rectangle, set the [Foreground Color] property to “153,153,102” and the [Line
Color] property to “Transparent”.
3.
Click on the drawing toolbar’s
icon and draw the three ellipses shown below.
Ellipse 1
Ellipse 2
Ellipse 3
3-20
4.
For Ellipse 1, set the [Foreground Color] property to “153,153,153” and the [Line Color]
property to “255,255,255”.
For Ellipses 2 and 3, set the [Foreground Color] property to “153,153,102” and the [Line
Color] property to “Transparent”.
5.
Click the drawing toolbar’s
6.
Set the [Foreground Color] and the [Line Color] properties to “255,255,255”.
icon and draw the following rectangle.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
7.
When the [Animation Properties] dialog box appears, click on the [Fill] tab and check the
[Enable Vertical Fill Animation] check box.
Next, click
and select the variable “_Seconds”. Set the [Start Point] property to “Top”,
the [Back Area Color] property to “0,0,255”, the [Value Range] - [To] (maximum value)
property to “59” and click [OK].
[Fill] tab
Use animation to
show changes in
the tank water level.
“_Seconds” is a system variable. These variables are reserved for Pro
Designer use. For details, refer to online help.
8.
Click the drawing toolbar’s
9.
Select “255,0,0” for the [Line Color] property.
Pro-Designer Startup Guide
icon and draw the following scale-type object.
3-21
Chapter 3 Creating Screens & Entering Settings
10. Refering to steps 1 and 2 of “4.1.2 Creating a title for Panel 1”, create the text object “#”
and place it on the tank as shown below. Enter the following settings..
.
[Language]: 2: Language2
[Font]: Arial (Western)
[Style]: Normal
[Font Size]: 20
11. Set the [Text Color] property to “255,255,255” and the [Background Color] and [Line Color]
properties to “255,102,0”.
12. When the following [Animation Properties] dialog box appears click on the [Value] tab.
Next, click the [Enable Value Animation] check box so that a check mark appears.
Then, click
, select the “_Seconds” variable, set the [Display Digits] property to “2.0”
and click [OK].
[Value] tab
Use animation to
numerically show
the tank overflow
amount.
Be sure to save your project file regularly .
See “5 Saving the Project”.
3-22
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.2.4 Creating a pipe
Create a pipe that indicates water flow from the tank.
1.
Click the drawing toolbar’s
(rectangle) icon and draw the following two rectangles.
2.
Set the [Line Color] and [Foreground Color] properties to “42”.
3.
Click the drawing toolbar’s
(polygon) icon and draw the following object.
Procedure:
1. Left-click the mouse at point A.
2. Left-click the mouse button at
vertexes B through G.
3. Right-click on the panel.
• To use the [Snap to Grid] feature, right-click on the panel and check that
check box. Each vertex will be positioned automatically at a grid point.
4.
Set the [Line Color] property to “255,255,255” and the [Foreground Color] property to
“0,0,255".
5.
Click the drawing tool bar’s
Pro-Designer Startup Guide
(Select) icon and select the arrow created in step 3.
3-23
Chapter 3 Creating Screens & Entering Settings
6. Select [Edit] menu -> [Copy] and then [Paste].
7.
This creates another arrow. Select the arrow and choose [Rotate Right] in the [Arrange]
menu. The arrow will turn clockwise to point to the left.
8.
Repeat step 6. to create another downward-pointing arrow. Select [Rotate Left] in the
[Arrange] menu so that the arrow points to the right.
9.
Create two more rightward-pointing arrows and two more leftward-pointing arrows.
10. Place the seven arrows created in Steps 3 through 9 in the rectangles, as shown below.
• Enlarge or reduce the size of the arrows or objects if needed.
3-24
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
11. Select all seven arrows. Select [Group] in the [Arrange] menu to create a group object.
• To simultaneously select multiple objects, hold down the [Shift] key while
selecting the objects.
12. Click the [Visib.] tab in the [Animation Properties] dialog box for the grouped object created
in Step 11.
Next, check [Enable Blink Animation], click
, select the “_Seconds” variable, and click
[OK].
[Visib.] tab
Use animation to
show water is
flowing through the
pipe.
Pro-Designer Startup Guide
3-25
Chapter 3 Creating Screens & Entering Settings
4.2.5 Creating a panel selector switch
Create a switch to change Panel 2 to Panel 3.
1.
Click on [1:Panel1] in the Navigator to open Panel 1. Click the drawing toolbar’s
(Select) icon to select the “SwSp0_0005_01” switch.
Next, select the [Edit] menu’s [Copy] command.
2.
Click [2:Panel2] in the Navigator to open Panel 2. Click on the panel and select [Paste].
3.
Select the switch labeled “SwSp0_0005_01”. Select “3” for the [ID] property.
Refer to “4.1.6 Creating a panel selector switch”. (Step 3)
Be sure to save your project file regularly .
See “5 Saving the Project”.
This completes the procedure for creating Panel 2.
4.3 Creating Panel 3
This section describes how to create the following panel.
3-26
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.3.1 Creating a new panel
1.
Click on the Navigator’s [Project] tab. Right-click on [Graphical Panels] and select [New
Panel].
See Step 1 of “4.2.1 Creating a new panel”.
2.
Set [3:Panel3] panel’s [Background Color] property to “153,255,0”.
See Step 4 of “4.1.1 Opening the panel”.
4.3.2 Creating a title for Panel 3
1.
Create the text object “Water Level Data Chart (Historical)”. Enter the following setting data
in the [Text Editor] dialog box:
See Steps 1 and 2 of “4.1.2 Creating a title for Panel 1”.
[Language]: 2: Language2
[Font]: Times New Roman (Western)
[Style]: Normal
[Font Size]: 36
2.
Set [Text Color] to “255,153,0”, and select “Transparent” for the [Background Color] and
[Line Color] properties.
4.3.3 Creating a graph indicator
Create a graph indicator that displays water level changes. The graph indicator displays timeseries changes in variables. For details, refer to the online help.
1.
Click on the drawing toolbar’s
Pro-Designer Startup Guide
(Graph) icon and create a graph-type indicator.
3-27
Chapter 3 Creating Screens & Entering Settings
2.
Select “102,255,255” for the [PlateColor] property and “0,153,0” for the [Border Color]
property. Next, set the [Data Axis Label] -> [Text Color] property to “255,102,0”.
Select “sec” for the [Channel 1] -> [Variable] property.
Defines the variable
assigned to the
graph indicator.
3.
Click on the [Variables] tab in the Navigator. Select the “sec” variable and set the [Record
Rate[sec]] property to “1”.
Updates variables
every second.
[Variables] tab
3-28
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.3.4 Creating a panel selector switch
Create a switch to change Panel 3 to Panel 1.
1.
Copy the “SwSp0_0005_01” switch from Panel 1, as explained previously for Panel 2.
See “4.2.5 Creating a panel selector switch”.
2.
Click the drawing toolbar’s
the [ID] property to “1”.
3.
Click on the [Label] property and click the
to call up the [Text Editor] dialog box. Enter
“Back” in the dialog box, and set up each item as follows:
(Select) icon, select the “SwSp0_0005_01 switch, and set
[Language]: Language2
[Font]: Times New Roman
(Western)
[Style]: Bold
[Font Size]: 18
Be sure to save your project file regularly .
See “5 Saving the Project”.
This completes the procedure for creating Panel 3.
Pro-Designer Startup Guide
3-29
Chapter 3 Creating Screens & Entering Settings
4.4 Creating Panel 10001
This section describes how to create the following panel.
4.4.1 Creating a pop-up window
Panel10001 is a pop-up window that can be overlaid on another, previously opened panel. For set
up details, refer to online help.
1.
Click on the [Project] tab in the Navigator and right-click on [Popup Windows] to select
[New Popup Window].
[Project] tab
2.
3-30
“1:Window” and “10001:Panel4” are now completed. Click on “10001:Panel4” to open the
panel.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
4.4.2 Creating an alarm summary
This section explains how to create an alarm summary that displays alarm messages related to
Panel 1 setting errors. For alarm summary setup details, refer to online help.
1.
Click the drawing toolbar’s
2.
Set the [Message Font Size] property to “8”, the [BackAreaColor] property to
“255,255,255”, the [Frame] property to “Enabled”, and the [Line Color] property to
“255,102,0”.
Next, set the [Ruler] property to “Enabled”, and the [Line Color] property to “0,0,153”.
Pro-Designer Startup Guide
(Alarm Summary) icon to create an alarm object.
3-31
Chapter 3 Creating Screens & Entering Settings
4.4.3 Creating an alarm message
Use the [Variable] property to designate the alarm message(s) shown in the alarm summary. For
details, refer to online help.
1.
Click on the [Variables] tab in the Navigator to select the “alm” variable.
Next, set the [Alarm] - [Alarm Summary] property to “True”.
Click on the [Alarm Message] property and click
.
[Variables] tab
2.
After the [Alarm Message Editor] dialog box appears, enter “Setting value is over 100!” in
the dialog box and click [OK].
4.4.4 Creating a panel closing switch
This section explains how to create a switch for closing the pop-up window panel.
3-32
1.
Click on the drawing toolbar’s
(Rectangle) icon and draw a rectangle.
2.
Select “255,255,102” for the [Foreground Color] property.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
3.
When the [Animation Properties] dialog box appears, click on the [Touch] tab and check
the [Enable Touch Animation] check box. Next, double-click on the [Operation] property to
display the [Function Setting] dialog box. Select “Popup Panel” for the [Function] property,
then “Close Popup Panel”, and click [OK]. Also, click [OK] in the [Animation Properties]
[Touch] tab
dialog box.
4.
Click the drawing toolbar’s
(Text) icon and create a text object named “Close”. Enter the
[Language]: 2: Language2
[Font]: Arial (Western)
[Style]: Normal
[Font Size]: 14
5.
Select “255,0,102” for the [Text Color] property and “Transparent” for the [Background
Color] and [Line Color] properties.
Be sure to save your project file regularly .
See “5 Saving the Project”.
This completes the procedure for creating Panel 10001.
Pro-Designer Startup Guide
3-33
Chapter 3 Creating Screens & Entering Settings
4.5 Creating a Panel Script
In Pro-Designer, a script is a set of programs that describe processes performed via Pro-Designer
Runtime. If you use a script to define a process and then perform that script when a trigger
condition is satisfied, you can add a function that is not available with the panel settings alone.
For details on script creation, refer to online help.
4.5.1 Creating the “Script1” panel script
The following explains how to create a script that is performed when a pre-defined value is
entered in Panel 1.
1.
Click on the [Project] tab in the Navigator. Right-click [1:Panel1] to select [New Script].
[Project] tab
2.
3-34
Select “Conditional” for the [Trigger] property, “value” for the [Trigger Variable] property
and “On Data Change” for the [Trigger Condition] property.
Pro-Designer Startup Guide
Chapter 3 Creating Screens & Entering Settings
3.
Click [Script1] to open the script editor and enter the following program.
When the “Value” variable is greater
than 100, the “alm” variable bit turns
on and window panel 10001 is
displayed.
When the “Value” variable is 100 or
less, the “alm” variable bit turns off.
• Place your cursor over the script, right-click and use the “Insert” menu to
easily create a script. For details, refer to online help.
4.5.2 Creating the “Script2” panel script
Here a script will be used to change the values used by the Graph display.
1.
Click on the [Project] tab in the Navigator. Right-click [3:Panel3] to select [New Script].
See Step 1 of “4.5.1 Creating the “Script1” panel script”.
2.
“Script2” is created. In the Inspector select “Periodic” for the [Trigger] property and “1000”
for the [Frequency[msec]] property .
3.
Click [Script2] to open the script editor and enter the following program.
The value of system variable “_Seconds” is
assigned to variable “sec”.
• Since the graph display cannot directly allocate system variables, create
a script to copy the system variable “_Seconds” to the variable “sec”.
This completes the project file “Lesson1”.
Pro-Designer Startup Guide
3-35
Chapter 3 Creating Screens & Entering Settings
5
Sa
ving the Pr
oject
Saving
Project
Click on the [Project] tab, right-click on [Lesson1], and select [Save].
[Project] tab
3-36
Pro-Designer Startup Guide
4
Data Transfer
1. Types of Data Transfer
2. Build Processing
3. Data Transfer Procedures
Pro-Designer Startup Guide
4-1
Chapter 4 Data Transfer
1
Types of Data Transf
er
ransfer
To transfer a project file created with Pro-Designer, use any of the following four methods:
Type
Ethernet
Tool
Connector*1
File System
Local*2
Process
Data created with "Build" is transferred to a target machine via
Ethernet.
Data created with "Build" is transferred to a target machine via the
serial interface.
Data created with "Build", a Runtime system file or compressed
project file will be written in the file system.
Data created with "Build" is copied to a PC where a development
environment is installed.
*1 This can only be selected if the target unit is a GP Series or a Factory Gateway unit.
*2 This can only be selected if the target unit is a Windows® compatible PC, a PL Series or a PS
Series B-type unit.
2
Build Pr
ocessing
Processing
"Build" is a process for converting a project file created with Pro-Designer into data that can be
used by Pro-Designer Runtime.
If you perform [Download], the system transfers the data after performing the build process. ProDesigner can also perform the build process by itself.
Pro-Designer can perform the following three types of build processes:
Type
Build
Quick B uild
Clean Up
4-2
Process
Builds only the part of the data updated after the previous build
process and optimizes the resulting file. The processing time is
longer than "Quick Build".
Rebuilds the entire project in a specified target unit and optimizes the
resulting file. E ven though the creation time is faster than "B uild", the
simulation function's "RUN" speed is comparitively slower than
"B uild". It can only be used for the simulation function.
Deletes the previously built data for the specified unit(s). If the entire
project is "Built", the build process is performed after Clean Up is
completed.
Pro-Designer Startup Guide
Chapter 4 Data Transfer
3
Data Transf
er Pr
ocedures
ransfer
Procedures
This section describes a sample procedure for transferring a project file created with Pro-Designer
to a PC that is running a development environment. For information about transferring a project
file to a target machine with no development environment, refer to online help.
1.
Select “Local” as the target in the [Download] property.
2.
The [IP Address] property automatically displays the IP address of the target machine.
• If the IP address of the target PC cannot be read, the correct IP address
will not be displayed. In this case, re-check the target PC's network
settings.
Pro-Designer Startup Guide
4-3
Chapter 4 Data Transfer
3.
Right-click [Target1] in the Navigator and select [Download].
[Project] tab
• If an error message appears in the feedback zone, download did not
complete normally. After correcting the problem, try to download the data
again.
• If you double-click on the error currently displayed in the feedback zone,
the error’s location is automatically displayed.
4-4
Pro-Designer Startup Guide
Running/Exiting
Pro-Designer
5
1.
2.
3.
4.
Simulation
Running the Project
Closing the Project
Exiting Pro-Designer
Pro-Designer Startup Guide
5-1
Chapter 5 Running\Exiting Pro-Designer
1
Sim
ulation
Simulation
The simulation function performs a trial run of a project file created with Pro-Designer on a target
PC.
Right-click on the project and select “Start Simulation (Build)” to start the simulation. To end the
simulation, press [Ctrl] and [Z] at the same time.
[Project tab]
• The following items are disabled during a simulation:
- Graph indicator
- Alarm backup function
- Connected devices
- Data logging function
- Pro-eView
5-2
Pro-Designer Startup Guide
Chapter 5 Running\Exiting Pro-Designer
2
Running the Pr
oject
Project
After file transfer (“Download”) has been completed, start Pro-Designer Runtime on the target
machine. This allows the Pro-Designer project file to be run.
To start Pro-Designer Runtime, select [Program] → [Pro-face] → [Pro-Series] → [Pro-Designer
Runtime] in the [Start] menu. Or, simply double-click the shortcut icon on the desktop.
• If you are starting Pro-Designer Runtime for the first time after
installation, be sure to enter the Runtime license key code, found on the
key code label.
3
Closing the Pr
oject
Project
When you exit Pro-Designer Runtime, the project file currently being run is closed.
To exit Pro-Designer Runtime, press the [Z] key while holding down the [Ctrl] key. When the exit
confirmation dialog box appears, click [Yes].
• For information on the procedure for running or closing a project file on a
target machine that has no development environment software, refer to
online help.
Pro-Designer Startup Guide
5-3
Chapter 5 Running\Exiting Pro-Designer
4
Exiting Pr
o-Designer
Pro-Designer
Select [Exit] from the [File] menu.
5-4
Pro-Designer Startup Guide
Download PDF
Similar pages