Alpha Four to Alpha Five: The Transition

Alpha Four to Alpha Five:
The Transition
by Frances M. Peake
Excerpted from
The Basics and More for Version 10
by Susan Hussey Bush
For more information, go to www.libertymanuals.com
Alpha Five Made Easy, The Basics and More for Version 10 Bonus Pages
Published by
Liberty Manuals Co.
130 East River Road
Rumson, NJ 07760-0453
www. LibertyManuals.com
Copyright © 2010, Susan Hussey Bush. All rights reserved. No part of this book, including interior design and cover
design, may be reproduced or transmitted in any form, by any means (electronic, photocopying, recording, or otherwise)
without the prior written permission of the publisher.
ISBN 978-0-9820955-1-5
Printed in the United States of America.
10 9 8 7 6 5 4 3 2 1 First Printing.
Distributed by Liberty Manuals Company.
This manual has been designed for the use of authorized owners of Alpha Four and Alpha Five software. Alpha Four©
and Alpha Five© are the registered trademarks of Alpha Software Inc. Liberty Manuals Company is a separate company
and has no connection with Alpha Software Inc.
Every effort has been made by the publisher and the author in preparing this book. No warranty is made as to the accuracy or completeness of the contents of this book. Liberty Manuals Company assumes no responsibility or liability for any
errors or inaccuracies that may appear in this documentation.
It is important to remember that artwork or images in this document may be protected by copyright law. Unauthorized
use of such material could be a violation of the rights of the copyright owner. Permission to use any part of this document
must be obtained from Liberty Manuals Company.
The Liberty Manuals logo is the property of Liberty Manuals Company. “Get Outta DOS” and “GET INTO ALPHA
FIVE!” seminars are the property of Susan H. Bush and Frances M. Peake. Alpha Five© and Alpha Software are the property of Alpha Software, Inc. Microsoft©, Windows©, MsDos©, Excel©, Works© and Access© are either registered
trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Adobe Acrobat©, Acrobat
Reader© and Adobe Framemaker© are the property of Adobe Corporation. Alpha Five Mailer© and AlphaMailer© are
the trademarks of JangoMail. All other trademarks are the property of their respective owners.
For information on purchasing the books in the Alpha Five series, contact:
Liberty Manuals Company, PO Box 453, Rumson, NJ 07760, USA.
Tel: (732) 842-3000. Fax: (732) 741-5820.
Email and Website: info@LibertyManuals.com; www.LibertyManuals.com.
Chapter 16.
Alpha Four to Alpha Five:
The Transition
It’s time to make the move!
Frances M. Peake shows Alpha Four users how to make a smooth transition to Alpha
Five.
Alpha Four is the original DOS database program developed by Alpha Software, Inc. In
this section, Frances draws on her many years of experience in converting Alpha Four databases to Alpha Five applications. Alpha Four users will find the information invaluable.
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Notes:
568
ALPHA FIVE MADE EASY
The Basics and More for Version 6
Frances M. Peake
“Frances Peake has over 20 years of experience helping
people use databases to increase their productivity. She has
been a professional database consultant, developer and
trainer since 1990. She began her career as Manager of
Technical Support and Quality Assurance for Alpha Software, Inc. after graduating from Tufts University in Boston.
“Although she is equally proficient with Microsoft
Access and Alpha Five, Frances enjoys a special relationship with Alpha Software, Inc. She has been a speaker at
the Alpha Five Conferences in Boston, co-instructor of the
“Get Into Alpha Five!” seminars and has hosted Alpha
Software’s weekly “Live Intro to Alpha Five” on the web.”*
Francie and I first did “Get Outta Dos” seminars for those making the transition from
Alpha Four to Alpha Five; later, we renamed them, “Get Into Alpha Five!
Early versions of Alpha Five Made Easy included this chapter on making the A4 to
A5 Transition. Unfortunately, we were unable to include it in the last one due to space
considerations. We’re glad to have it back and know you will find it useful.
— Susan Bush
Overview
This chapter takes the reader from the initial point of understanding the difference
between the Alpha Four and Alpha Five programs. The following topics are covered:
• Understanding the differences between Alpha Four and Alpha Five.
• Understanding the basic concepts of the Alpha Five program.
• Creating a new Alpha Five database and adding the Alpha Four files.
• Converting existing sets, calculations and expressions.
• Strategies for developing, testing and making the final conversion.
This section is designed as a starting point for the Alpha Four user. After becoming
familiar with the procedure for making the transition, the reader should go to “Please
take a moment to read this” on page 4. to begin the complete understanding of Alpha
Five.
Windows databases
PLEASE TAKE A MOMENT TO
READ THIS
In a Windows database management system, the primary focus is on the objects used
to display, print and manipulate data. Whereas in a DOS database such as Alpha Four,
you must open a data file before working with it, in Windows databases such as Alpha
*. Bio quoted from her website: www.ProctorandPeake.com.
569
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Alpha Five terminology
Five, you do not need to open the data file. It is opened automatically when you open a
form, query or other database object that is associated with the data file.
Windows database programs, like all Windows programs, share many standard interface elements. The advantage of this for new Alpha Five users is that you can apply
your Windows skills to Alpha Five.
STANDARD ELEMENTS
Here are some standard Windows interface elements that you will use in Alpha Five:
• In all Windows programs you open, close, resize and switch between windows the
same way.
• The dialog boxes used for locating and opening files operate in a similar manner.
• There is support for long file names, containing up to 255 characters.
• The selections File, Edit, View, Window and Help are available on most menus.
Keyboard shortcuts to menu selections are ALT + the underlined letter of the command.
• In Windows’ graphical user interface, buttons and toolbars have a prominent role.
The mouse becomes an important tool for selecting and manipulating objects and
text.
WINDOWS HINT!
• Keyboard shortcuts such as CTRL+X (Cut), CTRL + C (Copy), CTRL + V (Insert
or Paste), CTRL + F4 (Close Window) and F1 (Help) work in all Windows programs.
• Last but not least, Windows handles printing. It is no longer necessary to configure
printers separately in each software program.
Alpha Five terminology
The key to going from Alpha Four to Alpha Five is understanding the change in terminology. What Alpha Four called a database, that is a .DBF file, is called a table in
Alpha Five. In Alpha Five, a database is a new entity, a collection of tables and sets.
FIGURE 1. An Alpha Four database, CLIENTS.DBF:
570
ALPHA FIVE MADE EASY
The Basics and More for Version 6
FIGURE 2. An Alpha Five table, CLIENTS.DBF:
FIGURE 3. An Alpha Five database is a collection of tables and sets.
Opening an existing database
PLEASE TAKE A MOMENT TO
READ THIS
Follow this procedure any time you want to open an existing database when (A)
Alpha Five is closed, (B) if the Databases/Tasks screen does not appear or (C) if Alpha
Five is already open.
571
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Opening an existing database
A. When Alpha Five is closed.
1. Start Alpha Five from the Start menu or the program icon.
2. Tab: Databases & Tasks:
FILE IN LIST
• If you have previously opened the existing database, it should appear on the list.
3. Highlight a selection (red box
above) to view its path (below the
Recent Database list window).
FILE NOT IN LIST
• To open a database that is not on the list:
a. Click
Open an existing database.
b. Choose
c. At
More Databases (blue box above). (Click OK)
the Open Database window, navigate to the desired folder.
d. Click
on the file with the tiny Alpha Five logo next to it
•File type: alpha5 document.
•If you have put each database in its own folder there will be only one
such file.
•The next time you open Alpha Five, the database should appear on the Databases/Tasks list.
•The ones most recently used will be at the top of the list.
B. When Alpha Five is closed and there is no Databases/
Tasks screen:*
•Begin at step 1 following. (If a database is already open, this method opens a
2nd instance of Alpha Five.)
C. When Alpha Five is already open.
•Start at step 2 following. (If a database is already open, this method closes the
first and opens the second in its place.)
1. Start Alpha Five from the Start menu or the program icon.
2. Choose File > Open Database.
*. The user is given the option to keep the Databases/Tasks screen from appearing. To turn them on or off, go to “Turning the welcome
screen on and off” on page 459.
572
ALPHA FIVE MADE EASY
The Basics and More for Version 6
•Navigate to the database as directed in the lesson. (Click Open).
A quick tour around Alpha Five
Several files have been included with this tutorial.
1.
Follow the above instructions to open
Alpha Five and navigate to the following file:
•c:\A5_Ver10Book\A5_Apps\ABC Seminars.adb
2. At the opening screen, click the Control Panel
button.
3. On the Alpha Five Control Panel, choose the
Tables/Sets tab.
VIEWING THE ALPHA FIVE
CONTROL PANEL
When you install the Alpha Five program, the database objects will appear as large
icons, as shown in the following illustration. We recommend changing the view so that
you can see more objects and get more information about them.*
4. With your mouse, click Detail View, the last graphic to the right (in
orange below).
•The full name of the path and the date last modified is now shown next to the
name of the Table or Set.
*. Depending on how Alpha Five was last opened, your screen may show a different view.
573
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
A quick tour around Alpha Five
FIGURE 4. The Control Panel is the “Main Menu” of Alpha Five. By default, it has the fol-
lowing tabs:
CONTROL PANEL TABS
•Tables/Sets
•Forms
•Browses
•Reports
•Letters
•Labels
•Operations
•Code
NOTE
If you do not see these tabs on the Alpha Five Control Panel
a. Be
sure that the Layouts is unchecked.
b. Right-click
c. Choose
on any tab.
the tabs to match the list above.
The Tables/Sets tab
When developing a database, you can use the Tables/Sets tab as a take-off point for
most design tasks.
In this section, we will use the right-click menus frequently. You can also access
Alpha Five’s features by choosing from the menu bar and toolbars at the top of the
Alpha Five program window.
5. With your mouse, right-click on the Seminars table.
574
ALPHA FIVE MADE EASY
The Basics and More for Version 6
TABLE AND SET ICONS
•Note that tables and sets have different icons. The sets icon has three
interlocking squares to indicate
linked tables. A menu of options for
tables appears.
6. Press ESC to close the right
click menu.
7. Right-click
on
the
Clients_form set to see the options
for sets.
8. Choose Open Default Form.
575
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
A quick tour around Alpha Five
•The default form includes all the
fields in all the tables in the set.
NOTE:
If a table or set has a large number of
fields, you will get a message indicating
that there are too many fields for the
form. This is because the fields are
listed vertically and forms have a maximum height of 22 inches. To learn how
to make a custom form that will accommodate all your fields, see ”Chapter 4”
beginning on page 67.
9. Use your mouse to grab the scroll
bar at the right edge of the form.
10. Scroll down to the very bottom of the form.
•The one-to-many links in the set
appear.
11. Close the default form.
•Click the X in the upper right corner
of the window or press CTRL + F4.
The Layouts tabs
The layouts tabs are: Forms, Browses, Reports, Letters and Labels.*
• Use these tabs to:
•Create and save new layouts
•Edit, view and delete existing layouts
•Preview and print layouts
*. Forms, Letters and Labels begin on page 67 Reports begin on page 179.
576
ALPHA FIVE MADE EASY
The Basics and More for Version 6
The Operations tab
Operations perform tasks on groups of
records. In Alpha Four, these commands
appeared on Utilities and Global update/
delete menus. Alpha Five has added the
ability to save the settings for all of the
Operations.
12. On the Alpha Five Control Panel,
choose the Operations tab.
NOTE
A different icon represents each type of
operation.
•Use the Operations tab to:
•Append records from one table to
another
•Copy records to a new table
•Cross-tabulate records
•Delete or mark records
•Export records
•Import records
•Join, intersect or subtract records by comparing two tables
•Post records from one table to another
•Summarize records to a new table
•Update records
13. Choose File > Exit to close Alpha Five.
Alpha Five file types
PLEASE TAKE A MOMENT TO
READ THIS
When using Alpha Five, it is not necessary to know how or where your data is
stored. However, it is helpful to be aware of this information during the process of converting Alpha Four data to Alpha Five.
• Alpha Five and Alpha Four share only one common file type, the .DBF file.
• Alpha Five stores all indexes for one table together in the .CDX file. In Alpha Four
each index is stored in a separate .NDX file.
• Alpha Five stores field rules, layouts (forms, reports, etc.) and saved operations
(queries, updates, etc.) in the Data Dictionary files. In Alpha Four each layout,
saved search/sort list, and so on, was stored individually in a separate file.
• In Alpha Five, scripts are embedded in the layout to which they are attached, or are
stored as global scripts in the database’s .ALB file.
577
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Alpha Five file types
Database file types
The following is a basic list of file types. A chart of all file types and their uses may
be seen at A5 Help > Tutorials > Alpha Five File Types.
THE DATABASE
Think of this file as a stored list of the tables in your database. It also stores saved
import operations.
•YourDatabase.ADB*
•YourDatabase.ALM
•YourDatabase.ALX
THE SCRIPT LIBRARY
The “Script Library” stores the global scripts, functions, custom toolbars and menu
bars.
•YourDatabase.ALB
Table file types
•YourTable.DBF – Stores records.
•YourTable.FPT – Stores memo text, if you are using memo fields.
•YourTable.CDX – Indexes.
DATA DICTIONARY
The table’s Data Dictionary. Stores the design of your layouts, field rules and saved
operations.
•YourTable.DDD
•YourTable.DDM
•YourTable.DDX
Set file types
DATA DICTIONARY
The set’s Data Dictionary. Stores the design of layouts and saved operations that you
have defined at the set level.
•YourSet.SEM
•YourSet.SET
•YourSet.SEX
Naming Alpha Five database objects
USING LONG NAMES
Use long names - but not too long.
•Make names long enough to be helpful, but not too long. If you use a lot of
long names, you risk running out of space when defining a calculated field
expression, for example.
•Also, space for displaying fields and file names is limited on some of Alpha
Five’s windows, dialog boxes and genies. If you use very long names, you
may not be able to see the entire name on the screen.
AVOIDING SPACES
Avoid spaces and special characters
*. In some instances, the .adb will not appear and the Type will be listed in Windows Explorer as alpha5 Document.
578
ALPHA FIVE MADE EASY
The Basics and More for Version 6
•Avoid using spaces and characters other than A-Z, 0-9 and _ (the underscore)
in names. There are a few places in Alpha Five that seem to have difficulty
interpreting spaces and special characters. Further, it is easier to refer to
objects in Xbasic when they do not have spaces.
RESERVED WORDS
Avoid using names that are already used by Alpha Five, such as file, field, or e-mail.
•Alpha Five will rename these illegal object names for you on form and report
layouts, but Xbasic may have difficulty interpreting them correctly. Instead
of file, field, or e-mail, use more distinct names such as file_num,
field_of_study and cust_email.
SELECTING NAMES
Be descriptive when choosing the names.
When naming layouts (forms, reports) and saved operations (queries, updates), be
descriptive and refer to the table or set it is based on. For example, name the data entry
form for clients “Client” or “ClientEntry”, not simply “DataEntry”.
•Do this because all of one type of database object are listed together on the
Alpha Five Control Panel.
Incorrect – One of these forms is
for Clients and the other is for
Registration, but how would you
know?
Correct – At a glance, you will
know on which table the form is
based.
• Alpha Five scripts refer to database objects by name only. This is another reason to
differentiate names of objects of the same type.
• Use a naming convention that will keep similar objects organized alphabetically.
Adopt a formal one or devise your own at the beginning of the development process
and be consistent. A widely accepted convention for databases is the Leszynski
Naming Convention or Hungarian Notation. A web search will direct you to
numerous articles on this subject.
Creating an Alpha Five database and pulling
your Alpha Four data into it
Your Alpha Four data can be brought into Alpha Five easily. There is no conversion
program for sets, field rules, forms, scripts and so on. You will need to recreate these
items in Alpha Five.
The following method will ensure that your data is brought into the proper folders
for the database. Your Alpha Four data will also remain safely in its original location.
• In this exercise you will:
•Create a new Alpha Five database and place it in its own folder.
579
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Creating an Alpha Five database and pulling your Alpha Four data into it
•Copy your Alpha Four data files into the new folder.
•Add your Alpha Four data files to the new database. Your Alpha Four data
files will appear as tables in the new Alpha Five database.
Creating a new Alpha Five database
In this exercise, you will create a:
•New folder (c:\A5_Ver10Book\A5_Data)
•A new Alpha Five database (MyConvertedDatabase).
IMPORTANT
It is very important to have each database in its own folder. If you simply define a
new database and add the tables from Alpha Four (or Alpha Five) without first copying
them to their own folder, you will be creating references to tables which will exist in
another location. This can be very confusing. For best results, follow the procedure
below.
1.
Start Alpha Five Version 10 from the
Start menu or the program icon.
•There are 2 tabs on the opening screen.*
•News & Updates
•Databases & Tasks
2. Tab: News & Updates: This screen is actually a web page.† It reports new information
from Alpha Software and gives helpful links.
If your software is out of date, you will get a
warning in a red box with a link to download
the latest patch.‡
•You can also access the download files from
within Alpha Five: From the Top Menu, choose
Help > Download patches.
*. This screen is sometimes referred to as the Welcome Screen.
†. As in many other instances, this screen is dynamic, meaning it may change from time to time depending on your most recent update.
‡. Updating always follows the same procedure: 1. At the Alpha website, choose the appropriate file for your software edition. 2.
Download. 3. Before running, close Alpha Five—not always required, but a good practice. 4. Follow instructions.
580
ALPHA FIVE MADE EASY
The Basics and More for Version 6
3. Tab: Databases & Tasks. Click Create a new, empty database.
•If you don’t see the above screen, open
Alpha Five; choose File > New Database.
4. Click OK at the following screen.
5. At the Create New Database window,
navigate
to
the
c:\A5_Ver10Book\ folder.
6. Create and open a new folder* with
the following name:
c:\A5_Ver10Book\A5_Data
NEW FOLDER
a. To make a new folder, click the Create
New Folder button (inset at left).
b. Over
type New Folder with the new
name (step 6 above) (Press ENTER)
c. Double
click the folder to open.
7. File Name: Enter the name of the database.
MyConvertedDatabase
8. Click Save.
The database is created and the Alpha Five Control Panel appears.
Copying your Alpha Four files
• Next, you will copy your Alpha Four data files into the newly created A5_Data
folder. The original Alpha Four application will remain intact.
*. Putting the database in its own folder is very important.
581
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Creating an Alpha Five database and pulling your Alpha Four data into it
HINT!
This method also allows you to experiment because the original data remains
untouched.
NOTE TO A5 USERS
These instructions may be applied to your Alpha Five files should you have a need to
copy files from one database to another. (Also complete the second part of the exercise,
“Adding tables to your Alpha Five database” on page 583.)
ADVANCED USERS
If you already know how to copy and paste files using Windows Explorer, navigate
to the C:\A5_Ver10Book\A4_Data folder, copy the seven files illustrated in step 17 on
page 583 to the C:\A5_Ver10Book\A5_Data folder. Then pick up the instructions at
step 24 on page 583.
9. Minimize the Alpha Five window of the database that you created in the
previous step. (Quit Alpha Four if open.)
10. Open the Windows Explorer.
WINDOWS HINT!
•There are several ways to do this. A shortcut is to use the Windows logo key
on your keyboard and press WINDOWS LOGO + E.
•On most keyboards, the windows logo key is located in the bottom row, next
to the CTRL key.
11. In the left-hand panel of
the Windows Explorer, doubleclick to the C: drive.
12. Double-click
A5_Ver10Book folder.
the
13. Double-click the A4_Data
folder.
14. Choose View > Details.
•Your screen should look like
this:*
15. On the right-hand panel,
click on the column heading
named Type. This will sort the
files by their type, or extension.
16. Locate the database (.DBF) and memo field (.DBT) files. They will be
of type “Database File” and “DBT” respectively.
NOTE
On some computers, the type for database files will be something other than “Database File.” This is because a program other than Alpha Five registered the DBF file type
in Windows with a different name. In the Windows Explorer you can confirm a file’s
DOS extension by right-clicking on the file and choosing Properties.
•Now we will select the files to copy.
*. The path in the Address window should read: c:\ A5_Ver10Book A5_Ver10Book\A4_Data.
582
ALPHA FIVE MADE EASY
The Basics and More for Version 6
17. Click on the first Database
File, Clients.
18. Hold down the SHIFT key
and click on the last DBT file,
Venue.
•Your screen should look as at
left.
19. Choose Edit > Copy.
20. In the left-hand panel of
the Windows Explorer, doubleclick to the C: drive.
21. Double-click the A5_Data
folder. In the right-hand panel,
you should now see the
MyConvertedDatabase files.
22. Choose Edit > Paste.
23. Close Windows Explorer.
Adding tables to your Alpha Five database
•Now that the data files have been added to the
folder, they need to be added to the database.
24. The Alpha Five program is minimized
on your Windows task bar. Click to restore
it.
• It will look like this:
25. Right-click in the white space below the
Tables/Sets tab.
26. Choose Add Table/Set.
•Check “Look in” to make sure that you will be
adding tables from the folder named
c:\A5_Ver10Book\A5_Data.
•To change folders:
a. Navigate
b. Select
to the folder.
the folder. (Click Open)
c. Next click on one of the .dbf files (inset at
left). (Click Open)
583
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Using the Conversion Tools
d. You
are returned to the Add Tables / Sets to Database window.
27. Use the Add Table button to choose all five tables. (Click OK)
SUMMARY
WHERE DO I GO FROM HERE?
You have learned the basic steps necessary to create a new Alpha Five database and
transfer your data files into it.
• We suggest you read through the rest of this chapter to familiarize yourself with the
additional tips for making the conversion.
•The Conversion Tools (see below) will help you recreate sets and move calculations and expressions.
•The 3-Step Plan begins on page 589. It outlines a method for developing the
new Alpha Five application while continuing to enter data into Alpha Four,
making the final conversion only when you are ready to begin using your
Alpha Five database.
• If you are new to the Alpha Five program, you can then begin the lessons at “Please
take a moment to read this” on page 4.
• If you are somewhat conversant with the program, you may wish to look through
the already familiar material to see if you can pick up additional tips, and, then proceed to the topics with which you are less acquainted.
• We are confident that, if you follow the steps in this book, you will become very
excited about the prospects of a new, even better application than you had before.
That will make the conversion a task to be completed, rather than a chore to be
dreaded!
Using the Conversion Tools
Using the Alpha Four Documentation Program
As we stated earlier, sets, field rules, layouts and scripts made in Alpha Four will
need to be recreated in Alpha Five. Fortunately, there is an Alpha Four tool which will
help you with some of these tasks.
Alpha Four Version 8 and several previous versions came with a Documentation
Program, A4DOC.EXE. It was installed automatically when you installed Alpha Four.
584
ALPHA FIVE MADE EASY
The Basics and More for Version 6
You can use A4DOC to print a copy of your Alpha Four set structure, field rules,
scripts and so on and refer to this documentation as you design these items in Alpha
Five.
• The following instructions will show you how to start A4DOC and print the Field
Rules for the Seminars table:
1. Quit Alpha Four if you have it open.
2. Click Start > Run and type: C:\ALPHA4V6\A4DOC.EXE
3. Click OK.
4. On the Alpha Four Documentation Options screen, choose Database/
Set documentation.
5. On the Database Directory screen, at the prompt “Enter name of the
database/set”
at
the
bottom
of
the
screen,
type:
C:\A5_Ver~1\A4_DATA\SEM_RPT.SET
6. Press ENTER.
•The Documentation Options screen appears.
7. Choose the following:
•Structure information: None
•Field rules information: by Field name
8. Press F10.
9. Proceed through the familiar Alpha Four printing options.
•When printed, your Field Rules will look like this
Field Rules - Listed by fields for SEMINARS
1. SEMINAR_ID (Field 1)
585
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Using the Conversion Tools
Type
Value
Auto Increment Field
Skip Rule Expression
Posting
Auto Advance
:
:
:
:
:
:
Numeric
User Entered
Increment for each new record
.t.
No
No
2. VENUE_ID (Field 2)
Type
Value
Posting
Auto Advance
Lookup Source
Lookup Validation Mode
Lookup Exceptions Allowed
Lookup Location
Lookup Display Rows
Lookup Auto Popup
Lookup Database
Lookup Link Index
Lookup Disp Index
:
:
:
:
:
:
:
:
:
:
:
:
:
Numeric
User Entered
No
No
Database
Exists
No
3
10
Yes
VENUE
VEN_ID
VEN_SITE
Lookup Layout
Choice Field
VENUE_ID
SITE_NAME
CITY
STATE
Filled Field
VENUE_ID
Display
N
Y
Y
Y
Width
25
10
2
3. TITLE (Field 7)
Type
: Character
Value
: User Entered
Automatic Capitalization Mode : Capitalize first letter of
each word and
convert the rest of the field to
lowercase
Posting
: No
Auto Advance
: No
Lookup
: No
Page 1
7-Oct-01
Shortcuts for moving calculations and expressions
into Alpha Five
Did you know that you can copy and paste from Alpha Four to Alpha Five? Using
the Windows Clipboard can save you time when building the Alpha Five version of
your Alpha Four database.
Copy and Paste are useful for moving calculated field expressions from your Field
Rules and layouts such as forms and reports.
586
ALPHA FIVE MADE EASY
The Basics and More for Version 6
• This exercise will show you how to use the Windows Clipboard to copy a calculated field expression from an Alpha Four report.
1. Open Alpha Four. For this exercise, you will need to work with Alpha
Four in a Window rather than Full-screen.
FIGURE 5. Alpha Four in a Window.
NOTE
If you do not see Alpha Four in a window, as shown above, press ALT+ENTER.
2. From the Alpha Four Main Menu, choose Choose database/set >
Open a database.
3. On the Database Directory screen, at the prompt “Enter name of the
database/set” at the bottom of the screen, type: C:\
A5_Ver10Book\A4_DATA\SEM_REPT.SET
4. Press ENTER.
5. Choose Layouts > Reports > Create/edit a report.
6. Choose report A.
7. Choose F2 > define Calculated fields.
587
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Using the Conversion Tools
8. Place your cursor in
the expression for the
field SEM_DATES and
press F8 Window On.
9. Right-click on the
title bar of the Alpha
Four window. Choose
Edit > Mark.
10. Use your mouse to highlight both lines of the expression in the
CalcField window.
FIGURE 6. The expression will be highlighted as shown in dark gray.
11. Press ENTER to copy the marked text.
•The expression is now saved in the Windows Clipboard. You can easily paste
it into Alpha Five or any Windows program by choosing Edit > Paste or
pressing CTRL+V.
• At this time, we will not continue on to pasting this expression into an Alpha Five
report.
• You may use this technique when adding calculated fields to forms, reports, etc.,
throughout Alpha Five. For using calculated fields in forms, see “Understanding
the Expression Builder” on page 143.
12. Press ESC until prompted, “Are you sure you want to lose all changes”?
Answer Yes.
588
ALPHA FIVE MADE EASY
The Basics and More for Version 6
13. Quit Alpha Four.
The 3- Step Plan
Strategies for developing, testing and
making the final data conversion
If you have a large and complex Alpha Four application, developing and testing its
Alpha Five counterpart will take time. You will probably need to keep working in your
Alpha Four database until your Alpha Five application is ready. When the time comes,
how will you update Alpha Five with the latest Alpha Four data?
• Here is a 3-step plan for development and final data conversion:
1. Make a copy of your Alpha Four data to use as a starting point for your
Alpha Five database. (See “Copying your Alpha Four files” on
page 581.)
2. Develop and test your Alpha Five database. In the meantime, you can
continue entering records in your Alpha Four database.
•Keep in mind that if you change field names in Alpha Five it will create extra
work in step #3.
3. When ready to begin using your new Alpha Five database, empty out
your Alpha Five tables and append current Alpha Four records. The
next exercise will demonstrate this technique.
• In the following exercise, you will simulate step #3 above. We will imagine that
you are done developing and testing MyConvertedDatabase and are ready to start
using it. We will use a finished version of the MyConvertedDatabase from the Lessons disk.
Emptying the Alpha Five table
1. Start Alpha Five from the Start menu or the program icon.
• If the Databases and Tasks screen opens, select “More Databases” and click OK.
• If the Welcome to Alpha Five screen does not open, choose File > Open Database.
589
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
The 3- Step Plan
2. In the Open Database dialog box, use “Look
In” to locate and select the folder
C:\A5_Ver10Book\A5_Trans.
3. Select the database MyConvertedDatabase.
Click the Open button.
4. In the Alpha Five Control Panel, choose the
Tables/Sets tab.
5. Right-click on the Clients table and choose
Utilities > Empty the Table.
6. When prompted for confirmation, click Yes.
7. Repeat the previous step for each table you
plan to update with current Alpha Four records.
Appending current Alpha Four records
IMPORTANT NOTE
If you have one or more calculated fields in Field Rules that use the current system
date, such as a LAST_UPDATED field using the DATE() function, be aware that they
will recalculate to today’s date when you append.
•To prevent this, go into Field Rules, note the Calculated field expression and
change the field(s) from Calculated to User entered. After the Append,
change back to Calculated.
8. Quit Alpha Four if it is open.
9. Open Alpha Five and open the database MyConvertedDatabase.
10. Right-click on the Clients table and choose Create Operation.
11. In the Create New Operation Genie, choose Append Records and click
Create Using Genie.
•The Append Genie will open. (Click Next)
12.
590
Click the Open File smart button.
ALPHA FIVE MADE EASY
The Basics and More for Version 6
13. Choose
<More
Files> because we want
to append from the Alpha
Four tables, not from the
tables that are already in
our Alpha Five database.
14. The Open dialog box
will appear. In Look in,
make sure to choose the
path
C:\A5_Ver10Book\A4_D
ata.
IMPORTANT
Verify that the A4_Data
folder appears in Look in as
shown at left
15. Select the Clients
table and click Open.
16. Click Next.
•The Append Genie – Common Field Names window will appear.
17. Choose No, fields in each table have different names. (Click Next)
NOTE
Our field names do match, but it will be instructive to see how to match field names
on the next screen.
18. Choose Match Fields by: Name.
19. Click Suggest Field Mappings.
591
APPENDIX. ALPHA FOUR TO ALPHA FIVE: THE TRANSITION
Indexes and their new role in Alpha Five
•Your screen will look like this:
20. Click in the blank Transaction table
listing next to Middle Initial.
21. Choose Middle Ini to complete the
listing.
22. Click Next 4 times to accept the
default choices and proceed to the
Append Genie – Finish window.
23. Choose Run the append operation now (but don’t save…). (Click
Finish)
24. Click Yes to allow the records to be
appended.
25. Repeat step 10 – step 24 for each
table you want to update with current
Alpha Four records.
Indexes and their new role in Alpha Five
PLEASE TAKE A MOMENT TO
READ THIS
Indexes are used by a database to control the order in which records are displayed,
manipulated and printed. They allow you to find records instantaneously, even in a table
with thousands of records.
Indexes play a principal role in Alpha Four. In Alpha Five, they have more of a supporting role. The differences are important for Alpha Four users to be aware of when
they begin designing databases in Alpha Five.
Required indexes are created automatically
There were several areas of Alpha Four that required you to create an index first,
such as:
•Defining links in the Set Editor.
•Creating a database lookup in Field Rules.
•Preventing duplicate values during data entry.
•Performing Relational Commands such as Post and Join.
Alpha Five makes these tasks much easier by creating indexes for you automatically
or by building impromptu queries to do the task. All you must do is choose the fields
you wish to use. See “Increasing performance” on page 318.
592
ALPHA FIVE MADE EASY
The Basics and More for Version 6
Sort and Find by Key
The most common way to find records in Alpha Four was to choose an Index and
then use Find. You can do the same thing in Alpha Five by using Sort and Find by Key.
Alpha Five has an added bonus: You can sort and find on any field on your form or
browse, regardless of whether it is indexed. See “Tools for finding, sorting and filtering
records” on page 307.
• The exercise is complete. You may close the database.
Congratulations!
In the first section, pages 569-584, you added your Alpha Four data to
Alpha Five. You are now familiar with the layout and terminology of Alpha
Five as it relates to Alpha Four.
In the second section, pages 584-593, you have printed the format of
your existing Alpha Four sets and learned how to copy and paste your
expressions from A4 to A5. Finally, once all the development is done, you
can follow the 3-step method to make the final transfer.
SUMMARY
Once the following changes between platforms and programs are accepted, the
changeover will not seem so overwhelming.
• A benefit of Windows programs is that certain elements are shared across the
platform. Most users today have some experience in Windows, even if is
only a word processor or e-mail. Alpha Five will have the same look and feel
as other Windows program.
•There is a change in terminology from Alpha Four to Alpha Five at the most
basic level. What was formerly called a database is now called a table. An
Alpha Five database is a collection of tables.
The Alpha Five Control Panel takes the place of the Alpha Four Main Menu. The
tabbed interface takes the user from section to section. It lists all the tables and sets in
the Tables/Sets tab, reports in the Reports tab, etc.
It is a good idea to become familiar with the file types for tables and sets.
Take care when naming database objects. File names should not be too long and it is
best to separate the words with underscores, rather than blanks.
Alpha Four data is easily transferred to Alpha Five.
The Alpha Four documentation program provides a printout of the set structure,
which can then be duplicated in Alpha Five.
Expressions designed in Alpha Four can be copied to Alpha Five by using Copy and
Paste when Alpha Four is opened in a window.
The final task is to implement the 3-Step Plan for making the final adjustments
between the two programs.
593
Download PDF
Similar pages