Importing Computer Data (CANTAB, MVWM, VDRL, CPT

Importing Computer Data (CANTAB, MVWM, VDRL, CPT, CBCL/TRF/YSR)
* Some subtests require extra steps before you can import them. For example, the
CANTAB data is probably stored on a separate computer and must be exported from
the program, e-mailed to the computer the database is stored on, and saved in an
appropriate location. Please see the notes on each individual subtest before proceeding
with the following steps.
** IMPORTANT: Before importing any data, you must make sure the subject has a file
within the database, and that the computer subtests are checked as having been given.
You do not need to enter any data into them (i.e., tester, date of testing, etc.) until after
you have imported the data.
1. Open the Neurobehavioral Database. Note: When opening Access files you will
get a warning about unsafe files. Click “Open” because this file is safe. ;)
2. Click on “Import Functions.”
3. Click on the type of file you want to import (i.e., MVWM, CANTAB, etc.).
4. In the new box that opens, navigate to the location where that file(s) is stored and
highlight it/them (hit “Shift” and mouse key or “Control” and mouse key, as
necessary to highlight the appropriate file(s)).
5. Click “Open.”
6. The computer will let you know if you successfully imported the data.
7. After importing, make sure to go to each individual subtest to enter in tester, date
of testing, age, any comments, and whether the test(s) is/are valid or not. Note:
The CANTAB also has more data than what was just imported, so you must
enter ALL the data.
CANTAB:
* IMPORTANT: In order to import the CANTAB data into the Neurobehavioral
Database, you must have 2 separate files: the raw and z-scores. You cannot import one
without the other.
1. Open the Results Manager.
2. Choose “Open an existing results set” and choose the results set where your
data is located (i.e., “Consortium Results,” “Default Results Set,” etc.)
3. Click on the subject you want to export.
4. Click on View -> Properties.
5. Click on the “Details” tab and make sure all appropriate details are entered. To
change/add data, click on the property you want to change/add. A box appears at
the top of the Properties box. Click on this box and change/add data as needed.
Then, choose the green check box.
6. Close the Properties box (“X” in upper right hand corner) when you are done
changing/adding details.
7. Click on the “Analysis Wizard…” box.
8. Choose “Summary datasheet” and click “Next.”
9. Uncheck the boxes about descriptions and warnings (they will not be imported
and will interfere with the importing process) and click “Next.”
10. Choose “Raw scores” (or “Standardised scores” as appropriate) and click “Next.”
Note: You will need both to import into the database.
11. A box pops up saying you must choose measures. Just click “Next.”
12. Under “Collection:,” choose the appropriate collection (i.e., “CIFASD Collection”),
then click “Finish.”
13. After the spreadsheet opens up, go to File -> Save, and save it to a known
location and name it “CIFASDID_Raw_Scores” or “CIFASDID_Z_Scores” as
appropriate (you must name them these or the program will not recognize them
when importing).
14. Close the spreadsheet.
15. Repeat steps 7-14 to get the “Standardised scores.” At step 10, make sure you
choose “Compare against all of the normative database.”
16. Close the Results Manager.
17. If required, e-mail yourself (or another person) the appropriate files so that they
can be downloaded onto the same computer as the database.
Congratulations! You are now ready to import the
CANTAB data into the Neurobehavioral Database!
Water Maze (MVWM):
1. Open Excel.
2. Click on File -> Open.
3. Navigate to the file you wish to import. Note: All Water Maze data is stored in a
folder marked “Data” within the “NIVN Morris water task” folder, each subject in
their own folder labeled with their “name” (should be using GlobalID for this!).
Make sure the “Files of type:” is changed to “All Files” and choose the
“Sum_GlobalID” file of the subject you wish to import.
4. Click “Open.”
5. The “Text Import Wizard” box should open up.
Step 1: We cannot include the heading information in the file that is imported, so
change the “Start import at row:” from “1” to “11” (where the header row is of your
data, i.e. “Block,” “Trial,” etc.). Then click “Next.”
Step 2: Check to make sure you are importing at the appropriate row and that
“tab” is marked as the “Delimiters.” Click “Next.”
Step 3: Click “Finish.”
6. Check the data to make sure no weird numbers have popped up. The only
concern is that every once in a great while, you will see the symbol “-1.#J” under
the column marked “HEAD.” Make sure to change this to “0.”
7. Go to File -> Save As…
8. Make sure the file name is “SUM_GlobalID” and change the “Save as type” to
“CSV (Comma Delimited).” Then click “Save.” Note: Make sure you know the
location of where you just saved the file. I would just save it in the same folder
with the rest of that subject’s data.
9. A box will pop up letting you know that some formatting cannot be stored in CSV.
Click “Yes.”
10. Close Excel. Note: If you see the box about wanting to save changes made to
the file, click “No.” You haven’t made any changes since you saved it. =)
11. If required, e-mail yourself (or another person) the appropriate file so that it can
be downloaded onto the same computer as the database.
Congratulations! You are now ready to import the
Water Maze data into the Neurobehavioral Database!
Reversal Learning (VDRL):
No extra steps need to be taken, unless the program is on a separate computer from
the database. Then, you need to e-mail the “GlobalID_sumdata.txt” file to yourself (or
another person) to download it onto the same computer as the database.
NES3 (CPT):
* IMPORTANT: In order to import the NES3 data into the Neurobehavioral Database,
you must have 3 separate files: CPAS, CPAR, and CPAF. You cannot import any one
without the others.
1. Open the data file for the NES3. Note: This is located within the “Data” folder
within the “NES3” folder. It is the Access database called “NES3.” When opening
Access files, you will get a warning about unsafe files. Click “Open” because this
file is safe. ;)
2. Double click on the “CPAS” file. You will do the next steps (3-5) 2 more times,
with “CPAF” and CPAR.”
3. The CPAS (CPAF/CPAR) data box will open up. Highlight the row of the subject
you are interested in.
4. Go to File -> Export…
5. Name the file “CPAS” (or CPAF/CPAR, as appropriate). Change the “Save as
type:” to “Microsoft Excel 97-2003.” Then make sure the box called “Save
formatted” is checked. Click on the arrow next to “Export All” and choose “Save
selection.” Note: Make sure you know the location of where you just saved the
file. I would just save it in the same folder as the NES3 Access file.
6. Repeat steps 2-5 for the other 2 subtests.
7. Open Excel.
8. Click on File -> Open.
9. Choose one of the files you just created (CPAS, CPAF, or CPAR).
10. Change the “Session ID” to the subject’s Global ID (or the data can’t be
imported).
11. Click on File -> Save.
12. Repeat steps 8-11 for the other 2 data files.
13. Close out of Excel.
14. If required, e-mail yourself (or another person) all files so that they can be
downloaded onto the same computer as the database.
Congratulations! You are now ready to import the
NES3 CPT data into the Neurobehavioral Database!
CBCL/TRF/YSR:
1.
2.
3.
4.
Open the CBCL scoring program.
Click “OK” (need not enter a password).
Go to Tools -> Export data for analysis.
In the first box, make sure that “Export data for analysis” is marked, then click
“Next >>.”
5. Choose a location to save the file (remember where you save it), label the
“Scored data file name” as appropriate (i.e., for the CBCL of SMS10 call it CBCLSMS10), and choose “Excel” for the file format. Then click on “Next >>.”
6. In the “Selection Criteria” box, choose “Name” under “Personal information” and
place a check in the box next to the subject’s name. Click “Done.”
7. Under “Form description” choose “Form types” and place a check box next to the
appropriate form (either, Child Behavior Checklist/6-18, Teacher’s Report
Form/6-18, or Youth Self Report (2001 version), and click “Done.”
8. Click “Next >>.”
9. After a moment, the box will show how many individuals were found and how
many forms were found. It should be 1 individual and 1 form. If this is correct,
click “Export.” If not, the subject may have more than one form. Go “Back” to
“Selection Criteria” and choose another selection that will separate out the form
you are interested in. Click “Done” and “Next >>.” Now, you should have only 1
individual and 1 form. Click “Export.”
10. You will either need to close the box (click “Exit”) and start from step 3, or you
can just click on “<< Back” until you reach the box with the location and file name
and repeat steps 5-9 for the TRF and/or the YSR, as necessary. Remember to
save them appropriately.
11. Close out of the CBCL Scoring program and open Excel.
12. Go to File -> Open and find the CBCL/TRF/YSR files you just exported.
13. Under “id” change the ID to their Global ID and then go to File -> Save. If the
computer tells you that it’s saved as an earlier version and do you want to
update, choose “Yes.”
14. Close Excel.
15. If required, e-mail all files to yourself (or another person) so they can be
downloaded onto the appropriate computer.
Congratulations! You are now ready to import the
CBCL/TRF/YSR data into the Database!
Download PDF
Similar pages