TIBCO Spotfire Qualification 4.5

TIBCO Spotfire® Qualification 4.5 User's Manual
Important Information
SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH
EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY
(OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE.
THE EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED
BY ANY OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.
USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND
CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED
SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT,
THE CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING
DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN
LICENSE_TIBCOSPOTFIREQUALIFICATION.PDF) OR IF THERE IS NO SUCH SOFTWARE
LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S)
LOCATED IN THE “LICENSE” FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS
SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL
CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.
This document contains confidential information that is subject to U.S. and international copyright laws
and treaties. No part of this document may be reproduced in any form without the written authorization of
TIBCO Software Inc.
TIBCO and Spotfire are either registered trademarks or trademarks of TIBCO Software Inc. and/or
subsidiaries of TIBCO Software Inc. in the United States and/or other countries. All other product and
company names and marks mentioned in this document are the property of their respective owners and are
mentioned for identification purposes only. This software may be available on multiple operating systems.
However, not all operating system platforms for a specific software version are released at the same time.
Please see the readme.txt file for the availability of this software version on a specific operating system
platform.
THIS DOCUMENT IS PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL
ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE
CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO
SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S)
AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.
Copyright © 1996- 2012 TIBCO Software Inc. ALL RIGHTS RESERVED.
THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY
OR INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE,
INCLUDING BUT NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES.
TIBCO Spotfire is covered by U.S. Patent No. 6,014,661 and U.S. Patent No. 7, 216,116.
Other patent(s) pending. TIBCO Software Inc. Confidential Information
Table of Contents
1
INTRODUCTION ........................................................................................................ 1
2
HOW TO USE TIBCO SPOTFIRE QUALIFICATION ................................................ 2
2.1
2.2
2.3
2.4
2.5
3
3.1
4
4.1
5
5.1
5.2
5.3
5.4
5.5
6
6.1
7
Create Analysis ................................................................................................................................. 2
Create Gold Standard ....................................................................................................................... 2
Export on another Installation ........................................................................................................... 3
Compare Gold Standard with Comparison Export ............................................................................ 3
Merge Files in Gold Standard ........................................................................................................... 4
CONSTRAINTS .......................................................................................................... 6
Constraints ........................................................................................................................................ 6
SETTINGS .................................................................................................................. 7
Settings.............................................................................................................................................. 7
TOOL DIALOGS ........................................................................................................ 9
Details on Export Dialog .................................................................................................................... 9
Details on Select Folders to Compare Dialog ................................................................................... 9
Details on Comparison Results Dialog ........................................................................................... 10
Details on Create New Gold Standard Dialog ................................................................................ 11
Details on Compare Files and Segments Dialog ............................................................................ 12
COMMAND LINE PARAMETERS ........................................................................... 13
Command Line Parameters ............................................................................................................ 13
INDEX ....................................................................................................................... 14
iii
Introduction
1
Introduction
TIBCO Spotfire Qualification allows you to verify that an analysis in TIBCO Spotfire yields
the same results on different installations of TIBCO Spotfire – that is, on other computers,
between development/test/production environments, or after upgrading TIBCO Spotfire.
Spotfire Qualification includes an export tool that exports all parts of a Spotfire analysis. The
first export is verified manually, and when the export is verified to be correct, it is used as a
gold standard. The Spotfire Qualification compare tool then compares that gold standard with
other comparison exports, reporting the differences between the exports.
An example gold standard, verified by the TIBCO Spotfire Quality Control team, is provided
with the product to help qualify the initial installation of TIBCO Spotfire across the system, but
any functionality available in TIBCO Spotfire can be used in a gold standard.
► To Qualify TIBCO Spotfire:
1.
Create an analysis, containing all plots, tables, calculations, and so on, that is to be
qualified.
2. Create a gold standard for that analysis by exporting it with the Qualification export
tool and verifying its contents manually.
3. Create an export of the same analysis on another computer or environment where
TIBCO Spotfire should be qualified.
4. Compare the new export with the gold standard using the Qualification compare tool,
and verify that the new export is the same as the gold standard.
5. Handle potential differences in the comparison export and the gold standard and create
a new gold standard.
Each of these steps are described in detail on their respective help pages.
To get access to the qualification tool, you need to have SpotfireQualification.spk deployed
on your TIBCO Spotfire Server, and the licenses Qualification Export Tool and Qualification
Compare Tool must be enabled. See the TIBCO Spotfire Qualification – Installation and
Configuration manual for more information.
1
TIBCO Spotfire® Qualification 4.5 - User's Manual
2
2.1
How to Use TIBCO Spotfire
Qualification
Create Analysis
The first step of qualifying TIBCO Spotfire is to create an analysis that contains all the
visualizations, calculations and settings to qualify. An example gold standard analysis and
corresponding export is provided with TIBCO Spotfire Qualification. It has been manually
verified by the TIBCO Spotfire Quality Control team and can be used to qualify a default
installation or upgrade of TIBCO Spotfire or it can be modified and extended to create a gold
standard with additional Spotfire features to qualify.
It is possible to qualify all features of Spotfire, such as functions, custom expressions,
calculated columns, and so on, as long as the result of the feature can be presented in a standard
visualization or a data table.
Provided Gold Standard Example
Some aspects of TIBCO Spotfire that are covered in the provided gold standard example are:
• Tabular and graphical visualizations
• Multiple data tables
• Most statistical measures
• Coloring
• Multiple filtering schemes
• Multiple markings
The provided gold standard example analysis and export are available in the Gold Standard
Example.zip file located in the root of the Qualification download.
2.2
Create Gold Standard
Once an analysis has been created, the next step is to export the analysis with the Qualification
export tool. After manually verifying that the contents of that export are correct, the export is
declared to be the gold standard. All other exports on different installations for that analysis are
then compared with that gold standard.
Exporting an Analysis
When an analysis is exported from the qualification tool, the export creates a top root folder and
three sub-folders, Export Information, Data Tables and Visualizations.
• The root folder contains an export report, an .xml file that holds the content of the
export and a log file describing what has been done in the export.
• The Export Information folder contains the analysis file (with linked or embedded data
depending on the file), export information and system information.
• The Data Tables folder contains all the data tables exported from the analysis as
Spotfire Text Data Format (.txt) files. These files contain the columns from the data
tables as well as metadata on the data table, such as the data types and the column
names.
• The Visualizations folder contains all the exported visualizations and text areas. The
visualizations are exported as .bmp images. The bitmap format is used to minimize
compression variants when comparing the images. Text areas created in Spotfire 3.1 or
later are exported as .html files without any images, and earlier versions of the text
area are exported as .rtf files.
2
How to Use TIBCO Spotfire Qualification
Comment: Tabular visualizations can be exported as both .bmp images and as tab
separated text files. Text areas can be exported as both .bmp images and as .html files
or .rtf files respectively. For more information, see Settings.
The Export Report
The export generates a report in HTML format, containing the export information, the system
information and all the exported files. The report gives a summary of what was exported, and is
useful for archiving what was exported.
► To Export the Analysis from the Qualification Tool:
1.
2.
3.
Select Tools > Qualification > Export...
Response: The Export dialog is displayed.
Specify the folder to export to.
Comment: A new sub-folder with the date and time of the export will be created to
avoid other exports to be over-written.
Click Export.
Response: Links to the exported files and the export report are displayed.
Click Close.
Verifying the Gold Standard
The export must then be verified manually. How this is done depends on the contents of the
analysis and export, but various statistical tools can be used to verify the values in the export as
correct.
Note: Some statistical methods can be calculated differently in different applications; see
Constraints for more information.
2.3
Export on another Installation
When a gold standard has been created, the same analysis can be exported from other
computers, or after applying patches, to verify that the contents of the exports are the same.
This comparison export is done in the same way as the export of the gold standard.
2.4
Compare Gold Standard with Comparison
Export
When a comparison export has been made on another installation, that export is compared with
the previously created gold standard. This is done with the Qualification compare tool. The
results are listed in the Comparison Results dialog for each file—visualization or data table—in
the export.
The Compare Report
Clicking Create Report in the Comparison Results dialog creates a compare report in HTML
format. The report contains the export information and system information for both the gold
standard and the comparison export. The report also lists the comparison results: which files
differ between the gold standard and the comparison export, and how these differences are to be
handled. For more information on how to handle differences, see Merge Files in Gold Standard.
► To Compare the Exports with the Qualification Tool:
1.
Select Tools > Qualification > Compare...
Response: The Select Folders to Compare dialog is displayed.
3
TIBCO Spotfire® Qualification 4.5 - User's Manual
2.
3.
2.5
Specify the folder of the gold standard and the folder of the comparison export.
Note: Select the top folder for each export.
Click Compare.
Response: The Comparison Results dialog is displayed.
A list of all succeeded and failed comparisons is shown. Select a failed comparison in
the list and click Compare to view the differing files.
Response: If an external comparison tool has been specified in the Settings dialog, the
two files will be opened in the specified tool. If no tool has been selected, both files
will be opened in the standard application for that file type.
Select how to handle the differing files; see Merge Files in Gold Standard.
Merge Files in Gold Standard
If there are differing files—visualizations or data tables—in the comparison export and the gold
standard, they will be shown in the Comparison Results dialog as failed. For each of the files,
the difference must be handled in one of the three ways described below. After handling each of
the differing files, a new gold standard is created by merging the original gold standard with the
comparison export.
► The Three Ways to Handle Differences:
1.
2.
3.
Keep the file from the original gold standard in the new gold standard.
Comment: Select this option if the file in the comparison export is considered to be
incorrect. This means that the new gold standard will be the same as the old gold
standard for this file.
Append the file from the comparison export to the gold standard to use both files in the
new gold standard.
Comment: Select this option if the file in the comparison export, as well as the file in
the gold standard, are deemed to be correct. For example, if different thousands
separators are used on different installations the file versions may not be identical, but
both can be correct. For more information, see Multiple File Versions below.
Replace the file in the original gold standard with the comparison file.
Comment: Select this option if the file in the comparison export is deemed to be
correct and that the file in the original gold standard is no longer correct.
New and Removed
If files have been added or removed in the analysis, shown as new and removed in the
Comparison Results dialog, they cannot be merged to a new gold standard as the actual
analyses, not just the files in the exports, differ. If this is the case, a new export and gold
standard should be created from the new analysis. When the new gold standard is created only
the files that differed, or were added to the analysis, must be verified.
Multiple File Versions
If files are appended to a gold standard, as described in option 2 above, multiple versions of that
file will be used in the new gold standard. That is, two or more versions of that file are deemed
to be correct despite the differences. This means that if any new comparison export files match
either of the variants, they will be verified as the same as the gold standard. If any files in a
comparison export differ from a file that has multiple versions in the gold standard, the
Compare Files and Segments dialog is displayed when the files are to be compared in the
Comparison Results dialog. In that dialog the differing file can be compared with either of the
versions in the gold standard.
4
How to Use TIBCO Spotfire Qualification
When there are multiple files in the gold standard, each of these files is annotated with a rising
number in the export report for the gold standard. It is possible to limit how many of these
versions are to be shown in the export report. For more information, see Settings.
Note: If there are multiple versions of a file in the gold standard, a differing file in the
comparison export cannot replace these, only be appended to the gold standard.
5
TIBCO Spotfire® Qualification 4.5 - User's Manual
3
3.1
Constraints
Constraints
There are parts of an analysis and export that may always differ in the comparison. For example
if the method DateTimeNow() is used in an expression, the files will differ because the time has
changed between the exports. The following constraints may also be important to consider
when using the qualification tools.
Statistical Methods
Some statistical methods can be calculated differently by different applications. This can lead to
variances between the results of a calculation in TIBCO Spotfire and other applications. For
information on how the methods are calculated in TIBCO Spotfire, please refer to the TIBCO
Spotfire User's Manual.
Text Rendering
If text areas or table plots are exported as images, there will be a difference in the export if
some systems have ClearType and some don't.
Image Size
Images are exported in a fixed (customizable) size and not the actual size on the screen. This is
to avoid differences in the exports due to different screen resolutions or different sizes of the
TIBCO Spotfire window on different systems.
Rounding
Data tables with columns containing double values and complex calculations with very high
precision can be exported differently due to the rounding effect in different processors.
3D Scatter Plot
The 3D Scatter Plot is not supported in TIBCO Spotfire Qualification because the hardware
acceleration needed is not supported in exports from Spotfire.
Locale and Regional Settings
If the different installations of Spotfire have different locale and regional settings, files in the
comparison exports may differ from the files in the Gold Standard even though all of them are
correct. This is due to the differences in date formats and thousands separators. If this is the
case, it is recommended to have multiple file versions in the Gold Standard. For more
information, see Merge Files in Gold Standard.
6
Settings
4
4.1
Settings
Settings
Preferences
The following settings are specified by an administrator for groups of users. These settings
specify what is to be exported when using the qualification tool, and what is to be displayed in
the export report.
Note: If different settings are used for different groups, it is possible that each group will
require a separate gold standard, as these settings affect the contents of the compared exports.
► To Reach the Qualification Preferences:
1.
2.
3.
4.
5.
As an Administrator, select Tools > Administration Manager.
Select the Preferences tab.
Select the group for which to specify the preferences.
Select Qualification > Qualification Settings in the list displayed for the selected
group.
Click Edit.
Option
Description
ExportAllTable
PagesAsImages
If tabular visualizations are exported as images, set this to true to
export the entire visualization as multiple images. Note that this
can create a large amount of images. The default value is false,
which only exports the part of the visualization that is visible on
the screen as an image.
ExportAllTrellis
PagesAsImages
Set this to true to export every page of a trellis as an image, and
false to export only the visible parts of the trellis as an image.
Note that enabling this feature can create a large amount of
images. However, if there are several pages of a trellis and only
the visible parts are exported, there will be parts of the analysis
that are not qualified. The default value is true.
ExportImageHeight
Specify the height of the exported images, in pixels. The default
value is 768.
7
TIBCO Spotfire® Qualification 4.5 - User's Manual
Note: Changing only one of the values for height or width will
override the aspect ratio of the image.
ExportImageWidth
Specify the width of the exported images, in pixels. The default
value is 1024.
Note: Changing only one of the values for height or width will
override the aspect ratio of the image.
ExportTablesAlso
AsImages
Set this to true to export tabular visualizations as images as well
as tab separated text files. The default value is false.
ExportTextAreas
AlsoAsImages
Set this to true to export text areas in the analysis as images in
addition to the standard .html or .rtf files. The default value is
false.
ReportMaximum
FileSegments
If all pages of tabular visualizations or trellised visualizations are
set to be exported as images, specify how many of these
exported segments to show in the export report. The default
value is 3.
Note: If this value is changed, old reports are not updated.
ReportMaximum
FileSizeKbFor
IFrame
Specify the maximum size of the text files of the exported
tabular visualizations to be shown in the export report, in
kilobytes. If the size is exceeded, a link to the text file will be
shown in the report. The default value is 1024.
ReportMaximum
FileVersions
If there are multiple versions of the same file - visualization or
data table - in the export, specify how many of these to show in
the export report. The default value is 3.
Note: If this value is changed, old reports are not updated.
Settings Dialog
Use the Settings dialog to specify an external tool to compare differing image or text files in the
gold standard and comparison export. To reach the Settings dialog, select Tools >
Qualification > Settings.
8
Option
Description
Select external
compare tool:
Browse for an available tool to use to compare the differing files. This
tool will be used when clicking the Compare button in the Comparison
Results dialog. If no tool is specified, the default application for the file
type of the selected file in the comparison dialog will be used.
Command line
parameters:
Specify potential command line parameters for the chosen compare
tool.
Tool Dialogs
5
5.1
5.2
Tool Dialogs
Details on Export Dialog
Option
Description
Destination folder:
Specify the folder where the export is to be saved.
Note: The folder must be empty.
Export
Creates the export in the selected folder.
Details on Select Folders to Compare Dialog
Option
Description
Gold standard
folder:
Select the folder where the gold standard export is located.
Comparison folder: Select the folder where the export to be compared with the gold
standard is located.
Compare
Compares the two exports and opens the Comparison Results dialog.
9
TIBCO Spotfire® Qualification 4.5 - User's Manual
5.3
Details on Comparison Results Dialog
Option
Description
Show only failed
comparisons
Select this to only show the failed comparisons in the list.
List
Name
The name of the data table, text area or visualization, and which page
it was on in the analysis.
Type
The file type.
Result
The result of the comparison. Succeeded if the exported files were
identical, failed if they were not. If a file not existing in the gold
standard has been added in the comparison export, the result is new.
If a file existing in the gold standard is missing from the comparison
export, the result is removed.
Note: If files have been added or removed, they cannot be merged to
a new gold standard as the analysis has been changed.
For more information, see Merge Files in Gold Standard.
Comment
Details on the comparison result.
Selected Comparison
10
Gold standard file:
A link to the gold standard version of the file.
Comparison file:
A link to the comparison version of the file.
Comment:
Details on the comparison result.
Compare
Opens the files in the external compare tool specified in the Settings
dialog, or in the standard application for the file type. If there are
multiple versions of the file in the gold standard, the Compare Files
and Segments dialog is displayed.
Note: If there is only one file selected, this button is called Show.
Tool Dialogs
5.4
Use in new gold
standard:
Specify which file to use in a new gold standard export for each of
the comparisons that failed.
Gold standard
(keep)
Select gold standard to keep the file from the old gold standard in the
new gold standard.
Both files
(append)
Select both files to append the comparison file to the old gold
standard file in the new gold standard. This means that two versions
of the same file are considered to be correct in the new gold
standard.
Comparison file
(replace)
Select comparison file to replace the file from the old gold standard
with the comparison file in the new gold standard.
Create Report
Create a compare report.
Create New
Create a new gold standard export with the changes specified for
each failed comparison. Opens the Create New Gold Standard
dialog.
Details on Create New Gold Standard Dialog
Option
Description
Destination folder: Specify the folder where the new gold standard is to be saved.
Summary:
Shows the actions taken for the failed comparisons.
11
TIBCO Spotfire® Qualification 4.5 - User's Manual
5.5
Details on Compare Files and Segments Dialog
This dialog is displayed when two files are to be compared in the Comparison Results dialog
and there are multiple versions of a file in the gold standard or there are several segments in an
exported visualization. Several segments may exist if the exported visualization is trellised over
several pages or if it is a tabular plot that is not displayed in its entirety. Select the version or
segment to compare.
Option
Description
Gold standard
files:
Lists the different correct versions of a file in the gold standard.
Created
The date and time the file was exported.
Original Path
The path to the original export for the file.
File segments:
Segment
The number of the segment.
Result
The result of the comparison for that segment.
Comment
Details on the comparison result.
Compare
12
Lists the different segments of a selected file.
Opens the files in the external compare tool specified in the Settings
dialog, or in the standard application for the file type.
Command Line Parameters
6
6.1
Command Line Parameters
Command Line Parameters
It is possible to run TIBCO Spotfire and the Qualification export tool from the command line.
Using command line parameters, analyses can be exported without any user interaction.
Exporting analyses from the command line will open the analysis in Spotfire, create an export
of the file and then close Spotfire. It is possible to do this for files stored on disk and files stored
in the library.
The parameter for exporting an analysis is:
/qualificationexport:<Path>
where path is the location where the export should be saved.
Exporting a File Stored on Disk
An example of how to export an analysis stored on disk is:
C:\Program Files (x86)\TIBCO\Spotfire\4.5.0>Spotfire.Dxp.exe
/qualificationexport:"C:\Documents\Qualification\Comparison1"
/file:"C:\Documents\Qualification\Gold Standard Example.dxp" /offline
where /qualificationexport:<Path> is the path where the export is to be saved, /file:<Path> is
the location of the analysis file and /offline is an optional parameter to perform the export
without connecting to the server.
Exporting a File Stored in the Library
An example of how to export an analysis stored in the library is:
C:\Program Files (x86)\TIBCO\Spotfire\4.5.0>Spotfire.Dxp.exe
/qualificationexport:"C:\Documents\Qualification\Comparison2"
/uri:analysis:”/Library/Qualification/Gold Standard Example” /noupdates
/username:user /password:pass
where /qualificationexport:<Path> is the path where the export is to be saved,
/uri:analysis:<Library Path> is the location of the analysis file in the library, /noupdates is a
parameter that prevents updates from the server from being performed during the qualification,
and /username:<Username> and /password:<Password> are the username and password to
access the server with, so as to prevent the login dialog from being shown.
Note: The suffix .dxp is not to be included in the file name.
13
TIBCO Spotfire® Qualification 4.5 - User's Manual
7
Index
C
Command Line Parameters ............................................... 13
Compare Files and Segments Dialog ................................. 12
Comparison
Export ............................................................................. 3
Results .......................................................................... 10
Comparison Results Dialog ................................................ 10
Constraints........................................................................... 6
Create New Gold Standard Dialog..................................... 11
E
Export Dialog ....................................................................... 9
G
Gold Standard
Compare ......................................................................... 3
Create ............................................................................. 2
Merge ............................................................................. 4
I
Introduction ......................................................................... 1
S
Select Folders to Compare Dialog ....................................... 9
Settings ................................................................................ 7
14