Complete User Manual

Valve Sizing Program
Version 3.0
USER MANUAL
Windows 2000/XP
January, 2007
11122 West Little York – Houston, Texas 77041
Tel: (713) 466-3552 z Fax: (713) 896-7386
www.norriseal.com
NorriSize™
Valve Sizing Program
version 3.0
Introduction................................................................................................................................................. 3
Installation................................................................................................................................................... 3
Project Manager Module............................................................................................................................. 4
Project Tree............................................................................................................................................. 4
Project Information Panel ....................................................................................................................... 5
Creating Projects..................................................................................................................................... 5
Creating Project Items............................................................................................................................. 5
Editing Projects and Project Items.......................................................................................................... 5
Daily Sizing ............................................................................................................................................ 6
Address Book.......................................................................................................................................... 6
Valve Sizing Module .................................................................................................................................. 7
Service Selection..................................................................................................................................... 8
Service Data Panel .................................................................................................................................. 8
Steam Service...................................................................................................................................... 8
Liquid Service..................................................................................................................................... 9
Gas Service ......................................................................................................................................... 9
Two-Phase Service.............................................................................................................................. 9
Case Data Entry ...................................................................................................................................... 9
Units Selection ........................................................................................................................................ 9
Pipe Selection........................................................................................................................................ 10
Valve Selection ..................................................................................................................................... 10
Calculating Valve Coefficient............................................................................................................... 11
Preliminary Coefficient..................................................................................................................... 11
Final Coefficient ............................................................................................................................... 11
Sizing Results Panel.............................................................................................................................. 11
File Menu .................................................................................................................................................. 12
New Project… ( ) ............................................................................................................................... 12
New Project Item… ( )....................................................................................................................... 12
Open Project… ( ).............................................................................................................................. 13
Close Project ( ) ................................................................................................................................. 13
Save Project ( )................................................................................................................................... 13
Export…................................................................................................................................................ 13
Export Item ........................................................................................................................................... 14
Print…................................................................................................................................................... 14
Print to File ....................................................................................................................................... 14
Print Project .......................................................................................................................................... 15
Print Item ( )....................................................................................................................................... 15
Exit........................................................................................................................................................ 15
Edit Menu.................................................................................................................................................. 15
Options.................................................................................................................................................. 15
General Preferences .......................................................................................................................... 15
Default Units..................................................................................................................................... 16
User Information............................................................................................................................... 17
Clear Case ............................................................................................................................................. 18
Clear Service Data ................................................................................................................................ 18
Case Names........................................................................................................................................... 18
1
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Calc Prelim Cv ( )............................................................................................................................... 18
Create New Fluid ( ) .......................................................................................................................... 19
Creating a Custom Liquid................................................................................................................. 19
Creating a Custom Gas ..................................................................................................................... 20
Copying From an Existing Fluid....................................................................................................... 21
Delete Project........................................................................................................................................ 21
Delete Project Item ............................................................................................................................... 21
View Menu................................................................................................................................................ 21
Specification Views .............................................................................................................................. 21
Project Items ......................................................................................................................................... 21
Cv Curve ( ) ....................................................................................................................................... 22
Calculation Messages ( ).................................................................................................................... 22
Appendix A: Walkthrough........................................................................................................................ 23
Example 1 ............................................................................................................................................. 23
Example 2 ............................................................................................................................................. 24
©2007 Norriseal
2
NorriSize™
Valve Sizing Program
version 3.0
Introduction
NorriSize™, the Norriseal Valve Sizing Program, enables one to calculate the required Cv, Flow
Velocity, Mach Number and Flow Noise based on a given set of parameters, and aids the user in
determining the appropriate valve selection for a fluid service application. The program can
automatically provide values for many common fluids; however, the user’s knowledge of the
environment is essential for proper valve selection for any service application. It is ultimately the user’s
responsibility to assure the data used for calculations is correct.
Version 3.0 of the program has been written from the ground up, and represents an
overwhelming improvement over version 2.x in terms of program interaction and interface design.
Efforts have been focused on providing a flexible, project based environment and modularizing the
interface to cleanly separate project management tasks from valve sizing. New features include the
display of Cv curves, expanded printing options, a simple address book and persistent user preferences
which make the program a more effortless tool for sizing valves.
Flow coefficients are calculated using the latest ISA standard S75.01.01-2002 Flow Equations
for Sizing Control Valves. Unfortunately, there has been no progress in the draft standard dS75.07.01,
so noise prediction is still calculated using ISA standard S75.17-1989 Control Valve Aerodynamic
Noise Prediction. Calculation accuracy has been improved over the previous version by implementing a
more robust specific gravity calculator and expanding fluid property temperature ranges. Calculation
messages have been improved to provide the user with information to correct the problem which causes
the message to appear.
Installation
Installation of the Norriseal Valve Sizing Program requires that you have an installed Java
Runtime Environment (JRE) version 1.4.x or 1.5.x. Issues have bee identified in version 1.6.x which
have not been fully investigated. Regardless of whether you have received your copy of the program on
CD or downloaded from our website, you can always get the appropriate version of the JRE from Sun
Microsystem’s website: http://java.sun.com.
System Requirements
• Microsoft Windows 2000/XP (compatibility w/ Vista is expected)
• Pentium II-233 or higher
• 256MB Memory
• 50MB Free Hard Disk Space
• CD-ROM (for CD installation)
• Installed Printer (for reports)
• Mouse or other pointing device
To install the NorriSize™, Norriseal Valve Sizing Program, simply double-click on the selfextracting executable and select a directory into which the files are to be extracted. To run the program,
double-click on the NorriSize shortcut found in the directory where the files were extracted. The first
3
©2007 Norriseal
Valve Sizing Program
NorriSize™
version 3.0
time the program is executed, Agent and Company dialogs are displayed for entering user-specific
information. See Simple Address Book for creating and maintaining Agent and Company information.
Project Manager Module
The Project Manager provides the main interface to create and maintain projects. The module
consists of the Project Tree on the left and the Project Information panel on the right. The Project Tree
displays open projects and allows the user to navigate through all the items contained within these
projects. The Project Information panel displays project and project item information.
Project Tree
Projects that you create are displayed in the Projects folder of the project tree. A second project
folder named Daily Sizing is a permanent project that appears below the Projects folder, and can be used
for quick sizing of general inquiries where creating and maintaining a project is not desirable. Project
items are displayed under its parent project using the tag number given when the item was created.
Selecting a project or project item in the Project Tree will display its information in the Project
Information panel. Double-clicking a project item will take you into the Sizing Module for that item.
©2007 Norriseal
4
NorriSize™
Valve Sizing Program
version 3.0
Project Information Panel
The Project Information panel displays project, item and specification information for the
currently selected project. Only the current project item and its parent project can be edited from the
Project Information panel; specification information (if available) is read-only and is intended only to
aid the user to more easily identify where and how the item is used. Each display list can be minimized
using the Details<< button, which is beneficial for low resolution screens when all the information
panels cannot be seen at one time. By minimizing an information panel, it is not required to utilize the
scroll bar to view information that cannot be displayed due to low resolution screens. An option to
permanently hide one or all of the specification information panels is also available to customize project
information display to suit the user’s preference.
Creating Projects
New projects are created via the Project Wizard. To create a new project, select the FileÆNew
Project… menu item, or the first icon ( ) on the project toolbar. See New Project... in the File Menu
section for details on creating new projects.
Creating Project Items
New project items are created via the Project Item Wizard. With a project active (i.e. displayed
in the Project Information panel), select the FileÆNew Project Item… menu item, or the second icon
( ) on the project toolbar. New items can also be created while in the Sizing Module. See New Project
Item… in the File Menu section for details on creating new project items.
Editing Projects and Project Items
Projects and project items can be edited within the Project Information panel. There are two
types of editors within the information panels: an inline text editor for character fields such as the
project name or tag number, and an external editor for multiline fields such as an address book object or
notes. External editors are shown as an ellipsis button to the right of the selected cell. When pressed,
the external editor is displayed to allow changes to be made to the underlying data.
Figure 1: Inline text editor
Figure 2: External object editor
5
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Daily Sizing
The Daily Sizing project is automatically updated with the current date and a generic quote
reference every time the program is loaded. An option to automatically remove all items of the Daily
Sizing folder when the program is closed is available to simplify management of the Daily Sizing folder.
Address Book
The Valve Sizing Program incorporates a simple address book as a convenient method for
storing company and agent information. The address book is not directly accessible via any module, but
is utilized internally by the program for maintaining contact information in a project. The Customer,
Contact, Agent and Company fields are address book data objects which can be edited through the
external object editors.
•
•
•
New Entry – Creates a new agent or company address book entry. Multiple entries can be
created during the dialog session.
Remove Entry – Permanently removes the current address book entry from the database.
Search – Opens the Search Address Book dialog. The list displayed depends on the role of the
object being edited (i.e. Customer vs Company). For example, the Customer search dialog will
display customers only, whereas the Company dialog will typically only display the user’s
company. The latter case is illustrated below. Search dialogs cannot edit data.
©2007 Norriseal
6
NorriSize™
Valve Sizing Program
version 3.0
Changes made to the currently selected address book entry are dynamically updated when the
editor is closed using the OK button or New Entry/Search is selected. Changes made to the currently
selected item will be discarded when the editor is closed using the Cancel or Close Window buttons.
Valve Sizing Module
The Valve Sizing module provides the main interface to enter service application parameters and
perform sizing calculations. The module consists of the Service Selection panel at the top, the Service
Data panel in the center, and the Sizing Results panel at the bottom.
7
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Service Selection
The Service Selection panel is used to describe the service environment, and contains the
following components:
• Service – A drop-down list for the type of fluid service: Liquid, Gas, Steam or Two-Phase.
• Fluid – A drop-down list for selecting the fluid. The fluid list is automatically updated for the
service type selected. Selecting a different fluid when the Fluid Override is checked will disable
the override for the new fluid in order to calculate its properties.
• Fluid Override – A check box to override the default fluid properties calculated by the program.
Checking this component allows the user to enter custom fluid data which more accurately
reflects the service environment, such as specific gravity or vapor pressure. Unchecking the
component reverts fluid properties to their predefined values based on the current temperature
and pressure of the service data. When the Fluid Override is unchecked, the fluid is considered
dynamic because changes in service conditions recalculate the fluid’s properties. When checked,
the fluid is considered static because changes in service conditions will not affect fluid property
values.
• Calculate button – Calculates the flow coefficient and noise prediction. The program does not
perform calculations automatically. NOTE: Any change made to the data of the sizing module
requires the user to recalculate the results. The percentage of rated Cv is updated, for the
benefit of comparison, in the sizing results panel when a change to the trim is made.
• Pipe Selection – Provides pipe sizes and schedules to select for the service. NOTE: The pipe
selection panel is not enabled until a preliminary Cv has been calculated.
• Valve Selection – Provides valve and trim options to select for the service. NOTE: The valve
selection panel is not enabled until a preliminary Cv has been calculated.
Service Data Panel
The Service Data panel is used to describe the variable properties of the service environment,
and contains the following components:
• Cv check box – Selected by default, calculations are solving for Cv
• Flow check box – When selected, calculations are estimating flow. NOTE: Flow calculations
are only an estimate, and may not accurately reflect the maximum flow due to the iterations
required to solve for Cv. It is the user’s responsibility to recalculate solving for Cv to determine
if the estimated flow meets the actual Cv rating of the associated trim.
• Service Parameters table – Used for entering service data, the table lists the required parameters
for the currently selected service type and provides up to three case scenarios for calculating a
flow coefficient. The case scenarios have the default names of Minimum, Normal and
Maximum, but may be changed on a per-item or global basis to suit the user’s preference.
The Service Parameters table contains both system and fluid service conditions. The values
required for entry depend on the type of service a valve is being sized for.
Steam Service
•
•
•
•
Flow Rate – The rate of flow of the fluid through the valve
Inlet Pressure (P1) – The line pressure at the valve inlet
Outlet Pressure (P2) – The line pressure at the valve outlet
Pressure Drop (∆P) – The pressure drop across the valve
©2007 Norriseal
8
NorriSize™
Valve Sizing Program
version 3.0
•
Temperature (T) – The temperature of the fluid flowing through the valve
Liquid Service
•
•
•
•
In addition to the required values of Steam Service, Liquid Service requires the following values:
Vapor Pressure (Pv) – The vapor pressure of the fluid at the specified temperature for the case
Critical Pressure (Pc) – The critical pressure of the fluid
Viscosity (V) – The viscosity of the fluid at the specified temperature for the case
Specific Gravity (Gf) – The specific gravity of the fluid at the specified temperature for the case
Gas Service
•
•
•
•
•
•
In addition to the required values of Steam Service, Gas Service requires the following values:
Compressibility (Z) – The compressibility of the fluid at the specified inlet pressure for the case
Molecular Mass (M) – The molecular mass of the fluid
Specific Gravity (Gf) – The specific gravity of the fluid at the specified temperature for the case
Specific Heats Ratio (k) – The specific heats ratio of the fluid
Critical Pressure (Pc) – The critical pressure of the fluid
Critical Temperature (Pc) – The critical temperature of the fluid
Two-Phase Service
In addition to the required values of Liquid Service, Two-Phase Service requires the following
values:
• Specific Gravity Gas (Gf) – The specific gravity of the gas at the specified temperature for the
case
• Specific Heats Ratio (k) – The specific heats ratio of the gas
Note: Two-phase sizing does not provide flow velocities or noise prediction calculations.
Case Data Entry
Case data entry is a simple process of entering the required parameter values for the specified
service type. Entry can begin in any of the min/norm/max scenario columns. The rows have been
organized so that all non-fluid related service conditions are at the top, which allows the program to
calculate standard fluid properties once all service condition values have been entered. Once a value has
been entered, pressing the <Enter> key will focus entry to the next cell in the current column unless the
active cell is the last row, in which case focus will jump to the beginning of the next column. Cell
navigation can also be performed by pressing any of the arrow keys.
If the fluid properties need to be overridden, it is recommended that all case scenarios’ service
conditions be entered prior to selecting the Fluid Override checkbox. This allows the Service Data
Panel to dynamically calculate the standard fluid properties based on the service conditions entered for
the current scenario. Otherwise, by selecting the Fluid Override before all scenarios have been entered,
the fluid properties become static and will be copied to the next case without taking into account
changes in pressure or temperature. See Fluid Override in Service Selection for more information.
Units Selection
Unit selection is straightforward through the use of drop-down lists next to the parameters that
are not dimensionless. When selecting a unit for Inlet or Outlet pressure, the corresponding parameter is
changed automatically to the selected unit. The Inlet and Outlet pressure units will always use the same
9
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
unit of measure, including the Pressure Drop. Fluid parameters, such as Vapor Pressure and Critical
Pressure, may utilize different units of measure. Flow Rates have the time unit independent of the
quantity unit as a matter of convenience and to minimize the chance of error in performing manual rate
conversions. To change the unit of measure for a parameter, right-click in the far right (east) area of the
cell to display the drop-down list of available units.
Pipe Selection
Specifying upstream/downstream pipe size and schedule in the Pipe Selection panel can be as
quick as two selections. When making selections for upstream pipe, the downstream pipe is
automatically set to the same size/schedule. However, if downstream pipe is different than the upstream
pipe, changes to the downstream size/schedule can be made without affecting the upstream
size/schedule. Pipe selections are available in inches and schedules defined in ANSI B36.10M-2000.
Valve Selection
The Valve Selection panel provides drop-down lists for specifying the valve to be sized. Each
list box is dynamically updated to reflect a change in the valve/trim selection. Pressure classes for
Norriseal valves range from ANSI 150 to ANSI 2500, depending on the valve model. The Valve Size
and Trim Size list boxes display rated Cv values when the mouse is hovered over the list (illustrated
below), allowing the user to select the appropriate valve/trim size based on the preliminary coefficient.
Rated Cv for valves is based on the largest Quick Opening trim size available for each valve size. All
valve and trim selections are in inches.
•
•
•
Acronyms in parentheses of the Trim Style list box denote the following:
UPC – Unbalanced Plug Control trim
BPC – Balanced Plug Control trim
BCC – Balanced Cage Control trim
©2007 Norriseal
10
NorriSize™
Valve Sizing Program
version 3.0
Calculating Valve Coefficient
For new project items, flow coefficient calculation is a two-step process: calculating a
preliminary coefficient and calculating a final coefficient. Pressing the Calculate Button ( ) will
perform calculations for all case scenarios in the Service Data Panel.
Preliminary Coefficient
In order to make valve selection more efficient, a preliminary calculation based on generic flow
equations is performed prior to making pipe and valve selections. With a preliminary flow coefficient,
the user can more easily determine the valve type, size and trim, doing away with the need for trial and
error methodologies. After performing the preliminary calculation, the Valve and Pipe Selection panels
become accessible, allowing the user to complete the specification for final flow coefficient and noise
prediction calculations.
Final Coefficient
The final coefficient calculation is a combination of flow, flow velocity and noise prediction
calculations, and can be determined after the valve and pipe selections have been made. When a final
calculation is performed, any messages generated from the calculations are displayed in a dialog and are
ordered by case scenario. If Cv data is available for the selected trim, a chart which plots the final Cv
along the trim’s Cv curve can also be displayed.
Sizing Results Panel
Preliminary and final Cv calculation results are displayed beneath the Service Data panel in the
Sizing Results panel. The results displayed in the Sizing Results Panel vary depending upon the type of
service selected:
• Calculated Coefficient – The flow coefficient calculated, either preliminary or final
• Flow Noise SPL – The predicted noise generation
• Critical Pressure Drop – The pressure drop limit whereupon choked flow occurs
• Actual Pressure Drop – The actual pressure drop across the valve
• Required FL – The required liquid pressure recovery factor for the valve at the specified service
conditions (liquid only)
• Rated FL – The rated liquid pressure recovery factor for the selected valve model
• Valve Outlet Velocity – The flow velocity at the valve outlet
• Pipe Outlet Velocity – The flow velocity at the pipe outlet
• Percentage Lift or Degrees Open – For plug style trim valves, the percentage of plug travel
required to achieve the specified flow rate. For rotary style valves, the amount of rotation of the
disc/ball to achieve the specified flow rate.
• Percentage Cv – The ratio of the calculated coefficient to the rated coefficient of the valve/trim
selection
• Valve Mach Number – The ratio of the flow velocity in relation to the speed of sound in the fluid
media (gas/vapor only)
11
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
File Menu
New Project… ( )
Displays the New Project Wizard and creates a new valve sizing project in the main Projects
folder. New projects can be created while in either the Project Manager or the Sizing Module.
•
•
•
•
•
Project – The name of the project to create. This is the name that appears in the project tree
panel. This is a required field.
Customer – The customer for which the project is prepared and will appear in the heading of the
printed report. This is a required field.
Agent – The name of the company’s agent assigned to the project. This field is automatically
filled with the current user’s information. It can be changed if, for instance, someone other than
the current user is the main Agent assigned to the project.
Quote Reference – The quote number/reference assigned to this project. This is a required
field.
Entered By – The initials of the user performing the valve sizing, if different than the Agent.
New Project Item… ( )
Displays the Project Item Wizard and creates a new project item in the currently selected project.
A project must be selected for this action item to be enabled. New project items can be created while in
either the Project Manager or the Sizing Module.
•
•
•
•
Tag No. – The tag number of the valve (if required) or name of the project item if no tag number
is used. This is the name that appears in the project tree panel. If this field is left blank, the
default tag name “Item x” is used, where x is the current item count.
Quantity – The quantity of valves required for this item.
Valve – The type of valve to be sized. This allows the Sizing Module to more accurately
calculate a preliminary Cv.
Copy From – Select the project item to use for creating a new project item with identical data
©2007 Norriseal
12
NorriSize™
Valve Sizing Program
version 3.0
Open Project… ( )
Displays the Open Project dialog for selecting one or more projects to add to the Project Tree
panel. To select multiple projects, hold down the <Control> key and right-click on each of the desired
projects to open.
Close Project ( )
Removes the currently selected project from the Project Tree panel. The user will be prompted
to save any changes made to the project prior to being closed.
Save Project ( )
Saves any changes to the currently selected project and/or project item. The user will be notified
that any changes made to the specification of a project item will generate a recalculation prior to being
saved.
Export…
Displays the Export Wizard to export projects and/or project items to an external data file.
Projects are saved in an XML format which can be imported back into the program. The Export Wizard
consists of the following components:
• Directory Path text field – determines the directory location files are exported to
13
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
•
•
•
•
•
File Chooser button (…) – displays a File Chooser dialog for selecting the directory path
Projects/Items button – switches from project selection to item selection, and vice-versa
Select All checkbox – selects all items in the display list
Project list (Item selection only) – project drop-down list for item selection
List Selection panel – lists projects/items to select from and displays related information. To
select multiple projects/items, hold down the <Control> key and right-click on each of the desired list
items.
Export Item
Displays a File Save dialog to export the currently selected project item to an external data file.
Exporting from this menu item differs in that the variables from flow calculations are included, and is
intended for technical support purposes only. NOTE: Files created may not be capable of being
imported back into the program.
Print…
Displays the Print Wizard for printing sizing reports of project items from the projects listed in
the Project Tree panel to the current default Windows printer. The Print Wizard layout is similar to the
Export Wizard, and consists of the following components:
• Print to file checkbox – when selected, writes sizing reports to a PDF file
• Directory Path text field – determines the directory location files are exported to
• File Chooser button (…) – displays a File Chooser dialog for selecting the directory path
• Project list – project drop-down list for item selection
• Select All checkbox – selects all items in the display list
• List Selection panel – lists items to select from and displays related information. To select
multiple items, hold down the <Control> key and right-click on each of the desired items to print.
Print to File
The Print Wizard provides the user with the ability to save reports to a file by selecting the Print
to file checkbox. When selected, the file location can be chosen by either typing the directory path in
the text field or via a directory selection dialog by pressing the ellipsis to the right of the text field. It is
©2007 Norriseal
14
NorriSize™
Valve Sizing Program
version 3.0
highly recommended to use the selection dialog to ensure a valid directory path is chosen. Each project
item selected will have its sizing report saved to a PDF file using the tag number as the filename.
Print Project
Prints all items of the currently selected project to the current default Windows printer.
Print Item ( )
Prints the currently selected project item to the current default Windows printer.
Exit
Closes the Valve Sizing Program. The user will be prompted to save any changes made to the
project prior to program shutdown.
Edit Menu
Options
Displays the Options dialog for customizing various aspects of the Valve Sizing Program and
consists of three tabs:
• General Preferences – customizes the project and sizing modules
• Default Units – customizes the units used for new project items
• User Info – customizes the Agent and Company information for the current user
General Preferences
Project Module
•
Recent Projects – sets the number of projects to load upon program startup
15
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
•
•
•
•
•
Tree Panel Width – sets the width of the Project Tree panel in pixels (NOTE: manually
resizing the tree panel using the divider will not change this value)
Remove Daily Items – determines whether the program deletes all items in the Daily
Sizing project upon program exit
Service Data View – sets the visibility of the Service Data information panel
Pipeline Data View – sets the visibility of the Pipeline Data information panel
Valve Data View – sets the visibility of the Valve Data information panel
Sizing Module
•
•
•
•
Case Name 1 – sets the name of the first case scenario for new project items
Case Name 2 – sets the name of the second case scenario for new project items
Case Name 3 – sets the name of the third case scenario for new project items
Decimal Precision – sets the number of decimal places to display in the Service Data and
Sizing Results panels
Default Units
As of the release of v3.0, all service and fluid units of measure can be customized for new
project items with the exception of viscosity, which will be added in a later release. The default pressure
©2007 Norriseal
16
NorriSize™
Valve Sizing Program
version 3.0
unit applies to both inlet and outlet pressures, as well as pressure drop (which cannot be changed). For
two-phase service, the Liquid Flow Period is used as the default time period.
User Information
In the event that a user’s contact or company information changes, updates to the address book
can be made through the User Information tab. User information can be modified by one of two ways:
editing the existing entry or creating/selecting a new entry. In order for any address book entry to be
saved to the user’s profile as the default Agent/Company, it must be created or selected via the User
Information tab and pressing the OK button of the Options dialog.
Editing an Existing Entry
When editing an existing Agent or Company address book entry, the changes made will
be reflected in all existing projects referencing the entry. This method is useful for updating
phone number or e-mail address changes.
Creating or Selecting a New Entry
In some instances, such as having secondary contact information or company address, it
is beneficial to create a new address book entry. After creating or selecting a new entry, it will
be used as the default Agent/Company for new projects; existing projects will retain the original
Agent/Company entry.
17
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Clear Case
Displays a sub-menu of the case scenarios from which to choose. Selecting a case scenario from
the sub-menu will remove all service data and sizing results for that case.
Clear Service Data
Removes all service data and sizing results for each case scenario, effectively reverting to a new
item state. Valve and pipeline selections are not affected.
Case Names
Allows modifying case scenario names from the default profile names found in the General
Preferences tab of the Options menu item. Alternate case names are specific to the project item for
which they were modified.
Calc Prelim Cv ( )
As a matter of convenience, a preliminary Cv using the standard generic flow equations can be
calculated at any time.
©2007 Norriseal
18
NorriSize™
Valve Sizing Program
version 3.0
Create New Fluid ( )
Displays the Create New Fluid wizard to create a custom fluid that is not available in the
standard fluids included with the program. Custom fluids are restricted to a single state, e.g. property
values are static and should reflect a fluid’s state at the given temperature and pressure. After a custom
fluid is created, it is set as the selected fluid for the current project item. The custom fluid only needs to
be created for the initial case scenario. When added to the Sizing Module, it is set as a permanently
overridden fluid which allows fluid property modifications to the other case scenarios. Custom fluids in
the Fluid list are denoted with an asterisk (*) in front of the fluid name.
Creating a Custom Liquid
•
•
•
•
•
•
•
•
Creating a custom liquid is a straight forward process - all fluid property values are required.
Name – Enter the name of the fluid; do not enter an asterisk before the name, this is done
automatically by the program
State – switches between liquid and gas custom fluids
Temperature and Pressure – select the appropriate unit of measure and enter the values at the
valve inlet. NOTE: Temperature and Pressure inputs are not required, but are included to
provide a complete view of the fluid state while creating the fluid.
Critical Pressure – select the appropriate unit of measure and enter the critical pressure of the
fluid
Molecular Mass – the molecular mass of the fluid
Specific Gravity – the specific gravity of the fluid at the given temperature
Vapor Pressure – select the appropriate unit of measure and enter the vapor pressure of the fluid
at the given temperature
Viscosity – the dynamic viscosity of the fluid at the given temperature. NOTE: As of initial
release, only centipoise is supported for viscosity.
19
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Creating a Custom Gas
Creating a custom gas is a little more complex than its liquid counterpart. In addition to the
property values for liquid (except vapor pressure), gases include the following required properties:
• Critical Temperature – the critical temperature of the fluid
• Specific Heats Ratio – the ratio of specific heats of the fluid. NOTE: This is typically a difficult
value to obtain, therefore a value of 1.4 (SHR of oxygen) can be used when the fluid SHR is
unknown. However, care must be taken to use a valid SHR because it is an integral part of
the flow equations; e.g. if the actual SHR of the fluid is lower than that of oxygen, the valve
may be undersized.
• Compressibility – the compressibility of the fluid at the given pressure. NOTE: A value of 1.0
can be used when the fluid compressibility is unknown. However, care must be taken to
obtain a valid compressibility factor when a valve is operating at high pressures; e.g. if the
actual compressibility is lower than 1.0, the valve may be oversized.
•
•
Additional notes regarding fluid properties for gases:
Viscosity – viscosity for gases can be difficult to obtain, therefore a value of .02cP can be used
when the fluid viscosity is unknown. Gas viscosities are typically very low and have minimal
impact on the flow coefficient, so correctly sizing a valve when the viscosity is unknown can be
accomplished with high confidence.
Molecular Mass vs. Specific Gravity – specific gravity of gases can be assumed to be a direct
relationship to the molecular mass of oxygen. Therefore, if one of these values is unknown, it
can be determined from the following equation:
Mf ÷ Mo = Gf
where
Mf = molecular mass of custom fluid
Mo = molecular mass of oxygen (32.0)
Gf = specific gravity of custom fluid
©2007 Norriseal
20
NorriSize™
Valve Sizing Program
version 3.0
Copying From an Existing Fluid
Often times there are fluids which have similar properties. In such cases, select the Copy …
button to display the Select Fluid dialog which has the following components:
• Custom Fluids – checkbox to display only custom fluids that have been created for other project
items. The list displays a custom fluid for each case scenario, which typically have different
pressure/temperature ranges and the related fluid property values at those ranges.
• All Fluids – displays all fluids in the list panel
• Liquid – displays only the predefined liquids in the list panel
• Gas – displays only the predefined gases in the list panel
NOTE: As of the initial release, the predefined fluids only provide constant fluid property
values (Critical Pressure, Molecular Mass, etc.).
Delete Project
Permanently deletes a project from the database and removes it from the project tree panel.
Delete Project Item
Permanently deletes a project item from the database and removes it from the project tree panel.
View Menu
Specification Views
Displays a sub-menu of the specification views from which to choose. Menu items which are
checked are displayed in the project information panel. Deselecting an item will hide the associated
information panel, and vice-versa. The Specification Views menu is linked to the General Preferences
tab in the Options menu, therefore changes made are persistent and saved to the user’s profile.
Project Items
As a matter of convenience, a sub-menu listing project items in the current project is displayed,
allowing the user to switch to a different item while in another module.
21
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
Cv Curve ( )
Displays the Cv Curve associated with the selected valve trim, and plots the points of intersection
of the calculated Cv for each case scenario.
Calculation Messages ( )
Displays the messages generated from coefficient and noise prediction calculations.
©2007 Norriseal
22
NorriSize™
Valve Sizing Program
version 3.0
Appendix A: Walkthrough
Example 1
This example uses the Daily Sizing project (and assuming no items exist) to size a basic water
application using the predefined fluid properties and does not utilize a tag number or quantity.
Fluid:
Flow Rate:
Inlet Pressure:
Outlet Pressure:
Temperature:
Water
15,000 barrels/day
15 psig
10 psig
120 F
Upstream Pipe:
DownStream Pipe:
Valve Style:
8in Sch 40
8in Sch 40
Control Valve
1. Create a new project item
1.1. Press the Project Manager button to display the Project Module.
1.2. Select the Daily Sizing project in the Project Tree panel
1.3. Display the Project Item Wizard by selecting the FileÆNew Project Item… menu item or
pressing the button in the Project toolbar.
1.3.1. Since there is no tag number and the default valve style is for a Control Valve, press the
OK button.
1.3.2. The new project item is created using the default name Item 1 and added to the Daily
Sizing project.
1.4. Double-click on the Item 1 node in the project tree or press the Sizing Module button to begin
sizing the valve.
2. Service and fluid selection
2.1. The default service for a new item is Liquid and the default fluid is Water.
3. Service parameters data entry
3.1. Flow Rate
3.1.1. Select bbl in the Unit column
3.1.2. Select day in the Rate column
3.1.3. Enter 15000 in the Normal column
3.2. Inlet Pressure
3.2.1. Select psi_g in the Unit column
3.2.2. Enter 15 in the Normal column
3.3. Outlet Pressure
3.3.1. Enter 10 in the Normal column
3.4. Temperature
3.4.1. Select F in the Unit column
3.4.2. Enter 120 in the Normal column
4. Calculate a preliminary Cv
4.1. Press the button to calculate
4.2. A preliminary Cv of 194.627 is displayed in the Sizing Results panel
5. Pipe and valve selection
23
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
5.1. Pipe Selection
5.1.1. Select 8.0 in the Upstream list box (the Downstream size is automatically selected)
5.1.2. Select 40 in the Schedule list box (the Downstream schedule is automatically selected)
5.2. Valve Selection
5.2.1. Select 2700A/2700E Control Valve for the Valve Model
5.2.2. Select 8.0 in the Valve Size list box (NOTE: Hovering the mouse cursor over the list
selections will display the rated Cv of the valve)
5.2.3. Select ANSI 150 in the Pressure Class list box (NOTE: ANSI 150 is rated up to 285psi)
5.2.4. Select Equal Percentage (BCC) in the Trim Style list box
5.2.5. Select 6.0 in the Trim Size list box for a max Cv of 508 (NOTE: Hovering the mouse
cursor over the list selections will display the rated Cv of the trim)
6. Calculate a final Cv
6.1. Press the button to calculate
6.2. The Sizing Messages dialog is displayed, stating there were no messages generated by the flow
and noise calculations. Press OK to close the window.
6.3. A final Cv of 194.773 is displayed in the Sizing Results panel, which is 38% of the valve’s flow
capacity under normal conditions. The predicted noise generation is 56.4601dB, which is
acceptable.
7. Save the results
7.1. Press the button to save the item to the database
8. Print the results
8.1. Press the button to print the sizing report
Example 2
This example uses the Daily Sizing project to size a CO2 application, overriding the predefined
fluid properties and does not utilize a tag number or quantity.
Fluid:
Flow Rate:
Inlet Pressure:
Outlet Pressure:
Temperature:
Compressibility:
Specific Gravity:
Carbon Dioxide
1066 lb/hr min | 63,943lb/hr max
334 psig
84 psig
255 F
0.7055
1.5047
Upstream Pipe:
DownStream Pipe:
Valve Style:
3in Sch 80
3in Sch 80
Control Valve
1. Create a new project item
1.1. Display the Project Item Wizard by selecting the FileÆNew Project Item… menu item or
pressing the button in the Project toolbar. If you have not saved any changes made to the
previous item, you will be asked to confirm saving the changes.
1.1.1. Since there is no tag number and the default valve style is for a Control Valve, press the
OK button.
©2007 Norriseal
24
NorriSize™
Valve Sizing Program
version 3.0
2.
3.
4.
5.
1.1.2. The new project item is created using the default name Item 2 and added to the Daily
Sizing project.
1.2. Double-click on the Item 2 node in the project tree or press the Sizing Module button to begin
sizing the valve.
Service and fluid selection
2.1. Select Gas in the Service list box
2.2. Select Carbon Dioxide in the Fluid list box
Service parameters data entry
3.1. Minimum case
3.1.1. Flow Rate
3.1.1.1. Select lb in the Unit column
3.1.1.2. Select hr in the Rate column
3.1.1.3. Enter 1066 in the Minimum column
3.1.2. Inlet Pressure
3.1.2.1. Select psi_g in the Unit column
3.1.2.2. Enter 334 in the Minimum column
3.1.3. Outlet Pressure
3.1.3.1. Enter 84 in the Minimum column
3.1.4. Temperature
3.1.4.1. Select F in the Unit column
3.1.4.2. Enter 255 in the Minimum column
3.2. Maximum case
3.2.1. Flow Rate
3.2.1.1. Enter 63943 in the Maximum column
3.2.2. Inlet Pressure
3.2.2.1. Enter 334 in the Maximum column
3.2.3. Outlet Pressure
3.2.3.1. Enter 84 in the Maximum column
3.2.4. Temperature
3.2.4.1. Enter 255 in the Maximum column
3.3. Override fluid properties
3.3.1. Select the Override checkbox
3.3.2. Compressibility
3.3.2.1. Enter .7055 in the Minimum and Maximum columns
3.3.3. Specific Gravity
3.3.3.1. Enter 1.5047 in the Minimum and Maximum columns
Calculate a preliminary Cv
4.1. Press the button to calculate
4.2. A preliminary Cv of 1.187/71.2006 for Min/Max is displayed in the Sizing Results panel
Pipe and valve selection
5.1. Pipe Selection
5.1.1. Select 4.0 in the Upstream list box (the Downstream size is automatically selected)
5.1.2. Select XS in the Schedule list box (the Downstream schedule is automatically selected)
5.2. Valve Selection
5.2.1. Select 2700A/2700E Control Valve for the Valve Model
5.2.2. Select 3.0 in the Valve Size list box
5.2.3. Select ANSI 300 in the Pressure Class list box (NOTE: ANSI 300 is rated up to 740psi)
25
©2007 Norriseal
NorriSize™
Valve Sizing Program
version 3.0
5.2.4. Select Equal Percentage (BCC) in the Trim Style list box
5.2.5. Select 2.0 in the Trim Size list box for a max Cv of 77.2 (NOTE: Hovering the mouse
cursor over the list selections will display the rated Cv of the trim)
6. Calculate a final Cv
6.1. Press the button to calculate
6.2. The Sizing Messages dialog is displayed, stating choked flow exists for both Min/Max
conditions, and that flow velocity exceeds .33 sonic under the Max condition. Press OK to close
the window.
6.3. A final Cv of .9958/58.8476 is displayed in the Sizing Results panel, which is 1/76% of the
valve’s flow capacity under Min/Max conditions. The predicted noise generation is
72.5977/106.3498dB, which we will consider unacceptable at the Maximum condition.
7. Eliminate choked flow
7.1. Change the Pressure Drop to 225psi for both Min/Max conditions.
7.2. Press the button to calculate
7.3. The Sizing Messages dialog is displayed; choked flow is no longer applicable to either
conditions. Press OK to close the window.
8. Reduce valve outlet velocity
8.1. Method “A”
8.1.1. Change the Flow Rate to 60,000 for the Max condition
8.2. Method “B”
8.2.1. Change the Valve Size to 4.0
8.3. Press the button to calculate
8.4. The Sizing Messages dialog is displayed; the valve’s outlet velocity is now acceptable. Press
OK to close the window.
9. Reduce the noise level
9.1. Change the Trim Style to DBII (BCC)
9.2. Press the button to calculate
9.3. The Sizing Messages dialog is displayed, stating there were no messages generated by the flow
and noise calculations. Press OK to close the window.
9.4. A final Cv of .9645/57.8625 is displayed in the Sizing Results panel, which is 1/62% of the
valve’s flow capacity under Min/Max conditions. The predicted noise generation is
<50/78.5692dB, which is now acceptable at the Maximum condition. (NOTE: Notice that the
critical pressure drop has changed. The Pressure Drop can be increased to more closely match
the original service condition of 250psi)
10. Save the results
10.1.
Press the button to save the item to the database
11. Print the results
11.1.
Press the button to print the sizing report
©2007 Norriseal
26