BetaLOG TI User Manual Distributed by MicroDAQ.com, Ltd www

Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
BetaLOG TI
User Manual
Revision 1.00
October 22, 2010
Page 1 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
Table of Contents
1. Introduction
3
2. Description
3
3. Probe Operation
3.1 Data Logging Disabled
3.2 Data Logging Enabled
3
3
3
4. BetaLOG TI Microsoft Windows Application
4.1 Installation and Registration
4.2 Menus
4.2.1 File Menu
4.2.2 Probe Menu
4.2.3 Options Menu
4.2.4 Help Menu
4.3 Main Display
4.4 Log Upload Display
4.5 Display Options
4.6 Export Options
5
6
6
6
6
7
7
8
10
11
12
5. Excel Templates
5.1 Single Run Graph for Interval End Data Upload
5.2 Single Run Graph for All Data Upload
14
14
15
6. Warranty
15
Page 2 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
1.
www.MicroDAQ.com
(603) 746-5524
Introduction
The BetaLOG TI application is used to configure data logging parameters
in the BetaProbe TI and TI+ temperature probes, and to retrieve logged
data from the probe for storage and analysis on a personal computer.
2.
Description
The probe can log multiple sets of data, each of which is identified by a
sequential run number. Data logging runs are started and stopped using
items on the probe’s SETUP menu sequence. Logging parameters can
be changed from one data logging run to the next, and data logging runs
may be as short as a single sample or as long as the maximum storage
capacity of the probe.
The probe has a capacity of 10752 data records for storing run
identification data and log sample data. Each new data logging run
requires 1 record for run identification overhead, and one record is
required to log each sample.
The interval time setting determines the frequency of sample calculation
and storage. Six discrete interval times are available, ranging from 1 to 60
seconds. The following four values are calculated and saved at the end of
each interval based on all of the temperature measurements made during
that interval:
• Last value in the interval
• Minimum value over the interval
• Maximum value over the interval
• Average of all values over the interval
The data logging function is disabled by default in all new probes. The
BetaLOG TI application is used to enable and disable the data log function
in a probe.
3.
Probe Operation
3.1
Data Logging Disabled
Until data logging functionality is enabled using the BetaLOG TI
application, the probe operates as described in the user manual received
with the probe.
3.2
Data Logging Enabled
Once data logging functionality is enabled, a new item is inserted at the
start of the SETUP menu tree to direct the user to a completely separate
branch which contains all data logging functions. This new menu item
shows ‘LOG’ in the main display and ‘DATA’ in the secondary display.
Press the SETUP key to proceed to the existing configuration functions, or
press the ENTER key to proceed to the new data logging branch. The
data logging configuration menu sequence (new branch) is as follows:
Page 3 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
1) Start or stop data logging
• Main display: LOG
• Secondary display: FULL if the log memory is full, OFF if not
presently logging data, or ON if presently logging data.
• Press the SETUP key to step to the next menu item.
• If FULL, the ENTER key is ignored.
• If not FULL, press the ENTER key to change to data edit
mode:
- Press the ▼ or ▲ key to toggle between OFF and
START if not presently logging data, or to toggle
between ON and STOP if presently logging data.
- When START is displayed, press the ENTER key
to start data logging and exit data edit mode.
- When STOP is displayed, press the ENTER key to
stop data logging and exit data edit mode.
- When OFF or ON is displayed, press the ENTER
key to exit data edit mode without changing the
data logging operation.
• Press the MAX/MIN key to exit the SETUP menus and return
to the main display.
2) Display number of free log records or percent empty
• Main display: number of free records or percent free
• Secondary display: RECS or PCNT
• Press the ENTER key to toggle between the number of free
log records and percent free.
• Press the SETUP key to step to the next menu item.
• Press the MAX/MIN key to exit the SETUP menus and return
to the main display.
3) Select logging interval
• Main display: interval choice presently selected, one of 1, 2,
5, 10, 30 or 60 seconds.
• Secondary display: SEC
• If presently logging data, the ENTER key is ignored.
• If not presently logging data, press the ENTER key to
change to data edit mode:
- Press the ▼ key to decrease the interval
selection, cycling to 60 after 1.
- Press the ▲ key to increase the interval selection,
cycling to 1 after 60.
- Press the ENTER key to exit data edit mode.
• Press the SETUP key to step to the next menu item.
• Press the MAX/MIN key to exit the SETUP menus and return
to the main display.
4) Send logged data to the RS232 port
• Main display: SEnd
Page 4 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
•
•
•
Secondary display: DATA
If presently logging data, the ENTER key is ignored.
If not presently logging data, press the ENTER key to
change to data edit mode:
- Press the ▼ or ▲ key to toggle the secondary
display between CNFRM and CANCL.
- Press the ENTER key when CANCL is displayed
to exit data edit mode without sending the data.
- Press the ENTER key when CNFRM is displayed
to exit data edit mode and send the data. While
the data is being sent, BUSY is shown in the
secondary display.
• Press the SETUP key to step to the next menu item.
• Press the MAX/MIN key to exit the SETUP menus and return
to the main display.
5) Erase logged data
• Main display: ErASE
• Secondary display: DATA
• If presently logging data, the ENTER key is ignored.
• If not presently logging data, press the ENTER key to
change to data edit mode:
- Press the ▼ or ▲ key to toggle the secondary
display between CNFRM and CANCL.
- Press the ENTER key when CANCL is displayed
to exit data edit mode without erasing the data.
- Press the ENTER key when CNFRM is displayed
to erase the data and exit data edit mode.
• Press the SETUP key or the MAX/MIN key to exit the
SETUP menus and return to the main display.
While not logging data, the probe operates as described in the user
manual received with the probe.
When a log run is started, the text LOG, the text RUN, and the run number
are cycled on the secondary display at a rate of once per second. This
provides visual feedback that data logging is active and the run number for
later reference.
4.
BetaLOG TI Microsoft Windows Application
This application provides the following features:
• set up the data logging configuration in a probe
• upload logged data from the probe, including export of run
data to text, CSV, and Excel format files
• clear logged data from the probe
Page 5 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
The application requires Microsoft Windows 2000 (SP4), XP (SP2), Vista,
or 7. Exporting data to Excel files requires Microsoft Excel version 2002
or later.
4.1
Installation and Registration
Installation, registration, and activation must all be performed by a logon
user account that has Administrator priviledges.
Insert the distribution CD into the drive on your computer. The install
should start automatically. If it does not, navigate to the drive containing
the CD and run the program “setup.exe”. Follow the prompts on the
screen to install the application.
BetaLOG TI must be registered and activated within seven days of
installation. Full operation is available for seven days, but is then
restricted until activation is completed. A registration screen is displayed
at startup until activation is completed. Click Cancel to proceed directly to
the application. Fill in the requested information and click REGISTER to
save it to a text file on disk. Email this file to Martel as an attachment, or
print and fax it, per the contact information on the support screen. When
Martel returns the activation key, enter it at the bottom of the registration
screen and click ACTIVATE to complete the process.
BetaLOG TI must be registered and activated separately on each
computer on which it is installed.
4.2
Menus
The control buttons on the Main Display are intended to be the primary
method used to operate the application. The menu items duplicate the
functions of these buttons for those users who are more comfortable with
menu style operation.
4.2.1 File Menu
The File Menu contains the application exit function:
Exit
Exit the Data Log Utility.
4.2.2 Probe Menu
The Probe Menu contains the functions required to interact with the probe:
Connect
Connect to the probe and retrieve the probe
description and data logging setup. The
communications port to which the probe is connected
must be selected on the Main Display before using
this item. See the Connecting to a Probe description
in the Main Display section 4.3.
Disconnect
Disconnect from the probe. See the Disconnecting
from a Probe description in the Main Display section
4.3.
Page 6 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
Upload Data
Upload all data logging runs from the probe and show
them on the Log Upload Display described in section
4.4. The data may be exported from that display.
See the Uploading Logged Data description in the
Main Display section 4.3.
Clear Data
Erase all data logging runs from the probe. See the
Clearing Logged Data description in the Main Display
section 4.3.
Send Setup
Send the setup data to the probe. See the Sending
Setup Configuration description in the Main Display
section 4.3.
Retrieve Setup
Retrieve the setup data from the probe. See the
Retrieving Setup Configuration description in the Main
Display section 4.3.
4.2.3 Options Menu
The Options Menu contains functions for specifying the default display and
export options. These functions are described in detail in sections 4.5 and
4.6 below.
4.2.4 Help Menu
The Help Menu contains the functions required to obtain help and support
information:
Help
Display online help
Support
Display customer support information.
Registration
Register BetaLOG TI and display registration
information
About
Display application description and version
information.
Page 7 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
4.3
www.MicroDAQ.com
(603) 746-5524
Main Display
The top portion of the display contains controls to connect to a probe,
disconnect from a probe, upload logged data, clear logged data, and exit
the application. Once connected to a probe, it shows the model, serial
number, and firmware version of the probe. The number of data logging
records presently used and free is also displayed if data logging is
enabled in the probe.
The lower portion of the display contains controls to configure data logging
parameters in a probe, send the configuration to a probe, and retrieve the
present configuration from a probe.
Connecting to a Probe
Select the communications port to which the probe is connected
and click the Connect button. The drop down box lists those ports
which are available on the computer and are not presently in use.
The probe description, present capacity, and present setup are
retrieved from the probe and displayed in the appropriate fields.
The button description and function change to Disconnect. A
connection must be established before any other actions may be
performed. To change to another probe, first disconnect from the
present probe and reconnect.
Disconnecting from a Probe
Click the Disconnect button. The button description and function
change to Connect and all displayed data is cleared.
Uploading Logged Data
Click the Upload button and choose the data values to be uploaded
for each sample point. The choice is to upload interval end values
only (faster), or to upload interval end, minimum, maximum, and
average values. The logged data for all runs is uploaded and
Page 8 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
shown on the Log Upload Display described in section 4.4. A
progress display shows percent complete and an estimate of the
time remaining in the upload. Data logging must be set to Enabled,
otherwise this function is not available.
Clearing Logged Data
Click the Clear button. After confirmation of the action, all logged
data is cleared from the probe and all data on the display is
refreshed. Data logging must be set to Enabled, otherwise this
function is not available.
Sending Setup Configuration
After making the desired selections, click the Send button. The
configuration is sent to the probe and all data on the display is
refreshed. Data logging must be set to Enabled to change anything
more than the Data Logging mode.
Retrieving Setup Configuration
Click the Retrieve button. The probe description, present capacity,
and present setup are retrieved from the probe and displayed in the
appropriate fields.
Setup Configuration Fields
Data Logging
Disabled
Enabled
Disable data logging in the probe. All data
logging functions are removed from the
probe's SETUP menu sequence.
Enable data logging in the probe. All data
logging functions are available in the
probe's SETUP menu sequence.
Interval
One of the following sampling intervals:
1, 2, 5, 10, 30, or 60 seconds
Page 9 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
4.4
www.MicroDAQ.com
(603) 746-5524
Log Upload Display
The top portion of the display lists the individual data logging runs found in
the uploaded data. To display a run's data in the lower portion of the
display, highlight it by clicking on it.
Use the Display Mode box to select the subset of run data displayed: All
Data, Selected Data, or Readings Only. When the Display Mode is set to
Selected Data, click the Change Selection button to modify the display
options. This is described further under Display Options in section 4.5.
The probe has no calendar hardware so the uploaded data samples are
initially tagged by elapsed day and time from run start. Also the runs are
described simply by numeric position within the uploaded data. To enter a
more descriptive label and a true calendar base date and time for a run,
highlight the run and click the Set Date/Label button. The base date and
time are added to the elapsed day and time for each sample to provide a
true calendar date and time for each sample.
To export an individual run, highlight the run and click the Save Run
button. The Export Options screen is shown to allow the options to be
customized for exporting this run. Next, a standard Save As screen is
Page 10 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
shown for selecting the file name and the folder where the file is to be
placed. Click the Cancel button of either screen to skip the export. The
Export Options screen is described further under Export Options in section
4.6.
To export all runs, click the Save All button. The Export Options screen is
shown to allow the options to be customized for exporting these runs; the
same options are used for all runs. For each run, a standard Save As
screen is shown for selecting the file name and the folder where the file is
to be placed. Click the Cancel button of the Save As screen for an
individual run to skip the export of that run. Click the Cancel button of the
Export Options screen to skip the export of all runs. The Export Options
screen is described further under Export Options in section 4.6.
Export to an Excel file requires Excel 2002 or later to be installed on your
computer.
The default location for files is the folder “Martel BetaLOG TI” in “My
Documents”.
4.5
Display Options
This screen is used to modify the default selections for the run description
fields shown on the Log Upload Display when the display mode is set to
Selected Data. When data is initially uploaded the selections are set to
these default values. After the initial data display, the selections may be
temporarily changed for the duration of the data display. Place a
checkmark next to each field that is to be shown on the display when the
display mode is set to Selected Data. Logged temperature readings are
always displayed.
Page 11 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
4.6
www.MicroDAQ.com
(603) 746-5524
Export Options
This screen is used to modify the default selections for the file type and
run description fields to be exported from the Log Upload Display. When
data is initially uploaded the selections are set to these default values.
After the initial data display, the selections may be temporarily changed for
each export operation, and remain changed for the duration of the data
display. Logged temperature readings are always exported.
The selections are as follows:
File Type
TXT File
CSV File
A formatted text file that may be printed directly
or opened in a text editor. The run description
fields are placed on separate lines at the
beginning of the file, followed by a line for each
logged data sample.
An Excel Comma Separated Variable file
where each data item on a line is enclosed in
quotation marks and all items are separated by
commas. The run description fields are placed
on separate lines at the beginning of the file,
followed by a line for each logged data sample.
Page 12 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
New Excel File
Excel Template
Multiple runs in
Single File
Separate Files
www.MicroDAQ.com
(603) 746-5524
A new Excel spreadsheet (xls) file. The
locations of the run description fields and
logged data samples within the spreadsheet
are specified in the Excel Cell column below.
This option requires Excel 2002 or later to be
installed on your computer.
An Excel spreadsheet (xls) file based on a
predefined Excel template (xlt) file. The
locations of the run description fields and
logged data samples within the spreadsheet
are specified in the Excel Cell column below.
These locations must be coordinated with the
fixed data in the template. This option requires
Excel 2002 or later to be installed on your
computer.
When the upload contains multiple data
logging runs, export all runs to a single file.
When the upload contains multiple data
logging runs, export each individual run to a
separate file.
Excel Template
When the file type is set to Excel Template, the template to be used
is selected here. Click on the Browse button and navigate to the
desired template file. See section 5 for more information on Excel
templates.
Include Field
Place a checkmark next to each field that is to be exported.
Logged temperature readings are always exported.
Insert Description
An optional field description may be included for each field being
exported. Place a checkmark on each field description that is to be
included.
Excel Cell
Enter the cell location where the data is to be placed. Cell columns
may range from A to YZ. Cell rows may range from 1 to 99999.
The data fields are placed as follows:
Run description fields
If the field description is included, the field description
is placed in the specified cell and the field value is
placed in the next cell to the right. If the field
description is not included, the field value is placed in
the specified cell. The Probe Description field has 3
values (model, serial, and version), with the second
Page 13 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
and third placed in the immediately adjacent cells to
the right of the first.
Readings
Readings are listed one per row starting at the
specified cell row. There are four field values for each
single value sample: the date, the time, the interval
end temperature reading, and the temperature unit.
The second, third, and fourth values are placed in the
immediately adjacent cells to the right of the first.
There are seven field values for each multiple value
sample: the date, the time, the interval end
temperature reading, the minimum temperature, the
maximum temperature, the average temperature, and
the temperature unit. The second, third, etc. values
are placed in the immediately adjacent cells to the
right of the first. If the field description is included, the
field description is placed in the specified cell column
and the field values are placed in the next cell
columns to the right. If the field description is not
included, the field values are placed in the specified
cell columns.
5.
Excel Templates
An Excel template contains predefined text, titles, graphs, and calculations
which are merged with uploaded temperature data to form a more
complete spreadsheet presentation. A template may be reused many
times, thus avoiding unnecessary work reformatting raw data. Templates
are created with Excel in the same manner as normal spreadsheets and
they support all Excel features. They are stored with the special “.xlt”
suffix to differentiate them from normal spreadsheets, and to avoid
overwriting them when saving merged data.
The field options and Excel cell locations specified on the Export options
screen must be coordinated with the predefined data in the template to
ensure a correct merging of the data.
The sample templates provided with BetaLOG TI are described below.
They are provided in a separate folder on the distribution media and must
be manually copied to your hard drive.
5.1
Single Run Graph for Interval End Data Upload
This template provides custom titles and a graph of the merged data for a
single run. It lists and graphs the interval end values for all sample points.
It assumes that a base date is entered for the run. The graph vertical axis
is scaled to the range of the uploaded temperature values and the
horizontal axis is scaled to the number of samples uploaded.
The template file name is:
Page 14 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
BetaLOG-TI-template-single-run-one-value-graph.xlt
The Export options that must be set for this template are as follows:
5.2
Field
Include
Field
Insert
Description
Excel
Cell
Run # or Label
Yes
No
B3
Probe Description
Yes
No
B5
Interval Time
Yes
No
B9
Unit
Yes
No
B7
Readings
Yes
No
B24
Single Run Graph for All Data Upload
This template provides custom titles and a graph of the merged data for a
single run. It lists the interval end, minimum, maximum, and average
values for all sample points. It graphs the interval end values for all
sample points. It assumes that a base date is entered for the run. The
graph vertical axis is scaled to the range of the uploaded temperature
values and the horizontal axis is scaled to the number of samples
uploaded.
The template file name is:
BetaLOG-TI-template-single-run-four-values-graph.xlt
The Export options that must be set for this template are as follows:
6.
Field
Include
Field
Insert
Description
Excel
Cell
Run # or Label
Yes
No
B3
Probe Description
Yes
No
B5
Interval Time
Yes
No
B9
Unit
Yes
No
B7
Readings
Yes
No
B24
Warranty
The media on which you receive this software is warranted not to fail, due
to defects in materials or workmanship, for a period of 90 days from date
of shipment. Martel Electronics Corporation will, at its option, repair or
replace the media upon notice of such failure. Martel Electronics
Corporation does not warrant that the operation of the software shall be
Page 15 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010
Distributed by MicroDAQ.com, Ltd
www.MicroDAQ.com
(603) 746-5524
uninterrupted or error free. In no event shall Martel Electronics
Corporation be liable for any damages arising out of, or related to, the use
of the software.
Martel Electronics Corporation has carefully reviewed all documentation
related to the software for technical accuracy. In the event that technical
or typographical errors exist, Martel Electronics Corporation reserves the
right to make changes to subsequent revisions of the documentation
without prior notice to holders of the current revision. In no event shall
Martel Electronics Corporation be liable for any damages arising out of, or
related to, the use of the documentation, or the information contained in it.
The foregoing warranties are in lieu of all other warranties, express or
implied, including but not limited to the implied warranties of
merchantability and fitness for a particular purpose.
TRADEMARKS
Trademarks or trade names are subject to state and federal laws
concerning their unauthorized use or other infringements. The fact that
the product marks or names in this software, and related documentation,
do not bear a trademark symbol does not mean that the product mark or
name is not registered as a trademark or trade name. Any queries
concerning ownership or existence of any trademarks or trade names
mentioned in this software, and related documentation, should be
independently confirmed with the manufacturer or distributor of the
product.
Martel Electronics Corporation
3 Corporate Park Drive, Unit 1
Derry, NH 03038
USA
Toll Free: (800) 821-0023
Phone: (603) 434-1433
Fax: (603) 434-1653
sales@martelcorp.com
Page 16 of 16
BetaLOG TI
User Manual
Revision 1.00, October 22, 2010