ToolMap User Manual

Research Center on Alpine Environment
ToolMap User Manual
Author:
L. Schreiber
L. Amez-Droz
c
CREALP
Draft date June 27, 2011
Contents
1 Installation
1.1 Windows . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.1.1 Silent Installation . . . . . . . . . . . . . . . . . . . . . .
1.2 Mac OSX . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2 User Interface Overview
2.1 Menu bar . . . . . . . . . .
2.2 Toolbar . . . . . . . . . . .
2.2.1 Selection tool . . . .
2.2.2 Navigation tools . .
2.2.3 Edition tool . . . . .
2.2.4 Attribution tools . .
2.2.5 Information tool . .
2.2.6 Scale . . . . . . . . .
2.3 Table of Content . . . . . .
2.4 Status bar . . . . . . . . . .
2.5 keyboard shortcuts . . . . .
2.5.1 Project management
2.5.2 Navigation tools . .
2.5.3 Editor tools . . . . .
2.5.4 Attribute tool . . . .
2.5.5 Others . . . . . . . .
3
3
4
5
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
6
6
7
7
7
7
8
8
8
8
8
8
9
9
9
9
10
3 Project Management
3.1 New project . . . . . . . . . . . . .
3.1.1 Generalities . . . . . . . . .
3.1.2 Spatial model . . . . . . . .
3.2 Create from template . . . . . . .
3.3 Open a project . . . . . . . . . . .
3.4 Edit a Project . . . . . . . . . . . .
3.4.1 Edit the project properties
3.4.2 Edit objects . . . . . . . . .
3.4.3 Edit attributes . . . . . . .
3.4.4 Settings . . . . . . . . . . .
3.5 Save and restore a project . . . . .
3.5.1 Backup . . . . . . . . . . .
3.5.2 Template . . . . . . . . . .
3.6 Export a project . . . . . . . . . .
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
11
11
12
12
16
17
17
17
17
18
19
20
20
20
21
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
1
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
3.7
Close the Project . . . . . . . . . . . . . . . . . . . . . . . . . . .
21
4 Spatial Data management
4.1 Add . . . . . . . . . . . .
4.1.1 Rotation . . . . . .
4.2 Import . . . . . . . . . . .
4.2.1 Step1 . . . . . . .
4.2.2 Step2 . . . . . . .
4.2.3 Step3 . . . . . . .
4.3 Table of contents options
4.3.1 contextual menu .
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
22
22
22
22
23
23
24
24
25
5 Visualization
5.1 Menu view Options
5.2 Symbology . . . .
5.2.1 Points . . .
5.2.2 Lines . . . .
5.2.3 Polygons .
5.2.4 Images . . .
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
26
26
26
26
27
28
28
6 Features Selection
6.1 Selection menu . . .
6.2 Information window
6.2.1 Feature tab .
6.2.2 Layer tab . .
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
29
29
29
29
30
7 Edition
31
7.1 Construction layers definition . . . . . . . . . . . . . . . . . . . . 31
7.1.1 Edition menu . . . . . . . . . . . . . . . . . . . . . . . . . 31
7.2 snapping . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
8 Attribution
8.1 Basic attribution . . . . . . .
8.2 Advanced attribution . . . . .
8.3 Advanced attribution batch .
8.4 Attribute orientation to point
8.5 Shortcuts . . . . . . . . . . .
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
35
35
36
37
38
39
9 Validation
40
9.1 Semantic Validation . . . . . . . . . . . . . . . . . . . . . . . . . 40
9.2 Dangling nodes . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
10 FAQ
10.1 Rotation Warning . . . . . . . . .
10.1.1 Introduction . . . . . . . .
10.1.2 Using ArcGIS . . . . . . . .
10.1.3 Note about word files (tfw)
2
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
43
43
43
43
44
Chapter 1
Installation
1.1
Windows
The installation of ToolMap is rather simple. First you have to download the
windows installer. It can be found on our web site http://www.crealp.ch/fr/toolmaptelechargement.html. The setup wizard will then guide you through the installation process.
Choose whenever you want to install ToolMap only for yourself or for all
users using the computer (administrator privilege required).
Once you have activated the next step the wizard will generate a default
destination folder for the installation; you can of course change the destination
folder.
3
If you click on the [install] button the installation will begin, otherwise you
can go back to change settings or simply cancel the operation. If you decied to
achieve the installation a progress window will pops up, the installation process
should be pretty fast.
Once the installation has been completed you’ll have the choice to create a
desktop shortcut before closing the setup wizard.
ToolMap could now be launched using either the desktop icon or the menu
entry located in Programs → ToolMap2 → ToolMap
1.1.1
Silent Installation
ToolMap may also be installed without requiring the user to select options or
click next. This mode, also called unattended installation, may be particularly
useful for system administrator trying to deploy ToolMap on multiple computer
without the hassle to go through all the wizard pages.
Installing The following command line may be used for the silent installation
of ToolMap:
InstallToolMap d967.exe /S /INSTDIR=”C:\Program Files\ToolMap2” /AllUsers
• /S: inform the installer to be silent
4
• /INSTDIR: Path for installing ToolMap
• /AllUsers (or /CurrentUser): Install ToolMap for all user (administrator privilege required) or for the current one.
Uninstalling The following command line may be used for uninstalling ToolMap
silently:
“C:\Program File\ToolMap2\uninst.exe” /S
1.2
Mac OSX
Download the ToolMap’s .DMG file from http://www.crealp.ch/fr/toolmaptelechargement.html, then double-click on it. A new Finder window similar
to the one illustrated bellow should appear.
Drag the ToolMap icon into the “Applications” folder to install ToolMap.
Once ToolMap is installed, you can safely eject it’s disk image. Click on the
ToolMap disk icon on the Desktop and then press CMD-E.
Delete the .DMG file by dragging it to the trash.
5
Chapter 2
User Interface Overview
The ToolMap user interface integrates the following elements:
1. Menu bar
2. Toolbar
3. Table of contents
4. Visualization and editing window
5. Status bar
2.1
Menu bar
In the menu bar ten menus are available, each of them will lead you to different
options:
1. Project: This menu contains all options related to the project management
2. Data: This menu allows the user to add or import support data into the
project
3. View : The view menu contains all options for navigating and zooming
into the displayed data
4. Edition: All tools related to the editing process are located into this menu
5. Attribution: This menu contains the tools used when attributing the data.
6
6. Tools: This menu contains a validation tool for checking our data against
dangling nodes
7. Selection: This menu contains tools for managing the selection
8. Queries: queries management
9. Window : windows management
10. Help: The Help Menu provides various help functions as well as options
for reporting a bug
2.2
Toolbar
The toolbar is accessible on top of the application window, right under the menu
bar. It allows to quickly access to the different main tools available in ToolMap.
Most of the toolbar buttons are grayed out while no project is open.
2.2.1
•
2.2.2
Selection tool
Select one or several geometrical objects
Navigation tools
•
Zoom to the maximum extent of all visible layers
•
Zoom in or out into the visualization window
•
Pan the view in any direction
•
Go back to the previous zoom extent
2.2.3
Edition tool
•
Draw a new object
•
Modify an existing object
•
Modify shared node
7
2.2.4
Attribution tools
•
Display the Object kind panel
•
Display the Object attribute window
2.2.5
•
Display the identification window
2.2.6
•
2.3
Information tool
Scale
Drop-down menu of available scales. User defined
scale could be set using the Project → Edit → Settings menu
Table of Content
The table of contents allows listing the loaded layers in the project. It looks like
the following:
1. Construction layers, they are automatically generated at the creation of
the project and can be edited. They are displayed using a bold font.
2. Support Themes, they cannot be edited.
2.4
Status bar
The status bar at the bottom of the application window provides additional
information like geographical coordinates or the number of features selected.
2.5
keyboard shortcuts
Keyboard Shortcuts have been set to the most used functions to make the use
of Toolmap easier/quicker.
Under Mac OSX, Ctrl is replaced by the standard CMD
(Cmd) button.
8
2.5.1
Project management
• Ctrl+N: Create a new empty project
• Ctrl+Alt+N: Create a new project from an existing one
• Ctrl+O: Link data
• Ctrl+W: Unlink data
2.5.2
Navigation tools
• Z: Zoom tool
• H: Pan tool
• <: Previous zoom
• Ctrl+0: Zoom to the full extent
2.5.3
Editor tools
• D: Draw a feature
• M: Modify a feature
• Ctrl+T: Move a shared Node
• DEL: Delete the selected objects
• ESC: Cancel an edition or modification
• Ctrl+Z: Remove the last vertex
• Ctrl+X: Activate the line cutter tool
• Ctrl+V: Display the vertex positions window
• Ctrl+F: Merge the selected lines
• Ctrl+I: Create intersections
• Ctrl+S: Display the snapping panel
• ENTER OR TAB: Finish a segment or apply the modifications
2.5.4
Attribute tool
• Ctrl+A: Display the Object attribute window
• Ctrl+Alt+A: Display the Object attribute window (batch)
9
2.5.5
Others
• V: Selection tool
• Ctrl+Alt+S: Clear Selection
• Ctrl+L: Display the log window
• Ctrl+Alt+R: Run the selected query
• Ctrl+Alt+I: Display the information Window
• Ctrl+Y: Set Orientation tool
10
Chapter 3
Project Management
The whole management of the project is made with the menu Project, which
includes the following options:
• New Project: create a new project
• Open. . . : open an existing project
• Recent: open a recently used project
• Backup: create a backup of the project
• Manage backup: open the backup management window
• Save as Template: save your project as a template
• Export: export the project
• Edit: edit the project
• Exit: quit ToolMap
3.1
New project
To create a new project, select Project → New Project → Empty. . . . The dialog
illustrated bellow appear.
1. Project Path
2. Project name
3. Units (meters, Kilometers, Lat/Long). Actually this option isn’t enabled
and projects are allways using meters as their units
11
4. Projection system (no projection, Swiss projection). Actually this option
isn’t enabled and only “no projection” is supported.
5. Create a new empty project and activate the next step
6. Cancel the creation of the project
ToolMap will not run correctly if the project isn’t stored on a local disk
3.1.1
Generalities
The Project Properties tab of the Project Definition window allows to complete
some generic project informations.
1. Define the author of the project
2. Comments about the project
3. Saves the properties modifications of the project (this button is enabled
only when at least one layer is created)
4. Cancel the properties modifications of the project
3.1.2
Spatial model
The Spatial Model tab of the Project Definition window lists the layers. Each
layer contains objects and may have attributes.
1. List of layers defining the spatial model, several operations can be realized
in this list:
• Editing layer’s characteristics by double-clicking on a layer
• Sorting layers by clicking on the list header
• Reorganizing layers order with a contextual menu
2. Layers management controls
12
+ : add a layer
- : delete one or several selected layer(s), the supression can also be
made with the DELETE or BACKSPACE keys.
3. Number of layers
4. Number of selected layers
5. Save the project modifications (this button activate only when at least
one layer is created)
6. Close the window without saving the modifications.
Layers Definition The Thematic layer definition window appears when adding
a new layer:
1. Layers name. This name is used as the output file name when exporting
the layer.
2. Spatial layer type (line, point, polygon)
3. Name of the polygon contour. This field is only displayed for polygon
layers
Objects definition The objects belonging to a layer are defined in the Object
kind tab of the Thematic layer Definition window
1. List of defined objects. Following operations can be realized in the list:
13
• Sorting objects by clicking on the list header
• Editing the objects characteristics by double-clicking on an object
• Reorganizing objects order with a contextual menu
2. Objects management controls
+ : Add an object
(a) Code (numerical value) duplicates are allowed but not recommended. This code will be exported as OBJ CD field when the
layer is exported
(b) Description: a textual description of the object. This value will
be exported as OBJ DESC field when the layer is exported
- : Delete one or several selected objects. The suppression can also be
made with the DELETE or BACKSPACE keys.
Import : import list of objects from files of following format:
– *.CSV Format :<Code>;<Description>;<Theme>;<Frequency>
– *.TXT Format :<Code>[TAB]<Description>[TAB]<Theme>[TAB]<Frequency>
3. Save or cancel the object modifications
Attributes definition The attributes management is made from the Attributes tab of the Thematic layer definition window.
1. List of defined attributes Following operations can be realized in the list:
• Sort attributes in alphabetical order by clicking on the Name or Type
header
• Edit an attribute characteristic by double-clicking on it
• Reorganize the list of attributes with the contextual menu by rightclicking
2. Attributes management controls
+ : Add an attribute
- : Delete one or several pre selected attributes. The suppression can
also be made with the DELETE or BACKSPACE keys.
14
3. Save or cancel the attributes modifications. An attribute is defined by:
• A name: the name cannot contain spaces or reserved words (annexe)
• A type of data:
–
–
–
–
–
Text
Integer
Float
Date
Enumeration
Attribute creation
1. Attribute name
2. Attribute type
3. Attribute options: each type has different options, in this case the enumeration type. Following operations can be realized in the list:
• Sort the values of the list by alphabetical order by clicking on the
Code or Description header
• Edit values characteristics of the list by double-clicking on it
• Reorganize the list of values with the contextual menu by rightclicking
4. Enumeration management controls
+ : add a new value
- : delete one or several pre selected values. The suppression can also
be made with the DELETE or BACKSPACE keys.
Import : import lists of values, two types of format can be imported:
– *.CSV Format: <CODE>;<Description>
– *.TXT Format: <CODE>[TAB]<Description>
Export : export the list of values in TXT files
5. Save or cancel the list of values modifications.
15
Orientation of a point type object It’s possible to orientate an object
of a layer. However, several constraints have to be considered:
• The spatial type of the layer has to be a Point type
• The data attribute type has to be a Float or an Integer type
• Only one object per Layer can be oriented.
Activation of the orientation
In the Object Attribute tab of the Thematic layer definition window, you have
to select the attribute by clicking on it, and then activate the case Orientation
Field at the bottom of the window(1)(see also attribute orientation to point for
further informations).
3.2
Create from template
The option Project → New Project → From template. . . allows you to create
a new project with the same layers/objects/attribute as an existing one. This
option will create a new project from an existing template. The creation is
made through the two following steps:
1. existing template path
2. Informations on the template
16
1. Directory for the new project
2. Name of the new Project
3. Creation controls:
• Back: Return to the previous window (choose another template)
• Finish: Create the new project with the current settings
• Cancel: Cancel the creation of the new project
3.3
Open a project
There are two possibilities to open an existing project:
• With the option Project → Open. . . : open a project saved on your computer
• With the option Project → Recent: open a project which had already
been opened recently
3.4
Edit a Project
The Edit option from the menu Project allows editing the characteristics and
components (layers, objects, attributes, settings) of the current project.
3.4.1
Edit the project properties
The layers and attributes of the project can be modified with the Project Definition. . . function of the Edit submenu.
The first tab Project Properties of the window allows modifying the properties of the project like the name of author and the eventual comments. (See
chap. Generalities)
The second Tab Spatial Model allows modifying the layers (see chap. Spatial
model) and the attributes (see chap. Attributes definition).
3.4.2
Edit objects
The objects can be modified with the menu Project→Edit→Objects kind. . .
They are distributed in the three spatial kinds: point, line and polygon.
17
1. List of objects defined by spatial type. Following operations can be realized in the list:
• Sort objects by alphabetical order by clicking on the Code, Description, Layer or Frequency header.
• Edit the objects characteristics by double-clicking on it.
• Reorganize the list of objects with the contextual menu by rightclicking.
2. Objects kind management controls
+ : add an object
- : remove the selected object
import : import an object
export : export the selected object
3. Save or cancel the objects modifications
4. Number of objects in the selected spatial type
5. Number of selected objects
3.4.3
Edit attributes
The attributes can be modified with the option Project→Edit→Object Attribute. . .
1. List of available layers, you can modify them by double-clicking on it
2. Objects management controls
+ :add a new layer
18
- : delete the selected layer
Update : update the project saving the modifications [Cancel]: Cancel the modifications
3. Number of available Layers
3.4.4
Settings
The settings edition is activated with the option Project → Edit → Settings. . .
Project Settings The project settings tab of the project settings window
allows to manage the export and backup properties
1. Export data type (Shapefile, Graphics (EPS))
2. Export file path
3. Backup file directory
Scale
The scale tab of the project settings window allows managing the scales
1. List of defined scales. Following operations can be realized in the list:
• Edit a scale by double-clicking on it
• reorganise the list of scales with the contextual menu
2. Scales management
+ : Add a new scale
- : Delete one or several preselected scales. The suppression can also
be made with the [Delete] or [Backspace] keys
• Management options of the scales list. The list can be ordred with
the options of the order drop-down menu
– Sort ascending
– Sort descending
– User defined: Ordred by the user
3. Save or cancel the settings modifications
19
3.5
3.5.1
Save and restore a project
Backup
When working on ToolMap the changes are automatically and constantly saved.
Because of that it is safe to create frequent backups of the project. The Backup
function from the menu Project allows you to make backups of your current
project.
At the creation of a backup, you can write a comment about your save.
The comment will appear in the Manage Backup window.
The Manage Backup window is accessible with the option Manage backup
from the menu Project. This window lists all the backups stored in your backup
file. The name of the backups is automatically generated following this model:
Projectname-YYYY-MM-DD-HHMMSS
1. List of the backups with their characteristics and comment. The list can
be ordred by each of the characteristics
2. Backups management controls
• Delete: Delete the selected backup(s)
• Restore: Restore the selected backup. When clicking on this option,
a window asks you the confirmation of the restoration process.
• Close: Close the window and return to your current project
1. The Backup path (beforhand defined in the Settings)
3.5.2
Template
You can create templates of your project with the option Save as template. . .
from the menu Project. The creation of a template is made as such:
20
1. Path where the template will be stored
2. Name of the template and the format
3. Save the template or cancel the operation
After saving your template you can enter a comment that will appear if you
use the create from template option.
1. Comment on the template
3.6
Export a project
The exportation allows generating layers which were defined at the spatial model
level in order to be used in others programs. The export path and format have
to be beforehand defined (see chap. Settings)
The layers exportation can be made in two different ways:
1. Export by layer (Project→Export→Export layer. . . ); this option allows
the user to select the layers to export.
2. Export the whole project (Project→Export→Export project); this second
option allows exporting all the layers defined at the spatial model level.
3.7
Close the Project
To quit the project, you just have to click on the upper-right icon or select the
option Project → Exit.
21
Chapter 4
Spatial Data management
4.1
Add
The Link Data. . . option from the menu Data allows loading some support
themes for the vectorization of the construction layers. Those support themes
can be vector data (*.shp) or raster data (*.tif, *.JPG1 and Esri’s binary GRID).
In the opposite of the construction layers, the support themes are not stocked
in the project but only referenced.
4.1.1
Rotation
Some of your files may have rotation information, which is not yet supported
by ToolMap. In that case you will see the following message:
1. rotation information
2. display option
This message will pop up every time you make an action regarding the layer
(including trivial actions like zoom or pan), so be sure to convert your images
into non-rotated rasters. If the rotation is insignificant, you may prefer to simply
ignore the message by checking the option Hide warnings for this layer. This
option prevent the appearance of the message for the current session, but it will
pop again the next time you launch your project.
4.2
Import
The Import data. . . option from the menu Data allows you to import some
existing informations into your construction layers. You can only import lines
or points geometries. The process is made in 3 different steps.
1 Joint
Photographics Experts Group
22
4.2.1
Step1
1. the Import data. . . option allows two types of data, choose the one you
want to import
2. Go to the next step of the import or cancel the operation
4.2.2
Step2
If you choose to add a shapefile the following step comes ahead
1. Directory path of the shapefile
2. data informations of the shapefile
3. allow to go back to step 1 or to continue to step 3
If you choose to add a CSV file the following step comes ahead
1. Directory path of the CSV file
2. Informations on the CSV file
3. allow to go back or to continue to step 2.2
23
Step2.2 The CSV files are composed of columns of data separated with commas, you will have to choose wich column you want to assign to the X and Y
coordinates
1. List of the columns wich can be assigned as X or Y coordinates
2. allows to go back or to continue to step 3
4.2.3
Step3
1. List of layers within the datas will be imported (with the shapefile import
the choice is restricted to the geometrical type of the datas)
2. import the data or cancel the operation
4.3
Table of contents options
1. : Activate the display of the layer
: Deactivate the display of the layer
1. Edition mode activated: the layer is underlined
24
4.3.1
contextual menu
The contextual menus are opened by right-clicking on a layer of the table of
contents. They vary according to the selected layer.
• Name of the layer
• Edit this layer(construction layers only) Remove layer(support themes
only)
• Move the selected layer in the table of contents
• Display management of the vertex (line and polygon layers type only)
• Symbology management. This option can also be activated by doubleclicking on the layer. (see chap. Symbology)
25
Chapter 5
Visualization
5.1
Menu view Options
• Previous zoom (<): go back to the previous displayed scale, available only
if you have once changed the scale
• Zoom by rectangle: This tool uses a click-release action, click on the left
button of the mouse and drag it, it makes a rectangular ghost. The zoom
factor is inversely proportional to the size of the rectangle. The type of
zoom is determined by the direction of the drag:
– Left to right: zoom in
– Right to left: zoom out
• Pan : Move the map with a drag and drop action
• Zoom to full extend: Adjust the scale to display all the activated layers
• zoom to layer: Adjust the scale to display the whole selected layer
5.2
Symbology
The symbology windows allow you to manage the style of each layer. You have
several options available depending of the layer style. They are accessible by
double clicking on the layer name in the table of content or with the option
Symbology. . . of the contextual menu.
5.2.1
Points
26
1. Points style management: you can change the color and the radius of the
points
2. Transparency management
3. Apply or cancel the modifications
The points have an additional option found on the other tab of the window
(multiple). Under this tab you are able to attribute two different symbology to
your lines. The differenciation of the points is made through the queries.
1. Query selected for the differenciation
2. symbology management of the two classes
3. transparency management
The symbology is directly connected to the attribution of the point, changing
its attributes may instantly change its symbology. This option can be very
helpfull to highlight specific classes.
5.2.2
Lines
1. Lines style management, you can change the color the width and the
symbol of the lines. There are four choices of shape
2. Transparency management
3. Apply or cancel the modifications
The lines have an additional option found on the other tab of the window
(multiple). Under this tab you are able to attribute two different symbology to
your lines. The differenciation of the lines is made through the queries.
27
1. Query selected for the differenciation
2. symbology management of the two classes in this case the selected features
are all the lines with the “Bedrock PLG” attribution
3. transparency management
The symbology is directly connected to the attribution of the line, changing
its attributes may instantly change its symbology. This option can be very
helpfull to highlight specific structures.
5.2.3
Polygons
1. Polygons style management: you can change the border width and color
as the fill color and style. There are few Styles available
2. Transparency management
3. Apply or cancel the modifications
5.2.4
Images
1. Transparency management
2. Apply or cancel the modifications
28
Chapter 6
Features Selection
6.1
Selection menu
The menu Selection regroups the following options:
• Select (V)
• Select by Feature ID. . .
• Clear Selection (Ctrl+Alt+S)
• Invert Selection
To select features you first have to activate the selection tool with:
• the menu Selection
• with the icone
• with the V shortcut
you can either make a simple or multiple selection.
• Single selection: just click on the object you want to select or select the
object with its ID using the option select by object ID. . .
• Multiple selection: maintain the [SHIFT] key while clicking on the objects
or create a rectangular gohst with your cursor, all the objects within the
rectangle will be selected
6.2
6.2.1
Information window
Feature tab
The information window is accessible with the menu window → information
window. When selecting one or several features, it allows you to display the
attributes of each selected feature.
29
1. Selected feature ID
2. Features type and attributes
By right-clicking on a feature ID you can access to a contextual menu with
the following operations.
• Move to: center the screen on the selected feature
• Zoom to: adjust the scale to display the selected feature on the whole
screen. (this option does not work for the point type layers)
• Remove from selection: remove a feature from your selection
• Select this feature only: unselect all the other features in your selection
• Copy data to clipboard: copy the informations of the selected feature
6.2.2
Layer tab
The Layer tab of the Information window displays all the informations on the
layer in edition (Layer of the selected features).
30
Chapter 7
Edition
7.1
Construction layers definition
The activation of the editing mode is made out of two steps:
• Select the layer to edit in the table of contents
• Activate the Edit Layer option in the pull-down menu
This operation activate the edition menu Remark: only one layer at once
can be edited.
7.1.1
Edition menu
The edition menu regroups the following options:
Draw feature
The draw tool allows creating new features
Point type layers
• Activate the tool, the edition cursor displays
• Vectorize the object with the mouse
Line type layers
• Activate the tool, the edition cursor displays
• Vectorize the object with the mouse, each left-click creates a vertex
• Cancel the last vertex of the segment in edition; Remove last vertex (Ctrl+Z)
option of the Edition menu
• Finish the construction of the object with the ENTER or TAB key
• Cancel the segment in creation with the ESC key
31
Modify feature
The modify option allows modifying features.
Point type layers
• Select a point
• Activate the tool ; the modification cursor displays
• Modify the feature position with the cursor
Line type layers
• Select a line
• Activate the tool ; the modification cursor displays
• Modify the vertex position with the cursor by dragging it
• Cancel the modification of the current segment with the ESC key
• Apply the modifications with the ENTER or TAB keys
• Insert or delete a vertex with the contextual menu
• Insert vertex (active when the cursor point on a segment of the line)
• Delete selected vertex (active when the cursor point on a vertex)
• Apply the modifications
• Cancel the modifications
Move shared node The Move shared Node allows to move a vertex which is
assigned to more than one line. The point is to move a vertex by keeping the
boundaries of every lines related to it. This tool is activated using the menu
Edition→Move shared node(Ctrl+T) or using the corresponding button in the
toolbar.
Edit Vertex Allows modifying the geographical coordinates of the vertexes.
• Select a feature
• activate the tool ; The following window pops up
32
1. Geographical coordinates of the vertexes defining the geometry of the
feature
2. The coordinates can be directly edited in the table.
+ : add a new Vertex, the insertion is made after the current selection.
The X,Y coordinates have to be edited. The insertion of a vertex
without coordinates provoke an error message at the update of the
geometry ([Update]).
- : suppression of the selected vertex.
Display Vertex : Visualization of the selected vertex.
3. Update or cancel the current modifications
4. Selected feature ID
5. Number of vertexes of the selected feature
Delete selected feature allows deleting the selected features
• Select the feature(s)
• Use the option Delete selected feature of the Edit menu or use the DELETE
key
In the case of a multiple selection, a window appears asking a confirmation
of the suppression.
Cut line The cut lines option allows cutting lines. The cut can only be done
on a vertex.
• Select a line
• Activate the tool with the menu or with the shortcut (Ctrl+X) ; the tool
cursor displays
• click on the vertex where the division must be done
The two lines will then have the attributes of the original line.
Merge Line Allows merging the selected lines. The selected lines have to be
adjacent, the lines must have a begin/end vertex in common.
• Select lines
• Activate the tool : several cases are possible:
1. Same attributes ⇒no consequencess
2. Different attributes ⇒ the user has to define the attributes to keep
3. 1 non attributed object ⇒ the user has to define the attributes to
keep
4. Same polarity ⇒ no consequences
5. Different polarities ⇒ the polarity becomes left to right
33
Create intersection Allows creating intersections between lines which cross
themselves. All the segments created will keep their previous attributes
• Select a line which cross another one
• Activate the tool
The tool won’t cut the lines if they cross themselves on a vertex
Flip fline The Flip line option allows to reverse the polarity of the selected
line. To check the polarity of the line you have to open the vertex editor(see
Edit vertex and check the coordinates of the first vertex.
7.2
snapping
During the vectorisation of a point or line feature, the snapping function allows
to hang on the nodes of an existing feature. The snapping can be done on the
features of the active layer (i.e. current edition) and/or on features belonging
to other layers (construction layers and vectorial support themes)
The snapping is defined by the following elements:
1. The capture tolerance of nodes: in edition, the tolerance zone is figured
out with a circle on the screen
2. The involved classes
3. The constructions layers implicated. Vertexes and/or nodes from start
and arrival. The activation or the deactivation is done by double-clicking
on the corresponding element.
4. Snapping management controls
+ : add a snapping theme
- : delete a snapping theme. The suppression can also be made with the
DELETE or BACKSPACE keys.
Clear Snapping : reinitialization
The Space key temporarily deactivates the snapping
34
Chapter 8
Attribution
The attribution function allows assigning descriptive properties to the selected
feature or group of features. The descriptive properties of an object are defined
by the following elements:
• The object kind
• The attributes bounded to the layer of the object
The access to the attribution functions is made with the menu Attribution
• Object kind
• Object Attribute (single feature). . . (Ctrl+A)
• Object attribute (multiple features). . . (Ctrl+Alt+A)
• Shortcut. . .
The attribution procedure is made according to two complementary modes:
• Basic attribution: allows to assign objects to features.
• Advanced attribution: allows to appoint the attributes of the related layer
to the selected feature.
8.1
Basic attribution
This mode of attribution is active with the Object kind. . . option of the menu
Attribution. Once activated, the attribution is only effective for the construction
layer in edition.
The possible values of attribution are determined by:
• The current construction layer
• The available object kind of the current layer
35
The attribution of objects to selected feature(s) is made with the management window in the attribution mode.
1. The current construction layer in edition
2. The list of objects related to the layer defined in (1). This list can be
reordained using a contextual menu. The objects are distributed in two
categories:
• Frequent objects
• Less frequent objects. The assignation of the objects to one or the
other category is made at the level of the objects definition (cf. chap.
Objects edition). The list is based on the marked spot principle and
allows multiple choices.
3. The [Attribute] button allows validating the attribution of the selected
features. The attribution procedure in basic mode is schematized by the
following picture(basic attribution) The [Info] button allows displaying the
attribute value(s) of the selected features(enable only for a single selection)
4. The
Button allows selecting the following functions:
• Enable full attribution: automatically open the advanced attribution
after basic attribution.
• Empty list after attribution: clear the list after the attribution of an
object kind.
• Enable auto display attributes: automatically displays the objects
kind of the selected feature.
basic attribution scheme
8.2
Advanced attribution
This mode of attribution is activated with the option Object attributes. . . of
the Attribution menu or with the object attribute button of the toolbar. The
constraints associated with this mode of attribution are the following:
• Is effective only for the current layer in edition
• Can be activated only if the selected element has already been basically
attributed.
36
• Cannot be use in a multiple selection
The advanced attribution of a feature is made with the management window
activated by the option Object attributes(single feature). . . This window is
contextual and retakes the attributes and values of the layer.
1. Name of the Layer
2. Attributes
3. Save or Cancel the modifications
4. Number of attributes available
8.3
Advanced attribution batch
The Object attribute(multiple features). . . option from the menu Attribution
allows you to assign a same attribute to all the selected features having the
same object type:
1. List of the objects kind corresponding to the selected features, the value
in bracket indicates the number of selected features corresponding to the
same kind.
2. List of the attributes corresponding to the selected object kind
3. Value of the selected attribute, the value can be a text, an integer, a
float, a date or an enumeration type (in this case: a text). There you can
assign the new value to all the selected and concerned features. Only one
attribute can be edited at once, apply your modification before making
another changes.
4. Attribution batch controls:
Save : save the modifications and close the window
Cancel : cancel the modifications and close the window
37
Apply : apply the modifications without closing the window, a message
appears to confirm the succeed of the operation.
8.4
Attribute orientation to point
In the case where the object can be oriented, you can give a feature an orientation. You have two ways to do it:
• From the advanced attribution window, just enter the value in the proper
attribute.
1. Some text attributes (the number in bracket is the maximal number of
characters, this number is defined in the attributes properties)
2. The orientation attribute
3. Attribution controls
4. number of attributes available
• With the option Set orientation (interactive mode) (CTRL+Y) from
the menu Tools, your cursor also change and you will be able to assign an
orientation with a click-and-release action.
1. The orientation cursor
2. The orientation indicator
Once you have release the click, the value of the orientation indicator is
attributed to the feature.
If you don’t drag your cursor enough, an error message will pops up telling
you that there isn’t enough data to compute the orientation
38
8.5
Shortcuts
The Shortcut. . . option of the attribution menu allows to assign shortcuts to
facilitate the attribution.
1. Drop-down menu allowing to select the construction layer which are assigned the shortcuts
2. List of the shortcuts and descriptions. Following operations can be realized
in the list:
• Edit the shortcuts characteristics by double-clicking on it
• Reorganize the list of shortcuts with the contextual menu by rightclicking
3. List of shortcuts management controls
+ : add a shortcut
- : delete a shortcut. The suppression can also be made with the
DELETE or BACKSPACE keys.
The shortcuts edition window looks like the following:
1. List of key functions available which can be assigned to a shortcut
2. Description of the shortcut
3. Object kind associated to the shortcut, the shortcut can attribute more
than one object
4. Apply or Cancel the modifications
At the attribution with a shortcut, you have a message in the status bar
wich confirms the attribution.
39
Chapter 9
Validation
The validation allows verifying the geometrical and semantic meaning of the
objects.
9.1
Semantic Validation
The Queries editor option of the Queries menu allows editing and executing
queries.
Example of queries:
1. List of available queries. Following operations can be realized in the list:
• Edit queries by double-clicking on it
• Reorganize the list of queries with the contextual menu by rightclicking.
2. Queries management controls
+ : add a query
- : delete a query. The suppression can also be made with the DELETE
or BACKSPACE keys.
Run : execute the selected query
The edition of a query is made with the following management window:
40
1. Query description
2. Construction layer on whom the query will be applied
3. Definition of the query in SQL1 language
When adding a new query the query wizard guides you through the creation
of the new query
9.2
Dangling nodes
The Tools menu includes the option Search dangling nodes. . . which allows to
highlight the geometrical errors in the construction layers of polygonal type. The
problematic nodes are identified with a red and white circle. The geometrical
validation tool window looks like the following:
1. Research extent
Search : search the errors [Clear]: clear the highlighting of the errors
There is basically two types of errors:
1 Structured
Query Language
41
Dangling nodes
The polygon is not closed. The snapping option shall prevent this error.
Missing attribution
The nodes are correctly snapped but the segment between the highlighted
nodes is badly attributed, it shall have the same attribute as the orange lines.
42
Chapter 10
FAQ
10.1
Rotation Warning
10.1.1
Introduction
Some raster file have associated rotation information. This indicates that an
appropriated rotation should be applied for the raster to be correctly displayed.
ToolMap display a Warning when such files are encountered because displaying
those files with rotations isn’t supported yet.
To still use those images we need to convert them into non rotated raster.
Following method may be used for that purpose:
10.1.2
Using ArcGIS
1. Load the raster
2. Right-click the raster name in the Table of contents
3. Choose Data → Export Data
4. Select the Location, file Format and file name
5. Press Save
The new raster is now correct and didn’t contain anymore rotation information
43
10.1.3
Note about word files (tfw)
Since ArcGIS 9.2 no more word files (tfw) are written and the georeferencing information is now stored in a aux.xml file(see ESRI help: http://tinyurl.com/68ykjqu).
It is however possible to manually create such word file using “Export Raster
Word File” tool from the ArcToolBox
44