xi4 translation management tool zh CN

翻译管理工具用户指南
■ SAP BusinessObjects Business Intelligence platform 4.0 Feature Pack 3
2012-05-10
版权所有
© 2012 SAP AG。保留所有权利。SAP、R/3、SAP NetWeaver、Duet、PartnerEdge、ByDesign、SAP
BusinessObjects Explorer、StreamWork、SAP HANA 和本文提及的其它 SAP 产品和服务及其各自
标识均为 SAP AG 在德国和其它国家/地区的商标或注册商标。 Business Objects 和 Business
Objects 标识、BusinessObjects、Crystal Reports、Crystal Decisions、Web Intelligence、
Xcelsius 和本文提及的其它 Business Objects 产品和服务及其各自标识均为 Business Objects
Software Ltd 的商标或注册商标。Business Objects 是一家 SAP 子公司。Sybase 和 Adaptive
Server、iAnywhere、Sybase 365、SQL Anywhere 和本文提及的其它 Sybase 产品和服务及其各自
标识均为 Sybase Inc. 的商标或注册商标。Sybase 是一家 SAP 子公司。Crossgate、m@gic EDDY、
B2B 360° 和 B2B 360° 服务是 Crossgate AG 在德国和其它国家的注册商标。Crossgate 是一
家 SAP 公司。 文中提及的所有其他产品和服务名称均为各自所有人的商标。本文档中包含的数据
仅供参考。各国的产品规格可能不同。上述资料如有变更,恕不另行通知。上述资料由 SAP AG 及
其关联公司(统称"SAP Group") 提供,仅供参考,SAP Group 对其不做任何陈述或保证,对于其
中的错误或疏漏不承担任何责任。对 SAP Group 产品和服务所做的保证仅为这类产品和服务随附
的明示保证声明中的保证(如有)。本文中的任何信息均不构成额外保证。
2012-05-10
目录
3
第 1 章
翻译管理工具简介....................................................6
1.1
1.2
1.3
1.4
1.5
1.6
1.7
1.8
文档历史记录:翻译管理工具..6
翻译管理工具简介..6
可翻译的资源类型..7
关于翻译 Interactive Analysis 报表..8
关于翻译从 Universe 设计工具生成的 Universe..9
关于翻译从信息设计工具生成的 Universe..9
翻译管理工具中使用的术语..10
关于身份验证和安全性..11
第 2 章
工具入门...........................................................13
2.1
2.2
2.3
2.3.1
2.3.2
2.3.3
2.3.4
2.3.5
2.3.6
2.4
2.5
2.5.1
2.5.2
2.5.3
2.5.4
2.5.5
2.5.6
登录 ..13
更改登录密码..13
关于翻译管理工具窗口..14
关于“翻译编辑器”视图..15
关于“语言管理”视图..15
关于文本编辑器视图..16
关于过滤器视图..17
关于单元格属性视图..17
关于帮助视图..18
自定义翻译管理工具窗口..18
设置首选项..19
设置产品语言..19
设置默认文件夹位置..20
设置要自动添加的区域设置..20
设置常用语言..20
设置自动填充选项..21
设置格式的示例数据..21
第 3 章
翻译工作流.........................................................22
3.1
3.2
3.3
3.4
3.5
关于翻译工作流..22
翻译后的区域设置的管理方法..22
关于安全性和翻译权限..23
关于并发翻译 ..24
关于翻译来自 CMS 资源库的资源..24
2012-05-10
目录
4
3.5.1
3.5.2
3.6
3.6.1
3.6.2
3.7
从 CMS 资源库的资源导入要翻译的内容..25
关于将翻译导出到 CM 资源库中的源资源内 ..26
关于翻译本地资源..26
从本地资源导入要翻译的内容..26
将译文导出到本地存储的资源..27
关于 TMGR 格式..27
第 4 章
翻译文档...........................................................28
4.1
4.2
4.3
4.4
4.5
4.6
在文档中添加和删除语言..28
设置备用语言..28
在翻译编辑器中翻译字符串..29
在文本编辑器中翻译字符串..30
在翻译编辑器中对字符串排序..30
在翻译编辑器中搜索和替换字符串..31
第 5 章
设置格式...........................................................33
5.1
5.2
5.3
5.4
5.5
5.6
在翻译编辑器中设置默认格式..33
关于格式编辑器..33
启动格式编辑器..34
启动自定义格式编辑器..35
创建自定义格式..35
删除自定义格式..36
第 6 章
管理状态...........................................................38
6.1
6.2
6.3
6.4
6.5
翻译状态..38
关于元数据翻译历史记录 ..39
按状态过滤列表视图..40
更改单元格属性..40
更改单元格状态..41
第 7 章
使用 XLIFF 交换文档翻译............................................42
7.1
7.2
7.3
7.4
7.5
关于 XLIFF 文件..42
导出和导入 XLIFF 文件..43
导出到 XLIFF - 选择源..43
导出到 XLIFF - 选择目标..44
从 XLIFF 文件导入..44
第 8 章
参考...............................................................46
8.1
8.2
8.3
8.4
区域设置及其主区域设置列表..46
数字格式标记..51
日期和时间格式标记..53
翻译管理工具支持的 InfoObject 类型..57
2012-05-10
目录
附录 A
更多信息...........................................................60
索引................................................................................62
5
2012-05-10
翻译管理工具简介
第 1 章 翻译管理工具简介
1.1 文档历史记录:翻译管理工具
下表概述了最重要的文档更改。
版本
日期
SAP BusinessObjects 4.0
2010 年 11 月 30
日
SAP BusinessObjects 4.0 Service
Pack 1
2011 年 2 月 25 日
SAP BusinessObjects 4.0 Service
Pack 2
2011 年 6 月 15 日
SAP BusinessObjects 4.0 Feature
Pack 3
2011 年 2 月 20 日
说明
本文档的第一个版本。“翻译
管理器”更名为“翻译管理工
具”
1.2 翻译管理工具简介
翻译管理工具提供框架,支持 BusinessObjects Enterprise 国际部署的本地化要求。
用户可以以自己的特定语言处理以下类型的文档:
• 本地存储或存储在资源库中的资源:Interactive Analysis 文档、Universe 设计工具 Universe
(.unv)。
• 本地存储,或存储在“Shared Projects”文件夹(资源库中)内的资源:信息设计工具为
Universe 生成的业务层和数据基础。
6
2012-05-10
翻译管理工具简介
• 仅在资源库中存储的资源:Dashboard Design 创建的仪表盘和 BI 工作区创建的工作区、Crystal
Reports 文档,以及大多数 InfoObject。
对于多语言受众,Universe 或报表设计员可以创建一个文档,并利用翻译管理工具将其翻译为多种
语言,而无需用每种语言分别创建 Universe 或文档。
译文会保存在 Universe 和报表文档中,在报表使用过程中以读者的语言显示。
为了从资源库导入要翻译的内容,此工具使用翻译服务器与其他模块通信。有关翻译服务器的更多
信息,请参阅管理指南。导入的内容以 TMGR 格式存储在本地。还将使用 TMGR 格式文件管理翻译管理
工具与翻译服务器之间交换的内容。
此工具的功能包括:
• 可以翻译大多数 SAP BusinessObjects 资源中的元数据:Universe、Interactive Analysis 报表
和 Crystal Reports 文档……
• 为内部翻译设计的界面。
• 格式编辑器,方便定义自定义日期、时间和数字格式。
• 可管理大约 130 个区域设置。
• 企业部署,带有与 SAP BusinessObjects Enterprise 的完全集成,其中包括对所有中央管理服务
器(CMS)身份验证模式和独立模式的支持。
• 中级市场(小规模)或无资源库的本地部署。
• 使用 XLIFF(XLIFF 本地化互交换文件格式)文件与外部翻译者协作。专业翻译人员通常都使用此
格式,它与许多翻译工具兼容。
• 可以执行并行和脱机翻译。
• 整个翻译过程中支持使用翻译状态。
注意:
• 虽然翻译管理工具运行在 Windows 平台上,但它可以连接到运行于其他平台上的中央管理服务
器。
• 此工具中使用的 XLIFF 标准与翻译管理工具的早期版本不兼容。 特别是不能读取早期版本翻译
管理器生成的 XLIFF 文件。
相关主题
• 第 8 页上的“关于翻译 Interactive Analysis 报表”
1.3 可翻译的资源类型
可翻译以下类型的资源:
7
2012-05-10
翻译管理工具简介
表1-1: 可翻译资源类型
资源类型
操作
Web Intelligence 报表
本地存储,或存储在 CMS 资源库中
通过 Universe 设计工具创建的 Universe
本地存储,或存储在 CMS 资源库中
使用信息设计工具创建的数据基础或业务层
Crystal Reports for Enterprise 文档(而
不是使用 C++ 设计器创建的文档)
使用 Dashboard Design 创建的仪表盘
使用 BI 工作区和大多数 InfoObject 创建的
工作区
本地存储,或存储在 CMS 资源库的“Shared
Projects”文件夹中
存储在 CMS 资源库中,且使用 BI 4 创建
存储在 CMS 资源库中,且使用 BI 4 创建
存储在 CMS 资源库中
注意:
• 翻译管理工具只能翻译下面的旧版资源:Web Intelligence 文件(wid)、Universe Designer
Universe (unv) 和常规 InfoObject。
• 翻译管理工具不能翻译查询名称。
1.4 关于翻译 Interactive Analysis 报表
可使用翻译管理工具翻译使用 Interactive Analysis 或 Web Intelligence XI 3.0 或更高版本创
建的报表元数据(.wid 文件)。此类元数据包括:
•
•
•
•
•
•
报表名称
查询名称或数据提供者名称
提示文本
局部变量名称
报警器名称及说明
Interactive Analysis 公式中的内容(例如位于表单元格内的内容)、报警器消息或报表变量(如
果要求使用 GetLocalized 函数)。
默认情况下,不翻译 Interactive Analysis 报表中报表公式的内容。要令报表公式中的字符串可
用于翻译管理工具中的翻译,在设计报表时,报表设计器必须使用 GetLocalized 函数。有关
GetLocalized 函数的更多信息,请参阅《使用 SAP BusinessObjects Interactive Analysis 中的函
数、公式和计算》指南。
8
2012-05-10
翻译管理工具简介
相关主题
• 第 9 页上的“关于翻译从信息设计工具生成的 Universe”
1.5 关于翻译从 Universe 设计工具生成的 Universe
可以翻译:
• Universe 名称和说明
• 上下文名称及说明
• 类名称及说明
• 对象名称、说明及格式
• 过滤器名称及说明
• 自定义层次结构名称
• 提示文本
• 输入列(标识为翻译管理工具中的提示)
派生 Universe
使用翻译管理工具打开基于一个或多个核心 Universe 的派生 Universe 时,只需翻译派生 Universe
的内容。用户基于派生 Universe 生成报表时,会使用核心 Universe 和派生 Universe 的译文。如果
派生 Universe 包含位于核心 Universe 类文件夹中的对象,将在未命名文件夹中显示这些对象。
此报表应用程序显示派生 Universe 的内容时,可用的翻译包括为派生 Universe 定义的语言,以
及为其核心 Universe 定义的语言。此应用程序使用以下规则集确定派生 Universe 的备用语言。
。1
如果为此派生 Universe 定义一种备用语言,此应用程序将使用该备用语言。
。2
如果没有为此派生 Universe 定义备用语言,此应用程序将在核心 Universe 中搜索备用语言。
。3
如果没有为任何核心 Universe 定义备用语言,则该 Universe 没有备用语言。
1.6 关于翻译从信息设计工具生成的 Universe
通过信息设计工具生成的 Universe 不能直接翻译。翻译管理工具可以独立翻译信息设计工具创建
的数据基础或业务层。这些资源可以位于本地信息设计工具项目中,也可以位于存储在 CMS 资源库内
的共享信息设计工具项目中。
翻译了这些资源之后,请使用信息设计工具重新发布将包含这些翻译内容的 Universe。
9
2012-05-10
翻译管理工具简介
相关主题
• 第 38
• 第 10
• 第 15
• 第 28
页上的“翻译状态”
页上的“翻译管理工具中使用的术语”
页上的“关于“语言管理”视图”
页上的“设置备用语言”
1.7 翻译管理工具中使用的术语
术语
说明
区域设置
一个区域设置定义一种语言和一个地区。一种语言可以与多个国家/地区关联。例
如,法国(FR)、比利时(BE)和瑞士(CH)都讲法语(fr)。对于瑞士的法语,
其区域设置为法语(瑞士)或 fr-CH。
区域设置还定义了数据的排序方式以及日期和数字的格式设置。
注意:
在翻译管理工具中,术语“语言”和“区域设置”可互换使用。
区域设置缩写
区域设置缩写由语言缩写后面跟随国家/地区缩写组成。
区域设置缩写的显示随操作系统或所使用的应用程序而有所不同。例如:
• Windows:法语(法国)
• Java:fr_FR
• Sun Solaris:fr_FR.ISO8859-1
• InfoView 6.5.1:法语(法国) [fr-FR]
主区域设置
主区域设置是一个预定义的区域设置,将在没有为文档定义替换语言时用作替换
语言。为每种语言都定义一个主区域设置。
产品语言
产品语言是指用于显示应用程序界面的语言。
首选查看区域设置 首选查看区域设置是指用户在应用程序中查看报表和查询对象时首选的语言。
(PVL)
10
2012-05-10
翻译管理工具简介
术语
说明
源语言
每次在将文档导出到 XLIFF(XML 本地化互交换文件格式)时,都可以定义一种
源语言,此语言将在生成的 XLIFF 文件中标识为源语言。
备用区域设置
如果查看已翻译的文档,并且用户的首选查看区域设置(PVL)中没有可用翻译,
可定义要显示的备用区域设置。
注意:
在一个文档中只能定义一种备用区域设置,因此在大多数情况下,完全可以不
定义备用区域设置,而使用主区域设置的默认替换语言。
翻译状态
每种语言中的所有字符串都与一种翻译状态相关联。该状态可指明字符串是否已
翻译、查看或更改。还可确定是否准备好在报表中显示翻译。
相关主题
• 第 46 页上的“区域设置及其主区域设置列表”
• 第 38 页上的“翻译状态”
• 第 9 页上的“关于翻译从信息设计工具生成的 Universe”
• 第 19 页上的“设置产品语言”
• 第 28 页上的“设置备用语言”
1.8 关于身份验证和安全性
此工具使用在中央管理控制台(CMC)中配置的登录信息和应用程序权限来控制访问。
可使用以下登录模式之一登录到翻译管理工具:
11
2012-05-10
翻译管理工具简介
Mode
说明
连接模式
身份验证类型有三种:“Enterprise”、“LDAP”和“Windows AD”。
使用这些身份验证类型可以连接到 CMS 资源库,从 CMS 导入文档和将文档导
出到 CMS,以及更改 CMS 登录密码。
用户也可以打开和翻译在本地目录中保存的未受保护资源。
独立模式
在独立模式下使用此工具时不需要提供身份验证。
用户只能翻译在本地目录中保存的未受保护的资源。
除非从 CMS 资源库导入的文档是未受保护的或已保存供所有用户使用,否则
用户不能打开这些文档。
要在连接模式或脱机模式下登录到翻译管理工具,必须具有针对翻译管理工具授予的“登录到翻译
管理器并将其显示为 CMC 中的对象”权限。
中央管理服务器(CMS)资源库中的文件夹和对象的访问权限受 SAP BusinessObjects Enterprise
管理员授予的权限控制。要打开文档和编辑译文,必须具有以下权限:
• 要打开和编辑 Universe 中的译文,必须具有针对 Universe 授予的“查看对象”和“编辑对象”
权限。
• 要打开和编辑 Interactive Analysis 文档中的译文,必须具有针对该文档授予的“查看对象”、
“编辑对象”和“下载与对象关联的文件”权限。
• 还需要针对包含 Universe 和报表对象的文件夹授予的“查看对象”权限。
有关用户权限的说明和定义的更多信息,请参阅《SAP BusinessObjects Enterprise 管理员指南》。
相关主题
• 第 13 页上的“登录 ”
12
2012-05-10
工具入门
第 2 章 工具入门
2.1 登录
要使用连接到中央管理服务器(CMS)的此工具,必须具备用户名、密码以及由管理员设置的相应权限。
在独立模式下使用翻译管理工具时不需要提供身份验证。
翻译管理工具将随 SAP BusinessObjects Enterprise 客户端工具自动安装。
1。 此工具如果尚未启动,请将其启动。从 Windows“开始”菜单中选择“所有程序” > “SAP
BusinessObjects XI 4.0” > “SAP BusinessObjects Enterprise 客户端工具” > “翻译管理工
具”。
将出现“用户标识”对话框。
2。 从“身份验证”框中选择身份验证类型。要在独立模式下使用此工具,请选择“独立”,然后单击
“确定”。
3。 对于所有其它身份验证类型,请在“系统”框中输入或选择 CMS 所在的系统名称。
有关身份验证类型的更多信息,请参阅相关主题。
4。 在“用户名”和“密码”框中输入用户名和密码。
5。 单击“确定”。
注意:
登录之后,CMS 会话信息就会显示在翻译管理工具窗口右下角的状态栏中。可以选择命令“工
具” > “登录为”,使用其他用户名或身份验证类型登录。
相关主题
• 第 11 页上的“关于身份验证和安全性”
2.2 更改登录密码
13
2012-05-10
工具入门
登录并连接到 CMS 之后,可更改用户在翻译管理工具内的 CMS 登录密码。
1。 选择“工具” > “更改密码”。
将出现“更改密码”对话框。
2。 在“旧密码”框中输入旧密码。
3。 在“新密码”和“确认新密码”框中输入新密码。输入值必须完全匹配。
4。 单击“确定”。
新密码保存在 CMS 中。
2.3 关于翻译管理工具窗口
该工具首次启动时,窗口将显示三个最常用的视图:“翻译编辑器”、“文本编辑器”和“语言管
理”视图。
用户可以自定义窗口,以在需要时显示其它视图:“单元格属性”、“过滤器”和“帮助”视图。
菜单栏包含以下命令菜单:
•
•
•
•
•
“文件”,包含用于打开、保存、导入和导出文件的命令。
“编辑”,包含常用文本编辑命令。
“工具”,包含用于重新输入登录信息和更改密码的命令。
“窗口”,包含用于打开和关闭视图以及设置应用程序首选项的命令。
“帮助”,包含用于在独立窗口中显示翻译管理工具帮助以及打开“帮助”视图的命令。
菜单栏下面的工具栏包含以下图标:
• 命令快捷方式图标,单击可执行菜单命令
• 常用文本编辑命令图标
• 用于显示翻译管理工具不同视图的图标
当将指针放在每个图标上时,会以工具提示形式显示该图标的功能。
翻译管理工具窗口底部的状态指示器显示了与中央管理服务器的连接状态。
相关主题
• 第 18 页上的“自定义翻译管理工具窗口”
14
2012-05-10
工具入门
2.3.1 关于“翻译编辑器”视图
“翻译编辑器”视图可用于翻译文档中的字符串。有关可以在“翻译编辑器”视图中执行的任务的
信息,请参阅下面的“相关主题”。
当打开文档时,“翻译编辑器”视图中会打开一个新表格。表的左列显示文档对象名称,下一列显
示原始内容,后续列显示要翻译的语言。
可通过以下两种方式查看表:
• 默认情况下将出现“类别”视图,并显示按层次结构组织的文档。
• 列表视图将文档显示为简单列表,且不包含层次结构信息。对象名称及其图标出现在左列。通过列
表视图可以查找、替换、过滤字符串以及对字符串排序。
对于每个对象,翻译管理工具会显示可翻译的内容:字符串(例如,名称、说明或提示)或格式(日
期或数字)。
用户可编辑单元格的内容以输入译文。
注意:
用户不能编辑“源”语言列中的单元格。
单元格内容的外观会随 XLIFF 翻译状态而变化。
属性与每个单元格的内容关联。要查看单元格的属性,请使用“单元格属性”视图。
相关主题
• 第 29
• 第 30
• 第 31
• 第 33
• 第 40
• 第 38
页上的“在翻译编辑器中翻译字符串”
页上的“在翻译编辑器中对字符串排序”
页上的“在翻译编辑器中搜索和替换字符串”
页上的“在翻译编辑器中设置默认格式”
页上的“按状态过滤列表视图”
页上的“翻译状态”
2.3.2 关于“语言管理”视图
15
2012-05-10
工具入门
通过“语言管理”视图可以在文档中添加和管理语言。有关可以在“语言管理”视图中执行的任务
的信息,请参阅相关主题。
“语言管理”视图左侧的“可用语言”列表显示了此工具支持的所有语言,用户可以从此列表中选
择要添加到文档中的语言。在应用程序首选项中,可以定义常用语言,使其显示在列表的顶部。
右侧的“选定的语言”表列出了为文档选定的语言。默认情况下,在“翻译编辑器”视图中会对应
每个选定的语言显示一列。
以下信息适用于添加到文档的每种语言:
列
说明
查看
使用“视图”复选框可以选择是否在“翻译编辑器”视图的列中显示该语言。
已翻译
“已翻译”列显示已翻译内容(具有 NEEDS_REVIEW_TRANSLATION、NEEDS_REVIEW_L10N、NEEDS_REVIEW_ADAPTATION、TRANSLATED、SIGNED_OFF或FINAL状态的
单元格)的百分比。
可见
“可见”复选框可用于定义某语言已完成翻译,准备就绪,可在报表中查看。某
种语言的翻译必须先导出回原始文档,才能查看。
备用
“备用”选项可用于定义要在未提供首选查看语言的译文时显示的语言。在将语
言设置为备用语言之前,必须先将它设置为“可见”。一个文档中只能定义一种
替换语言。
相关主题
• 第 28
• 第 28
• 第 20
• 第 10
页上的“在文档中添加和删除语言”
页上的“设置备用语言”
页上的“设置常用语言”
页上的“翻译管理工具中使用的术语”
2.3.3 关于文本编辑器视图
如果字符串因为太长而无法在“翻译编辑器”的单元格中查看,使用“文本编辑器”视图可以翻译
此超长字符串。默认情况下“文本编辑器”视图显示在“翻译管理工具”窗口右侧。
当在“翻译编辑器”视图中选定某个单元格时:
• 该单元格的内容显示在“文本编辑器”视图的“翻译”框中,用户可以在此处编辑它。
注意:
用户不能编辑原始内容。
• 关联的源语言内容显示在“文本编辑器”视图的“源”框中且不可被编辑。
16
2012-05-10
工具入门
• 对于 Interactive Analysis 文档,将在“注释”框中显示翻译者的注释。不能编辑这些注释。
相关主题
• 第 30 页上的“在文本编辑器中翻译字符串”
2.3.4 关于过滤器视图
“过滤器”视图可用于过滤要以某种语言显示在“翻译编辑器”列表视图中的行。
对于文档中的每种语言(一次一种语言),用户可选择是显示字符串,并同时显示一种状态、所有
状态还是一组状态。
激活“过滤器”视图后,“翻译编辑器”会以列表视图显示。
相关主题
• 第 40 页上的“按状态过滤列表视图”
• 第 38 页上的“翻译状态”
2.3.5 关于单元格属性视图
“单元格属性”视图显示“翻译编辑器”视图中的单元格的属性,并可用于更改单元格状态。
“单元格属性”视图会显示“翻译编辑器”视图中的当前单元格的以下属性:
属性
说明
名称(说明、格式)
单元格内容:文本字符串或格式定义。
状态
所选单元格的 XLIFF 翻译状态。可使用下拉列表更改状态。
上次更新时间
上次更改单元格内容或状态的日期和时间。
相关主题
• 第 40 页上的“更改单元格属性”
• 第 38 页上的“翻译状态”
17
2012-05-10
工具入门
2.3.6 关于帮助视图
要打开“帮助”视图,并显示关于特定主题的帮助,请按 F1,或选择“帮助” > “相关主题”。
“帮助”视图将列出一个指向与当前视图或对话框最相关的主题的链接。“动态帮助”部分列出指
向其它相关主题的链接以及搜索的结果。
使用该视图底部的图标可以列出所有主题、搜索帮助内容和在某个主题上创建标签以共将来参考。
2.4 自定义翻译管理工具窗口
用户可以自定义如何在翻译管理工具窗口中显示视图。每次登录到翻译管理工具时都会应用此自定
义设置,与登录信息无关。
操作
说明
打开视图
要打开视图,请从“窗口”菜单中选择它,或者单击“翻译管理工具”
工具栏上的图标。
关闭视图
要关闭视图,请在视图的标题栏中单击“关闭”按钮,或者在“翻译管
理工具”工具栏上单击视图图标。
移动视图
要在“翻译管理工具”窗口中移动视图,请单击视图的标题栏,然后将
视图拖到新位置。
分离视图
要在新窗口中打开视图,请将视图拖到翻译管理工具窗口之外,或者右
键单击视图的标题栏,然后选择“Detached”(已分离)。
重新附加视图
要将分离的视图移回到翻译管理工具窗口中,请右键单击视图的标题栏,
并取消选择“Detached”(已分离)。
调整视图大小
要放大或缩小视图,请拖动视图的边界。要最小化或最大化视图,请使
用视图右上角的图标。
相关主题
• 第 14 页上的“关于翻译管理工具窗口”
18
2012-05-10
工具入门
2.5 设置首选项
用户可以为以下项设置首选项:
• 使用此工具时的产品界面语言。
• 文档和 XLIFF 文件的默认文件夹。
• 自动添加到要翻译的新资源的语言。如果要翻译的字符串是从翻译管理工具中的资源获取的,将添
加此区域设置。
• 文档中常用的语言。这些语言出现在“语言管理”视图的可用语言列表顶部。
• 自动填充选项定义是否必须通过复制另一个区域设置的内容添加新区域设置。
• 在此工具中显示格式示例时使用的日期时间和数字值。
每次启动此工具时都会应用首选项设置,与登录信息无关。
相关主题
• 第 20
• 第 20
• 第 19
• 第 10
页上的“设置默认文件夹位置”
页上的“设置常用语言”
页上的“设置产品语言”
页上的“翻译管理工具中使用的术语”
2.5.1 设置产品语言
使用此过程可以更改翻译管理工具的界面语言。
1。 选择“窗口” > “首选项” > “设置产品语言”。
2。 在可用“产品语言”列表中选择语言。
注意:
对于可用产品语言列表中已有的语言,必须在安装翻译管理工具时为其选择语言包。
3。 单击“应用”以应用更改,或单击“确定”以应用更改并关闭“首选项”对话框。
重新启动翻译管理工具,以便以新语言显示界面。
相关主题
• 第 10 页上的“翻译管理工具中使用的术语”
19
2012-05-10
工具入门
2.5.2 设置默认文件夹位置
可以为以下两种类型的文件定义默认文件夹:
• 资源文件
• XLIFF 文件
在保存文件时,翻译管理工具向导会使用这些默认文件夹。
1。 选择“窗口” > “首选项” > “设置默认文件夹”。
2。 要为其他文档设置默认文件夹,请在“默认用户文档文件夹”框中输入或浏览到此文件夹。
3。 要为 XLIFF 文件设置默认文件夹,请在“默认 XLIFF 文件夹”框中输入或浏览到此文件夹。
4。 单击“应用”以应用更改,或单击“确定”以应用更改并关闭“首选项”对话框。
2.5.3 设置要自动添加的区域设置
使用此过程可在要翻译的区域设置列表中自动添加语言。
1。 选择“窗口” > “首选项” > “设置语言管理选项”
2。 选中“自动添加区域设置”复选框。
3。 在可用区域设置列表中,选择要添加的区域设置。
资源打开时,将自动添加选中的区域设置。
4。 单击“应用”以应用更改,或单击“确定”以应用更改并关闭“首选项”对话框。
2.5.4 设置常用语言
1。 选择“窗口” > “首选项” > “设置语言管理选项”。
2。 在“可用”列表中选择语言,然后单击右箭头。
此语言移至“常用”列表中。在“语言管理”视图中,“常用”列表中的语言出现在可用语言列表
的顶部。
20
2012-05-10
工具入门
3。 添加常用语言之后,请单击“应用”以应用所做的更改,或单击“确定”以应用所做的更改并关闭
“首选项”对话框。
相关主题
• 第 15 页上的“关于“语言管理”视图”
2.5.5 设置自动填充选项
1。 选择“窗口” > “首选项” > “设置语言管理选项”
2。 如果希望新区域设置在添加到支持的区域设置列表之后自动填充,请选中“使用自动填充源语言的
文本填充新列”。
3。 从下拉菜单中选择要添加的区域设置。
4。 如果不希望初始化新区域设置,请选中“添加空列”。
5。 添加常用语言之后,请单击“应用”以应用所做的更改,或单击“确定”以应用所做的更改并关闭
“首选项”对话框。
2.5.6 设置格式的示例数据
1。 选择“窗口” > “首选项” > “设置格式的示例数据”。
2。 定义在显示日期时间格式时使用的特定日期:
a。 选择“自定义日期时间”。
b。 从“日期”框的日历中选择一个日期。
c。 在“时间”框中,选择小时、分钟或秒,然后通过选择或键入新数字来更改数字。
3。 要定义在显示数字格式时使用的特定数字,请在示例数字框中输入新数字。
4。 单击“应用”以应用更改,或单击“确定”以应用更改并关闭“首选项”对话框。
21
2012-05-10
翻译工作流
第 3 章 翻译工作流
3.1 关于翻译工作流
可以以下面的方式翻译文档:
• 使用翻译管理工具在内部翻译,以便从本地资源或在资源库中保存的资源导入要翻译的内容。
• 翻译者可以添加自己的翻译语言,翻译自己的字符串,并将其导出回原始资源文件。翻译的内容
将与原始文件合并在一起。
• 翻译者可以在本地保存翻译元数据,以便以 .tmgr 文件的格式进行脱机工作。
• 提取了要翻译的字符串之后,也可以将其以 XLIFF 格式文件导出,并分发该文件,以便使用任
何兼容 XLIFF 的翻译工具进行翻译(请查阅第 8 章)。
注意:
不能在资源库内翻译文档。必须导入可翻译内容并进行处理。
相关主题
• 第 24 页上的“关于翻译来自 CMS 资源库的资源”
• 第 24 页上的“关于并发翻译 ”
3.2 翻译后的区域设置的管理方法
翻译管理工具仅导出回以下区域设置:
• 翻译者通过翻译管理工具添加的区域设置(区域设置被添加到资源)
• 翻译者使用翻译管理工具已经修改的区域设置(如果没有同步问题,将更新区域设置)
翻译管理工具从源获取可翻译属性时,不会锁定源。如果翻译过程中源发生了变化,此工具将新译
文导出到源时,将执行检查以验证源与翻译后的文档之间的同步/一致性。
22
2012-05-10
翻译工作流
如果发现了不一致,此工具将建议选择执行以下三种方法之一:
• 使用源更新翻译管理工具中存储的内容(建议执行此操作)。
• 取消整个导出。在这种情况下,将不执行任何操作。翻译管理工具中打开的元数据内无更改,而
源中也没有更改。
• 强制导出翻译后的字符串。
表3-1: 不同发布选项
状态
更新
已经从源删除
了某个翻译单
元。
已删除的翻译单元也会从翻译管理工
具中的翻译元数据内删除。
已经向源添加
了新翻译单元,
且必须翻译该翻
译单元。
新单元将添加到翻译管理工具中的翻
译元数据内。其状态为 NEW。
源中已修改了
某个翻译单元。
(正在执行的翻
译可能已过
期)。
将导入修改后的翻译单元,且其状态
为 NEEDS_REVIEW_TRANSLATION 或
NEEDS_REVIEW_LOCALISATION。
源中已经修改
了某个翻译单元
的一条或多条译
文。
修改后的翻译会以 NEEDS_REVIEW_TRANSLATION 或 NEEDS_REVIEW_LOCALISATION 状态导入翻译管理工具中。
取消
强制执行区域设置发布
无更
改。
已删除的翻译单元会
从翻译管理工具中的翻
译元数据内删除。
无更改
将添加新可翻译属
性,且状态为 NEW,但
是没有译文。
无更改
文本源将在翻译管理
工具中更新,但是翻译
始终会以来自翻译管理
工具的 XLIFF 状态发
布。
无更改
修改后的翻译会使用
来自翻译管理工具的
XLIFF 状态在资源中发
布。
3.3 关于安全性和翻译权限
翻译在 CMS 存储库中发布的对象意味着用户已经获得了翻译这些对象的授权。这些授权通过可在资
源级别或翻译管理工具级别定义的 CMC 权限提供。
要使用翻译管理工具,必须已经得到了“登录到翻译管理工具并将其显示为 CMC 中的对象”权限。
要翻译特定资源,需要获得以下权限:
• 翻译对象
• 编辑对象
如果用户已登录系统(即翻译管理工具),分配给该用户的权限将定义对象是否可编辑或翻译。
23
2012-05-10
翻译工作流
表3-2: 编辑权限的管理方式
级别
说明
在系统级别,在 CMS 中。
如果未授予“编辑”权限,CMS 会阻止翻译管理工具
用户更新任何 InfoObject 多语言信息。
在翻译管理工具级别,打开对象之前
翻译管理工具会检查此权限对当前用户的有效值。 如
果拒绝该值,将显示警告消息。将打开该对象。翻译者可
以在翻译管理工具中打开源并进行编辑,但是之后不能对
其进行保存。
在翻译管理工具级别,在将新翻译保
存到 CMS 中的源之前
翻译管理工具会检查当前用户的编辑权限。 如果拒绝
这些权限,将显示错误消息,并且不会保存翻译。这种情
况适用于 XLIFF 导入、XLIFF 成批导入或将翻译元数据
导入源时。
3.4 关于并发翻译
通过并发翻译文档,可以在翻译过程中节约时间。不同翻译者可以同时处理不同的区域设置。建议
只让一位翻译者处理一个特定区域设置。如果有两位翻译者尝试提交同一区域设置,则后一位翻译者的
更改可能会删除前一位翻译者的更改。翻译文档的方法有两种:
• 使用翻译管理工具在内部翻译,以便导入本地存储的文件,并添加要翻译的区域设置。翻译内
容,然后将文件重新导出到源文件中。翻译的内容将与原始文件合并在一起。
• 外部翻译,方法是将 .tmgr 文件导出为 XLIFF 格式的文件,并分发该文件以便使用任何兼容
XLIFF 的翻译工具进行翻译。
将翻译内容导入回原始源时,翻译管理工具将仅导出回区域设置:
• 翻译者通过翻译管理工具添加的区域设置(区域设置被添加到资源)。
• 翻译者使用翻译管理工具已经修改的区域设置(如果没有同步问题,将更新区域设置)。
因此,要翻译的字符串可以发送给可并行翻译这些字符串的不同翻译者。翻译者将自己的翻译导出
回原始资源时,导出的内容不会覆盖其他翻译者的翻译,因为这些翻译应该处理的是不同区域设置。
3.5 关于翻译来自 CMS 资源库的资源
24
2012-05-10
翻译工作流
可以翻译 CMS 中的元数据(文档内容)和文档名。要翻译资源库中存储的资源:
• 必须具有访问该资源库的权限。
• 必须具有翻译文档的权限,否则不能将译文导入回源文档。
• 必须将资源导入翻译管理工具,并在本地保存 .tmgr 文件。
• 将译文重新导出到资源库中的源文档。
除了翻译内容之外,还可以翻译资源库中的文件名。在资源库中浏览到文件,单击该文件,然后选
择“添加”。
3.5.1 从 CMS 资源库的资源导入要翻译的内容
可以从资源导入所有可翻译内容并在本地打开。可导入资源并翻译,然后再将其导出,也可导入资
源并保存,以便在本地进行处理。使用翻译管理工具在资源库中打开资源时,将验证用户权限,以便检
查用户是否可编辑或翻译该文档。
将从选定对象获取翻译元数据。该对象不会真的保存到文件系统中,也不会真的从资源库中抽取出
来。这样在只有一小部分文档内容需要翻译时,就可以防止导入整个文档,此翻译元数据可从翻译管理
工具获取时,翻译者即可对其进行处理。
将仅获取所需信息。用户可以处理信息,也可将翻译元数据临时保存在本地,以便进行脱机处理。
完成翻译并检查用户是否具有相应的应用程序权限之后,请使用翻译管理工具将翻译后的内容导出到资
源库中的资源内。
1。 使用 SAP BusinessObjects 凭据运行翻译管理工具。
2。 在“文件”菜单中,选择“文件” > “要翻译的字符串导入自” > “资源库”
3。 在该对话框中,导航到包含要翻译的资源的文件夹,并将其选中。
可用文档显示在右侧的窗格中。
4。 在窗格中选择一个资源,然后单击“添加”。
资源文件名出现在“添加”按钮下面的导入窗格中。可以按同样的方式添加更多资源。
5。 要从要导入的资源列表中删除某个资源,请单击资源名称,然后单击“删除”。
6。 如果要使用导入的文件替换同名的现有本地资源,请选中“覆盖现有文档”。
7。 单击“导入”。
如果某个资源导入失败,“导入”窗格的“导入状态”列中将出现一条警告。成功导入的文档被保
存到在“首选项”中定义的本地默认文件夹中。如果成功导入所有文档,向导将关闭。
8。 翻译管理工具将检查用户的权限;如果未授予“编辑对象”或“翻译对象”权限,将引发警告,否
则翻译管理工具会从源获取翻译元数据(导入翻译元数据)。将在“翻译管理工具”窗口中显示翻
译元数据。
9。 向文档添加区域设置并在本地保存译文。
翻译后的文件将在本地保存,并且可重新打开进行编辑。翻译完文件之后,请将其导回到资源库中
的原始资源。
25
2012-05-10
翻译工作流
3.5.2 关于将翻译导出到 CM 资源库中的源资源内
以所需区域设置翻译了资源内容之后,这些译文必须导出回资源库中的资源,以便供用户使用。译
文的状态必须已经设置为 NEEDS_REVIEW_TRANSLATION、NEEDS_REVIEW_L10N、NEEDS_REVIEW_ADAPTATION、
TRANSLATED、SIGNED_OFF 或 FINAL,且区域设置必须设置为“可见”。
将翻译后的内容导出到源资源:
• 必须已经连接到包含该资源的 CMS 资源库。
• 必须具有管理员授予的必要安全权限。
必须为翻译后的元数据指定“可见”状态,并且将这些元数据导出到资源库,这样才能在文档中使
用译文。
3.6 关于翻译本地资源
对于为所有用户保存的资源和本地存储的资源,可以从本地资源提取元数据并翻译这些元数据。 可
使用翻译管理工具翻译位于文件系统中的资源,但是此工具只能翻译未经保护的资源。
可翻译的资源为:
• Interactive Analysis 报表
• 通过 Universe 设计工具创建的 Universe
• 使用信息设计工具创建的数据基础和业务层
对于位于 CMS 资源库中的资源,要翻译本地资源,需要使用翻译管理工具提取要翻译的内容,并在
本地保存文件,再以翻译本地资源的相同方式进行翻译。
3.6.1 从本地资源导入要翻译的内容
导入要翻译的内容:
26
2012-05-10
翻译工作流
1。 选择“文件” > “要翻译的字符串导入自” > “资源库”
2。 在该对话框中,导航到包含要导入的文档的文件夹,并将其选中。
3。 选择要翻译的资源,然后单击“确定”。
字符串导入之后,可以添加区域设置并以这些区域设置翻译这些字符串,也可以将这些字符串导出
为 XLIFF 以便进行外部翻译。
3.6.2 将译文导出到本地存储的资源
以所需区域设置翻译了资源内容之后,这些译文必须导出回资源,以便供用户使用。译文的状态必
须已经设置为 NEEDS_REVIEW_TRANSLATION、NEEDS_REVIEW_L10N、NEEDS_REVIEW_ADAPTATION、
TRANSLATED、SIGNED_OFF 或 FINAL。区域设置必须设置为“可见”。
• 选择“文件” > “导出已翻译的字符串”
已翻译的内容将导回到本地资源。
3.7 关于 TMGR 格式
翻译来自本地资源或 CMS 资源库中保存的资源的字符串时,可以在本地以称为 TMGR 的翻译管理工
具专有文件格式保存工作(文件保存为 <文件名>.tmgr)。此文件包含要翻译的所有字符串、这些字符
串不同区域设置的当前译文,及其状态。可以在以后打开此文件继续处理,再最终将译文导出回资源。
保存当前译文对脱机工作非常有用,这样就可以在不连接 CMS 资源库资源的情况下仍然处理该资源
的译文。只需选中“文件” > “保存”,即可本地保存译文。获得翻译之后,即可关闭翻译管理工具。
可以在以后某天启动此工具并打开 .tmgr 文件继续翻译内容。
27
2012-05-10
翻译文档
第 4 章 翻译文档
4.1 在文档中添加和删除语言
在添加语言之前,请决定是否要更改“自动填充”选项或自动填充源语言。
1。 从资源导入要翻译的内容。
2。 打开“语言管理”视图(如果尚未打开)。选择“窗口” > “语言管理视图”。
3。 要添加语言,请从“可用语言”列表中选择它,然后单击右箭头。
此语言被添加到“选定的语言”列表中。对应此语言的一个新列被添加到“翻译编辑器”视图中。
如果已启用“自动填充”选项,翻译管理工具会使用以自动填充源语言写成的内容填充此列。
4。 要在“翻译编辑器”视图中隐藏对应新语言的列,请清除“视图”复选框。
注意:
虽然此语言没有显示,但它仍保留在文档中。
5。 要从文档中删除语言,请在“选定的语言”列表中选定它,然后单击左箭头。
翻译管理工具会要求确认删除操作。
警告:
如果删除某种语言,以此语言显示的所有已翻译内容都将丢失。
用户可以开始用新添加的语言进行翻译。
相关主题
• 第 15 页上的“关于“语言管理”视图”
4.2 设置备用语言
28
2012-05-10
翻译文档
有关备用语言的说明,请参阅相关主题中的术语主题。
1。 打开“语言管理”视图(如果尚未打开)。选择“窗口” > “语言管理视图”。
2。 在“语言管理”视图中,为该语言选择“可见”。
3。 为该语言单击“备用”选项。
4。 选择“文件” > “保存”。
将文档导出至资源库,以使该语言可在查询和报表生成程序中用作备用语言。
相关主题
• 第 10 页上的“翻译管理工具中使用的术语”
4.3 在翻译编辑器中翻译字符串
可以在“翻译编辑器”视图中翻译短字符串。要翻译更长的字符串,请使用“文本编辑器”视图。
在开始翻译之前,必须:
• 从资源导入要翻译的内容。
• 至少添加一种要翻译的语言。
1。 在“翻译编辑器”中包含要翻译的语言的列上,单击包含要翻译内容的单元格。
如果添加语言时已启用“自动填充”选项,该单元格将包含以自动填充源语言显示的内容。否则
此列为空白。
2。 输入译文并覆盖以前的字符串。
单击单元格时,内容会出现在“文本编辑器”视图中。一旦输入译文,单元格的状态就会自动设置
为 TRANSLATED。
注意:
在含有日期和数字格式的单元格中不能键入内容。要设置格式,请右键单击该单元格,并选择默
认格式,或使用“格式编辑器”创建自定义格式。
3。 要移至下一个要翻译的单元格,请单击该单元格。
提示:
在翻译时,除“编辑”菜单上的标准编辑命令之外,还可以按 ESC 键取消当前译文,或同时按
Ctrl + Z 键以撤消上一个译文。
4。 选择“文件” > “保存”。
29
2012-05-10
翻译文档
相关主题
• 第 33
• 第 15
• 第 30
• 第 38
页上的“在翻译编辑器中设置默认格式”
页上的“关于“翻译编辑器”视图”
页上的“在文本编辑器中翻译字符串”
页上的“翻译状态”
4.4 在文本编辑器中翻译字符串
如果字符串因为太长而无法在“翻译编辑器”的单元格中进行翻译,使用“文本编辑器”视图可以
翻译此超长字符串。
1。 从资源导入要翻译的内容。
2。 打开“文本编辑器”视图(如果尚未打开)。选择“窗口” > “文本编辑器视图”。
3。 在“翻译编辑器”视图中,单击要翻译其内容的单元格。
源语言出现在文本编辑器的“源”框中。此内容不能编辑。
现有的已翻译内容出现在“翻译”框中。
4。 在“翻译”框中编辑内容。
注意:
用户不能编辑原始内容。
5。 要在“翻译编辑器”视图中应用已翻译的内容,请单击“应用”。
6。 要取消更改,请单击“重置”。
7。 选择“文件” > “保存”。
相关主题
• 第 16 页上的“关于文本编辑器视图”
4.5 在翻译编辑器中对字符串排序
1。 从资源导入要翻译的内容。
2。 单击“翻译编辑器”视图左侧的选项卡,打开列表视图。
3。 单击列标题以按该列的字符串对列表排序。
30
2012-05-10
翻译文档
再次单击列标题,可以将排序顺序从升序更改为降序。
4.6 在翻译编辑器中搜索和替换字符串
1。 从资源导入要翻译的内容。
2。 单击“翻译编辑器”视图左侧的选项卡,打开“列表”视图。
3。 选择“编辑” > “查找/替换”。
4。 在“查找并替换”对话框中,在“查找”框中输入要搜索的字符串。
注意:
翻译管理工具从“列表”视图中选定的单元格开始搜索。
5。 搜索列表视图的选定部分:
a。 单击要搜索的部分的第一行。
b。 按住 Shift 键,并单击此部分的末尾行。
此部分被将突出显示。
c。 在“查找并替换”对话框中,为范围选择“选定的行”选项。
注意:
可以在选定“编辑” > “查找/替换”之前选定部分,“选定的行”选项会被自动选定。
6。 要更改搜索方向,请选择“向前”或“向后”选项。
7。 通过选择相应的复选框,可以选择其它选项:
选项
说明
区分大小写
仅搜索与“查找”框中的字符串匹配且大小写也匹配的字
符串。
全字匹配
仅搜索与“查找”框中的整个字符串相匹配的字符串。
从头继续搜索
当搜索到结尾时,从文档开头继续搜索。
渐进式搜索
当用户在“查找”框中输入字符时就开始查找字符串。
8。 单击“查找”(选定了“渐进式搜索”选项则除外)。
翻译管理工具会突出显示在其中找到搜索字符串的单元格。“替换”和“替换/查找”按钮变为可
用。如果未找到字符串,这些按钮则不可用。
9。 当翻译管理工具找到字符串的一个实例时:
• 要查找下一个实例,请单击“查找”。
• 要替换字符串,请在“替换为”框中输入替换字符串,然后单击“替换”;如果要替换字符串并
查找下一个实例,请单击“替换/查找”。
31
2012-05-10
翻译文档
10。 搜索完成时,单击“关闭”。
32
2012-05-10
设置格式
第 5 章 设置格式
5.1 在翻译编辑器中设置默认格式
使用“翻译编辑器”视图可以将数字和日期时间值的格式设置为默认格式。
注意:
也可以选择默认格式。要定义自定义格式,必须使用格式编辑器。
1。 在“翻译编辑器”中,右键单击数字或日期时间格式对象的单元格。
将显示一个快捷菜单。
2。 从快捷菜单中选择要使用的默认格式。
新格式出现在单元格中。
注意:
此应用程序使用当前系统日期和时间,以及数值 987,654,321 显示格式示例。在应用程序首选
项中,用户可以自行定义要在显示格式时使用的数字和日期时间值。
3。 选择“文件” > “保存”以保存格式。
相关主题
• 第 21 页上的“设置格式的示例数据”
• 第 33 页上的“关于格式编辑器”
5.2 关于格式编辑器
33
2012-05-10
设置格式
使用“格式编辑器”可以定义用于显示日期时间和数字值的格式。用户可以选择默认格式,也可以
定义自定义格式。对于文档中的元数据对象,可以为每个区域设置定义一种格式。这些格式保存在文档
中作为其本地化的一部分。
应用程序使用当前系统日期和时间以及数值 987,654,321 显示格式。在应用程序首选项中,用户可
以自行定义要在显示格式时使用的数字和日期时间值。
默认格式
默认格式是依据统一码协会管理的通用区域数据仓库(CLDR)建议提供的。如果 Microsoft 标准与
CLDR 建议存在差异,则以前者为准。日期和时间值有 15 种默认格式,数字有 4 种默认格式。
“格式编辑器”列出每个数据类别的可用默认格式。
自定义格式
如果可用默认格式不能满足需求,用户可以使用“自定义格式编辑器”创建格式。
即使在文档中使用了自定义格式,也可以删除该格式。下次为使用已删除的格式的对象启动格式编
辑器时,将自动重新创建自定义格式。
自定义格式由文本和标记组成。标记是数字或日期的预格式化部分。例如,“日:1-31”是一个将
日期的日部分显示为 1 至 31 之间数字的标记。有关标记的更多信息,请参阅相关主题。
“自定义格式编辑器”列出可能的标记类别。要定义格式,请在“格式定义”框中键入文本,然后
从“标记”框中拖动标记。标记出现在格式定义中,并带有矩形边框和灰色背景。在定义格式时,预览
会显示产生的外观。
用户可以为每个自定义格式定义一种显示颜色。如果没有定义颜色,则由客户端应用程序(例如,
Interactive Analysis)管理要显示的颜色。
在“未定义的值的格式”框中,可以定义要在报表生成期间未返回任何值时显示的文本和颜色。默
认情况下,将不会为未定义值显示文本。
在定义数值格式时,可输入要在值为负或等于零时显示的不同格式。如果没有输入格式,则使用为
正值定义的格式。
相关主题
• 第 34
• 第 35
• 第 36
• 第 53
• 第 51
• 第 21
页上的“启动格式编辑器”
页上的“启动自定义格式编辑器”
页上的“删除自定义格式”
页上的“日期和时间格式标记”
页上的“数字格式标记”
页上的“设置格式的示例数据”
5.3 启动格式编辑器
34
2012-05-10
设置格式
1。 在“翻译编辑器”中,右键单击数字或日期时间格式对象的单元格。
将显示一个快捷菜单。
2。 从快捷菜单中选择“其它格式(格式编辑器)...”。
相关主题
• 第 35 页上的“创建自定义格式”
• 第 33 页上的“关于格式编辑器”
5.4 启动自定义格式编辑器
用户可以从头开始创建自定义格式,或者使用现有格式(默认格式或自定义格式)作为新格式的基
础。
1。 如果格式编辑器尚未打开,请将其启动。
“格式类别”中列出可能的格式类别。
2。 如果对象可能具有多种格式类别,请在“格式类别”中选择类别。
“可用格式”中列出默认格式和以前定义的任何自定义格式。
3。 要从头开始创建格式,请单击“自定义格式”以打开“自定义格式编辑器”。
4。 要使用格式作为新自定义格式的基础,请先在“可用格式”列表中选择该格式,然后单击“自定义
格式”以打开“自定义格式编辑器”。
相关主题
• 第 35 页上的“创建自定义格式”
5.5 创建自定义格式
1。 如果自定义格式编辑器尚未打开,请将其启动。
2。 在“标记”列表中,选择标记类别或单独的标记,然后使用以下方法之一将它添加到“格式定义”
框中:
35
2012-05-10
设置格式
• 双击标记或标记类别。
• 将标记或标记类别拖到“格式定义”框中。
提示:
将光标放在“标记”列表中的每个标记上时,该标记的说明将显示为工具提示。有关标记的更多
信息,请参阅相关主题。
3。 要选择类别中的另一个标记,请单击刚添加到“格式定义”框中的标记上的箭头。
4。 以相同方法输入附加标记。要在定义中添加文本,请直接在“格式定义”框中键入。
提示:
使用复制(Ctrl + C)、粘贴(Ctrl + V)、剪切(Ctrl + X)和 Delete 键编辑“格式定义”
框的内容。
5。 要设置格式定义的颜色,请从“格式定义”框旁边的列表中选择颜色。
格式外观的示例显示在“预览”框中。
6。 对于数字格式,如果要定义在值为负或零时显示的格式,请在“负值的格式”和“等于零的值的格
式”定义框中添加标记和文本。
注意:
如果没有定义这些格式,则会为负值和零值显示在“正”框中定义的格式。
7。 对于日期时间和数字对象,如果要定义在数据库未返回值时显示的文本,请在“未定义的值的格式”
框中输入文本。
8。 要保存格式定义,请单击“确定”。
“自定义格式编辑器”对话框关闭。
刚定义的自定义格式显示在“格式编辑器”对话框的“可用格式”列表中。要使用格式,请选择该
格式,然后单击“确定”。
相关主题
• 第 35
• 第 53
• 第 51
• 第 33
页上的“启动自定义格式编辑器”
页上的“日期和时间格式标记”
页上的“数字格式标记”
页上的“关于格式编辑器”
5.6 删除自定义格式
1。 如果格式编辑器尚未打开,请将其启动。
“格式类别”中列出可能的格式类别。
2。 如果对象可能具有多种格式类别,请在“格式类别”中选择类别。
“可用格式”中列出默认格式和以前定义的任何自定义格式。
36
2012-05-10
设置格式
3。 在“可用格式”列表中选择自定义格式。
4。 要删除格式,请单击“删除”。
从列表中删除该格式。
5。 要确认删除,请单击“确定”。
即使在文档的其他位置使用了自定义格式,也可以删除该格式。下次为使用已删除的格式的对象启动格
式编辑器时,将自动重新创建自定义格式。
相关主题
• 第 34 页上的“启动格式编辑器”
37
2012-05-10
管理状态
第 6 章 管理状态
6.1 翻译状态
要翻译成每种语言的每个单元格的内容都会获分配一个状态。翻译管理工具使用十种标准的 XML 本
地化交换文件格式(XLIFF)状态,共分两种类别。
类别
NEEDS TRANSLATION
(此内容
不对最终用户
显示)
翻译可见
(此内容
可以对最终用
户显示)
38
XLIFF 状态
说明
NEW
指明是新内容。例如,在以前翻译过的文档中
添加或编辑的内容。
NEEDS_TRANSLATION
指明需要翻译内容。
NEEDS_ADAPTATION
指明只需要修改非文本信息。
NEEDS_L10N
指明需要翻译文本和修改非文本信息。
NEEDS_REVIEW_ADAPTATION
指明只需要复核非文本信息。
NEEDS_REVIEW_ L10N
指明需要复核非文本内容的翻译和修改。
NEEDS_REVIEW_TRANSLATION
指明需要复核已翻译的内容。
TRANSLATED
指明内容已翻译。
SIGNED_OFF
指明已复核并批准了更改。
FINAL
指明终止状态。
2012-05-10
管理状态
注意:
• 在 BI 启动板中,用户可以在 BI 启动板内查看译文,即使特定译文的状态为“需要翻译”,也不
例外。
• 本地化(L10N)是指文本的翻译和非文本内容(例如日期格式)的适应性更改。
用户可以使用其中的部分状态或所有状态,具体视贵组织和进度而定。翻译管理工具自动设置状态,
并在翻译过程中的某些阶段更改在编辑器中的显示内容。
• 当添加语言时,单元格处于归入“需要翻译”类别的某种状态。其内容在翻译编辑器中呈蓝色斜体
显示。
• 在以前翻译过的文档中已添加或编辑的内容处于 XLIFF 状态“NEW”。内容呈蓝色粗斜体显示。
• 一旦翻译了单元格的内容,其状态就自动更改为“TRANSLATED”,该状态属于“翻译可见”类别。
内容呈黑色普通字体显示。
• 当将某种语言设置为“可供使用”,并将文档导出到内容管理服务器时,其状态归入“翻译可见”
类别的字符串在客户查询和报表生成工具中可见。
如果按状态过滤列表视图中显示的单元格,可帮助管理翻译工作流程。
使用“单元格属性”视图可以查看单元格的状态。
有关 XLIFF 的更多信息,请参阅 OASIS Consortium 网站上的 XLIFF 标准。
相关主题
• 第 40 页上的“按状态过滤列表视图”
• 第 41 页上的“更改单元格状态”
• 第 40 页上的“更改单元格属性”
• 第 17 页上的“关于单元格属性视图”
• OASIS Consortium at http://www.oasis-open.org/
6.2 关于元数据翻译历史记录
此工具在保存元数据时可以一并保存元数据的上次编辑日期。以下对象支持此功能:
• Interactive Analysis 文档(.wid)
• Universe 设计工具 Universe(.unv)
• 信息设计工具数据基础和业务层(.dfx 和 .blx)
注意:
Crystal Reports 文档不支持此项功能。
39
2012-05-10
管理状态
6.3 按状态过滤列表视图
1。 从资源导入要翻译的内容。
2。 单击“翻译编辑器”视图左侧的选项卡,打开“列表”视图。
3。 打开“过滤器”视图(如果尚未打开)。选择“窗口” > “过滤器视图”。
4。 在语言列表中选择要过滤的语言。
5。 在状态类别列表中选择要作为过滤依据的类别。
6。 要根据各个 XLIFF 状态过滤,请在类别列表中选择“更多...”。
将出现所有 XLIFF 状态的列表。选择要作为过滤依据的状态的复选框。
过滤器被应用到列表视图的显示中。
相关主题
• 第 38 页上的“翻译状态”
• 第 17 页上的“关于过滤器视图”
6.4 更改单元格属性
1。 从资源导入要翻译的内容。
2。 选择“窗口” > “单元格属性视图”以打开“单元格属性”视图。
3。 在“翻译编辑器”视图中,单击要更改其状态的单元格。
单元格的属性出现在“单元格属性”视图中。
4。 要更改 XLIFF 状态,请在“单元格属性”视图中,在“状态”属性的“值”列列表中选择状态。
注意:
要为一组单元格更改 XLIFF 状态,请使用“更改状态”对话框。
5。 要更改“已批准”状态,请在“已批准”属性的“值”列列表中选择“真”或“假”。
注意:
翻译管理工具不使用“已批准”属性。建议使用 XLIFF 翻译状态。
6。 选择“文件” > “保存”。
40
2012-05-10
管理状态
相关主题
• 第 41 页上的“更改单元格状态”
• 第 17 页上的“关于单元格属性视图”
6.5 更改单元格状态
1。 从资源导入要翻译的内容。
2。 在“翻译编辑器”视图中,单击要更改其状态的单元格所在的行。
3。 要选择某部分中的所有单元格,请单击此部分的第一行。按住 Shift 键,并单击此部分的末尾行。
4。 右键单击选定的行或部分,然后选择“更改状态”。
5。 在“更改状态”对话框中,从“语言”列表中选择语言。
6。 在“状态”框中选择新状态,然后单击“确定”。
7。 选择“文件” > “保存”。
注意:
用户还可以在“单元格属性”视图中更改单元格的状态。
41
2012-05-10
使用 XLIFF 交换文档翻译
第 7 章 使用 XLIFF 交换文档翻译
7.1 关于 XLIFF 文件
翻译管理工具会为在导出时选定的每种目标语言创建一个 XLIFF 文件。用户可以为导出选择一种源
语言和任意多种替代翻译语言。
在创建每个 XLIFF 文件时,都会在文件名中包含源语言和目标语言,例如:Docu
ment_name.unv_en_US_DE.xlf,这是一个要译成德语的美式英语文件的 Universe 文件。对于
Interactive Analysis 文档,文件格式为:
文档名.wid_en_US_DE.xlf。
XLIFF 文件包括:
• 文档信息:
• 全文档名,包括中央管理服务器名称
• 源区域设置
• 目标区域设置
• 文档类型
• 对于每个字符串:
• 字符串标识符
• 用源语言显示的字符串
• 每种替代翻译语言的字符串、翻译状态和区域设置
• 翻译者注释
注意:
翻译管理工具遵守 XLIFF 规范版本 1.2。
有关 XLIFF 文件格式的更多信息,请参阅 OASIS Consortium 网站上的 XLIFF 标准。
相关主题
• OASIS Consortium at http://www.oasis-open.org/
42
2012-05-10
使用 XLIFF 交换文档翻译
7.2 导出和导入 XLIFF 文件
如果将翻译发送给第三方翻译者或供应商,可使用 XLIFF(XML 本地化互交换文件格式)文件来交
换文档。
使用翻译管理工具中的以下工作流,可以将文档的译文以 XLIFF 文件形式外包。有关此工作流中各
步骤的更多信息,请参阅相关主题。
• 从中央管理服务器(CMS)打开或导入文档。
• 使用“导出到 XLIFF”向导将文档导出到 XLIFF。
• 当从第三方收到完成的 XLIFF 文件时,使用“从 XLIFF 中导入”向导将它们导入到翻译管理工具
文档中。
• 可使用翻译管理工具显示和编辑译文,管理状态以及将文档导入到 CMS。
相关主题
• 第 43 页上的“导出到 XLIFF - 选择源”
• 第 44 页上的“导出到 XLIFF - 选择目标”
• 第 44 页上的“从 XLIFF 文件导入”
7.3 导出到 XLIFF - 选择源
必须在“翻译编辑器”视图中打开要导出的文档。如果尚未打开“导出到 XLIFF”向导,请打开它。
选择“文件”>“导出到 XLIFF”。
1。 在文档列表中选择要导出的文档。
注意:
一次只能导出一个文档。
2。 在文档的可用语言列表中,选中要导出的语言旁边的复选框。可以导出一种或多种语言。
可以添加 .tmgr 文件中尚未包含的其他区域设置。
注意:
至少必须导出一种语言。
3。 为其中一种导出语言选择“源”选项。
所选的语言是 XLIFF 文件的源语言。其它任何导出的语言被包括在 XLIFF 文件中作为备用翻译。
43
2012-05-10
使用 XLIFF 交换文档翻译
4。 如果导出原始内容,则必须从语言列表中选择原始内容的语言。
5。 单击“下一步”以选择目标语言,并继续导出。
相关主题
• 第 44 页上的“导出到 XLIFF - 选择目标”
• 第 42 页上的“关于 XLIFF 文件”
7.4 导出到 XLIFF - 选择目标
已启动“导出到 XLIFF”向导,并选择了源语言。继续导出:
1。 在“可用语言”列表中选择目标语言,然后单击右箭头。
2。 使用相同方式添加更多目标语言。
翻译管理工具会为每种目标语言创建一个 XLIFF 文件。
3。 要删除目标语言,请从“选定的语言”列表中选择它,然后单击左箭头。
4。 翻译管理工具将在本地默认文件夹中创建 XLIFF 文件。要更改文件夹,请在 XLIFF 文件的文件夹
框中输入新文件夹,或浏览到新文件夹。
5。 单击“完成”。
注意:
如果尚未完成所需的信息,“完成”按钮不可用。请确保至少选择一种目标语言。使用“上一
步”按钮(如有必要),确保已完成“导出到 XLIFF - 选择源”对话框中的步骤。
注意:
如果用户选择的是自己已翻译或已添加到文档中的目标语言,第三方翻译者将看到用户的译文,而
且也许能够对译文进行修改。这将导致在用户导入 XLIFF 文件时出现一则警告消息。
相关主题
• 第 43 页上的“导出到 XLIFF - 选择源”
• 第 42 页上的“关于 XLIFF 文件”
7.5 从 XLIFF 文件导入
如果尚未打开“从 XLIFF 中导入”向导,请打开它。选择“文件”>“从 XLIFF 中导入”。
44
2012-05-10
使用 XLIFF 交换文档翻译
1。 选择要将 XLIFF 文件导入其中的文档。
2。 输入或浏览到已翻译的 XLIFF 文件所在的 XLIFF 文件夹。
将列出文件夹中的所有 XLIFF 文件。如果要按与文档相同的名称来过滤,请单击“按文档名称过
滤”。
3。 选中要导入的 XLIFF 文件旁边的框。
“匹配状态”列提供了有关要导入的 XLIFF 文件的信息:
• 如果 XLIFF 文件中的语言已存在文档中,将出现警告消息。可以继续导入,但任何以前的译文
将被覆盖。
• 如果该 XLIFF 文件不是从同一文档中导出的,将出现一则消息。可以继续导入,但有些内容可
能被损坏。
• 在将文档与 XLIFF 文件匹配时,如果没有发现任何问题,将出现消息“确定”。
4。 单击“完成”。
译好的语言被添加到“编辑编辑器”和“语言管理”视图中。
相关主题
• 第 42 页上的“关于 XLIFF 文件”
45
2012-05-10
参考
第 8 章 参考
8.1 区域设置及其主区域设置列表
46
区域设置
区域设置缩写
主区域设置
南非荷兰语(南非)
af_ZA
af_ZA
阿尔巴尼亚语(阿尔巴尼亚)
sq_AL
sq_AL
阿拉伯语(阿尔及利亚)
ar_DZ
ar_SA
阿拉伯语(巴林)
ar_BH
ar_SA
阿拉伯语(埃及)
ar_EG
ar_SA
阿拉伯语(伊拉克)
ar_IQ
ar_SA
阿拉伯语(约旦)
ar_JO
ar_SA
阿拉伯语(科威特)
ar_KW
ar_SA
阿拉伯语(黎巴嫩)
ar_LB
ar_SA
阿拉伯语(利比亚)
ar_LY
ar_SA
阿拉伯语(摩洛哥)
ar_MA
ar_SA
阿拉伯语(阿曼)
ar_OM
ar_SA
阿拉伯语(卡塔尔)
ar_QA
ar_SA
阿拉伯语(沙特阿拉伯)
ar_SA
ar_SA
阿拉伯语(叙利亚)
ar_SY
ar_SA
阿拉伯语(突尼斯)
ar_TN
ar_SA
阿拉伯语(阿拉伯联合酋长国)
ar_AE
ar_SA
2012-05-10
参考
47
区域设置
区域设置缩写
主区域设置
阿拉伯语(也门)
ar_YE
ar_SA
亚美尼亚语(亚美尼亚)
hy_AM
hy_AM
阿塞拜疆语(阿塞拜疆)
az_AZ
az_AZ
巴斯克语(西班牙)
eu_ES
eu_ES
白俄罗斯语(白俄罗斯)
be_BY
be_BY
孟加拉语(印度)
bn_IN
bn_IN
波斯尼亚语(波斯尼亚和黑塞哥维那)
bs_BA
bs_BA
保加利亚语(保加利亚)
bg_BG
bg_BG
加泰罗尼亚语(西班牙)
ca_ES
ca_ES
中文(中国)
zh_CN
zh_CN
中文(中国香港特别行政区)
zh_HK
zh_TW
中文(中国澳门特别行政区)
zh_MO
zh_TW
中文(新加坡)
zh_SG
zh_CN
中文(台湾)
zh_TW
zh_TW
克罗地亚语(克罗地亚)
hr_HR
hr_HR
捷克语(捷克共和国)
cs_CZ
cs_CZ
丹麦语(丹麦)
da_DK
da_DK
荷兰语(比利时)
nl_BE
nl_NL
荷兰语(荷兰)
nl_NL
nl_NL
英语(澳大利亚)
en_AU
en_US
英语(伯利兹)
en_BZ
en_US
英语(加拿大)
en_CA
en_US
英语(爱尔兰)
en_IE
en_US
英语(牙买加)
en_JM
en_US
英语(新西兰)
en_NZ
en_US
英语(菲律宾)
en_PH
en_US
英语(南非)
en_ZA
en_US
2012-05-10
参考
48
区域设置
区域设置缩写
主区域设置
英语(特立尼达和多巴哥)
en_TT
en_US
英语(美属维尔京群岛)
en_VI
en_US
英语(英国)
en_GB
en_US
英语(美国)
en_US
en_US
英语(津巴布韦)
en_ZW
en_US
爱沙尼亚语(爱沙尼亚)
et_EE
et_EE
法罗语(法罗群岛)
fo_FO
fo_FO
芬兰语(芬兰)
fi_FI
fi_FI
法语(比利时)
fr_BE
fr_FR
法语(加拿大)
fr_CA
fr_FR
法语(法国)
fr_FR
fr_FR
法语(卢森堡)
fr_LU
fr_FR
法语(摩纳哥)
fr_MC
fr_FR
法语(瑞士)
fr_CH
fr_FR
加利西亚语(西班牙)
gl_ES
gl_ES
格鲁吉亚语(格鲁吉亚)
ka_GE
ka_GE
德语(奥地利)
de_AT
de_DE
德语(德国)
de_DE
de_DE
德语(列支敦士登)
de_LI
de_DE
德语(卢森堡)
de_LU
de_DE
德语(瑞士)
de_CH
de_DE
希腊语(希腊)
el_GR
el_GR
古吉特拉语(印度)
gu_IN
gu_IN
希伯来语(以色列)
he_IL
he_IL
北印度语(印度)
hi_IN
hi_IN
匈牙利语(匈牙利)
hu_HU
hu_HU
冰岛语(冰岛)
is_IS
is_IS
2012-05-10
参考
49
区域设置
区域设置缩写
主区域设置
印度尼西亚语(印度尼西亚)
id_ID
id_ID
意大利语(意大利)
it_IT
it_IT
意大利语(瑞士)
it_CH
it_IT
日语(日本)
ja_JP
ja_JP
卡纳达语(印度)
kn_IN
kn_IN
哈萨克语(哈萨克)
kk_KZ
kk_KZ
刚卡尼语(印度)
kok_IN
kok_IN
朝鲜语(韩国)
ko_KR
ko_KR
拉脱维亚语(拉脱维亚)
lv_LV
lv_LV
立陶宛语(立陶宛)
lt_LT
lt_LT
马其顿语(马其顿)
mk_MK
mk_MK
马来语(文莱)
ms_BN
ms_MY
马来语(马来西亚)
ms_MY
ms_MY
马拉雅拉姆语(印度)
ml_IN
ml_IN
马耳他语(马耳他)
mt_MT
mt_MT
马拉地语(印度)
mr_IN
mr_IN
蒙古语(蒙古)
mn_MN
mn_MN
北萨米语(挪威)
se_NO
se_NO
挪威博克马尔语(挪威)
nb_NO
nb_NO
挪威尼诺斯克语(挪威)
nn_NO
nn_NO
波斯语(伊朗)
fa_IR
fa_IR
波兰语(波兰)
pl_PL
pl_PL
葡萄牙语(巴西)
pt_BR
pt_BR
葡萄牙语(葡萄牙)
pt_PT
pt_BR
旁遮普语(印度)
pa_IN
pa_IN
罗马尼亚语(罗马尼亚)
ro_RO
ro_RO
俄语(俄罗斯)
ru_RU
ru_RU
2012-05-10
参考
50
区域设置
区域设置缩写
主区域设置
塞尔维亚语(波斯尼亚和黑塞哥维那)
sr_BA
sr_BA
塞尔维亚语(塞尔维亚和黑山)
sr_CS
sr_BA
斯洛伐克语(斯洛伐克)
sk_SK
sk_SK
斯洛文尼亚语(斯洛文尼亚)
sl_SI
sk_SK
西班牙语(阿根廷)
es_AR
es_ES
西班牙语(玻利维亚)
es_BO
es_ES
西班牙语(智利)
es_CL
es_ES
西班牙语(哥伦比亚)
es_CO
es_ES
西班牙语(哥斯达黎加)
es_CR
es_ES
西班牙语(多米尼加共和国)
es_DO
es_ES
西班牙语(厄瓜多尔)
es_EC
es_ES
西班牙语(萨尔瓦多)
es_SV
es_ES
西班牙语(危地马拉)
es_GT
es_ES
西班牙语(洪都拉斯)
es_HN
es_ES
西班牙语(墨西哥)
es_MX
es_ES
西班牙语(尼加拉瓜)
es_NI
es_ES
西班牙语(巴拿马)
es_PA
es_ES
西班牙语(巴拉圭)
es_PY
es_ES
西班牙语(秘鲁)
es_PE
es_ES
西班牙语(波多黎各)
es_PR
es_ES
西班牙语(西班牙)
es_ES
es_ES
西班牙语(乌拉圭)
es_UY
es_ES
西班牙语(委内瑞拉)
es_VE
es_ES
斯瓦希里语(肯尼亚)
sw_KE
sw_KE
瑞典语(芬兰)
sv_FI
sv_SE
瑞典语(瑞典)
sv_SE
sv_SE
叙利亚语(叙利亚)
syr_SY
syr_SY
2012-05-10
参考
区域设置
区域设置缩写
主区域设置
泰米尔语(印度)
ta_IN
ta_IN
泰卢固语(印度)
te_IN
te_IN
泰语(泰国)
th_TH
th_TH
茨瓦纳语(南非)
tn_ZA
tn_ZA
土耳其语(土耳其)
tr_TR
tr_TR
乌克兰语(乌克兰)
uk_UA
uk_UA
乌兹别克语(乌兹别克斯坦)
uz_UZ
uz_UZ
越南语(越南)
vi_VN
vi_VN
威尔士语(英国)
cy_GB
cy_GB
科萨语(南非)
xh_ZA
xh_ZA
祖鲁语(南非)
zu_ZA
zu_ZA
8.2 数字格式标记
数字格式定义
数字格式定义由以下部分组成:
•
•
•
•
•
•
符号(可选)
小数分隔符之前的整数值
分组分隔符,添加到整数值中
小数分隔符(可选)
小数分隔符之后的小数值(可选)
指数符号且后跟指数值(可选)
使用两个标记可以定义要在整数、小数和指数值中显示的有效数字位数。格式定义中的每个标记代
表一位要显示的数位:
• 必显的数位标记“0”,如果数位是有效数字,则显示该数位,否则显示 0。
• 或显的数位标记“#”,仅在数位是有效数字时,才显示该数位。
在确定有效数字时,将按从右到左的顺序评估整数值和指数值,按从左到右的顺序评估小数值。最
后一个“0”或“#”标记映射到其余的数位(如果有)。
51
2012-05-10
参考
示例: 数字格式显示
本例显示如何使用“格式编辑器”中定义的不同格式来显示值“-1,234”。
使用标记定义的格式:
预览显示:
[符号] [#]
-1234
[负值左括号] [0] [0] [0] [0] [0] [0] [N负值右括号]
(001234)
[始终带符号] [#] [小数分隔符] [0] [0]
-1234.00
[符号] [#] [小数分隔符] [0] [0] [E+] [0] [0] [0]
-1.23E+003
收入:[始终带符号] [#] [小数分隔符] [0] [0]
收入:-1234.00 €
[布尔值]
真
数字格式标记列表
类别
标记
说明
符号
如果值为负,则带负号。如果值为正或零,则不带符号。
始终带符号
如果值为负,则带负号。如果值为正或零,则带正号。
负值左括号
如果值为负,则带左括号。如果值为正或零,则不带符号。
负值右括号
如果值为负,则带右括号。如果值为正或零,则不带符号。
#
或显数位。仅在数位为有效数字时,才显示该数位。
0
必显数位。如果数位是有效数字,则显示该数位,否则显示 0。
小数分隔符
用于分隔数字的整数部分和小数部分的符号。采用的符号视区域设
置而定。在表达式中只能使用小数分隔符一次。
分组
默认情况下,使用区域设置定义的规则和分隔符对数字进行分组。
在表达式中只能使用分组符号一次。它必须出现在小数分隔符之前。
E+
大写的指数符号,始终带符号。在一个表达式中只能使用一次。
E-
大写的指数符号,仅在值为负时带符号。在一个表达式中只能使用
一次。
e+
小写的指数符号,始终带符号。在一个表达式中只能使用一次。
e-
小写的指数符号,仅在值为负时带符号。在一个表达式中只能使用
一次。
百分比
值乘以 100。
百分比 %
值乘以 100,后跟百分比符号(%)。在一个表达式中只能使用一
次。
符号
数位
分隔符
指数
百分比
52
2012-05-10
参考
类别
布尔值
标记
说明
布尔值
如果数值不为零,则为“真”;如果数值为零,则为“假”。
真
始终显示“真”。
假
始终显示“假”。
8.3 日期和时间格式标记
示例:日期和时间格式显示
本例显示如何使用“自定义格式编辑器”中定义的不同格式来显示日期“Wednesday March 5th
2008”。
53
2012-05-10
参考
使用标记定义的格式:
预览显示:
[日名称], [月份名称] [日:01~31] [年份:0000~
9999]
Wednesday, March 05 2008
[月份:01~12]/[日:01~31]/[年份:0000~9999]
03/05/2008
[首字母大写的短日名称] [日:01~31] [首字母大写的 Wed 05 Mar
短月份名称]
[日名称], week [年中第几周:01~53]
Wednesday, week 10
当前日期为 [日名称], [月份名称] [日:01~31] [年 当前日期为 Wednesday, March 05 2008。
份:0000~9999]。日名称是 [大写的日名称]。月份名 日名称为“WEDNESDAY”。月份名称为
称是 [小写的月份名称]。年份是 [年份:00~99]。
“march”。年份为 08。
日期和时间标记列表
类别
标记
说明
日:01~31
以两位数表示的月中的第几天:01~31。
日:1~31
以一位或两位数表示的月中的第几天:1~31。
日名称
与区域设置对应的日名称,例如:Monday。
短日名称
与区域设置对应的首字母大写的日名称,例如:
Mon。
年中第几天:001~366
以三位数表示的年中的第几天:001~366。
年中第几天:01~366
以两位或三位数表示的年中的第几天:01~366。
年中第几天:1~366
以一位、两位或三位数表示的年中的第几天:1~
366。
月中的第几个星期几
与区域设置对应的月中第几个星期几,例如,3
表示 6 月的第三个星期一。
大写日名称
大写的日名称,例如:MONDAY。
小写日名称
小写的日名称,例如:monday。
首字母大写的日名称
首字母大写的日名称,例如:Monday。
大写的短日名称
大写的短日名称,例如:MON。
小写的短日名称
小写的简短日名称,例如,周一。
首字母大写的短日名称
首字母大写的短日名称,例如:mon。
日
54
2012-05-10
参考
类别
月
年和年代
55
标记
说明
月份:01~12
以两位数表示的年中的第几月:01~12。
月份:1~12
以一位或两位数表示的年中的第几月:1~12。
月份名称
与区域设置对应的首字母大写的月份名称,例如:
June。
短月份名称
与区域设置对应的首字母大写的短月份名称,例
如:Jun。
大写月份名称
大写的月份名称,例如:JUNE。
小写月份名称
小写的月份名称,例如:june。
首字母大写的月份名称
首字母大写的月份名称,例如:June。
大写的短月份名称
大写的短月份名称,例如:JUN。
小写的短月份名称
小写的短月份名称,例如:jun。
首字母大写的短月份名称
首字母大写的短月份名称,例如:Jun。
年份:00~99
以两位数字表示的年份:00~99。
年份:0000~9999
以四位数字表示的年份:0000~9999。
日本日历的皇纪年代和年份
日本日历的皇纪年代和年份数字,例如,
。
日本日历的皇纪年代(英语)和年份
日本日历的皇纪年代(英文缩写)和年份数字,
例如,H20。
日本日历的皇纪年份数字:01~99
以两位数表示的日本日历的皇纪年份数字。
日本日历的皇纪年份数字:1~99
以一位或两位数表示的日本日历的皇纪年份数字。
日本日历的皇纪年代
日本日历的皇纪年代。
日本日历的皇纪年份
不赞成使用。返回的结果与“日本日历的皇纪年
份数字:0~99”标记的结果相同。
公元
公元缩写,例如,AD 或 BC。
2012-05-10
参考
类别
周
标记
说明
月中第几周
以一位数字表示的月中的第几周:1~6。
年中第几周:01~53
以两位数字表示的年中的第几周(ISO 周):01
~53。
年中第几周:1~53
以一位或两位数字表示的年中的第几周(ISO
周):1~53。
年中第几周的年份:0000
以四位数字表示的 ISO 年份数字(与 ISO 周一
致):0000~9999。
年中第几周的年份:00
以两位数字表示的 ISO 年份数字(与 ISO 周一
致):00~99。
年中的季度:1~4
以一位数表示的季度数字:1~4。
年中的短季度名称:Q1~Q4
以 Q1 到 Q4 表示的季度短名称。
季度名称:一季度~四季度
第一季度到第四季度的季度名称。
半年数字:1~2
半年数字:1~2。
小时:00~23
以两位数字表示的 24 小时制小时:00~23。
小时:0~23
以一位或两位数字表示的 24 小时制小时:0~
23。
小时:01~12
以两位数字表示的 12 小时制小时:01~12。
小时:1~12
以一位或两位数字表示的 12 小时制小时:1~
12。
小时:01~24
以两位数字表示的 24 小时制小时:01~24。
小时:1~24
以一位或两位数字表示的 24 小时制小时:1~
24。
小时:00~11
以两位数字表示的 12 小时制小时:00~11。
小时:0~11
以一位或两位数字表示的 12 小时制小时:0~
11。
分钟:00~59
以两位数字表示的分钟:00~59。
分钟:0~59
以一位或两位数字表示的分钟:0~59。
季度和半年
小时
分钟
56
2012-05-10
参考
类别
秒和次秒
时区
标记
说明
秒:00~59
以两位数字表示的秒:00~59。
秒:0~59
以一位或两位数字表示的秒:0~59。
毫秒:000~999
以三位数字表示的毫秒:000~999。
百分之一秒:000~999
以两位数字表示的百分之几秒:00~99。
十分之一秒:0~9
以一位数字表示的十分之几秒:1~9。
时区
与协调世界时的偏移量,例如,GMT+00:00。
AM/PM
上午/下午的缩写,根据区域设置决定首字母大小
写,例如,AM 或 PM。建议。
大写 AM/PM
大写的上午/下午缩写,例如,AM 或 PM。
小写 am/pm
小写的上午/下午缩写,例如,am 或 pm。
首字母大写的 Am/Pm
首字母大写的上午/下午缩写,例如,Am 或 Pm。
不建议使用此缩写。
日期分隔符
不赞成使用。此标记曾经在 Desktop Intelligence 中用作日期分隔符,现在不建议使用。可
在格式说明中直接键入要用作日期分隔符的字符,
或使用一种默认格式。
时间分隔符
不赞成使用。此标记曾经在 Desktop Intelligence 中用作时间分隔符,现在不建议使用。可
在格式说明中直接键入要用作时间分隔符的字符,
或使用一种默认格式。
AM/PM
分隔符
8.4 翻译管理工具支持的 InfoObject 类型
可以翻译大多数类型的 InfoObject 的说明或名称与说明。此工具支持以下类型的 InfoObject:
57
对象类型
可翻译属性
不可知
SI_NAME、SI_DESCRIPTION
日历
SI_NAME、SI_DESCRIPTION
类别
SI_NAME、SI_DESCRIPTION
2012-05-10
参考
58
对象类型
可翻译属性
自定义角色
SI_NAME、SI_DESCRIPTION
企业节点
SI_DESCRIPTION
事件
SI_NAME、SI_DESCRIPTION
Excel
SI_NAME、SI_DESCRIPTION
收藏夹文件夹
SI_DESCRIPTION
文件夹
SI_NAME、SI_DESCRIPTION
超级链接
SI_NAME、SI_DESCRIPTION
收件箱
SI_DESCRIPTION
清单
SI_NAME、SI_DESCRIPTION
对象包
SI_NAME、SI_DESCRIPTION
PDF
SI_NAME、SI_DESCRIPTION
PersonalCategory
SI_DESCRIPTION
配置文件
SI_NAME、SI_DESCRIPTION
程序
SI_NAME、SI_DESCRIPTION
发布
SI_NAME、SI_DESCRIPTION
QaaWS
SI_NAME、SI_DESCRIPTION
远程群集
SI_NAME、SI_DESCRIPTION
复制
SI_NAME、SI_DESCRIPTION
RTF
SI_NAME、SI_DESCRIPTION
服务器
SI_NAME、SI_DESCRIPTION
服务器组
SI_NAME、SI_DESCRIPTION
快捷方式
SI_NAME、SI_DESCRIPTION
TXT
SI_NAME、SI_DESCRIPTION
用户
SI_DESCRIPTION
用户组
SI_NAME、SI_DESCRIPTION
Word
SI_NAME、SI_DESCRIPTION
Universe (.unv)
SI_NAME、SI_DESCRIPTION、Universe 内容
2012-05-10
参考
对象类型
可翻译属性
数据基础
SI_NAME、SI_DESCRIPTION、数据基础内容
业务层
SI_NAME、SI_DESCRIPTION、业务层内容
Interactive Analysis 文档
SI_NAME、SI_DESCRIPTION、Interactive
Analysis 文档内容
Web Intelligence 文档
SI_NAME、SI_DESCRIPTION、Web Intelligence
文档内容
Crystal Reports 文档
SI_NAME、SI_DESCRIPTION、Crystal Report
文档内容
Xcelsius
仪表盘
59
SI_NAME、SI_DESCRIPTION、Xcelsius 文档本
身
SI_NAME、SI_DESCRIPTION、InfoObject 中保
存的某些属性
2012-05-10
更多信息
附录 A 更多信息
信息资源
SAP BusinessObjects 产品信息
位置
http://www.sap.com
导航到 http://help.sap.com/businessobjects/ 并在“SAP BusinessObjects Overview”(SAP BusinessObjects 概述)侧面板上单击“All
Products”(所有产品)。
SAP Help Portal
用户可以从 SAP Help Portal 访问涵盖所有 SAP BusinessObjects
产品及其开发信息的最新文档。用户可以下载 PDF 版本或可安装的 HTML
库。
某些指南存储在 SAP Service Marketplace 中,并且无法从 SAP
Help Portal 获得。这些指南将在 Help Portal 上列出,并附有指向
SAP Service Marketplace 的链接。拥有维护协议的客户有访问此站点
的授权用户 ID。如要获得 ID,请联系客户支持代表。
http://service.sap.com/bosap-support > 文档
• 安装指南:https://service.sap.com/bosap-instguides
• 发行说明:http://service.sap.com/releasenotes
SAP Service Marketplace
SAP Service Marketplace 用于存储某些安装指南、升级和迁移指
南、部署指南、发行说明以及所支持平台的文档。拥有维护协议的客户
有访问此站点的授权用户 ID。请联系客户支持代表以获得 ID。如果是
从 SAP Help Portal 重定向到 SAP Service Marketplace,请使用左侧
导航窗格中的菜单找到包含要访问的文档的类别。
https://cw.sdn.sap.com/cw/community/docupedia
Docupedia
开发人员资源
Docupedia 提供更多文档资源、协作编写环境,以及交互式反馈渠
道。
https://boc.sdn.sap.com/
https://www.sdn.sap.com/irj/sdn/businessobjects-sdklibrary
60
2012-05-10
更多信息
信息资源
位置
https://www.sdn.sap.com/irj/boc/businessobjects-articles
SAP Community Network 上的 SAP
BusinessObjects 文章
这些文章以前称为技术论文。
https://service.sap.com/notes
技术说明
这些技术说明以前称为知识库文章。
SAP Community Network 上的论坛
https://www.sdn.sap.com/irj/scn/forums
http://www.sap.com/services/education
培训
从传统的课堂学习到有针对性的电子学习讲座,我们都可以提供一套
培训方案,满足您的学习需要,适合您喜欢的学习方式。
http://service.sap.com/bosap-support
联机客户支持
SAP Support Portal 包含关于客户支持计划和服务的信息。它还包
含指向各种技术信息和下载内容的链接。拥有维护协议的客户有访问此
站点的授权用户 ID。如要获得 ID,请联系客户支持代表。
http://www.sap.com/services/bysubject/businessobjectsconsult
ing
咨询
61
从最初的分析阶段到交付部署项目为止,顾问将始终与您协同工作。
我们提供各种主题(例如,关系数据库和多维数据库、连通性、数据库
设计工具以及自定义嵌入技术)的专业技能。
2012-05-10
索引
A
安装翻译管理工具 13
按状态过滤字符串 40
B
“帮助”视图 18
编辑
状态 41
字符串 29, 30
标记 51, 53
C
CMS
访问权限 11
连接到 13
查看自定义 18
查找/替换字符串 31
产品语言
定义 10
设置 19
常用语言
设置 20
窗口 14
翻译 (续)
由第三方 43
字符串 29, 30
“翻译编辑器”视图 15
翻译状态 38
访问权限 11
默认
格式 33
区域设置 10
文件夹 20
G
内部翻译 29
格式
日期时间标记 53
设置 33
数字标记 51
格式编辑器
使用 33
说明 33
更改
单元格属性 40
密码 14
状态 41
更新
单元格属性 40
状态 41
管理语言 15, 28
“过滤器”视图 17
P
H
D
“单元格属性”视图 17
导出
导出文件至 XLIFF 43
导入
XLIFF 44
登录到翻译管理工具 13
登录密码 14
第三方翻译 43
独立模式 11
对字符串排序 30
回退语言 10
I
Interactive Analysis Intelligence
报表 9
Interactive Analysis 报表 8
J
界面,翻译管理工具 14
E
L
Enterprise 身份验证 11
LDAP 身份验证 11
类别视图 15
列表视图 15
F
翻译
Web Intelligence 报表 8
翻译
Interactive Analysis 报表 8
62
M
N
派生 Universe 9
Q
区域设置 10
权限 11
R
日期时间格式 33, 53
S
source 命令
XLIFF 43
删除语言 28
身份验证
登录 13
说明 11
视图
帮助 18
单元格属性 17
翻译编辑器 15
过滤器 17
文本编辑器 16
语言管理 15
首选查看语言 10
首选项
产品语言 19
常用语言 20
设置 19
文件夹 20
属性
更改 40
视图 17
数字格式 33, 51
搜索字符串 31
密码,更改 14
2012-05-10
索引
T
替换语言
定义 10
设置 29
显示 9
添加语言 28
脱机模式 11
U
Universe 9
W
Web Intelligence 报表 8
Windows 身份验证 11
63
外部翻译 43
“文本编辑器”视图 16, 30
文档,定义 10
语言术语 10
原始内容语言 10
源语言 10
X
Z
XLIFF
导出文件
导入 44
目标语言
文件交换
文件结构
状态 38
43
44
43
42
Y
主区域设置 9, 10, 46
状态
翻译 38
更改 41
过滤依据 40
自定义
格式 33, 35
视图 18
“自动填充”选项
源语言 10
“语言管理”视图 15
2012-05-10