ADL_quickstart

Asterisk / DAHDI / Libpri
®
QuickStart Installation
Software Installation
Installation Steps
Digium® hardware requires drivers and libraries that are not
integrated with the Linux kernel. Digium hardware is only
supported under Linux. Digium recommends CentOS, Debian,
RedHat, and Ubuntu distributions of Linux.
1) If you are installing a digital card, download and install the latest version of libpri. Substitute the
version of libpri for the X.X in the command line below. libpri is available for download from:
http://downloads.digium.com/pub/telephony/libpri
# wget http://downloads.digium.com/pub/telephony/libpri/libpri-X.X-current.tar.gz
Digium’s software, including drivers and application software,
may be obtained from Digium’s downloads server at:
http://downloads.digium.com
For an introduction to Asterisk®, Digium’s telephony software,
including information on its configuration, setup and features,
please refer to: http://www.asterisk.org
For information on setting up and configuring DAHDI drivers
for your Digium hardware product, please refer to the product’s
manual, available in the product-specific documentation section
at: http://www.digium.com
2) Expand the downloaded file, compile its contents, and install the library. Substitute the version of
libpri for the X.X and X.X.X in the command lines below.
# tar -zxvf libpri-X.X-current.tar.gz
# cd libpri-X.X.X/
# make
# make install
3) Download the latest DAHDI drivers. DAHDI is available for download from:
http://downloads.digium.com/pub/telephony/dahdi-linux-complete
# wget http://downloads.digium.com/pub/telephony/dahdi-linux-complete/dahdi-linux-complete.tar.gz
To install your Digium® card, you will need:
• Linux 2.6 kernel headers
• Development libraries and headers for ncurses
• Development libraries and headers for zlib and openssl
• Development libraries and headers for libnewt
• GCC and standard software build tools
It is recommended that you use the most recent version of the
Asterisk, DAHDI, and libpri software for the best results. If you
have previously installed any of these, Digium recommends that
you upgrade to the latest “-current” version of each.
4) Expand the downloaded file, compile its contents, and install the drivers and applications. Substitute
the version of DAHDI for the X.X.X in the command lines below.
# tar -zxvf dahdi-linux-complete-current.tar.gz
# cd dahdi-linux-complete-X.X.X+X.X.X
# make
# make install
5) Download the latest version of Asterisk. Substitute the version of Asterisk for the X.X in the
command line below. Asterisk is available for download from:
http://downloads.digium.com/pub/telephony/asterisk/
# wget http://downloads.digium.com/pub/telephony/asterisk/asterisk-X.X-current.tar.gz
6) Expand the downloaded file, compile its contents, and install the application. Substitute the version
of Asterisk for the X.X and X.X.X in the command lines below.
THANKS FOR
THE INSTALL!!
# tar -zxvf asterisk-X.X-current.tar.gz
# cd asterisk-X.X.X
# ./configure
# make menuselect
# make
# make install
7) If this is your first Asterisk install, you should install the sample configuration files. To do this run:
# make samples
Note that running this command will overwrite, after making a backup copy, any older Asterisk
configuration files that you may have on your system
www.digium.com
www.asterisk.org
v1.3 - 9 FEB 09
Your installation of Asterisk, DAHDI, and libpri is now complete.
If your installation has failed, please contact the reseller from whom you have purchased your Digium
product, or e-mail Digium Technical Support via support@digium.com.