Yamaha | DM2000 | Installation guide | Yamaha DM2000 Installation guide

/
/
DIGITAL MIXING CONSOLE
Special Notices
• The software and this manual are the exclusive copyrights of
Yamaha Corporation.
• Use of the software and this manual is governed by the
Software Licensing Agreement which the purchaser fully
agrees to upon breaking the seal of the software packaging.
(Carefully read the agreement at the end of this manual before
installing the software.)
• Copying of the software or reproduction of this manual in
whole or in part by any means is expressly forbidden without
the written consent of the manufacturer.
• Yamaha makes no representations or warranties with regard
to the use of the software and documentation and cannot be
held responsible for the results of the use of this manual and
the software.
• This disc is a CD-ROM. Do not attempt to play the disc on an
audio CD player. Doing so may result in irreparable damage
to your audio CD player.
• Copying of the commercially available music sequence data
and/or digital audio files is strictly prohibited except for your
personal use.
• The screen displays as illustrated in this manual are for
instructional purposes, and may appear somewhat different
from the screens which appear on your computer.
• Future upgrades of application and system software and any
changes in specifications and functions will be announced
separately.
• Specifications and descriptions in this installation guide are
for information purposes only. Yamaha Corp. reserves the
right to change or modify specifications at any time without
prior notice. Since specifications may not be the same in every
locale, please check with your Yamaha dealer.
• The company names and product names in this installation
guide are the trademarks or registered trademarks of their
respective companies.
* OMS is a trademark of Opcode Systems, Inc.
* SmartMedia is a trademark of Toshiba Corporation.
Contents
Getting Started............................................. 2
Introduction.....................................................
CD-ROM Contents ...........................................
Windows System Requirements........................
Macintosh System Requirements......................
System Hookup................................................
Configuring Your Yamaha Mixing Console .......
Caution when using a USB connection.............
2
2
4
4
5
5
5
Windows Installation .................................... 5
Adobe Reader ..................................................
USB MIDI Driver...............................................
Installing Yamaha CBX Driver (DM2000/02R96
only) ................................................................
Installing an Editor ...........................................
Installing Studio Manager ................................
Installing Card Filer (DM2000 only)..................
5
5
8
8
8
8
Macintosh Installation .................................. 9
Adobe Reader .................................................. 9
OMS (Open Music System) .............................. 9
USB MIDI Driver.............................................. 10
Installing an Editor .......................................... 11
Installing Studio Manager ............................... 11
Installing Card Filer (DM2000 only)................. 11
Setting Up OMS.............................................. 11
Getting Started............................................ 12
Overview of Studio Manager........................... 12
Starting and setting up Studio Manager.......... 13
Troubleshooting .......................................... 14
SOFTWARE LICENSING AGREEMENT .......... 15
Yamaha Professional Audio web site:
http://www.yamahaproaudio.com/
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
1
FRANÇAIS
DIGITAL MIXING CONSOLE
ESPAÑOL
/
DEUTSCH
Studio Manager V2 Installationshandbuch
Studio Manager V2 Manuel d’installation
Studio Manager V2 Guía de Instalación
ENGLISH
Studio Manager V2 Installation Guide
Getting Started
Introduction
Yamaha Studio Manager enables you to control your Yamaha mixing console from a Windows or Macintosh computer.
This Installation Guide explains how to install Studio Manager and the necessary driver software for Windows and Macintosh computers.
For information on how to use Studio Manager and the various editors, refer to the PDF format Studio Manager manual and the manuals
for the various editors which are installed on your computer when Studio Manager is installed. Refer to the owner’s manuals for your
devices for information on operating the devices.
CD-ROM Contents
CD-ROM included with the DM2000/02R96
Folder
Software
Editor1
Description
DM2000 Editor for Studio Manager (for Windows 2000/XP).
SM_\DM2k_
DM2000
SM_\02R96_
02R96 Editor1
02R96 Editor for Studio Manager (for Windows 2000/XP).
SM_\SM2_
Studio Manager1
Yamaha Studio Manager (for Windows 2000/XP).
Mididrv_
Yamaha CBX Driver
Yamaha serial driver. Necessary if you are connecting to a serial
port on your computer.
USBdrv_
Yamaha USB MIDI Driver
(Windows 98, Me)
USBdrv2k_
Yamaha USB MIDI Driver
(Windows 2000, XP)
Card_
Card Filer1
Yamaha utility for transferring and managing data stored on
the DM2000’s SmartMedia card.
Mac OS X
\SM_\DM2k_
DM2000 Editor1
DM2000 Editor for Studio Manager (for Mac OS X).
Mac OS X
\SM_\02R96_
02R96 Editor1
02R96 Editor for Studio Manager (for Mac OS X).
Mac OS X
\SM_\SM2_
Studio Manager1
Yamaha Studio Manager (for Mac OS X).
Open Music System (OMS) 2.3.81, 2
Opcode driver software for use with MIDI applications on Macintosh computers (Mac OS 9 or earlier).
OMS Setup for YAMAHA
OMS studio setup files for use with the DM2000 and 02R96
(Mac OS 9 or earlier).
Windows
Macintosh
Mac OS 9\OMS_
Mac OS 9\USBdrv_
YAMAHA USB MIDI Driver
Mac OS X\USBdrv_
YAMAHA USB MIDI Driver for OS X
Mac OS 9\Card_
Card Filer1
Yamaha USB driver. Necessary if you are connecting to a USB
port on your computer.
Yamaha USB driver. Necessary if you are connecting to a USB
port on your Macintosh computer.
Yamaha utility for transferring and managing data stored on
the DM2000’s SmartMedia card (Mac OS 9 or earlier).
1. For information on using this software, refer to the PDF manual after installation.
2. This software is not supported by Yamaha.
2
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
CD-ROM included with the DM1000/01V96
Software
Editor1
Description
SM_\DM1000_
DM1000
SM_\01V96_
01V96 Editor1
01V96 Editor for Studio Manager (for Windows 2000/XP).
SM_\SM2_
Studio Manager1
Yamaha Studio Manager (for Windows 2000/XP).
USBdrv_
Yamaha USB MIDI Driver
(Windows 98, Me)
USBdrv2k_
Yamaha USB MIDI Driver
(Windows 2000, XP)
Mac OS X
\SM_\DM1000_
DM1000 Editor1
DM1000 Editor for Studio Manager (for Mac OS X).
Mac OS X
\SM_\01V96_
01V96 Editor1
01V96 Editor for Studio Manager (for Mac OS X).
Mac OS X
\SM_\SM2_
Studio Manager1
Yamaha Studio Manager (for Mac OS X).
Open Music System (OMS) 2.3.81, 2
Opcode driver software for use with MIDI applications on Macintosh computers (Mac OS 9 or earlier).
OMS Setup for YAMAHA
OMS studio setup files for use with the DM1000 and 01V96
(Mac OS 9 or earlier).
Windows
Macintosh
Mac OS 9\OMS_
Mac OS 9\USBdrv_
YAMAHA USB MIDI Driver
Mac OS X\USBdrv_
YAMAHA USB MIDI Driver for OS X
DM1000 Editor for Studio Manager (for Windows 2000/XP).
Yamaha USB driver. Necessary if you are connecting to a USB
port on your computer.
Yamaha USB driver. Necessary if you are connecting to a USB
port on your Macintosh computer.
1. For information on using this software, refer to the PDF manual after installation.
2. This software is not supported by Yamaha.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
3
ENGLISH
Folder
Windows System Requirements
Macintosh System Requirements
The system requirements of your operating system may differ
from those listed here.
The system requirements of your operating system may be
different to those listed here.
Studio Manager
Studio Manager
Computer
A computer with a 800 MHz or faster Intel Pentium or Celeron family processor
OS
Windows 2000, XP Home Edition, XP Professional
Memory
Computer
A Macintosh G4 or better and a USB port
OS
Mac OS X 10.2 or later
Memory
512 MB or more of free memory
256 MB or more
Hard Disk
30 MB or more of free space
Hard Disk
30 MB or more of free space
Display
MIDI Driver
USB, MIDI, Serial, or mLAN (depending on the
connection between the console and the computer)
1024 x 768 pixels, 256 colors or higher
1280 x 1024, 32,000 colors recommended
MIDI Driver
Display
1024 x 768 pixels, 256 colors or higher
1280 x 1024, High Color 16-bit recommended
(If you use display settings of 1024 x 768, turn
on the Task Bar’s Auto-hide option.)
USB, MIDI, Serial, or mLAN (depending on the
connection between the console and the computer)
Card Filer (DM2000 only)
Card Filer (DM2000 only)
Computer
A Macintosh computer with a PowerPC processor or better
OS
Mac OS 7.5 to 9.2.2 (Mac OS X not supported)
8 MB or more of free memory
Computer
A computer with a 100 MHz or faster Intel Pentium or Celeron family processor
Memory
Hard Disk
6 MB or more
OS
Windows 95, 98, 98SE, Me, NT4.0, 2000, XP
Home Edition, XP Professional
Display
800 x 600 pixels, 256 colors or higher
Memory
8 MB or more
Hard Disk
2 MB or more of free space
Display
800 x 600 pixels, 256 colors or higher
Yamaha USB MIDI Driver
Computer
A Macintosh computer with a PowerPC processor or better and a USB port
OS
Mac OS 8.6 to 9.2.2 (Mac OS X not supported)
Memory
64 MB or more (recommended: 128 MB or
more)
Hard Disk
2 MB or more
Yamaha USB MIDI Driver
Computer
A computer with a 166 MHz or faster Intel Pentium or Celeron family processor and a USB
port
OS
Windows 98, 98SE, Me, 2000, XP Home Edition, XP Professional
Memory
32 MB or more
Hard Disk
2 MB or more of free space
Yamaha CBX Driver (DM2000/02R96 only)
OS
Windows 95, 98, 98SE, Me, NT4.0, 2000, XP
Home Edition, XP Professional
System requirements for software not listed here can be found
on the CD-ROM.
You can check the latest version information of each program/
driver and its system requirements at the following website:
http://www.yamahaproaudio.com/
4
Yamaha USB MIDI Driver for OS X
Computer
A Macintosh computer with a PowerPC processor or higher and a USB port
OS
Mac OS X 10.2 or later
Memory
64 MB or more (recommended: 128 MB or
more)
Hard Disk
2 MB or more
System requirements for software not listed here can be found
on the CD-ROM.
You can check the latest version information of each program/
driver and its system requirements at the following website:
http://www.yamahaproaudio.com/
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
System Hookup
Yamaha mixing console rear panel
Mac or PC
1. Serial
(DM2000/02R96 only)
(Yamaha CCJ-Mac
or equivalent)
Mac serial port
Serial cable
(Yamaha CCJ-PC2
or equivalent)
Adobe Reader
Adobe Reader (available free of charge) must be installed on
your computer in order for you to view the PDF format manuals
for Studio Manager and the various editors. If you don’t have
Adobe Reader, access the Adobe Corporation website at the URL
shown below, and download Adobe Reader.
http://www.adobe.com
PC serial port
USB MIDI Driver
TO HOST
USB
2. USB
USB port
USB cable
If you are connecting your Yamaha mixing console to a USB
port on your computer, you’ll need to install the Yamaha USB
driver. If you already have this driver installed, skip this section.
Computer
3. MIDI
OUT
Studio
Manager
IN
MIDI interface
MIDI cables
NOTE: Before you connect to serial or MIDI ports, turn off your
Yamaha mixing console and computer.
Configuring Your Yamaha Mixing
Console
Press the DISPLAY ACCESS [SETUP] button to open the MIDI/
TO HOST Setup page. Under “Studio Manager,” select a port
and assign an ID to your Yamaha mixing console. If you’ve
connected the DM2000/02R96 to the serial port, set the TO
HOST SERIAL options as appropriate (i.e., “PC-2” for a
Windows PC, or “Mac” for a Macintosh computer).
USB cable
Driver
Yamaha
mixing console
The procedure you use for installing the Yamaha USB driver
depends on which version of Windows you’re using:
• Windows 98 & 98SE: See page 6
• Windows Me: See page 7
• Windows 2000: See page 7
• Windows XP: See page 8
NOTE: Studio Manager is supported by only Windows 2000/XP.
The driver for Windows 98/98SE/Me is necessary if you use other
MIDI applications on Windows 98/98SE/Me.
Warning: Do not set the TO HOST SERIAL option to “Mac” while
your Yamaha mixing console is connected to your computer’s serial
port. Doing so may damage your computer.
Caution when using a USB connection
If you’ve used the USB TO HOST connector to connect to your
computer, you must perform the following actions. If you fail to
do so, your computer or the connected mixing console may
hang up, causing data damage or loss. If your computer or
mixing console hangs up, turn off the power, and restart your
computer.
• Disable the energy conservation mode (suspend/sleep/
standby/hibernate) on your computer before connecting your
computer via the USB TO HOST connector.
• Connect the USB TO HOST connector to your computer
before powering-on the mixing console.
• Close all application programs (such as StudioManager)
before powering the mixing console on/off or connecting/
disconnecting the USB cable.
• Wait at least three seconds between turning the mixing
console on or off, and between connecting and disconnecting
the USB cable.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
5
ENGLISH
Windows Installation
The following illustration shows the available hookup methods
you can use to connect your Yamaha mixing console to your
computer: serial, USB, MIDI.
Windows 98 & 98SE
1
Start your computer and Windows, and then
insert the included CD-ROM into your computer’s
CD-ROM drive.
2
Turn off your Yamaha mixing console, and then
use a USB cable to connect its USB TO HOST port
to a USB port on your computer.
3
Turn on your Yamaha mixing console.
The “Add New Hardware Wizard” appears. If it doesn’t
appear, try disconnecting and reconnecting the USB cable.
Alternatively, open the Add New Hardware control panel.
6
Select “Specify a location,” and specify
“D:\USBdrv_” (replacing “D” with the drive letter
of your CD-ROM drive), and then click [Next].
When the driver is located, “YAMAHA USB MIDI Driver”
is displayed, as shown below.
7
Click [Next].
NOTE: You may be prompted to insert your Windows
CD-ROM. Do not insert it! Click [OK], and in the “Copy files
from” section of the subsequent dialog box, enter
“D:\USBdrv_” (replacing “D” with the drive letter of your
CD-ROM drive), and then click [OK].
4
The driver is installed, and the following window appears
when the installation is complete.
Click [Next].
The following window appears.
8
5
Click [Finish], and then restart your computer.
Select “Search for the best driver for your device
(Recommended),” and then click [Next].
The following window appears.
6
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
Windows 2000
1
Start your computer and Windows, and then
insert the included CD-ROM into your computer’s
CD-ROM drive.
1
Start your computer to launch Windows, then log
in as Administrator.
2
2
Turn off your Yamaha mixing console, and then
use a USB cable to connect its USB TO HOST port
to a USB port on your computer.
Insert the included CD-ROM into your computer’s
CD-ROM drive.
3
Turn on your Yamaha mixing console.
The “Add New Hardware Wizard” appears. If it doesn’t
appear, try disconnecting and reconnecting the USB cable.
Alternatively, open the Add New Hardware control panel.
Go to My Computer–>Control Panel–>System–
>Hardware–>Driver Signing–>File Signature
Verification, select “Ignore—Install all files,
regardless of file signature,” and then click [OK].
4
Turn off your Yamaha mixing console, and then
use a USB cable to connect its USB TO HOST port
to a USB port on your computer.
5
Turn on your Yamaha mixing console.
The “Found New Hardware Wizard” appears.
6
7
Click [Next].
8
In the subsequent window, select “CD-ROM
drives” only, and then click [Next].
3
4
5
Select “Automatic search for a better driver
(Recommended),” and then click [Next].
Windows Me should be able to locate the driver
automatically, in which case you can proceed to Step 5. If
the driver cannot be located, select “Specify the location of
the driver (Advanced),” click [Next], specify your CDROM drive (e.g., D:\USBdrv_), and then continue as
prompted.
The following window appears when the installation is
complete.
Select “Search for a suitable driver for my device
(Recommended),” and then click [Next].
NOTE: You may be prompted to insert your Windows
CD-ROM. Do not insert it! Click [OK], and in the “Copy files
from” section of the subsequent dialog box, enter
“D:\USBdrv2k_” (replacing “D” with the drive letter of your
CD-ROM drive), and then click [OK].
The driver is installed, and the message “Completing the
Found New Hardware Wizard” appears.
9
Click [Finish], and then restart your computer.
Click [Finish], and then restart your computer.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
7
ENGLISH
Windows Me
Windows XP
1
Start your computer to launch Windows, then log
in as Administrator.
2
Insert the included CD-ROM into your computer’s
CD-ROM drive.
3
Click the [Start] button, and then click [Control
Panel].
The following window appears.
Installing Yamaha CBX Driver
(DM2000/02R96 only)
If you’re connecting your Yamaha mixing console to a serial port
on your computer, you’ll need to install the Yamaha CBX driver.
If you already have this driver installed, skip this section.
1
Double-click the “Mididrv_” folder on the
CD-ROM.
2
3
Double-click “Setup.exe.”
Follow the on-screen instructions to install the
software.
Installing an Editor
You must install an Editor that supports your console before you
install Studio Manager.
4
Click [Switch to Classic display] in the left column
in the window to display all items in the Control
Panel.
5
Go to System Hardware–>Driver signatures–
>Driver signature options, select “Ignore—Install
software without asking for confirmation,” and
then click [OK].
6
Click [OK] to close the “System Properties”
window, and then click the Close button to close
the “Control Panel” window.
7
Turn off your Yamaha mixing console, and then
use a USB cable to connect its USB TO HOST port
to a USB port on your computer.
8
Turn on your Yamaha mixing console.
The “Found New Hardware Wizard” appears.
9
Select “Install software automatically
(recommended) (I),” and then click [Next].
The driver is installed, and the message “Completing the
Found New Hardware Wizard” appears.
10
1
2
Double-click the “SM_” folder on the CD-ROM.
3
4
Double-click “Setup.exe.”
Double-click the folder for the mixing console
you’re using (for the DM2000, this is “DM2K_”).
Follow the on-screen instructions to install an
Editor that supports your console.
Installing Studio Manager
After you install an Editor, install Studio Manager.
NOTE: If you install an Editor and Studio Manager that support
another device, an older version of Studio Manager may be installed
and Studio Manager may not operate correctly. In this case, install
the correct version of Studio Manager from this CD-ROM, or
download the latest version of Studio Manager from the Yamaha
website.
1
2
3
4
Double-click the “SM_” folder on the CD-ROM.
Double-click the “SM2_” folder.
Double-click “Setup.exe.”
Follow the on-screen instructions to install Studio
Manager.
Click [Finish], and then restart your computer.
Installing Card Filer (DM2000 only)
1
2
3
8
Double-click the “Card_” folder on the CD-ROM.
Double-click “Setup.exe.”
Follow the on-screen instructions to install the
software.
For information on using Card Filer, see the
“CardFilerManual.pdf.” This file is installed in the same
folder as Card Filer.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
USB MIDI Driver
If you’re connecting your Yamaha mixing console to a USB port
on your computer, you’ll need to install the Yamaha USB driver.
If you already have this driver installed, skip this section.
Adobe Reader
Computer
NOTE: Adobe Reader is not required if you’re using Mac OS X.
Adobe Reader (available free of charge) must be installed on
your computer in order to view the PDF format manual for
Card Filer. If you don’t have Adobe Reader, access the Adobe
Corporation website at the URL shown below, and download
Adobe Reader.
http://www.adobe.com
OMS (Open Music System)
NOTE: If you are planning to use only Studio Manager, you do not
need to install OMS. Install OMS to use MIDI applications other
than Studio Manager.
Studio
Manager
USB cable
Driver
Yamaha
mixing console
The procedure for installing the USB driver varies with different
Macintosh OS versions.
• Mac OS 8.6 – 9.2.2: See below.
• Mac OS X: See page 10.
Mac OS 8.6 – 9.2.2
NOTE: This USB MIDI driver is required for MIDI
applications other than Studio Manager. Studio Manager
supports Mac OS X 10.2 or later, but not earlier. To use Studio
Manager, install the USB MIDI driver for Mac OS X.
OMS enables you to use MIDI applications on a Macintosh
computer with Mac OS 9 or earlier. If you already have OMS
2.3.3 or later installed, skip this section.
1
Start your Macintosh, and then insert the included
CD-ROM into your computer’s CD-ROM drive.
1
Double-click the “Mac OS 9” folder on the CDROM.
2
Double-click the “Mac OS 9” folder on the CDROM.
2
Double-click the “USBdrv_” folder on the
CD-ROM.
3
4
5
Double-click the “OMS_” folder on the CD-ROM.
3
Double-click “Install USB MIDI Driver.”
The “Install USB MIDI Driver” window appears, as shown
below.
6
When the installation is complete, click [Restart].
Double-click “Install OMS 2.3.8.”
Follow the on-screen instructions to install the
software.
NOTE: Once the installation is complete, you may receive an
error message warning that the installer did not quit. In this
case, choose [Quit] from the [File] menu to quit the installer,
then restart your computer.
7
Copy the “OMS_2.3_Mac.pdf” from the “OMS_”
folder on the CD-ROM to the “Opcode:OMS
Applications” folder on your hard disk.
This file contains information on using and configuring
OMS.
Normally there’s no need to set the Install Location,
because the startup disk is selected by default. To select
another disk, click the [Switch Disk] button.
Although you can select a destination folder from the
pop-up menu, the files are installed in the specified disk’s
System Folder regardless, so you can ignore that option.
4
Click [Install], and follow the on-screen
instructions to install the software.
5
When the installation is complete, click [Restart].
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
9
ENGLISH
Macintosh Installation
Mac OS X
6
Click [Continue].
The “Select a Destination” is displayed.
7
Select a destination for the driver installation,
then click [Continue].
A window opens, displaying the message “Click install to
perform a basic installation of this software.”
The message “Installing this software requires 100MB of
disk space” may appear. However, the actual required free
disk space is specified in the “Macintosh System
Requirements” on page 6.
8
Click [Install].
If the driver has already been installed, the [Upgrade]
button is displayed instead of the [Install] button.
The driver is installed, and message “The software was
successfully installed” is displayed.
9
Click the [Close] button.
The driver installation is complete.
You can check the following locations to confirm that the
driver has been installed:
• Library -> Audio -> MIDI Drivers -> YAMAHAUSBMIDIDriver.plugin
• Library -> PreferencePanes -> YAMAHAUSBMIDIPatch.prefPane
NOTE: Before installing the driver, disconnect any USB devices
(other than the keyboard and mouse) from the computer.
1
Start your computer, then log in as Administrator.
To confirm that the Administrator account is available,
select [System Preferences], then [Users (Account)].
2
Double-click the “Mac OS X” folder on the CDROM.
3
4
Double-click the “USBdrv_” folder.
5
10
Double-click “USB-MIDI Driver v1. *****.mpkg”
(***** represents the version number).
An “Authenticate” window opens, prompting the
password.
If the window does not prompt you to enter the password,
click the lock icon.
Enter the password for the Administrator’s
account. If you have not set the password, click
[OK].
The “Welcome to the YAMAHA USBMIDI Driver
Installer” window is displayed.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
Setting Up OMS
You must install an Editor that supports your console before you
install Studio Manager.
The “OMS Setup for YAMAHA” folder on the included
CD-ROM contains OMS studio setup files preconfigured for use
with your Yamaha mixing console.
1
Double-click the “Mac OS X” folder on the CDROM.
2
3
Double-click the “SM_” folder.
4
Double-click “Install xxxxx_Editor” (“xxxxx”
represents the name of the console).
5
Follow the on-screen instructions to install an
Editor that supports your console.
1
Turn off your Yamaha mixing console, and then
use a USB cable to connect its USB TO HOST port
to a USB port on your computer.
If you are connecting to the SERIAL TO HOST port, use a
serial cable to connect to the Printer or Modem port on
your computer.
2
3
Turn on your Yamaha mixing console.
4
Double-click the “Mac OS 9” folder on the CDROM.
5
6
Double-click the “OMS_” folder on the CD-ROM.
7
Copy the appropriate file to your computer’s hard
disk, and then double-click it.
Double-click the folder for the mixing console
you’re using (for the DM2000, this is “DM2K_”).
Installing Studio Manager
After you install an Editor, install Studio Manager.
NOTE: If you install an Editor and Studio Manager that support
another device, an older version of Studio Manager may be installed
and Studio Manager may not operate correctly. In this case, install
the correct version of Studio Manager from this CD-ROM, or
download the latest version of Studio Manager from the Yamaha
website.
1
2
3
4
5
Double-click the “Mac OS X” folder on the CDROM.
Double-click the “SM_” folder.
OMS Setup starts and the “Studio Setup file” window
appears.
Double-click “Install Studio Manager.”
Installing Card Filer (DM2000 only)
1
Double-click the “Mac OS 9” folder on the CDROM.
2
3
4
Double-click the “Card_” folder on the CD-ROM.
Double-click “Install Card Filer.”
Double-click the “OMS Setup for YAMAHA”
folder.
This folder contains the following OMS studio setup files:
• ****-USB
• ****-Modem
• ****-Printer
(**** will be the model name)
NOTE: If the AppleTalk dialog box appears, click the [Turn It
Off] button, and then click [OK] on the subsequent dialog box.
Double-click the “SM2_” folder.
Follow the on-screen instructions to install Studio
Manager.
Start your Macintosh, and then insert the included
CD-ROM into your computer’s CD-ROM drive.
8
Choose [Make Current] from the [File] menu, and
then save the setup.
NOTE: If the console is connected to the computer’s Modem or
Printer port, from the [Edit] menu select [Preferences], then
select “Use Apple SerialDMA driver when available.”
After completing the above setup, your Yamaha mixing
console will be the only MIDI device in the current OMS
studio setup. In order to use other MIDI devices, or to add
an additional Yamaha mixing console, you must create a
new studio setup. See the “OMS_2.3_Mac.pdf” for more
information.
Follow the on-screen instructions to install the
software.
For information on using Card Filer, see the
“CardFilerManual.pdf.” This file is installed in the same
folder as Card Filer.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
11
ENGLISH
Installing an Editor
Getting Started
Overview of Studio Manager
Studio Manager is a cross-platform application that enables you to start multiple Editors that control YAMAHA
hardware products remotely, and to save multiple Editor settings.
You can run Studio Manager as a stand-alone application, or as a plug-in within supported DAW (digital audio
workstation) / sequencer applications, such as Cubase SX 3.0.1 or later. In either case, the basic functionality is the
same. For the latest information on compatible DAW applications, refer to the following website.
http://www.studioconnections.org/
Hardware products
Open an editor from
Studio Manager
Synchronize
DM2000
DM2000 Editor application
Synchronize
Studio Manager
Start up Studio
Manager in
stand-alone form
Open from a
compatible DAW
application
DM1000
DM1000 Editor
application
Synchronize
SPX2000
SPX2000 Editor application
The settings of each editor can be saved and recalled together from Studio Manager or the DAW application. In other
words, you can change the settings of your entire system in a single operation by recalling the settings for multiple
devices from Studio Manager or your DAW application.
12
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
Starting and setting up Studio Manager
1
You’ll need to perform the following setup in order to use the editors in Studio Manager.
Start up Studio Manager.
As a stand-alone application in Windows 2000/XP: Click the [Start] button, place your
mouse cursor over [Programs (All Programs)] -> [YAMAHA Studio Manager], then click [Studio
Manager].
As a stand-alone application in Mac OS X: Open folders in the order of “Appears” ->
“YAMAHA” -> “Studio Manager,” and double-click “SM2.”
With Cubase SX: From Cubase SX’s [Device] menu, choose [Yamaha Studio Manager] to open the
Studio Manager window. (Studio Manager starts running when Cubase SX is started.)
2
Set up Studio Manager.
For details, refer to the PDF format Studio Manager manual.
3
Start up each editor.
In the Studio Manager window, double-click the icon for each editor.
Studio Manager window
4
Set up each editor.
For details, refer to the PDF manual for each editor.
5
Synchronize each editor with your mixing console.
For details, refer to the PDF manual for each editor.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
13
ENGLISH
When you want to save setting files, you can do this from Studio Manager to recall multiple devices at once, or from
an individual Editor to recall only a specific device. When you save your settings in your DAW application, the Studio
Manager settings will also be saved together with the DAW application file, and can also be recalled in the same way.
To use Studio Manager, you must first perform the following operations:
1. Start and configure Studio Manager (see below).
2. Start and configure an Editor.
3. Synchronize the application with the corresponding device.
For more information on using the Editors, refer to the Owner’s Manual for the Editors.
Troubleshooting
Q: Cannot install Studio Manager?
A: Check the system requirements for Studio Manager (on page
5 for a Windows machine, or on page 6 for a Macintosh
computer). If the computer’s operating system does not
satisfy the system requirements, you cannot install the
software.
Q: The console is unable to communicate with
Studio Manager via USB.
A: Have you installed the Yamaha USB MIDI driver (Windows
page 5, Mac page 9)?
A: Is the USB cable connected correctly (page 5)?
A: Is your Yamaha mixing console configured correctly
(page 5)?
A: Is Studio Manager set to the correct ID (page 5, the manual
for each editor)?
A: If a USB hub is connected between the console and the
computer, remove it and connect the console directly to the
computer.
A: Mac OS 9 or earlier: Is OMS configured correctly (page 11)?
On some systems, the included OMS studio setup files may
not work correctly. In this case, you must create a new
studio setup. See the “OMS_2.3_Mac.pdf” for more
information.
Q: Cannot install the Yamaha USB MIDI Driver?
A: Is the USB cable connected correctly (page 5)?
A: Try disconnecting the USB cable, and then reconnecting it.
A: Windows: Is USB enabled? When your Yamaha mixing
console is connected to your computer for the first time, if
the “Add New Hardware Wizard” doesn’t appear, it may be
because your computer’s USB controller is disabled. To
check this, open the System control panel, click the Device
Manager tab, and check for any crosses (x) or exclamation
points (!) next to the “Universal Serial Bus controllers” and
“USB Root Hub” items. If these items do have these marks
next to them, your USB controller is disabled. For
information on enabling your USB controller, refer to your
computer’s documentation.
A: Windows: If for some reason installation of the Yamaha USB
Driver fails, your Yamaha mixing console may be registered
as an unknown device and you may not be able to reinstall
the driver until the unknown device is deleted. In this case,
open the System control panel, click the Device Manager tab,
and select the “View devices by connection” option. If an
item called “Other devices” appears in the list, click it. If
there’s an item called “Unknown device,” select it and then
click the Remove button. Disconnect the USB cable,
reconnect it, and then try reinstalling the driver again.
Q: OMS stops working after installing the
Yamaha USB MIDI Driver?
A: Mac OS 9 or earlier: The Yamaha USB MIDI Driver
supports Mac OS 8.6 through 9.2.2. If you install it on a
computer that is running an earlier version of the Mac OS,
OMS will not work correctly. In this case you should remove
the Yamaha USB MIDI Driver as explained below.
Q: How to remove & reinstall the Yamaha USB
MIDI Driver
A: Windows 98/Me: Presuming that the Yamaha USB MIDI
Driver was installed successfully, and that your Yamaha
mixing console has been recognized correctly, the driver can
be removed from your computer as follows. Open the
System control panel, click the Device Manager tab, select
14
the “YAMAHA USB MIDI Driver,” and then click the
[Remove] button. After deleting the following files,
disconnect the USB cable, reconnect it, and then reinstall the
driver again.
Windows\Inf\Other\YAMAHA****.INF (**** will be the
model name)
Windows\System\Xgusb.drv
Windows\System\Ymidusb.sys
A: Mac OS 9 or earlier: The driver can be removed from your
computer by deleting the following files, after which you
should restart your computer, reinstall the driver, and then
set up OMS.
System Folder:Control Panels:YAMAHA USB MIDI Patch
System Folder:Extensions:USB YAMAHA MIDI Diver
System Folder:OMS Folder:YAMAHA USB MIDI OMS
Driver
A: Mac OS X: When you delete the following files, the driver
will be removed. After removing the driver, restart the
computer and re-install the driver.
— -> Library -> Preferences ->
jp.co.yamaha.USBMIDIDriver.plist (This file is created after
the driver is loaded.)
Library -> Audio -> MIDI Drivers ->
YAMAHAUSBMIDIDriver.plugin
Library -> PreferencePanes ->
YAMAHAUSBMIDIPatch.prefPane
Note: “—” represents folders for users in the Users folder on the
hard disk.
Note: Only root users can delete the driver. Most users are not
authorized to delete the driver.
Q: The system fails to function correctly.
A: Make sure that the console’s system software is version 2.0 or
later. If the version is older than 2.0, the correct operation of
the console along with Studio Manager is not guaranteed.
A: If your computer seems unresponsive, make sure it satisfies
the system requirements (Windows page 4, Mac page 4).
A: Quit any other applications that you are not using.
Q: After I installed a new editor, a different
editor will no longer start up.
A: For some combinations of versions of Studio Manager and
the various editors, an editor may not start up. Please
download the latest versions from the website, and reinstall
the latest versions of all editors.
http://www.yamahaproaudio.com/
Q: Studio Manager windows seem to open
slowly. How can I achieve better performance?
A: Windows: If you are using a laptop computer, turning off
the hardware accelerator may improve system performance.
Note that this accelerator setting affects the performance of
other application programs.
1. In the Control Panel, double-click [Display] to open the
“Display Properties” panel.
2. Click the Settings tab, then click [Advanced] to open the
detailed properties panel.
3. Click the Troubleshoot tab, then set the “Hardware
Acceleration” option to “None.”
Q: Cannot suspend or resume your computer?
A: Windows: Suspend will not work if there are any MIDI
applications open.
A: Windows 2000: Depending on your system’s USB controller,
suspend and resume may not work properly. If your Yamaha
mixing console does stop responding, try disconnecting and
reconnecting the USB cable.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
PLEASE READ THIS SOFTWARE LICENSE AGREEMENT (“AGREEMENT”) CAREFULLY BEFORE USING THIS SOFTWARE. YOU ARE
ONLY PERMITTED TO USE THIS SOFTWARE PURSUANT TO THE
TERMS AND CONDITIONS OF THIS AGREEMENT. THIS AGREEMENT
IS BETWEEN YOU (AS AN INDIVIDUAL OR LEGAL ENTITY) AND
YAMAHA CORPORATION (“YAMAHA”).
BY breaking the seal of this package YOU ARE AGREEING TO BE BOUND
BY THE TERMS OF THIS LICENSE. If you do not agree with the terms, do
not install, copy, or otherwise use this software.
1. GRANT OF LICENSE AND COPYRIGHT
Yamaha hereby grants you the right to use the software program(s) and data
(“SOFTWARE”) accompanying this Agreement. The term SOFTWARE shall
encompass any updates to the accompanying software and data. The SOFTWARE is owned by Yamaha and/or Yamaha’s licensor(s), and is protected by
relevant copyright laws and all applicable treaty provisions. While you are
entitled to claim ownership of the data created with the use of SOFTWARE,
the SOFTWARE will continue to be protected under relevant copyrights.
• You may use the SOFTWARE on your computer(s).
• You may make one or reasonable copies of the SOFTWARE in machinereadable form for backup purposes only, if the SOFTWARE is on media
where such backup copy is permitted. On the backup copy, you must
reproduce Yamaha’s copyright notice and any other proprietary legends
that were on the original copy of the SOFTWARE.
• You may permanently transfer to a third party all your rights in the SOFTWARE, provided that you do not retain any copies and the recipient reads
and agrees to the terms of this Agreement.
2. RESTRICTIONS
• You may not engage in reverse engineering, disassembly, decompilation or
otherwise deriving a source code form of the SOFTWARE by any method
whatsoever.
• You may not reproduce, modify, change, rent, lease, or distribute the
SOFTWARE in whole or in part, or create derivative works of the
SOFTWARE.
• You may not electronically transmit the SOFTWARE from one computer
to another or share the SOFTWARE in a network with other computers.
• You may not use the SOFTWARE to distribute illegal data or data that violates public policy.
• You may not initiate services based on the use of the SOFTWARE without
permission by Yamaha Corporation.
Copyrighted data, including but not limited to MIDI data for songs, obtained
by means of the SOFTWARE, are subject to the following restrictions which
you must observe.
• Data received by means of the SOFTWARE may not be used for any commercial purposes without permission of the copyright owner.
• Data received by means of the SOFTWARE may not be duplicated, transferred, or distributed, or played back or performed for listeners in public
without permission of the copyright owner.
• The encryption of data received by means of the SOFTWARE may not be
removed nor may the electronic watermark be modified without permission of the copyright owner.
3. TERMINATION
This Agreement becomes effective on the day that you receive the SOFTWARE and remains effective until terminated. If any copyright law or
provisions of this Agreement is violated, the Agreement shall terminate automatically and immediately without notice from Yamaha. Upon such
termination, you must immediately destroy the licensed SOFTWARE, any
accompanying written documents and all copies thereof.
4. LIMITED WARRANTY ON MEDIA
As to SOFTWARE sold on tangible media, Yamaha warrants that the tangible
media on which the SOFTWARE is recorded will be free from defects in
materials and workmanship under normal use for a period of fourteen (14)
days from the date of receipt, as evidenced by a copy of the receipt. Yamaha’s
entire liability and your exclusive remedy will be replacement of the defective
media if it is returned to Yamaha or an authorized Yamaha dealer within
fourteen days with a copy of the receipt. Yamaha is not responsible for replacing media damaged by accident, abuse or misapplication. TO THE FULLEST
EXTENT PERMITTED BY LAW, YAMAHA EXPRESSLY DISCLAIMS ANY
IMPLIED WARRANTIES ON THE TANGIBLE MEDIA, INCLUDING THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE.
5. DISCLAIMER OF WARRANTY ON SOFTWARE
You expressly acknowledge and agree that use of the SOFTWARE is at your
sole risk. The SOFTWARE and related documentation are provided “AS IS”
and without warranty of any kind. NOTWITHSTANDING ANY OTHER
PROVISION OF THIS AGREEMENT, YAMAHA EXPRESSLY DISCLAIMS
ALL WARRANTIES AS TO THE SOFTWARE, EXPRESS, AND IMPLIED,
INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NON-INFRINGEMENT OF THIRD PARTY RIGHTS. SPECIFICALLY, BUT
WITHOUT LIMITING THE FOREGOING, YAMAHA DOES NOT WARRANT THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS,
THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE SOFTWARE
WILL BE CORRECTED.
6. LIMITATION OF LIABILITY
YAMAHA’S ENTIRE OBLIGATION HEREUNDER SHALL BE TO PERMIT
USE OF THE SOFTWARE UNDER THE TERMS HEREOF. IN NO EVENT
SHALL YAMAHA BE LIABLE TO YOU OR ANY OTHER PERSON FOR
ANY DAMAGES, INCLUDING, WITHOUT LIMITATION, ANY DIRECT,
INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES, EXPENSES,
LOST PROFITS, LOST DATA OR OTHER DAMAGES ARISING OUT OF
THE USE, MISUSE OR INABILITY TO USE THE SOFTWARE, EVEN IF
YAMAHA OR AN AUTHORIZED DEALER HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. In no event shall Yamaha’s total liability to you for all damages, losses and causes of action (whether in contract,
tort or otherwise) exceed the amount paid for the SOFTWARE.
7. THIRD PARTY SOFTWARE
Third party software and data (“THIRD PARTY SOFTWARE”) may be
attached to the SOFTWARE. If, in the written materials or the electronic data
accompanying the Software, Yamaha identifies any software and data as
THIRD PARTY SOFTWARE, you acknowledge and agree that you must
abide by the provisions of any Agreement provided with the THIRD PARTY
SOFTWARE and that the party providing the THIRD PARTY SOFTWARE is
responsible for any warranty or liability related to or arising from the THIRD
PARTY SOFTWARE. Yamaha is not responsible in any way for the THIRD
PARTY SOFTWARE or your use thereof.
• Yamaha provides no express warranties as to the THIRD PARTY SOFTWARE. IN ADDITION, YAMAHA EXPRESSLY DISCLAIMS ALL
IMPLIED WARRANTIES, INCLUDING BUT NOT LIMITED TO THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE, as to the THIRD PARTY SOFTWARE.
• Yamaha shall not provide you with any service or maintenance as to the
THIRD PARTY SOFTWARE.
• Yamaha is not liable to you or any other person for any damages, including, without limitation, any direct, indirect, incidental or consequential
damages, expenses, lost profits, lost data or other damages arising out of
the use, misuse or inability to use the THIRD PARTY SOFTWARE.
8. GENERAL
This Agreement shall be interpreted according to and governed by Japanese
law without reference to principles of conflict of laws. Any dispute or procedure shall be heard before the Tokyo District Court in Japan. If for any reason
a court of competent jurisdiction finds any portion of this Agreement to be
unenforceable, the remainder of this Agreement shall continue in full force
and effect.
9. COMPLETE AGREEMENT
This Agreement constitutes the entire agreement between the parties with
respect to use of the SOFTWARE and any accompanying written materials
and supersedes all prior or contemporaneous understandings or agreements,
written or oral, regarding the subject matter of this Agreement. No amendment or revision of this Agreement will be binding unless in writing and
signed by a fully authorized representative of Yamaha.
Studio Manager V2 Installation Guide (for DM2000/02R96/DM1000/01V96)
15
ENGLISH
SOFTWARE LICENSING
AGREEMENT
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising