PLS - Graph User`s Guide Version 3.0 Wynne W. Chin

PLS - Graph User`s Guide Version 3.0 Wynne W. Chin
A1
A2
PLS -
Graph User’s
Guide
Affect
0.32
0.35
Belief of Ease
of Use
A3
0.24
Belief of
Relative
Advantage
0.41
0.26
E1
R2
R3
R1
Intention To
Adopt an IT
0.45
R2
R3
I1
I2
I3
Interaction btwn
Affect & Relative
Advantage
I1*A1
I2*A2
I3*A3
I2*A1
I2*A2
I3*A2
I1*A3
I2*A3
I3*A3
Version 3.0
Wynne W. Chin
PLS-Graph User’s Guide, Version 3.0, February, 2001 edition Wynne W. Chin (author)
Copyright Notice
©1993–2001. Soft Modeling Inc. All rights reserved worldwide. No part of this publication may be
reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language or
computer language, in any form or any means, electronic, mechanical, magnetic, optical, chemical,
manual or otherwise without the express written permission of Soft Modeling Inc.
SOFT MODELING SOFTWARE LICENSE AGREEMENT
The following constitutes the terms of the License Agreement between a single user (User) of this software
package, and the producer of the package, Soft Modeling, Inc. (called Soft Modeling hereafter). By
opening the package, you (the User) are agreeing to become bound by the terms of this agreement.
If you do not agree to the terms of this agreement do not open the package, and contact the Soft Modeling
Customer Service Department at a local Soft Modeling office (or an authorized Soft Modeling reseller) in
order to obtain an authorization number for the return of the package. This License Agreement pertains
also to all third party software included in or distributed with Soft Modeling products.
License
Unless explicitly stated on the program media (CD or disks), the enclosed software package are sold to be
used on one computer system by one user at a time. This License Agreement explicitly excludes renting
or loaning the package. Unless explicitly stated on the program media, this License Agreement explicitly
excludes the use of this package on multi-user systems, networks, or any time-sharing systems.
(Contact Soft Modeling concerning Multi-user License Programs.) The user is allowed to install the
software package on a hard disk and make a backup copy for archival purposes. However, the software
will never be installed on more than one hard disk at a time. The documentation accompanying this
software package (or any of its parts) shall not be copied or reproduced in any form.
Disclaimer of Warranty
Although producing error free software is obviously a goal of every software manufacturer, it can never be
guaranteed that a software program is actually free of errors. Business and scientific application software
is inherently complex (and it can be used with virtually unlimited numbers of data and command settings,
producing idiosyncratic operational environments for the software); therefore, the User is cautioned to
verify the results of his or her work. This software package is provided "as is" without warranty of any
kind. Soft Modeling and distributors of Soft Modeling software products make no representation or
warranties with respect to the contents of this software package and specifically disclaim any implied
warranties or merchantability or fitness for any particular purpose.
In no event shall Soft Modeling be liable for any damages whatsoever arising out of the use of, inability to
use, or malfunctioning of this software package. Soft Modeling does not warrant that this software
package will meet the User's requirements or that the operation of the software package will be
uninterrupted or error free.
i
Limited Warranty
If within 30 days from the date when the software package was purchased (i.e., invoice date), the program
media (CD or disks) are found to be defective (i.e., they are found to be unreadable by the properly aligned
media drive of the computer system on which the package is intended to run), Soft Modeling will replace
the media free of charge. After 30 days, the User will be charged for the replacement a nominal disk
replacement fee.
If within 30 days from the date when the software package was purchased (i.e., invoice date), the software
package was found by the User not capable of performing any of its main (i.e., basic) functions described
explicitly in promotional materials published by Soft Modeling, Soft Modeling will provide the User with
replacement media free of defects (or a replacement component downloadable from the Soft Modeling
WEB site),
or if the replacement cannot be provided within 90 days from the date when Soft Modeling was notified by
the User about the defect, the User will receive a refund of the purchasing price of the software package.
Updates, Corrections, Improvements
The User has a right to purchase all subsequent updates, new releases, new versions, and modifications of
the software package introduced by Soft Modeling for an update fee or for a reduced price (depending on
the scope of the modification); however, purchasing an update or upgrade (for a reduced price) constitutes
a replacement of an existing license and not acquisition of a new license.
Soft Modeling is not obligated to inform the User about new updates, improvements, modifications, and/or
corrections of errors introduced to its software packages. In no event shall Soft Modeling be liable for any
damages whatsoever arising out of the failure to notify the User about a known defect of the software
package.
ii
PREFACE
PLS-Graph represents an attempt to make latent variable path modeling using the Partial Least
Squares (PLS) approach accessible and convenient to all interested parties. The utility of the PLS method
has been documented elsewhere (Chin, 1998; Chin & Newsted, 1999; Falk and Miller, 1992) as possibly
more appropriate for a large percentage of the studies and data sets typically used among researchers. As
opposed to covariance-based approaches (exemplified by software such as LISREL or EQS), PLS places
much less restrictions on matters such as sample size and data distributions. While the most widely
available program developed by Lohmoller (1984) has a great deal of functionality and is available at
reasonable cost, its ease of use can be extremely daunting to the initial user.
In order to increase the usablility and accessibility of the PLS approach, PLS-Graph was developed
as a self contained Graphical User Interface (GUI) based software which creates input decks compatible
with the existing PLSX program developed by Lohmoller. PLS-Graph allows the user to focus more on
the appropriateness of the model and data set rather than on how to get the program to run. Our
experiences have shown that using PLS-Graph has decreased the time to complete a PLS analysis over
ten-fold compared to other existing programs.
We hope that you agree.
Wynne Chin & Tim Frye (developers)
iii
PLS-Graph User Manual
Introduction
PLS-Graph is a Windows based graphical user interface that assists in performing PLS analyses. The
program assists in generating PLSX (version 1.8) compatible command files. PLS-Graph can then be
used to process the command file to create an output file containing the results of the analysis as specified
by the command file. PLS-Graph allows you to view the results file in a scrollable window or
alternatively extract some of the results back into the same graph used to generate the PLSX command
file. By using a consistent two button mouse metaphor, the user can quickly depict a theoretical model in
a graphical representation consistent with the Partial Least Squares method of structural equations
modeling with latent variable (i.e., relationships among latent variables and their respective indicators),
process the model, and display the results all within a graphical user environment.
Installation.
(This procedure need only be performed once)
1. Double click the file Plsgraph.exe The entire installation occupies approximately 1 Meg.
2. The default directory of c:\Program Files\plsgraph will present itself. While you can specify a new
directory, we recommend that you use the default in order to be consistent with the example files which
expect the data files to reside in this directory.
3. The result should be a new icon in your new PLS-Graph group window.
4. Licensed users need to copy the “license.dat” file into the plsgraph directory.
Test Run
1. Start-up the PLS-Graph program by either clicking on the icon, running from the program menu, or
clicking on the plsgraph.exe file in the plsgraph directory. The result is shown in Figure 1.
2. Move you cursor to the Top left menu item labeled File – click and select Open (see Figures 2 and 3).
3. Move the floating Menu titled “PLS Graph Tools” (by clicking the label and dragging the menu) to
uncover the floating Menu titled “PLS Functions” (see Figure 5).
4. Click the far left icon in the “PLS Functions” menu with the three squares to run the model and extract
the results back into the graph (see Figure 6). If the software is working, you should obtain results as
depicted in Figure 7.
1
Figure 1. Initial Workspace.
Figure 2. Menu option to select an existing Graph file.
2
Figure 3. Select existing graph file wynne.gph.
Figure 4. Wynne.gph graph file.
3
Figure 5. Moving Floating Tools Menu.
Figure 6. Result from Clicking “Generate Extract” icon in the Floating Functions menu.
4
Figure 7. Resulting parameter estimates in graph after clicking the ok button.
Creating a Raw Data File
The raw data file from which the PLS-Graph program draws from to create a PLSX deck should be set up
as follows:
1. Plain ASCII file with the names of the variables first followed by each data case in the same
order as the variables listed (missing data points should be imputed a-priori or given a code such as –
99). An error message will occur if the number of numeric data points counted is not an even multiple
of the variables listed.
2. Variable names and numeric data should be separated from each other by at least one or mores
spaces or tabs.
3.
There should be no blank lines anywhere within the raw data file.
4. Variable names can be written up to 32 characters (as long as it is a continuous name using any
alphabetic or underscore character).
5. You may wish to have the suffix of your raw data file designated as .raw (this is the default
assumption in PLS-Graph).
5
Starting Up PLS-Graph
1.
Double click your PLS-Graph icon to start up the program.
2.
To exit the program anytime, select the File option at the top menu and then select Exit.
3. To increase the work area to the entire screen, click at the upper right corner of the PLS-Graph
window displaying the upward pointing arrow head pointing.
Creating a New Graph
At start-up, you are placed in a new work area to create a graph. Otherwise, go to the File Menu and
select the New option.
Floating Tools Menu
This item is used to create your graph. This floating Menu titled PLS Graph Tools always appears upon
startup of the program. To hide it, you need to go up to the Top menu item titled View and select the
Tools option. You can move this menu anywhere in work area by moving the cursor to the menu title
(PLS Graph Tools), pressing and holding down the left mouse button, and then “dragging” the menu to its
new location. To select any option, move your cursor to that particular option and click the left mouse
button.
1.
Select Option:
This option is the leftmost one in the menu. This is the default option which allows you to select objects
in your graph for further action. Choosing another option from the Menu allows you to perform that
particular function once before automatically going back to this option. If you don't like this automatic
return to select mode, you can disable this feature by moving to the Top menu item titled Preferences and
select the Select On option. To select an object, move your cursor to the object and click your mouse
button. To select multiple objects, press down on the Shift key on your keyboard as you select an object.
Alternatively, press your mouse button and drag your mouse down and to the right to create a box to
outline the area where all objects are to be selected.
2.
Zooming option:
This option allows you to magnify or shrink the graph on your monitor. Choose this option and then click
the left mouse button within the work area to shrink the graph by 10 percent. Clicking the right button
increases the graph by 10 percent. You can always go back to normal size by going to the View option at
the top menu and selecting the normal size option. An alternate method is to place your cursor on the
upper left corner of the area you wish to magnify. Then press your mouse button and drag your mouse
down and to the right to create a box to outline the area for magnification. Yet another method is
discussed in the section labeled PLS Zoom Box.
3.
Construct option:
This option allows you to create constructs. After selecting this option, move your cursor to where you
wish to place the construct and then click the left mouse button. A circle representing a construct is then
created and given a default label, which you can subsequently change if you desire.
6
4.
Linkage option:
This option allows you to draw path links among constructs or connect indicators to constructs. When
connecting two constructs, you hold the left mouse button down and drag a link from one construct to
another. Upon reaching the second construct, you release the left mouse button. This results in a link with
a directional arrow pointing at the second construct. When connecting an indicator to a construct with
existing indicators, the directionality will automatically align in the same direction as the existing
indicators.
5.
Text option:
This option allows you to create text for display in the graph. It has no impact on the rest of the program.
Floating Functions Menu
This item is used to speed up the process of generating PLSX command files, executing the command
files, and displaying the results. This floating Menu titled PLS Functions always appears upon startup of
the program. To hide it, you need to go up to the Top menu item titled View and select the Execute
option. You can move this menu anywhere in work area by moving the cursor to the menu title (PLS
Functions), pressing and holding down the left mouse button, and then “dragging” the menu to its new
location. To select any option, move your cursor to that particular option and click the left mouse button.
1.
Generate Extract Option:
This leftmost option in the menu is identical to the first option Generate Extract offered by the Top menu
item titled Execute. Once the model is created, raw data file selected, and PLS deck name specified - this
option allows you to generate, run, and extract the results. (See Top Menu - Extract Option section for
further elaboration).
2.
View Option:
This second option is used to look at information in addition to those displayed on the graph. This second
option by default uses Windows Notepad for viewing the detailed results file generated by the PLS-Graph
program. This option is identical to selecting the Results option offered by the Top menu item titled
View. You can use the program of your choice as the editor to view the results files under the top Menu
Preferences: Editor option.
In addition to viewing the standard PLS output files when you click the “A” icon in the PLS Function
floating menu, you can make the editor default to open either the re-sampling output files selecting the
Show *.out option under the Top Menu View item. The default is Show *.lst. This means that you wish
to view the PLS results when you click the View icon (i.e., the icon with the letter A) in the Floating
Menu. If you select Show *.out, clicking the View icon will produce the output from either Jackknife or
Bootstrap (depending whichever re-sampling procedure was last executed).
3.
Extract results Option:
This option allows you to extract the information from the results file into your graph. With higher
dimensional analyses, this option can be used to step through the results for each dimension. This
rightmost option in the menu is identical to the fourth option Extract results offered by the Top menu item
titled Execute. If the results file is consistent with the model graphically displayed, path and R-squared
results can be extracted and displayed into the graph.
7
PLS Zoom Box
This item can be used to navigate throughout your graph and reduce or enlarge your graph. Titled PLS
Zoom, this floating box can be made to appear by going to the Top menu item titled View and selecting
the Zoom option. You can move this object in the same manner as the Floating Tools Menu. Within the
box is a miniature representation of your entire graph. A rectangular box within the Zoom Box represents
the area size of your window.
1. Navigating throughout the graph:
To move to different parts of your graph, you select the rectangular box and drag it to the area of the
graph you wish to move to.
2. Reduce and Enlarge the graph:
Position your cursor to the bottom right corner of the rectangular box. Press and hold down the left mouse
button. At this point, by dragging the cursor diagonally outwards - your enlarge the graph. By dragging
the cursor diagonally inwards - you reduce the graph.
Designating a Raw Data File:
Before linking indicators to constructs, you may wish to designate the raw data file, which you plan to
draw from to create your PLSX deck. To do so, go to leftmost top menu item File and select the Links
option. Then select Data file and choose the particular raw data file. Note the default assumption for raw
data files to choose from end with the suffix .raw. By linking a raw data file, the names of the indicators
will be made available for you to choose from when the time comes for connecting to constructs.
At this point, the minimal specification is to name the Raw Data File (with the suffix .raw). If you give
no other specifications, the other files are automatically specified with the following defaults:
PLS Deck File: Noname01.pls
Bootstrap File: Boot.pls
Jackknife File: Jack.pls
Results Files: PLS Deck File name with the suffix .lst
It should be noted that output from Jackknifing or Bootstrapping are written to Jack.out and Boot.out
(with intermediate results in Jack.lst and Boot.lst). If you give a different main name for the Jackknife or
Bootstrap file, the output name will use the name you give, but ending with the suffix .out.
Designating a PLSX deck File:
At this point you may also wish to designate the name of the PLSX command file to be generated by PLSGraph. To do this, go through the same procedure as designating a raw data file, but choose the PLS deck
option for linking. You may select an existing file name to be overwritten or else create a new name.
Note the default assumption of PLSX deck files to choose from end with the suffix .pls.
Designating a PLSX results File:
You can designate any PLSX results file for viewing. If you don't specify a file name, PLS-Graph will
automatically assume the file name to be the same main body name as the one designated for the deck file,
8
but with the suffix .lst. If you had specified a file name earlier and wish to go back to the automatic
default, enter * as the file name. To view the file you can go to the top menu item titled View and select
the Results option or Floating Functions MenuView icon.
If you plan to specify all the file names at once and wish to avoid selecting each file option, you can
choose the ALL option to Links. Selecting this allows you to specify all the various files to run PLSGraph.
Actions on Objects:
The metaphor used throughout the PLS-Graph program for modeling is to use the left mouse button to
select objects in the graph. Upon selection, a right mouse button click will display the options available
on the object. [At this point, if you are just starting with this program, we suggest you link the raw data
file wynne.raw].
1. Actions Available On a Construct
1.
Create a construct and select it by pointing to it and clicking with your left mouse
button.
2.
If the construct is selected, it should be shaded in red.
3.
Click the right mouse button to see the various options that can be performed on a
construct. They are:
1. Labeling
This allows you to label the construct with up to 32 characters (spaces included).
2. Indicators
A window will occur with three sections. The first represents the construct label. The
second section lists all the indicators that are available for linking to the construct. The
third section lists indicators already linked to the construct. To add or remove indicators
associated with a construct, you must select (highlight) the particular indicators and click
either the Assign or Remove button.
You can use your mouse to do single, multiple contiguous, or multiple discontiguous
selects. Moving the cursor to the name of the indicator and clicking the left mouse button
will accomplish a single select. To select a contiguous group of indicators, move the
cursor to one end (top or bottom) of the list of indicators, press and keep the left mouse
button down as you drag the cursor to the indicator at the other end of the list.
Alternatively, select the beginning indicator, press down on the Shift key as you scroll to
and select the ending indicator. To select a discontiguous set of indicators, keep the
Control key on your keyboard continuously press down as you move your cursor to each
indicator and select through clicking the left mouse button.
Once you have selected the indicators, move your cursor to the Assign or Remove button
and click your mouse.
9
When the appropriate indicators have been assigned or removed, move the cursor to the
OK button and click the left mouse button. The designated indicators should now be
graphically linked with the construct. The default mode is reflective.
3. Reverse link
This option allows you to change the mode of the indicators between reflective to
formative.
4. Toggle indicators
This option allows you to hide the indicators.
5. Blindfold
This option allows you to designate a construct to be blindfolded. It will ask you what the
omission distance should be set at (with a default of 25). Going to another construct
overrides the previous designation. Should you wish to cancel this request - you need to
go up to the top menu under Options item, select the Run option, and go to the slot
marked Blindfold Measure and choose No blindfolding Measures.
6. Deflation
This option allows you to override the global deflation setting for that particular
construct. You need to click off the check mark, which says use global deflation setting
and then select the one you desire.
7. Toggle Ghost Mode
This option allows you to designate the construct and all links associated to it as
temporarily non-existent. When a PLSX deck is generated, processed, and results
displayed - those constructs toggled would not be included. Ghost constructs are shaded
in green. (This feature is currently under development and not working).
2. Actions Available On an Indicator
Select an Indicator by clicking the left mouse button. Shading of the indicator will occur if selected.
Clicking the right mouse button shows two options. They are:
1. Labeling the indicators
This allows you the opportunity to type in the name of the variable you wish to associate with this
indicator. If you have already designated a raw data file, the names in that file will be available
in a scrolling list.
2. Missing value
This action allows you to override the global designated value which indicates what constitutes
missing data. You need to check off the box which says “Use global missing value” and then
specify the particular value to be used locally for this indicator.
10
3. Actions Available On a Path Link Between Constructs
1. Reverse link
(Only between constructs) - This changes the direction of the path between constructs.
2. Toggle label
This toggles the display of path result for that particular path extracted from a PLS results file.
For global display actions, use the View item in the Top Menu.
4. Deleting Objects
You can delete any object by selecting it and then pressing either the Backspace key or Delete key.
Deleting an indicator or construct will also delete any associated path links. Deleting a construct will
also delete any associated indicators.
Top Menu Options:
A.
File item:
This menu item allows for the creation, saving, printing, and opening of existing PLS-Graph files.
For printing, PLS-Graph uses whatever printer setup you have already designated in Windows. The
default assumption regarding the suffix for PLS-Graph files is .gph.
The Links option allows you to designate the files to use or write to. This does not execute any
action. It merely informs the PLS-Graph program where the various files needed for processing exist.
Currently, there are five options to choose. The Data file refers to the Raw Data file as described
earlier. This action allows the PLS-Graph program to determine where the raw data file consisting of
variable names and case values reside. The PLS deck option refers to the name of the file that you
want the PLSX deck to be written to. It can either be an existing deck, which will then be
overwritten, or a new one. The Results option designates the PLS results file which you wish to
extract information from into your PLS-Graph file. The Jackknife and Bootstrap deck (which must
use a different name from the PLS deck file) specifies the file names for performing resampling.
Analysis. The Log file option (not currently available) designates the name of the file the program
will write information concerning various program executions you subsequently generate.
B.
Edit item:
Allows you to cut, copy, or paste PLS-Graph objects to and from the Windows clipboard. You can
paste PLS-Graph objects to other Windows software in either text-based, bitmapped formats, or as a
metafile (under the Paste Special option of most packages). This allows you to move the individual
objects of the graph using the drawing package of your choice. It works quite well under Word 6.0.
We are aware that there are problems when transferring to PowerPoint and for large meta-files. We
would be interested in hearing about whether or not it works with other graphics packages.
11
C.
Tool item:
Identical to the Floating Tools Menu.
D.
View item:
This items allows you to
1. Reset the graph to normal size.
2. Display the entire graph within the working area window.
3. Hide or Display Floating Tools Menu, PLS Zoom Menu, or Results window.
4. Hide or display Help information (which appears on the bottom of the graph)
for Top Menu items
5. Indicate which results file (PLS results or resampling results) is opened when you click the
View icon. The default is Show *.lst. This means that you wish to view the PLS results when
you click the View icon (i.e., the icon with the letter A) in the Floating Menu. If you select
Show *.out, clicking the View icon will produce the output from either Jackknife or Bootstrap
(depending whichever resampling procedure was last executed).
6. Hide or Display path links or R-squared information on endogenous constructs.
7. Redraw Graph. The Redraw option helps overwrite any graphing defects that may occur and
should not appear in your drawing.
E.
Preferences item:
1.
Reset Defaults
This option allows you to set the PLS-Graph program options to their default settings.
2.
Save Current
This option allows you to set your current settings as the default when starting up the program. This
includes all Link options to directories where files are to be accessed or written to, Viewing Options,
and Run and Output settings in the Options item (see below).
3.
Select On
This option allows you to change the response mode for the Floating Tools. The default is to
automatically shift back to the Select button after any Tool button is used. If you wish the default to
stay on a particular button until you decide to click on another one, then you need to select this
option.
4.
Editor
You can use the program of your choice as the editor to view the results files under the Preferences
Menu: Editor option. The default is notepad
12
5.
Font
You can change the font style and sizes of labels for constructs, indicators, and paths under the
Preferences Menu: Font option. The program does not allow you to save any changes at this point in
time - but will in the next release.
6.
Background Color:
You can change the grey background color to white.
F.
Options item:
This menu item represents options available in the PLS program which you can specify when
generating a PLSX deck. The menu is broken into two sections as follows:
1.
Run
Pertains to all the run options available in the PLSX program. In particular, you need to specify the
inner weighting scheme, number of dimensions, stop criterion, iterations, deflation. The program
currently has default settings which you can view upon selecting this option (to change these settings,
use the Save Current option in the Preferences item). In addition, if you choose to perform
blindfolding, the blindfold measure slot allows you to select the particular measure. The blindfold
slot also allows you to cancel the command to perform blindfolding executed at the Construct level.
Three additional features are provided in this section. They are:
A. Case Selection by indicator:
You can choose a particular indicator as a case filter where you decide to select only those cases that
are (greater than, equal, or less than) a particular value.
B. Case Selection by missing value:
Here you choose the option <Missing Value>. When using this in conjunction with greater than,
equal, or less than comparison symbol, you are filtering the data according to how many missing
values you will allow for a particular case. As an example, if you graphed a model with 10
indicators, a <Missing Value> < 4 means that only cases that have 3 or fewer missing values are
written to the PLSX deck.
C. Run Information
If a raw data file has been linked, run information regarding how many cases and variables are
available are presented. In addition, information on the number of constructs in your existing graph
and whether one was chosen for blindfolding are also presented.
D. Global Setting of Missing Values
The use of missing values need to be given a check in the designated box. In the adjacent slot, you
can indicate what the global missing value should be. If a particular indicator uses a different value
to indicate as missing, you need to select that particular indicator in your graph and specify the
appropriate missing value locally.
13
E. Creating a Separate PLSX Data Deck
Placing a check in the Create Separate Data file option alerts PLS-Graph to write the PLSX deck data
to a separate file. The default file will be the same name as you gave for the PLS deck (under the
Linking option), but appended with the suffix *.dat.
F. Append to PLSX Data Deck
Placing a check in the Append Data option alerts PLS-Graph to append additional models to the
designated PLS deck. This is useful if you wish to specify a series of models and run them all in a
batch. Unfortunately, you would not be able to see the results in graphical form. By choosing this
option, you intend to append a series of models by using the Generate PLS deck command in the Top
Menu Execute item command. This is accomplished by drawing executing the Generate PLS deck
command after each model is drawn. You can then process the entire batch by executing the Run PLS
program also located in the Top Menu Execute item.
2. Output
This pertains to all the results information that the PLS-PC program can produce. In addition, this is
where you can include the title and description for each PLSX deck. Default options for output on
Final Results, Each Iteration, Model Specification, and Blindfolding are provided.
There are also two slots to specify the data format for sample cases when generating the PLS deck.
The default is to write the data in a field width of 12 with 2 significant digits. If your raw data
consists of only integers no larger than two digits and no missing values, you can change the setting
to a field width to as small as 3 with 0 significant digits.
3. Resampling
Resampling procedures are used to assess the significance of PLS parameter estimates. In addition to
the Blindfolding option, PLS-Graph incorporates both Jackknife and Bootstrap options.
The default Jackknife case deletion is the traditional number of 1. This means that each jackknife
resample consists of n-1 cases, where n equals the total number of cases in your original sample.
Specifying higher deletion numbers will result in smaller number of resamples, higher critical value
for a particular alpha level, and potential loss in robustness of the t-statistic (Wildt, Lambert, &
Durand, 1982).
The default Bootstrap options are 100 resamples with each sample consisting of the same number of
cases as your original sample set. The bootstrap procedure samples with replacement from your
original sample set. It continues to sample until it reaches the number of cases you specify (or the
default). This procedure is repeated until it reaches the number of bootstrap resamples you specify (or
the default of 100). In general, resamples of 200 tend to provide reasonable standard error estimates.
In comparing the bootstrap to the jackknife, you need to consider the tradeoff between computational
time and efficiency. Jackknife estimation tends to take less time for standard error estimation under
the joint assumption that the bootstrap procedure utilizes a confidence estimation procedure other
than the normal approximation and the number of resamples are larger than those of the jackknife.
14
Conversely, the jackknife is viewed as less efficient than the bootstrap since it can be considered as an
approximation to the bootstrap (Efron & Tibshirani, 1993, pp. 145-146).
Output options for both resampling procedures are available to compensate for arbitrary sign changes
in PLS parameter estimates. The structural path, loadings, and weights obtained from the PLS runs
for the full sample (i.e., original sample cases) and each of the resamples can have arbitrary
differences with regards to the signs. While the magnitudes may be similar, the signs of the linear
composites (i.e., component scores for the constructs) can differ between the full sample and
resamples. The interpretation is that for each particular construct, the directionality of the scores can
be in one of two directions. The component scores may change from one resample run to another
(not unlike transforming a questionnaire item from one direction to the opposite). This tends to
magnify the t-ratios (Wildt, et al., 1982, p. 101).
Checking the Standard Preprocessing Option means you wish to see the resampling statistics without
compensating for potential sign changes.
Selecting the Individual Sign Changes Preprocessing Option will result in aligning the sign of each
resample to be consistent with the sign of the same parameter in your original full sample. The
resulting effect tends to reduce the t-values, which becomes a more conservative test of the parameter
significance (Fornell & Barclay, 1983).
Selecting the Construct Level Changes Preprocessing Option (default option) will result is checking
the vector of loadings for each construct in a resample to the corresponding vector in the full sample.
If the absolute magnitude of the sum of the differences is less than the absolute magnitude of the sum,
the signs for the weights and loadings are reversed. As a result, if the vector signs for only one of the
two constructs that share a structural path changed, the sign of the path is changed. In general, the
results tend to be similar to those using the Individual Sign Change procedure. Differences may
occur where the magnitude of the structural path is close zero. Under this condition, this approach
should produce a more consistent estimate of the t-statistic than that of the Sign Change approach.
Finally, by checking off the Report Changes in the File, those resamples where signs were changed
are identified.
The results of resampling , at present, do not appear in the graph. The output results end in the suffix
*.out with the main name being either the default jack or boot or designated under the Top Menu File
Links option.
The adjusted t-statistic in the jackknife output represents a correction for the possibility of
interdependence between jackknife estimates (i.e., the pseudo values). Using Gray and Schucany
(1972) suggestion, the intraclass correlation r is assumed to equal 1/N where N is the number of
resamples. The resulting effect is to have a more conservative estimate of the t-statistic.
7.
Execute item:
This is where the PLS-Graph commands that generates the PLSX deck, executes the PLS-PC
program, or extracts information from a results file created by the PLS-PC program. If the raw data
file and PLSX file names have been linked, then the option Generate PLS deck can be executed. Run
PLS Program is used to process the PLSX deck. It uses the internal PLS-Graph engine. A new
results file with the suffix .lst is then created. Extract Results will display the path and R-squared
results available in the results file. For higher dimensional models, each execution of this option
allows you to step through results for each dimension. Create graph (not available in the current
15
version, but has been built into the architecture for future development) allows you to generate a
graph from an existing PLSX deck file. Generate, Run, Extract automates the three step procedure of
generating, running, and extracting of results.
The execution of either bootstrapping or jackknifing is accomplished by selecting either Generate
Jackknife or Generate Bootstrap. The current program does not check for free space on your hard
disk. Before resampling you should make sure you have enough room. A quick estimate is to
multiply the size of the PLS deck generated by your model with 2N where N equals the number of
resamples.
Finally, the program currently does not check for errors related to any n dimensional analysis - the
resampling output will likely be trash. In general, you may wish to check the intermediate *.lst file to
guarantee that no errors occurred for any of the resample results.
8.
Help item:
Pertains to on-line information about the PLS-Graph program. This is not implemented in the
current version.
Example Files Provided:
Example Files are provided with the PLS-Graph program. Specifically, Wynne.gph is a PLS-Graph
file which expects to find the raw data file named Wynne.raw in a directory c:\plsgraph and will write
a PLSX deck file named Wynne.PLS. The data set comes from a undergraduate class of 3rd and 4th
year students who have previously taken one MIS course. The items refer to End User Computing
Satisfaction developed by Doll and Torkzadeh ( MIS Quarterly, volume 12, Number2, pp. 274) , 7
semantic differential measures of affect, and 3 measure of intention toward Lotus 123.
Another raw data file named 400var.raw is provided. This file is an artificial set consisting of 9 cases
and 400 variables. The values are numbered to reflect the particular variable and case and may be
helpful to check the processing capabilities of PLS-Graph.
Hints/Shortcuts:
1. When labeling or re-labeling a construct or indicator, double clicking with the left mouse button
will automatically bring you to the labeling menu.
2. Rather than deleting indicators from constructs, you might wish to delete the path link instead.
With the path loading link missing, that particular indicator will not be reflected on the next PLSX
deck generated. But can be re-linked if you so desire thereby eliminating the action of adding and
labeling new indicators.
3.
Link your raw data file first to help you in labeling indicators.
4. Create the constructs and associated indicators first, toggle to hide the indicators, and then draw
the structural paths.
16
Program Limitations
Maximum characters for construct labels are: 500
Maximum characters for indicator labels are: 32
Maximum characters for Output description are: 2000
Maximum file size for Results file viewing is: 32K
Maximum number of indicators allowed are: 30 (student version) & 100 (licensed version)
Maximum number of objects to the clipboard: 200
Maximum sample size allowed are: 9998 cases
Glossary of Terms
Block: a set of indicators linked to a particular construct.
Construct: theoretical concept that is not directly measurable. Also known as latent variables.
Drag: refers to moving a graphical object around. This is accomplished by selecting. an object first. But
instead of clicking and letting go of the left mouse button, you keep the button pressed. In this position,
you can move the object around. Releasing the mouse button places the object at the particular location.
Formative mode: paths connecting construct to indicators are directed towards the construct. Such
constructs are often designated as emergent constructs. Also referred to as mode B.
Indicator: measurable variable used to represent a construct (e.g., item on a questionnaire). Also
referred to as manifest variables, item, indicant.
Inner Model: the structural relationship (i.e., path model) among constructs.
Loading: a path from a construct to an indicator.
Outer Model: the relationships between constructs and their indicators. Often referred to as the
measurement model.
Path: the link between constructs or construct to indicator.
Reflective mode: paths connecting construct to indicators are directed towards the indicators. Such
constructs are often designated as latent constructs. Also referred to as mode A.
Select: refers to using the mouse to position the cursor on a graphical object and clicking on the left
mouse button. The resulting action is to shade the object.
17
References:
Chin, W. W. (1998). The partial least squares approach for structural equation modeling. In George A.
Marcoulides (Ed.), Modern Methods for Business Research, Lawrence Erlbaum Associates, pp. 295-336.
Chin, W. W., and Newsted, P. R. (1999). Structural Equation Modeling analysis with Small Samples
Using Partial Least Squares. In Rick Hoyle (Ed.), Statistical Strategies for Small Sample Research, Sage
Publications, pp. 307-341.
Falk, R. F., & Miller, N. B. (1992). A primer for soft modeling. Akron: The University of Akron Press.
Fornell, C. & Barclay, D. W. (1983). Jackknifing in PLS. Graduate School of Business Administration,
The University of Michigan, Ann Arbor, MI.
Efron, B. & Tibshirani, R. J. (1993). An introduction to the bootstrap. New York: Chapman and Hall.
Gray, H. L & Schucany, W. R. (1972). The generalized jackknife statistic. New York: Marcel Dekker.
Wildt, A. R., Lambert, Z. V., & Durand, R. M. (1982). Applying the jackknife statistic in testing and
interpreting canonical weights, loadings, and cross-loadings. Journal of Marketing Research, 19, pp. 99107.
18
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement