Getting started with Workbench

Getting started with Workbench
Adobe Enterprise Technical Enablement
Getting Started with Workbench
In this topic, you will learn how Workbench relates to the Eclipse development platform
and how to navigate and modify the Workbench interface.
Objectives
After completing this unit, you should be able to
• Explain the relationship between the Eclipse development environment and Workbench
• Explain the terminology used in Eclipse and Workbench
• Navigate and rearrange the Workbench interface
Concepts
In this topic, you will learn about the following concepts
• The relationship between Eclipse and Workbench
• Exploring the Workbench interface
Copyright © 2011 Adobe Systems Incorporated
1
The relationship between Eclipse and
Workbench
• Workbench is built on the Eclipse Integrated Development Environment (IDE)
• Workbench is an integrated development environment for building applications that consist
of forms and business processes
The Eclipse Foundation
• Not-for-profit organization
• Open source community whose projects are focused on providing a vendor-neutral, open
development platform and application frameworks for building software
• Based on software released by IBM in November 2001 into the public domain
• Hundreds of plug-ins available for different environments
■ Flash Builder
■ Java
■ C/C++
■ CFEclipse for ColdFusion
Adobe Workbench
• Based on Eclipse
• Workbench is an IDE that process developers, form developers, and form authors use to
model, create, or automate processes and forms
• Used to manage the resources and services used by the processes and forms
• Logging into an Adobe Digital Enterprise Platform Document Server is required
■ An ADEP Document Services administrator must configure user accounts and assign
an appropriate role for each user or group that will be using Workbench
2
Copyright © 2011 Adobe Systems Incorporated
Exploring the Workbench interface
• The Workbench interface contains different tools to assist in building applications
• Key tools
■ Editors
■ Views
■ Perspectives
Understanding editors
• An editor is used to create and edit objects or files of various types, such as process diagrams
and forms
• The editor opens automatically when required with the associated form or process
Understanding views
• Tab within a window that contains a set of elements such as an editor, a navigation tree or
fields for setting object properties
• Provides support to work being done in the editor
• Views have their own menus and toolbars
Table 1: Frequently used views
View
Description
Applications
View and manage ADEP Document Services
applications
Process Properties
View and edit object properties
Processes
Design process diagrams
Variables
Create and configure variables
Validation Report
View the results of process validations
Copyright © 2011 Adobe Systems Incorporated
3
Understanding perspectives
• A perspective is a collection of views for accomplishing a specific task
• Workbench has five built-in perspectives
■ Data Model - used to create or edit models
■ Document Builder - used create and test assembly descriptors (DDX documents)
without working directly in XML
■ Guide Design - used to create or edit Guides
■ Runtime View - used for seeing all of the assets that are active on the server
■ Process Design - used to create or edit process diagrams
Figure 1: List of available perspectives
• Switch to another perspective by selecting Window > Open Perspective or by clicking the
Open Perspective button in the toolbar
• Switch between perspectives freely, but only one is displayed at a time
• Customize a perspective to suit your personal preferences by selecting, placing, and sizing
the editors and views that you need to accomplish your development tasks
Saving changed perspectives
• Save the perspective after making changes (e.g., moving and resizing views)
• Make changes then select Window > Save Perspective As...
Manipulating views within a perspective
• Views can be opened, closed, moved and resized
• Click on the tab of the view to change
• A gray box will appear, called the drop cursor, which indicates where the view will be
dropped
■ Move the cursor to drop the view full width/height or constrained by existing views
and/or editors
4
Copyright © 2011 Adobe Systems Incorporated
Task 1: Using the Workbench interface
In this task, you will perform the following
• Open Workbench
• Change the size of an editor
• Manipulate views
Steps
Open Workbench
1. Open Workbench by selecting Start > All Programs > ADEP Document Services >
Workbench 10.0 or click the shortcut on the desktop.
2. Click the Click here to login link.
3. When the login screen appears, click the Configure... button.
4. Click the plus (+) sign to configure a new ADEP Document Server.
Copyright © 2011 Adobe Systems Incorporated
5
5. Supply the following information in the Adding New Server dialog. Leave the other data
unchanged.
• Server Title: Adobe Enterprise Server
• Hostname: 127.0.0.1
6. Click OK. Click OK again to save the configured server.
7. Login using the following information.
• User Name: administrator
• Password: password
8. Select Window > Open Perspective > Data Model to open the Data Model perspective.
9. Select the Process Design perspective and then the Data Model perspective. Note that the
views available change as you choose each perspective.
Change the size of an editor
10.
11.
12.
13.
Be sure you are in the Process Design perspective.
Be sure the Start Page is displayed. If not select Help > Workbench Start Page.
Double-click the Start Page editor’s tab to maximize the editor.
Double-click the editor’s tab again to restore it to its previous state.
Manipulate views
14. Double-click the tab on the Applications view to maximize and restore that view.
15. Close the Start Page by clicking the X on the tab.
16. Right-click the Data Model perspective and select Close.
17. Select Window > Show View > Process Properties to open the Process Properties view.
6
Copyright © 2011 Adobe Systems Incorporated
18. Change the order of the stacked Applications and Process Properties views by clicking the
tab of one of the views and moving it over the tab of another view. You will see the drop
cursor indicate when the view can be dropped.
19. Click the tab for the Variables view and drag it to the right side of the Workbench until you
see the cursor transform to a right facing arrow and the drop cursor (the gray box) of the view
appears as follows, then drop it.
20. Open another view not shown by default by selecting Window > Show View > Services.
21. Return the Workbench to its default layout by selecting Window > Reset Perspective... and
click OK when prompted to Reset Perspective.
Copyright © 2011 Adobe Systems Incorporated
7
Summary
• Workbench is built on Eclipse, a popular development environment
• Key tools in the environment are
■ Editors - Used to create and edit objects or files of various types, such as process
diagrams or forms
■ Views - A tab within a window which contains tools to support work being done in an
editor
■ Perspectives - A group of views and editors in a particular arrangement
• Workbench has five perspectives
■ Data Model
■ Document Builder
■ Guide Design
■ Runtime View
■ Process Design
8
Copyright © 2011 Adobe Systems Incorporated
Review
1. Workbench is built on what development platform?
2. Name three perspectives in Workbench and provide a short description of each.
3. Name three views and provide a short description of each.
Adobe Systems Incorporated
345 Park Avenue
San Jose, CA 95110-2704
USA
www.adobe.com
Adobe, Acrobat, Adobe AIR, AIR, Distiller, Flash, Flash Builder, Flash Catalyst, Flex, Adobe Digital Enterprise Platform, MXML,
PostScript, Reader, SiteCatalyst, SearchCenter, Discover, Recommendations, Insight, Test&Target, ReportBuilder, Survey,
Search&Promote, and Social Media are either registered trademarks or trademarks of Adobe Systems Incorporated in the United
States and/or other countries.
© 2011 Adobe Systems Incorporated. All rights reserved.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement