M-Audio | Black Box | BLACK BOX SE

SoundTower Software
BLACK BOX SE
User Guide.
Copyright © 2006 SoundTower Software
professional support for:
M-AUDIO
BLACK BOX™
guitar performance | recoding system
www.soundtower.com
This page intentionally left blank.
Copyright © 2007 SoundTower Software
2
BLACK BOX SE HELP PAGES CONTENTS
1. INTRODUCTORY NOTES
4
2. SYSTEM REQUIREMENTS
4
3. CREDITS
4
4. STARTING EDITOR FOR FIRST TIME
5
5. INITIAL EDITOR SET UP
6
6. MIDI SETUP
6
7. RECEIVING USER BANK DATA
8
8. TRANSMITTING USER DATA
9
9. CHANGING PRESET PARAMETERS
9
10. SELECTING PRESETS FOR EDITING OR AUDITION
10
11. COPY & PASTE FUNCTIONS FOR PRESETS
12
12. TEMPLATES
14
13. PARAMETER CHANGE SENSING
17
14. GLOBAL SETTINGS
18
15. WRITING/SAVING PRESET TO BLACK BOX
19
16. DRUM SEQUENCE (NOT CURRENTLY IMPLEMENTED)
20
17. CONTINUOUS CONTROLLER MAPPER
21
18. KEYS
23
19. PRESET LIBRARIAN
24
20. HELP/WEB SUPPORT
32
21. MIDI IMPLEMENTATION NOTES
33
Copyright © 2007 SoundTower Software
3
INTRODUCTORY NOTES
The SoundTower BLACK BOX Sound Editor is an exciting product for the ST team. This effort has
become the effective starting point for our new look and strengthening position in the Editor/Librarian
segment of the MIDI market. We are proud of the new direction in GUI, the robust engine and the
range of functions implemented with great success. We would like to offer our heartfelt thanks to our
customers who work the software so much harder and creatively than we ever could imagine doing.
As a result many valuable enhancements to in our software over the years have been added, many
valuable suggestions for improvements in functionality and interface have added greatly to our
success.
We hope the SoundTower Editor/Librarian adds value to your enjoyment of M-Audio’s BLACK BOX.
Thank you and happy picking from the SoundTower team.
SYSTEM REQUIREMENTS
•
•
•
•
•
Windows 95 / 98 / ME / 2000 / XP
Mac OSX
* Black Box - OS software version 2 or higher.
(Optional) Midi Interface IN/OUT
(Optional) Mouse with scroll wheel for easy and precise parameter adjustment
CREDITS
Software Development: SoundTower Software, Windsor, Ontario, Canada.
User Guide Development: Derek Prowse.
Copyright © 2007 SoundTower Software
4
STARTING EDITOR FOR FIRST TIME
When starting the SoundTower Black Box editor for the fist time you will be greeted by a splash
screen:
User will then be prompted by a dialogue box requesting your name and registration code.
Registration codes are sent to you
usually within 12 hours of purchase of
product. Point your browser to:
http://www.soundtower.com/blackbox/
and follow the PayPal or 2CheckOut
links.
Enter the codes if you have obtained them or click “Demo Mode” to continue in demonstration mode.
The Send and Writing of Patches will be disabled but the basic functionality is maintained for the
purposes of evaluation.
Copyright © 2007 SoundTower Software
5
INITIAL EDITOR SET UP
The SoundTower Black Box SE has initial set up preferences that if utilized makes life much easier
for the user by virtually eliminating the frustrations of lost data, editor setup and patch organization.
Under main menu select Preference under File.
The Preferences dialogue window offers several options for user:
that sets editor startup and shut down preferences. They are as seen above. Any or all can be
selected or de-selected depending on your particular editing needs.
MIDI SETUP
Even though your Black Box editor connects with BB automatically - no port selection is necessary
providing that BB is connected to the computer via USB, you may want to arrange a different
configuration or MIDI port routing. This next section will walk you through the necessary steps.
Under MIDI in main menu (Ctrl-M):
Copyright © 2007 SoundTower Software
6
User accesses Midi setup window:
.
Select the MIDI IN that is desired based on list provided by system. By clicking on the “More” button
all MIDI IN and MIDI OUT ports and MIDI emulators are listed:
All ports are listed: physical, virtual as well as emulations as demonstrated above with
Microsoft GS Wavetable SW Synth listed.
Copyright © 2007 SoundTower Software
7
RECEIVING USER BANK DATA
To receive all user data from BLACKBOX, select "Receive User Data" from Midi menu
or use Ctrl+R. and press start. Because of the use of USB protocol with the BLACK BOX there
should be no problems with Midi interface not keep up with fast coming Midi messages as there used
to be but if this does occur because of a system slow down you can adjust timing by adding delay in
milliseconds.
Copyright © 2007 SoundTower Software
8
TRANSMITTING USER DATA
To transmit User Data from the Editor to BLACK BOX select "Transmit" from Midi menu.
The data you send will be written into BLACK BOX bank memory overriding existing Presets and
Drum sequence. Transmitting bank data takes little bit longer than Receiving because the editor has
to wait till BLACK BOX performs actual writing to its flash memory and sends the "Ready" message.
CHANGING PRESET PARAMETERS
Changing preset parameters is very simple. You can use on-screen knobs, computer up/down arrow
keys to increase or decrease values by 1. If your mouse is equipped with a scroll wheel, you can
simply move mouse cursor over a control, or its label, and scroll; the knobs will self adjust. While
using a mouse wheel, you do not have to click on any controls to change values.
Copyright © 2007 SoundTower Software
9
SELECTING PRESETS FOR EDITING OR AUDITION
After Receiving User Data,
the preset names are
displayed in "Preset
Bank" section.
BLACK BOX does use
patch names and patch
names are stored in
BLACK BOX internal
memory.
(Note: The editor's patch
names are limited to 6
characters.)
Of course you can rename Preset by double clicking on list box cell and typing a new name into the
pop-up.
The Preset bank section can be used not only to select and display BLACK BOX's internal presets
but also to perform Preset copy/paste functions.
Copyright © 2007 SoundTower Software
10
With a single right click on patch name a small edit popup menu will appear:
From this you may make these following selections:
If you use paste
function from
window's Edit menu,
the copied Preset
will be pasted to
Black Box’s edit
buffer without
writing it to the user
bank.
•
•
•
Copy command copies selected Preset to editor's clipboard.
Paste + Write sends and saves copied Preset to BLACK BOX
Send to Buffer sends copied Preset to BLACK BOX's edit buffer
without writing it to the user bank.
If you use copy function from window's Edit menu, the edited Preset will
be copied. If you use paste function from window's Edit menu, the copied
Preset will be pasted to Black Box’s edit buffer without writing it to the
user bank.
Copyright © 2007 SoundTower Software
11
COPY & PASTE FUNCTIONS FOR PRESETS
To further increase functionality of the editor we added separate Copy and Paste functions for preset
grouped parameters. This way for example you can copy all effect settings from one Preset and
seamlessly apply it to another.
For instance if you a have selected the preset called BYPASS and want to copy and paste the AMP
parameter values go to the AMP panel and click on “Edit”
From the drop down menu select copy or Amp Template.
Selecting Copy will sends the parameters to Clipboard for Pasting to other Patch’s Amp grouped
parameters you might select next. In the case below we have selected Deluxe as the patch and are
set to Paste Amp parameters from BYPASS. Restated: simply Copy one Presets Amp settings,
change to another Preset and click on Edit label, select Paste Amp and the current Amp settings will
be over written with contents of the clipboard.
Copyright © 2007 SoundTower Software
12
The Template feature is a powerful form of librarian that is meant to help organize sub groupings of
parameters.
Each of:
•
•
•
•
Amp
Delay
FX and
Reverb
are groupings of parameters that are naturally associated for the purposes of the function described.
For any technical information relating to the Black Box hardware please see MAudio Black Box User guide for more details on setup, functionality and
specifications.
(See MIDI IMPLEMENTATION NOTES section (p. 33) in this User Guide for URL)
Copyright © 2007 SoundTower Software
13
TEMPLATES
By way of example we shall focus on the Amp settings Template.
If you had selected the Amp Template with DLXREV
you will open another window that will have a
mirroring control panel. You will also note a list box
and a blue label above that to the left of the control
panel. The Preset Amp setting that was active in the
main window will be displayed in the Amp Template
window.
By clicking on the Add Current button you will add
Black Box’s Template feature is
most valuably viewed as an
extension of the patch Librarian
feature. Its power lays in the User’s
ability to fine tune any of Amp, FX,
Reverb or Delay parameters
incrementally without loosing the
previous changes during
exploration.
the Amp settings to the list box. You may note that the list box names consist of:
1. template number ( the number order of Amp template addition),
2. the name of the Preset the Amp settings were derived (in the case below: BYPASS) and
3. the number and name of the actual Amp setup saved (below: 2. DLXREV). (see image)
The text in the list box may be renamed by clicking on the name in the list box and typing a new name
in the blue label above it after the original name appears in label.
A useful feature of the Template is its real time connection with the main editor. Once you have
added the Amp setting to the list box you can make adjustments with the knobs in the Template
Copyright © 2007 SoundTower Software
14
screen (these changes will be reflected in main editor) or on the Amp portion of the main editor
screen and the changes (and changes there will be reflected in the Amp Template screen).
By clicking Add Current again a new entry to the list box will be made with the Preset and Amp effect
name from the editor used again. Each change of the amp settings and addition to the list box are
separate entities. If you then successively click each of the entries in the list box you will note that the
different settings are remembered and displayed in the Template field and in the main editor Amp
field.
A useful feature of the Template is its real time connection with the main editor. All
changes in either are immediately mirrored in the other.
In this manner you can experiment with the settings of the module and not lose the original or
interesting setting made.
Preset grouped parameter functions are:
•
•
•
•
Copy/Paste of Effect section
Copy/Paste of AMP section
Copy/Paste of Delay section
Copy/Paste of Filter Sequence
Templates can be accessed through main menu as well:
The grouped parameters utilize a drop down menu for selection activated by clicking on the name
labels in each panel. Staying with the AMP section if the label is single clicked a list is presented to
choose the AMP type effect desired. In this case TWNREV is selected.
Copyright © 2007 SoundTower Software
15
Note that there is a small toggle button (with the two Chevrons) that will expand the list width wise to
display more information about the parameter. Above we see that the TWNREV is equivalent to the
Fender Twin Reverb. The selection must be clicked again, or the user must click on the main screen,
to set the parameter selection into active use by the editor. This allows for browsing without
immediate commitment prior to final selection.
The Template option also allows for loading all Amp parameter groupings from the entire User Bank.
This can be accomplished by directing you mouse to File under the main menu:
The Template option also allows for loading all Amp, Reverb, FX and Delay
parameter groupings from the entire User Bank.
Copyright © 2007 SoundTower Software
16
Selecting Load settings from the User Bank will extract all Amp settings from the currently loaded
User Patches.
You may, after arranging, changing names and making all adjustments to individual setups, save your
Template set as a separate file (Ctrl-S). Previously saved Template files are loaded by menu or CtrlL.
Under Edit in main menu there are given options to move, delete and otherwise arrange the Amp
settings saved in the list box to accommodate your needs:
PARAMETER CHANGE SENSING
This feature has been added to the editor allow for immediate updates to the editor when manual
changes are done on BLACKBOX. It allows for display of the parameter(s) change. Its function is to
automatically request Preset and Drum Beat edit buffers in 1sec time interval. Click the button when
you want the sensing to commence. The function is operational when the button has turned to dark
blue and the label text changes to light blue from yellow (below).
The PARAMETER
CHANGE SENSING
feature causes
immediate updates
to the editor when
a manual change
occurs on the
Black Box.
Copyright © 2007 SoundTower Software
17
GLOBAL SETTINGS
The global settings are independent of any preset or Drumbeat setting. Here you can adjust the main
output level, balance between Drum Beat output level and processed Input signal, Noise Gate, Global
Tempo.
A common feature of the BLACK BOX SE drop down box selections is the ability to select a
parameter with a single click and without making it the final choice. One click to select and a second
click to finalize it. You can also click anywhere else on the interface to final select the parameter.
See image below for example:
Popup menus: One click to select and a second click to finalize selection.
Copyright © 2007 SoundTower Software
18
WRITING/SAVING PRESET TO BLACK BOX
Use WRITE button to save edited Preset to BLACKBOX. In the "Write..." dialog you can select
current or new target location within the user bank.
WRITE button is found at the top left panel of the editor, as shown in image below:
From the Edit menu you can select Write or use ctrl-W, as shown in image below:
Either manner of engaging the WRITE function will activate the WRITE window:
Copyright © 2007 SoundTower Software
19
In the blue label the Preset name can be changed. Here BYPASS was changed to BVPASS for
illustration purposes.
The "Write..." dialog lets User select current or new target location within the user bank.
Clicking Send Preset sends the current patch to the edit buffer. Clicking Get Preset calls the current
patch from the edit buffer. These are found in the same panel as WRITE (below).
DRUM SEQUENCE (not currently implemented)
(NOTE: THIS FEATURE IS NOT CURRENTLY IMPLEMENTED IN THE BLACK BOX
OS. WE INCLUDE THIS DESCRIPTION IN ANTICIPATION OF FUTURE
IMPLEMENTATION BY MANUFACTURER.)
The Drum Sequence section (bottom left corner of Editor) of the main editor's screen shows Drum
Beat linked to a current Preset with some parameters (Tempo, Send to FX level, signal sent to Delay,
Input and Reverb.
Copyright © 2007 SoundTower Software
20
To change linked Drum Beat from the main editor screen simply move your mouse over the Drum
Beat name label and use mouse scroll wheel or click and select from popup window’s list box.
You will notice the Edit label that, when clicked, brings up a Drum Beat Sequencer window. This will
give a sense of what the editor is potentially capable of.
CONTINUOUS CONTROLLER MAPPER
Under Midi in main menu select “Controller Setup” (as shown below)
The CONTINUOUS
CONTROLLER MAPPER
allows for complete
mapping flexibility
between parameters,
channels and
controllers.
In the Continuous Controllers Mapping window you are given several options for control.
You will see five columns.
•
•
•
•
•
The No. column is fixed as it’s function is organizational only
Controller No.,
Chn (MIDI channel),
Parameter columns,
And On/Off.
The check box allows for activation of the Continuous Controllers Mapping in a global sense. If not
checked, none of the assignments will be active. If checked then the assignments with the On/Off
column set to ON will be active.
Copyright © 2007 SoundTower Software
21
When Controller No., Chn or Parameter columns are clicked a list window opens for you to select
parameters from.
Click once to highlight, (you can browse without committing) and a double click to select.
In the example below:
No. selection 4 is set with Controller No. 5 (Portamento Tm) controlling Parameter 19 (DRM –
Tempo) through Chn (MIDI channel) 1. You will note that at the far right there is a further logical
control column that allows for setup to be active (ON) or inactive (OFF). This is activated by a single
click to toggle between ON/OFF states.
Copyright © 2007 SoundTower Software
22
In the Continuous Controllers Mapping window menu you have the option of creating New, Loading
saved or saving created maps.
KEYS
The Keys function is found under the Keys menu item or by typing ctrl+k. This function, once
activated (as indicated by a check mark to the left of the Keys On menu item) will allow for single
touch activation/deactivation of the selected parameter. This is designed for live performance or
recording situations where time is of the essence for quick effects changes.
KEYS function is used for single touch activation/deactivation of the selected parameter.
Used for live performance or recording situations where time is of the essence.
Copyright © 2007 SoundTower Software
23
PRESET LIBRARIAN
Here is where you can really thrive as a BLACK BOX user. It will pay to familiarize yourself with all
Librarian features. Our Librarian lets you store unlimited number of BLACK BOX sounds. In addition
you can have as many Library files on your computer as you want. Each item stored in the library
consists of one Preset and one Drum Beat that was linked to a Preset. This way you never have to
worry about losing your favorite BLACK BOX settings. The Librarian provides for you 32 sound
categories to organize your sounds and to have them available for immediate use. Initially, we named
some categories like "Pop", "Rock" but you are welcomed to rename them according to your styles or
needs.
Accessing the Librarian is as simple as clicking the LIBRARY button,
It will pay to familiarize
yourself with all Librarian
features. Our Librarian lets
you store unlimited number
of BLACK BOX sounds.
A single click will set the list box below to the contents of the “Cat 0 – Not Assigned” category
already in the Librarian (a second click will open the Librarian window itself). If you have opened a
new library or this is the first time you have accessed the function since installing the BLACK BOX SE
then the listbox will be empty.
Copyright © 2007 SoundTower Software
24
and the Librarian window will open but will be initially unpopulated (below)
You can use the Librarian to build a set of Patches from those you are working on in the Editor
currently or by sensed changes from the BLACK BOX by clicking the Add Current button.
The other option is to load a pre-existing Library from your hard drive or Load from User Bank Data.
The Librarian is used to build a set of Patches from those in Editor currently or by
pulling from the BLACK BOX by clicking the Add Current button.
Another option is to load a pre-existing Library from your hard drive or Load from
User Bank Data.
Copyright © 2007 SoundTower Software
25
For the next example we shall load in User Bank Data. This results in all patches being dropped into
the Not Assigned category (Cat. 0) See image below.
Adding Preset to the librarian
To add current Preset select a category to which you want to add and press the “-" beside the
category to move the arrow button:
Copyright © 2007 SoundTower Software
26
Now if we select 004 TWNREV (by clicking once to highlight) to be moved from Not Assigned to
Rock:
After clicking the arrow we should see the total number of Preset remain the same but the relative
distribution between categories adjust. Here we see 99 in Not Assigned and one in Rock. Also note
the list box has adjusted itself making the next preset in the list, DELUXE, move from 005 spot to the
now vacant 004.
All categories can be renamed. In the image below, after the right pointing black triangle to the left of
empty category field was clicked once and rename category is selected from the Librarians File
menu, we create a category Jazz. You must hit keyboard Enter to set the name.
Copyright © 2007 SoundTower Software
27
Naming and re-naming new and
existing Preset Categories is as
simple as clicking the black
triangle and retyping.
Remember: press enter on
keyboard to set name change.
A single click on the JAZZ preset and you select it for movement to the new category by clicking the
arrow button.
Note that the HIWHAT at 013 position moves to the 012 cell after the move is complete.
Copyright © 2007 SoundTower Software
28
You man also simply drag and drop with the mouse if Drag and Drop radio button is selected:
Note also that if the Multi Select option is checked (see below)
it is a simple matter of highlighting a range of preset with a drag of the cursor or select non-congruent
individual presets by ctrl + click
Copyright © 2007 SoundTower Software
29
Note that 5 presets were selected and 5 show up in the category. The other category the presets
were taken from adjusts automatically to new value of 95.
Remember: Any preset or group of presets in the list box can be selected
and copied by Copy menu option in Edit in Librarian menu.
Any preset or group of presets in the listbox can be selected and copied by Copy in Edit in Librarian
menu. The selected group can then be Pasted by using the Paste in Edit in menu to copy the
selection, with altering the original set of presets, to another category.
Copyright © 2007 SoundTower Software
30
Renaming of Presets can be accomplished in Librarian simply by double clicking and typing in box:
In this way the Librarian can be used to select and sort the entire Preset banks for more functionality
suited to the individual musician.
Saving and loading previously saved Librarian setups are accomplished through the File menu; New
Library option is also accessible here as well as on the Librarian main face by way of the buttons.
Copyright © 2007 SoundTower Software
31
HELP/WEB SUPPORT
Although we have provided this PDF help file/User Guide it is possible to find yourself in the position
that you are using the Black Box executable on a computer without access to the files. For this
reason we post these files on our website. Under Help in the main menu you can access the Black
Box page (Ctrl-H) and On-Line Help page by clicking on selection.
If in the unlikely situation that you cannot find the information you
need on our Black Box page or in the On-line Help pages please
email us at:
editors@soundtower.com
Please ensure you put “Black Box Technical Support” in the subject
line.
Enjoy your Black Box and this editor! Thanks from the SoundTower
team.
www.soundtower.com/blackbox
Copyright © 2007 SoundTower Software
32
MIDI IMPLEMENTATION NOTES
MIDI implementation in M-Audio’s BLACK BOX is USB driven so the perennial problems associated
with MIDI drivers being incompatible for various systems are eliminated. SoundTower Software has
taken advantage of this hardwired strength associated with the USB system but cannot take
responsibility for USB issues that might arise within the BLACK BOX itself. For this M-Audio would be
the best resource.
SoundTower Software URL for the software:
http://www.soundtower.com/blackbox
This help file in ADOBE .pdf and MS-Word .doc formats can be found there.
An online HTML page with this information is found at:
http://www.soundtower.com/blackbox/help
M-Audio URL for the BLACK BOX:
http://www.m-audio.com/products/en_us/MAudioBlackBox-main.html
Technical specs are found:
http://www.m-audio.com/products/en_us/MAudioBlackBox-focus.html
Updates for drivers are found:
http://www.m-audio.com/index.php?do=support.drivers
Copyright © 2007 SoundTower Software
33
Download PDF