Access 2003

Access 2003
Microsoft®
Access 2003
Quick Reference Card
888.903.2432 | www.customguide.com
The Database Window
The Standard Toolbar
Save
New
Print Preview Cut
Keyboard Shortcuts
Paste
OfficeLinks
Code
Properties
New Object
General
Open a Database <Ctrl> + <O>
Open
Spell
Check
File Print
Search
Copy
Undo
Database Objects
Create a new object by
clicking the New button…
…or by using a Wizard.
Analyze
Script
Editor
Relationships
Help
• To Cut or Copy an Object: Select the object
and click the
Cut button or
Copy
button on the toolbar, or press <Ctrl> + <X>
(cut) or <Ctrl> + <C> (copy).
Paste
• To Paste an Object: Click the
button on the toolbar or press <Ctrl> + <V>.
Objects
bar
Select the
type of
object you
want to
view.
• To Import an Object from Another File:
Right-click any empty area of the Database window
and select Import from the shortcut menu. Select
the database that contains the object(s) you want to
import, click Import, select the objects, and click
OK.
Database objects appear
in this area.
Tables store related data in rows (records) and
columns (fields).
Queries view, filter, calculate, change, sort, and
examine the data stored in tables.
Forms are custom screens that provide an easy
way to enter and maintain data in a table or query.
Reports present data from a table or query in a
printed format—no data entry.
Pages are forms saved as Web pages so that the
database can be accessed over the Internet.
Macros automate common tasks and can be
invoked by clicking a button or pressing a shortcut key.
Modules are groups of procedures that are
written in Visual Basic and used to automate tasks.
• To Open an Object: Double-click the object.
• To Create a New Object: Click the object type
you want to create on the Objects bar. Click the
New button on the toolbar to create the
object from scratch or double-click a
Wizard
icon to create an object step by step.
• To Export a Table: Click Tables on the
Objects bar, right-click the table you want to export,
and select Export from the shortcut menu. Enter a
file name and select the file format from the Save
as type list. Click Export and follow the
onscreen instructions.
Linking Tables tells Access how two tables are
related to each other. The fields that you use to link
two tables must contain the same concept in two
different tables. A primary key field from one table is
often used when linking two different tables.
• To Link Tables:
Relationships button on the
1. Click the
toolbar.
2. If necessary, open the Show Tables window by
Show Table button. Then
clicking the
select the table, click the Add button, and repeat
for each table. Click Close when finished.
3. Find the related table fields. Drag the field from one
table and drop it on the related field in the second
table. Make sure that the field names are correct.
Close a Database <Ctrl> + <W>
Print Current View <Ctrl> + <P>
Delete
<Delete>
Undo
<Ctrl> + <Z>
Help
<F1>
New Record
<Ctrl> + < + >
Delete Record
<Ctrl> + < - >
Save Record
<Shift> + <Enter>
Cancel Changes
<Esc>
Insert Date
<Ctrl> + < ; >
Insert Time
<Shift> + <Ctrl> + <:>
Insert Value from
Same Field in
Previous Record
<Ctrl> + < ’ >
(Apostrophe)
Check Spelling
<F7>
Switch Between
Applications
<Alt> + <Tab>
Navigation—Go To:
Next Field
<Tab>
Previous Field
<Shift> + <Tab>
Next Screen
<Page Down>
Previous Screen <Page Up>
First Record
<Ctrl> + < ↑ >
Last Record
<Ctrl> + < ↓ >
Editing
Cut
<Ctrl> + <X>
Copy
<Ctrl> + <C>
Paste
<Ctrl> + <V>
• To Modify an Object: Select the object and
click the
Design button on the toolbar.
Find
<Ctrl> + <F>
Replace
<Ctrl> + <H>
• To Delete an Object: Select the object and
press <Delete>.
Select All
<Ctrl> + <A>
• To Rename an Object: Right-click the object,
select Rename from the shortcut menu, enter the
new name, and press <Enter>.
• To View the Database Window: Select
Window and the database name from the menu.
• To Repair/Compress a Database: Select
Tools → Database Utilities → Compact
and Repair Database from the menu.
Design View
4. (Optional) Check the Enforce Referential
Integrity box to avoid creating “orphan” data. If you
want to change the “join type” between the tables,
click the Join Type button, select the type of
join and click OK.
5. Click Create to create the relationship, then close
the Relationships window and save your changes.
Customizable Business Training
9 Online Learning 9 Skills Assessments 9 Courseware
Properties
<Alt> + <Enter>
Open object in
Design View
<Ctrl> + <Enter>
Shift focus to a <Ctrl> + <Tab>
subsection
Save Object
<Ctrl> + <S>
888.903.2432 | www.customguide.com
© 2010 CustomGuide
Creating and Designing Tables
Working with Data
View
Search
Save
Print
Preview Cut
Spell
Check
Print
Insert
Paste Hyperlink
Copy Undo
• To Create a New Table Using a Wizard: Click Tables in the
Apply/Remove
Filter
The Datasheet Toolbar
Filter By
Selection
New
Record
Filter Find
Sort Ascending/ By Form
Descending
Database
Window Help
Delete New
Record Object
The Navigation Bar
(Found on the horizontal scrollbar near the bottom of most windows.)
First
Record
Current Record
Number
Last
Record
Total Number of Records in
the Table, Query, or Filter
Objects bar and double-click the
Create table by using wizard
icon. Follow the onscreen instructions.
• To Create a New Table from Scratch: Click Tables in the Objects
bar and double-click the
Create table in Design view icon. Type a
field name for the first column you want to create in the Field Name
column, press <Tab>, click the Data Type drop-down arrow, and
select the data type for the field. Repeat as necessary to add new fields to the
table. Close the table window, click Yes to save the table, enter a table
name, and click OK.
Data Types
Previous
Record
Next
New
Record Record
Filter
Indicator
• Database information can be directly added and modified from tables and
some queries and forms.
• To Add a New Record: Click the
Navigation bar.
New Record button on the
• To Select a Record: Click the
Record selector to the left of the
record or select Edit → Select Record from the menu.
Delete
• To Delete a Record: Select the record and click the
Record button on the toolbar, or select Edit → Delete Record from
the menu.
• To Spell Check: Click the
Spelling button on the toolbar.
• To Find Information in a Table: Place the cursor in the field that
contains the value you want to search for, then click the
Find button on
the toolbar or press <Ctrl> + <F>. Type the value you want to search for in
the Find What box and click Find Next. Click Find Next until you’ve
found what you’re looking for.
• To Replace Information in a Table: Place the cursor in the field that
contains the value you want to replace, then select Edit → Replace from
the menu or press <Ctrl> + <H>. Then type the value you want to search
for in the Find What box and the new value in the Replace With box.
Click Find Next until you’ve found what you’re looking for, and then click
Replace or Replace All to replace every instance of the value.
• To Sort Information: Place the cursor in the field that you want to sort by
and click either the
Sort Ascending or
Sort Descending
button on the toolbar.
• To Filter by Selection: Place the cursor in the record and field that
matches the selection criterion and click the
Filter By Selection
button on the toolbar.
• To Filter by Form: Click the
Filter by Form button on the
toolbar. Click the down arrow next to the field that contains the selection
criterion and select the value you want the filtered records to match. You can
use more than one field to filter data.
• To Remove a Filter: Click the
toolbar.
Remove Filter button on the
Forms and Reports
• To Create a Form Using a Wizard: Click Forms in the Objects bar
and double-click the
Create form by using wizard icon. Follow the
onscreen instructions.
• To Create a Report Using a Wizard: Click Reports in the Objects
Create report by using wizard icon.
bar and double-click the
Follow the onscreen instructions.
• To Toggle between Form/Report and Design View: Click the
View button on the toolbar.
Data Type
Text (Default)
Memo
Number
Date/Time
Currency
AutoNumber
Yes/No
OLE Object
Hyperlink
Lookup Wizard
Description
Stores text, numbers, or a combination of both, up to 255
characters long.
Stores long text entries—up to 64,000 characters long.
Stores numbers that can be used in calculations.
Stores dates, times, or both.
Stores numbers and symbols that represent money.
Automatically fills in a unique number for each record.
Stores only one of two values, such as Yes or No.
Stores objects created in other programs, such as a
graphic, Excel spreadsheet, or Word document.
Stores clickable links to Web pages on the Internet or files
on a network.
A wizard that helps you create a field whose values are
selected from another table, query, or list of values.
Queries
The Design Query Window
To add a field to
the query, click
and drag it from
the table…
The queried tables
appear here. You
can also link tables.
…down to the
QBE grid.
Sort order
QBE Grid
Show results
Criteria rows
• To Create a Select Query: Click Queries in the Objects bar and
double-click
Create query in Design view icon. Select the table
you want to query and click Add. Repeat for all the tables you want to add to
the query. Click Close when you’re finished. Find the field you want to query
(use the scroll bars) and drag the field down to the QBE grid. Repeat until you
have added all the fields you want to include in the query. If you want to filter
records, enter the criteria in the Criteria row. Close the query window, click
Yes to save the query, enter a query name, and click OK.
• To Switch Views: Click the
View button on the toolbar.
• To Calculate Total Values: Open the Query in Design View, select
View → Totals from the menu, find the query field you want to calculate or
group by, and select a calculation from the field’s drop-down list.
Criteria Example
Description
“London”
Displays records where the field equals “London.”
Between 1/1/00 and
Displays records where the date is between 1/1/00 and
12/31/00
12/31/00.
NOT "USA" or
Displays records where the field does not contain the
<> ""
text "USA" and is not blank.
Like “S*”
Displays records where the field text starts with an “S.”
IS NULL
Displays records where the field is blank.
IS NOT NULL
Displays records where the field is not blank.
>100
Displays records whose field value is greater than 100.
Customizable Business Training
9 Online Learning 9 Skills Assessments 9 Courseware
888.903.2432 | www.customguide.com
© 2010 CustomGuide
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement