MPC Software [v1.8.2] Release Notes

MPC Software [v1.8.2] Release Notes
MPC Release Notes
About
Akai Professional is continually updating and enhancing the MPC experience.
This document lists the new features, fixes and improvements made to your MPC
software.
Version 1.8.2 (April 2015)
New features
◾ The Plugin Manager is a new way of managing your VST/Audio Unit instruments
and insert effects with MPC (See Tools>Plugin manager).
◾ View all scanned plugins in a detailed list
◾ Filter the list by plugin format, type, and whether it was scanned
successfully or not.
◾ Type in the search field to quickly refine what’s shown in the list.
◾ Re-order the list by name, type, etc
◾ Re-scan individual failed plugins (this is really useful when your plugins do
not scan because you’ve not got a copy protection key with you; at your
leisure you can scan the plugins you want)
◾
◾
◾
◾
◾ “Use” checkbox provides the ability to filter out plugins from the list so you
can hide plugins you don’t want to use.
◾ Favourite plugins option allows you to move your preferred plugins to a
new section at the top of the new plugin dialog for rapid access.
◾ You can also launch the plugin manager from the “new plugin” dialog (use
the “cog” icon)
New sample loop types (see sample trim mode, or the pad parameters in program
edit)
◾ Off - no looping occurs.
◾ Forward loop - is the existing MPC loop behaviour. When playback reaches
the “end” point, it resumes playing forwards from the “loop” point
◾ Alternating loop - when playback reaches the “end” point, the sample will
play backwards to the “loop” point, then forwards to the “end” point, and so
on.
◾ Reverse loop - when playback reaches the “end” point it will continually play
backwards to the “loop” point from “end”
Sequence note duration recording enhancements (see
Preferences>Sequencer>Truncate Duration).
◾ Select To Sequence Length to truncate notes when they go beyond the
length of the current sequence. When a sequence loops you can be sure
that the note will never “play over” itself.
◾ Select To Sequence End to truncate notes to the end of the current
sequence. When the sequence loops round, the note will stop playing.
◾ Select As Played to record events exactly as they were played. The note
events may overlap as the sequence plays back.
Automation support for the pad offset and pad reverse parameters. You can now
assign these parameters to Q—Links and record their changes in real time.
The Expansion Manager allows you to manage your installed expansion packs.
(See Tools>Expansion Manager).
◾ View a list of expansions installed into your MPC, along with their details.
◾ The “Use” field allows you to hide expansions you don’t want to see in the
expansion browser.
◾
◾
◾
◾
◾
◾
◾
◾
◾ XPN-format expansions can be automatically uninstalled (select the XPN
and press “Uninstall”)
Master tempo allows you to lock your MPC to a unified tempo, regardless of the
current sequence’s tempo.
◾ In MPC GUI, click the BPM sync field on the transport toolbar to engage
“master tempo”. The toolbar displays “MST” when master tempo is engaged.
◾ On the MPC LCD, select the “seq” field beside the sequence BPM, and press
+/- to select “mst”.
Real-time track transpose allows you to adjust note pitches as the sequence is
running. This does not affect the recorded events shown in the event grid. Adjust
from the GUI parameter panel in main mode, or using the custom track parameter
display on the LCD.
Real-time sequence transpose allows you to transpose MIDI the pitch of all notes
in every track at once. Adjust from the GUI parameter panel in main mode, or using
the “Tran:” field on the LCD. You can combine real-time sequence transpose and
real-time track transpose.
Audio VU meter on LCD main page shows the current level of the master outputs.
MIDI activity indicator displays on the LCD main page.
Ability to Convert a sequence to progression (accessed via the Tools menu).
◾ You can now construct your own chord progressions and map them to pads
in Pad Perform Mode.
◾ Record a chord sequence on a plugin, MIDI or keygroup track and open the
conversion dialog. All chords will be detected from your sequence, and the
chord name will be automatically detected. Choose a name for your
progression and hit Do It.
◾ The progression is saved in an individual file on your hard drive (on Mac, this
is: /User/<your name>/Library/Application Support/Akai/MPC/Progressions, on
Windows this is: C:\Users\All Users\Akai\MPC\Progressions)
◾ You can share these progressions with other MPC users.
Advance keyboard and VIP software integration. Enjoy using VIP as your
instrument host within MPC.
The looper gain can be adjusted via Q4. This allows you to adjust the mix of the
looper with your sequence.
◾ An LCD Window (see the Tools menu) that displays a large GUI representation of
the LCD display on your MPC Renaissance or MPC Studio.
Improvements
◾ New MPC “pattern” file format (with extension “.mpcpattern”). These files are a
snapshot of the events on a single track.
◾ You can export an mpc pattern file using File>Export>As Pattern.
◾ MPC patterns can be loaded from the MPC file browser or dragged into the
MPC window. (They appear under the SEQ and NO FILT file filters.)
◾ The Expansion Browser supports “categorized” expansion packs.
◾ Expansions in this format present a hierarchical view of their contents rather
than a plain alphabetical list.
◾ Look out for new categorised expansions available in the MPC expansion
pack store.
◾ You can use the Expansion Builder to build your own categorised expansion
pack.
◾ The Expansion Browser supports MPC pattern files.
◾ MPC patterns in an expansion pack will load into a new empty track in the
current sequence.
◾ They auto-load the relevant program (unless you hold down shift).
◾ The plugin scanner is more robust and will not re-scan failed plugins with you
select “Scan New”. The result display of the plugin scanner has been made clearer.
◾ Improved MIDI input handling. Issues with hanging notes when changing tracks,
using sustain, etc have been resolved.
◾ Improved waveform scrolling/focusing in the sample editor.
◾ Vintage mode moved into LCD’s “Effects” page.
◾ Updates to file save/export dialogs.
◾ Looper and sample record settings are stored for ease of use.
◾ Improved compatibility with UAD plugins.
◾ Bug fixes and stability enhancements.
◾
Version 1.8.1 (March 2015)
Improvements
◾ Bug fixes and stability enhancements.
Version 1.8 (February 2015)
Version 1.8 vastly improves the sample capture, edit and slice experience. It also
brings exciting new features for live performance.
New features
◾ Non-destructive chop MPC 1.8 provides two new “non-destructive” chop facilities.
This allows you to chose the slice/edit behaviour that you prefer without
destroying your original sample. This gives you far more control over your sample
playback.
◾ Per-sample: Sample slices are now saved inside the sample file. When
assigning a sample to a pad, you can either chose to assign “all” of the
sample (previous MPC behaviour) or a particular slice (referenced by the
slice number). This means that you can save your sliced sample, and re-use
the slice data in another project.
◾ Per-pad: Additionally, each pad can reference specific regions of an audio
sample, regardless of whether it has been sliced or not. Select the “pad” slice
to unlock “pad start” and “pad end” pad parameters which determine which
samples to play. Also, the pad can have an independent sample loop setting.
◾ Built-in looper allowing you to record, overdub, and manipulate audio in real time.
It’s great fun! Access the looper by pressing Looper (or F1 on the hardware) on the
Sample Record page.
◾ Quickly record and overdub audio in a looper audio buffer, with punch-in
overdub/replace capability.
◾ Can be enabled live by LCD, GUI or footswitch.
◾ Configurable number of bars of audio record loop.
◾ Looper input and output monitoring on LCD.
◾ Large, clear LCD looper display.
◾ Sequencer SYNC mode ensures that the loop buffer always plays in step
with your sequence playback. You can disable this to use the looper without
sync.
◾ Realtime loop reverse. (When sequencer sync is on, this switches direction
at end of each sequence loop. When sync if off, reverse happens
immediately.)
◾ Export recorded loops to a pad, or to the sample pool for further use with
MPC.
◾ The sample editor has received numerous improvements and new workflow to
make chopping samples into slices easier and more fun:
◾ Program/pad audition mode in the sample editor. You can now edit a
sample in the context of the program it will play in. Select PROGRAM mode,
and the current program will appear on the pads. Tap a pad to select it. The
sample editor will allow you to edit the settings of that pad’s first layer. You
can audition the sample through the pad and the program’s entire audio
chain. In this mode, you are adjusting the pad parameters, as if you were
using the Program Editor.
◾ Live sample chop. In sample chop mode, start auditioning a sample, and
press “Slice +”. A new slice point is inserted in real time. This allows you to
checking “perform” a chop as you listen to the sample. At any time, you can
drop out of audition mode, fine tune a pad chop point, and then re-start the
live chop.
◾ Sample trim mode can now trim "all" of the sample (the legacy behaviour,
which allows you to set the automatic chop ranges), or a specific slice. This
provides a more detailed view of a single slice than you get in sample chop.
You can switch between trim and chop to make slice edits.
◾ Sample chop has a new “cue” playhead for fast manual chopping. You can
manually select a sample position, audition the sample from that point, and
then insert a slice at the cue point.
◾ Cue audition behaviour can toggle between “toggle” (press to start, then
press to stop) and “note on” (play whilst button is held) play modes.
◾ Click in the GUI timeline to quickly set the cue point.
◾ Audio marker preview function (press WINDOW over the “Start:”, “End:”, or
“Cue:” LCD field, or use the GUI’s “Other” preference tab). This plays a small
snippet of audio at the marker point when you adjust it from Q-Link, data
wheel, or GUI. Tap a Q-Link knob to replay the audio marker preview.
◾ Audio marker preview play can be configured to play a snippet BEFORE or
AFTER the marker. The different modes can help you find accurate cue
points by listening to the preview.
◾ When adjusting start/end/loop sample positions, the data wheel adjustment
increment is scaled based on zoom level. Zoom in for very fine, samplelevel, control or zoom out for coarser adjustments.
◾ The selection of chop type (e.g. threshold, regions, BPM, etc) from LCD is
now made in a cancellable popup so you don't destroy slice edits
accidentally.
◾ Limitations on slices have been removed. Slices no longer have to run in
order, or be contiguous. They can even overlap.
◾ Added many new convert/assign features employing the new nondestructive chop functions.
◾ Sample chop operations are undoable.
◾ GUI waveform handles improved. They are now clearer and easier to move,
and include the slice number, and intelligent display.
◾ Waveform handles are adaptively displayed in chop mode: the end marker is
only shown for the currently selected slice. This reduces visual clutter and
makes it easier to see all of your slices. The handles highlight to indicated
which point (start/end/loop) is being edited from the hardware.
◾ GUI timelines are clearer, and have new bars/beat/pulses display option.
◾ The sample editor automatically opens on currently selected sample.
Playing pads in main mode updates the currently selected sample.
◾ Updated pad lights in new sample trim and chop modes to make use easier.
◾ Retune a sample to the sequence tempo (press WINDOW over the sample
edit “tune” parameter, or process FROM BPM in the GUI panel).
◾ New, reorganised, sample process panel.
◾ Time stretch process gains a ratio setting allowing you to easy calculate the
time stretch factor.
◾
◾
◾
◾
◾ Ability to remove all slices in a sample.
◾ Your sample editor settings are remembered between runs on MPC.
Pad perform mode allows you to assign musical scales, modes, chords, and
progressions to the pads for more creative performance. Press PAD ASSIGN when
using a plugin, MIDI, or keygroup program.
◾ Allows mapping any scale over the pads starting from any note in any
octave. (Also provides modes.)
◾ User-selectable start octave to ensure playable range in bank A is useful. This
can be quickly adjusted with via up/down function keys.
◾ LCD displays the mapping of notes/chords to the current pad bank.
◾ Pad perform mode highlights each octave’s root notes so you can see how
octaves map onto your pads.
◾ The ability to base each pad bank on an octave’s root note, or to map the
pads continuously though the banks.
◾ Chord playback facility, with ability to select notes from the selected scale
(e.g. 1-3-5, 1-3-5-7b), and chromatic patterns (e.g. major/minor/sus4/
diminished).
◾ In chord mode, press SHIFT and tap a pad for a quick chord variation.
◾ Play musical progressions with your pads: in progression mode you can
select banks of chord progressions with which you can quickly construct
songs.
◾ Each progression has an associated scale that will be automatically selected.
This means you can immediately switch into “notes” mode and play
something cool over your recorded progression.
Input insert effects allow you to sample audio and record in the looper through
an insert FX chain.
Vintage mode effects can be used universally as an insert effect.
New pad layer play styles. These adjust how a sample plays without altering the
sample itself.
◾ Non-destructive sample reverse: play a slice or a region of a sample
backwards without editing the sample.
◾ Pad offset parameter:
◾ Start playback a number of samples into the audio (with a positive
offset value), or
◾ Delay a layer’s playback (with a negative offset value).
◾ Enhanced sampler.
◾ Larger GUI VU meter for better signal visibility, and greater input threshold
control.
◾ Ability to send the mono or stereo input signal through mono or stereo
insert effects.
◾ Ability to chose whether to record samples as mono or stereo audio.
◾ Enhanced program edit mode:
◾ New expanded LCD “Samples” tab with three further pages housing all new
pad layer options (slice, pad start, pad end, pad loop enable, pad loop
position, offset and reverse). This is available on the F2 tab from the
hardware, or via a collapsible GUI tab section.
◾ Pad slice parameter can select a specific sample slice (from 1 - number of
slices), “All” of the sample (this is the previous MPC behaviour, you can set
the bounds of “All” in sample trim mode), or “Pad” which unlocks the pad
parameters for pad start, pad end, pad loop.
◾ Pad level and pan added to the master tab in LCD and GUI program edit
pages.
Improvements
◾ Vintage mode effects available for MPC Studio users
◾ One-touch sequence half/double (See Edit>Sequence, or right click over the
sequence combo box, or press WINDOW over the Sequence field in Main Mode).
◾ Sequence Edit operations are available in the GUI (See Edit>Sequence, or right click
over the sequence combo box).
◾ You can now drag files anywhere into the MPC window from Finder/Windows
explorer to open them.
◾ Cursor keys are supported in the project info sample list for quick sample selection.
◾ Command/Control-click a sample in the sample list to deselect it.
◾ Project preview
◾
◾
◾
◾
◾
◾
◾
◾
◾ You can select a sequence, track, etc to export as a project preview in the
Audio Mixdown dialog. (Select “Save as project preview”).
◾ Highlighting a project XPJ file that has an associated preview will cause the
preview to automatically audition from both GUI and LCD file browsers.
◾ The file browser will hide the [ProjectData] directories when PROJECT filter
is engaged.
Step sequencer “Pad Select” button available on F4. When this is engaged, you can
tap a pad to quickly switch to step sequence events on different pads.
Sample edit time stretch off-line process extended to include BPM calculation from
sample length.
Tapping a pad in main mode updates the selected sample in the project info
window.
GUI workflow improvements:
◾ Ability to move the the main window by dragging in spare space on the
transport toolbar.
◾ Sequence/Track combo boxes open on a single click. To rename the
sequence or track, double-click the combo box.
◾ New “modal” window support. Pop-up windows are contained in the main
MPC window rather than spilling out.
LCD workflow improvements:
◾ Improved button styles, +/- pairs are clearer, as are toggle buttons and tabs.
◾ SHIFT + “multi option” tab to flip backwards through the tabs.
◾ Some LCD pages have a second bank of function keys, accessible via shift.
(See sample edit and looper pages.)
Improved audio path performance.
Many minor workflow improvements for MPC Renaissance and MPC Studio users.
Bug fixes and stability enhancements.
Version 1.7.2 (November 2014)
New features
◾ New expansion file format The new MPC “xpn” file format is a self-contained
expansion pack bundle that you can easily drag into MPC to install into the
expansion browser.
◾ MPC Expansion Builder application added, allowing you to create “xpn” expansion
pack files. Share your MPC expansions with other MPC users! (This is an optional
installable item in the MPC installer.)
◾ Drag a pad onto a Q-Link to quickly assign the Q-Link mapping.
Improvements
◾ Bug fixes and stability enhancements.
Version 1.7.1 (October 2014)
New features
◾ Pad Keys (See Tools>Pad Keys). Drive the pads and banks from your computer
keyboard. Use 1/2/3/4, Q/W/E/R, A/S/D/F and Z/X/C/V to emulate pad presses. Use
[ and ] to switch pad banks. Use J/K/L to set pad input velocity (to quarter level, half
level, full level).
◾ New keyboard shortcut (and menu item) to change sequence immediately, and to
change after current sequence finishes playing (See Edit>Sequence>Next
Sequence Now).
◾ Mixer view filters are remembered between runs of MPC. Your favorite mixer setup
is now permanent!
◾ Menu item for launching the MPC expansion pack store.
◾ Solo operations are now automatable.
Improvements
◾ Insert effects in the “assignable parameter” LCD pop-up (accessed from main
mode) launch the insert editor when you press Window.
◾ Audio export defaults to saving in the project’s directory.
◾ Improved performance of Expansion Browser when viewing many expansion
packs.
◾ Improved program change and bank change (LSB/MSB) MIDI message support.
◾
◾
◾
◾
Improved stability of file load/save operations.
Improved VST plugin scanning performance.
Improved audio path performance.
Bug fixes and stability enhancements.
Version 1.7 (September 2014)
Important note
This is a major MPC release with many new features and important enhancements.
Please be aware that the audio architecture has changed significantly. All old MPC
projects will load into version 1.7 and should still sound identical. However, the old
project structure will be converted into the new MPC 1.7 format. The files you save
will not be backwards compatible with MPC version 1.6 or earlier.
New hardware support
◾ Support for MPC Studio Gold.
New mixer architecture
◾ Tracks are no longer audio channels, but house MIDI data.
◾ Each program is an audio channel, complete with its own insert effect chain and
audio routing options. All program automation (e.g. pad/program audio channel
mixer settings, plus other pad/program automatable parameters) is recorded perprogram in each sequence.
◾ All mixer channels now have headroom, and can apply up to 6.0 dB boost. (This is
available on pad audio strips, program audio strips, the metronome and master
volume controls).
◾ All mixer values are shown accurately with dB values. This appears on slider scales
and on all value tooltips.
◾ Audio VU meters reflect accurate audio values in dB.
◾ Audio VU meters have peak hold.
◾ Click to reset the peak value.
◾ Clipping audio channels are indicated by a red peak value.
◾ The Program Mixer shows a program audio channel strip to the right of the mixer.
◾
◾
◾
◾
◾
◾
◾ This allows you to control the overall program level and add inserts in the
context of entire-program mixing.
◾ You can hide this by deselecting “Show program strip” in the mixer sidebar.
Program Mixer improvements when mixing pads:
◾ Pads route audio to their associated program audio channel by default.
◾ Enabling pad inserts no longer routes to a submix — the pad continues to
route to it’s program audio channel.
◾ Program Mixer now shows VU meters for every pad.
◾ A pad indicator below the channel strip indicates pad activity, and allows
you to preview a pad sound in the mixer. You can drag a sample onto this
pad from the file browser.
New Program Mixer strip filters available in the Program Mixer sidebar:
◾
Show all pads (to show all pads, including unused pads)
◾
Show pads with samples
◾
Show pads with events
◾
Show pads with samples or events
◾
The “events” filters can check for events on the current track only, or on all
tracks in the current sequence.
New Track Mixer strip filters available in the Track Mixer mixer sidebar:
◾
Show tracks (de-select this to hide all MIDI track strips).
◾
Show all tracks (to show all tracks, including all unused tracks).
◾
Show programs (de-select this to hide all program audio channel strips).
◾
Show unused programs (de-select this to hide programs that are not used
in the current sequence).
New keygroup mixer (shown in Program Mixer Mode for a keygroup program)
allows you to add inserts to individual key groups and mix keygroups directly.
Program Edit Mode allows you to adjust pad and program inserts.
Drag-and-drop insert effects between pad strips, program strips, and the master
insert effect slots.
◾ Drag an insert to move it into a new slot.
◾ Hold control/command to copy the effect to the new insert slot.
◾ Alt/Option click on all faders, knobs and sliders to reset to the default value. This
works in all mixers, for the metronome volume, master volume, and sample
audition volume controls.
◾ GUI mixer channel strips show the current track/program/pad with a red highlight
ring.
◾ Click a mixer channel strip to select it as the current track/pad.
New automation architecture
◾ Individual programs now have automation “arm” mode: Off, Read, Write.
◾ Press the
icons on the channel strip to toggle Off, Read, and Write arm
modes. When there is recorded automation you must hold Shift to enter Off mode
(without Shift-clicking the button will toggle Read and Write arm modes only).
◾ If a program is armed in Write mode, all automation adjustments (to its mixer
settings, Program Edit Mode setup, pad settings, and program/pad insert effects)
will be recorded into the program. Automation is written whether the transport is
in Record mode or in Play mode.
◾ The GUI toolbar provides a “global” automation control. Selecting a global state will
force all programs into this automation arm mode.
◾ The Q-Link Trigger hardware button acts as an automation arm control. The
button illuminates in Read arm mode, and flashes in Write arm mode. No light
shows when automation is Off.
◾ When there is automation recorded you have to simultaneously press the
Shift hardware button to enter the Off arm mode.
◾ In the LCD preferences you can set the Q-Link Trigger button behavior
page to be:
◾ Control current program automation arm state.
◾ Control global program automation arm state.
◾ Many more MPC parameters are now automatable.
◾ You can automate many more drum program parameters.
◾ You can record automation for program insert effects.
◾ You can record automation for pad insert effects.
◾ Selection of automation parameters has been vastly improved, with a hierarchical
menu providing access to track (i.e. MIDI CCs), program (drum program or software
plugin instrument) parameters, pad insert parameters (for drum and keygroup
programs), and insert effects.
◾ MPC GUI editors denote automation event types clearly with color-coded icons.
◾ Orange icons are performance events, green icons are track (MIDI) events,
blue icons are program automation events, red icons are pad automation
events.
◾
note events, performance data (aftertouch, pitch bend, channel/note
pressure events), track “mixer” MIDI event, other track MIDI event,
program mixer automation, program parameter automation, program
insert effect automation, pad mixer automation, pad parameter
automation, pad insert effect automation.
Other new features
◾ AAX plugin format for Pro Tools 10 and 11.
◾ Multi-processing audio path to improve audio performance. (You can configure
this in the “Other” Preferences window tab).
◾ AIR’s Hybrid 3 virtual instrument integrated deeply into MPC.
◾ Hybrid appears in the plugin program instrument browser under “MPC
Expansions” and in the new Expansion Browser sidebar.
◾ A custom Hybrid Program Edit Mode layout allows hands-on live control of
common Hybrid 3 controls on the Q-Links.
◾ An integrated Program Edit Mode GUI layout shows these Hybrid controls
clearly. You can open the standard Hybrid GUI in a separate window for fine
control of all Hybrid settings.
◾ MPC’s Hybrid 3 is compatible with standard Hybrid 3 presets, so any presets
you install will instantly appear in MPC.
◾ You can access the Hybrid 3 manual from the Help menu.
◾ Integrated Expansion Browser providing a more streamlined way to access your
MPC instrument and sample expansion packs. Press the expansion button in the
bottom-left of the GUI file browser to switch to/from expansion browser mode.
◾
◾
◾
◾
◾
◾
◾ Sample expansion pack contents are accessible by program, sample,
sequence or demo project.
◾ Virtual instrument expansions are accessible by their preset.
◾ Loading an expansion demo sequence will automatically load the
corresponding program. (Hold shift when loading to skip this.)
◾ Hold shift when loading a program to auto-load the corresponding demo
sequence.
Direct Record in Sample Record Mode. When you record audio with the transport
running, you have the option to “Add Event” when you assign the new sample to a
pad. Selecting “Add Event: Yes” here will insert an event on the timeline at the exact
time you made this recording, so the new sample plays seamlessly in your project
You can use this to create complex layered recordings very easily.
The file browser sample audition has a configurable audition volume. Select this in
the GUI via slider or using the “Volume” F-Key button on the LCD Browser window.
Q-Link controls are enhanced to be able to control many more parameters.
◾ Improved Q-Link pad mapping menu.
◾ Access to many more drum program parameters.
◾ Better selection of insert effects and insert parameters.
New plugin scanner:
◾ Crash protection for scanning unreliable/buggy plugins.
◾ Scans plugins concurrently for faster results.
◾ Improved scanner output, showing progress and results more clearly.
◾ Ability to drag a VST into the project info area to scan it quickly.
Enhanced audio export:
◾ Ability to automatically “explode” the audio export:
◾ by program, and
◾ by track.
◾ Optional mixdown of the master insert effects when exporting master
outputs.
◾ Optional mixdown of the insert return buses as separate files when
exporting tracks and programs.
Track Explode function (See Edit>Track>Explode).
◾ Drag pads Main Mode to move/copy them.
◾ Drag from one pad onto another pad to move it.
◾ Hold control/command to copy the pad into the new pad.
◾ A GUI keyboard display can be shown at the bottom of the screen. (See
Tools>Show MIDI Keyboard). This shows the notes being played on the current
track, and allows you to enter notes directly into MPC.
◾ MIDI Keys: You can use your computer keyboard to input MIDI notes (See
Tools>MIDI Keys). The QWERTY keys A to ; and W to P act as a piano keyboard. You
can adjust the octave played using the [ and ] keys.
◾ Duplicate to new track: Duplicate a program to new track: Right-click a program
in the project info list and select “Duplicate to new track”. This makes a new copy of
the program, assigns it to the next unused track, and switches to that track.
◾ MPC toolbar shows a MIDI input indicator as well as a MIDI output indicator.
◾ Support for Akai MPK keyboards.
◾ Registration information shown in a Preferences window tab.
◾ New View menu, allowing you to select MPC mode, and toggle various editor view
settings.
◾ Keyboard shortcut controls for many common operations:
◾ M: Note erase
◾ N: Note repeat
◾ Control/Command + 1 through 0: Change MPC mode
◾ Shift + Control/Command + W: Show/hide GUI keyboard
◾ Control/Command + W: Toggle MIDI keys
◾ Shift+Control/Command + K: Show TC settings
◾ Control/Command + [ or ]: Track down/up
◾ Shift+Control/Command + [ or ]: Sequence down/up
Workflow improvements
◾ Sequence playback position and loop start/end points shown as a progress bar
overview in Main Mode and Sample Record Mode.
◾ The Main Mode GUI panel now shows a program audio channel strip beside the
pads, for quick access to inserts and mixer setup. (For MIDI programs, this shows
the current track MIDI strip.)
◾ One shot audition option in Sample Edit Mode. In Trim Mode pads 1 to 4 audition
the sample as One Shot, pads 5 to 8 as Note On. In Chop Mode you can select
whether to audition as One Shot or Note On.
◾ Press and hold the Shift button to see the name of the items being mixed on the
LCD (i.e. the program, track, or pad name).
◾ Main Mode screen has an Assignable Parameter display. Place the cursor over the
“Vel%” field and press the Window button to show and edit more track/program
values. Highlight a field and press “Set” to show this parameter on the main screen.
◾ Faster hardware pad copy workflow: Press and hold Shift. With Shift held: Press
Pad Copy, tap the “from” pad and then tap the “to” pad. The pad is instantly copied.
Continue to hold Shift and press Pad Copy again to quickly make more pad
copies.
◾ LCD mixers show accurate dB values. You can set the whole and fractional part of
these for fine control, or use The MPC Renaissance numeric keypad to type in a
new dB values.
◾ Hold down Shift when adjusting a Q-Link for fine-grained control of a parameter.
◾ Double-tap the Note Repeat button to latch note repeat mode.
◾ Multiple pad selection is shown on the pad lights in Program Edit Mode.
◾ Enhanced Program Edit Mode pad selection. Highlight an editor field and
press the Window button to refine the pad selection.
◾ Sample Record Mode shows the “Now” position, a sequence progress overview bar,
and the current sample recording length.
◾ Holding Shift whilst pressing +/- in LCD lists jumps by ten items.
◾ Program Edit mode keygroup selection improved: press Shift+pad to select the
keygroup that this pad will trigger. Continued Shift+pad presses cycle through all
keygroups that apply.
◾ MPC grid editors automatically switch to show newly recorded automation events.
◾ GUI list editor improved, with clearer display and enhanced event editing.
◾ Program lists and menus are no longer separated by program type, all programs in
your project are selectable from the same list.
◾ Single-click in the sample editor Chop Mode waveform to insert a new slice point.
◾ Audio recording improvements in Sample Record Mode:
◾ Audio recording does not truncate the start of the sample.
◾ LCD shows accurate recording length during the recording.
◾ Master volume/metronome volume knob tooltips show the currently selected level
for better volume control.
◾ Enhanced file browser:
◾ Performance enhancements: sample preview is more responsive.
◾ GUI: Click a sample again to re-preview.
◾ GUI: Folder drop-down menu lists all installed expansion packs for easy
access.
◾ File Browser automatic sample audition play duration is configurable (See
Preferences>Other>Audition Auto Play).
◾ Grid editor piano roll shows the currently playing notes (for MIDI programs and
plugin programs).
◾ Improved automation and MIDI control change menus, and the on-screen display
of these selections.
◾ Sixteen Levels setting is saved and restored between MPC uses.
◾ Loading a sequence file into an unused sequence does not prompt for which
sequence to load into.
◾ Unused pads behave more consistently in the mixers.
◾ New plugin dialog remembers filter settings.
◾ Many other minor LCD and GUI workflow improvements.
Improvements
◾
◾
◾
◾
Increased the number of virtual outputs available when running MPC as a plugin.
MPC handles a missing audio device more gracefully.
Improved and more reliable virtual instrument hosting.
Audio path optimizations.
◾ Many bugfixes and stability enhancements.
◾
Version 1.6 (November 2013)
New features
◾ List Editor: Provides a GUI and LCD-based event editing interface for fine-tuning
event lists. Click the GUI list toolbar icon to switch between grid or list view. SHIFTpress STEP SEQ to enter the LCD list editor.
◾ Note length quantize: adjusts the position of the note ends, or make notes play
legato.
◾ New editor scrolling behaviour: toolbar buttons toggles between scroll modes: Off,
Page, Scroll.
◾ Added MIDI control mode layouts for pad chromatic scale layout.
Improvements
◾ Bugfixes and stability enhancements.
Version 1.5 (September 2013)
New features
◾ MIDI control mode: use your MPC hardware as a configurable MIDI control surface.
◾ MPC software runs without hardware present; use MPC on the road without
plugging in hardware.
◾ Configurable pulse display resolution (set this in Preferences>Sequencer).
Improvements
◾ 16-levels now works instantly. 16-level engages as soon as you hit the button. Press
and hold 16 LEVEL, then tap a pad to change pad assignment on the fly.
◾ Improved project information display, including a tree-view of project contents,
improved icons displaying program and sample types, and built-in sample
◾
◾
◾
◾
◾
◾
◾
◾
◾
◾
◾
◾
◾
auditioning. The sample list is context sensitive, and shows only the samples used
by the current selection (i.e. the selected sequence/track/program).
Many UI and workflow improvements.
Purge samples workflow improvement.
Next sequence mode and song mode show sequence loop points in the timeline.
Improved timeline editing. You can now extend a sequence and set loop points
directly in the timeline.
Improved stability hosting various third party plugins.
Improved drag and drop capabilities.
Plugin editor window position made persistent.
Improved behavior when an audio interface is removed.
MPC saves the master level and submix levels in project files.
Support for MPC Element hardware.
Compatibility with MPC Essentials projects.
Performance enhancements.
Many bugfixes and stability enhancements.
Version 1.4 (April 2013)
New features
◾ 64-bit support for PC/Mac. The standalone application, VST and Audio Unit plugins
now have 64-bit versions.
◾ Ability to load samples when playing.
◾ Ability to export return buses.
◾ Auto-save function (see preferences window).
◾ New AD envelope type (see Program Edit mode).
◾ Control surface buttons auto-repeat when you hold them down (useful for zoom,
locate, etc).
◾ Quick bank/mode selection via button double-tap. You can double-tap shift to
enter “shift lock” mode. You can also double-tap bank/mode buttons directly.
◾ Multiple file selection in file browser.
◾ New file browser folder button behavior. The 1-5 buttons retain their stored
location when you move away from them; the location can be set by holding shift
as you press.
◾ QLink control of zoom and scroll in the sample editor.
◾ Added a sample overview in sample editor.
◾ LCD sample editor supports zoom and scroll.
◾ MIDI clock receive.
◾ Ability to alphabetically sort the samples list (see button over the Sample list)
◾ New command history window, with the ability to drag the undo position around
(Edit>History…).
◾ Holding shift at startup skips any autoload files.
Improvements
◾ Improved performance when switching sequences suddenly. No more dropped
beats!
◾ Improved display of events in the track view.
◾ Grids and lists show when they have lost focus.
◾ Title bar shows "+" when the project has unsaved changes.
◾ Updated the UI in many other areas.
◾ Click and drag in grid headers to audition a range of events.
◾ Track view supports region select across multiple tracks.
◾ Undo/redo buttons on toolbar.
◾ Effects selection has updated UI, with sort by vendor/type.
◾ Address issue where some plugins and MIDI equipment react badly to MIDI volume
changes. (Volume control messages are not sent on a track unless explicitly set.
Until set, the fader shows a “?”.)
◾ Rationalize track types.
◾ You can now assign "no program" to a track.
◾ Automation chase when relocating playback position.
◾ Optimization and performance improvements for better workflow.
◾ Fixed many bugs.
◾ Fix MIDI sync send.
◾ Fixed hardware screen corruption issues.
◾ Fixed software unlock issue experienced by some users.
Version 1.3.1 (March 2013)
This release addresses some minor issues in version 1.3:
◾ Newly loaded projects play at the correct tempo.
◾ Fixed issues with MPC 5000 import.
◾ Fixed issues with sample audition from file browser.
Version 1.3 (February 2013)
New features
◾ Completely redesigned plugin architecture, allowing more features and flexibility.
You can route multiple tracks to the same plugin.
◾ ProTools transport control (see Help menu for setup instructions).
◾ New vintage emulation mode: SP1200 Ring.
◾ Hardware zoom control (press shift + cursor keys).
◾ Project archive facility, to easily move projects between computers (File>Export>As
Project Archive).
◾ Facility to delete all unused samples in a project (Edit>Delete Unused Samples).
◾ File import of MPC2000 and 2000XL format APS and ALL files.
◾ Support for custom program edit UIs for plugin programs. The bundled
instruments now have tailor-made editors.
Improvements
◾ New program mixer, with ability to hide unused tracks, and show mixer strips for
plugin programs.
◾ Improved plugin selection system, allowing you to browse by plugin type, and by
manufacturer.
◾ Redesigned main mode GUI, making information clearer and speeding up the
workflow.
◾ Added new track and sequence selectors to speed up access.
◾ Project info list shows program type and the plugin loaded in each plugin program.
◾ Improved track view display, with automation editing for plugin programs, and
access to common track settings in the lane.
◾ Improved the program editor for plugin programs.
◾ You can drag samples to lanes in the grid to load them onto a pad.
◾ Double-click in sequence editor to insert/remove a slice point.
◾ Improved the hardware’s pad light performance.
◾ Improved QLink performance.
◾ Better preferences window, that looks better and is better organized.
◾ Audio export of submixes and plugin programs.
◾ Improved MPC 3000 file import.
◾ Next sequence mode works like an MPC 4000, rather than an MPC 5000.
◾ Many, many bug fixes.
Version 1.2 (November 2012)
Improvements
◾ Many bug fixes and stability enhancements.
◾ Improved the software installation procedure.
Version 1.1 (October 2012)
New features
◾ Support for MPC Studio hardware.
◾ Support for ProTools. MPC runs as an RTAS format plugin inside ProTools 9 and
ProTools 10.
◾ Tracks are assignable to individual outputs in the Track Mixer.
◾ Enhanced audio export, with better workflow and the ability to export individual
Submix busses.
◾ Support for Bank Select and Program Change MIDI messages.
◾ Realtime sample playback indicator in the Sample Editor.
◾ Selectable MIDI output port routing to DAW when running as a plugin.
◾ Quick tool selection when grid editing using numeric keys.
◾ Support for VST and Audio Unit plugin preset selection.
Improvements
◾ Improved audio synchronization when running as a plugin in Ableton Live, Logic,
ProTools and Cubase.
◾ Improved file save and load performance in plugin mode.
◾ Improved performance when recording long sequences and automation.
◾ Support for fullscreen mode and retina text display on Mac.
◾ Improved support for 3rd party VST and Audio Unit plugins.
◾ Bug fixes and stability enhancements.
Version 1.0 (August 2012)
This is the initial MPC software release, with support for MPC Renaissance hardware.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement