Agilent Technologies J-BERT N4903B Technical data

Agilent Technologies J-BERT N4903B Technical data
Agilent Technologies
N5990A-301
PCI Express
Link Training Suite
Getting Started Guide
Notices
© Agilent Technologies, Inc. 2013
No part of this manual may be reproduced in
any form or by any means (including electronic
storage and retrieval or translation into a
foreign language) without prior agreement and
written consent from Agilent Technologies,
Inc. as governed by United States and
international copyright laws.
Manual Part Number
N5990-11301
Edition
4th edition, Oct. 09, 2013
Printed in Germany
Agilent Technologies
Warranty
The material contained in this document is
provided “as is,” and is subject to being
changed, without notice, in future editions.
Further, to the maximum extent permitted by
applicable law, Agilent disclaims all
warranties, either express or implied, with
regard to this manual and any information
contained herein, including but not limited to
the implied warranties of merchantability and
fitness for a particular purpose. Agilent shall
not be liable for errors or for incidental or
consequential damages in connection with
the furnishing, use, or performance of this
document or of any information contained
herein. Should Agilent and the user have a
separate written agreement with warranty
terms covering the material in this document
that conflict with these terms, the warranty
terms in the separate agreement shall
control.
Technology Licenses
The hardware and/or software described in
this document are furnished under a license
and may be used or copied only in accordance
with the terms of such license.
Restricted Rights Legend
If software is for use in the performance of a
U.S. Government prime contract or
subcontract, Software is delivered and licensed
as “Commercial computer software” as
defined in DFAR 252.227-7014 (June 1995), or
as a “commercial item” as defined in FAR
2.101(a) or as “Restricted computer software”
as defined in FAR 52.227-19 (June 1987) or any
equivalent agency regulation or contract
clause. Use, duplication or disclosure of
Software is subject to Agilent Technologies’
standard commercial license terms, and nonDOD Departments and Agencies of the U.S.
Government will receive no greater than
Restricted Rights as defined in FAR 52.22719(c)(1-2) (June 1987). U.S. Government users
will receive no greater than Limited Rights as
defined in FAR 52.227-14 (June 1987) or DFAR
252.227-7015 (b)(2) (November 1995), as
applicable in any technical data.
Safety Notices
CAUTION
A CAUTION notice denotes a
hazard. It calls attention to an
operating procedure, practice,
or the like that, if not correctly
performed or adhered to, could
result in damage to the product
or loss of important data. Do
not proceed beyond a
CAUTION notice until the
indicated conditions are fully
understood and met.
WARNING
A WARNING notice denotes a
hazard. It calls attention to an
operating procedure, practice, or the
like that, if not correctly performed
or adhered to, could result in
personal injury or death. Do not
proceed beyond a WARNING notice
until the indicated conditions are
fully understood and met.
Technical Assistance: Contact Center
If you need product assistance or if you have suggestions, contact the
Agilent Technologies, Inc. Contact Center in your area listed on the
Agilent homepage at:
http://www.home.agilent.com
Representatives of the Agilent Contact Centers are available during
standard business hours.
Before you contact the Contact Center, please note the actions you
took before you experienced the problem. Then describe those
actions and the problem to the technical support engineer.
Find a Mistake?
We encourage comments about this publication. Please report any
mistakes to the Contact Center. The Contact Center representative
passes your comments to the Learning Products Department.
NOTE
3
Agilent continually strives to provide its customers with current, accurate, and
complete information to assist them in the use of our products. The Agilent
documents available online contain up-to-the minute changes that occurred
after the preparation of this manual. They are located on the Agilent web at:
http://www.agilent.com/find/support.
N5990A-301 Getting Started Guide
Contents
1. INTRODUCTION...........................................................................................................6
PCI Express Link Training Suite................................................................................................................................6
2. SOFTWARE INSTALLATION AND UPDATE.............................................................7
Software Update............................................................................................................................................................7
Software Installation.....................................................................................................................................................7
3. STARTING AND REGISTERING THE SOFTWARE...................................................8
Starting Registered Software.......................................................................................................................................8
Software Registration...................................................................................................................................................8
4. SETUP..........................................................................................................................9
5. USING THE SOFTWARE...........................................................................................10
Connecting To The Instruments................................................................................................................................10
Main User Interface....................................................................................................................................................12
Help...........................................................................................................................................................................13
Basics........................................................................................................................................................................13
Demo Mode...............................................................................................................................................................14
Applying....................................................................................................................................................................14
PCI Express Physical Parameters.............................................................................................................................14
Link Training Pattern................................................................................................................................................15
Loopback Pattern......................................................................................................................................................16
Clock Tolerance Compensation................................................................................................................................17
Error Detector...........................................................................................................................................................18
Output Parameters.....................................................................................................................................................18
Timing.......................................................................................................................................................................18
Voltage Levels..........................................................................................................................................................19
De-Emphasis.............................................................................................................................................................19
Jitter/SSC..................................................................................................................................................................19
Interferences..............................................................................................................................................................20
Bit Error Rate Measurement.....................................................................................................................................20
Sequencer..................................................................................................................................................................20
BERT Control...........................................................................................................................................................21
Power Switching.......................................................................................................................................................21
Saving And Loading Settings...................................................................................................................................22
Expert Mode..............................................................................................................................................................22
Exporting The Script.................................................................................................................................................22
Script Editing...............................................................................................................................................................22
Limitations................................................................................................................................................................24
6. TROUBLESHOOTING...............................................................................................25
4
N5990A-301 Getting Started Guide
Startup Fails..............................................................................................................................................................25
Slow Response..........................................................................................................................................................25
Link Training Fails....................................................................................................................................................25
7. SWITCHING TO VERSION 1.1..................................................................................26
Script.........................................................................................................................................................................26
Setting Files...............................................................................................................................................................26
8. SUPPORT...................................................................................................................27
5
N5990A-301 Getting Started Guide
1. Introduction
PCI Express Link Training Suite
The Agilent PCI Express Link Training Suite (N5990A-301) is a
software tool which allows to train PCI Express 3.0 links. It controls
the pattern sequencer of an Agilent J-BERT N4903B to bring the
device under test into the loopback mode. Enabling the loopback
mode is usually a prerequisite for receiver compliance testing. In the
following, the PCI Express Link Training Suite is also referred to
shortly as “PCIe Link Training Suite” or "software".
6
N5990A-301 Getting Started Guide
2. Software Installation and Update
The PCI Express Link Training Suite N5990A-301 runs on a PC which
controls the J-BERT. If N5990A-301 is already installed on the PC
and shall not be updated, proceed to the next chapter.
Software Update
If you want to upgrade a previous version of the PCI Express Link
Training Suite, please uninstall it first from the PC. Continue with
the software installation.
Software Installation
Prior to installing N5990A-301, if not yet installed, the following
software has to be installed, items 1 through 3 in this particular
order:
1
Microsoft Windows XP SP3 or higher
2
Agilent VISA IO Library 16.3 or higher
3
Microsoft .NET Framework redistributable 2.0
Make sure your N4903B J-BERT has firmware version 7.40 or higher
installed. Then execute the installer file
“PCIeLinkTrainingSuiteInstaller” (see Figure 1).
Figure 1: Installer wizard
7
N5990A-301 Getting Started Guide
3. Starting and Registering the Software
Starting Registered Software
Double click on the PCI Express Link Training Suite icon on the
desktop or start the software from the Start / Programs / BitifEye
menu.
If you already registered your software, it will start automatically.
Proceed to the next chapter.
Software Registration
If you start the software without a valid registration key, the window
shown in Figure 2 will open.
To get a valid registration key, send an e-mail to
[email protected] with the following information:
•
Customer name (such as company and department or university
and institute)
•
16 digit certificate number (XXXX-XXXX-XXXX-XXXX), supplied
with your license certificate.
•
Site Code and MID from the startup license dialog.
Your activation code will be provided within three working days after
sending the mail to the address indicated above.
Figure 2: Licensing window
8
N5990A-301 Getting Started Guide
4. Setup
There are several instruments which can be controlled by the PCIe
Link Training Suite when properly connected:
•
An N4903B J-BERT is required
◦
If an J20 module is installed, it can be used to generate
sinusoidal interferences
◦
If jitter and/or SSC is available, these parameters can be
controlled
◦
If the AUX OUT is available, two-lane data can be
generated
•
An N4916B de-emphasis signal converter can be used to
generate de-emphasized signals. The N4916B must be
connected to the J-BERT via USB
•
An N4880A reference clock multiplier can be used to
multiply a reference clock from a DUT, in order to use the
DUT's clock for pattern generation. The N4880A must be
connected to the J-BERT via USB
•
An 81150A arbitrary waveform generator (AWG) can be used
to generate common-mode sinusoidal interference. If no AWG
is connected, the interferences are generated using the JBERT's J20 module, if available
Please follow the connection diagrams in the PCIe Link Training
Suite for details about the proper connection.
9
N5990A-301 Getting Started Guide
5. Using the Software
Connecting To The Instruments
Once the software started, the main window and the connection
dialog will appear as shown in Figure 3.
Figure 3: Main window and connection dialog
In the “Connection Dialog” window:
10
1.
Select the J-BERT configuration (one or two channels)
2.
Enter the VISA address of the J-BERT
3.
Select whether you want to use an N4916B de-emphasis signal
converter or not, and whether you want to use an N4880A
reference clock multiplier or not
4.
If you chose a two-channel configuration: since the J-BERT has
only one error detector, select which TX lane of the DUT is
connected to the J-BERT's error detector
5.
If you want to use calibration data from the Agilent N5990A
automated test solution, select the calibration data folder in the
“Calibration Files Directory” box.
6.
If you have an 81150A AWG to generate common-mode
interference, check the “CM Interference AWG” check-box and
enter its VISA address in the text-box below
7.
If you have a remote-controllable power switch, check the
“Power Switch” check-box and enter it's address. The default
address format is “IP;Username;Password”. You must also
select a channel number.
N5990A-301 Getting Started Guide
8.
Click the „Connect“ button
9.
If the connection was successful, the button „Apply and Close“
will be enabled, see Figure 4
10. Click the „Apply and Close“ button. This will reset and
initialize the instruments
•
If you don't want to reset the instruments, click the
“Close” button. However, the “Apply and Close” button is
recommended, to initialize the instruments into a wellknown state.
Figure 4: Connection Window (instruments connected)
You can use instruments (N4903B, 81150A) connected via Ethernet,
USB or GPIB. The instruments must already be configured in the
Agilent IO Expert in order to be able to remote-control it using the
PCI Express Link Training Suite. Please refer to the Agilent IO
Libraries Suite Quick Start Guide when connecting the J-BERT to
your PC the first time. As soon as this is done, you can find out the
VISA address by selecting the J-BERT in the list of instruments in the
Agilent IO Expert. Note that socket connections are not supported.
In order to be able to use an N4916B de-emphasis signal converter, it
must be connected to the rear USB port of the J-BERT. Please refer to
the N4916B Getting Started Guide when connecting an N4916B the
first time. The same applies for the N4880A reference clock
multiplier.
11
N5990A-301 Getting Started Guide
Main User Interface
After the successful connection to the instruments, the main window
is displayed as given in Figure 5. This window is split into two major
parts:
•
•
The left part of the window displays PCI Express specific
parameters:
•
PCI Express spec version and DUT type
•
The training sequence and loopback pattern
•
PCI Express specific presets
The right part of the window displays common J-BERT
parameters:
•
Data rate and clock generation
•
Voltage levels
•
De-Emphasis
•
Jitter injection and interferences
•
Bit error rate measurement
•
BERT control
Figure 5: Frame Generator main window
12
N5990A-301 Getting Started Guide
Help
In the “Help” menu (top right corner of the main window), you will
find:
•
The "Getting Started Guide" (F1; this document)
•
The "Language Guide", which describes the script language
you can use in expert mode
•
The "About" dialog, with version and license information
Basics
The basic operation of the PCIe Link Training Suite would be as
follows:
•
Select a PCIe revision
•
Select a loopback pattern
•
Apply the settings to the instruments and train the device
into loopback
Now you can adjust the instrument parameters to debug your DUT,
e. g. reduce the differential amplitude until bit errors are observed or
deviate the data rate to test the DUT's margins.
One of the main features of the PCIe Link Training Suite is to modify
the training sequence and the loopback pattern. You can let the PCIe
Link Training Suite generate those automatically, or you can finetune the sequence and patterns using a simple macro language.
Two terms you might encounter from time to time are "sequence" and
"pattern". A pattern is a stream of bits that is sent out by the BERT.
In order to be more flexible, the entire bit stream is divided into
multiple patterns, which are then processed by a sequencer. The
sequencer can loop patterns and step from one pattern to another.
This way, it is possible to generate very long data streams with only
short patterns, which perfectly fit into the instrument's limited
memory.
CAUTION
13
Since the PCI Express Link Training Suite is mainly intended for
debugging and troubleshooting, the parameters are not constrained
to the compliance values. Therefore, you must take care not to
increase critical parameters beyond the ratings of your DUT. Also
note that the parameters you apply should be calibrated with the
corresponding instrument, they are typically however not calibrated
with regard to your specific setup!
N5990A-301 Getting Started Guide
Demo Mode
When you close the connection dialog without connecting
instruments, you enter the Demo Mode.
The Demo Mode is intended for demostration purposes, where no
actual hardware is available. Most functions will be available, but no
instruments are affected.
Applying
When changing any parameter in the user interface, you'll have to
apply those changes to the instruments by clicking the “Apply”
button in the bottom left corner of the main window. This applies all
parameters at once. Pressing F6 on your keyboard has the same
effect, as well as using the menu command “Apply” in the
“Instruments” menu.
Many group boxes and windows have a dedicated “Apply” button,
which only apply the parameters in that group or window.
There is also the menu command “Apply Pattern Only” to apply the
pattern only while remaining all other parameters untouched. You
can find this command in the “Instruments” menu. You can also
press Shift+F6 on your keyboard, or click the main “Apply” button
while holding the shift-key.
One special case are track bars. For example, there is a track bar in
the “Voltage Levels” group box. When you move a track bar, the
affected parameter is immediately applied to the hardware.
PCI Express Physical Parameters
The corresponding controls are shown in Figure 6.
To test a PCI Express DUT, you must define the PCIe specification
revision and a DUT type. These parameter affect the available
settings and the way calibration data is handled. For PCIe Gen3 ASIC
tests, you'll also have to select the calibration channel.
Figure 6: PCI Express Physical Parameter Settingss
When you change one of these settings, your instruments will
automatically be re-configured.
14
N5990A-301 Getting Started Guide
When the de-emphasis signal converter is connected, or when the PCI
Express specification 3.0 is used, the current preset is also shown.
The “Preset...” button allows to select a preset from a list. The
selected preset is applied to the de-emphasis parameters on the right
side of the main window, and to the encoded preset hin in the
“Loopback Pattern” box. When the de-emphasis levels on the right
side of the main window are changed, the corresponding is shown.
Link Training Pattern
The link training sequence is supposed to train your device into
loopback. By default, it is generated automatically. However, you
have the option to parametrize the sequence to adjust it to your
device's needs.
Figure 7: Link Training Pattern Settings
When you click on “Edit Training Parameters…” (Figure 7), you can
adjust the number of packets transmitted for every stage of the link
training (Figure 8).
The “Initial delay” is a sequence of zeros transmitted before link
training. By default, you'll have to start the link training by exiting
this block via the “Manual Trigger” button (main window). However,
you can specify a time span instead.
The “Add EIEOS” check-box allows to insert some EIEOS (Exit From
Electrical Idle Ordered Sets) before loopback starts. This is not
required by the CTS, but might me helpful for some DUTs. Every 32nd
TS1 ordered set will be replaced by an EIEOS. This number is fixed
in order to match the J-BERT pattern granularity.
15
N5990A-301 Getting Started Guide
Figure 8: Sequence to Loopback Mode
All other parameters reflect the standard sequence described in the
CTS. Note that “Min. initial TS1 count” and “Min TS1 count before
Loopback” are only arbitrary numbers. The actual number of
transmitted ordered sets might be slightly different in order to match
the J-BERT pattern granularity.
There are two presets, which can be selected using the “Preset...”
button. Trying both can be helpful for debugging. The “Optimized
Parameters” is used as default, since it works with most DUT. The
“CTS Parameters” represents the link training procedure
recommended by the CTS; however, this link training procedure
might not work with every DUT.
The option “Encoded Lane Number” option (in the main window)
allows to define the lane number which is encoded in the training
Pattern. By default, this value is always set to “Lane 0”. When you
want to run link training on another physical port of the DUT, just
connect that port to the J-BERT; the lane number can remain “Lane
0”. However, some DUTs require the lane number being set to the
corresponding physical port number.
The option “Encoded DUT TX Preset Hint” allows to define the
equalization preset that is requested for the DUT.
Loopback Pattern
The pattern which is continuously transmitted in loopback mode can
be defined in the “Loopback Pattern” box, as shown in Figure 9. You
can select between the PCI Express Compliance Pattern, the PCI
Express Modified Compliance Pattern, and a custom pattern file.
16
N5990A-301 Getting Started Guide
Figure 9: Loopback Pattern Settings
In the simplest case, a custom pattern file can be a text-file
containing only hexadecimal data. Note that the binary data
represented by this file must have a 512 bit granularity; otherwise,
the pattern cannot be loaded into the J-BERT's pattern memory. The
syntax of the selected file is automatically verified before the file can
be used. For details about the syntax and the possibilities of custom
pattern files, please refer to the “PCI Express Link Training Suite
Language Guide”.
When the Complaince Pattern is used in PCI Express Gen 3, the
generator's equalization preset hint is also encoded in the pattern.
The encoded value can be manually changed.
Clock Tolerance Compensation
In this group box you can select how SKP ordered sets are inserted
into the training and loopback pattern. By default, no extra SKP
ordered sets are generated (except at points where the PCI Express
specification explicitly requires them, e.g. in the Gen 3 modified
compliance pattern).
Figure 10: Clock Tolerance Compensation Setting
When the DUT has it's own reference clock, and no SSC is used
(“SRNS”, Separate Reference Clocks with No SSC), SKP ordered sets
must be inserted at an interval defined in the PCI Express
specification. When the DUT has it's own reference clock, and SSC is
used on both the generator and the DUT side (“SRIS”, Separate
Reference Clocks with Independent SSC), SKP ordered sets must be
inserted in even shorter intervals.
Changing the “SKP Ordered Set Insertion” option (Figure 10) defines
how often SKP ordered sets are inserted. Note that the gap between
two SKP ordered sets might be shorter than required by the
specification, in order to fit the pattern into the J-BERT's pattern
memory.
Note that when a custom loopback pattern is used, there are no SKP
ordered sets inserted into the custom pattern.
17
N5990A-301 Getting Started Guide
Error Detector
By default, the J-BERT error detector compares all bits from the DUT
with the loopback pattern. With the option in the “Error Detector”
group box, SKP ordered sets can be excluded from bit comparison.
Figure 11: Error Detector Settings
Changing this setting (Figure 11) to ignore 8b/10b SKP ordered sets
or 128b/130b ordered sets is usually required when the DUT uses its
own reference clock.
Output Parameters
In the upper right part of the main window, as shown in Figure 12,
you can adjust the following parameters of the J-BERT:
•
Timing
•
Voltage levels
•
De-Emphasis
•
Jitter and SSC
•
Sinusoidal interferences
Figure 12: Output Parameters
Timing
Click “Timing Setup” to open the timing setup window. Here you can
define the data rate and add some deviation to it. The reference clock
can also be modified, but keep in mind that the valid range and
granularity is restricted by the J-BERT hardware.
18
N5990A-301 Getting Started Guide
By default, the generator uses an internal clock source, or an
external clock multiplier (N4880A) for system board tests. Note that
the N4880A must be connected to the J-BERT and configured in
order to use it.
You can configure the analyzer's clock to external clock or internal
CDR.
Voltage Levels
You can set the voltage levels for every output independently. Note
that when moving any slider, the corresponding parameter will be
written to the hardware immediately. Otherwise, you'll have to click
the “Apply Levels” button. Note that the “Apply Levels” button also
applies the de-emphasis levels (if available).
You can also use the "Apply" button on the lower left corner of the
window to apply all parameters at once. Alternatively, you can click
the "Apply" command from the "Instruments" menu, or press F6 on
your keyboard.
De-Emphasis
If you connected an N4916B to the J-BERT, you can control the deemphasis and preshoot levels. The tabs let you select between three
different views:
•
de-emphasis and pre-shoot in dB
•
FIR tap coefficients
•
emphasized and de-emphasized voltage levels
Note that when moving any slider, the corresponding parameter will
be written to the hardware immediately. Otherwise, you'll have to
click the “Apply” or “Apply Levels” button.
Jitter/SSC
Click “Jitter/SSC” to open the jitter window. Note that the
composition of available jitter sources is different for every spec
version and DUT type (which is selected in the main window in the
“PCI Express Physical Parameters” box).
Note that when moving any slider, the corresponding parameter will
be written to the hardware immediately. Otherwise, you'll have to
click the “Apply” button. When you change any parameter, e. g. enter
a new value into a text-box, the corresponding “Apply” button is
highlighted. This means that you have to apply in order to activate
your changes.
If you use calibration data, the compliance jitter values will use
calibrated levels. However, jitter parameters which are not covered
by the specification will not be calibrated.
19
N5990A-301 Getting Started Guide
Note that some jitter/SSC parameters will reset the sequencer when
modified. This means that the current sequencer state is left and the
link training is restarted. With the default settings, this means you'll
have to click the “Manual Trigger” button again to start link training.
The PCIe Link Training Suite tries to minimize the sequencer resets
as much as possible, but it is recommended to keep an eye on the
sequencer state when changing jitter or SSC parameters.
Interferences
Click the "Interferences…" button to open the interferences window.
You can modify the common-mode and differential-mode sinusoidal
interferences.
If you are connected to an 81150A AWG, common-mode interference
is generated using this AWG. If there is no AWG connected, commonmode interference is generated with the J-BERT J20 module. Using
the J20 is less accurate and cannot be combined with differentialmode interference. Be sure to have the AWG/J20 connected properly.
If you use calibration data, the compliance interference values will
use calibrated levels.
Bit Error Rate Measurement
You can click the "Start BER Measurement" (Figure 13) in the right
part of the window to automatically poll the J-BERT's bit and error
counters. By default, the displayed BER (Bit Error Rate) is calculated
from the total number of bits and total number of errors. You can
click the button on the left side of the BER display to toggle to the
current BER, which is the calculated BER of the last error counter
reading. Note that neither of these number is necessarily always
equal to the BER displayed in the J-BERT, since the measurement
intervals might be different.
Figure 13: Bit Error Rate Measurements
You can click "Reset BER Measurement" to reset the bit- and errorcounter.
The BER can be used to determine whether link training was
successful or not. A very high BER and increasing error count could
indicate that no link training was performed, because the error
counter is always programmed to only compare the loopback pattern.
Sequencer
The group box in Figure 14 shows the sequencer control.
20
N5990A-301 Getting Started Guide
Figure 14: Sequencer Control
When the “Poll Sequence State” option in the “Options” menu is
enabled, the current state of the sequencer is shown.
When the sequence contains a loop with a manual break condition,
that loop can be ended with the “Manual Trigger” button.
BERT Control
Figure 15 Shows the BERT control. Here you can control the
sequencer, the pattern generator and the analyzer.
Figure 15: BERT control
The “Insert Bit Error” causes the J-BERT to insert a single bit error
into the data stream. This can be useful to verify that the DUT is in
loopback; when the DUT is not in loopback, inserting bit errors do
not affect the bit error and BER counters.
You can use the "Auto Align" button to force the analyzer to autoalign to the incoming data. This is usually necessary after the pattern
generator was restarted, e.g. when a new pattern was downloaded.
Power Switching
If a power switch system is connected, the group-box “Power Switch”
will be visible in the main window (see Figure 16; only visible when
Power Switch is connected). Here you can turn the power off and on.
This can be used to power-cycle the DUT.
Figure 16: Power Switch
21
N5990A-301 Getting Started Guide
Saving And Loading Settings
You can store your current settings using the “Apply and Save...”
button in the main window, or via the main menu. Note that before
the settings are saved, they are applied to the hardware. Only if
applying succeeds, the settings can be saved. This guarantees that
only those settings can be saved which are in a consistent state.
The settings can be restored at any time using the “Load and Apply...”
button. The restored settings are then immediately applied to the
hardware.
Expert Mode
In the "Options" menu, you can enable "Expert Mode". This mode is
recommended for advanced users and offers you some more
parameters to modify. The main advantage of the Expert Mode is the
possibility to edit the link training sequence and pattern using a
special script.
Exporting The Script
Once you found a link training sequence suitable for your needs, you
may want to export this sequence, e. g. for later use or to export it to
the automated test solution software.
To export the current script, click “File”, then “Export Script”. This
saves the currently used script for the training sequence to a file,
regardless whether you defined it via parameters or editing the PCIe
or generic script. Please refer to the next section for details about
scripts.
Script Editing
The main advantage of the Expert Mode is the possibility to edit the
link training sequence and pattern using a script. This allows you to
define virtually any kind of pattern, whereas the methods mentioned
earlier in this document only allow to generate patterns which are in
sync with the PCIe link training methodology.
In order to be able to edit the script, Expert mode must be enabled,
and the script must be defined as the source of the pattern. By
default, the pattern that is downloaded to the J-BERT is defined via
parameters, like the “PCI Express Training Parameters” box.
However, in Expert Mode the group box “Pattern/Sequence Script”
becomes available (Figure 17).
22
N5990A-301 Getting Started Guide
Figure 17: Expert Mode
When the radio button “Generate From Parameters” is checked, the
pattern will be automatically generated, i. e. the same way as in nonExpert Mode. When the radio button “Use Custom Script” is checked
(see Figure 18), a custom script will be used. The parameters for the
automatically generated script are disabled then and have no
influence.
Figure 18: Expert Mode With Custom Script
23
N5990A-301 Getting Started Guide
To edit the script, click the “Edit Script” button. The script editor, as
shown in Figure 19, will pop up. In the script editor, you can edit the
sequence and pattern, with a unified syntax. It allows you to define
the data using terms common to PCI Express. For example, to
generate a TS1 ordered set with the loopback flag set, you can use the
macro “TS1(Loopback)”. You can also use the menu to convert
pattern data between different representations (binary, hexadecimal,
8b/10b).
Clicking the “Process PCIe Macros” button starts a script translation,
where all PCI Express specific macros and symbol names are
converted into their binary or 8b/10b representation.
When the automatically generated script is used, the “Edit Script”
button will change to “View Script”. In that case, the script can only
be changed by modifying the parameters in the main window.
Figure 19: Script Editor
For more details about the language syntax, please refer to the “PCI
Express Link Training Suite Language Guide”. This document can be
opened from the “Help” menu of the main window or the Script
Editor window.
Limitations
When editing the script, the resulting pattern must not violate the JBERT's limitations. The main limitation is the 512 bit pattern
granularity.
If the pattern you want to define doesn't meet this granularity, you
could e. g. repeat the pattern until the granularity is met (using the {}
operator), or place a Pad0() macro somewhere to stuff the pattern
with zeros. For more details, please refer to the “PCI Express Link
Training Suite Language Guide”.
24
N5990A-301 Getting Started Guide
6. Troubleshooting
Startup Fails
The anti-virus software Sophos Endpoint Security might
inadvertendly detect the PCIe Link Training Suite as a virus and
prevent it from executing. Starting the Link Training Suite then leads
to an error message like "Windows cannot access the specified
device, path, or file". In this case, please check if the anti-virus
software blocked the executable file of the PCIe Link Training Suite
and add it to the exceptions. Note that you probably have to repeat
this procedure for some of the DLLs.
Slow Response
If you encounter a slow response of the PCIe Link Trainging Suite
user interface, this might be a result of a bad remote connection.
Probably the delay over ethernet is too high.
In most cases, it will be helpful to disable the BER polling and the
sequencer status polling. The BER polling can be disabled by simply
clicking the "Stop" button in the "Bit Error Rate Measurement" group.
The sequencer state polling can be disabled by un-checking the "Poll
Sequence Status" item in the "Options" menu.
Link Training Fails
If link training fails, you might want to check the following points:
25
•
Did you already click "Apply" after connecting and adjusting
all your parameters? Note that just connecting doesn't
automatically download the pattern and settings!
•
Is the injected jitter too high? Try reducing or disabling the
injected jitter in the "Jitter/SSC" dialog.
•
Is the timing, the voltage levels and the de-emphasis correct?
•
Is the selected link training sequence suitable for your DUT?
Probably using a tweaked sequence helps your DUT to get
into loopback. Try the "Preset..." button in the "Sequence to
Loopback Mode" dialog. This dialog opens when you click
"Edit Parameters..." in the "PCI Express Training Parameters"
group of the main window.
N5990A-301 Getting Started Guide
7. Switching to Version 1.1
Script
The PCIe Link Training Suite v1.0 automatically inserted a pause at
the beginning of the link training sequence. You had to click "Manual
Trigger" to start link training. The PCIe Link Training Suite v1.1
requires to have this sequence step being defined in the script.
When you load a script generated with v1.0 into the new v1.1
software, link training will immediately start after downloaded to the
instrument. To get the old behavior back, you have to modify the old
script as follows:
•
After "Blocks:", insert the following line:
initial_pause: Pad0();
•
After "Sequence:", insert the following line:
00. initial_pause, manual;
Note that you don't have to apply these changes unless you want to
load an old script into the new version of the Link Training Suite.
Setting Files
The jitter mechanism changed from PCIe Link Training Sutie v1.0 to
v1.1. When you use v1.1 or later to load a settings-file (*.ltss) which
was saved with v1.0, the jitter settings can't be restored. Instead,
jitter will remain untouched.
Settings that weren't available in v1.0 also won't be restored when
loading a settings file generated with v1.0. Those settings will remain
unchanged when loading a settings file.
26
N5990A-301 Getting Started Guide
8. Support
In case of persisting problems with the PCI Express Link Training
Suite, please send a problem description to the PCI Express support
node [email protected]
In case you want to report an error shown in an error dialog, please
copy the complete contents into the e-mail. You can press CTRL+C in
the error dialog to copy the contents into the system clipboard.
27
N5990A-301 Getting Started Guide
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement