Google SketchUp Lesson3
Google SketchUp 3
Camera Angles
Scenes
Animations
Camera Angles
Unlike other NLEs or animations programs, SketchUp does not use timelines and keyframes. SketchUp
instead uses Scenes to control an animation. Each Scene is a different camera angle of a project. An
Animation is simply a string of Scenes played end to end. SketchUp offers a variety of tools for setting
up camera angles. Before learning about animations and scenes, we’ll take a look at the camera tools at
your disposal.
Orbit (Camera > Orbit)
This tool rotates the camera around your model. The center of the screen will always be the focal point.
This tool will allow you to rotate the camera under your model if you need to look up into your model for
modifications
Pan (Camera > Pan)
This tool will allow you to pan the camera vertically or horizontally. This tool combined with the Zoom tool
will allow you to move along all 3 axes (X,Y,Z).
Zoom (Camera > Zoom)
The Zoom tool lets you move in and out of your model. By default, a scroll mouse always controls this
tool.
Orbit, Pan and Zoom are all easily available through the Large Tool Set. On a PC, the Large Tool Set
can be activated by View > Toolbars > Large Tool Set. On a Mac, the Large Tool Set can be activated
by View > Tool Palettes > Large Tool Set.
Walk (Camera > Walk)
This tool allows you to set the camera at a specific height and walk around your model. By default, all
faces and edges you have drawn become solid objects the camera cannot move through. You will
however climb up any ramps and stairs you have built. The Walk tool only allows you to walk around
though.
Hotkeys:
•
Type in a measurement: set your eye height.
•
Arrow Up/Down or Mouse Up/Down: Move forward and back
•
Arrow Left/Right or Mouse Left/Right: Turn left and right
•
Shift + Arrow Up/Down or Mouse Up/Down: Move up or down. Be careful, this changes
your eye height! You can reset it by typing in a measurement again.
•
Shift + Arrow Left/Right or Mouse Left/Right: Walk sideways left or right
•
Option + Arrow Up/Down or Mouse Up/Down: Run forward and back
•
Option + Arrow Left/Right or Mouse Left/Right: Turn left and right quickly
•
Option + Shift + Arrow Left/Right or Mouse Left/Right: Run sideways left or right
Look Around (Camera > Look Around)
This tool allows you to set the camera at a specific height and look around your model. By default, you
cannot move when using this tool. If you zoom in/zoom out, you will effectively move forward, but you will
also change your eye height.
Once you can walk and look around, you can start creating an animation. This is a simple process but it
is recommended you create a new copy of your work for this. What you will effectively do is add Scenes
to your project. Each scene will be a separate keyframe in your animation. Once you play your
animation, SketchUp will play through all your different Scenes animating the camera based on the
different views you made for each scene.
2
Scenes
Adding Scenes
We’ll set up a simple animation with these steps, remember to save a new version of your file for this:
1.
Position your camera in front of your model using any camera tool you want. Use the
Walk tool and set your eye height to any reasonable value (like your actual height).
2.
Create a new Scene by going to the View menu and selecting Animation > Add Scene.
This is the first view/keyframe of your animation.
3.
Move forward into your model a few feet.
4.
Add a new Scene.
5.
Move forward a few more feet.
6.
Add a new Scene.
Playing your Scenes
1.
If you have multiple Scenes, you can click through all of them to see the different steps in
your animation.
2.
Go to View > Animation > Play to play your animation. A set of Pause and Stop buttons
should appear.
3.
Go to View > Animation > Play to stop playing your animation.
Updating your Scenes
Each time you add a Scene, you are locking in a camera angle. You can always go back into a Scene
and change the camera angle if you like though.
1.
Go back into a previously created Scene
2.
Change the camera angle with the Look Around tool
3.
Go to View > Animation > Update Scene to set in the new angle
4.
Go to View > Animation > Play to play your updated animation
3
Animations
Modifying Animation Timing
SketchUp does not offer several options to modify the speed of your animations. There are only 2
options to modify: Scene Transitions and Scene Delay. Both options are available through Window >
Model Info > Animation. Scene Transitions and Scene Delays can both be modified while an Animation
is playing only in the Mac version of SketchUp.
Scene Transitions
Unchecking the “Enable Scene Transitions” box turns off transitions. In SketchUp, transitions are the
actual movement in an animation. Increasing the numbers in the “Transition:time” field will slow down an
animation’s movement.
Scene Delay
Scene Delay is the pause between Scenes. Setting this number to 0 will create one continuous motion
through your Scenes.
Exporting the Animation
Once you are happy with your animation, it is a simple process to export your animation. You have
several options though that can influence the quality of your exported animation. The easiest option is to
simply have SketchUp make a video file of your animation.
1.
Once your animation is done, go to File > Export > Animation.
2.
On a Mac, you should choose QuickTime Movie, Options > CD-ROM Large for best
results
or
On a PC you should choose AVI, set your Width and Height to 640x480 and choose Full
Frames (Uncompressed) for best results.
3.
Save your video file. SketchUp will create a video file for you.
4
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising