Cisco Configuration Engine

Cisco Configuration Engine
Automatic Configuration Deployment Using
Cisco Configuration Engine (CCE)
BRKNMS-2784
Agenda
  What Is Cisco Configuration Engine?
  Cisco Configuration Engine Architecture
  Network and Device Configuration Requirements
  Configuration Deployment Process using CCE
  CCE Deployment Considerations
  Templates Overview
  Sample Templates
  Integration Through Webservice APIs
  Case Studies
  Demo
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
2
What Is Cisco Configuration Engine
  Cisco Configuration Engine is
Scalable and flexible application designed to automate
Configuration and Image deployment to large number of
devices quickly and efficiently
  Who could benefit from this application
Service Providers—for consistent and large scale
deployment of Customer Premise Equipments (CPE),
automatic turn up of services and efficiently handle Moves,
Adds, Changes, and Deletes
Large and Medium Enterprises—for deployment of routers
in with consistent configuration which are geographically
dispersed. Efficiently handle any large scale configuration
changes and Image management
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
3
Product Features
Secure and
Scalable
  Scalable up to 30,000 CPE devices on single server
  Secure deployment and management over SSL
Zero-Touch Service   Significant reduction in time to roll out new service
through elimination of staging and manual processes
Deployment
Configuration
Services
  Configuration update to one or a group of devices
  Email and e-page notification of outcome
Image Services
  Policy-based validation of device resources
  Support for devices behind firewall and dynamic
IP addressing
Web-Based GUI
  Feature-rich Web GUI that enables customers to use
the product without additional configuration
Velocity Template
Engine
  Customizable to meet customers’ business and
operation requirements
  Work flow control and support for scripts
Web Services
  XML and Simple Object Access Protocol (SOAP) Web
Service Description Language (WSDL) available for all
features supported from the Web GUI
2010
Cisco
and/or its affiliates.
All rights reserved.
C97-504880-00BRKNMS-2784_c1
© 2008 Cisco Systems, Inc.©All
rights
reserved.
Cisco Confidential
Cisco Public
4
Cisco Configuration Engine:
Supported Platforms
Access Routers
 
 
 
 
 
 
 
 
 
 
 
 
Cisco 800 Series
Cisco 1800 Series
Cisco 2800 Series
Cisco 3200 Series
Cisco 3800 Series
Cisco SOHO 70 and
90 Series
Cisco 1700 Series
Cisco 2600 Series
Cisco 3600 Series
Cisco 3700 Series
Cisco Unified
Communications
500 Series
Cisco 500 Series
Secure Routers
BRKNMS-2784_c1
Access and Metro
Switches
 
 
 
 
 
 
 
 
 
 
 
 
 
Cisco Catalyst 2950
Cisco Catalyst 2960
Cisco IE3000
Cisco Catalyst 3550
Cisco Catalyst 3560
Cisco Catalyst 3560-E
Cisco Catalyst 3750
Cisco Catalyst 3750-E
Cisco ME 3400 Series
Cisco ME 3400E Series
Cisco Catalyst 4500
Cisco ME 4900 Series
Cisco Catalyst 6500
© 2010 Cisco and/or its affiliates. All rights reserved.
Aggregation
Routers
 
 
 
 
 
 
 
 
Cisco 7200 Series
Cisco 7300 Series
Cisco 7500 Series
Cisco ASR 1000 Series
Cisco 7600 Series
Cisco 10000 Series
Cisco 10700 Series
Cisco 12000 Series
Cisco Public
Voice and
Wireless
 
 
 
 
 
 
 
Cisco AS5300 Series
Cisco AS5400 Series
Cisco AS5800 Series
Cisco IAD2400 Series
Cisco IAD880 Series
Cisco MWR 1900
Cisco MWR 2900
5
CCE System Architecture
Customer
Application
XML and SOAP
Publish and Subscribe Event Bus
Velocity
Template
Engine
Dynamic
NSM
Intelligent Modular
Gateway (IMGW)
Device
Module
Toolkit
SSH
Telnet
Configuration Service
Web Services XML and SOAP
Event
Gateway
Configuration
Services
Image
Services
Data Storage
TCP and SSL
TFTP
Server
FTP
Server
  Delivers initial and partial
configuration
Image Service
HTTP and HTTPS
  Distributes and activate
software image to
Cisco devices
Event Gateway
Device Interface
Cisco
Catalyst® OS
Cisco IOS
Software
Cisco VPN
3000
BRKNMS-2784_c1
Device Interface
Event
Agent
Execution
Agent
Image
Agent
Configuration
Agent
  Acts as an interface
between the devices
and the event bus
Cisco IOS Software Device
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
6
Required Bootstrap Configuration
What is a Bootstrap
Configuration?
Configuration for Secure Mode of Operation
Bootstrap configuration is
initial set of dynamic startup
configuration commands
•  Specific to the customer
•  Service, location, etc., agnostic
Cisco IOS Software Device
BRKNMS-2784_c1
crypto ca trustpoint corp.abc.com
enrollment mode ra
enrollment url ftp://<ftp-user>:<ftp-password>@<certserver>/<signed-certificate>.crt
usage ssl-client
revocation-check none
!
crypto ca authenticate corp.abc.com
!
cns password <challenge-password>
!
cns trusted-server all-agents <CCE-Server>
cns id hardware-serial
cns id hardware-serial event
cns id hardware-serial image
cns event <CCE-Server> encrypt <Event Gateway Port>
keepalive 60 3
cns config initial <CCE-Server> encrypt 443 inventory
!
cns image server https:// <CCE-Server>:443/cns/
HttpMsgDispatcher status
https:// <CCE-Server> :443/cns/HttpMsgDispatcher
!
cns inventory
transport event
announce config
cns exec encrypt 443
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
7
Preparing the Configuration Engine
Device ID and Configuration Template
Set up device in Cisco Configuration
Engine before device deployment
  Add device ID: Unique device identifier
Device ID can be hostname, IP address, MAC
address, hardware serial number, unique device
identifier (UDI)), or any string
  Associate configuration template
with device
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
8
Deployment of CPE using CCE
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
9
Deployment Model with CCE
True Zero Touch Deployment
DHCP/tftp
bootstrap
<config-data>
Blah
Blah
Blah
…
</config-data>
S
S
L
Network
Config
Branch
Office or
Customer
Premises
<config-data>
Configuration
Engine
Blah
Blah
Blah
…
</config-data>
1. Device shipped from Cisco manufacturing to branch with no config.
2. CE is notified to add the device and associated with a configuration template
3. Device is connected and initiates DHCP/TFTP requests for bootstrap
4. Device loads bootstrap, initiates connection to CE
5. CE identifies the device and sends the full configuration to the device,
config agent loads the configuration, device operational
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
10
True Zero Touch Deployment Sequence
CPE
2
DHCP Request
DHP Ack—Option 150
5
4
Bootstrap Configuration
Config Send
7
Cisco
Configuration Engine
DHCP Discover
DHCP Offer
3
TFTP
6
1. 
CPE sends Dynamic Host
Configuration Protocol (DHCP)
Discover
2. 
3. 
DHCP server replies with Offer
CPE sends DHCP Request
4. 
5. 
11. 
12. 
13. 
14. 
DHCP server replies with Option 150
CPE requests bootstrap file over TFTP
TFTP server sends CPE bootstrap file
CPE requests config template
CE responds with the template
CPE is operational
HTTP Get for Template
Response for Template
9
Warehouse and Service
Provider Network
1
DHCP
8
CPE becomes Operational
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
11
Deployment Model with CCE (2)
One-Touch Deployment
Staging
facility
Configure basic IP setting and
default route to reach CCE
box
!
CNS Configuration
ip host cns-ce1 10.1.3.7
cns config initial 10.1.3.7 80
cns id hardware-serial
cns id hardware-serial event
cns id hardware-serial image
cns event cns-ce1 11011
keepalive 60 3
cns exec 80
Device Connects to CCE
Validate Certificates
Request Configuration from
CCE
S
S
L
Customer
Premises
CCE authenticates the device
Provides the configuration for
the device (includes base+wan
+service)
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
12
Bootstrap Options
  Traditional staging
Manual or script
Same bootstrap configuration for all devices
  USB token
Load bootstrap from a USB key, if supported
  Configuration express
Cisco manufacturing loads bootstrap before shipping
  Remote user GUI
A GUI application to allow remote users to upload bootstrap
  Autoinstall
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
13
Beyond Initial Deployment
Customer or Partner
Application
Web Services
XML and SOAP
Configuration and Image Services
  Configuration Changes
Secure configuration updates to thousands
of devices in minutes
Secure distribution of service configuration
(voice, VPN, and security)
  Image Distribution
Cisco IOS Software images, Cisco Catalyst
software images, intrusion protection system
(IPS) files, Cisco Security Manager files,
Cisco IP Phone images, music-on-hold
(MOH) files, interactive voice response
(TCL IVR) files, and more
network
  Image Activation: Any File, Anywhere
Cisco IOS Software and Cisco Catalyst
software images can be activated and
the device reloaded and verified
Configuration commands can be applied
immediately prior to image activation
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Web GUI or Web Services Interface
Cisco Public
14
Support for Platforms Other than Cisco IOS Software
Network Services or Other Cisco Platforms
Device Development Module (IMGW)
  Device Communication Driver
Extend configuration engine to support
protocol native to the device (Telnet, SSH,
HTTP, TL1, etc.)
Enable customers to develop their own
scripts and communicate with devices not
supported by configuration engine
  Sample Applications
Non-IP: Develop module to communicate
to the devices
through modem or console server
and use all product functions
available through GUI or API
Third-party devices: Extend configuration
engine functions
to support third-party devices
and platforms
Configuration
Server
Directory
IMGW Runtime
Southbound Interface
Existing Device
Module
Devices Not Enabled
for Network Services
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
Registration
Utility
Plug-in
Device Module
New Types
of Devices
15
CCE Deployment Consideration
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
16
Configuration Engine
Recommended Hardware
Linux Platform: Red Hat v4.0 &
v5.0
Solaris Platform: Solaris 10
VMWare
Recommended Specifications
(20,000 Devices)
Recommended Specifications
(30,000 Devices)
Recommended Specifications
  CPU: Intel Xeon Processors 4 @ 2.33
GHz
  CPU: Sun T1000 with 8 core, 1.0 GHz
UltraSPARC T1 Processor
  RAM: 4 GB
  RAM: 16 GB
  Hard drive: 72 GB
  Hard drive: 146 GB 10K RPM SAS drive
Minimum Specifications
(5,000 Devices)
Minimum Specifications
(10,000 Devices)
  CPU: Intel Pentium III
  CPU: Sun Sparc
  RAM: 1 GB
  Hard drive: 40 GB
BRKNMS-2784_c1
Guest OS specification same as
Linux Platform.
  RAM: 1 GB
  Hard drive: 40 GB
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
17
Deployment Consideration
  Support external LDAP for ease of sharing
devices database
  Load sharing with an external load balancer (such as
ACE) to achieve even higher scales
  Highly available operation (with load balancer)
Support both n+1 and 1+1 deployment model
Redundancy setup is completely transparent to the day-to-day
operation of the Configuration Engine
Failover to the standby is automatic
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
18
Consistent configuration deployment process is a
primary requirement for successful management of
a service
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
19
CCE Templates for
Device Configuration
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
20
Templates
  Templates allows the customer to create parameterized
service configuration, which could then be used for
configuration of the CPEs
  CCE supports two types of templating mechanism
Legacy templating mechanism
Direct IOS commands are used
Parameters can be substituted where ever user input is required (No
manipulations allowed)
Suited for simple configurations
Velocity templating mechanism
Industry standard and equivalent to scripting
Parameters are supported and logical actions can be taken based on
user input
Suited for sophisticated service configurations
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
21
Template Parameters
  Template parameters allow the user to provide the
values for each device. Device configuration is
generated with the user provided parameter values
  CCE provides the capability to define new
parameters based on service requirements
  Optionally, parameter validation rules can be
associated to prevent user input errors
  Out-of-the-box validation rules are available;
custom validation rules can also be created
Example: IP address, numeric only, etc.,
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
22
Legacy Templates: Example
hostname ${LDAP://this:attrName=IOShostname}
!
interface %FastEthernet 0%
description ${LDAP://this:attrName=IOSwandescription}
ip address ${LDAP://this:attrName=IOSwanipaddress} ${LDAP://this:attrName=IOSwannetmask}
speed ${LDAP://this:attrName=IOSintfspeed}
duplex ${LDAP://this:attrName=IOSduplex}
no ip directed-broadcast
no ip redirects
no ip proxy-arp
no shutdown
load-interval 30
no cdp enable
!
snmp-server community ${LDAP://this:attrName=IOSsnmpcommunity1} view SNMPbugfix RO 99
snmp-server community ${LDAP://this:attrName=IOSsnmpcommunity2} view SNMPbugfix RO 99
snmp-server community ${LDAP://this:attrName=IOSsnmpcommunity3} view SNMPbugfix RO 99
snmp-server community ${LDAP://this:attrName=IOSsnmpcommunity4} view SNMPbugfix RO 99
snmp-server community ${LDAP://this:attrName=IOSsnmpcommunity5} view SNMPbugfix RO 99
!
snmp-server location ${LDAP://this:attrName=IOSlocation}
snmp-server contact ${LDAP://this:attrName=IOScontact}
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
23
Legacy Templates: Output
  Parameter Screen
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
  Config Preview
Cisco Public
24
Velocity Templates
  Enables user customization based on device configuration
and service activation requirements
  Supports Java, Perl, Expect, and other scripting tools
  Enables customers to generate configuration dynamically
through interaction with the device
  Enables customers to develop and plug in scripts
to validate device attributes entered by network operations
center staff
  Supports scripts to autopopulate attribute values retrieved
from customer’s data repository
  Provides native support for
Variables
Nested conditions
Compound conditions
Loops
Range operators
  Velocity user guide:
http://jakarta.apache.org/velocity/user-guide.html
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
25
Velocity Templates: Variables and
Logical Conditions
Nested Conditions
Variables
#set( $vpi = 101 ) - Digits
#set( $encap = "aal5snap" ) - Strings
#set( $subnetmask = "$!
{dsobj.getValue('IOSipaddress')}")
– Substitute template attribute
#if ( $ip_address_needed == "YES" &&
$no_atm_keepalive == "YES")
ip address 10.10.1.1 255.255.255.0
no atm ilmi-keepalive
#else
no ip address
#end
Compound Conditions
2010
Cisco
and/or its affiliates.
All rights reserved.
C97-504880-00BRKNMS-2784_c1
© 2008 Cisco Systems, Inc.©All
rights
reserved.
Cisco Confidential
#if ( $ip_address_needed == "YES" )
ip address 10.10.1.1 255.255.255.0
#if ( $no_atm_keepalive == "YES")
no atm ilmi-keepalive
#end
#else
no ip address
#end
#set( $ip_digits = [1..10] )
#foreach( $ip_d in $ip_digits )
ip route 30.0.0.$ip_d 255.255.255.255 10.0.0.2
#end
Loops and Range Operators
Cisco Public
26
Velocity Templates: Example
#set( $wanDescription = $!{dsobj.getValue('IOSwandescription')} )
#set( $wanIPAddress = $!{dsobj.getValue('IOSwanipaddress')} )
#set( $wanNetmask = $!{dsobj.getValue('IOSwannetmask')} )
#set( $intfSpeed = $!{dsobj.getValue('IOSintfspeed')} )
#set( $duplex = $!{dsobj.getValue('IOSduplex')} )
!
interface FastEthernet 0/0
description $wanDescription
ip address $wanIPAddress $wanNetmask
speed $intfSpeed
duplex $duplex
no ip directed-broadcast
no shutdown
load-interval 30
no cdp enable
!
#if($snmpComm1 != "")
snmp-server community $snmpComm1 view SNMPbugfix RO 99
#end
#if($snmpComm2 != "")
snmp-server community $snmpComm2 view SNMPbugfix RO 99
#end
!
#set($fxsPortList=[0..$count])
#set($dpid = 1)
#foreach($port in $fxsPortList)
dial-peer voice $dpid pots
service mgcpapp
port 2/$port
#set($dpid=$dpid+1)
#end
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
27
Velocity Templates: Java Script
Functions
  Calling Java Script from Velocity Templates
##Invoke Javascript function to generate market specific base configuration
#if ($market == “SFO" || $market == “sfo")
$js.invoke(“sanfrancisco.io.vm", “SANFRANCISCO")
#elseif ($market == “SJC" || $market == “sjc")
$js.invoke(“sanjose.io.vm", “SANJOSE")
#end
!
##End Javascript call
  Sample Java Script
if (snmpComm1 != "") {
println("snmp-server community " + snmpComm1 + " view SNMPbugfix RO 99");
}
if (snmpComm2 != "") {
println("snmp-server community " + snmpComm2 + " view SNMPbugfix RO 99");
}
if (snmpComm3 != "") {
println("snmp-server community " + snmpComm3 + " view SNMPbugfix RO 99");
}
if (snmpComm4 != "") {
println("snmp-server community " + snmpComm4 + " view SNMPbugfix RO 99");
}
if (snmpComm5 != "") {
println("snmp-server community " + snmpComm5 + " view SNMPbugfix RO 99");
}
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
28
Using Web Services
for North Bound Integration
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
29
CCE Web Services Overview
  Provides standards-based programmatic access to
configuration engine
  Combines WSDL and client library approaches
  Packaged as a separate configuration
engine SDK sister product
  Available web services:
ConfigService: Send and acquire configurations
to and from devices
ImageService: Distribute and activate images,
obtain hardware inventory and file systems,
and delete files
ExecService: Execute show commands and
reload devices
AdminService: Create and manage system
objects used by configuration engine to
manage devices (devices, users, groups,
templates, etc.)
NSMService: Manage namespace and subjects
and subject mappings in namespace
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
30
Webservice Architecture
OSS
Application
Publish/Subscribe events
Web Services calls
Datastore
OSS apps can
integrate with CE
in two ways:
Image Server
•  Event services
Configuration
Engine
Event Bus
Device
Module
Toolkit
Telnet/SSH
Non-agent
Device
BRKNMS-2784_c1
Configuration
Server
Event
Gateway
Web Services
Distributes and
activates software
images
IMGW
•  Web services
Delivers initial and
partial
configuration
TCP/SSL
HTTP/HTTPS
Agent enabled
IOS Device
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
31
Zero Touch Using Webservice APIs
1. Provisioning application
creates the device in CCE
Provisioning
Application
7
3
2
CE
2. Associate template with
this device.
1
3. Subscribe events sent
by the device
4. Power on device; device
contact DHCP to get TFTP
IP; device download and
applies bootstrap config
Datastore
Event Bus
Web Services
Image Server
IMGW
7
Device
Module
Toolkit
Event
Gateway
7
Non-Agent
Device
BRKNMS-2784_c1
Distributes and
activates software
images
5
Configuration
Server
5. Device initiates connection
to CE to get config
6. Device gets and
applies the config
Delivers initial and
partial
configuration
6
5
Agent-enabled
IOS Device
© 2010 Cisco and/or its affiliates. All rights reserved.
4
Cisco Public
7. Device notifies CE the
config status; event gateway
forward notification;
provisioning application
receives the event.
32
Case Studies
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
33
US Service Provider—
Managed Voice Service
  Service provider offers managed voice and data
services using Cisco IAD 243x series
  Customer can choose from different tiers of
the offering
  Geographically dispersed deployment with specific
configuration for each major city/market
  Prior to CCE deployment Cisco IAD configuration
was done by copy and paste of information from
spreadsheet
  No standard provisioning and configuration
management process was in place
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
34
How Cisco Config Engine Was Used?
Phase-1
Bench Configuration:
IOS Bootstrap Config
Step 1:
Bootstrap Config
Staging Center
Step 2:
Device Configuration
Business
Inputs
Site Survey & Order
Details
“Phone Home”
instructions for CCE
Service
Params
Field Engineer
Cisco Config
Engine
Request
Config
Step 3:
Installation Truck Roll
Service
Cisco Config Config
Engine
Step 4:
Backup Running
Config in Ciscoworks
BRKNMS-2784_c1
IAD from
Warehouse
Backup “As Installed”
IAD Config in Ciscoworks
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
Customer
Premise
Customer
Premise
35
How Velocity Templates Were Used?
Phase-1
Device
Configuration
Region 1
Data
Region Specific
Configuration
Using Java
Script
Master Service
Configuration
Template
Using Velocity
Region 2
Data
Region 3
Data
Service Specific
Parameters from
CCE
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
36
How Web Service Interface Was Used?
Phase-2
Other BSS/OSS
Systems
Order Management
1
Create the device in CCE and
associate the template
2
Associate service Parameters to the
device
Device Added in
Ciscoworks
Web Services API
Cisco Configuration Engine
4
Ciscoworks LMS
CCE Authenticates the device
CCE Provides the service
configuration
5
Device Boots up and
initiates
communication
3
6
Device sends a syslog
to Cisco LMS about the
configuration change
Agent-enabled
IOS Device
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
37
Cisco Validated Design
Zero-Touch Deployment Solution
Load
balancer
Configuration
Engine
External
LDAP
Cisco Network
Registrar
(DHCP/DNS/TFTP)
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
38
Cisco Validated Design
Cisco Virtual Office
  Cisco Virtual Office is an end-to-end solution for employees that work in remote
locations including branch and home offices
  Cisco IT uses this solution
Deployed 17,000, plan to expand to 30,000
  The solution features office-caliber end-user experience
with voice, video, wireless, and real-time data
  Integrated security protects the employee and the corporate network
Cisco Unified
Communications
Manager
Family (Internet
Access Only)
Employee
(Corporate
VPN Access)
Corporate
Campus
Internet
Cisco Virtual
Office Router
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Redundant
Converged
VPN
Gateways
Cisco Public
Management
39
Cisco Virtual Office Architecture
Small Offices
and Teleworkers
Mobile Users
Public
Hotspots
  Cisco Security Manager is used to
generate configurations for
individual user.
  Cisco Configuration Engine is used
to distribute configuration as well
as image upgrade.
Secure
Wireless
Router
  A couple of 3845s are used for
DHCP as well as security
certificate management.
Management—NOC
Aggregation
SDP Server or
Management
VPN Gateway
Cisco
Cisco
Security
Manager Configuration
Engine
BRKNMS-2784_c1
  Remote routers can be shipped
directly to end user with factory
defaults or staged
Redundant
Converged
VPN Gateways
CA
Server
ACS
© 2010 Cisco and/or its affiliates. All rights reserved.
  Architecture allows for outsourcing
of NOC to separate IT entity
Corporate
Network
Cisco Public
40
CCE Demo
NMS Sessions Offered (1 of 2)
Session
Title
BRKNMS-1030
ITIL v3 Foundation and Enhanced Telecom Operations Map (eTOM) frameworks
BRKNMS-1031
Network Health Framework - A proactive solution for network health
improvement
BRKNMS-1204
Introduction to Network Performance Measurement with Cisco IOS IP Service
Level Agent
BRKNMS-1532
Introduction to Accounting Principles and NetFlow
BRKNMS-1640
Advanced DHCP and DNS Deployments
BRKNMS-1831
Network Performance Management: A proactive End-to-End approach
BRKNMS-1942
Managing Infrastructure as a Service (IaaS) for a Cloud environment
BRKNMS-2022
UC Network Management: How to Ensure Your UC Services are Operating as
Expected
BRKNMS-2025
Cisco Network Optimization
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
42
NMS Sessions Offered (2 of 2)
Session
Title
BRKNMS-2030
Onboard Automation with Cisco IOS Embedded Event Manager
BRKNMS-2031
SYSLOG Design, Methodology and Best Practices
BRKNMS-2032
DHCP and DNS for Large Scale Network Architectures and Cloud Computing
BRKNMS-2361
Accounting and Performance Management with Network Based Application
Recognition
BRKNMS-2658
Securely Managing Your Networks and SNMPv3
BRKNMS-2784
Automatic Configuration Deployment using CCE
BRKNMS-3021
Advanced Cisco IOS Device Instrumentation
BRKNMS-3043
Advanced Performance Measurement for Critical IP Traffic with Cisco IOS IP
Service Level Agreements
BRKNMS-3132
Advanced Netflow
PNLNMS-3000
Implementing Effective Day-2 Network Operations Support with ITIL
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
43
Complete Your Online
Session Evaluation
  Give us your feedback and you
could win fabulous prizes.
Winners announced daily.
  Receive 20 Cisco Preferred
Access points for each session
evaluation you complete.
  Complete your session evaluation
online
• open a browser through our wireless
network to access our portal
• or visit one of the Internet stations
throughout the Convention Center
• or from the mobile phone go to
www.ciscolive2010.com/mobile and
enter the mobile ID (located on the
front of the badge) to login.
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Don’t forget to activate your
Cisco Live and Networkers Virtual
account for access to all session
materials, communities, and on-demand
and live activities throughout the year.
Activate your account at any internet
station or visit www.ciscolivevirtual.com.
Cisco Public
44
Enter to Win a 12-Book Library
of Your Choice from Cisco Press
Visit the Cisco Store in the
World of Solutions, where
you will be asked to enter
this Session ID code
Check the Recommended Reading brochure for
suggested products available at the Cisco Store
BRKNMS-2784_c1
© 2010 Cisco and/or its affiliates. All rights reserved.
Cisco Public
45
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement