TR8 Discoverer Reports

TR8 Discoverer Reports
IP4 - Running reports
To assist with tracking and monitoring HRIS recruitment and personnel, reports can be
run from Discoverer Plus.
This guide covers the following process steps:
Logging in ........................................................................................................... 2
Selecting and running reports ................................................................................ 3
Navigation and Layout .......................................................................................... 6
Removing the ‘Available Items’ and ‘Selected Items’ panes .................................... 7
Expanding the report ......................................................................................... 7
Working with parameters and filters ....................................................................... 7
Viewing and refreshing parameters ..................................................................... 7
Page Items ...................................................................................................... 8
Group sort ....................................................................................................... 8
Re-ordering columns ......................................................................................... 9
Opening a new tab ............................................................................................ 9
Opening a new report ........................................................................................ 9
Printing and exporting reports ..............................................................................10
Printing reports ...............................................................................................10
Exporting reports .............................................................................................11
Logging out ........................................................................................................13
APPENDIX - Working with Excel ............................................................................15
Hiding and unhiding columns .............................................................................15
Deleting columns .............................................................................................16
Sorting data ....................................................................................................16
To sort by colour..............................................................................................17
Filtering data ...................................................................................................17
To filter on a colour ..........................................................................................18
v20 Version 1.0
Page 1 of 20
IP4 - Running reports
Navigate to: Personnel Services > Using HRIS > System Availability & Login
Logging in
1. Click on
under Discoverer. The Log in window opens:
2. Enter your Username (this will be
the same as your Oxford Username
e.g. admn1234).
3. Enter your Password.
4. Enter hrisprd into the Database
5. Click
.
Selecting and running reports
1. To help reduce the length of the list, enter part of the report name into the Name
contains field e.g. enter REC to find recruitment reports. Select
the full list of reports.
Note: The reports in your list may
differ from this screenshot. What you
see is dependent upon your access.
v20 Version 1.0
Page 2 of 20
to return to
IP4 - Running reports
2. Where a report has multiple tabs, double
click on the report name or click on the + to
display the list of individual tabs.
3. Highlight the required report/tab and click
.
Note: If you do not specify a tab when you select a report and it has multiple
tabs, the report will open on the tab which was run last. If you have not
previously run that report and you do not select a tab, it will default to run
the first tab.
4. The Edit Parameter Values window opens:
Note: The parameters will vary
depending upon the report and,
where applicable, tab selected.
If a value(s) is mandatory it will be indicated by an (*). If a value is not mandatory you
can leave the field blank to include all values.
Some parameters can be entered manually e.g. a two character department code.
Dates can be entered by clicking on the calendar icon.
The Description area may provide further information when you click into a parameter
(see example above).
v20 Version 1.0
Page 3 of 20
IP4 - Running reports
Note: If you only want to export the data to Excel and not review it first, it is
not necessary to enter the parameters at this point. Select Cancel. You will be
prompted to enter the required parameters during the export process.
5. Enter the required parameter/s or (if shown) click on
values.
to choose from a list of
If you click on
, the Select Values window will open. Items displayed in the
‘Selected values’ box will appear in the report. To edit the selection:
a) Click on ‘Selected values’.
b) To find a specific value, use the
‘Search for’ box. Items displayed in
the ‘Selected values’ box will
appear in the report.
c) To move an individual item select
the value and then click on the
single arrow to select or de-select as
required.
d) To move all items between the
‘Displayed values’ and the
‘Selected values, boxes, click on
the double arrows.
e) Click
or ‘Enter’ to run the
report.
v20 Version 1.0
Page 4 of 20
IP4 - Running reports
Navigation and Layout
Tool Bar
Only these items can be
used by departments.
Report title
Any parameters entered
will also be shown here.
Available Items
You will not be able to
change anything here.
Selected Items
You will not be able to
change anything here.
v20 Version 1.0
Page 5 of 20
Message
Where there is a message
relating to a specific tab it
will be displayed here.
Tabs
Where a report has
multiple tabs they
will be displayed
here.
IP4 - Running reports
Removing the ‘Available Items’ and ‘Selected Items’ panes
To see more of the columns in your report you can remove the Available Items and
Selected Items from your screen view:

From the toolbar select ‘View’ then untick the two items.
Expanding the report
Where a report contains more than 250 rows you may need to expand it to include all
rows. There are two ways to do this:
1. At the bottom of the worksheet you will
have the option to click on
to
retrieve the next 250 rows.
Note: If your report is likely to return more than 500 rows, follow step 2.
2. Go to Tools > Retrieve All Rows. This
will return all rows for the parameters
you have selected.
Note: If you are exporting the report and do not want to review it first you do
not need to expand the rows. All rows will be exported.
v20 Version 1.0
Page 6 of 20
IP4 - Running reports
Working with parameters and filters
Viewing and refreshing parameters
1. To view the parameters that you have selected once you have run a report you can
either:
a) At the top of the report beneath the report name the parameters you have
entered will be displayed. These details will also be displayed at the top of the
page if you export the report to Excel.
OR
b) Click on
. The Edit Parameter Values window will open and the parameters
you entered to run the open report will be visible.
2. To change the parameters on an open report click on
Values window will open.
3. Enter the new parameters and click on
. The Edit Parameter
or ‘enter’ to run the new report.
Page Items
Some reports include ‘Page Items’ which allow you to filter the data returned in the
report.
1. Click on the button next to ‘Page Items:’ to
view the list of options.
2. Click on the option you require and the report
will refresh to return the filtered data.
Group sort
Some reports are sorted on certain data items to ‘group’ the data under specified
headings. This makes the data easier to view on screen but if you are going to export
the report to Excel you may wish to remove the group sort. This will make it easier for
you to enhance the data by adding pivot tables and/or filters for example.
v20 Version 1.0
Page 7 of 20
IP4 - Running reports
1. To remove the group sort from a single
column, right click on the relevant column.
The menu shown will appear:
2. Click on ‘Group Sort’ to de-select. The
data will then appear in every row.
3. To remove the group sort from all columns
in the report, click on the area shown. The
entire sheet will be highlighted in blue:
4. Click on ‘Group Sort’ to de-select and wait for
the report to refresh.
Note: If you have already de-selected group sort on a single column you will
need to re-select then de-select in order for it to apply to the entire sheet.
Re-ordering columns
In some reports you can re-order the columns in Discoverer:
1. To move a column, click on the column heading and while holding the left mouse
button down drag the column across. The thick black line shows where the column
will be moved to:
v20 Version 1.0
Page 8 of 20
IP4 - Running reports
2. Release the mouse button and wait for the report to refresh. The column has now
moved.
Opening a new tab
Some reports have multiple tabs for different purposes. Personnel reports have a full
data set tab which contains all columns, and is only suitable for reviewing on screen or
exporting to Excel. A limited data set tab contains a reduced set of columns and is
intended for printing.
1. To run one of the other tabs on the report you are viewing select the tab you want to
open. If the tab relies on different parameters you will be prompted to enter or
select the values you wish to include in the report – see ‘Viewing and refreshing
parameters’ on page 5 of this guide.
2. Click
or ‘Enter’ to run the report.
Opening a new report
If you want to run a new report you can do so without exiting or closing the existing
report.
1. Go to File > Open or click on
.
2. Choose the new report that you want to run.
v20 Version 1.0
Page 9 of 20
IP4 - Running reports
Printing and exporting reports
Printing reports
Note: If you have used Page Filters only the filtered data will print. Change
the status back to <All> if you want to print out all the data in the report.
1. Select File > Print…
Where there is the option, ensure you are on the Report (limited data set)
tab which is intended for printing.
1. Select ‘Current Worksheet’ or ‘Entire
Workbook’ (this will print all tabs).
2. Click on
to ensure the format is
correct (it is generally advisable to
change page setup to A3, landscape
and adjust size to fit to 1 page wide).
3. When ready to print click
complete the printing process.
to
4. Enter or select the parameters you wish
to include in the report. If a value is
mandatory it will be indicated by an (*).
If a value is not mandatory you can
leave the field blank to include all
values.
5. Click
v20 Version 1.0
or ‘Enter’ to print the report.
Page 10 of 20
IP4 - Running reports
Exporting reports
1. Select File > Export...
wizard will open:
The
export
2. Select worksheet/workbook as required
and click
.
3. Specify destination, change the file name if required, then click
name defaults to the report name.)
. (The file
Note: Data subject to the Data Protection Act must not be stored on your C:\
drive. You should choose an appropriate alternative location to save the
report.
If you try to export the file again at a later date and save it to the same
location it will ask you if it is OK to overwrite the file.
4. Enter or select the values you wish to include in the report. If a value is mandatory
it will be indicated by an (*). If a value is not mandatory you can leave the field
blank to include all values. click
.
Note: If you are exporting a file with multiple tabs and the tabs have different
parameters you will need to enter the parameters for each tab. The edit
parameters window will show the title of each tab (see below).
v20 Version 1.0
Page 11 of 20
IP4 - Running reports
5. Finally, select the export approach
(the default of “Supervised” is
recommended):
6. When the export has completed
an Export Log will open:
7. Click on OK to finish
If the report has not returned any data the status column will show the comment below
against each of the applicable tabs.
8. Click
v20 Version 1.0
.
Page 12 of 20
IP4 - Running reports
Note: If you have used Page Filters only the filtered data will export. Change
the status back to <All> if you want to export all the data in the report.
9. Open the file in Excel.
Note: Some reports contain macros to create the formatting and include
colours to denote exceptions. In order to see the fully formatted report you
must enable the macros.
10.You may see the following yellow security warning at the top of the sheet.
11. Click ‘Enable Content’ to enable the macros.
12. The following message will
appear. Choose yes or no (you
may need to refer to your local IT
support for advice).
Note: It is possible that your local settings have been set up to deal with
macros. If the formatting is visible then you should be able to continue. If the
formatting is not visible, or you are in any doubt, speak to your local IT
support to check the policy regarding macros.
Logging out
1. To close the current report select File > Close.
2. To exit Discoverer select File > Exit.
v20 Version 1.0
Page 13 of 20
IP4 - Running reports
3. For both options the following message
will appear:
4. Click
v20 Version 1.0
.
Page 14 of 20
IP4 - Running reports
Appendix - Working with Excel
Intermediate Excel skills will be an advantage when running and exporting reports from
Discoverer. Although you can make some basic changes to some reports in Discoverer
there is much more you can do in Excel to enhance the layout of the report. We have
included some simple tips here but if you are interested in expanding your Excel
knowledge there are courses available from IT Services. Further details can be found on
the IT Services website.
Please note: this is intended to be a basic guide. The HRIS Support Centre does not
support Excel so if you are experiencing difficulties or need further assistance in the use
of Excel please seek assistance from colleagues or contact your local IT support.
Note: We have included one method for making the changes described. We
recognise that there are alternatives which you may already be using.
Hiding and unhiding columns
You may want to view a limited version of a spreadsheet but not remove the data
completely. Hiding columns or rows enables you to remove them from view.
1. Highlight the column/s you want to hide.
Click the right mouse button, choose
‘hide’.
2. To unhide, highlight the columns either
side of the ‘hidden’ column. Click right
mouse button and choose ‘unhide’.
Alternatively you can hover over the line
between the two columns either side of the
hidden column and double click the right
mouse button.
You can also hide and unhide rows using
the same method
v20 Version 1.0
Page 15 of 20
IP4 - Running reports
Deleting columns
If you no longer want a column included in a spreadsheet you can delete it completely.
Please note, once saved this cannot be undone.
1. To delete a column(s) highlight the
column(s) you wish to delete.
2. Click on the right mouse button and choose
‘delete’.
You can also delete rows using the same
method.
3. Alternatively highlight the columns and from the
home tab go to ‘cells’.
4. Click on the downward arrow under ‘Delete’,
choose delete > delete columns.
You can also delete rows using the same
method.
Sorting data
The order of data contained in a spreadsheet can be changed by ‘sorting’. E.g. you may
want to show the data in ascending order by surname or employee number.
1. In the header row click on the name of the
column you want to sort then go to the ‘Data’
Tab and click on
or
.
(Do not select the entire column as that will
result in only that column being sorted)
v20 Version 1.0
Page 16 of 20
IP4 - Running reports
2. The data will be sorted alphabetically or numerically as applicable.
To sort by colour
1. Click on any cell that contains data.
Go to the Data tab and click on Sort
.
2. Using the drop down menus choose
the following:
Sort By – Title of the column that
contains the colour
Sort On - Cell Colour
Order - choose the colour you want
to sort by.
3. Click
.
Filtering data
Filtering enables you to edit the view of data in a spreadsheet. For example, if you have
run a report containing multiple departments, you can use the filter option to show only
specified department(s).
1. Highlight the contents of the spreadsheet
from the header row down - i.e. do not
include any rows above the header row.
2. Go to the ‘Data’ tab and click on the Filter
icon.
v20 Version 1.0
Page 17 of 20
IP4 - Running reports
3. You will now see downward arrows in each
column of the header row.
4. Click on the arrow in the column you want to
filter. All of the unique items in that column
will appear in a list (alphabetically or
numerically as applicable).
5. Un-tick any that you want to remove.
If there are multiple items and you only want
to view one, untick ‘select all’ and then tick
the item/s you want to view.)
6. Click
.
7. The column you have filtered on will now
show a filtered icon
.
To filter on a colour
1. Click on the arrow in the column you want
to filter.
2. Choose ‘Filter by Colour’.
3. Click on the colour you want to view.
v20 Version 1.0
Page 18 of 20
IP4 - Running reports
4. To restore the spreadsheet to show all data,
click on the
5. Click
, click ‘select all’.
.
To toggle the text between upper and lower case
When you export reports from Discoverer the text sometimes contains a mix of upper
and lower case as shown in the example. You can correct this by applying a simple
formula in your excel document.
1. Insert a column to the right of the text you want
to amend (right Click on the column and select
Insert)
2. This will insert a new blank column.
3. Click in the first empty cell below the header row
and type in the following: =PROPER(A1) then
press Enter.
(A1 refers to the cell you are copying as shown in
the example so if your text is in column B you
would enter B1.)
4. The text has been converted so that the first
letter of each word is in capitals and the rest is
lower case
v20 Version 1.0
Page 19 of 20
IP4 - Running reports
5. Copy the formula down the rest of the new
column.
Tip: Double click the tiny black box at the bottom
right corner of the cell containing your formula.
6. We suggest you now replace the formulas with normal text. Copy the column that
you entered the formula into and paste values back into the same column.
Nothing will appear to have happened but the column now contains the corrected
text without the formulae.
7. You can now delete the column containing the mixed text. NB: Do not do this until
you have replaced the formulae in the entire column.
Tips:
To copy and paste text you can either Right click >
COPY > right click > Paste special and choose
‘values’
or Right Click > COPY > right click and click on the
values icon as shown below.
The method will depend upon the version of Excel that you are using.
There are other formulae that you can apply to correct the text case as follows:
= UPPER() - forces all letters to be UPPER CASE
= LOWER() - forces all letters to be lower case
v20 Version 1.0
Page 20 of 20
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement