Quartus II ソフトウェアの

Quartus II ソフトウェアの

14. Design Space Explorer

QII52008-9.1.0

The Quartus ® II software includes many advanced optimization algorithms to help you achieve timing closure, optimize area, and reduce dynamic power. Various settings and parameters control the behavior of the algorithms. These options provide complete control over the Quartus II software optimization and power techniques.

Each FPGA design is unique. There is no standard set of options that always results in the best performance or power utilization. Each design requires a unique set of options to achieve optimal performance. This chapter describes Design Space

Explorer (DSE), a utility written in Tcl/Tk that automates finding the best set of options for your design. DSE explores the design space of your design by applying various optimization techniques and analyzing the results. The DSE Tcl script dse.tcl is located in the <Quartus II installation directory>/common/tcl/apps/dse directory on

Windows and Linux operating systems.

DSE is a valuable tool to use in the late phases of your design cycle. You can take advantage of DSE’s capability to automatically sweep multiple options to close timing, minimize area, or reduce power consumption on a design that is nearing completion.

DSE Concepts

This section explains the concepts and terminology used with DSE.

Exploration Space and Exploration Point

Before DSE explores a design, DSE creates an exploration space, which consists of

Analysis and Synthesis, and Fitter settings available in the Quartus II software. Each group of settings in an exploration space is referred to as a point. An exploration space contains one or more points. DSE traverses the points in the exploration space to determine optimal settings for your design.

Seed and Seed Sweeping

The Quartus II Fitter uses a seed to specify the starting value that randomly determines the initial placement for the current design. The seed value can be any non-negative integer value. Changing the starting value may or may not produce better fitting results. However, varying the value of the seed or seed sweeping allows the Quartus II software to determine an optimal value for the current design.

DSE extends Fitter seed sweeping in exploration spaces by providing a method for sweeping through compilation and Fitter parameters to find the best options for your design. You can run DSE in various exploration space modes, ranging from an exhaustive try-all-options-and-values mode to a mode that focuses on one parameter.

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–2 Chapter 14: Design Space Explorer

Running DSE

DSE Exploration

DSE compares all exploration point results with the results of a base compilation, generated from the initial settings that you specify in the original Quartus II project files. As DSE traverses all points in the exploration space, all settings not explicitly modified by DSE default to the base compilation setting. For example, if an exploration point turns on register retiming, but does not modify the Placement Effort

Multiplier setting, the Placement Effort Multiplier setting defaults to the value you specified in the base compilation.

1

DSE performs the base compilation with the settings you specified in the original

Quartus II project. These settings are restored after DSE traverses all points in the exploration space. DSE makes a copy of your base revision and uses this copy for changing the settings required to traverse through all other points in the chosen exploration space. Your base revision is not affected by DSE exploration.

DSE Support for Altera Device Families

DSE support varies across Altera device families. The Stratix ® series of devices, the

Cyclone ® series of devices, and the Arria ® series of devices can take advantage of all the available DSE optimization methods. The MAX

®

II device family supports a subset of DSE options.

Timing Analyzer Support

DSE supports both the Quartus II TimeQuest Timing Analyzer and the Quartus II

Classic Timing Analyzer. You must set the timing analyzer with the

Quartus II software prior to opening the project in DSE. After the timing analyzer is set, DSE performs the design exploration with the selected timing analyzer.

You can directly launch the TimeQuest Timing Analyzer from DSE if you have set the default timing analyzer to TimeQuest and have specified the timing constraints in a

Synopsis Design Constraint File (.sdc).

Running DSE

You can use DSE in either the graphical user interface (GUI) or from a command line.

Using DSE from a Command Line

To run DSE from a command line, type the following command at the command prompt: quartus_sh --dse -nogui [<options>] r

You can run DSE with the following options:

-archive

-concurrent-compiles [0..6]

-custom-file <filename>

-decision-column <"column name">

-exploration-space <"space">

-ignore-failed-base

-llr-restructuring

-lower-priority

-lsf-queue <queue name>

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

Running DSE

14–3

-nogui

-optimization-goal <"goal">

-project <project name>

-report-all-resource-usage

-revision <revision name>

-run-power

-search-method <"method">

-seeds <seed list>

-skip-base

-slaves <"slave list">

-stop-after-time <dd:hh:mm>

-stop-after-zero-failing-paths

-use-lsf f

For more information about DSE command line options, type the following command at the command prompt: quartus_sh --help=dse r

Using the DSE Graphical User Interface

To run DSE with the GUI, either click Launch Design Space Explorer on the Tools menu in the Quartus II software, or type the following at the command prompt: quartus_sh --dse r

Figure 14–1 shows the DSE graphical user interface. The Settings tab is divided into

two sections: Project Settings and Exploration Settings.

Figure 14–1. DSE Graphical User Interface

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–4 Chapter 14: Design Space Explorer

DSE Flow

DSE Flow

DSE Configuration File

Many options exist that allow you to customize the behavior of each DSE exploration.

For example, you can specify seed values or a list of slave computers to be used for a

Parallel DSE run. Each time you close the DSE GUI, it saves these values in a configuration file, dse.conf. The next time you launch the DSE GUI, it reads the values from dse.conf and restores the previous exploration settings.

Where the dse.conf file is stored varies depending on the operating system that

launches DSE. Table 14–1

specifies the locations where dse.conf files are stored.

Table 14–1. DSE Configuration File Location

OS

Windows

Linux

File Location (default) Comment

%APPDATA%/Altera/dse.conf

If the variable %APPDATA% is not defined, the configuration file is saved to

%HOME%\.altera.quartus\dse.conf

~/.altera.quartus/dse.conf

1

Settings specified in the DSE command-line mode are not saved to a dse.conf configuration file.

f

For more information about the DSE GUI, launch the DSE GUI. On the Help menu, click Contents or press the F1 key.

You can run DSE at any point in the design process. However, Altera recommends that you run DSE late in your design cycle when your focus is on optimizing performance and power. The results gained from different combinations of optimization options early in the design cycle may not persist over large changes in a design.

DSE runs the Quartus II software for every point in the exploration space. The

Quartus II software always attempts to achieve all your timing requirements regardless of whether or not you are running DSE. The Exploration Settings you choose in DSE will determine the settings to be used for compilation. DSE does not change the behavior of the Quartus II software.

DSE provides a summary of results for all the compilations, and flags the best compilation run based on the exploration setting you have chosen. Specifying all timing requirements before you use DSE to explore your design is very important to ensure that DSE finds the optimal set of parameters for your design based on design criteria you set in your initial design.

You can change the initial placement configuration used by the Quartus II Fitter by varying the Fitter Seed value. You can enter seed values in the Seeds box of the DSE user interface.

To set the seed value in the Quartus II software, on the Assignments menu, click

Settings

and select Fitter Settings.

Compilation time increases as DSE exploration spaces become more comprehensive.

Increased compilation time results from running several compilations and comparing the generated results with the original base compilation results.

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

DSE Flow

14–5

For a typical design, varying only the seed value varies the f

MAX

within a range of

+/-5%. For example, when compiling with three different seeds, one-third of the time f

MAX

does not change over the initial compilation, one-third of the time f

MAX

improves by 5%, and one-third of the time f

MAX

worsens by 5%.

DSE Project Settings

This section provides the following information about DSE project settings:

Setting Up the DSE Work Environment

Specifying the Revision

Setting the Initial Seed

Project Uses Quartus II Integrated Synthesis

Restructuring LogicLock Regions

Setting Up the DSE Work Environment

From the DSE GUI, you can open a Quartus II project for a design exploration by clicking Open Project on the File menu and then browsing to your project. Clicking the Quartus II icon in the DSE GUI closes the DSE GUI and opens the project in the

Quartus II software.

Specifying the Revision

You can specify the revision to be explored with the Revision field in the DSE GUI.

The Revision field is populated after the Quartus II project has been opened.

1

If no revisions were created in the Quartus II project, the default revision, which is the top-level entity, is used. For more information, refer to the

Managing Quartus II

Projects

chapter in volume 2 of the Quartus II Handbook.

Setting the Initial Seed

To specify the seed that DSE uses for an exploration, specify a non-negative integer value in the Seeds box under Project Settings on the Settings tab. The seed value determines your design’s initial placement in a Quartus II compilation.

To specify a range of seeds, type the low end of the range followed by a hyphen, followed by the high end of the range. For example, 2-5 specifies that DSE uses the values 2, 3, 4, and 5 as seeds.

Project Uses Quartus II Integrated Synthesis

Ensure that you turn on the Project Uses Quartus II Integrated Synthesis option if you use Quartus II Integrated Synthesis to synthesize your design. The DSE explores several options that affect, and can help, the synthesis stage of compilation when this option is turned on.

f

For more information about integrated synthesis options, refer to the

Quartus II

Integrated Synthesis

chapter in volume 1 of the Quartus II Handbook.

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–6 Chapter 14: Design Space Explorer

DSE Flow

Restructuring LogicLock Regions

The Allow LogicLock Region Restructuring option allows DSE to modify the properties of LogicLock regions in your design. DSE applies the Soft property to

LogicLock regions to improve timing. In addition, DSE can remove LogicLock regions that negatively affect the performance of the design.

1

DSE makes a copy of your base revision and modifies the LogicLock region settings on the new copy to test whether timing improves with the Allow

LogicLock Region Restructuring

option. Your original revision remains intact.

DSE Exploration Settings

This section provides the following information about DSE exploration settings:

Using DSE to Search for the Best Area

Using DSE to Search for the Best Performance

Using DSE to Search for the Lowest Power

Use the Exploration Settings list to select the type of exploration to perform.

Using DSE to Search for the Best Area

The Search for Best Area option uses a predefined exploration space that targets device utilization improvements for your design.

Using DSE to Search for the Best Performance

The Search for Best Performance option uses a predefined exploration space that targets performance improvements for your design. Depending on the device that your design targets, you can select up to five predefined exploration spaces: Low

(Seed Sweep), Medium (Extra Effort Space), High (Physical Synthesis Space),

Highest

(Physical Synthesis with Retiming Space), and Selective (Selected

Performance Optimizations

). As you move from Low to Highest, the number of options explored by DSE increases, which causes compilation time to increase.

In an exploration for best performance, DSE works on reducing the worst magnitude slack, regardless of whether it is a hold slack or setup slack. During this process, DSE also takes into consideration all process corners before flagging one of the compilations as the best.

Effort Level

When you select Search for Best Performance under the Exploration Settings in the

DSE GUI, you can select the effort level you wish to use to compile your design in

DSE. The effort levels are Low (Seed Sweep), Medium (Extra Effort Space), High

(Physical Synthesis Space), Highest (Physical Synthesis with Retiming Space) and

Selective

(Selected Performance Optimizations). DSE traverses the points in the exploration space, applies the settings to the design, and compares compilation results to determine the best settings for your design based on your chosen effort level. Search time increases proportionally with the breadth of the options being explored. The exploration space search time increases with the number, type, and combination of options DSE explores.

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

DSE Flow

14–7

DSE offers the following exploration space types:

Seed Sweep

Extra Effort Space

Physical Synthesis Space

Physical Synthesis with Retiming Space

Selective (Selective Performance Optimizations)

Seed Sweep

Enter the seed values in the Seeds field in the DSE user interface. There are no

“magic” seeds. The variation between seeds is truly random, any non-negative integer value is as likely to produce good results. DSE defaults to seeds 2, 3, 4, 5, and

6. The Low (Seed Sweep) option exploration space does not change your netlist.

1

The Seeds field accepts individual seed values, for example, 2, 3, 4, and 5, or seed ranges, for example, 2-5.

Each seed value you specify requires an additional compilation. For example, if you enter five seeds, the compilation time increases to 5 times the initial (or base) compilation time.

Extra Effort Space

The Extra Effort Space effort level increases the Quartus II Fitter effort during placement and routing in addition to performing a seed sweep. The Extra Effort

Space

effort level does not change your netlist.

Physical Synthesis Space

The Physical Synthesis Space effort level adds physical synthesis options such as register retiming and physical synthesis for combinational logic to the options included in the Extra Effort Space effort level. These netlist optimizations move registers in your design. Look-up tables (LUTs) are modified by these options.

However, the design behavior is not affected by these options.

f

For more information about physical synthesis, refer to the

Netlist Optimizations and

Physical Synthesis

chapter in volume 2 of the Quartus II Handbook.

Physical Synthesis with Retiming Space

The Physical Synthesis with Retiming Space effort level includes all the options in the Physical Synthesis Space effort level, and it explores various Quartus II

Integrated Synthesis optimization options and register retiming. Register retiming can move registers in your design.

The Physical Synthesis with Retiming Space effort level works only for designs that have been synthesized using Quartus II Integrated Synthesis.

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–8 Chapter 14: Design Space Explorer

DSE Flow

Selective (Selective Performance Optimizations)

The Selective Performance Optimizations effort level combines a seed sweep with various performance Fitter settings to improve the timing of your design. The seed sweep is performed over a limited number of points in such a way that the base settings are not replicated. This is the recommended option for large designs where other spaces may be too large. Use this exploration space for first-time DSE searches on your designs to evaluate the range of results.

Table 14–2

shows the settings adjusted by each effort level.

Table 14–2. Summaries of Effort Levels

(Note 1)

Optimization Options Seed Sweep

Effort Levels

Extra Effort

Physical

Synthesis Retiming

Analysis and Synthesis Settings

Optimization Technique

Perform WYSIWYG primitive resynthesis

— v v v v

Fitter Settings

Fitter seed

Increase PowerFit Fitter effort v

— v v

— v v v

Perform physical synthesis for combinational logic

Perform register retiming — — —

Note to

Table 14–2 :

(1) For effort levels that include Quartus II Integrated Synthesis projects, DSE increases the synthesis effort.

v v v v

Using DSE to Search for the Lowest Power

The Search for Lowest Power option uses a predefined exploration space that targets overall power improvements for your design. When Search for Lowest Power is selected, DSE automatically runs the PowerPlay Power Analyzer for each point in the space. You must ensure that the PowerPlay Power Analyzer is configured correctly to ensure accurate results. DSE issues a warning if the confidence level for any power estimate is low.

DSE Flow Options

You can control the configuration of DSE with the following options:

Continue Exploration Even If Base Compilation Fails

Skip Base Analysis and Compilation If Possible

Stop Flow When Zero Failing Paths are Achieved

Stop Flow After Time

Report all Resource Usage Information

Parallel DSE Information

Create Revisions Without Compiling

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

DSE Flow

14–9

Run Quartus II PowerPlay Power Analyzer During Exploration

Show Full Path to Project in Title Bar

Continue Exploration Even If Base Compilation Fails

With the Continue Exploration Even If Base Compilation Fails option turned on,

DSE continues the exploration even when a design compilation error occurs. For example, if timing settings are not applied to your design, a DSE error occurs. To direct DSE to continue with the exploration instead of halting when an error occurs, turn on this option.

Skip Base Analysis and Compilation If Possible

The Skip Base Analysis & Compilation if Possible option allows DSE to skip the

Analysis and Elaboration stage or the compilation of the base point if base point compilation results are available from a previous Quartus II compilation.

Stop Flow When Zero Failing Paths are Achieved

Instructs DSE to stop exploring the space after it encounters any point, including the base point, that has zero failing paths. DSE uses the failing path count reported in the

All Failing Paths report

column to make this decision.

Stop Flow After Time

Turn on Stop Flow After Time to stop further exploration after a specified number of days, hours, and/or minutes.

1

Exploration time might exceed the specified value because DSE does not stop in the middle of a compilation.

Report all Resource Usage Information

Turn on Report all Resource Usage Information to include all resource information from the Quartus II Fitter reports in the DSE report. The Report all Resource Usage

Information

option allows you to compare resource utilization in one place, rather than comparing the Fitter report from multiple compilations. You may find this option useful if you are trying to optimize the design for the lowest use of a particular type of resource. Turn off Report all Resource Usage Information to include only logic elements and RAM blocks used.

Archive All Compilations

Turn on Archive all Compilations to create a Quartus II Archive File (.qar) for each compilation. These archive files are saved to the dse directory in the design’s working directory.

The result of each DSE run is saved as a .qar file in the dse subdirectory under your project directory. Each run is identified by a number. The best result of DSE run is saved with the name best.qar.

The dse directory also contains a spreadsheet (results.csv) that compares the results of all the individual runs in your DSE compilation.

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–10 Chapter 14: Design Space Explorer

DSE Flow

Create Revisions Without Compiling

Turn on Create Revisions Without Compiling to create a Quartus II project revision for every combination of Quartus II software settings in the exploration space, without compiling the project. That is, DSE creates a revision for every combination of

Analysis & Synthesis settings, Fitter settings, LogicLock region settings, and seed values in the exploration space. DSE creates n synthesis settings

x n fitter settings

x n

LogicLock settings

x n seeds revisions.

Run Quartus II PowerPlay Power Analyzer During Exploration

Turn on Run Quartus II PowerPlay Power Analyzer During Exploration to run the

Quartus II PowerPlay Analyzer for every exploration performed by DSE. Using this option can help you debug your design and determine trade-offs between power requirements and performance optimization.

Show Full Path to Project in Title Bar

Shows, in the title bar of the DSE window, the full directory path to the project.

1

Changes to this option do not take effect until you restart DSE.

DSE Processing Commands

You can process design explorations with the following commands:

Explore Space

View Last DSE Report for Project

Create a Revision from a DSE Point

Open Project in TimeQuest Timing Analyzer

Open Project in Quartus II

Explore Space

The Explore Space command directs DSE to begin the search of the exploration space.

View Last DSE Report for Project

The View Last DSE Report for Project command displays the DSE report generated by the most recent exploration of the project.

Create a Revision from a DSE Point

This command facilitates the creation of multiple revisions based on the same space point for further optimization within the Quartus II software. After you have performed a design exploration, you can use the Create a Revision from a DSE Point to create a new revision with the Quartus II settings of any exploration point. You can also use this command to merge the Quartus II settings of any exploration point with an existing revision.

Open Project in TimeQuest Timing Analyzer

The Open Project in TimeQuest Timing Analyzer command closes DSE and opens the current project revision in the TimeQuest Timing Analyzer.

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

Parallel DSE Information

14–11

Open Project in Quartus II

The Open Project in Quartus II command closes DSE and opens the current project revision in the Quartus II software.

Parallel DSE Information

This section covers the Parallel DSE option, which enables you to run an exploration on multiple computers concurrently. This feature increases the processing efficiency of design space exploration. You can access the settings for Parallel DSE from the

Parallel DSE menu in the DSE GUI.

Computer Load Sharing Using Parallel DSE

DSE uses cluster computing technology to decrease exploration time when you click

Distribute Compilations to Other Machines

on the Parallel DSE menu. DSE uses multiple client computers to compile points in the specified exploration space.

Parallel DSE functions in one of the following modes:

Use LSF Resources

—DSE uses the Platform LSF grid computing technology to distribute exploration space points to a computing network.

Use QSlave

—This function uses a Quartus II master process. DSE acts as a master and distributes exploration space points to client computers.

1

When you use the Distribute Compilations to Other Machines option, different exploration points in the exploration space are compiled on different slave client computers at the same time. Concurrent compilations requires a separate license for each instance of the Quartus II software being used to compile the design. Each compilation also might require licenses for any IP cores in the design. Therefore, the number of parallel distributed compilations can be limited to the number of licenses available for the Quartus II software or the IP core used in your design.

Parallel DSE Using LSF Resources

The easiest way to use distributed DSE technology is to submit the compilations to a preconfigured LSF cluster at your local site. For more information about LSF software, refer to www.platform.com

, or contact your system administrator. To run Parallel DSE using LSF resources, on the Parallel DSE menu, click Configure Resources.

Parallel DSE Using a Quartus II Master Process

Before DSE can use computers in the local area network to compile points in the exploration space, you must create Quartus II software slave instances on the computers that will be used as clients. Type the following command at a command prompt on a client computer: quartus_sh --qslave r

Repeating this command on several computers creates a cluster of Quartus II software slaves for DSE to use. After you have created a set of Quartus II software slaves on the network, add the names of each slave computer in the QSlave tab of the Configure

Resources

dialog box.

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–12 Chapter 14: Design Space Explorer

Parallel DSE Information

To access the Configure Resources dialog box, on the Parallel DSE menu, click

Configure Resources

. To add resources, click the QSlave tab and click Add and type the client name. Click OK.

At the start of an exploration, DSE assumes the role of a Quartus II software master process and submits points to the slaves on the list to compile. If the list is empty, DSE issues an error and the search stops.

1

For more information about running and configuring Quartus II slaves, type the following command at the command prompt: quartus_sh --help=qslave r

Parallel DSE uses a protocol based on FTP to move files between the master and the slaves. By default, the qslave client listens to port number 1977 for communication with the master. If you are running a firewall on a computer that is running the qslave client, make sure you configure the firewall software such that it allows incoming and outgoing transmission control protocol (TCP) and user datagram protocol (UDP) packets on the port used by qslave.

You must set this configuration in every computer that is used as a slave in a distributed DSE environment.

1

You can change the default port number used by qslave by typing the following command at a command prompt: quartus_sh --qslave port=<new_port_number> r

You must use the same version of the Quartus II software to run the slave processes as you use to run DSE. To determine which Quartus II software version you are using to run DSE, select Help and click About DSE. Unexpected results can occur if you mix different Quartus II software versions when using the Parallel DSE feature.

1

When you are using ClearCase revision control software, Parallel DSE compilations launched within a ClearCase view might fail. ClearCase catches system I/O calls that can prevent communication between the DSE master and its slave computers. To avoid this problem, run Parallel DSE outside of the ClearCase environment.

Concurrent Local Compilations

To reduce compilation time, DSE can compile exploration points concurrently. The

Concurrent Local Compilations

option allows you to specify up to six concurrent compilations by choosing an integer value ranging from 0 through 6. You can use this option in conjunction with Parallel DSE. However, your system must have the appropriate resources and licenses to perform concurrent compilations, and distributed processing. Multiprocessor or multicore systems are recommended for concurrent local compilations.

1

Concurrent Local Compilations

require a separate Quartus II software license for each concurrent compilation. For example, if you compile four concurrent compilations, you must have four licenses. Ensure that sufficient licenses are available before you choose a Concurrent Local Compilations value and start compilation.

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

Referenced Documents

14–13

You can use concurrent compilations and distributed compilations with other computer options at the same time if you use the QSlave approach for distributing compilations to other computers.

If you use LSF, all the jobs are submitted to the LSF system.

Referenced Documents

This chapter references the following documents:

Managing Quartus II Projects

chapter in volume 2 of the Quartus II Handbook

Netlist Optimizations and Physical Synthesis

chapter in volume 2 of the Quartus II

Handbook

Quartus II Integrated Synthesis

chapter in volume 1 of the Quartus II Handbook

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–14 Chapter 14: Design Space Explorer

Document Revision History

Document Revision History

Table 14–3

shows the revision history for this chapter.

Table 14–3. Document Revision History (Part 1 of 2)

Date and

Document

Version

November 2009 v.9.1.0

March 2009 v9.0.0

Changes Made

Updated the following sections:

Updated

Figure 14–1

.

Added the following section:

“DSE Processing Commands” on page 14–10

Updated the following sections:

“Introduction” on page 14–1

“DSE Support for Altera Device Families” on page 14–2

“DSE Exploration Settings” on page 14–6

“DSE Flow Options” on page 14–8

Was chapter 12 in the 8.1.0 release.

Updated

Table 14–2

and Table 14–1

Added the following sections:

“Project Uses Quartus II Integrated Synthesis” on page 14–5

“DSE Exploration Settings” on page 14–6

“Effort Level” on page 14–6

Updated the following sections:

“Running DSE” on page 14–2

“Setting Up the DSE Work Environment” on page 14–5

“Seed Sweep” on page 14–7

“Physical Synthesis Space” on page 14–7

“Concurrent Local Compilations” on page 14–12

Deleted the following sections:

Ignore SignalTap and SignalProbe Settings

Quartus II Integrated Synthesis

Search fir Best Performance, Search for Best Area

Options, or Search for Lowest Power Option

Summary of Changes

Updated for the Quartus II software version 9.1 release.

Updated for the Quartus II software version 9.0 release.

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Chapter 14: Design Space Explorer

Document Revision History

14–15

Table 14–3. Document Revision History (Part 2 of 2)

Date and

Document

Version

November 2008 v8.1.0

May 2008 v8.0.0

Changes Made

Changed to 8½” x 11” page size. No change to content.

Updated the following sections:

“Search for Best Performance, Search for Best Area Options, or Search for Lowest Power Option” on page 12–5

“Using the DSE to Search for the Best Performance” on page

12–6

“Physical Synthesis with Retiming Space” on page 12–7

“Parallel DSE Information” on page 12–10

Deleted the following sections:

Advanced Search Options

Exploration Space

Custom Space

Area Optimization Space

Change Decision Column

Save Exploration Space to File

Creating Custom Spaces for DSE

Summary of Changes

Updated for the Quartus II software version 8.1 release.

— f

For previous versions of the Quartus II Handbook, refer to the Quartus II Handbook

Archive .

© November 2009 Altera Corporation Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization

14–16 Chapter 14: Design Space Explorer

Document Revision History

Quartus II Handbook Version 9.1 Volume 2: Design Implementation and Optimization © November 2009 Altera Corporation

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement