Yamaha | VL Visual Editor | Owner`s manual | Yamaha VL Visual Editor Owner`s manual

VL Expert Editor
Beta 1.0 Release for VL Ver.2 series Virtual Acoustic Synthesizers
[VL1 Ver.2, VL1-m Ver.2, VL7 Ver.2]
1. Introduction
The VL Expert Editor application is a voice editor and voice file management tool for the
Yamaha VL version 2-series Virtual Acoustic Synthesizers: the VL1 Ver.2, VL1-m Ver.2, and
VL7 Ver.2. Effective VL voice editing requires a thorough understanding of the VL system and
voice structure: please refer to the appropriate VL synthesizer owner's manual for details.
This manual only deals with operation of the software itself.
•Platform & Operating System Compatibility
This application is designed to run on Macintosh™ computers. It has not been fully tested on
all machine/system combinations, however, and may not function properly in some cases.
Always backup important data to prevent accidental loss.
•Disclaimer
Yamaha provides no warranty, either express or implied, regarding this software. Yamaha will
in no event be liable for any incidental or consequential damage or loss incurred through use of
this software.
-1-
The contents of this manual may be updated or changed without notice. Yamaha will not be
able to respond to any questions or queries regarding this software, so please read the manual
thoroughly before using the VL Expert Editor application.
•Copyright Notice
This manual and software are copyright © 1992 — 1996 by Yamaha Corporation. All rights
reserved. This manual may not be duplicated in whole or in part without written consent from
Yamaha Corporation.
•Trademarks
All trademarks and registered trademarks are the property of their respective holders.
•Notation Conventions
In accordance with Macintosh convention, shortcut command keystrokes will be printed using
the " " symbol. For example, " -N" indicates that the "N" key should be pressed while holding
the [command] (" ") key … this has the same effect as selecting "New" from the "File" menu.
Use the menus or shortcut keystrokes as convenient.
2. Installation & Initial Setup
2-1. Installation and MIDI Connections
The VL Expert Editor (hereafter referred to as "Expert Editor") is compatible with the Apple
MIDI Manager. No other extensions or control panel devices are required. Expert Editor is
supplied as a compressed file. Copy the file to any convenient location on your hard disk and
extract it (double click on the icon) before use.
Expert Editor works with the Apple MIDI Manager and PatchBay to handle MIDI data
transmission and reception via the Macintosh modem or printer port. Connect the assigned port
to your VL-series synthesizer's MIDI IN and OUT connectors via an appropriate MIDI interface.
If you are currently using the Opcode MIDI System (OMS), you will either have to remove OMS
from your system, or set OMS to work with PatchBay.
If the Apple MIDI Manager, OMS, or other MIDI management software is not installed on your
computer, Expert Editor can handle MIDI data transfer via the modem port alone.
Since AppleTalk LocalTalk operation can interfere with MIDI data transfer, AppleTalk should
be turned OFF when using Expert Editor.
2-2. PatchBay Setup
-2-
Launch the Expert Editor application by either double-clicking on the application icon or the
icon of a file created by the Expert Editor. If you are using the Apple MIDI Manager, the first
thing to do after launching Expert Editor is to open the PatchBay window and make sure that
the Expert Editor is connected to the desired serial port. Normally this setting will be
memorized, so you won't have to repeat the procedure each time the Expert Editor is launched.
The memorized PatchBay settings can be lost, however, if a MIDI application is aborted
abnormally or other MIDI parameters are changed.
VL1-m Users:
For VL1-m users, Yamaha recommends using an external MIDI merger unit (e.g.Yamaha YMM2)
to merge the MIDI output from the Macintosh computer and the controlling keyboard (or other
controller) to be sent to the VL1-m MIDI input. It is also necessary to merge the MIDI output
from the VL1-m and the controlling keyboard to be sent to the VL Expert Editor. If no hardware
MIDI merger is available, use the Apple PatchBay application to route both the keyboard MIDI
output and VL Expert Editor MIDI output to the VL1-m MIDI input (see the connection diagram,
below). The latter "software merge" setup should work on most systems, but is likely to be
less reliable than the recommended "hardware merge" approach.
From VL1-m MIDI OUT
VL Expert Editor
The MIDI IN/OUT of an SY77, SY99, DX7, or other
synthesizer with a breath controller input jack.
Example: Merging synthesizer key-on and breath controller data with the Expert
Editor MIDI OUT data for transmission to the VL1-m, and also merging synthesizer
key-on with VL1-m MIDI OUT data for transmission to the Expert Editor.
3. Using Expert Editor as a Voice Librarian
3-1. Opening a Voice File
Select "Open" from the "File" menu ( -O) and open a voice file created by the Expert Editor. A
list of the voices contained in the opened file will appear in the Voice List window. Click on a
voice name to transmit the corresponding voice data to the edit buffer of the connected
VL-series synthesizer, allowing the selected voice to be played and monitored via the
-3-
synthesizer. When the data is transmitted a "data received" message will appear on the VL
synthesizer display. This message can be cancelled by pressing the [PLAY] button
A file-type selection box will appear at the bottom of the "Open" dialog box. The default
setting is "VL Ver.2", allowing the Expert Editor to read VL Version 2 voice data. Voices saved
directly to MS-DOS format disk via the VL Version 1 or Version 2 synthesizer's internal disk
drive can be read via the Macintosh PC Exchange extension if the "Open" dialog box file type
parameter is set to "All".
CAUTION!
• Please note that when the "All" type is selected it may be possible to read files unrelated to
the Expert Editor which may cause errors or crash the system.
When a VL Version 1 voice file is opened a dialog box asking you to confirm whether it is OK
to convert the Version 1 data to Version 2 format will appear. Click "OK" to convert the data
and continue.
3-2. Copying Voices
After clicking on and highlighting a voice name in the voice list window, select "Copy" from
the "Edit" menu ( -C) to copy the voice data to the Macintosh clipboard. Then click on and
highlight the voice name at the voice number to which you want to copy the data, then select
"Paste" from the "Edit" menu ( -V). This completes the copy procedure.
Multiple adjacent voices can be selected and copied by using the standard Macintosh
click-and-drag or shift-click method. First select the region containing the items to be
copied, select "Copy" from the "Edit" menu ( -C) to copy the voice data to the Macintosh
clipboard, then select the region you want to copy the data to, and finally select "Paste" from
the "Edit" menu ( -V). If the selected paste region is smaller than the number of items copied,
only the number of items that will fit in the paste region will be copied. On the other hand, if
the number of items copied is smaller than the selected paste region, the copied items will
all be pasted and the extra paste locations will remain unaffected.
3-3. Creating a New File
Select "New" from the "File" menu ( -N) to create a new "empty" voice list with locations for
128 voices. None of the newly created voices actually contain data, so they will not produce
any sound even if transferred to the VL synthesizer.
Voices can be copied to the new voice list from another voice list which does contain data by
using the voice copy procedure described in "3-2 Copying Voices", above. This makes it easy to
create multiple voice files, each containing sets of voices organized in the best way for your
personal requirements. The Expert Editor allows a maximum of four voice lists to be open at a
time for editing.
3-4. Saving a File
-4-
To save a new voice file with a new name, select "Save as …" from the "File" menu, enter the
file name in the dialog window which appears, then click the "Save" button. To save changes to
an existing file without entering a new file name, select "Save" from the "File" ( -S).
3-5. Changing the Number of Voice In a File
The number of voice in the currently active voice list window can be set to any number from 1
to 128: select "Voice number…" from the "File" menu, enter the desired number of voice in the
voice number box, then click the "OK" button.
CAUTION!
• If you reduce the number of voices in a list, all voices with numbers higher than the highest
number in the newly specified range will be erased!
3-6. Loading Voice Data from a VL Synthesizer
Select "Load from Synth" from the "Utility" menu to load voice data currently in the connected
VL synthesizer memory. Enter the range of voices and/or system data you want to load in the
dialog box which appears, then click the "Start" button to begin loading the data. The loaded
voice data will automatically be placed in a new voice list. System data can be viewed (and
edited) by clicking on the "System" button in the upper left corner of the voice list.
NOTE
• Unless the loaded data is saved as described in "3-4. Saving a File", above, the loaded voice
data exists only in the computer's RAM memory and will be erased when you quit the Expert
Editor application. Be sure to save any data you want to keep before quitting the Expert Editor.
3-7. Sending Voice Data to a VL Synthesizer
Select "Send to Synth" from the "Utility" menu to send voice data from the currently active
voice list to the connected VL synthesizer memory. Enter the range of voices to be sent and the
number of the first VL synthesizer memory location to which you want the voices to be saved
in the dialog box which appears. Check boxes in the dialog box determine whether system data
will or will not be sent. If the "System" box is checked, the system data is transmitted prior
to the voice data. It is therefore important to be careful with the system Device Number and
Memory Protect settings, since these can affect reception of the voice data which follows. For
example, if the synthesizer's memory protect parameter is turned "OFF" but the system data
memory protect setting is "ON", the synthesizer memory protect will be turned ON when the
system data is received, thereby preventing loading of the voice data (the reverse also
applies).
3-8. Transferring Voice Data to the VL Synthesizer via Floppy Disk
-5-
Superdrive-equipped Macintosh computers which can handle MS-DOS disks (MF2HD/MF2DD) can
be used to create voice disks which can be read directly by the VL-series synthesizers. Simply
save or copy an Expert Editor voice file to an MS-DOS format disk (1.44MB/720KB), making
sure than the file name has an ".ALL" extension regardless of the number of voices contained in
the file: e.g. "VLVOICE1.ALL". Since the VL synthesizer disk system conforms to MS-DOS
standards, file names are limited to 8 characters and extensions to 3 characters. Refer to the
MS-DOS documentation for full details on file name limitations.
3-9. Loading Voice Files Created By a VL Synthesizer
Voice files saved to floppy disk via the VL synthesizer's internal floppy disk drive can be read
by the Expert Editor on superdrive-equipped Macintosh computers. Please note, however, that
the Expert Editor can only load "All" type voice files. "1Voice" and "System" type files are not
recognized.
3-10. Loading Voice Files Created by the VL Visual Editor
Files created by the VL Visual Editor — simple VL voice editor with an easy-to-use graphic
interface — can be directly opened by the Expert Editor for detailed editing: select "Open" from
the "File" menu ( -O) then select the file to be opened in the dialog box which appears.
By switching between the VL Visual Editor and Expert Editor applications via the Finder it is
also possible to directly copy and paste voices as required. When using the VL Visual Editor,
the voice data being edited is always maintained in the Macintosh clipboard, so to copy the
current voice data to the Expert Editor all you have to do is switch to the Expert Editor via the
Finder and paste the data into an appropriate location in the active voice list — either select
"Paste" from the "Edit" menu or use the " -V" shortcut keystroke.
3-11. Editing Voice Names
Voice names can be edited via the normal edit window (described later), but they can also be
edited directly in the voice list. Double-click on the voice name to be edited while holding the
[command] ( ) key to open the voice name edit window, then edit as required.
4. Basic Voice Editing
4-1. Opening the Edit Window
Click on and highlight the name of the voice to be edited in the voice list window, then click
the "EDIT" button in the upper left corner of the window. The edit window for the selected
voice will open. The same effect can be achieved by double-clicking on a voice name in the
voice list. The Expert Editor allows the edit windows for up to 4 voices to be open
simultaneously.
-6-
4-2. Switching Edit Pages
Each edit page has 2 Common and 5 Element pages, each of which is divided into several
parameter groups visually separated by horizontal lines. The "Common <Miscellaneous>" page,
for example, is divided into 7 parameter groups: "Voice", "Element Name", "Setting", etc.
When the edit window is initially opened the "Common Miscellaneous" page will appear. Other
edit pages can be selected via the pull-down menu in the upper left corner of the window. If
you have an extended keyboard the function keys — [F1] through [F7] — can be used to directly
select the various pages. The element pages can also be switched via the [F8] key on an
extended keyboard. See the appropriate VL synthesizer owner's manual for details about the
individual parameters available in each page.
A data entry box appears to the right of each parameter. For parameters which also have
related key-scaling parameters, a button marked ">" appears to the right of the data entry box.
Pressing this button (or the [F10] function key on an extended keyboard) takes you to the
related key-scaling edit window.
When editing for the VL7, please note that although parameters for both element 1 and
element 2 are available, only the element 1 parameters are used by the VL7 (the VL1 and
VL1-m have two elements while the VL7 has one).
NOTE
• The "Instrument" edit page provides access to a range of parameters which are not available
via the VL synthesizers themselves. The operation and interaction of these parameters are so
complex that they have not been included in the VL synthesizer editing interface, and for the
same reason they will not be described in detail here.
4-3. Data Entry
The data values in the data entry boxes to the right of the edit parameters can be changed in
four ways:
• The values can be incremented or decremented by clicking on or holding the increment (up
arrow) or decrement (down arrow) button to the right of the data entry box.
• Click on a data entry box to highlight the value, enter a new value via the keyboard, then
press the [enter] or [return] key.
• Click and hold the data entry box, and select an appropriate value from the pop-up menu
which appears.
• Copy the data from another data entry box: click on and highlight the data to be copied,
select "Copy" from the "Edit" menu ( -C), click on the data box you want to copy the data to,
then select "Paste" from the "Edit" menu ( -V). This method is an efficient way to copy a
value and its related key-scaling settings.
The key-scaling window allows both graphic entry and direct numeric entry for each
breakpoint. A number of breakpoints can be selected for simultaneous editing by using the
Macintosh "shift-click" technique.
When 2 key-scaling parameters are available, the "Both" button can be used to simultaneously
-7-
move the upper and lower breakpoints, and the "Width" button allows the upper and lower
widths to be changed at the same time by moving only one of the breakpoints. Where applicable
the "More" and "Less" buttons can be used to increase or decrease the number of breakpoints.
The [caps lock] key can be used to restrain movement to the horizontal and vertical directions.
Also, by setting the "Key scale B.P.(Fix)" parameter in the "Preference" menu, a single
breakpoint can be moved to the left or right without affecting adjacent breakpoints.
Breakpoint note numbers can be set directly from an external MIDI keyboard when the
keyboard button in the key-scaling window is pressed.
4-4. Storing After Editing
When finished editing, click the close box in the upper left corner of the edit window. If any
changes have been made a confirmation dialog box will appear. Click the "OK" button if it's OK
to replace the original voice with the edited data. This stores the edited voice to the
appropriate location in the current voice list maintained in the computer's RAM. If you quit the
Expert Editor at this point, however, the edited data will be lost! Be sure to save the voice file
as described in "3-4. Saving a File" before quitting the application.
4-5. Storing While Editing
While the store method described in "4-4. Storing After Editing" closes the edit window,
thereby ending the editing session, it is also possible to store without ending the editing
session. To do this select "Voice Update" from the "File" menu ( -T), specify the destination
voice number in the dialog box which appears, then click the "OK" button to store the data and
return to the current editing session.
As described in "4-4. Storing After Editing", if you quit the Expert Editor at this point the
edited data will be lost! Be sure to save the voice file as described in "3-4. Saving a File"
before quitting the application.
4-6. Comparing Sounds
During editing the data from the currently active window is transferred to the connected VL
synthesizer. If you click on a non-active voice list window thereby bringing it to the front and
making it active, the pre-edit voice data of the currently selected voice in the list will be
transferred to the synthesizer. This makes it easy to compare the sound of the edited and
pre-edit voice while editing.
4-7. Parameter Group Copy
To copy all the parameters from a group to the same group in a different voice, click on the
group name and select "Copy" from the "Edit" menu ( -C). Then open the edit window of the
voice to which the data is to be copied, click on the name of the same parameter group in the
-8-
new voice, then select "Paste" from the "Edit" window ( -V). The shift-click technique can be
used to select and copy the parameters from several parameter groups at the same time.
5. Special Edit Window Buttons
5-1. MI (Memory In) and MR (Memory Recall)
When the MI (Memory In) button in the upper right corner of the edit window is pressed, the
current state of the voice is stored in a temporary buffer. This state can then be recalled at
any time by pressing the MR (Memory Recall) button. This function facilitates efficient
programming by allowing a voice to be created in stages. The initial state of a voice selected
for editing is stored in the temporary buffer when the edit window is first opened.
5-2. Tuning
Press the "Tune" button in the upper section of the element edit window to open the tuning
window, allowing element tuning while editing. Element re-tuning often becomes necessary
when any of the "<Instrument>" page parameters are edited or the "<Envelope>" page "Pressure
EG/Sustain Level" parameter is modified.
For effective tuning select "Tune 1 key" from the "Tuning Menu", and tune each key individually
while monitoring the sound by pressing the "Hold" button at the bottom of the window. The
"Auto Tuning" feature is convenient, but is not always as accurate as the 1-key method since
several notes are tuned at the same time.
Since tuning in the "physical modeling" environment corresponds to the fundamental
"Pipe/String Length" parameter, it must be done carefully or the entire instrument will end up
out of tune. When using "Detune" or related parameters, use the waveform button in the upper
left corner of the window to select "50 cents", then re-tune at 50 cents higher pitch. The
Expert Editor automatically sends "+50 cents" system data to the connected VL synthesizer at
this point.
When tuning set "Element Detune", "Random Pitch", and related parameters to "0", and make
sure that the synthesizer's pitch bend wheel is set to its center position. It is also a good idea
to bypass all effects. Make sure that breath control pressure is maximum during the actual
tuning process. The "Software Keyboard", described later, is particularly handy for tuning.
The "Hold" button transmits note-on messages from the Expert Editor, with the velocity value
fixed at 127 (maximum).
When tuning is finished press the "GO" button. If the results aren't satisfactory, press the
"Cancel" button to discard all tuning changes. An "Undo" button is also available so you can
"back up" if a mistake is made.
The results of the tuning process end up in the "Pipe Length"/"String Length" parameter group
at the bottom of the "<Instrument>" page. Using the parameter group copy function described in
"4-7. Parameter Group Copy", you can simultaneously copy all the tuning data to another voice
which uses the same "<Instrument>" and "Pressure EG/Sustain Level" parameters.
5-3. Compensation
-9-
The "Compensation" parameter group is second from the bottom of the "<Instrument>" page.
Since most sustained voices exhibit slight pitch variations in response to breath control
pressure changes, VL tuning is normally based on maximum breath pressure. Depending on the
voice, pitch may drop or rise when breath pressure is reduced below the maximum level. The
"Compensation" parameter can be used to compensate for this variation by either raising or
lowering pitch in response to breath pressure. Positive ("+") compensation values cause the
pitch to rise when breath pressure is reduced, while negative ("-") compensation values cause
the pitch to drop when breath pressure is reduced. Since the compensation requirements are
different in different pitch ranges, "Compensation" has corresponding key-scaling parameters
which can accessed via the ">" button to the right of the parameter.
5-4. Comment
This function allows a "comment" of up to 256 characters to be entered for each voice. Press
the "Comment" button in the upper section of the edit window to open the comment edit
window.
5-5. Response
The "Response" button in the upper section of the edit window "<Instrument>" page opens a
"Response" display which shows the acoustic impedance frequency characteristics of the S/VA
tone generator system as seen from the Pipe/String Driver. Refer to the VL synthesizer manual
for more information about the VL Pipe/String Driver.
6. System Data Editing
6-1. System Edit Window
The Expert Editor allows the VL system data to be edited as well as the voice data. Click on
the "System" button in the upper left corner of the voice list window to open the system data
edit window. Unlike the voice data, which is transferred to the connected VL synthesizer edit
buffer during editing, the system data is directly sent to the synthesizer's memory when the
system data edit window is opened, thereby immediately affecting operation. For example, if
the "Device Number" is "off" when the system data is transferred, the connected synthesizer
will not receive any subsequent edit data from the Expert Editor. In such a case it is necessary
to reset the device number to an appropriate value via the VL synthesizer interface before
editing from the Expert Editor can be continued.
Also note that the system data for the various VL-series synthesizer models is not all the
same. In order to be compatible with all VL models the Expert Editor provides all pertinent
parameters, some of which will be unnecessary and unusable depending on the VL model for
which you are editing.
To edit the "Greeting Message", "Micro Tuning 1", "Micro Tuning 2", or "Program Change Table"
data, double click in the data entry box to access the edit window for the corresponding
parameter.
- 10 -
6-2. Micro Tuning
Although the VL synthesizer editing interface only provides a selection of preset
micro-tuning tables, the Expert Editor system data edit window includes two individually
programmable micro-tuning tables. Double-click in one of the micro-tuning data entry boxes to
open the corresponding edit window.
7. The Preferences Window
7-1. Key Scale (Large -> Small) or (Small -> Large)
This item changes the size of the key-scaling windows from "Large" to "Small", or vice versa.
7-2. Key Scale Normalize
By editing the base value of key-scalable parameters it is possible to move the entire
key-scaling curve up or down without changing its shape. This function automatically sets the
base value so that it corresponds to the center of the key-scaling curve whenever a
key-scaling window is closed. The Key Scale Normalize function is ON when this item is
checked. This item has no effect on the actual voice.
7-3. Key Scale B.P (Fix -> Unfix) or (Unfix -> Fix)
In the key-scaling windows it is possible to click and drag breakpoints to the desired
position. This function can be used to limit the range of movement for a single breakpoint to
the area between the adjacent breakpoints (this is the "Fix" setting). No limit is imposed when
"Unfix" is selected. When "Unfix" is selected it is relatively easy to accidentally move
adjacent breakpoints that you have painstakingly set, so the "Fix" mode is recommended for
general editing.
7-4. MIDI
Provides access to the Expert Editor's MIDI transmit/receive channels and device number
parameters. The connected VL synthesizer must be set to receive via the same MIDI channel
and device number.
7-5. Response Window
Determines whether the response window, described in "5-5. Response", is displayed in color
or in black-and-white, and whether the plot will be redrawn immediately whenever a pertinent
note setting is changed.
8. Software Keyboard
- 11 -
Select "Software Keyboard" from the "Windows" menu to open a window which displays a
graphic keyboard and buttons. When this window is selected the connected VL synthesizer is
automatically switched to the EDIT mode. The synthesizer EDIT mode is engaged because the
buttons displayed in the upper right area of the window are only effective when the edit mode
is active. Do not switch to a different mode via the synthesizer panel controls when the
Software Keyboard window is active.
9. Change Term. Menu
The VA (S/VA) tone generation system used in the VL synthesizers includes separate
parameter supersets for pipe and string instruments. Accordingly, separate parameter
names/explanations are available for the pipe physical model and the string physical model.
This menu lets you select the "Pipe Term." or "String Term." display mode.
10. Quitting the Application
Select "Quit" from the "File" menu ( -Q) to quit the Expert Editor. If a voice list window
containing an edited voice has not been saved, a dialog box will appear asking you if you want
to save the edited data. Click the appropriate button to save, quit, or cancel.
===========================================================
- 12 -
Download PDF

advertising