18 Configuring DHCP Features and IP Source Guard

18 Configuring DHCP Features and IP Source Guard
C H A P T E R
18
Configuring DHCP Features and IP Source Guard
This chapter describes how to configure DHCP snooping and the option-82 data insertion features on the
Cisco ME 3400 Ethernet Access switch. It also describes how to configure the IP source guard feature,
which is supported on switches running the metro access and metro IP access images.
Note
For complete syntax and usage information for the commands used in this chapter, see the command
reference for this release, and see the “DHCP Commands” section in the Cisco IOS IP Command
Reference, Volume 1 of 3: Addressing and Services, Release 12.2.
This chapter consists of these sections:
•
Understanding DHCP Features, page 18-1
•
Configuring DHCP Features, page 18-8
•
Displaying DHCP Snooping Information, page 18-15
•
Understanding IP Source Guard, page 18-15
•
Configuring IP Source Guard, page 18-16
•
Displaying IP Source Guard Information, page 18-19
Understanding DHCP Features
DHCP is widely used in LAN environments to dynamically assign host IP addresses from a centralized
server, which significantly reduces the overhead of administration of IP addresses. DHCP also helps
conserve the limited IP address space because IP addresses no longer need to be permanently assigned
to hosts; only those hosts that are connected to the network consume IP addresses.
These sections contain this information:
•
DHCP Server, page 18-2
•
DHCP Relay Agent, page 18-2
•
DHCP Snooping, page 18-2
•
Option-82 Data Insertion, page 18-3
•
Cisco IOS DHCP Server Database, page 18-6
•
DHCP Snooping Binding Database, page 18-6
For information about the DHCP client, see the “Configuring DHCP” section of the “IP Addressing and
Services” section of the Cisco IOS IP Configuration Guide, Release 12.2.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-1
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
DHCP Server
The DHCP server assigns IP addresses from specified address pools on a switch or router to DHCP
clients and manages them. If the DHCP server cannot give the DHCP client the requested configuration
parameters from its database, it can forward the request to one or more secondary DHCP servers defined
by the network administrator.
DHCP Relay Agent
A DHCP relay agent is a Layer 3 device that forwards DHCP packets between clients and servers. Relay
agents forward requests and replies between clients and servers when they are not on the same physical
subnet. Relay agent forwarding is different from the normal Layer 2 forwarding, in which IP datagrams
are switched transparently between networks. Relay agents receive DHCP messages and generate new
DHCP messages to send on egress interfaces.
DHCP Snooping
DHCP snooping is a DHCP security feature that provides network security by filtering untrusted DHCP
messages and by building and maintaining a DHCP snooping binding database, also referred to as a
DHCP snooping binding table. For more information about this database, see the “Displaying DHCP
Snooping Information” section on page 18-15.
DHCP snooping acts like a firewall between untrusted hosts and DHCP servers. You use DHCP snooping
to differentiate between untrusted interfaces connected to the end user and trusted interfaces connected
to the DHCP server or another switch.
Note
For DHCP snooping to function properly, all DHCP servers must be connected to the switch through
trusted interfaces.
An untrusted DHCP message is a message that is received from outside the network or firewall. When
you use DHCP snooping in a service-provider environment, an untrusted message is sent from a device
that is not in the service-provider network, such as a customer’s switch. Messages from unknown devices
are untrusted because they can be sources of traffic attacks.
The DHCP snooping binding database has the MAC address, the IP address, the lease time, the binding
type, the VLAN number, and the interface information that corresponds to the local untrusted interfaces
of a switch. It does not have information regarding hosts interconnected with a trusted interface.
In a service-provider network, a trusted interface is connected to a port on a device in the same network.
An untrusted interface is connected to an untrusted interface in the network or to an interface on a device
that is not in the network.
When a switch receives a packet on an untrusted interface and the interface belongs to a VLAN in which
DHCP snooping is enabled, the switch compares the source MAC address and the DHCP client hardware
address. If the addresses match (the default), the switch forwards the packet. If the addresses do not
match, the switch drops the packet.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-2
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
The switch drops a DHCP packet when one of these situations occurs:
•
A packet from a DHCP server, such as a DHCPOFFER, DHCPACK, DHCPNAK, or
DHCPLEASEQUERY packet, is received from outside the network or firewall.
•
A packet is received on an untrusted interface, and the source MAC address and the DHCP client
hardware address do not match.
•
The switch receives a DHCPRELEASE or DHCPDECLINE broadcast message that has a MAC
address in the DHCP snooping binding database, but the interface information in the binding
database does not match the interface on which the message was received.
•
A DHCP relay agent forwards a DHCP packet that includes a relay-agent IP address that is not
0.0.0.0, or the relay agent forwards a packet that includes option-82 information to an untrusted port.
If the switch is an aggregation switch supporting DHCP snooping and is connected to an edge switch
that is inserting DHCP option-82 information, the switch drops packets with option-82 information when
packets are received on an untrusted interface. If DHCP snooping is enabled and packets are received on
a trusted port, the aggregation switch does not learn the DHCP snooping bindings for connected devices
and cannot build a complete DHCP snooping binding database.
When an aggregation switch can be connected to an edge switch through an untrusted interface and you
enter the ip dhcp snooping information option allowed-trust global configuration command, the
aggregation switch accepts packets with option-82 information from the edge switch. The aggregation
switch learns the bindings for hosts connected through an untrusted switch interface. The DHCP security
features, such as dynamic ARP inspection or IP source guard on a Cisco ME 3400 switch running the
metro access or metro IP access image, can still be enabled on the aggregation switch while the switch
receives packets with option-82 information on ingress untrusted interfaces to which hosts are
connected. The port on the edge switch that connects to the aggregation switch must be configured as a
trusted interface.
Option-82 Data Insertion
In residential, metropolitan Ethernet-access environments, DHCP can centrally manage the IP address
assignments for a large number of subscribers. When the DHCP option-82 feature is enabled on the
switch, a subscriber device is identified by the switch port through which it connects to the network (in
addition to its MAC address). Multiple hosts on the subscriber LAN can be connected to the same port
on the access switch and are uniquely identified.
Note
The DHCP option-82 feature is supported only when DHCP snooping is globally enabled and on the
VLANs to which subscriber devices using this feature are assigned.
Figure 18-1 is an example of a metropolitan Ethernet network in which a centralized DHCP server
assigns IP addresses to subscribers connected to the switch at the access layer. Because the DHCP clients
and their associated DHCP server do not reside on the same IP network or subnet, a DHCP relay agent
(the Cisco ME switch) is configured with a helper address to enable broadcast forwarding and to transfer
DHCP messages between the clients and the server.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-3
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
Figure 18-1
DHCP Relay Agent in a Metropolitan Ethernet Network
DHCP
server
Access layer
Cisco ME switch
(DHCP relay agent)
VLAN 10
Subscribers
Host B
(DHCP client)
92999
Host A
(DHCP client)
When you enable the DHCP snooping information option 82 on the switch, this sequence of
events occurs:
•
The host (DHCP client) generates a DHCP request and broadcasts it on the network.
•
When the switch receives the DHCP request, it adds the option-82 information in the packet. By
default, the remote-ID suboption is the switch MAC address, and the circuit-ID suboption is the port
identifier, vlan-mod-port, from which the packet is received. Beginning with Cisco IOS
Release 12.2(25)SEG, you can configure the remote ID and circuit ID. For information on
configuring these suboptions, see the “Enabling DHCP Snooping and Option 82” section on
page 18-11.
•
If the IP address of the relay agent is configured, the switch adds this IP address in the DHCP packet.
•
The switch forwards the DHCP request that includes the option-82 field to the DHCP server.
•
The DHCP server receives the packet. If the server is option-82-capable, it can use the remote ID,
the circuit ID, or both to assign IP addresses and implement policies, such as restricting the number
of IP addresses that can be assigned to a single remote ID or circuit ID. Then the DHCP server
echoes the option-82 field in the DHCP reply.
•
The DHCP server unicasts the reply to the switch if the request was relayed to the server by the
switch. The switch verifies that it originally inserted the option-82 data by inspecting the remote ID
and possibly the circuit ID fields. The switch removes the option-82 field and forwards the packet
to the switch port that connects to the DHCP client that sent the DHCP request.
In the default suboption configuration, when the described sequence of events occurs, the values in these
fields in Figure 18-2 do not change:
•
Circuit ID suboption fields
– Suboption type
– Length of the suboption type
– Circuit ID type
– Length of the circuit ID type
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-4
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
•
Remote ID suboption fields
– Suboption type
– Length of the suboption type
– Remote ID type
– Length of the circuit ID type
In the port field of the circuit ID suboption, the port numbers start at 3. For example, on a switch with
24 10/100 ports and small form-factor pluggable (SFP) module slots, port 3 is the Fast Ethernet 0/1 port,
port 4 is the Fast Ethernet 0/2 port, and so forth. Port 27 is the SFP module slot 0/1, and so forth.
Figure 18-2 shows the packet formats for the remote ID suboption and the circuit ID suboption when the
default suboption configuration is used. The switch uses the packet formats when DHCP snooping is
globally enabled and when the ip dhcp snooping information option global configuration command is
entered.
Figure 18-2
Suboption Packet Formats
Circuit ID Suboption Frame Format
Suboption
Circuit
type
ID type
Length
Length
1
6
0
VLAN
4
1 byte 1 byte 1 byte 1 byte
Module Port
2 bytes
1 byte 1 byte
Remote ID Suboption Frame Format
Suboption
Remote
type
ID type
Length
Length
8
0
6
1 byte 1 byte 1 byte 1 byte
MAC address
6 bytes
116300
2
Figure 18-3 shows the packet formats for user-configured remote-ID and circuit-ID suboptions The
switch uses these packet formats when you globally enable DHCP snooping and enter the ip dhcp
snooping information option format remote-id global configuration command and the ip dhcp
snooping vlan information option format-type circuit-id string interface configuration command.
The values for these fields in the packets change from the default values when you configure the
remote-ID and circuit-ID suboptions:
•
Circuit-ID suboption fields
– The circuit-ID type is 1.
– The length values are variable, depending on the length of the string that you configure.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-5
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
•
Remote-ID suboption fields
– The remote-ID type is 1.
– The length values are variable, depending on the length of the string that you configure.
Figure 18-3
User-Configured Suboption Packet Formats
Circuit ID Suboption Frame Format (for user-configured string):
Suboption
Circuit
type
ID type
Length
Length
1
N+2
1
N
1 byte 1 byte 1 byte 1 byte
ASCII Circuit ID string
N bytes (N = 3-63)
Remote ID Suboption Frame Format (for user-configured string):
2
N+2
1
N
1 byte 1 byte 1 byte 1 byte
ASCII Remote ID string or hostname
145774
Suboption
Remote
type
ID type
Length
Length
N bytes (N = 1-63)
Cisco IOS DHCP Server Database
During the DHCP-based autoconfiguration process, the designated DHCP server uses the Cisco IOS
DHCP server database. It has IP addresses, address bindings, and configuration parameters, such as the
boot file.
An address binding is a mapping between an IP address and a MAC address of a host in the Cisco IOS
DHCP server database. You can manually assign the client IP address, or the DHCP server can allocate
an IP address from a DHCP address pool. For more information about manual and automatic address
bindings, see the “Configuring DHCP” chapter of the Cisco IOS IP Configuration Guide, Release 12.2.
DHCP Snooping Binding Database
When DHCP snooping is enabled, the switch uses the DHCP snooping binding database to store
information about untrusted interfaces. The database can have up to 8192 bindings.
Each database entry (binding) has an IP address, an associated MAC address, the lease time (in
hexadecimal format), the interface to which the binding applies, and the VLAN to which the interface
belongs. The database agent stores the bindings in a file at a configured location. At the end of each entry
is a checksum value that accounts for all the bytes associated with the entry. Each entry is 72 bytes,
followed by a space and then the checksum value.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-6
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Understanding DHCP Features
To keep the bindings when the switch reloads, you must use the DHCP snooping database agent. If the
agent is disabled, dynamic ARP inspection or IP source guard is enabled, and the DHCP snooping
binding database has dynamic bindings, the switch loses its connectivity. If the agent is disabled and only
DHCP snooping is enabled, the switch does not lose its connectivity, but DHCP snooping might not
prevent DHCPP spoofing attacks.
When reloading, the switch reads the binding file to build the DHCP snooping binding database. The
switch keeps the file current by updating it when the database changes.
When a switch learns of new bindings or when it loses bindings, the switch immediately updates the
entries in the database. The switch also updates the entries in the binding file. The frequency at which
the file is updated is based on a configurable delay, and the updates are batched. If the file is not updated
in a specified time (set by the write-delay and abort-timeout values), the update stops.
This is the format of the file that has the bindings:
<initial-checksum>
TYPE DHCP-SNOOPING
VERSION 1
BEGIN
<entry-1> <checksum-1>
<entry-2> <checksum-1-2>
...
...
<entry-n> <checksum-1-2-..-n>
END
Each entry in the file is tagged with a checksum value that the switch uses to verify the entries when it
reads the file. The initial-checksum entry on the first line distinguishes entries associated with the latest
file update from entries associated with a previous file update.
This is an example of a binding file:
2bb4c2a1
TYPE DHCP-SNOOPING
VERSION 1
BEGIN
192.1.168.1 3 0003.47d8.c91f 2BB6488E Fa1/0/4 21ae5fbb
192.1.168.3 3 0003.44d6.c52f 2BB648EB Fa1/0/4 1bdb223f
192.1.168.2 3 0003.47d9.c8f1 2BB648AB Fa1/0/4 584a38f0
END
When the switch starts and the calculated checksum value equals the stored checksum value, the switch
reads entries from the binding file and adds the bindings to its DHCP snooping binding database. The
switch ignores an entry when one of these situations occurs:
•
The switch reads the entry and the calculated checksum value does not equal the stored checksum
value. The entry and the ones following it are ignored.
•
An entry has an expired lease time (the switch might not remove a binding entry when the lease time
expires).
•
The interface in the entry no longer exists on the system.
•
The interface is a routed interface or a DHCP snooping-trusted interface.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-7
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Configuring DHCP Features
These sections contain this configuration information:
•
Default DHCP Configuration, page 18-8
•
DHCP Snooping Configuration Guidelines, page 18-9
•
Configuring the DHCP Server, page 18-10
•
Configuring the DHCP Relay Agent, page 18-10
•
Specifying the Packet Forwarding Address, page 18-10
•
Enabling DHCP Snooping and Option 82, page 18-11
•
Enabling DHCP Snooping on Private VLANs, page 18-13
•
Enabling the Cisco IOS DHCP Server Database, page 18-13
•
Enabling the DHCP Snooping Binding Database Agent, page 18-14
Default DHCP Configuration
Table 18-1 shows the default DHCP configuration.
Table 18-1
Default DHCP Configuration
Feature
Default Setting
DHCP server
Enabled in Cisco IOS software, requires configuration1
DHCP relay agent
Enabled2
DHCP packet forwarding address
None configured
Checking the relay agent information
Enabled (invalid messages are dropped)2
DHCP relay agent forwarding policy
Replace the existing relay agent information2
DHCP snooping enabled globally
Disabled
DHCP snooping information option
Enabled
DHCP snooping option to accept packets on
untrusted ingress interfaces3
Disabled
DHCP snooping limit rate
None configured
DHCP snooping trust
Untrusted
DHCP snooping VLAN
Disabled
DHCP snooping MAC address verification
Enabled
Cisco IOS DHCP server binding database
Enabled in Cisco IOS software, requires configuration.
Note
DHCP snooping binding database agent
The switch gets network addresses and configuration parameters
only from a device configured as a DHCP server.
Enabled in Cisco IOS software, requires configuration. This feature is
operational only when a destination is configured.
1. The switch responds to DHCP requests only if it is configured as a DHCP server.
2. The switch relays DHCP packets only if the IP address of the DHCP server is configured on the SVI of the DHCP client.
3. Use this feature when the switch is an aggregation switch that receives packets with option-82 information from an edge switch.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-8
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
DHCP Snooping Configuration Guidelines
These are the configuration guidelines for DHCP snooping.
•
You must globally enable DHCP snooping on the switch.
•
DHCP snooping is not active until DHCP snooping is enabled on a VLAN.
•
Before globally enabling DHCP snooping on the switch, make sure that the devices acting as the
DHCP server and the DHCP relay agent are configured and enabled.
•
When you globally enable DHCP snooping on the switch, these Cisco IOS commands are not
available until snooping is disabled. If you enter these commands, the switch returns an error
message, and the configuration is not applied.
– ip dhcp relay information check global configuration command
– ip dhcp relay information policy global configuration command
– ip dhcp relay information trust-all global configuration command
– ip dhcp relay information trusted interface configuration command
•
Before configuring the DHCP snooping information option on your switch, be sure to configure the
device that is acting as the DHCP server. For example, you must specify the IP addresses that the
DHCP server can assign or exclude, or you must configure DHCP options for these devices.
•
When configuring a large number of circuit IDs on a switch, consider the impact of lengthy character
strings on the NVRAM or the flash memory. If the circuit-ID configurations, combined with other
data, exceed the capacity of the NVRAM or the flash memory, an error message appears.
•
Before configuring the DHCP relay agent on your switch, make sure to configure the device that is
acting as the DHCP server. For example, you must specify the IP addresses that the DHCP server
can assign or exclude, configure DHCP options for devices, or set up the DHCP database agent.
•
If the DHCP relay agent is enabled but DHCP snooping is disabled, the DHCP option-82 data
insertion feature is not supported.
•
If a switch port is connected to a DHCP server, configure a port as trusted by entering the ip dhcp
snooping trust interface configuration command.
•
If a switch port is connected to a DHCP client, configure a port as untrusted by entering the no ip
dhcp snooping trust interface configuration command.
•
Follow these guidelines when configuring the DHCP snooping binding database:
– Because both NVRAM and the flash memory have limited storage capacity, we recommend that
you store the binding file on a TFTP server.
– For network-based URLs (such as TFTP and FTP), you must create an empty file at the
configured URL before the switch can write bindings to the binding file at that URL. See the
documentation for your TFTP server to determine whether you must first create an empty file
on the server; some TFTP servers cannot be configured this way.
– To ensure that the lease time in the database is accurate, we recommend that NTP is enabled and
configured. For more information, see the “Configuring NTP” section on page 5-4.
– If NTP is configured, the switch writes binding changes to the binding file only when the switch
system clock is synchronized with NTP.
•
Do not enter the ip dhcp snooping information option allowed-untrusted command on an
aggregation switch to which an untrusted device is connected. If you enter this command, an
untrusted device might spoof the option-82 information.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-9
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Configuring the DHCP Server
The switch can act as a DHCP server. By default, the Cisco IOS DHCP server and relay agent features
are enabled on your switch but are not configured. These features are not operational.
For procedures to configure the switch as a DHCP server, see the “Configuring DHCP” section of the
“IP addressing and Services” section of the Cisco IOS IP Configuration Guide, Release 12.2.
Configuring the DHCP Relay Agent
Beginning in privileged EXEC mode, follow these steps to enable the DHCP relay agent on the switch:
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
service dhcp
Enable the DHCP relay agent on your switch. By default, this feature is
enabled.
Step 3
end
Return to privileged EXEC mode.
Step 4
show running-config
Verify your entries.
Step 5
copy running-config startup-config
(Optional) Save your entries in the configuration file.
To disable the DHCP relay agent, use the no service dhcp global configuration command.
See the “Configuring DHCP” section of the “IP Addressing and Services” section of the Cisco IOS IP
Configuration Guide, Release 12.2 for these procedures:
•
Checking (validating) the relay agent information
•
Configuring the relay agent forwarding policy
Specifying the Packet Forwarding Address
If the DHCP server and the DHCP clients are on different networks or subnets and the switch is running
the metro IP access image, you must configure the switch with the ip helper-address address interface
configuration command. The general rule is to configure the command on the Layer 3 interface closest
to the client. The address used in the ip helper-address command can be a specific DHCP server IP
address, or it can be the network address if other DHCP servers are on the destination network segment.
Using the network address enables any DHCP server to respond to requests.
Beginning in privileged EXEC mode, follow these steps to specify the packet forwarding address:
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
interface vlan vlan-id
Create a switch virtual interface by entering a VLAN
ID, and enter interface configuration mode.
Step 3
ip address ip-address subnet-mask
Configure the interface with an IP address and an IP
subnet.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-10
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Step 4
Command
Purpose
ip helper-address address
Specify the DHCP packet forwarding address.
The helper address can be a specific DHCP server
address, or it can be the network address if other
DHCP servers are on the destination network
segment. Using the network address enables other
servers to respond to DHCP requests.
If you have multiple servers, you can configure one
helper address for each server.
Step 5
exit
Return to global configuration mode.
Step 6
interface range port-range
Configure multiple physical ports that are connected
to the DHCP clients, and enter interface range
configuration mode.
or
or
interface interface-id
Configure a single physical port that is connected to
the DHCP client, and enter interface configuration
mode.
Step 7
no shutdown
Enable the interface(s), if necessary. By default, user
network interfaces (UNIs) are disabled and network
node interfaces (NNIs) are enabled.
Step 8
switchport mode access
Define the VLAN membership mode for the port.
Step 9
switchport access vlan vlan-id
Assign the ports to the same VLAN as configured in
Step 2.
Step 10
end
Return to privileged EXEC mode.
Step 11
show running-config
Verify your entries.
Step 12
copy running-config startup-config
(Optional) Save your entries in the configuration file.
To remove the DHCP packet forwarding address, use the no ip helper-address address interface
configuration command.
Enabling DHCP Snooping and Option 82
Beginning in privileged EXEC mode, follow these steps to enable DHCP snooping on the switch:
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
ip dhcp snooping
Enable DHCP snooping globally.
Step 3
ip dhcp snooping vlan vlan-range
Enable DHCP snooping on a VLAN or range of VLANs. The range is 1
to 4094.
You can enter a single VLAN ID identified by VLAN ID number, a series
of VLAN IDs separated by commas, a range of VLAN IDs separated by
hyphens, or a range of VLAN IDs separated by entering the starting and
ending VLAN IDs separated by a space.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-11
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Command
Purpose
Step 4
ip dhcp snooping information option
Enable the switch to insert and remove DHCP relay information
(option-82 field) in forwarded DHCP request messages to the DHCP
server. This is the default setting.
Step 5
ip dhcp snooping information option
(Optional) Configure the remote-ID suboption.
format remote-id [string ASCII-string |
You can configure the remote ID to be:
hostname]
• String of up to 63 ASCII characters (no spaces)
•
Note
Configured hostname for the switch
If the hostname is longer than 63 characters, it is truncated to 63
characters in the remote-ID configuration.
The default remote ID is the switch MAC address.
Step 6
ip dhcp snooping information option
allowed-untrusted
(Optional) If the switch is an aggregation switch connected to an edge
switch, enable the switch to accept incoming DHCP snooping packets
with option-82 information from the edge switch.
The default is disabled.
Note
You must enter this command only on aggregation switches that
are connected to trusted devices.
Step 7
interface interface-id
Specify the interface to be configured, and enter interface configuration
mode.
Step 8
no shutdown
Enable the port, if necessary. By default, UNIs are disabled and NNIs are
enabled.
Step 9
ip dhcp snooping vlan vlan information (Optional) Configure the circuit-ID suboption for the specified interface.
option format-type circuit-id string
Specify the VLAN and port identifier, using a VLAN ID in the range of 1
ASCII-string
to 4094.
You can configure the circuit ID to be a string of 3 to 63 ASCII characters
(no spaces).
The default circuit ID is the port identifier, in the format vlan-mod-port.
Step 10
ip dhcp snooping trust
(Optional) Configure the interface as trusted or untrusted. You can use the
no keyword to configure an interface to receive messages from an
untrusted client. The default is untrusted.
Step 11
ip dhcp snooping limit rate rate
(Optional) Configure the number of DHCP packets per second that an
interface can receive. The range is 1 to 2048. By default, no rate limit is
configured.
Note
Step 12
Step 13
We recommend an untrusted rate limit of not more than 100
packets per second. If you configure rate limiting for trusted
interfaces, you might need to increase the rate limit if the port is
a trunk port assigned to more than one VLAN on which DHCP
snooping is enabled.
exit
Return to global configuration mode.
ip dhcp snooping verify mac-address
(Optional) Configure the switch to verify that the source MAC address in
a DHCP packet that is received on untrusted ports matches the client
hardware address in the packet. The default is to verify that the source
MAC address matches the client hardware address in the packet.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-12
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Command
Purpose
Step 14
end
Return to privileged EXEC mode.
Step 15
show running-config
Verify your entries.
Step 16
copy running-config startup-config
(Optional) Save your entries in the configuration file.
To disable DHCP snooping, use the no ip dhcp snooping global configuration command. To disable
DHCP snooping on a VLAN or range of VLANs, use the no ip dhcp snooping vlan vlan-range global
configuration command. To disable the insertion and removal of the option-82 field, use the no ip dhcp
snooping information option global configuration command. To configure an aggregation switch to
drop incoming DHCP snooping packets with option-82 information from an edge switch, use the no ip
dhcp snooping information option allowed-untrusted global configuration command.
This example shows how to enable DHCP snooping globally and on VLAN 10 and to configure a rate
limit of 100 packets per second on a port:
Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping vlan 10
Switch(config)# ip dhcp snooping information option
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# ip dhcp snooping limit rate 100
Enabling DHCP Snooping on Private VLANs
You can enable DHCP snooping on private VLANs. If DHCP snooping is enabled, the configuration is
propagated to both a primary VLAN and its associated secondary VLANs. If DHCP snooping is enabled
on the primary VLAN, it is also configured on the secondary VLANs.
If DHCP snooping is already configured on the primary VLAN and you configure DHCP snooping with
different settings on a secondary VLAN, the configuration for the secondary VLAN does not take effect.
You must configure DHCP snooping on the primary VLAN. If DHCP snooping is not configured on the
primary VLAN, this message appears when you are configuring DHCP snooping on the secondary
VLAN, such as VLAN 200:
2w5d:%DHCP_SNOOPING-4-DHCP_SNOOPING_PVLAN_WARNING:DHCP Snooping configuration may not take
effect on secondary vlan 200. DHCP Snooping configuration on secondary vlan is derived
from its primary vlan.
The show ip dhcp snooping privileged EXEC command output shows all VLANs, including primary
and secondary private VLANs, on which DHCP snooping is enabled.
Enabling the Cisco IOS DHCP Server Database
For procedures to enable and configure the Cisco IOS DHCP server database, see the “DHCP
Configuration Task List” section in the “Configuring DHCP” chapter of the Cisco IOS IP Configuration
Guide, Release 12.2.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-13
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring DHCP Features
Enabling the DHCP Snooping Binding Database Agent
Beginning in privileged EXEC mode, follow these steps to enable and configure the DHCP snooping
binding database agent on the switch:
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
ip dhcp snooping database
{flash:/filename |
ftp://user:password@host/filename |
http://[[username:password]@]{hostna
me | host-ip}[/directory]
/image-name.tar |
rcp://user@host/filename}|
tftp://host/filename
Specify the URL for the database agent or the binding file by using one
of these forms:
Step 3
ip dhcp snooping database timeout
seconds
•
flash:/filename
•
ftp://user:password@host/filename
•
http://[[username:password]@]{hostname | host-ip}[/directory]
/image-name.tar
•
rcp://user@host/filename
•
tftp://host/filename
Specify when to stop the database transfer process after the binding
database changes.
The range is from 0 to 86400. Use 0 for an infinite duration. The default
is 300 seconds (5 minutes).
Step 4
ip dhcp snooping database write-delay Specify the duration for which the transfer should be delayed after the
seconds
binding database changes.
The range is from 15 to 86400 seconds. The default is 300 seconds
(5 minutes).
Step 5
end
Step 6
ip dhcp snooping binding mac-address (Optional) Add binding entries to the DHCP snooping binding database.
vlan vlan-id ip-address interface
The vlan-id range is from 1 to 4904. The seconds range is from 1 to
interface-id expiry seconds
4294967295.
Return to privileged EXEC mode.
Enter this command for each entry that you add.
Note
Use this command when you are testing or debugging the switch.
Step 7
show ip dhcp snooping database
[detail]
Display the status and statistics of the DHCP snooping binding database
agent.
Step 8
copy running-config startup-config
(Optional) Save your entries in the configuration file.
To stop using the database agent and binding files, use the no ip dhcp snooping database global
configuration command.To reset the timeout or delay values, use the ip dhcp snooping database
timeout seconds or the ip dhcp snooping database write-delay seconds global configuration
command.
To clear the statistics of the DHCP snooping binding database agent, use the clear ip dhcp snooping
database statistics privileged EXEC command. To renew the database, use the renew ip dhcp snooping
database privileged EXEC command.
To delete binding entries from the DHCP snooping binding database, use the no ip dhcp snooping
binding mac-address vlan vlan-id ip-address interface interface-id privileged EXEC command. Enter
this command for each entry that you delete.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-14
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Displaying DHCP Snooping Information
Displaying DHCP Snooping Information
To display the DHCP snooping information, use one or more of the privileged EXEC commands in
Table 18-2:
Table 18-2
Commands for Displaying DHCP Information
Command
Purpose
show ip dhcp snooping
Displays the DHCP snooping configuration for a switch
show ip dhcp snooping binding
Displays only the dynamically configured bindings in the DHCP snooping binding
database, also referred to as a binding table.1
show ip dhcp snooping database
Displays the DHCP snooping binding database status and statistics.
show ip source binding
Display the dynamically and statically configured bindings.
1. If DHCP snooping is enabled and an interface changes to the down state, the switch does not delete the manually configured bindings.
Understanding IP Source Guard
Note
IP source guard is supported only when the metro access or metro IP access image is running on the
switch.
IP source guard is a security feature that restricts IP traffic on nonrouted, Layer 2 interfaces by filtering
traffic based on the DHCP snooping binding database and on manually configured IP source bindings.
You can use IP source guard to prevent traffic attacks caused when a host tries to use the IP address of
its neighbor.
You can enable IP source guard when DHCP snooping is enabled on an untrusted interface. After IP
source guard is enabled on an interface, the switch blocks all IP traffic received on the interface, except
for DHCP packets allowed by DHCP snooping. A port access control list (ACL) is applied to the
interface. The port ACL allows only IP traffic with a source IP address in the IP source binding table and
denies all other traffic.
The IP source binding table has bindings that are learned by DHCP snooping or are manually configured
(static IP source bindings). An entry in this table has an IP address, its associated MAC address, and its
associated VLAN number. The switch uses the IP source binding table only when IP source guard is
enabled.
IP source guard is supported only on Layer 2 ports, including access and trunk ports.You can configure
IP source guard with source IP address filtering or with source IP and MAC address filtering.
These sections contain this information:
•
Source IP Address Filtering, page 18-16
•
Source IP and MAC Address Filtering, page 18-16
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-15
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring IP Source Guard
Source IP Address Filtering
When IP source guard is enabled with this option, IP traffic is filtered based on the source IP address.
The switch forwards IP traffic when the source IP address matches an entry in the DHCP snooping
binding database or a binding in the IP source binding table.
When a DHCP snooping binding or static IP source binding is added, changed, or deleted on an interface,
the switch modifies the port ACL using the IP source binding changes, and re-applies the port ACL to
the interface.
If you enable IP source guard on an interface on which IP source bindings (dynamically learned by
DHCP snooping or manually configured) are not configured, the switch creates and applies a port ACL
that denies all IP traffic on the interface. If you disable IP source guard, the switch removes the port ACL
from the interface.
Source IP and MAC Address Filtering
When IP source guard is enabled with this option, IP traffic is filtered based on the source IP and MAC
addresses. The switch forwards traffic only when the source IP and MAC addresses match an entry in
the IP source binding table.
When IP source guard with source IP and MAC address filtering is enabled, the switch filters IP and
non-IP traffic. If the source MAC address of an IP or non-IP packet matches a valid IP source binding,
the switch forwards the packet. The switch drops all other types of packets except DHCP packets.
The switch uses port security to filter source MAC addresses. The interface can shut down when a
port-security violation occurs.
Configuring IP Source Guard
These sections contain this configuration information:
•
Default IP Source Guard Configuration, page 18-16
•
IP Source Guard Configuration Guidelines, page 18-17
•
Enabling IP Source Guard, page 18-17
Default IP Source Guard Configuration
By default, IP source guard is disabled.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-16
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring IP Source Guard
IP Source Guard Configuration Guidelines
Note
IP source guard is supported only when the metro access or metro IP access image is running on the
switch.
These are the configuration guides for IP source guard:
•
You can configure static IP bindings only on nonrouted ports. If you enter the ip source binding
mac-address vlan vlan-id ip-address interface interface-id global configuration command on a
routed interface, this error message appears:
Static IP source binding can only be configured on switch port.
•
When IP source guard with source IP filtering is enabled on a VLAN, DHCP snooping must be
enabled on the access VLAN to which the interface belongs.
•
If you are enabling IP source guard on a trunk interface with multiple VLANs and DHCP snooping
is enabled on all the VLANs, the source IP address filter is applied on all the VLANs.
Note
If IP source guard is enabled and you enable or disable DHCP snooping on a VLAN on the
trunk interface, the switch might not properly filter traffic.
•
When IP source guard with source IP and MAC address filtering is enabled, DHCP snooping and
port security must be enabled on the interface.
•
When configuring IP source guard on interfaces on which a private VLAN is configured, port
security is not supported.
•
IP source guard is not supported on EtherChannels.
•
You can enable this feature when IEEE 802.1x port-based authentication is enabled.
•
If the number of ternary content addressable memory (TCAM) entries exceeds the maximum
available, the CPU usage increases.
Enabling IP Source Guard
Beginning in privileged EXEC mode, follow these steps to enable and configure IP source guard on an
interface.
Command
Purpose
Step 1
configure terminal
Enter global configuration mode.
Step 2
interface interface-id
Specify the interface to be configured, and enter interface configuration
mode.
Step 3
no shutdown
Enable the port, if necessary. By default, UNIs are disabled and NNIs are
enabled.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-17
Chapter 18
Configuring DHCP Features and IP Source Guard
Configuring IP Source Guard
Step 4
Command
Purpose
ip verify source
Enable IP source guard with source IP address filtering.
or
ip verify source port-security
Enable IP source guard with source IP and MAC address filtering.
When you enable both IP Source Guard and Port Security by
using the ip verify source port-security interface configuration
command, there are two caveats:
Note
•
The DHCP server must support option 82, or the client is not
assigned an IP address.
•
The MAC address in the DHCP packet is not learned as a secure
address. The MAC address of the DHCP client is learned as a
secure address only when the switch receives non-DHCP data
traffic.
Step 5
exit
Return to global configuration mode.
Step 6
ip source binding mac-address vlan
vlan-id ip-address inteface interface-id
Add a static IP source binding.
Step 7
end
Return to privileged EXEC mode.
Step 8
show ip verify source [interface
interface-id]
Display the IP source guard configuration for all interfaces or for a
specific interface.
Step 9
show ip source binding [ip-address]
[mac-address] [dhcp-snooping | static]
[inteface interface-id] [vlan vlan-id]
Display the IP source bindings on the switch, on a specific VLAN, or on
a specific interface.
Step 10
copy running-config startup-config
(Optional) Save your entries in the configuration file.
Enter this command for each static binding.
To disable IP source guard with source IP address filtering, use the no ip verify source interface
configuration command.
To delete a static IP source binding entry, use the no ip source global configuration command.
This example shows how to enable IP source guard with source IP and MAC filtering on VLANs 10
and 11:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# ip verify source port-security
Switch(config-if)# exit
Switch(config)# ip source binding 0100.0022.0010 vlan 10 10.0.0.2 interface
gigabitethernet1/0/1
Switch(config)# ip source binding 0100.0230.0002 vlan 11 10.0.0.4 interface
gigabitethernet1/0/1
Switch(config)# end
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-18
OL-9639-01
Chapter 18
Configuring DHCP Features and IP Source Guard
Displaying IP Source Guard Information
Displaying IP Source Guard Information
To display the IP source guard information, use one or more of the privileged EXEC commands in
Table 18-3:
Table 18-3
Commands for Displaying IP Source Guard Information
Command
Purpose
show ip source binding
Display the IP source bindings on a switch.
show ip verify source
Display the IP source guard configuration on the switch.
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
OL-9639-01
18-19
Chapter 18
Configuring DHCP Features and IP Source Guard
Displaying IP Source Guard Information
Cisco ME 3400 Ethernet Access Switch Software Configuration Guide
18-20
OL-9639-01
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising