Cisco Nexus 7000 NX-OS networking Configuration guide
Below you will find brief information for networking Nexus 7000 NX-OS. This document provides a comprehensive guide to configuring the EIGRP protocol on the Cisco Nexus 7000 Series switches running NX-OS. It covers everything from basic configuration to advanced features, including authentication, stub routing, and route summarization.
Advertisement
Advertisement
Configuring EIGRP
This chapter contains the following sections:
•
Finding Feature Information, page 1
•
Information About EIGRP, page 2
•
Licensing Requirements for EIGRP, page 9
•
Prerequisites for EIGRP, page 9
•
Guidelines and Limitations for EIGRP, page 9
•
Default Settings for EIGRP Parameters, page 10
•
Configuring Basic EIGRP, page 11
•
Configuring Advanced EIGRP, page 15
•
Configuring Virtualization for EIGRP, page 29
•
Verifying the EIGRP Configuration, page 30
•
Displaying EIGRP Statistics, page 31
•
Configuration Example for EIGRP, page 31
•
Related Documents for EIGRP, page 32
•
•
Feature History for EIGRP, page 33
Finding Feature Information
Your software release might not support all the features documented in this module. For the latest caveats and feature information, see the Bug Search Tool at https://tools.cisco.com/bugsearch/ and the release notes for your software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the “New and Changed Information” chapter or the
Feature History table below.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
1
Configuring EIGRP
Information About EIGRP
Information About EIGRP
EIGRP combines the benefits of distance vector protocols with the features of link-state protocols. EIGRP sends out periodic Hello messages for neighbor discovery. Once EIGRP learns a new neighbor, it sends a one-time update of all the local EIGRP routes and route metrics. The receiving EIGRP router calculates the route distance based on the received metrics and the locally assigned cost of the link to that neighbor. After this initial full route table update, EIGRP sends incremental updates to only those neighbors affected by the route change. This process speeds convergence and minimizes the bandwidth used by EIGRP.
EIGRP Components
EIGRP has the following basic components:
• Reliable Transport Protocol
• Neighbor Discovery and Recovery
• Diffusing Update Algorithm
Reliable Transport Protocol
The Reliable Transport Protocol guarantees ordered delivery of EIGRP packets to all neighbors. The Reliable
Transport Protocol supports an intermixed transmission of multicast and unicast packets. The reliable transport can send multicast packets quickly when unacknowledged packets are pending. This provision helps to ensure that the convergence time remains low for various speed links.
The Reliable Transport Protocol includes the following message types:
• Hello—Used for neighbor discovery and recovery. By default, EIGRP sends a periodic multicast Hello message on the local network at the configured hello interval. By default, the hello interval is 5 seconds.
• Acknowledgement—Verify reliable reception of Updates, Queries, and Replies.
• Updates—Send to affected neighbors when routing information changes. Updates include the route destination, address mask, and route metrics such as delay and bandwidth. The update information is stored in the EIGRP topology table.
• Queries and Replies—Sent as part of the Diffusing Update Algorithm used by EIGRP.
Neighbor Discovery and Recovery
EIGRP uses the Hello messages from the Reliable Transport Protocol to discover neighboring EIGRP routers on directly attached networks. EIGRP adds neighbors to the neighbor table. The information in the neighbor table includes the neighbor address, the interface it was learned on, and the hold time, which indicates how long EIGRP should wait before declaring a neighbor unreachable. By default, the hold time is three times the hello interval or 15 seconds.
EIGRP sends a series of Update messages to new neighbors to share the local EIGRP routing information.
This route information is stored in the EIGRP topology table. After this initial transmission of the full EIGRP route information, EIGRP sends Update messages only when a routing change occurs. These Update messages contain only the new or changed information and are sent only to the neighbors affected by the change.
2
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
EIGRP Route Updates
EIGRP also uses the Hello messages as a keepalive to its neighbors. As long as Hello messages are received,
Cisco NX-OS can determine that a neighbor is alive and functioning.
Diffusing Update Algorithm
The Diffusing Update Algorithm (DUAL) calculates the routing information based on the destination networks in the topology table. The topology table includes the following information:
• IPv4 or IPv6 address/mask—The network address and network mask for this destination.
• Successors—The IP address and local interface connection for all feasible successors or neighbors that advertise a shorter distance to the destination than the current feasible distance.
• Feasibility distance (FD)—The lowest calculated distance to the destination. The feasibility distance is the sum of the advertised distance from a neighbor plus the cost of the link to that neighbor.
DUAL uses the distance metric to select efficient, loop-free paths. DUAL selects routes to insert into the unicast Routing Information Base (RIB) based on feasible successors. When a topology change occurs, DUAL looks for feasible successors in the topology table. If there are feasible successors, DUAL selects the feasible successor with the lowest feasible distance and inserts that into the unicast RIB, avoiding unnecessary recomputation.
When there are no feasible successors but there are neighbors advertising the destination, DUAL transitions from the passive state to the active state and triggers a recomputation to determine a new successor or next-hop router to the destination. The amount of time required to recompute the route affects the convergence time.
EIGRP sends Query messages to all neighbors, searching for feasible successors. Neighbors that have a feasible successor send a Reply message with that information. Neighbors that do not have feasible successors trigger a DUAL recomputation.
EIGRP Route Updates
When a topology change occurs, EIGRP sends an Update message with only the changed routing information to affected neighbors. This Update message includes the distance information to the new or updated network destination.
The distance information in EIGRP is represented as a composite of available route metrics, including bandwidth, delay, load utilization, and link reliability. Each metric has an associated weight that determines if the metric is included in the distance calculation. You can configure these metric weights. You can fine-tune link characteristics to achieve optimal paths, but we recommend that you use the default settings for most configurable metrics.
Internal Route Metrics
Internal routes are routes that occur between neighbors within the same EIGRP autonomous system. These routes have the following metrics:
• Next hop—The IP address of the next-hop router.
• Delay—The sum of the delays configured on the interfaces that make up the route to the destination network. The delay is configured in tens of microseconds.
• Bandwidth—The calculation from the lowest configured bandwidth on an interface that is part of the route to the destination.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
3
Configuring EIGRP
EIGRP Route Updates
Note
We recommend that you use the default bandwidth value. This bandwidth parameter is also used by EIGRP.
• MTU—The smallest maximum transmission unit value along the route to the destination.
• Hop count—The number of hops or routers that the route passes through to the destination. This metric is not directly used in the DUAL computation.
• Reliability—An indication of the reliability of the links to the destination.
• Load—An indication of how much traffic is on the links to the destination.
By default, EIGRP uses the bandwidth and delay metrics to calculate the distance to the destination. You can modify the metric weights to include the other metrics in the calculation.
Wide Metrics
EIGRP supports wide (64-bit) metrics to improve route selection on higher-speed interfaces or bundled interfaces. Routers supporting wide metrics can interoperate with routers that do not support wide metrics as follows:
• A router that supports wide metrics—Adds local wide metrics values to the received values and sends the information on.
• A router that does not support wide metrics— Sends any received metrics on without changing the values.
EIGRP uses the following equation to calculate path cost with wide metrics: metric = [k1 x bandwidth + (k2 x bandwidth)/(256 – load) + k3 x delay + k6 xextended attributes] x
[k5/(reliability + k4)]
Because the unicast RIB cannot support 64-bit metric values, EIGRP wide metrics use the following equation with a RIB scaling factor to convert the 64-bit metric value to a 32-bit value:
RIB Metric = (Wide Metric / RIB scale value) where the RIB scale value is a configurable parameter.
EIGRP wide metrics introduce the following two new metric values represented as k6 in the EIGRP metrics configuration:
• Jitter—(Measured in microseconds) accumulated across all links in the route path. Routes lower jitter values are preferred for EIGRP path selection.
• Energy—(Measured in watts per kilobit) accumulated across all links in the route path. Routes lower energy values are preferred for EIGRP path selection.
EIGRP prefers a path with no jitter or energy metric values or lower jitter or metric values over a path with higher values.
Note
EIGRP wide metrics are sent with a TLV version of 2.
4
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Advanced EIGRP
External Route Metrics
External routes are routes that occur between neighbors in different EIGRP autonomous systems. These routes have the following metrics:
• Next hop—The IP address of the next-hop router.
• Router ID—The router ID of the router that redistributed this route into EIGRP.
• AS number—The autonomous system number of the destination.
• Protocol ID—A code that represents the routing protocol that learned the destination route.
• Tag—An arbitrary tag that can be used for route maps.
• Metric—The route metric for this route from the external routing protocol.
EIGRP and the Unicast RIB
EIGRP adds all learned routes to the EIGRP topology table and the unicast RIB. When a topology change occurs, EIGRP uses these routes to search for a feasible successor. EIGRP also listens for notifications from the unicast RIB for changes in any routes redistributed to EIGRP from another routing protocol.
Advanced EIGRP
You can use the advanced features of EIGRP to optimize your EIGRP configuration.
Address Families
EIGRP supports both IPv4 and IPv6 address families. For backward compatibility, you can configure EIGRPv4 in route configuration mode or in IPv4 address family mode. You must configure EIGRP for IPv6 in address family mode.
Address family configuration mode includes the following EIGRP features:
• Authentication
• AS number
• Default route
• Metrics
• Distance
• Graceful restart
• Logging
• Load balancing
• Redistribution
• Router ID
• Stub router
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
5
Configuring EIGRP
Advanced EIGRP
• Timers
You cannot configure the same feature in more than one configuration mode. For example, if you configure the default metric in router configuration mode, you cannot configure the default metric in address family mode.
Authentication
You can configure authentication on EIGRP messages to prevent unauthorized or invalid routing updates in your network. EIGRP authentication supports MD5 authentication digest.
You can configure the EIGRP authentication per virtual routing and forwarding (VRF) instance or interface using key-chain management for the authentication keys. Key-chain management allows you to control changes to the authentication keys used by MD5 authentication digest. See the Cisco Nexus 7000 Series NX-OS Security
Configuration Guide, for more details about creating key chains.
For MD5 authentication, you configure a password that is shared at the local router and all remote EIGRP neighbors. When an EIGRP message is created, Cisco NX-OS creates an MD5 one-way message digest based on the message itself and the encrypted password and sends this digest along with the EIGRP message. The receiving EIGRP neighbor validates the digest using the same encrypted password. If the message has not changed, the calculation is identical and the EIGRP message is considered valid.
MD5 authentication also includes a sequence number with each EIGRP message that is used to ensure that no message is replayed in the network.
Stub Routers
You can use the EIGRP stub routing feature to improve network stability, reduce resource usage, and simplify stub router configuration. Stub routers connect to the EIGRP network through a remote router.
When using EIGRP stub routing, you need to configure the distribution and remote routers to use EIGRP and configure only the remote router as a stub. EIGRP stub routing does not automatically enable summarization on the distribution router. In most cases, you need to configure summarization on the distribution routers.
Without EIGRP stub routing, even after the routes that are sent from the distribution router to the remote router have been filtered or summarized, a problem might occur. For example, if a route is lost somewhere in the corporate network, EIGRP could send a query to the distribution router. The distribution router could then send a query to the remote router even if routes are summarized. If a problem communicating over the
WAN link between the distribution router and the remote router occurs, EIGRP could get stuck in an active condition and cause instability elsewhere in the network. EIGRP stub routing allows you to prevent queries to the remote router.
Route Summarization
You can configure a summary aggregate address for a specified interface. Route summarization simplifies route tables by replacing a number of more-specific addresses with an address that represents all the specific addresses. For example, you can replace 10.1.1.0/24, 10.1.2.0/24, and 10.1.3.0/24 with one summary address,
10.1.0.0/16.
If more specific routes are in the routing table, EIGRP advertises the summary address from the interface with a metric equal to the minimum metric of the more specific routes.
6
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Advanced EIGRP
Note
EIGRP does not support automatic route summarization.
Route Redistribution
You can use EIGRP to redistribute static routes, routes learned by other EIGRP autonomous systems, or routes from other protocols. You must configure a route map with the redistribution to control which routes are passed into EIGRP. A route map allows you to filter routes based on attributes such as the destination, origination protocol, route type, route tag, and so on.
You also configure the default metric that is used for all imported routes into EIGRP.
You use distribute lists to filter routes from routing updates. These filtered routes are applied to each interface with the ip distribute-list eigrp command.
Load Balancing
You can use load balancing to allow a router to distribute traffic over all the router network ports that are the same distance from the destination address. Load balancing increases the usage of network segments, which increases effective network bandwidth.
Cisco NX-OS supports the Equal Cost Multiple Paths (ECMP) feature with up to 16 equal-cost paths in the
EIGRP route table and the unicast RIB. You can configure EIGRP to load balance traffic across some or all of those paths.
Note
EIGRP in Cisco NX-OS does not support unequal cost load balancing.
Split Horizon
You can use split horizon to ensure that EIGRP never advertises a route out of the interface where it was learned.
Split horizon is a method that controls the sending of EIGRP update and query packets. When you enable split horizon on an interface, Cisco NX-OS does not send update and query packets for destinations that were learned from this interface. Controlling update and query packets in this manner reduces the possibility of routing loops.
Split horizon with poison reverse configures EIGRP to advertise a learned route as unreachable back through that the interface that EIGRP learned the route from.
EIGRP uses split horizon or split horizon with poison reverse in the following scenarios:
• Exchanging topology tables for the first time between two routers in startup mode.
• Advertising a topology table change.
• Sending a Query message.
By default, the split horizon feature is enabled on all interfaces.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
7
Configuring EIGRP
Advanced EIGRP
BFD
This feature supports bidirectional forwarding detection (BFD). BFD is a detection protocol designed to provide fast forwarding-path failure detection times. BFD provides subsecond failure detection between two adjacent devices and can be less CPU-intensive than protocol hello messages because some of the BFD load can be distributed onto the data plane on supported modules. See the Cisco Nexus 7000 Series NX-OS Interfaces
Configuration Guide, for more information.
Virtualization Support for EIGRP
Cisco NX-OS supports multiple instances of EIGRP that runs on the same system. EIGRP supports Virtual
Routing and Forwarding instances (VRFs). VRFs exist within virtual device contexts (VDCs). By default,
Cisco NX-OS places you in the default VDC and default VRF unless you specifically configure another VDC and VRF. See the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, for more information.
Graceful Restart and High Availability
Cisco NX-OS supports nonstop forwarding and graceful restart for EIGRP.
You can use nonstop forwarding for EIGRP to forward data packets along known routes in the FIB while the
EIGRP routing protocol information is being restored following a failover. With nonstop forwarding (NSF), peer networking devices do not experience routing flaps. During failover, data traffic is forwarded through intelligent modules while the standby supervisor becomes active.
If a Cisco NX-OS system experiences a cold reboot, the device does not forward traffic to the system and removes the system from the network topology. In this scenario, EIGRP experiences a stateless restart, and all neighbors are removed. Cisco NX-OS applies the startup configuration, and EIGRP rediscovers the neighbors and shares the full EIGRP routing information again.
A dual supervisor platform that runs Cisco NX-OS can experience a stateful supervisor switchover. Before the switchover occurs, EIGRP uses a graceful restart to announce that EIGRP will be unavailable for some time. During a switchover, EIGRP uses nonstop forwarding to continue forwarding traffic based on the information in the FIB, and the system is not taken out of the network topology.
The graceful restart-capable router uses Hello messages to notify its neighbors that a graceful restart operation has started. When a graceful restart-aware router receives a notification from a graceful restart-capable neighbor that a graceful restart operation is in progress, both routers immediately exchange their topology tables. The graceful restart-aware router performs the following actions to assist the restarting router as follows:
• The router expires the EIGRP Hello hold timer to reduce the time interval set for Hello messages. This process allows the graceful restart-aware router to reply to the restarting router more quickly and reduces the amount of time required for the restarting router to rediscover neighbors and rebuild the topology table.
• The router starts the route-hold timer. This timer sets the period of time that the graceful restart-aware router will hold known routes for the restarting neighbor. The default time period is 240 seconds.
• The router notes in the peer list that the neighbor is restarting, maintains adjacency, and holds known routes for the restarting neighbor until the neighbor signals that it is ready for the graceful restart-aware router to send its topology table or the route-hold timer expires. If the route-hold timer expires on the graceful restart-aware router, the graceful restart-aware router discards held routes and treats the restarting router as a new router that joins the network and reestablishes adjacency.
8
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Licensing Requirements for EIGRP
After the switchover, Cisco NX-OS applies the running configuration, and EIGRP informs the neighbors that it is operational again.
Note
You must enable graceful restart to support in-service software upgrades (ISSU) for EIGRP. If you disable graceful restart, Cisco NX-OS issues a warning that an ISSU cannot be supported with this configuration.
Multiple EIGRP Instances
Cisco NX-OS supports multiple instances of the EIGRP protocol that run on the same system. Every instance uses the same system router ID. You can optionally configure a unique router ID for each instance. For the number of supported EIGRP instances, see the Cisco Nexus 7000 Series NX-OS Verified Scalabilty Guide.
Licensing Requirements for EIGRP
EIGRP requires an Enterprise Services license. For a complete explanation of the Cisco NX-OS licensing scheme and how to obtain and apply licenses, see the Cisco NX-OS Licensing Guide.
Prerequisites for EIGRP
You must enable EIGRP.
If you configure VDCs, you must install the Advanced Services license and enter the desired VDC (see the
Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide).
Guidelines and Limitations for EIGRP
• A metric configuration (either through the default-metric configuration option or through a route map) is required for redistribution from any other protocol, connected routes, or static routes.
• For graceful restart, an NSF-aware router must be up and completely converged with the network before it can assist an NSF-capable router in a graceful restart operation.
• For graceful restart, neighboring devices participating in the graceful restart must be NSF-aware or
NSF-capable.
• Cisco NX-OS EIGRP is compatible with EIGRP in the Cisco IOS software.
• Do not change the metric weights without a good reason. If you change the metric weights, you must apply the change to all EIGRP routers in the same autonomous system.
• A mix of standard metrics and wide metrics in an EIGRP network with interface speeds of 1 Gigabit or greater may result in suboptimal routing.
• Consider using stubs for larger networks.
• Avoid redistribution between different EIGRP autonomous systems because the EIGRP vector metric will not be preserved.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
9
Configuring EIGRP
Default Settings for EIGRP Parameters
• The no {ip | ipv6} next-hop-self command does not guarantee reachability of the next hop.
• The {ip | ipv6} passive-interface eigrp command suppresses neighbors from forming.
• Cisco NX-OS does not support IGRP or connecting IGRP and EIGRP clouds.
• Autosummarization is disabled by default and cannot be enabled.
• Cisco NX-OS supports only IP.
• High availability is not supported with EIGRP aggressive timers.
• If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.
Default Settings for EIGRP Parameters
Table 1: Default Settings for EIGRP Parameters
Parameters
Administrative distance
Bandwidth percent
Default metric for redistributed routes
EIGRP feature
Hello interval
Hold time
Equal-cost paths
Metric weights
Next-hop address advertised
NSF convergence time
NSF route-hold time
NSF signal time
Default
Internal routes—90
External routes—170
50 percent
Bandwidth—100000 Kb/s
Delay—100 (10 microsecond units)
Reliability—255
Loading—1
MTU—1500
Disabled
5 seconds
15 seconds
8
1 0 1 0 0 0
IP address of local interface
120
240
20
10
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring Basic EIGRP
Parameters
Redistribution
Split horizon
Default
Disabled
Enabled
Configuring Basic EIGRP
Enabling or Disabling the EIGRP Feature
You must enable the EIGRP feature before you can configure EIGRP.
Before You Begin
Ensure that you are in the correct VDC (or use the switchto vdc command).
Procedure
Step 1
Step 2
Step 3
Step 4
Command or Action
switch# configure terminal
Purpose
Enters global configuration mode.
switch(config)# [no] feature eigrp Enables the EIGRP feature. The no option disables the
EIGRP feature and removes all associated configuration.
switch(config)# show feature (Optional)
Displays information about enabled features.
switch(config)# copy running-config
startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example enables EIGRP: switch#
configure terminal
switch(config)#
feature eigrp
switch(config)#
copy running-config startup-config
Creating an EIGRP Instance
You can create an EIGRP instance and associate an interface with that instance. You assign a unique autonomous system number for this EIGRP process. Routes are not advertised or accepted from other autonomous systems unless you enable route redistribution.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
11
Configuring EIGRP
Creating an EIGRP Instance
• EIGRP must be able to obtain a router ID (for example, a configured loopback address) or you must configure the router ID option.
• If you configure an instance tag that does not qualify as an AS number, you must configure the AS number explicitly or this EIGRP instance remains in the shutdown state. For IPv6, this number must be configured under address family.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Command or Action
switch# configure terminal
Purpose
Enters global configuration mode.
switch(config)# [no] router eigrp
instance-tag
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an
AS number, you must use the autonomous-system command to configure the AS number explicitly or this EIGRP instance will remain in the shutdown state.
The no option deletes the EIGRP process and all associated configuration. You should also remove any EIGRP commands configured in interface mode if you remove the EIGRP process.
switch(config-router)#
autonomous-system as-number
(Optional)
Configures a unique AS number for this EIGRP instance.
The range is from 1 to 65535.
switch(config-router)#
log-adjacency-changes
(Optional)
Generates a system message whenever an adjacency changes state. This command is enabled by default.
switch(config-router)#
log-neighbor-warnings [seconds]
(Optional)
Generates a system message whenever a neighbor warning occurs.
You can configure the time between warning messages, from
1 to 65535, in seconds. The default is 10 seconds. This command is enabled by default.
switch(config-router)# interface
interface-type slot/port
Enters interface configuration mode. Use ? to determine the slot and port ranges.
switch(config-if)# {ip | ipv6}
router eigrp instance-tag switch(config-if)# show {ip |
ipv6} eigrp interfaces
Associates this interface with the configured EIGRP process.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Displays information about EIGRP interfaces.
12
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Restarting an EIGRP Instance
Step 9
Command or Action
switch(config-if)# copy
running-config startup-config
Purpose
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
This example shows how to create an EIGRP process and configure an interface for EIGRP: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip router eigrp Test1
switch(config-if)#
no shutdown
switch(config-if)#
copy running-config startup-config
Restarting an EIGRP Instance
You can restart an EIGRP instance. This action clears all neighbors for the instance.
Procedure
Step 1
Step 2
Step 3
Command or Action
switch(config)# flush-routes switch(config)# restart eigrp
instance-tag
switch(config)# copy
running-config startup-config
Purpose
(Optional)
Flushes all EIGRP routes in the unicast RIB when this
EIGRP instance restarts.
Restarts the EIGRP instance and removes all neighbors.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to restart an EIGRP instance: switch(config)#
flush-routes
switch(config)#
restart eigrp Test1
switch(config)#
copy running-config startup-config
Shutting Down an EIGRP Instance
You can gracefully shut down an EIGRP instance. This action removes all routes and adjacencies but preserves the EIGRP configuration.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
13
Configuring EIGRP
Configuring a Passive Interface for EIGRP
Procedure
Step 1
Step 2
Command or Action
switch(config-router)# shutdown switch(config-router)# copy
running-config startup-config
Purpose
Disables this instance of EIGRP. The EIGRP router configuration remains.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to shut down an EIGRP instance: switch(config-router)#
shutdown
switch(config-router)#
copy running-config startup-config
Configuring a Passive Interface for EIGRP
You can configure a passive interface for EIGRP. A passive interface does not participate in EIGRP adjacency, but the network address for the interface remains in the EIGRP topology table.
Procedure
Step 1
Step 2
Command or Action
switch(config-if)# {ip | ipv6}
passive-interface eigrp
instance-tag
switch(config-if)# copy
running-config startup-config
Purpose
Suppresses EIGRP hellos, which prevents neighbors from forming and sending routing updates on an EIGRP interface.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
Note
To configure all EIGRP interfaces as passive by default, use the passive-interface default command.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to configure a passive interface for EIGRP: switch(config-if)#
ip passive-interface eigrp tag10
switch(config-if)#
copy running-config startup-config
Shutting Down EIGRP on an Interface
You can gracefully shut down EIGRP on an interface. This action removes all adjacencies and stops EIGRP traffic on this interface but preserves the EIGRP configuration.
14
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring Advanced EIGRP
Procedure
Step 1
Step 2
Command or Action
switch(config-if)# {ip | ipv6} eigrp
instance-tag shutdown
Purpose
Disables EIGRP on this interface. The EIGRP interface configuration remains. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-if)# copy
running-config startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to shut down EIGRP on an interface: switch(config-if)#
ip eigrp Test1 shutdown
switch(config-if)#
copy running-config startup-config
Configuring Advanced EIGRP
Configuring Authentication in EIGRP
You can configure authentication between neighbors for EIGRP. You can configure EIGRP authentication for the EIGRP process or for individual interfaces. The interface EIGRP authentication configuration overrides the EIGRP process-level authentication configuration.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• Ensure that all neighbors for an EIGRP process share the same authentication configuration, including the shared authentication key.
• Create the key chain for this authentication configuration. For more information, see the Cisco Nexus
7000 Series NX-OS Security Configuration Guide.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Command or Action
switch# configure terminal switch(config)# router eigrp
instance-tag
Purpose
Enters global configuration mode.
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an
AS number, you must use the autonomous-system
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
15
Configuring EIGRP
Configuring Authentication in EIGRP
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Step 9
Step 10
Command or Action Purpose
command to configure the AS number explicitly or this
EIGRP instance will remain in the shutdown state.
switch(config-router)#
address-family {ipv4 | ipv6}
unicast
Enters the address-family configuration mode. This command is optional for IPv4.
switch(config-router-af)#
authentication key-chain key-chain
Associates a key chain with this EIGRP process for this
VRF. The key chain can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-router-af)#
authentication mode md5
Configures MD5 message digest authentication mode for this VRF.
switch(config-router-af)# interface
interface-type slot/port
Enters interface configuration mode. Use ? to find the supported interfaces.
switch(config-if)# {ip | ipv6} router
eigrp instance-tag
Associates this interface with the configured EIGRP process.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-if)# {ip | ipv6}
authentication key-chain eigrp
instance-tag key-chain
switch(config-if)# {ip | ipv6}
authentication mode eigrp
instance-tag md5
Associates a key chain with this EIGRP process for this interface. This configuration overrides the authentication configuration set in the router VRF mode. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
Configures the MD5 message digest authentication mode for this interface. This configuration overrides the authentication configuration set in the router VRF mode.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-if)# copy
running-config startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to configure MD5 message digest authentication for EIGRP over Ethernet interface 1/2: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
exit
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip router eigrp Test1
switch(config-if)#
ip authentication key-chain eigrp Test1 routeKeys
switch(config-if)#
ip authentication mode eigrp Test1 md5
switch(config-if)#
copy running-config startup-config
16
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring EIGRP Stub Routing
Configuring EIGRP Stub Routing
To configure a router for EIGRP stub routing, use these commands in address-family configuration mode:
Procedure
Step 1
Step 2
Step 3
Command or Action
switch(config-router-af)# stub [direct |
receive-only | redistributed [direct]
leak-map map-name] switch(config-router-af)# show ip eigrp
neighbor detail
switch(config-router-af)# copy
running-config startup-config
Purpose
Configures a remote router as an EIGRP stub router.
The map name can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Verifies that the router has been configured as a stub router.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to configure a stub router to advertise directly connected and redistributed routes. The last line of the output for the show ip eigrp neighbor detail command shows the stub status of the remote or spoke router.
switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
address-family ipv4 unicast
switch(config-router-af)#
stub direct redistributed
switch(config-router-af)#
show ip eigrp neighbor detail
IP-EIGRP neighbors for process 201
H Address Interface Hold Uptime SRTT RTO Q Seq Type
0 10.1.1.2
Se3/1
(sec)
11 00:00:59
Version 12.1/1.2, Retrans: 2, Retries: 0
(ms) Cnt Num
1 4500 0 7
Stub Peer Advertising ( CONNECTED SUMMARY ) Routes switch(config-router-af)#
copy running-config startup-config
Configuring a Summary Address for EIGRP
You can configure a summary aggregate address for a specified interface. If any more specific routes are in the routing table, EIGRP advertises the summary address out the interface with a metric equal to the minimum of all more specific routes.
Procedure
Step 1
Command or Action
switch(config-if)# {ip | ipv6}
summary-address eigrp
Purpose
Configures a summary aggregate address as either an IP address and network mask or an IP prefix/length. The instance
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
17
Configuring EIGRP
Redistributing Routes into EIGRP
Step 2
Command or Action
instance-tag ip-prefix/length
[distance | leak-map map-name] switch(config-if)# copy
running-config startup-config
Purpose
tag and map name can be any case-sensitive, alphanumeric string up to 20 characters.
You can optionally configure the administrative distance for this aggregate address. The default administrative distance is 5 for aggregate addresses.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to cause EIGRP to summarize network 192.0.2.0 out Ethernet 1/2 only: switch(config)#
interface ethernet 1/2
switch(config-if)#
ip summary-address eigrp Test1 192.0.2.0 255.255.255.0
switch(config-if)#
copy running-config startup-config
Redistributing Routes into EIGRP
You can redistribute routes in EIGRP from other routing protocols.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• You must configure the metric (either through the default-metric configuration option or through a route map) for routes redistributed from any other protocol.
• You must create a route map to control the types of routes that are redistributed into EIGRP.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Step 3
Command or Action
switch# configure terminal
Purpose
Enters global configuration mode.
switch(config)# router eigrp
instance-tag
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an AS number, you must use the autonomous-system command to configure the AS number explicitly or this
EIGRP instance will remain in the shutdown state.
switch(config-router)# address-family
{ipv4 | ipv6} unicast
Enters the address-family configuration mode. This command is optional for IPv4.
18
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Limiting the Number of Redistributed Routes
Step 4
Step 5
Step 6
Step 7
Command or Action Purpose
switch(config-router-af)# redistribute
{bgp as | {eigrp | isis | ospf | ospfv3 |
rip} instance-tag | direct | static}
route-map map-name
Injects routes from one routing domain into EIGRP. The instance tag and map name can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-router-af)#
default-metric bandwidth delay
reliability loading mtu
Sets the metrics assigned to routes learned through route redistribution. The default values are as follows:
• bandwidth—100000 Kb/s
• delay—100 (10 microsecond units)
• reliability—255
• loading—1
• MTU—1492 switch(config-router-af)# show {ip |
ipv6} eigrp route-map statistics
redistribute
switch(config-router-af)# copy
running-config startup-config
(Optional)
Displays information about EIGRP route map statistics.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to redistribute BGP into EIGRP for IPv4: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
redistribute bgp 100 route-map BGPFilter
switch(config-router)#
default-metric 500000 30 200 1 1500
switch(config-router)#
copy running-config startup-config
Limiting the Number of Redistributed Routes
Route redistribution can add many routes to the EIGRP route table. You can configure a maximum limit to the number of routes accepted from external protocols. EIGRP provides the following options to configure redistributed route limits:
• Fixed limit—Logs a message when EIGRP reaches the configured maximum. EIGRP does not accept any more redistributed routes. You can optionally configure a threshold percentage of the maximum where EIGRP logs a warning when that threshold is passed.
• Warning only—Logs a warning only when EIGRP reaches the maximum. EIGRP continues to accept redistributed routes.
• Withdraw—Starts the timeout period when EIGRP reaches the maximum. After the timeout period,
EIGRP requests all redistributed routes if the current number of redistributed routes is less than the maximum limit. If the current number of redistributed routes is at the maximum limit, EIGRP withdraws
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
19
Configuring EIGRP
Limiting the Number of Redistributed Routes
all redistributed routes. You must clear this condition before EIGRP accepts more redistributed routes.
You can optionally configure the timeout period.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Command or Action
switch# configure terminal switch(config)# router eigrp
instance-tag
Purpose
Enters global configuration mode.
Creates a new EIGRP process with the configured instance tag.
switch(config-router)# redistribute
{bgp id | direct | eigrp id | isis id | ospf
id | rip id | static} route-map
map-name
Redistributes the selected protocol into EIGRP through the configured route map.
switch(config-router)# redistribute
maximum-prefix max [threshold]
[warning-only | withdraw
[num-retries timeout]]
Specifies a maximum number of prefixes that EIGRP distributes. The range is from 0 to 65536. Optionally specifies the following:
• threshold—Percent of maximum prefixes that triggers a warning message.
• warning-only—Logs a warning message when the maximum number of prefixes is exceeded.
• withdraw—Withdraws all redistributed routes.
Optionally tries to retrieve the redistributed routes.
The num-retries range is from 1 to 12. The timeout is from 60 to 600 seconds. The default is 300 seconds. Use the clear ip eigrp redistribution command if all routes are withdrawn.
switch(config-router)# show
running-config eigrp
switch(config-router)# copy
running-config startup-config
(Optional)
Displays the EIGRP configuration.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to limit the number of redistributed routes into EIGRP: switch#
configure terminal
switch(config)#
router eigrp Test1
20
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring the Administrative Distance of Routes
switch(config-router)#
redistribute bgp route-map FilterExternalBGP
switch(config-router)#
redistribute maximum-prefix 1000 75
Configuring the Administrative Distance of Routes
You can set the administrative distance of routes added by EIGRP into the RIB.
Before You Begin
You must enable EIGRP.
Ensure that you are in the correct VDC (or use the switchto vdc command).
Procedure
Step 1
Step 2
Step 3
Step 4
Command or Action
switch# configure terminal switch(config)# router eigrp
instance-tag
switch(config-router)# table-map
route-map-name [filter]
Purpose
Enters global configuration mode.
Creates a new EIGRP instance and enters router configuration mode.
Configures a table map with route map information. You can enter up to 63 alphanumeric characters for the map name. The filter keyword filters routes rejected by the route map and does not download them to the RIB.
switch(config)# copy running-config
startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
Configuring Route-Map Filtering
You can enable EIGRP to interoperate with other protocols to leverage additional routing functionality by filtering inbound and outbound traffic based on route-map options.
Before You Begin
You must enable EIGRP.
Ensure that you are in the correct VDC (or use the switchto vdc command).
Procedure
Step 1
Step 2
Command or Action
switch# configure terminal
Purpose
Enters global configuration mode.
switch(config)# route-map map-tag
[permit | deny] [sequence-number]
Enters route-map configuration mode.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
21
Configuring EIGRP
Configuring Route-Map Filtering
Step 6
Step 7
Step 8
Step 9
Step 10
Step 11
Step 12
Step 3
Step 4
Step 5
Step 13
Command or Action Purpose
switch(config-route-map)# match
metric metric-value [+-
deviation-number] [... metric-value [
+- deviation-number ]]
Specifies a match clause that filters inbound updates that match an internal or external protocol metric.
The metric-value argument is an internal protocol metric that can be an EIGRP five-part metric. The range is from
1 to 4294967295.
The +- deviation-number argument represents a standard deviation, which can be any number. When you specify a metric deviation with the + and - keywords, the router matches any metric that falls inclusively in that range.
switch(config-route-map)# match
source-protocol source-protocol
[as-number] switch(config-route-map)# set tag
tag-value
Specifies a match clause that matches external routes from sources that match the source protocol.
The source-protocol argument is the protocol to match.
The valid options are bgp, connected, eigrp, isis, ospf,
rip, and static.
The as-number argument does not apply to the
connected, rip, and static options. The range is from 1 to 65535.
Sets a tag value on the route in the destination routing protocol when all the match criteria of a route map are met.
switch(config-route-map)# exit switch(config)# router eigrp
instance-tag
switch(config-router)# exit
Exits route-map configuration mode.
Creates a new EIGRP instance and enters router configuration mode.
Exits router configuration mode.
switch(config)# interface
interface-type slot/port
switch(config-if)# ip address
ip-address
switch(config-if)# ip router eigrp
as-number
Enters interface configuration mode. Use ? to determine the slot and port ranges.
Specifies an IP address for the EIGRP routing process.
Configures the EIGRP routing process and enters the router configuration mode.
switch(config-if)# ip distribute-list
eigrp as-number route-map map-tag
in
Filters networks received in updates.
switch(config)# copy running-config
startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
22
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring Load Balancing in EIGRP
Configuring Load Balancing in EIGRP
You can configure the number of Equal Cost Multiple Path (ECMP) routes using the maximum-paths option.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Step 3
Step 4
Step 5
Command or Action
switch# configure terminal switch(config)# router eigrp
instance-tag
Purpose
Enters global configuration mode.
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an
AS number, you must use the autonomous-system command to configure the AS number explicitly or this
EIGRP instance remains in the shutdown state.
Enters the address-family configuration mode. This command is optional for IPv4.
switch(config-router)#
address-family {ipv4 | ipv6}
unicast
switch(config-router-af)#
maximum-paths num-paths switch(config-router-af)# copy
running-config startup-config
Sets the number of equal cost paths that EIGRP accepts in the route table. The range is from 1 to 16. The default is 8.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to configure equal cost load balancing for EIGRP over IPv4 with a maximum of six equal cost paths: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
address-family ipv4 unicast
switch(config-router-af)#
maximum-paths 6
switch(config-router-af)#
copy running-config startup-config
Configuring Graceful Restart for EIGRP
You can configure graceful restart or nonstop forwarding for EIGRP.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
23
Configuring EIGRP
Configuring Graceful Restart for EIGRP
Note
Graceful restart is enabled by default.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• An NSF-aware router must be up and completely converged with the network before it can assist an
NSF-capable router in a graceful restart operation.
• Neighboring devices participating in the graceful restart must be NSF aware or NSF capable.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Procedure
Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Command or Action
switch# configure terminal switch(config)# router eigrp
instance-tag
Purpose
Enters global configuration mode.
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an AS number, you must use the autonomous-system command to configure the AS number explicitly or this
EIGRP instance remains in the shutdown state.
switch(config-router)#
address-family {ipv4 | ipv6}
unicast
switch(config-router-af)#
graceful-restart
Enters the address-family configuration mode. This command is optional for IPv4.
Enables graceful restart. This feature is enabled by default.
switch(config-router-af)# timers nsf
converge seconds
Sets the time limit for the convergence after a switchover.
The range is from 60 to 180 seconds. The default is 120.
switch(config-router-af)# timers nsf
route-hold seconds
Sets the hold time for routes learned from the graceful restart-aware peer. The range is from 20 to 300 seconds.
The default is 240.
switch(config-router-af)# timers nsf
signal seconds
Sets the time limit for signaling a graceful restart. The range is from 10 to 30 seconds. The default is 20.
switch(config-router-af)# copy
running-config startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
24
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Adjusting the Interval Between Hello Packets and the Hold Time
This example shows how to configure graceful restart for EIGRP over IPv6 using the default timer values: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
address-family ipv6 unicast
switch(config-router-af)#
graceful-restart
switch(config-router-af)#
copy running-config startup-config
Adjusting the Interval Between Hello Packets and the Hold Time
You can adjust the interval between Hello messages and the hold time.
By default, Hello messages are sent every 5 seconds. The hold time is advertised in Hello messages and indicates to neighbors the length of time that they should consider the sender valid. The default hold time is three times the hello interval, or 15 seconds.
On very congested and large networks, the default hold time might not be sufficient time for all routers to receive hello packets from their neighbors. In this case, you might want to increase the hold time.
Procedure
Step 1
Step 2
Step 3
Step 4
Command or Action
switch(config-if)# {ip | ipv6}
hello-interval eigrp instance-tag
seconds
Purpose
Configures the hello interval for an EIGRP routing process. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters. The range is from 1 to 65535 seconds. The default is 5.
switch(config-if)# {ip | ipv6}
hold-time eigrp instance-tag seconds
Configures the hold time for an EIGRP routing process.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters. The range is from 1 to 65535 seconds.
switch(config-if)# show ip eigrp
interface detail
(Optional)
Verifies the timer configuration.
switch(config-if)# copy
running-config startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to change the interval between Hello packets and the hold time: switch(config)#
interface ethernet 1/2
switch(config-if)#
ip hello-interval eigrp Test1 30
switch(config-if)#
ip hold-time eigrp Test1 30
switch(config-if)#
show ip eigrp interface detail
switch(config-if)#
copy running-config startup-config
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
25
Configuring EIGRP
Disabling Split Horizon
Disabling Split Horizon
You can use split horizon to block route information from being advertised by a router out of any interface from which that information originated. Split horizon usually optimizes communications among multiple routing devices, particularly when links are broken.
By default, split horizon is enabled on all interfaces.
Procedure
Step 1
Step 2
Command or Action
switch(config-if)# no {ip | ipv6}
split-horizon eigrp instance-tag switch(config-if)# copy running-config
startup-config
Purpose
Disables split horizon.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to disable split horizon on a particular interface: switch(config)#
interface ethernet 1/2
switch(config-if)#
no ip split-horizon eigrp Test1
switch(config-if)#
copy running-config startup-config
Enabling Wide Metrics
You can enable wide metrics in router or address family configuration mode.
Procedure
Step 1
Step 2
Step 3
Command or Action Purpose
switch(config-router)# metrics version
64bit
Enables 64-bit metric values.
switch(config-router)# metrics
rib-scale value
(Optional) Configures the scaling factor used to convert the 64-bit metric values to 32 bit in the RIB. The range is from 1 to 255. The default value is 128.
switch(config-router)# copy
running-config startup-config
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
This example shows how to enable wide metrics in router configuration mode: switch#
configure terminal
switch(config)#
router eigrp Test1
26
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Tuning EIGRP
switch(config-router)#
metrics version 64bit
switch(config-router)#
metrics rib-scale 128
switch(config-router)#
copy running-config startup-config
Tuning EIGRP
You can configure optional parameters to tune EIGRP for your network. Some of the parameters can be configured in address-family configuration mode, and others can be configured in interface configuration mode.
Procedure
Step 1
Step 2
Step 3
Step 4
Command or Action Purpose
switch(config-router-af)#
default-information originate
[always | route-map map-name]
(Optional)
Originates or accepts the default route with prefix 0.0.0.0/0.
When a route-map is supplied, the default route is originated only when the route map yields a true condition. The route-map name can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-router-af)# distance
internal external
(Optional)
Configures the administrative distance for this EIGRP process.
The range is from 1 to 255. The internal value sets the distance for routes learned from within the same autonomous system
(the default value is 90). The external value sets the distance for routes learned from an external autonomous system (the default value is 170).
switch(config-router-af)# metric
max-hops hop-count
(Optional)
Sets the maximum allowed hops for an advertised route.
Routes over this maximum are advertised as unreachable. The range is from 1 to 255. The default is 100.
switch(config-router-af)# metric
weights tos k1 k2 k3 k4 k5 k6
(Optional)
Adjusts the EIGRP metric or K value. EIGRP uses the following formula to determine the total metric to the network: metric = [k1 x bandwidth + (k2 x bandwidth)/(256 – load) + k3 x delay + k6 x extended attributes] x [k5/(reliability + k4)]
Default values and ranges are as follows:
• TOS—0. The range is from 0 to 8.
• k1—1. The range is from 0 to 255.
• k2—0. The range is from 0 to 255.
• k3—1. The range is from 0 to 255.
• k4—0. The range is from 0 to 255.
• k5—0. The range is from 0 to 255.
• k6—0. The range is from 0 to 255.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
27
Configuring EIGRP
Tuning EIGRP
Step 5
Step 6
Step 7
Step 8
Step 9
Step 10
Step 11
Step 12
Step 13
Step 14
Step 15
Command or Action Purpose
switch(config-router-af)# timers
active-time {time-limit | disabled}
(Optional)
Sets the time the router waits in minutes (after sending a query) before declaring the route to be stuck in the active (SIA) state.
The range is from 1 to 65535. The default is 3.
switch(config-router-af)# exit switch(config-router)# exit
Exits address-family configuration mode.
Exits router configuration mode.
switch(config)# interface ethernet
slot//port
Enters interface configuration mode.
switch(config-if)# {ip | ipv6}
bandwidth eigrp instance-tag
bandwidth
(Optional)
Configures the bandwidth metric for EIGRP on an interface.
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters. The bandwidth range is from 1 to
2,560,000,000 Kb/s.
switch(config-if)# {ip | ipv6}
bandwidth-percent eigrp
instance-tag percent
(Optional)
Configures the percentage of bandwidth that EIGRP might use on an interface. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters. The percent range is from 0 to 100. The default is 50.
switch(config-if)# no {ip | ipv6}
delay eigrp instance-tag delay
(Optional)
Configures the delay metric for EIGRP on an interface. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters. The delay range is from 1 to 16777215 (in tens of microseconds).
switch(config-if)# {ip | ipv6}
distribute-list eigrp instance-tag
{prefix-list name | route-map
map-name} {in | out}
(Optional)
Configures the route filtering policy for EIGRP on this interface. The instance tag, prefix list name, and route-map name can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-if)# no {ip | ipv6}
next-hop-self eigrp instance-tag
(Optional)
Configures EIGRP to use the received next-hop address rather than the address for this interface. The default is to use the IP address of this interface for the next-hop address. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-if)# {ip | ipv6}
offset-list eigrp instance-tag
{prefix-list name | route-map
map-name} {in | out} offset switch(config-if)# {ip | ipv6}
passive-interface eigrp
instance-tag
(Optional)
Adds an offset to incoming and outgoing metrics to routes learned by EIGRP. The instance tag, prefix list name, and route-map name can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Suppresses EIGRP hellos, which prevents neighbors from forming and sending routing updates on an EIGRP interface.
28
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Configuring Virtualization for EIGRP
Step 16
Command or Action
switch(config-if)# copy
running-config startup-config
Purpose
The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
The following example shows how to configure optional parameters in address-family configuration mode to tune EIGRP for your network: switch#
configure terminal
switch(config)#
router eigrp Test1
switch(config-router)#
address-family ipv4 unicast
switch(config-router-af)#
default-information originate always
switch(config-router-af)#
distance 25 100
switch(config-router-af)#
metric
max-hops
70
switch(config-router-af)#
metric weights 0 1 3 2 1 0
switch(config-router-af)#
timers active-time 200
switch(config-router-af)#
copy running-config startup-config
The following example shows how to configure optional parameters in interface configuration mode to tune
EIGRP for your network: switch#
configure terminal
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip bandwidth eigrp Test1 30000
switch(config-if)#
ip bandwidth-percent eigrp Test1 30
switch(config-if)#
ip delay eigrp Test1 100
switch(config-if)#
ip distribute-list eigrp Test1 route-map EigrpTest in
switch(config-if)#
ip next-hop-self eigrp Test1
switch(config-if)#
ip offset-list eigrp Test1 prefix-list EigrpList in
switch(config-if)#
ip passive-interface eigrp Test1
switch(config-if)#
copy running-config startup-config
Configuring Virtualization for EIGRP
You can configure multiple EIGRP processes in each VDC. You can also create multiple VRFs within each
VDC and use the same or multiple EIGRP processes in each VRF. You assign an interface to a VRF.
Note
Configure all other parameters for an interface after you configure the VRF for an interface. Configuring a VRF for an interface deletes all other configuration for that interface.
Before You Begin
• Ensure that you have enabled the EIGRP feature.
• Create the VDCs and VRFs.
• Confirm that you are in the correct VDC. To change the VDC, use the switchto vdc command.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
29
Configuring EIGRP
Verifying the EIGRP Configuration
Procedure
Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Command or Action
switch# configure terminal
Purpose
Enters global configuration mode.
switch(config)# vrf context
vrf-name
Creates a new VRF and enters VRF configuration mode. The
VRF name can be any case-sensitive, alphanumeric string up to 20 characters.
switch(config-vrf)# router eigrp
instance-tag
Creates a new EIGRP process with the configured instance tag. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
If you configure an instance tag that does not qualify as an
AS number, you must use the autonomous-system command to configure the AS number explicitly or this EIGRP instance remains in the shutdown state.
switch(config-router)# interface
ethernet slot//port
Enters interface configuration mode. Use ? to find the slot and port ranges.
switch(config-if)# vrf member
vrf-name
switch(config-if)# {ip | ipv6}
router eigrp instance-tag switch(config-if)# copy
running-config startup-config
Adds this interface to a VRF. The VRF name can be any case-sensitive, alphanumeric string up to 20 characters.
Adds this interface to the EIGRP process. The instance tag can be any case-sensitive, alphanumeric string up to 20 characters.
(Optional)
Saves the change persistently through reboots and restarts by copying the running configuration to the startup configuration.
This example shows how to create a VRF and add an interface to the VRF: switch#
configure terminal
switch(config)#
vrf context NewVRF
switch(config-vrf)#
router eigrp Test1
switch(config-router)#
interface ethernet 1/2
switch(config-if)#
ip router eigrp Test1
switch(config-if)#
vrf member NewVRF
switch(config-if)#
copy running-config startup-config
Verifying the EIGRP Configuration
Use one of the following commands to verify the configuration:
Command
show {ip | ipv6} eigrp [instance-tag]
Purpose
Displays a summary of the configured EIGRP processes.
30
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Displaying EIGRP Statistics
Command Purpose
show {ip | ipv6} eigrp [instance-tag] interfaces [type
number] [brief] [detail]
Displays information about all configured EIGRP interfaces.
show {ip | ipv6} eigrp instance-tag neighbors [type
number] [detail]
Displays information about all the EIGRP neighbors.
Use this command to verify the EIGRP neighbor configuration.
show {ip | ipv6} eigrp [instance-tag] route
[ip-prefix/length] [active] [all-links] [detail-links]
[pending] [summary] [zero-successors] [vrf
vrf-name]
Displays information about all the EIGRP routes.
show {ip | ipv6} eigrp [instance-tag] topology
[ip-prefix/length] [active] [all-links] [detail-links]
[pending] [summary] [zero-successors] [vrf
vrf-name]
show running-configuration eigrp
Displays information about the EIGRP topology table.
Displays the current running EIGRP configuration.
Displaying EIGRP Statistics
Use one of the following commands to display EIGRP statistics:
Command
show {ip | ipv6} eigrp [instance-tag] accounting
[vrf vrf-name]
show {ip | ipv6} eigrp [instance-tag] route-map
statistics redistribute
show {ip | ipv6} eigrp [instance-tag] traffic [vrf
vrf-name]
Purpose
Displays accounting statistics for EIGRP.
Displays redistribution statistics for EIGRP.
Displays traffic statistics for EIGRP.
Configuration Example for EIGRP
switch#
configure terminal
switch(config)#
feature eigrp
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip address 192.0.2.55/24
switch(config-if)#
ip router eigrp Test1
switch(config)#
exit
switch(config)#
no shutdown
switch(config)#
router eigrp Test1
switch(config-router)#
router-id 192.0.2.1
The following example shows how to use a route map with the distribute-list command to filter routes that are dynamically received from (or advertised to) EIGRP peers. The example configures a route table with a metric of 50, a source protocol of BGP, and an autonomous system number of 45000. When the match clauses
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
31
Configuring EIGRP
Related Documents for EIGRP
is true, the tag value of the destination routing protocol is set to 5. The route map is used to distribute incoming packets for an EIGRP process switch(config)#
route-map metric-range
switch(config-route-map)#
match metric 50
switch(config-route-map)#
match source-protocol bgp 45000
switch(config-route-map)#
set tag 5
switch(config-route-map)#
exit
switch(config)#
router eigrp 1
switch(config-router)#
exit
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip address 172.16.0.0
switch(config-if)#
ip router eigrp 1
switch(config-if)#
ip distribute-list eigrp 1 route-map metric-range in
The following example shows how to use a route map with the redistribute command to allow routes that are redistributed from the routing table to be filtered with a route map before being admitted into an EIGRP topology table. The example shows how to configure a route map to match EIGRP routes with a metric of
110, 200, or an inclusive range of 700 to 800. When the match clause is true, the tag value of the destination routing protocol is set to 10. The route map is used to redistribute EIGRP packets.
switch(config)#
route-map metric-eigrp
switch(config-route-map)#
match metric 110 200 750 +- 50
switch(config-route-map)#
set tag 10
switch(config-route-map)#
exit
switch(config)#
router eigrp 1
switch(config-router)#
redistribute eigrp route-map metric-eigrp
switch(config-router)#
exit
switch(config)#
interface ethernet 1/2
switch(config-if)#
ip address 172.16.0.0
switch(config-if)#
ip router eigrp 1
Related Documents for EIGRP
Related Topic
EIGRP CLI commands
VDCs and VRFs
EIGRP overview
EIGRP FAQs
Document Title
Cisco Nexus 7000 Series NX-OS Unicast Routing
Command Reference
Cisco Nexus 7000 Series NX-OS Virtual Device
Context Configuration Guide
Introduction to EIGRP Tech Note
EIGRP Frequently Asked Questions
MIBs
MIBs
CISCO-EIGRP-MIB
MIBs Link
To locate and download MIBs, go to the following
URL: http://www.cisco.com/public/sw-center/ netmgmt/cmtk/mibs.shtml
32
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Configuring EIGRP
Feature History for EIGRP
Feature History for EIGRP
This table includes only the updates for those releases that have resulted in additions or changes to the feature.
Table 2: Feature History for EIGRP
Feature Name
EIGRP
Release
6.2(2)
EIGRP
EIGRP
Wide metrics
BFD
Graceful shutdown
EIGRP instance tag
Limits on redistributed routes
EIGRP IPv6 support
Authentication
EIGRP
6.2(2)
6.2(2)
5.2(1)
5.0(2)
4.2(1)
4.2(1)
4.2(1)
4.1(2)
4.0(3)
4.0(1)
Feature Information
Added support for route-map filtering.
Added support for configuring the administrative distance of routes.
Added the ability to configure all
EIGRP interfaces as passive by default.
Added support for EIGRP wide metrics.
Added support for BFD. See the
Cisco Nexus 7000 Series NX-OS
Interfaces Configuration Guide for more information.
Added support to gracefully shut down an EIGRP instance or EIGRP on an interface but preserve the
EIGRP configuration.
Changed the length to 20 characters.
Added support for limiting the number of redistributed routes.
Added support for IPv6.
Added the ability to configure authentication within a VRF for
EIGRP.
This feature was introduced.
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
33
Feature History for EIGRP
Configuring EIGRP
34
Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide
Advertisement
Key Features
- EIGRP configuration
- Advanced EIGRP features
- Authentication
- Stub routing
- Route summarization
- Virtualization support
- Graceful restart