A P P L I C A T I O... The MAP Console Program 31/01/03 .

A P P L I C A T I O... The MAP Console Program 31/01/03 .
The MAP Console Program
A P P L I C A T I O N
N O T E
31/01/03
W W W
.
J D S U
.
C O M
/
I N S T R U M E N T S
I N T R O D U C T I O N
The Multiple Application Platform (MAP) is a modular and expandable platform, which is used in fiberoptic
production, test and measurement, and R&D environments to analyze, monitor, and test components and
equipment.
A single 19-inch rack-mountable chassis can hold as many as eight single-width cassettes. If more than eight
slots are required, seven slave chassis can be cascaded from the master chassis in a configuration that can hold
up to 64 single-width cassettes.
MAP can be configured as a benchtop instrument or as a rack-mount system and is controllable locally via the
local interface module or remotely by a GPIB or RS232 remote interface.
When integrating new MAP hardware it is useful to have a utility program to use as a learning or diagnostics
tool. The MAP Console program provided with the MAP chassis and modules is just such a utility program. It
provides easy-to-use remote access to the MAP chassis.
The MAP Console allows the user to exercise the MAP either with actual hardware or in simulation mode. It has
a number of features that allow it to be used as:
- a learning tool;
- a hardware debugging tool for MAP modules;
- a communication tool to upgrade firmware on modules or the MAP single-board computer;
- an easy-to-use remote interface to the MAP through either a GPIB or RS232 connection; and
- a ready-to-use measurement setup.
The many features of the MAP Console program are described below.
The MAP Console provides out-of-the-box instrument control and monitoring. Once the MAP Console and
drivers have been installed, remote control and monitoring of a full MAP system is possible. Additionally, during
test automation development, the MAP Console can be used as an integrated interface to clearly indicate how
the test programs/applications are controlling the MAP system.
The MAP Console can also be used to debug programs/applications. During test execution, the MAP Console
can be used in a supervisory mode to monitor and control the MAP system, which helps with troubleshooting
and minimizes downtime. The MAP Console can monitor all cassettes in a MAP system.
The MAP Console and drivers also allow the MAP to be controlled by multiple test applications. A MAP system
can be divided so that specific cassettes are controlled by one application while others are controlled by
another application.
The MAP Console comes with a built-in simulator, which allows automation developers to capture system
configurations and do most of their development off-line to free real hardware for other purposes and to allow
automation development to begin before the actual cassettes are available. The MAP Console makes test
automation development of the MAP fast and easy to debug.
1
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The MAP Console has two main modes of operation. It can operate as a stand-alone application used to control
and monitor the MAP System. Alternatively, the MAP Console provides support for external automation
applications using the MAP cassette drivers.
MAP Console Applications
Potential applications of the MAP Console include:
Installation of new chassis and modules
Learning to use new modules
Upgrading firmware on single-board computer of MAP chassis
System simulation
Remote control of MAP chassis and modules
Learning commands pertinent to existing modules
Monitoring MAP behaviour
Diagnostics of MAP modules/system
Installation and Use of MAP Console
Installation
The MAP Console program is installed on the computer attached to MAP. It can also be installed, and run in
simulation mode, on any computer not attached to MAP hardware.To install the program, load the CD supplied
with the MAP chassis or module.This CD contains three folders - Documentation; Console; and Firmware. Open
the Console folder. In this CD, you will find the Setup program. Double-click on its icon to start the installation.
The MAP Console program is installed in the \Program Files\JDSUMAPConsole folder. The new firmware is
automatically copied to the \Program Files\JDSUMAPConsole\Firmware folder. The documentation, if required,
should be copied from the CD by the user.
The MAP console installation software installs all of the necessary internal software drivers. The installation
software also defaults the Console Configuration, internal settings, interface settings, password, etc. Major
releases of the MAP Console/Driver software contain all available cassette drivers in one installation package.
When new MAP Optical Cassettes are added to the MAP chassis hardware, individual drivers can be installed to
add the functionality of the new cassettes to the MAP Console. Follow the steps listed below to install, initialize
and operate the MAP Console/Drivers:
1.
REMOVE ANY OLD VERSIONS OF THE MAP CONSOLE AND DRIVERS. Use the Add/Remove Programs
function in Windows under Start>Settings>Control Panel to remove any previous versions of the JDSU
MAP Console/Drivers.
2.
Make sure your PC has Internet Explorer 5.5 or higher installed.
3.
If you have a zipped copy of the MAP Console/Drivers, unzip the files to a temporary directory on your PC.
2
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Keep this directory until your evaluation is complete. This allows you to reinstall/cleanup/restore when a
CD version of the MAP Console/Drivers is unavailable. If you have the MAP Console/Driver CD, place this in
your CD-ROM drive.
4.
Double Click on Setup.exe. Click "Next" at each dialog box until the installation is complete. (Remember to
use the Control Panel>AddRemove Programs if you ever need to un-install MAP).
5.
Start the Console by clicking Start>Programs>JDSU MAP Console and Drivers>MAP Console. Note
that all the online help files are also located in this folder.
6.
When you first start the console, it starts in simulation mode with one instance of each card simulated.
Follow the instructions below to connect to the MAP System and refresh cards on the console and change
operating modes:
The version of the MAP Console should be verified by using the >Help>About Menu Item. It is not the same
as the version of the CD assembly printed on the label.
Overview
The MAP Console user interface has the following key controls and functions:
Each chassis in a MAP system is represented by a tab.
Tabs with visible indicators have cassettes installed.
Each cassette in a MAP chassis is represented by
a cassette-specific user interface, which shows
the cassette’s main controls and displays.
Place mouse over toolbar buttons to
get a description of each button
The MAP tab can be selected to monitor and control system specific settings. It also provides an interface to allow users to manually send commands or queries to the MAP system in SCPI format.
Figure 1: Features of MAP Console Interface
3
T H E
M A P
C O N S O L E
Closes the Console,
but leaves the MAP
server running
P R O G R A M
D E S C R I P T I O N
MAP Cassette Driver (Overview)
The MAP Console Driver user interface has the following key controls and functions:
Figure 2:Features of MAP Driver Interface
Using the MAP Console
When the program is run, it appears on the screen as shown in Figure 3. In this figure, the MAP Console program
is in simulation mode, as indicated at the bottom right. If it is properly connected to MAP hardware, it can be
switched to live mode by deselecting the simulation button in the tool bar. If it is not connected to MAP
hardware, or if the connection to the hardware cannot be established, the Console will run in simulation mode.
The user should check the bottom right corner of the MAP screen to verify the mode.
4
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Figure 3: The MAP Console
The Menu Bar
The menu bar at the top left corner has a number of drop down menus, namely:
Files
View
Tools
Help
The Files Menu
Figure 4: Files Menu
5
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The Files menu has the following menu items:
Add MAP System
The MAP Console can control multiple MAP Master Chassis.These can be setup on different COM Ports or GPIB
devices or addresses. To add a new MAP System to the console using Console Menu click File> Add MAP
System, give it a name or MAP System ID, and configure the communications interface to match those set on
the MAP Chassis System Hardware. Once configured click View> Refresh Cards or click
on the ToolBar.
Use the Combo Box located on the top right-hand-side of the MAP Tab of the Console to change the MAP
System currently being displayed on the MAP Console.
Remove MAP System
To remove a MAP System from the MAP Console click File> Remove MAP System and select the MAP System
ID you want to remove from Console Control.
Minimize Console
This option minimizes the MAP Console. The Console is inactive, but not closed, in order to support other
applications that may require MAP driver support.
Exit and Stop Server
This option stops the MAP Console program, and exits.
The View Menu
The View menu allows the user to select various aspects of the Console view, as shown in the figure below.
Figure 5: The View Menu
6
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The View menu allows the user to display/hide the tool bar, shown below.
Figure 6: Toolbar
The first icon is used to stop and exit the program. The second icon is used to refresh the information for all
cards on the MAP. Since cards can be removed or inserted without powering down the MAP, it is occasionally
necessary to refresh the card information. The third icon is used to refresh the data for the cards.
MAP provides a real time log, which displays all the communication between the computer and the MAP
chassis.This is extremely useful for debugging a device, or to learn to program a MAP module.The real-time log
is shown in Figure 7.
Figure 7: Real Time Log
The fourth icon in the tool bar allows the user to hide/display the Real Time Log. In both simulation and live
mode, the messages being communicated between the Console/Drivers and the simulation or Real MAP
System can be monitored by using the Real Time Log. To view the Real Time Log on the Console Menu Click
View> Show Real Time Log, or click
on the ToolBar.
The status bar is located at the bottom of the MAP screen. It displays the current action/state of the MAP, the
mode it is in (simulation or live), and the number of modules that have been detected. The status bar can be
hidden/displayed using the second menu item.
The third menu item is Refresh Cards. When this is selected, the cards in all MAP chassis are refreshed. The data
for each of the cards is refreshed using the next menu item.
The last menu item is used to hide/display the real time log.
7
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The Tools Menu
The next menu is for the tools. The items in this menu are:
Figure 8: Tools Menu
Auto Error Checking
Automatic error checking can be enabled by the MAP Console. When Auto-Error-Checking is enabled the
console will test for errors after each command sent. This is useful for further trouble- shooting, however,
enabling Auto-Error-Checking can be a serious performance hit. It is recommended that this be enabled only
for troubleshooting. To enable Auto-Error-Checking on the Console Menu Click Tools> Enable Auto Error
Check, or click
on the ToolBar. The additional error checks can be viewed in the Real Time Log Window.
Simulation Mode
If operating without real MAP Chassis hardware, you can use the MAP Console Built-in Simulation Mode.
In the Console Menu click Tools>Simulation Mode, or click on
the Toolbar. With a MAP System in
Simulation Mode, the Console communicates with an internal simulated data interface for a complete
MAP System.
To view the default simulation on the Console Menu click View> Refresh Cards or click
on the
ToolBar. The Console installs instances of each basic card from the default simulation. Card parametric
data can be refreshed without reloading the whole card configuration. On the Console Menu Click
View> Refresh Card Data or click
8
T H E
M A P
on the ToolBar. Card Data can be refreshed at any time.
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Options
When the Options menu item is selected, a dialog with three tabs appears.
Figure 9: Options - MAP Settings
The first tab allows the user to select MAP settings. In particular, it lets the user select linear or logarithmic units
for power, and select the clocking source and frequency.
Figure 10: Options - Communications
Figure 11: Options - Console
The second option allows the user to select either GPIB or RS232 as the communications link between the MAP
Console and the MAP chassis. If GPIB is selected, it allows the user to set the GPIB address of the MAP, the GPIB
board to use on the computer, and the GPIB timeout. If RS232 is selected, the user can set the baud rate, the
port to use, and the timeout. This option does not apply to the communication interface for firmware updates,
which is restricted to RS232.
9
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Note:
If the timeout is set too small, errors will occur. Default timeouts are:
GPIB:
3 seconds
Serial:
2 seconds
The last tab is for the console options. Here, the user can opt to log the communications traffic to a file, and
specify the name of the file, as well as its maximum length.
Firmware Upgrade
This option allows the user to upgrade the firmware in the MAP system's single board computer (SBC),if necessary.
The firmware on the MAP chassis may need to be upgraded occasionally.There are a number of reasons for this,namely:
New firmware released by JDS Uniphase to include new cards/devices for MAP
Additional MAP system hardware is introduced, e.g. hardware enhancements, MAP chassis variants
Enhancements are made to MAP firmware, e.g. new features introduced, maintenance releases etc.
There are two ways to upgrade the system firmware on the MAP chassis. The recommended method is to use
the MAP Console program.
Setting up for a Firmware Upgrade
To set up the system for a firmware upgrade, copy the new firmware source files, both the .TXT and .BIN, to the
JDSMAPConsole\Firmware folder. Next, connect the RS232 port on the MAP to an RS232 port on the computer.
You may need a special adapter/cable if the MAP is equipped with an RJ45 jack. Only the RS232 port can be
used for the firmware upgrade, not the GPIB interface.
The MAP chassis must be set up to use 115200 baud for RS232 communication. This can be done using the
keypad on the MAP chassis, as illustrated below.The chassis is shipped with the rate set to 9600 baud, and must
be changed before new firmware is loaded. First, shut down the console, so that it is not constantly
interrogating the chassis.
LOCAL INTERFACE
◗
1. Press 'SYSTEM’ ( )
MAP SYSTEM SETTING
Interlock:
Deactivated
RS232 Baudrate:
115200
GPIB Address:
12
Keypad Lock:
Off
CLK Line 1:
Offline
Source Freq:
0.000 KHz
EXIT
▼
▼or to disable keypad lock.
4. Press ▲ twice to highlight "RS232 Baudrate".
▼
5. Press ▼or to select 115200 for the baud rate.
3. Press
6. Press 'Exit' ( ).
◗
PAGE->
2. Press ▼ thrice to highlight "Keypad Lock".
Figure 12: Setting Baud Rate on the MAP Chassis
10
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Upgrading Firmware using the MAP Console
The MAP firmware can also be upgraded easily using the MAP Console program. To do this, run the MAP
Console program. The Console User Interface is shown in Figure 13. Under the 'Tools' menu, is a menu item
'Firmware Upgrade'. Select this. A new dialog appears as shown in Figure 14. This dialog allows you to choose
the file to be used for upgrading the firmware. When this is done, a new dialog appears as shown in Figure 15,
allowing you to verify the file, and start the download.
Figure 13: MAP Console used for Upgrading Firmware
Figure 14: First Dialog for Upgrading Firmware
Figure 15: Dialog to Start Downloading New Firmware
At the end of the download, which could take up to 7 minutes, the program either confirms that the firmware
was updated, or displays an error message. If there was error, check the RS232 interface, using the MAP Console
or any communication program, such as hyperterminal.
11
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Change Password
This feature allows the user to set a password, thus restricting access to the MAP equipment through the MAP
Console. The current password must be typed in before the password can be changed. To remove password
protection, change the password to nothing, by hitting the ENTER key for the new password.The password can
be defaulted/removed by reinstalling the Console.
Simulator
A live hardware configuration can be automatically captured for simulation. This is useful to allow the MAP
System Hardware to be used for something else while a major portion of the Automation Development can
occur using a captured simulation. To capture a simulation make sure the MAP Console is connected to a live
MAP System and cards are refreshed. Using Console Menu Click Tools> Capture for Simulation, or
click
on the ToolBar.
You can manually add-to or change the cards in the simulation by using the built-in simulation editor. In the
Console Menu Click Tools> Launch Simulator, or click
the ToolBar. Click or double-click on items in the
Simulator to see the various options. After the simulation has been captured or modified, see the "Start Up in
Simulation Mode" section to learn how to load the modified Simulation on the MAP Console.
Turn AutoUpdate On (all cards)
If this option is selected, the MAP Console program periodically queries MAP to update the status of all cards.
When visible, the console is designed to periodically update the system status information such as interlock
and card faults, and, for specific card types, monitored parameters such as power levels and signal conditions.
Console updates to system and cards can be enabled in the Console Menu by clicking Tools>Auto Update
(On/Off) or System Update (On/Off). Both system and card level updates can be turned on or off by clicking
one of these Toolbar buttons
or
.
Turn Auto-Update Off (all cards)
This option turns off the auto-update.
Turn System Update On
When this option is selected, the MAP Console periodically queries the MAP hardware to get the system status.
The option is greyed when it has been selected.
Turn System Update Off
This turns the auto-update off. When selected, the menu item is greyed.
12
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The Help Menu
The Help menu allows the user to access the online help. The user can search the contents using the first
option, or search for help on specific topics using the second option. The third option, "About" gives the user
information on the version, as shown in Figure 17.
Figure 16: Help Menu
Figure 17: MAP Console "About" Dialog
Chassis Tabs
The tabs labeled chassis 1 through chassis 8 each open the display showing the devices in the selected chassis.
For example, Figure 3 shows the devices in the first chassis.
13
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
The MAP Tab
The final tab marked MAP allows the user to communicate directly with the MAP chassis. This tab is shown in
Figure 18.
Figure 18: The MAP Tab
The buttons in the control panel at the bottom right of the screen are self-evident. The self test button should
be used sparingly, only when necessary. It can take an appreciable time to complete, depending on the
modules present.The grid above these buttons shows the configuration of the MAP, chassis by chassis.This can
be refreshed at any time by pressing the Refresh Summary button.
The black screen on the left is reserved for the communication between the MAP and the computer.
Commands can be typed in directly in the text box at the bottom left. Then press either the Send or the Query
button, as appropriate. If the Query button is pressed, the MAP must respond to the query. It cannot be used
for commands that do not automatically produce a response. If the Copy Output button is pressed, the
contents of the screen are copied to the Windows Clipboard, and this can be pasted into Notepad or other
document.
Using MAP Console and ActiveX Components
The MAP Console and Drivers must be properly installed and configured before MAP Card Drivers can be used
in an ADE (Automation Development Environment) can begin. Follow the basic steps listed below to ensure
that the MAP Test Development environment is properly setup:
1.
Read the release notes and follow the installation instructions. The console and drivers must be properly
installed, configured and operating in Simulation or Live mode, with cards loaded before the MAP Card
Drivers can be used in an ADE.
14
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
2.
Once configured, the console can be Minimized or Stopped. When MAP Card Drivers need to access the
Live or simulated MAP, the Console Server is automatically started. In a development environment, it is
normal to minimize the MAP Console when not needed. Click on the MAP Icon
in the Windows
Taskbar to open the console's user interface to monitor or control the MAP hardware.
3.
During installation, a component named "JDSUMAP" is installed on the target PC. This component
contains two ActiveX controls named JDSU System and JDSU Driver. See the ADE help for instructions on
how to add and use ActiveX controls in your specific development environment:
- The JDSU System ActiveX Control is a control used to monitor and control the MAP Console and
MAP System level functions such as communication settings, system functions etc. This control will
remain hidden while your application is running.
- The JDSU Driver ActiveX Control is Cassette/Card Driver. Once this control is loaded on a form, panel
or dialog in your ADE you can right-click on the control and select properties, or select custom
properties in the controls property list. A property page will appear representing the current selected
system and showing all the cards in that system. Now you can make this instance of the control
represent any cassette in the system by just clicking on that cassette. See each specific Cassette's
Driver for a full explanation of all the functions and properties of each driver.
4.
See the examples included in Start>Programs>JDSU MAP Console and Drivers>Examples for some
simple examples showing how to control and monitor typical cassettes using these controls in LabView,
Visual Basic, Visual C++, etc.
MAP Test Execution Environment Setup and Configuration
1.
The MAP Console and Drivers must be properly installed and configured before MAP Card Drivers can be
used by applications which include them. Follow the basic steps listed below to ensure that your MAP Test
Execution environment is properly setup:
a.
Read the release notes and follow the installation instructions described above. The console and
drivers must be properly installed, configured and operating in Simulation or Live mode, with cards
loaded before the MAP Card Drivers can be used by any application.
b.
Once the Console is properly setup, configured and talking to a live MAP Chassis it can be
minimized and locked with a password to protect unauthorized access. To set the password on the
MAP Console Menu Click Tools> Change Password, or click
on the ToolBar. Remember this
password. If the password is forgotten, the MAP Console must be reinstalled to restore the password
to the default.
c.
Once configured, the console can be Minimized or Stopped. When your Test Application using the
MAP Cassette Drivers is started, the MAP the Console Server is automatically started if it is not
currently running.
d.
15
To troubleshoot, debug, or monitor what is happening with the MAP System, click on the MAP Icon
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
in the Windows Taskbar. The console's user interface can be opened with the correct password,
if it has been set.
Using the MAP Console as a Diagnostic Tool
A primary use of the MAP Console is as a diagnostics tool, for integrating new MAP modules in a MAP Chassis.
The Real Time Log (RTL) is invaluable in monitoring the dialogue between a computer and the MAP Chassis.
Checking the RS232 Interface Using the MAP Console
One essential component of the MAP is the RS232 interface.This must function properly in order to upgrade the
firmware on the MAP single board computer, which must be done whenever a new type of MAP module is
introduced. Hence, a method of verifying whether the RS232 communication is functional is necessary.The MAP
Console program provides a simple way to test the communications between a computer and the MAP chassis.
Figure 19: Setting the Communications Option
Under the 'Tools' menu, select 'Options', as shown in Figure 19. A new dialog, shown in Figure 20 is displayed.
In this dialog, select the serial port. Also, set the proper communication port on the computer and the correct
baud rate. The baud rate must match the baud rate set on the MAP system. Exit this dialog by clicking 'Apply'.
Figure 21 shows the MAP console, now ready to accept and send commands to the MAP chassis.
In the text box at the bottom left corner, type in "*IDN?". This is the SCPI query to obtain the identification of
the connected instrument. Click on the 'Query' button. In the black area of the screen, the communication
between the computer and the MAP is displayed. The two lines should be as shown in Figure 21. If the
identification of the MAP unit is obtained correctly, proper communication has been established between the
computer and the MAP chassis.
16
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
Figure 20: Selecting the Serial Port
Figure 21: Testing Communications
Integrating New Modules into a MAP Chassis
The MAP Console is an ideal tool to use when integrating a new module into a MAP chassis. The new unit can
be plugged in while the MAP Console is running in live mode. Once this done, press the "Refresh Cards" button
in the tools menu. The new module should be recognized, and shown on the MAP Console interface. If this is
not the case, verify that the latest version of the firmware, supplied with the module, has been downloaded to
the MAP Chassis.
Once the module has been recognized by MAP, it can be controlled remotely.Try various commands to it using
the MAP tab and its communications function. Verify that it performs all valid operations it is commanded to
do. The module is now ready to be integrated into an automated test program.
17
T H E
M A P
C O N S O L E
P R O G R A M
D E S C R I P T I O N
To make this task even easier, the traffic between the MAP Console and the devices can be logged to a file, to
get a record of commands and responses to and from the devices. To do this, follows the
TOOLS>>OPTIONS>>CONSOLE menu selection, and specify the name of the file.This file can then be used to
figure out exactly how to connect to and control the MAP module using SCPI commands. Modules can also be
controlled using the ActiveX drivers supplied with MAP. This approach is discussed in detail in another
application note.
Sharing a MAP Chassis
It is possible to set up a MAP system in such a way that some of the devices on it are controlled by one
application, while others are controlled by another. There is a performance degradation compared to using
independent chassis because communications have to be interleaved between applications. However, the
advantage is that the same hardware can be used in different combinations by simply running different
applications that use different combinations of devices. An example of such resource sharing is shown in Figure
22. Here, two applications each use different devices on the same MAP chassis.The applications may be on one
computer, or separate computers.
APPLICATION 2
APPLICATION 1
Figure 22: Applications Sharing a MAP Chassis
18
T H E
M A P
C O N S O L E
P R O G R A M
W W W
.
J D S U
.
C O M
/
I N S T R U M E N T S
JDS Uniphase Corporation
8:00 am - 5:00 pm ET
3000 Merivale Rd
Ottawa, Ontario
Canada K2G 6N7
TEL: (613) 843.3000
FAX: (613) 843.3333
Instrumentation Global Sales and Customer Service
8:00 am - 5:00 pm ET (Monday - Friday)
North America: 1.800.406.9559
Outside North America: International Code+800.406.95599
China: 10.800.140.5599
[email protected]
www.jdsu.com/instruments
All information contained herein is believed to be accurate and is subject to change
without notice. No responsibility is assumed for its use. JDS Uniphase Corporation, its
subsidiaries and affiliates, or manufacturer, reserve the right to make changes, without
notice, to product design, product components, and product manufacturing methods.
Some specific combinations of options may not be available. Please contact
JDS Uniphase for more information. ©JDS Uniphase Corporation. All rights reserved.
10144291 REV 000
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement