Shake (Qmaster 1.2) Distributed Rendering Setup Guide for

Shake (Qmaster 1.2) Distributed Rendering Setup Guide for
90180SET Page 1 Thursday, April 15, 2004 3:32 PM
1
Shake Distributed Rendering
Setup Guide
This document takes you through the basic steps involved in the creation of two
different sample setups for Shake distributed rendering with Shake Qmaster. You can
use it to get an idea of the kind of distributed rendering environment you want to
create, and as a guide in setting up that environment.
The setup that resembles the kind of network you need depends on how much
rendering power you want and the kind of hardware you have:
• “Sample Setup for Part-Time Rendering on Desktop Computers” (page 3): This setup is
for an environment that uses desktop computers. We call it “part-time” rendering
because each computer acts as someone’s workstation, but at the same time is also
part of the rendering cluster. The bulk of the rendering jobs can be submitted with
Shake Qmaster at the end of the day, so that the computers are busy processing a
large queue of distributed rendering batches after everyone has gone home.
• “Sample Setup for a Full-Time Render Farm” (page 6): The full-time render farm setup is
for an environment that includes one Xserve and a number of Xserve cluster nodes
in a rack. The Xserve and cluster nodes form a Shake Qmaster cluster that is
completely dedicated to rendering jobs sent by user workstations (called client
computers). The client computers do not need to do any of the rendering, and they
can all be used for creating and sending Shake jobs.
Note: This section provides a sample setup for both Mac OS X Jaguar and
Mac OS X Panther.
Use this guide as a supplement to the Shake documentation and the Shake Qmaster
Help (accessible from the Help menu in Shake Qmaster and Shake Qadministrator). The
Shake documentation and the Shake Qmaster Help give you both the background
concepts and the details involved in using Shake and Shake Qmaster, while this
document helps you set up and use the network environment on which they will run.
1
90180SET Page 2 Thursday, April 15, 2004 3:32 PM
Shake Qmaster Network Essentials
Before you get started, you need to be aware of the following rules for any network
that uses Shake Qmaster:
• All computers using Shake Qmaster must be running a supported version of
Mac OS X (or, for servers, Mac OS X Server) as listed in the Shake Qmaster System
Requirements.
• The network must support the Apple Rendezvous technology built in to Mac OS X.
• A cluster must contain only one computer acting as the cluster controller, and at least
one computer acting as a service node. One computer can be used as both a cluster
controller and a service node. (The rendering is distributed across a cluster, which
contains a cluster controller that manages the cluster, and one or more service
nodes, which perform the rendering.)
• The cluster computers (cluster controller and service nodes) and the client
computers (user workstations) need to be on the same local network (subnet).
• All the computers in the setup need Read and Write access to any volumes that will
be specified as the source location or output destination for files, including Shake
scripts. The best way to configure this access, depending on whether your plan is for
part-time desktop computer rendering or full-time render farm rendering, is
addressed in the sample setups that follow.
2
90180SET Page 3 Thursday, April 15, 2004 3:32 PM
Sample Setup for Part-Time Rendering
on Desktop Computers
FireWire
drive
FireWire
drive
FireWire
drive
Network
FireWire
drive
FireWire
drive
Each computer acts as:
• A Shake Qmaster client that sends Shake jobs for rendering
• A service node that performs distributed rendering
All source and output files are stored on the FireWire drives.
In this sample setup, five computers act as both the clients (user workstations from
which users submit Shake jobs for distributed rendering) and the cluster computers
(which do the rendering). Each computer has an additional volume, such as a FireWire
drive, that is used for media before and after it is rendered, and for the associated
Shake scripts.
The steps that follow describe how to configure the desktop rendering environment
shown above. They assume that these computers are already connected to each other
on a network.
Step 1: Install Shake and Shake Qmaster
The necessary components of Shake and Shake Qmaster need to be installed on each
computer. For instructions, refer to the Installing Your Software booklet that came
with Shake.
3
90180SET Page 4 Thursday, April 15, 2004 3:32 PM
Step 2: Make sure each computer has a volume dedicated to media
Give each computer a second volume, such as a FireWire drive, that is used for media.
Each computer will use this volume for all source and destination files associated with
Shake scripts, including the Shake scripts themselves.
Note: Each media volume should have a different name.
Step 3: Turn off the UNC (Universal Naming Convention) setting for Shake
In order to make sharing and volume mounting work smoothly in this setup, you
need to turn the Shake UNC setting off on each computer. The UNC setting uses the
entire file pathname, with the network address, in a convention that starts with
//ComputerName/DriveName/path. You don’t want Shake to use this filenaming
convention because it conflicts with the file sharing and volume mounting used in
this setup.
In the three steps below, you make this change in a Shake startup .h file. As described
in the Shake documentation, the startup .h files, located in the startup directory, are
used to customize Shake settings (similar to setting preferences).
To turn off the UNC setting, do the following on each of the computers:
1 Log in as the user who will use Shake on the computer.
2 Double-click the Terminal icon in /Utilities/Applications to open a Terminal window.
3 Enter these two command lines in the Terminal window, pressing Return after each
command line:
mkdir -p ~/nreal/include/startup/
echo 'script.uncFileNames = 0;' > ~/nreal/include/startup/UNC_off.h
Step 4: Turn Personal File Sharing on
On each computer, open System Preferences, click Sharing, and turn on Personal File
Sharing. This allows the computers to share the media volumes.
Step 5: Mount all of the media storage volumes
On each computer, log in as the administrator. (The first user account you create when
you set up Mac OS X is an administrator account.) Then, on each computer in the
group, use the Connect to Server command in the Finder’s Go menu to mount each
media volume.
4
90180SET Page 5 Thursday, April 15, 2004 3:32 PM
On each computer, you need to:
• Enter another computer’s name in the Connect to Server dialog.
• Choose the associated media volume (FireWire drive) as the volume you want to mount.
Do this until all of the computers are mounting all of the media volumes in the cluster.
Step 6: Use Shake Qmaster to create a cluster
First, use the Shake Qmaster pane in System Preferences to enable cluster controlling
on one of the computers and enable the UNIX Processing service on all of the
computers (making them service nodes). Then, use Shake Qadministrator to assemble
these computers as a cluster. See the Shake Qmaster Help for detailed instructions.
Submitting Render Jobs in the Desktop Rendering Setup
After you finish the final step above, each one of these computers can be used to
submit Shake jobs for distributed rendering.
Because of the way access has been configured in this setup, all file pathnames are
conveniently consistent and simple for the purposes of specifying them in Shake scripts
and in Shake Qmaster, assuming that:
• Users place the source media on a mounted media volume (one of the FireWire drives).
• Users place the Shake scripts on a mounted media volume.
• All folders and files on the shared media volumes have Read and Write access
enabled for everyone (for Owner, Group, and Others). You can make this access
setting by selecting the folder or file and choosing File > Get Info.
The above three assumptions are important. They ensure that all of the computers
have Read and Write access to all of the media source files, Shake scripts, and output
destinations.
Specifying the Media File Locations in Shake Scripts
In the above setup, all the Shake render scripts should specify their source media (File
In) locations and output (File Out) destinations as: /Volumes/MediaDiskName.
For example: /Volumes/Media3.
Specifying Shake Script Locations in Shake Qmaster
In the above setup, all the Shake script locations should be specified in Shake Qmaster
as: /Volumes/MediaDiskName/ScriptFilename.
For example: /Volumes/Media3/Script.shk.
5
90180SET Page 6 Thursday, April 15, 2004 3:32 PM
Sample Setup for a Full-Time Render Farm
For visual effects companies that require more render power and speed, a full-time
render farm setup is the best choice.
Client
Client
Client
Client
Client
Network
Xserve
(cluster controller)
Xserve includes
second drive
for media.
Cluster nodes
(service nodes)
All client computers and cluster computers
mount the same media storage disk on the Xserve.
In this setup, the client computers and the cluster computers are two different groups,
networked together. The desktop computers are the client computers from which users
submit Shake jobs for distributed rendering. The cluster consists of an Xserve and a
number of Xserve cluster nodes (which provide high-density processing power without
unnecessary server features and optical drives) on a rack. The Xserve is configured as
the cluster controller and as a service node, and includes a second drive for all source
and destination media files. The Xserve cluster nodes in the rack are configured as
service nodes.
Note: Instead of using a second Xserve drive for the media storage, you could use an
Xserve RAID.
The steps that follow describe how to configure this render farm environment, with
separate sections for Mac OS X Jaguar (page 7) and Mac OS X Panther (page 13).
6
90180SET Page 7 Thursday, April 15, 2004 3:32 PM
Assumptions for This Setup
These setup steps assume the following:
• You have read the essentials described in “Shake Qmaster Network Essentials” on
page 2.
• You have a DHCP server on your network.
• For the Xserve, you have a static IP address that can be assigned within your DHCP subnet.
• The cluster nodes will get their IP address from DHCP.
• You have Apple Remote Desktop.
If you need to purchase Apple Remote Desktop, see http://www.apple.com/remotedesktop,
or contact your local Apple Store or Apple Authorized Reseller.
Getting More Information About Server Administration Tools
You can find the most up-to-date, step-by-step procedures for using the
Mac OS X Server tools mentioned here, such as Open Directory Assistant and
WorkGroup Manager, by using the onscreen help that is available with all server
administration programs. Administration tasks are also described thoroughly in the
Mac OS X Server documentation.
Sample Render Farm Setup for Mac OS X Jaguar
This section describes setting up a render farm on computers that are running a
supported version of Mac OS X (or Mac OS X Server) that is earlier than version 10.3.
Note: If your computers are using Mac OS X (or Mac OS X Server) version 10.3 or later,
go to “Sample Render Farm Setup for Mac OS X Panther” on page 13.
Step 1: Start up the Xserve and use Server Assistant for the initial setup
Turn on the Xserve and follow the Server Assistant onscreen instructions to get the
Xserve up and running. Be sure to:
• Configure it for a static IP address that can be assigned within your DHCP subnet and
that is outside the range of your dynamically assigned DHCP addresses.
• If you don’t know what address to enter, see your system administrator for assistance.
• Make the Host Name the same as the Computer Name.
Note: The DNS (Domain Name Server) address will be provided by DHCP and therefore
doesn’t have to be entered now.
If this is the first time you’ve set up this Xserve, Server Assistant appears when you start it
up. When you are finished with Server Assistant, Open Directory Assistant appears. If
neither of these appear automatically, you can always access them in /Applications/Server.
Note: Remember to plug in and connect all of your network cables, since you will need
the network for these steps.
7
90180SET Page 8 Thursday, April 15, 2004 3:32 PM
Step 2: Use Open Directory Assistant to configure directory and
password services
This step assumes that your Xserve is new and is not hosting any existing directory
service. If your Xserve is already hosting, skip this step and enter the information for the
currently hosted directory service when prompted in the upcoming steps.
Warning: Using Open Directory Assistant deletes any directory service hosting that
currently exists on the server.
Follow the Open Directory Assistant onscreen instructions, making sure to:
•
•
•
•
Select the option to use a permanent IP address.
Select the option to provide directory information to other computers.
Selecting this option automatically starts NetInfo directory services.
Select the option to provide password and authentication to other computers.
Step 3: Use Directory Access to specify the Xserve as the NetInfo server
Open the Directory Access utility (located in /Applications/Utilities) and use it to:
• Specify that you want to connect to a specific NetInfo server.
• Enter the Xserve IP address as the NetInfo server address, with the server tag “network.”
You need to restart the Xserve after using Directory Access.
Step 4: Use System Preferences to configure the Xserve for static IP and
name sharing
1 Open the Network pane in System Preferences and configure the network for static IP,
making sure to:
• Choose to configure manually in the TCP/IP pane.
• Enter the static IP address for the Xserve, as well as the subnet mask (for example,
255.255.0.0).
2 Open the Sharing pane and make sure the same Xserve name is entered in each of the
name fields.
Step 5: Install Shake and Shake Qmaster on the Xserve and on the
client computers
Install the necessary components of Shake and Shake Qmaster on the Xserve and on
the client (user) computers. Keep in mind that the Xserve will act as a service node and
a cluster controller, as well as an administrator computer.
For more information, refer to the Installing Your Software booklet that came with Shake.
Note: You will install Shake and Shake Qmaster on the cluster nodes in a later step,
using Apple Remote Desktop.
8
90180SET Page 9 Thursday, April 15, 2004 3:32 PM
Step 6: Use Disk Utility to configure the media disk
The second disk in the Xserve will be the media storage volume. All of the client and cluster
computers will use this same drive for all of the source and destination render media.
Important: This step assumes the disk is new and doesn’t contain content you need to
save. If this is a volume that already has data on it, skip this step.
Use Disk Utility (located in /Applications/Utilities) to erase (format) your new disk,
creating a clean disk.
Note: If you are using an Xserve RAID instead of a second Xserve disk, use the RAID
administration tools to configure it and then use Disk Utility to erase (format) the disk.
Step 7: Use WorkGroup Manager to configure sharing for the media disk
On the Xserve, open WorkGroup Manager (located in /Applications/Utilities), and use it
to configure the media disk as a share point that automounts to all of the client
computers and cluster nodes. (Share points are volumes that you have made accessible
over the network. Automounting means that the volume is automatically mounted by
the computers in the same NetInfo domain.) In the WorkGroup Manager, go to the
Sharing pane and be sure to do the following:
• Select the media disk.
• Enable Sharing for the media disk, and give everyone Read and Write access to it.
• In the Protocols pane, choose NFS Export Settings and make sure that you enable
exporting to World. Do not select mapping options and do not select Read only.
• In the Automount pane:
• Select the option to automount to clients in the domain.
• Mount dynamically in /Network/Servers/.
• Select NFS as the protocol.
Important: Be aware that the “export to World” setting could be a security risk for your
content if the network you are using is connected to the Internet without firewall protection.
9
90180SET Page 10 Thursday, April 15, 2004 3:32 PM
Step 8: Use Server Assistant and Open Directory Assistant to configure the
cluster nodes
For this step, the cluster nodes need to be on and connected to the network.
Open Server Assistant on the Xserve and use it to configure NetInfo on each of the
cluster nodes. Be sure to:
• Choose to “Set up a server,” then click Refresh List.
• Select a server (cluster node) to configure, then click the Lock button and enter the
required authentication.
• Follow the onscreen instructions to set up an administrator account on the cluster
node. Make sure that the Host Name and the Computer Name are entered as the
same name.
• Disable TCP/IP and AppleTalk for all ports except Built-in Ethernet. Make sure they are
enabled for the Built-in Ethernet port.
Note: Within Server Assistant, you should see the network addresses for the cluster
node that were assigned by the DHCP server. These are the ones you need, so do not
change them.
Open Directory Assistant appears when the Server Assistant configuration is complete.
In Open Directory Assistant, on each node, you need to:
• Select the option to use a permanent IP address and subnet.
Note: In a later step, using Apple Remote Desktop and System Preferences, you
configure each node to use DHCP, but for now you need to select the permanent IP
address option.
• Select the option to get directory information from an existing system.
• Choose to access the directory using NetInfo and to find the NetInfo server using a
static IP address.
• Enter the Xserve IP address as the NetInfo IP address, and enter “network” as the
NetInfo Server Tag.
Step 9: Use Directory Access to connect the client computers to the
NetInfo server
Log in to each client (user) computer, then open the Directory Access utility (located in
/Applications/Utilities) and use it to:
• Specify that you want to connect to a specific NetInfo server.
• Enter the Xserve IP address as the NetInfo server address, with the server tag “network.”
10
90180SET Page 11 Thursday, April 15, 2004 3:32 PM
Step 10: Install Apple Remote Desktop on the Xserve and on the cluster nodes
Since the cluster nodes do not have a graphical user interface, you will use Apple
Remote Desktop to log in to each node from the Xserve and perform the installations
remotely using the Xserve graphical user interface. If you do not already have Apple
Remote Desktop on the Xserve and cluster nodes, you need to install it. You have to
install it on the cluster nodes remotely.
1 Follow the onscreen Apple Remote Desktop Installer instructions to install Apple
Remote Desktop on the Xserve.
2 Use SSH (Secure Shell) to install and configure Apple Remote Desktop on each node.
On the Xserve, you need to use SSH to log in to each Xserve cluster node and install
and configure Apple Remote Desktop. Refer to the AppleCare Knowledge Base
articles 107145 and 106981 for details on using SSH to remotely install and configure
Apple Remote Desktop:
• http://docs.info.apple.com/article.html?artnum=107145
• http://docs.info.apple.com/article.html?artnum=106981
Step 11: Use Apple Remote Desktop to configure Network System
Preferences and Directory Access on each node
1 Log in to each cluster node using Apple Remote Desktop on the Xserve. Then, in
Network System Preferences, use the TCP/IP pane to configure the node so that the
built-in Ethernet port is using DHCP.
2 Log in to each cluster node, then open the Directory Access utility (located in
/Applications/Utilities) and use it to:
• Specify that you want to connect to a specific NetInfo server.
• Enter the Xserve IP address as the NetInfo server address, with the server tag “network.”
Note: If the Apple Remote Desktop window becomes unreadable after you log in to a
node, use SSH to log in to the node and then enter a command to stop Apple Remote
Desktop agent processes, as described in the following steps:
a Enter these two command lines in a Terminal window:
ssh ClusterNodeAddress
sudo killall “ARD Agent”
b Close the Apple Remote Desktop window, then use Apple Remote Desktop to log in
to the same node again.
11
90180SET Page 12 Thursday, April 15, 2004 3:32 PM
Step 12: Use Apple Remote Desktop to install Shake and Shake Qmaster
Follow the steps below to use the Apple Remote Desktop package installer feature on
the Xserve to install Shake and Shake Qmaster on all of the cluster nodes.
1 Insert the Shake CD in the Xserve CD drive.
2 In Apple Remote Desktop, select all of the cluster nodes and choose Manage > Install
Package. The Apple Remote Desktop Install Packages window appears.
3 In the “Go to” field, enter the Packages pathname, then press Return. For example,
/Volumes/ShakeVolumeName/Installer/Package, where ShakeVolumeName is the CD
icon name that appears on your desktop.
4 In the Packages folder, select the Shake “.pkg” file, then click Install.
5 When that installation is complete, select QTProMedia.pkg, then click Install.
6 When that installation is complete, select Qmaster.Services.pkg, then click Install.
7 When the Qmaster.Services.pkg installation is complete, select all of the cluster nodes
in Apple Remote Desktop again, then choose Manage > Restart.
For more information about Shake and Shake Qmaster installations, refer to the
Installing Your Software booklet that came with Shake.
Step 13: Use Shake Qmaster to create a cluster
Now you can create a Shake Qmaster cluster that contains the Xserve and the cluster
nodes. The three basic steps involved in creating the cluster are outlined below. See the
Shake Qmaster Help for more information about creating clusters.
1 Using Apple Remote Desktop on the Xserve:
a Log in to a cluster node.
b Open the Shake Qmaster pane in System Preferences, then enable the UNIX
Processing service. (This configures a cluster node to serve as a service node.)
c Repeat the above two steps on each cluster node.
2 Use the Shake Qmaster pane in System Preferences to enable cluster controlling and
UNIX Processing on the Xserve.
3 Use Shake Qadministrator on the Xserve to create a cluster that contains the Xserve
and the cluster nodes.
After you finish this final step, the client computers can start submitting Shake jobs to
the cluster for distributed rendering.
12
90180SET Page 13 Thursday, April 15, 2004 3:32 PM
Submitting Render Jobs in the Render Farm Setup
Because of the way access is configured in this setup, all file pathnames are
conveniently consistent for the purposes of specifying them in Shake scripts and in
Shake Qmaster, assuming that:
• Users place all source media for the Shake scripts on the second Xserve drive (which
each user will see mounted in /Network/Servers/XserveName.local/Volumes/).
• Users place all the Shake scripts on the second Xserve drive.
• All folders and files on the second Xserve drive (the media volume) have Read and
Write access enabled for everyone (for Owner, Group, and Others). You can make this
access setting by selecting the folder or file and choosing File > Get Info.
The above three assumptions are very important. They ensure that the user computers
and cluster computers have Read and Write access to all the media source files, Shake
scripts, and output destinations.
Specifying the Media File Locations in Shake Scripts
In the above setup, all the Shake render scripts should specify their source media (File
In) locations and output (File Out) destinations as:
/Network/Servers/XserveName.local/Volumes/MediaDiskName/.
For example: /Network/Servers/Xserve.local/Volumes/Media/.
Specifying Shake Script Locations in Shake Qmaster
In the above setup, all the Shake script locations should be specified in Shake Qmaster
as: /Network/Servers/XserveName.local/Volumes/MediaDiskName/ScriptFilename.
For example: /Network/Servers/Xserve.local/Volumes/Media/Script.shk.
Sample Render Farm Setup for Mac OS X Panther
This section describes setting up a render farm with computers that are running
Mac OS X (or Mac OS X Server) version 10.3.2 or later. See “Sample Setup for a Full-Time
Render Farm” on page 6 for a diagram of this setup.
Step 1: Start up the Xserve and use Server Assistant for the initial setup
Turn on the Xserve, which will act as the cluster controller, and follow the Server
Assistant onscreen instructions to get the Xserve up and running. (This sample setup
assumes you are setting up the Xserve for the first time.)
Configure the Xserve for a dynamic address that is assigned by DHCP, making sure to:
•
•
•
•
Make the Host Name match the Computer Name and Rendezvous name.
Select the option to use a dynamic (DHCP) IP address.
Select the option to be an Open Directory Master.
Enable Apple File Service.
13
90180SET Page 14 Thursday, April 15, 2004 3:32 PM
Note: In this example, the name “Blue” will be used for this Xserve.
Remember to plug in and connect all of your network cables, since you will need the
network for these steps. Take the time to make sure you have all cables properly connected.
Warning: Because having an additional primary domain controller on your network
could cause an existing primary domain controller to behave unpredictably, you
should not enable a Windows primary domain controller unless you are familiar with
the ramifications.
Step 2: Make a note of the Server Admin LDAP settings
Open Server Admin (located in /Applications/Server) and then:
1 Connect to the Xserve (for example, blue.local).
2 Go to the Open Directory page, then the Settings page, and click the Protocols tab.
3 Write down the Search Base that appears on this page. You will use this information in
the next step.
Step 3: Use Directory Access to specify the Xserve as the LDAP server
Open the Directory Access utility (located in /Applications/Utilities) and do the
following:
1 In the Service pane, select LDAPv3, then click Configure.
2 Click Show Options, then click New to create a new LDAP configuration.
3 Enter a Configuration Name that is similar to your Xserve name (for example,
Blue LDAP).
4 Set the Server Name or IP Address to the Rendezvous name of your Xserve (for
example, blue.local).
5 Set the Search Base to the value you noted in step 2 (for example, dc=blue).
6 In the Authentication pane, choose Custom Path from the Search pop-up menu.
7 Click Add, then choose the Xserve LDAP server (for example, /LDAPv3/blue.local).
Step 4: Install Shake and Shake Qmaster on the Xserve and on the
client computers
Install the necessary components of Shake and Shake Qmaster on the Xserve and on the
client (user) computers. Keep in mind that the Xserve will act as a service node and
cluster controller, as well as an administrator computer. For details on how to install Shake
and Shake Qmaster, refer to the Installing Your Software booklet that came with Shake.
Note: You will install Shake and Shake Qmaster on the cluster nodes in a later step,
using Apple Remote Desktop.
14
90180SET Page 15 Thursday, April 15, 2004 3:32 PM
Step 5: Use Disk Utility to configure the media disk
The second disk in the Xserve will be the media storage volume. All of the client and cluster
computers will use this same disk for all of the source and destination render media.
Important: This step assumes the disk is new and doesn’t contain content you need to
save. If this is a volume that already has data on it, do not erase (format) the disk.
Instead, proceed to the next step.
Use Disk Utility (located in /Applications/Utilities) to erase (format) your new disk,
creating a clean disk. (In this sample setup up, we name the media disk “BlueHD.”)
Note: If you are using an Xserve RAID instead of a second Xserve disk, use the RAID
administration tools to configure it and then use Disk Utility to format the disk.
Step 6: Use WorkGroup Manager to configure sharing for the media disk
Now you need to configure the media disk as a share point that automounts to all of the
client computers and cluster nodes. (Share points are volumes that you have made
accessible over the network. Automounting means that the volume is automatically
mounted by the computers in the same LDAP domain.)
On the Xserve, open WorkGroup Manager (located in /Applications/Server) and use it
configure the media disk as a share point. Be sure to do the following:
• In the Sharing pane, select the media disk.
• Enable Sharing for the media disk, and give everyone Read and Write access to it.
• In the Protocols pane, choose NFS Export Settings and make sure that you enable
“export to World.” Deselect “Map all users to Nobody” and deselect Read only.
In the Network Mount pane:
• Select the option to create a mount record for this share point.
• Select NFS as the protocol.
• Select the option to use for User Home Directories.
Important: Be aware that the “export to World” setting could be a security risk for your
content if the network you are using is connected to the Internet without firewall protection.
15
90180SET Page 16 Thursday, April 15, 2004 3:32 PM
Step 7: Use Server Assistant to configure the cluster nodes
For this step, the cluster nodes need to be turned on and connected to the network.
Open Server Assistant (located in /Applications/Server) on the Xserve and use it to
configure the cluster nodes. Be sure to:
• Choose to “Set up a remote server,” then click Continue.
• Select a server (cluster node) to configure, enter the required password, then click
Continue. (The default password is the first eight characters of the computer serial
number.)
• Follow the onscreen instructions to set up the cluster node. Make sure that the Host
Name, Computer Name, and Rendezvous Name are entered as the same name. You
will be prompted for your Mac OS X software serial number.
• Disable TCP/IP and AppleTalk for all ports except Built-in Ethernet. Make sure that
only TCP/IP is enabled for the Built-in Ethernet port.
Note: Within Server Assistant, you should see the DNS network addresses for the
cluster node that were assigned by the DHCP server. These are the addresses you
need; do not change them. The system acquires the networking information it needs
using DHCP.
• Add “local” to the Search domains field. (This enables Rendezvous name resolution,
which is required for later steps.)
• Set directory usage to Connected to a Directory System, and, in the window that
follows, select the Apple LDAP Directory option.
• Choose the option to enter the LDAP server manually.
• Enter the Rendezvous name of the Xserve (in this example, blue.local).
After you complete the cluster node configuration, you need to restart the nodes.
Step 8: Configure Apple Remote Desktop on the cluster nodes
Since the cluster nodes do not have a graphical user interface, you will use Apple
Remote Desktop to log in to each node from the Xserve and perform the Shake
installations remotely using the Xserve interface. But first, from the Xserve, you need to
use SSH to log in to each cluster node and configure Apple Remote Desktop. Refer to
the AppleCare Knowledge Base article 106981 for details on using SSH to remotely
configure Apple Remote Desktop:
http://docs.info.apple.com/article.html?artnum=106981
16
90180SET Page 17 Thursday, April 15, 2004 3:32 PM
Step 9: Use Apple Remote Desktop to configure Network System Preferences
on each node
Log in to each cluster node using Apple Remote Desktop on the Xserve. In Network
System Preferences on each node:
• Use the TCP/IP pane to configure the node so that the built-in Ethernet port is
using DHCP.
• Add “local” to the Search domains field. (This enables Rendezvous name resolution,
which is required for later steps.)
Step 10: Use Apple Remote Desktop to install Shake and Shake Qmaster
Follow the steps below to use Apple Remote Desktop on the Xserve to install Shake
and Shake Qmaster on each of the cluster nodes.
1 Insert the Shake CD in the Xserve CD drive.
2 Select the Shake CD. Choose Edit > Copy.
3 Open the media disk you configured and choose Edit > Paste Item. This makes a copy
of the Shake installation CD-ROM on your media disk.
4 Using Apple Remote Desktop, select a cluster node and click the Control icon to take
control of the node.
5 In the Finder on the remote cluster node, open the Shake installer on your
automounted media disk. (In this sample setup, it would be located in /Network/
Servers/XserveName/Volumes/MediaDiskName/ShakeVolumeName/Installer, where
ShakeVolumeName is the Shake CD icon name that appears on the desktop.)
6 Double-click the Shake “.mpkg” file. Install the necessary Shake and Shake Qmaster
components.
7 When the installation is complete, choose Manage > Restart, and then close the
Remote Desktop window for the cluster node.
Repeat these steps for each of the remaining cluster nodes.
For more information about Shake and Shake Qmaster installations, refer to the
Installing Your Software booklet that came with Shake.
Step 11: Use Shake Qmaster to create a cluster
Now you can create a Shake Qmaster cluster that contains the Xserve and the cluster
nodes. The three basic steps involved in creating the cluster are outlined below. See the
Shake Qmaster Help for more information about creating clusters.
1 Using Apple Remote Desktop on the Xserve:
a Log in to a cluster node.
b Open the Shake Qmaster pane in System Preferences, then enable the UNIX
Processing service. (This configures a cluster node to serve as a service node.)
c Repeat the above two steps on each cluster node.
17
90180SET Page 18 Thursday, April 15, 2004 3:32 PM
2 Use the Shake Qmaster pane in System Preferences to enable cluster controlling and
UNIX Processing on the Xserve.
3 Use Shake Qadministrator on the Xserve to create a cluster that contains the Xserve
and the cluster nodes.
After you finish this final step, the client computers can start submitting Shake jobs to
the cluster for distributed rendering.
Submitting Render Jobs in the Render Farm Setup
Because of the way access is configured in this setup, all file pathnames are
conveniently consistent for the purposes of specifying them in Shake scripts and in
Shake Qmaster, assuming that:
• Users place all source media for the Shake scripts on the second Xserve drive (which
each user will see mounted in /Network/Servers/XserveName.local/Volumes/).
• Users place all the Shake scripts on the second Xserve drive.
• All folders and files on the second Xserve drive (the media volume) have Read and
Write access enabled for everyone (for Owner, Group, and Others). You can make this
access setting by selecting the folder or file and choosing File > Get Info.
The above three assumptions are very important. They ensure that the user computers
and cluster computers have Read and Write access to all the media source files, Shake
scripts, and output destinations.
Specifying the Media File Locations in Shake Scripts
In the above setup, all the Shake render scripts should specify their source media (File
In) locations and output (File Out) destinations as:
/Network/Servers/XserveName.local/Volumes/MediaDiskName/.
For example: /Network/Servers/blue.local/Volumes/BlueHD/.
Specifying Shake Script Locations in Shake Qmaster
In the above setup, all the Shake script locations should be specified in Shake Qmaster
as: /Network/Servers/XserveName.local/Volumes/MediaDiskName/ScriptFilename.
For example: /Network/Servers/blue.local/Volumes/BlueHD/Script.shk.
© 2004 Apple Computer, Inc. All rights reserved.
Apple, the Apple logo, Apple Store, AppleTalk, FireWire, Mac, Mac OS, and Shake are trademarks of Apple Computer, Inc.,
registered in the U.S. and other countries. Apple Remote Desktop, Finder, Rendezvous, and Xserve are trademarks
of Apple Computer, Inc. AppleCare is a service mark of Apple Computer, Inc., registered in the U.S. and other countries.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement