Rational Developer for Power Systems Software – Lab 02 Level: Introductory

Rational Developer for Power Systems Software – Lab 02  Level: Introductory
IBM Software
Rational Developer for Power Systems Software – Lab 02
Edit an RPG source member and work with the LPEX editor
Level: Introductory
April 2010
© Copyright International Business Machines Corporation, 2010. All rights reserved.
US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract with
IBM Corp.
Page 6
Rational Developer for Power Systems Software
IBM Software
Contents
LAB 2
Lab 2
MAINTAIN AN IBM I APPLICATION USING REMOTE SYSTEMS EXPLORER (RSE) EDIT
RPG SOURCE 9
2.1
OVERVIEW ........................................................................................................................................... 9
2.2
OPENING SOURCE MEMBERS IN THE REMOTE SYSTEMS EXPLORE ...................................................... 10
2.3
WORKING WITH THE LPEX EDITOR ................................................................................................... 17
Page 7
IBM Software
Lab 2
Maintain an IBM i application using Remote Systems
Explorer (RSE) Edit RPG source
2.1
Overview
This tutorial teaches you how to maintain an IBM i application written in ILE RPG using the Remote Systems
Explorer.
Learning objectives
Use tools and views in the Remote Systems Explorer (RSE) perspective to edit, a source member.
Skill level
Introductory
Audience
IBM i developer
System requirements
IBM Rational® Developer for Power Systems Software, V7.5 and all software updates through the IBM Installation
Manager.
IBM i, V5.4, or V6.1
Prerequisites
Basic Microsoft Windows operations such as working with the desktop and basic mouse operations such
as opening folders and performing drag-and-drop operations
It will also help if you understand DDS and ILE RPG.
This tutorial is divided into a number of modules, each with its own learning objectives. You can
choose to skip the modules on Edit and Compile. You can go directly to other modules if you are only
interested in those parts . However you need to complete LAB01 to create a connection to an IBM i
server. Each module contains several lessons that should be completed in order for the tutorial to
work as shown in this script.
Expected results
Upon completion of this tutorial you will know how to edit, an IBM i application from the Remote
Systems Explorer. You will also know how to customize the Remote Systems Explorer.
Conventions used in this tutorial
•
Bold font for user interface controls
• Mono-spaced font for user input and code blocks
• Italic font for variable names and glossary terms.
Page 8
Rational Developer for Power Systems Software
IBM Software
Important!
You should go through Lab01 'Create a connection and get started
with RSE' before you work on this Lab. Lab01 contains the following
information:
• Which IBM i server to connect to,
• Which userid to use,
• How to setup the correct library list for this lab.
2.2
Opening source members in the Remote Systems Explore
This module teaches you about the Live Parsing eXtensible (LPEX) editor. How to edit source members
and how to navigate through source member.
Learning objectives
• Open a member for edit from the Table view or the Remote Systems view
• Maximize the editor space
• Open another member for edit
• Switch from one edit session to another edit session
• Open multiple views of the same source member
• Display a structural outline of items defined in a source member
•
2.2.1 Getting started with RDp
The information about starting Rational Developer for Power Systems Software (RDp) are described in
Lab01 the first of this series of labs. Please start with the first lab to learn how create a connection to an IBM
i system. How to use the Remote Systems Explorer View to access IBM i objects. After you went through
the exercises in the first Lab, you are ready to start with this Lab and use the connection to your IBM i
system that is available in the RDp workspace.
Make sure the library list is setup so library RSELABxx, xx being your assigned team number, is part of the
library list.
__1.
__2.
Lab 2
Expand library RSELABxx if it is not already expanded
Expand file QDDSSRC in library RSELABxx
Page 9
IBM Software
2.2.2
Opening a source member
You are going to use the LPEX Editor to edit the member MSTDSP found in QDDSSRC.
__1.
From the Remote Systems view double-click member MSTDSP in the QDDSSRC source file.
You can do this in the Remote Systems view or in the Object Table view.
The Remote Systems LPEX Editor opens. It is built right into the workbench, with rich editing
functions and is IBM i aware! It is a superset of SEU! The syntax checker is ported from SEU, and the
reference manuals are built-in and F1 cursor sensitive.
__2.
Double-click the MSTDSP tab to maximize the Editor window.
__3.
Double-click the MSTDSP tab again to return the view to its original size.
Page 10
Rational Developer for Power Systems Software
IBM Software
Tip: To open iSeries™ members quickly, you can use the keyboard shortcut Ctrl+Shift+A, or
right-click IBM i Objects and select Open Member, without the need to drill down through your
IBM i Objects subsystem to find the member.
2.2.3
Opening a second source member and multiple views
Next let’s open a second member in the editor.
To open a second source member:
__1.
In the Remote Systems view, double-click member PAYROLL in the QRPGLESRC source file.
You can easily switch between the two edit session
__2.
Click on each tab to switch from one edit session to another edit session.
Tip: You can also switch between files that are open in the editor view by pressing CTRL+F6.
You can open multiple views of the same source member while editing in the Remote Systems LPEX
editor. To open multiple views of your RPG source:
__3.
Double-click the PAYROLL tab in the editor to maximize the Editor window.
__4.
Right-click this source in the Editor view and click View > Open new view.
Lab 2
Page 11
IBM Software
Tip: You can open a maximum of five views of the same source.
__5.
Page 12
Right-click in one of the source views and select View > Next view or View > Previous view
to navigate among the views.
Rational Developer for Power Systems Software
IBM Software
Note:
Any changes made in one of the views will automatically update all other views of the same
source.
__6.
__7.
Scroll down and place the cursor at line 33 in the left view of the Payroll source.
Press Enter.
A new line is inserted in both views and since the previous line is a D-spec, the new line is also
marked as a D-spec.
__8.
Define a new variable, i as shown in the screenshot below, with length 10:
Lab 2
Page 13
IBM Software
Now, in the view on the right, you can start using the new variable while being able to maintain your
view on the left on the definition of the variable.
Another nice feature is the ability to change the way the views split, if you don't like the vertical split
you can specify to split horizontal instead. Lets try that:
__9.
Right-click a source view and select View > Horizontal split to change from a vertical split
of the views to a horizontal split of the views.
Here is how your edit view should look now:
Page 14
Rational Developer for Power Systems Software
IBM Software
If you want to close the extra views:
__10. Right-click the source view that you want to close
(RSELABXX/QRPGLESRC(PAYROLL): 2)
__11. Select View > Close view
Tip:
This option is not available on the first view
You have opened another member for edit and seen multiple views of a member.
2.2.4
Using the Outline view of a source member
The Outline view acts as an excellent resource when you want to navigate through RPG, COBOL
and DDS source in the Remote Systems LPEX editor. The Outline view displays a structural outline of
items defined in the file that you currently have open in the Remote Systems LPEX editor window.
With the editor active, you can expand the file structure in the Outline view, and click various
elements in the view to jump to that location in the source itself.
To see an Outline view of your RPG source:
__1.
Click the PAYROLL tab in the editor and click Refresh on the Outline view toolbar.
Tip:
If you have closed the Outline view previously, you can reset the perspective by selecting
Window > Reset perspective from the workbench menu or Window > Show view > Other
then expand General and click Outline in the Show view dialog.
The Outline view contains your source program in a tree view without the lines containing logic.
Lab 2
Page 15
IBM Software
Now you want to see more details of your source member.
__1.
Expand Files.
__2.
Expand the MSTDSP workstation file.
__3.
Expand the EMPSEL record format.
__4.
Expand EMPNO.
__5.
Click on any line number in the Outline view.
This will position the source editor accordingly.
Tip:
Clicking a field or a variable in the Outline view will position the editor to its definition.
__6.
Click the PAYROLL tab to get the PAYROLL editor window in focus for the next lesson.
You have displayed an outline of a source member while editing RPG or DDS sources.
2.3
Working with the LPEX editor
This module teaches you how to edit a RPG source member, and learn about some of the Remote
Systems LPEX Editor’s language support features.
• Learning objectives
Page 16
Rational Developer for Power Systems Software
IBM Software
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
Change the default settings of the LPEX Editor Parsers
Change the color settings and font used by the Editor
Change the default behavior of the Enter key
Use SEU commands to edit source
Undo and redo source changes
View language sensitive help for the MOVE operation code
View a list of all help contents
Limit the search of help to specific documents
Search the help
Request a prompt for a specification line
Display context sensitive help for any field in the IBM i Source Prompter
View the beginning and ending of constructs in your source
Use the Find and Replace window to search for an item in your source
Filter or subset your source
Filter lines based on line type
Search through members in a source physical file
Compare different versions of a program and identify the differences
Syntax check source by line
View help on syntax errors
Introducing the LPEX editor
Your program editing tasks are simplified with the Remote Systems LPEX Editor. The editor can access
source files on your workstation or your IBM i system directly. When a compilation results in errors,
you can jump from the compiler messages to an editor containing the source. The editor opens with the
cursor positioned at the offending source statements so that you can correct them.
Here is a list of some of the basic editor features that you would expect in a workstation editor:
• Cut, copy, and paste
• Block marking of lines, characters, or rectangles with copy, move, and delete operations
• Powerful find and replace function
• Unlimited undo and redo
In addition there are a few more functions that you may not have seen in a workstation editor:
• Token highlighting where different language constructs are highlighted using different colors to help
identify them in a program
• SEU-like format-line rulers to show the purpose of each column for column-sensitive
languages like RPG and DDS. These rulers can automatically update themselves to reflect the
current specification.
• SEU-like specification prompting for CL, RPG, and DDS
• Sequence numbers, which allow SEU-style commands in the prefix area
• Intelligent tabbing between columns for column-sensitive languages
• Automatic uppercasing for languages that expect uppercase
• Settings for column-sensitive languages that simplify text insertions and deletions
• On-line language reference
2.3.1
Changing default editor settings
The LPEX Editor has predefined settings, but also has an associated preferences page containing settings
that you can modify. The name of the preference category is LPEX Editor and it appears in the left pane
of the Preferences window.
Lab 2
Page 17
IBM Software
You will change the default settings of LPEX Editor Parsers, Appearance and User Key Actions.
LPEX provides special support for insertion and deletion in column-sensitive languages.
When column-sensitive editing is selected, each column is considered as a separate entry space. For
example, in an RPG source member, if you are inserting into or deleting characters from a string that
is in the Factor 2 entry, the Result field entry does not move. The default editor preference is that
column-sensitive editing is off. You can switch this support on by going to the workbench
preferences window.
To set column sensitive editing:
__1.
In the workbench menu, click Window > Preferences from the workbench menu.
The Preferences window opens
In the left pane of the Preferences window, expand Remote Systems.
__2.
Select Remote Systems LPEX Editor.
The right pane allows you to set preferences for this feature.
__3.
In the right pane of the Preferences window, select the Column sensitive editing check box.
When selected, each column is considered as a separate entry space.
Page 18
Rational Developer for Power Systems Software
IBM Software
__4.
Click the Apply button.
2.3.2
Autosave while editing source
To enable or disable autosave while editing source in the Remote Systems LPEX Editor, select or deselect the Autosave check box in the preference dialog.
By default, autosave is enabled and the value for the minutes is set to 5. You can specify a value
between 1 and 60 minutes
Note: The Autosave action will perform a local backup onto the workstation disk. It will not
remotely save the member onto the IBM i server. Use the Save or Save as actions to save the
member back onto the IBM i server.
2.3.3
Changing the editor appearance
Other interesting preference settings are located under LPEX Editor. You can use the link at the top of the
page to quickly jump to the LPEX Editor preferences. Appearance allows you to modify color settings and
font used by the Editor.
To change the editor appearance:
__1.
__2.
__3.
__4.
Lab 2
In the left pane of the Preferences window, expand LPEX Editor.
Select Appearance under LPEX Editor
In the right pane under the Styles list, select formatLine.
Change the Foreground color to dark green.
Page 19
IBM Software
__5.
__6.
Change Font to 12.
Change Background color to light green.
Notice, how your changes are reflected in the sample edit view.
To change the current line appearance to make it more visible when editing:
__7.
Select currentLine under the Styles list.
This option highlights the line that the cursor is on. The option applies to all source files opened in the
editor area.
__8.
Change the Background color to light yellow.
__9.
If you don’t like the changes you made, you can click Restore Defaults to return to the original
settings.
Page 20
Rational Developer for Power Systems Software
IBM Software
2.3.4
Changing key behavior in the editor
To modify the default behavior of the Enter key:
__1.
Expand LPEX Editor if not already expanded
__2.
Select User Key Actions.
The LPEX Editor has a predefined behavior for the Enter key to always add a new line and not split the
line when the Enter key is pressed. To change the default behavior for the Enter key to split the line, use
the following instructions. .
__3.
Type enter in the Key field.
Tip:
The Key and Action fields are case sensitive. Make sure that the values typed in the
Key and Action fields are exactly as shown above.
__4.
Type splitLine in the Action field.
Tip: Use the drop down list to select the value
Lab 2
Page 21
IBM Software
__5.
Click the Set button.
We go through one other preferences entry that users like to change. Adding the previous specification
type to a new line when editing RPG source is not liked by all users. Here is how to change this
behavior:
__6.
Expand Remote Systems
__7.
Expand Remote Systems LPEX Editor, and then IBM i Parsers
__8.
Select ILE RPG
__9.
Clear the Repeat previous specification type check box
__10. Click OK on the Preferences window
__11. Return to the Editor window.
Page 22
Rational Developer for Power Systems Software
IBM Software
Next let’s see the results of the customization.
2.3.5
Testing the editor customization
Notice that the line the cursor is on is now highlighted in the color you selected for it in the preference
setting for highlight current line.
__1.
Move the cursor to line 27, column 10
__2.
Make sure the editor is in Insert mode. If the status area shows Replace press the Insert key.
__3.
Press the spacebar 3 times.
Notice ,that only the file name is shifted but none of the other columns to the right are effected.
Lab 2
Page 23
IBM Software
Press the Backspace 3 times. Once again the filename is shifted but no other columns are effected.
Next let’s see the results of splitLine
__5.
Place the cursor somewhere on a line and press Enter.
__4.
You will actually notice that splitLine doesn't work, in order to make this behavior work you will
need to turn off the Enter key preferences for RPGIV. To do this go back to the preferences page.
__6.
Expand Remote Systems -->Remote Systems LPEX Editor -->IBMi Parsers
__7.
Click on RPGIV to display the preference dialog for this language
__8.
Unselect the Repeat Previous Specification check box
__9.
Click the Ok button
Now test the splitLine preference again in the editor.
Position your cursor on line 32, in the middle of the comment text.
Press the Enter key.
__10.
__11.
Page 24
Rational Developer for Power Systems Software
IBM Software
The text to the right of the cursor is moved to the next line.
You have changed some of the default editor settings and seen the results of the changes.
Feel free to change the preferences to your preferred settings.
2.3.6
Using SEU commands in the LPEX editor
You can configure the LPEX Editor to adopt the keyboard and command personalities of many
popular editors. Most editor profiles differ only in the keys and commands used to perform various
editor tasks. Some base editor profiles, listed below, also add prefix information and a command area
at the start of each line:
• ispf
• seu
• xedit
The editor recognizes prefix commands used by these editor profiles. Depending on which profile you
are using, you can enter SEU, XEDIT, or ISPF commands when the prefix area is active.
If you are an SEU expert you will appreciate the ability to use SEU commands.
To enter SEU commands:
__1.
Move the cursor into the gray sequence number area to the left of the edit area
__2.
On any sequence number type dd.
__3.
Go down a few lines and type dd again and press Enter.
Lab 2
Page 25
IBM Software
Notice that the lines have been deleted.
__4.
__5.
__6.
Now type i5 in the sequence number area.
Make sure the cursor is within the sequence number area.
Press Enter.
Five new lines are inserted.
You have learned how to use SEU commands in the editor.
2.3.7
Requesting undo and redo operations
The editor records each set of changes you make to a file in the Editor window. The number of
changes made since the last file save is displayed on the status line. If you want to undo a set of
changes made to a file you use the Undo operation. You can also cancel the effects of an Undo
operation by using the Redo operation.
Now you are going to undo some of the changes you just made to the file. Then you will cancel the
Undo operation by using the Redo operation. Finally you will reload the source so that it is back to its
original content.
__1.
Click Edit > Undo from the workbench menu. Notice that the 5 new lines disappear.
__2.
Page 26
Press Ctrl+Z to undo the last change.
Rational Developer for Power Systems Software
IBM Software
Notice that the deleted lines reappear.
__3.
Click Edit > Redo from the workbench menu.
Notice that the lines are deleted again.
At this point you will reload the source from the IBM i server to make sure that it is back in its original
form.
__4.
Click File > Close on the workbench menu.
Tip:
You can also click the X on the PAYROLL tab.
A Save Resource dialog opens asking if you want to save the latest changes.
__5.
Click No
__6.
Lab 2
In the workbench, in the Remote Systems view and open the PAYROLL member in the
QRPGLESRC file by double clicking on it.
Page 27
IBM Software
You have learned how to undo and redo changes that you made to a file.
2.3.8
Invoking language sensitive help
Inside the editor, there is cursor-sensitive language-reference help available.
This help is invaluable if you cannot remember the order of fields in an RPG specification or the
allowed values for a variable field. This help is available from the LPEX Editor window.
To receive language sensitive help, press F1 in an Editor window. If the cursor is on an operation
code, you receive help for that operation code; otherwise, you receive help for the current specification.
To access language sensitive help
__1.
Position the cursor over the MOVE operation code in line 112 of the ILE RPG source.
Tip:
To jump to a specific line, type the number into the editor’s command entry line and press
Enter.
__2.
Page 28
Press F1.
Rational Developer for Power Systems Software
IBM Software
Language-sensitive help for the MOVE operation code appears in a Help window.
Text marked in blue in the Help window contains the link to detailed information about the topic in blue.
Click the link Date Data Type.
The Help page for Date Data Type is displayed
__3.
Lab 2
Page 29
IBM Software
__4.
__5.
__6.
Explore the Help window to see what else is available.
Close the Help window.
Select Help > Help Contents on the workbench menu
You can see the help that is available in the product.
To locate the language reference information for ILE RPG:
In the left pane of the Help window:
__7.
Expand Reference.
__8.
Expand Rational Developer for Power Systems Software
__9.
Expand Language reference.
__10. Expand IBM i programming information.
__11. Expand High-level languages.
__12. Expand ILE RPG.
__13. Expand Language Reference.
Page 30
Rational Developer for Power Systems Software
IBM Software
Having the latest version of the manuals at your fingertips will make it easier to find programming
information. There is also the option to search the help by specifying a search string. By default, the
complete help will be searched.
You can limit the search scope to specific documents to avoid getting search results from all the
documentation in the workbench
__14.
__15.
__16.
Lab 2
Click Search scope. The Select Search Scope dialog opens
Select Search only the following topics radio button
Click New.
Page 31
IBM Software
The New Search List dialog opens.
__17.
__18.
__19.
In the List name field, type MyList .
Select the Reference check box to limit the search to this help area.
Click the OK button on the New Search List dialog.
The Select Search Scope dialog reopens with MyList selected in the topic list.
Page 32
Rational Developer for Power Systems Software
IBM Software
__12.
__13.
Click OK on the Select Search Scope dialog.
In the Search field, type chain for example
Searching requires a help index and it takes a bit of time to create the index in your workspace. If you
don't want to wait for the index to be build, skip this step.
__14. Click GO.
The search results from the selected topic area display.
Lab 2
Page 33
IBM Software
You have accessed language sensitive help
2.3.9
Prompting language specifications
Now back to editing the source code, let’s look at prompting and more.
Instead of entering or changing code directly in the Editor window, you can use prompts. When you
request a prompt for a specification line, a window appears where you can enter or change that line
using entry fields.
To access prompts:
__1.
Return to the workbench.
__2.
In the Editor window move your cursor to the D-spec on line 33.
__3.
Press F4 (You can also click Source from the workbench menu and then click Prompt.)
Page 34
Rational Developer for Power Systems Software
IBM Software
You see the Source Prompter at the bottom of the workbench. The Source Prompter shows the
specification line broken down into its individual fields
.
Lab 2
Page 35
IBM Software
On the Source Prompter toolbar you can use the three push buttons to:
• Disable source prompt view,
• Disable syntax checking,
• Change to insert mode.
To display context sensitive help for any field in the Source Prompter:
Tab to the Keywords field.
Press F1 to see help for this field.
The Help window with help for the D- spec keywords opens. If it doesn’t appear automatically, you
might have to bring it to the foreground by clicking on its icon on the Windows taskbar.
__4.
__5.
You will see words in the help that appear in a different color than the regular text. These are help links,
and they show that there is additional help available on that word or phrase.
Click on any link to see specific help for that item.
Close the Help window.
Prompting is easy, let’s look at more good stuff.
__6.
__7.
2.3.10 Indenting source
When editing ILE RPG source, it can be difficult to determine the beginning and ending of constructs.
The RPG Indentation view allows you to see your source with constructs in an indented mode.
To indent source:
__1.
Click on the editor tab for the PAYROLL member to make it active
__2.
Click Source > Show Indentation on the workbench menu.
Page 36
Rational Developer for Power Systems Software
IBM Software
You see the RPG Indentation view below the edit dialog
You can display the RPG Indentation view as a full view
__3.
__4.
Double-click RPG Indentation tab
Go to line 150.
The line shown on the status bar is the cursor position. In the Indent view you see some nested
conditions with indented lines. As you will notice this helps to recognize the beginning and ending of
these conditions.
Lab 2
Page 37
IBM Software
Tip:
The RPG Indentation view is Browse mode only and cannot be edited.
Click the X in the top right corner of the Indentation view to close it.
Double-click any of the tabs to show the editor again.
You have used the RPG Indentation view to see the beginning and ending of constructs.
__5.
__6.
2.3.11 Finding and replacing text
The LPEX Editor also has a powerful find and replace text feature. You use the Find and Replace
window to search for an item. You can search for a word, a partial word, or a sequence of such. You
can also enter a pattern you want to match, provided that the pattern follows the rules of regular
expression. You can replace the found search item. If the entered text or pattern is found, the cursor
moves to either the next or previous occurrence of the search item, according to your chosen search
direction, and replaces the found text according to your selections.
To find and replace text:
__1.
Click anywhere in the editor to give it focus then press Ctrl+Home to go to the top of the
file.
Tip:
When you press Ctrl+Home to go to the top of a file or Ctrl+End to go to the bottom of a file, a
quick mark is set at your cursor position. This allows you to return to that line by pressing Alt+Q.
Ctrl+Q will set a quick mark.
__2.
Click Edit > Find/Replace from the workbench menu or press Ctrl+F.
The Find/Replace window opens at the bottom of the Editor window
Page 38
Rational Developer for Power Systems Software
IBM Software
At the bottom of this window, you will notice that you have some options to select from, for example,
search only in certain columns. You want to find the first occurrence of BEGSR.
In the Find field, enter BEGSR to find the start of a subroutine.
Make sure the Replace field is blank.
You would use this field for text replacement.
__3.
__4.
The Editor moves the active line to line 52, which contains the first BEGSR phrase in the file.
__5.
Lab 2
Click Next to go to the next location of BEGSR in the file
Page 39
IBM Software
__6.
Click in the Editor window to close the Find/Replace window.
You have searched for a string in your source using the Find/Replace window.
Next let's do some flitering
Page 40
Rational Developer for Power Systems Software
IBM Software
2.3.12 Filtering lines by string
The editor allows you to filter or subset your source so that you see only lines containing a given string.
Filtering lines makes it quick and easy to find lines without having to scroll through your source.
To filter source by string:
__1.
Double-click the variable EMPAPL in the Editor window, to select it.
__2.
Select Edit > Selected > Filter Selection from the workbench menu.
A compressed source view is shown, it only displays the lines that contain the string EMPAPL. Plus signs
in front of the line numbers allow to expand the source lines following the line containing the string
Lab 2
Page 41
IBM Software
The number of occurrences is shown at the botton of the editor view.
To expand the section of source after line 79 up to the next occurrence of the string:
__2.
Expand line 79.
Page 42
Rational Developer for Power Systems Software
IBM Software
This expands the section up to the next instance of EMPAPL.
Now you want to show the entire source again:
__3.
Click Edit > Show all from the workbench menu, or right click in the editor and select
Show all from the context menu, or press Ctrl+W.
The entire source member is displayed again.
You have filtered your source so that you see only lines containing a given string.
2.3.13 Filtering lines by type
To help you navigate quickly through your ILE RPG source the editor allows you to filter lines based
on the line type. Imagine you want to see where all the subroutines are defined in your source.
To filter lines by type:
__1.
Right-click in the Editor view for the PAYROLL member.
__2.
Click Filter view > Subroutines in the context menu.
Lab 2
Page 43
IBM Software
All source lines containing the BEGSR or ENDSR operation codes are displayed allowing you to move
quickly and easily to the desired subroutine in your file.
__3.
Page 44
Expand the subroutine declaration for CHGCDE (line 444). to show all lines in this subroutine.
Rational Developer for Power Systems Software
IBM Software
Now you could work with the source inside this subroutine.
Right-click in the Editor window and click Show all on the context menu to show all lines in the
edit view.
__4.
You have filtered lines in your source by line type.
2.3.14 Searching multiple files
Lab 2
Page 45
IBM Software
If you would like to search through the members in a source physical file or through the files in a
local directory, you can use the Search tool. The Multi-File Search utility allows you to search for a
particular string of text in many members on the host. This function can also be used on local files.
You need to change the current library for your RSE job to your development library so the results of
the SEARCH are placed in this library and not into the default current library QGPL.
To change the current library:
__1.
In the RSE view, right click on the Library List filter
__2.
Click on the Change current library action
In the Change Current Library dialog
__3.
Key in the library name RSELABxx
__4.
Click the OK button
You are done setting the current library, RSELABxx now shows a decorator (a little star) that indicates
this is the current library.
To search multiple files:
Page 46
Rational Developer for Power Systems Software
IBM Software
__5.
Click Search --> IBM i on the workbench menu.
The Search window opens
__6.
In the Search string field, type ENHRS.
The Connection field should contain your IBM i server name, otherwise enter it there.
__7.
Under Target in the Library field, type RSELABxx.
__8.
Under Target in the File field, type QDDSSRC to search all members in this source physical file.
__9.
Under Target in the Member field, select *ALL.
__10. Click Search.
The Multi-File Search window lists all the lines in all the files that reference ENHRS.
__11.
Double-click the last line in the list at
A
Lab 2
ENHRS 3 1
TEXT(’EMPLOYEE NORMAL WEEK HOURS’)
Page 47
IBM Software
The member REFMST is automatically loaded into the editor and the cursor is placed on the correct line.
__12.
Click the X in the REFMST tab to close the REFMST file.
You have searched through members in a source physical file.
2.3.15 Comparing files using the Remote Systems Explorer
If your product undergoes many changes, you will find the Compare utility useful. It allows you to
compare different versions of a program and find the differences.
Using the compare utility in the workbench you can view the differences between two files by
comparing them. You can compare different files, and you can compare versions in the workbench
with versions in the repository or with the local edit history.
After a comparison is carried out, the Compare Editor opens in the editor area. In the compare Editor,
you can browse through all the differences and copy highlighted differences between the compared
resources. You can save changes to resources that are made in the comparison editor.
Tip:
Make sure all lines show in the source before starting the Compare tool.
First let’s setup some preferences to get the best results from the Compare tool
__13. Click Window > Preferences from the workbench menu. The Preferences window opens.
Page 48
Rational Developer for Power Systems Software
IBM Software
__14.
__15.
__16.
In the left pane of the Preferences window, expand LPEX Editor.
Click Compare under LPEX Editor. In the right pane of the Preferences window make sure that
the Ignore all blanks check box is selected.
Click OK in the Preferences window.
Back in the Editor window of the PAYROLL member
__17. Double-click the PAYROLL tab to show the edit view in full screen mode.
__18. Click Edit > Compare to file on the workbench menu.
Lab 2
Page 49
IBM Software
The Compare window opens.
__19. Expand your connection.
__20. Expand *LIBL.
__21. Expand RSELABxx.
__22. Expand QRPGLESRC.
__23. Select member PAYROLLG.
__24. Click OK.
Page 50
Rational Developer for Power Systems Software
IBM Software
.
The editor now will show the differences of these two members PAYROLL and PAYROLLG
You can move from mismatch to mismatch by right-clicking the source and selecting Compare -> Next
Mismatch, or by using Ctrl+Shift+N.
Mismatches in PAYROLL and PAYROLLG are highlighted in different colors so that you know where
the mismatched lines are in each file.
Click Ctrl+Shift+N to find the next mismatch.
Next, end the compare session
__26. Right-click the source and select Compare > Clear.
__25.
Lab 2
Page 51
IBM Software
You have compared different versions of the program and found the differences.
There is a second compare tool that provides a different user interfaces it is the built in Eclipse compare
tool. Let' s tgive that a try, and you can then decide which of the two tools you prefer and use in your day
to day work.
This tool is not based on the editor so you actually invoke it in the RSE view.
__27. Right click on the PAYROLL member in source file QRPGLESRC in library RSELABxx
To select a second member to compare with
__28. Press the CTRL key then select member PAYROLLG in the same source file.
__29. Click the Compare with --> Each other actions on the content menu
Page 52
Rational Developer for Power Systems Software
IBM Software
The compare editor displays,it is best to maximize this view:
__30. Double-click on the Compare editor tab.
You see both members side by side, the differences are marked by markers in the right side bar. The tool
buttons allow you to position to next or previous line with a difference.
The editor is positioned at the first difference to position it to the next:
__31. Click on the next difference button.
It now show the next line with differences
Lab 2
Page 53
IBM Software
To close the Compare Editor.
__32. Click the X on the Editor tab
Let's have a look at the syntax checker
2.3.16 Checking syntax
One of the powerful features that the LPEX Editor shares with SEU is its ability to syntax check your
source. Syntax checking can be done either when the cursor leaves each line of source or all at once
on either the currently selected source or on the entire source member.
Now you will create a syntax error and watch for the prompt to correct it. To syntax check the file:
__1.
In the PAYROLL Editor window move the cursor to line 211by typing the line number in the
sequence number column, or scrolling down.
Append an X to the EXSR op-code to make it EXSRX.
Move the cursor off of the line.
An error message appears to draw attention to the error.
__2.
__3.
Page 54
Rational Developer for Power Systems Software
IBM Software
__4.
__5.
Move the cursor onto the pink error message.
Press F1.
This opens a window with second level help for the error.
__6.
Close the Help window.
__7.
Change EXSRX to EXSR to correct the error. (Similarly, you can use Edit > Undo to correct this).
Lab 2
Page 55
IBM Software
__8.
Move the cursor off the line you just fixed.
The error message is automatically removed from the editor.
Tip:
You can toggle automatic syntax checking. Click Window > Preferences from the workbench
menu and then expand Remote Systems > Remote Systems LPEX Editor > IBM i Parsers.
Now, select the language you want to change the settings for in the left pane of the
Preferences window, select or deselect the Automatic syntax checking check box and then
click OK
Tip:
You can syntax check the whole source member currently in the editor by clicking Source >
Syntax Check All.
Page 56
Rational Developer for Power Systems Software
IBM Software
Congratulations!
You have successfully completed the introduction to editing IBM i source members using the LPEX
editor.
Feel free to exploit the other Labs 03 -08, that are available, the next logical lab to work through is the
'Verify/compile an RPG source member and work with the error list', Lab03.
More information and material can be found at our RPG CAFE
http://www-949.ibm.com/software/rational/cafe/community/rpg
Look for the RDp hub
Enjoy working with Rational Developer for Power
Systems Software!
Lab 2
Page 57
IBM Software
Notices
© Copyright IBM Corporation 1992, 2010 All rights reserved.
U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule
Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. IBM may not offer the products,
services, or features discussed in this documentation in other countries. Consult your local IBM
representative for information on the products and services currently available in your area. Any reference
to an IBM product, program, or service is not intended to state or imply that only that IBM product, program,
or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM
intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify
the operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter described in this
documentation. The furnishing of this documentation does not give you any license to these patents. You can
send license inquiries, in writing, to:
IBM Director of Licensing IBM
Corporation
North Castle Drive
Armonk, NY 10504-1785 U.S.A.
For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:
IBM World Trade Asia Corporation Licensing
2-31 Roppongi 3-chome, Minato-ku Tokyo
106, Japan
The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF NONINFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not
allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not
apply to you.
″
″
This information could include technical inaccuracies or typographical errors. Changes are periodically made
to the information herein; these changes will be incorporated in new editions of the publication. IBM may
make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any
time without notice.
Any references in this information to non-IBM Web sites are provided for convenience only and do not in any
manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the
materials for this IBM product and use of those Web sites is at your own risk.
Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange
of information between independently created programs and other programs (including this one) and (ii) the
mutual use of the information which has been exchanged, should contact:
Page 58
Rational Developer for Power Systems Software
IBM Software
Intellectual Property Dept. for WebS phere Software IBM
Corporation
3600 Steeles Ave. East
Markham, Ontario
Canada L3R 9Z7
Such information may be available, subject to appropriate terms and conditions, including in some cases, payment
of a fee.
The licensed program described in this documentation and all licensed material available for it are provided
by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any
equivalent agreement between us.
Any performance data contained herein was determined in a controlled environment. Therefore, the results
obtained in other operating environments may vary significantly. Some measurements may have been made on
development-level systems and there is no guarantee that these measurements will be the same on generally
available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results
may vary. Users of this document should verify the applicable data for their specific environment.
Information concerning non-IBM products was obtained from the suppliers of those products, their published
announcements or other publicly available sources. IBM has not tested those products and cannot confirm the
accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the
capabilities of non-IBM products should be addressed to the suppliers of those products.
All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice,
and represent goals and objectives only.
Copyright license
This information contains sample application programs in source language, which illustrates programming
techniques on various operating platforms. You may copy, modify, and distribute these sample programs in
any form without payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the operating platform for
which the sample programs are written. These examples have not been thoroughly tested under all conditions.
IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.
Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as
follows:
© (your company name) (year). Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 1992, 2009. All rights reserved
Trademarks and service marks
The following terms are trademarks or registered trademarks of International Business Machines
Corporation in the United States, other countries, or both.
•
•
•
•
•
i5/OS
IBM
OS/400
Rational
WebSphere
Microsoft, Windows, and the Windows logo are trademarks of Microsoft Corporation in the United States,
other countries, or both.
Lab 2
Page 59
IBM Software
Other company, product or service names may be trademarks or service marks of others.
Page 60
Rational Developer for Power Systems Software
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement