ION Audacity Software Guide

ION Audacity Software Guide
AUDACITY
SOFTWARE GUIDE
TABLE OF CONTENTS
GENERAL SOFTWARE NOTES ...................................................................................... 2
AUDACITY SOFTWARE INSTALLATION....................................................................... 3
CONFIGURING WINDOWS VISTA TO WORK WITH THE USB TURNTABLE ............. 4
CONFIGURING WINDOWS XP TO WORK WITH THE USB TURNTABLE ................... 6
AUDACITY CONFIGURATION ON PC ............................................................................ 8
CONFIGURING AUDACITY FOR MAC OS 10.4 AND ABOVE .................................... 10
RECORDING INTO THE COMPUTER ........................................................................... 14
ADJUSTING YOUR AUDIO LEVEL (optional).............................................................. 15
CLEANING YOUR AUDIO (optional) ............................................................................ 16
HIGH-SPEED RECORDING OF YOUR VINYL (optional) ............................................ 19
DIVIDING YOUR ALBUM INTO TRACKS ..................................................................... 20
EXPORTING TRACKS TO SEPARATE FILES ............................................................. 23
LISTENING AND EXPORTING TO WAV/MP3 .............................................................. 24
RECORDING 78RPM RECORDS .................................................................................. 24
TROUBLESHOOTING .................................................................................................... 25
1
GENERAL SOFTWARE NOTES
Your USB turntable is compatible with any recording software that
supports USB Audio devices. We have included Audacity, however you
may prefer to use one of a variety of the 3rd party software packages
that are also available.
Audacity is free software, distributed under the General Public License
(GPL). More information, as well as open source code, can be found on
the included CD or on the web at http://audacity.sourceforge.net.
Audacity works on both Windows (98 and greater) as well as Mac OS (X
and 9.2+). Software for Linux can be found on the Audacity website.
Go to http://audacity.sourceforge.net/help/tutorials for additional
tutorials.
The website also has information for separate add-ons to Audacity to
enhance performance and features.
2
AUDACITY SOFTWARE INSTALLATION
Before Starting the Software
Make sure that your USB turntable is plugged into the computer with the supplied USB cable,
and both the computer and the turntable are plugged in and on. Refer to the included USB
turntable quick start instruction manual before proceeding with software installation.
REMOVE THE CLEAR PLASTIC CARTRIDGE (NEEDLE) COVER
For your first recording, we recommend that you test your settings on
short section (a minute or less) of recorded audio so you can become familiar with the the
process before recording a full LP.
To Install Software (PC)
1.
2.
3.
4.
5.
6.
Plug your turntable into an AC power outlet and use the included USB cable to
connect the USB port on your turntable to the USB port on your computer.
Turn your computer on if it is not on already. Allow it to boot fully.
Turn on the turntable by pressing the power button near the base of the
tonearm.
Your computer might display a message saying that it has detected a new device,
and that it is available to use. Depending on your system, this message may or
may not appear. This is normal.
Insert the CD that came with your USB turntable into your computer’s CD drive.
A window will pop up automatically. Click on the [INSTALL] icon next to
“Audacity”.
To Install Software (MAC)
1.
2.
3.
4.
5.
6.
7.
Plug your turntable into an AC power outlet and use the included USB cable to
connect the USB port on your turntable to the USB port on your computer.
Turn your computer on if it is not on already. Allow it to boot fully.
Insert the included CD into your computer’s CD drive.
Open the CD icon on the desktop.
Drag the installation folder for Audacity to your hard drive. We recommend that
you move the folder to your Applications folder.
A window will come up which shows the files copying.
Once the files are done copying, EJECT the CD.
SELECTING YOUR LANGUAGE
Before you begin using the software, note
that Audacity’s controls and menus can be
displayed in a variety of different languages.
Go to Edit | Preferences and click on the
Interface tab. Under the Language pulldown tab, you can select your preferred
language.
3
CONFIGURING MICROSOFT WINDOWS VISTA TO
WORK WITH THE USB TURNTABLE
1.
Close all programs that
are open on your
computer.
2.
On the bottom left of
your screen, select the
Start menu.
Select Settings then
Control Panel.
3.
4.
5.
6.
7.
In the window that
opens, find and doubleclick the Sound control
panel. (If you don’t see
a choice called “Sound”,
choose the Switch to
Classic View option in
the panel on the left of
the window, and the
Sound Control Panel
should become available
on the right.)
Select the Recording
tab at the top of the
Sound Control Panel.
Under the Recording
tab, choose
Microphone - USB
Audio Codec as the
default device. The USB
Audio Codec represents
your Turntable.
Click on the Set Default
button to confirm your
choice.
4
8.
9.
Now select the Playback tab at the top of the Sound control
panel.
Under the Playback
tab, choose the
device that you
would like your
computer’s audio to
come out of.
Your computer’s
audio outputs may
appear as:
Speakers – High
Definition Audio
Device
or
Headphones –
High Definition
Audio Device
or both, depending
on the hardware
installed in your
computer.
Click on the device that best matches your desired audio setup
and click Set Default to confirm your selection.
Note: Do NOT choose “Speakers - USB Audio Codec” as your
playback device. USB Audio Codec represents your turntable,
and can only be used as recording input, not a playback output.
10.
11.
12.
13.
Click Set Default to confirm your choice.
Click Apply if possible, then click OK to close the Control Panel.
Click Apply (if possible), then click OK.
Make sure that your computer’s speakers (if not built-in) are
plugged into your computer’s audio output and turned on so you
can hear your recording. If your computer has a headphone
output, you can use headphones in-place of speakers.
5
CONFIGURING MICROSOFT WINDOWS XP
TO WORK WITH THE USB TURNTABLE
1.
2.
3.
4.
5.
6.
7.
Close all programs that are
open on your computer.
On the bottom left of your
screen, select the Start
menu.
Select Settings then
Control Panel.
In the window that opens,
find and double-click the
Sounds and Audio
Devices control panel. (If
you don’t see a choice
called Sounds and Audio
Devices, choose the Switch
to Classic View option in the
panel on the left of the
window, and the Sounds
and Audio Devices should
become available on the
right.
Select the Voice tab at the
top of the Sounds and Audio
Devices control panel.
Under Voice Playback,
choose your internal sound
card as the default device.
This varies by computer but
should not be set to “USB
Audio Codec, Modem, or
Microsoft Sound Mapper.”
Under Voice Recording,
select USB Audio Codec for
your default device – this is
the USB truntable.
6
8.
9.
10.
11.
12.
13.
Select the Audio tab at the
top of the Sounds and Audio
Devices control panel.
Under Sound Playback,
choose your internal sound
card as the default device.
This varies by computer but
should not be set to “USB
Audio Codec, Modem, or
Microsoft Sound Mapper.”
Under Sound Recording,
select USB Audio Codec
for your default device –
this is the USB turntable.
Check the box titled Use
only default devices.
Click Apply (if possible), then click OK.
Make sure that your computer’s speakers (if not built-in) are
plugged into your computer’s audio output and turned on so you
can hear your recording. If your computer has a headphone
output, you can use headphones in-place of speakers.
7
AUDACITY CONFIGURATION ON PC
1.
2.
3.
Launch Audacity: Click on the Start menu on the bottom left of
your screen. Select All Programs, then Audacity.
In Audacity, click on the Edit menu at the top of the screen.
Select Preferences from the Edit menu.
Figure 1: Select Preferences
4.
5.
The Audacity Preferences window will come up (Figure 2).
Choose the Audio I/O tab from the top of the Preferences
screen.
Set your Playback Device to your internal sound card. Since
different computers have different internal sound cards, your
selection may be different from the image below (Figure 2). The
correct selection, however, will NOT be USB Audio Codec,
Microsoft Sound Mapper or Modem.
Set your Recording Device to USB Audio Codec. This
represents your turntable.
Note: The USB turntable may show up with a different name in
the Preferences window. This may depend on your computer
model and operating system. 99% of the time it will contain
“USB” in the Name.
6.
7.
Set Channels to 2 (Stereo).
Check the box labeled Software Playthrough.
8
Figure 2: Select USB Audio Device from Preferences
8.
9.
10.
Under the Quality tab, set the Default Sample Format to 16bit.
Select OK to save your settings and close the Preferences
window.
At the top of the main Audacity window, to the right of the play
control buttons, you will see the input and output level meters
(labeled L and R). Under the output level meter, is an icon that
looks like a microphone. Next to the microphone is a black
arrow that points down. Click this arrow and select Monitor
Input. (If you don't see the input and output level meters, open
your Preferences again as described above, select the Interface
tab, and make sure that Enable Mixer Toolbar is checked.)
You should be all ready to record.
These settings will be saved when you exit. However, you will need to
select Monitor Input from the input meter’s drop-down menu each
time you launch Audacity.
9
CONFIGURING AUDACITY FOR MAC OS
10.4 AND ABOVE
1.
2.
3.
4.
5.
6.
7.
bit.
With the Audacity program open, click on the Audacity menu at
the top of the screen.
Select Preferences from the Audacity menu.
Under the Audio I/O tab, set your Playback Device to BuiltIn Audio.
Under the Audio I/O tab, set your Recording Device to USB
Audio Codec.
Under the Audio I/O tab, set your Channels to 2 (Stereo).
Check the box labeled Software Playthrough.
Under the Quality Tab, set the Default Sample Format to 16-
10
8.
9.
Select OK to save your settings and close the Preferences
window.
At the top of the main Audacity window, to the right of the play
control buttons, you will see the input and output level meters
(labeled L and R). Under the output level meter, is an icon that
looks like a microphone. Next to the microphone is a black
arrow that points down. Click this arrow and select Monitor
Input. (If you don't see the input and output level meters, open
your Preferences again as described above, select the Interface
tab and make sure that Enable Mixer Toolbar is checked.)
These settings will be saved when you exit. However, you will need to
select Monitor Input from the input meter’s drop-down menu each
time you launch Audacity.
11
Other Important Macintosh Settings:
We have set up Audacity’s separate playback and record preferences,
but your Mac also has its own audio playback and record settings. When
you first connect the turntable, the Macintosh will often select the “USB
Audio Codec” as the audio input and output for your entire system.
Since your turntable does not have speakers, audio will not be heard
from your other programs until you tell your Mac not to use the
turntable as an output device.
Here’s how to change these settings so that your internal sound card will
always be used for playback, whether or not your turntable is connected
via USB:
The Audio Midi Setup Utility:
1.
2.
3.
4.
Open your Finder.
Open your Applications folder.
In the Applications folder, open the Utilities folder.
In the Utilities folder, open the Audio MIDI Setup.
5.
In the Audio MIDI Setup under Audio Devices, set:
The Default Input to USB Audio Codec
The Default Output to Built-in Audio or Built-in Output
The System Output to Built-in Audio or Built-in Output
12
Now, programs other than Audacity will only use your internal sound
card for audio output.
13
RECORDING INTO THE COMPUTER
Note: We recommend that the first time you use the
software you test with a small (1min or less) section of
audio while recording. Once you feel comfortable with
recording, then record a full song or LP.
1.
2.
Press the Record Button
Start playback on the USB Turntable. You will see the waveform of
the audio on the screen as it is recording. You will hear the audio
coming from the output of your computer’s soundcard.
No Audio? - go back to the preference menu (Figure 2) and make
sure you have “Software Playthrough” selected and the speaker
volume up on your computer. See troubleshooting at the end of this
manual for more help.
3.
Play through the entire track/album you desire to record.
4.
5.
Press Stop
SAVE YOUR FILE NOW by clicking on File -> Save Project.
Select the destination and file name for the project and click Save.
You have completed the recording process. The file you just saved
to your computer is an Audacity Project file. This file can only be
opened by Audaity. The following sections will guide you through
some optional editing that may be performed, as well as how to
divide this Audacity Project into separate Wav files which may be
burned to CD or played in music programs such as iTunes and
Windows Media Player.
6.
Figure 3: Recording Sample
14
ADJUSTING YOUR AUDIO LEVEL (optional)
1.
Select your entire recording by selecting Edit, then Select…, then
click All. You can also use Ctrl+A on a PC or APPLE+A on a
Macintosh to quickly select all.
Figure 4: Select All
2.
Select the Effect menu and choose the desired effect.
a. There are various types of effects which are described
further in the software’s help section as well as on the web
(See Figure 5).
b. Normalize should be used to have the correct volume on
the recording. (See Figure 6)
Please note:
It is a good idea to place the needle on the record, while it is
stopped, before you begin the recording and press ‘Play’ on
the turntable after you begin recording. If you place the
needle down while the record is spinning and after you have
began recording, there might be audible clicks and pops.
These clicks on pops might not allow the Normalize effect to
bring the volume of the recording to the level that it should
be.
15
Figure 6: Normalize
Figure 5: Effect Drop Down List
CLEANING YOUR AUDIO (optional)
1.
2.
3.
4.
5.
6.
7.
Drag the cursor over a portion of the audio track which contains
noise. We recommend using the beginning or the end of a track
where there is no music and only vinyl noise. (See Figure 7)
Select Noise Removal from the Effect drop down menu to bring up
the Noise Removal window. (See Figure 8)
Click Get Noise Profile. The Noise Removal window will now close
automatically.
Select the entire track of audio you wish to remove noise from. If
you wish to clean up the entire recording use Select All under the
Edit Menu. (See Figure 4)
Repeat Step 2 to bring up the Noise Removal Window.
Adjust the amount of audio that you would like to filter by moving
the slider in the Noise Removal window. We recommend using the
minimum noise removal for optimum sound.
Note: you can preview the audio before removing the noise by
clicking on Previe’.
Click on Remove Noise.
16
Figure 7: Selecting Noise in Track
Figure 8: Noise Removal Window
17
Additional Editing Notes:
ƒ
ƒ
ƒ
ƒ
Audio levels may vary based on the cartridge (needle), tone arm
counter weight, vinyl, and computer set up. We recommend always
normalizing your audio.
Similar to word processing, you may delete unwanted audio by
dragging over the section, which will highlight, then pressing
Delete. This may include excessive hiss, silence before/after songs,
or skips/scratches.
You must select the noise profile before you can remove the noise
from a track. If you select actual audio for the noise profile, the
computer may remove all of your audio. See Step 1.
Once the Noise Profile is set, it will save the profile until you restart
the application. In other words, the software must learn what the
noise profile is only when you first start the software. You do not
need to get the noise profile for every recording once it is set up.
18
HIGH-SPEED RECORDING OF YOUR VINYL
(optional)
Using the USB turntable with Audacity software, you are able to quickly
record your 33 1/3 speed vinyl into the computer and use the software
to adjust the faster speed back to normal playback. This feature is
useful for recording multiple records. For example, you can record 10
minutes of audio in as little as 7 minutes when recording at 45RPM.
Saving three minutes isn’t a large saving for one record, but if you are
recording multiple LPs, you can record 4 hours of music in under 3
hours.
Instructions:
1.
2.
3.
4.
5.
Record your 33 1/3 RPM vinyl at 45RPM by pressing the 45RPM of
the turntable.
You will hear the audio recording at an unusual pitch due to its high
speed.
When you finish recording stop the recording.
Go to Edit and Select All (See Figure 4).
Go to Effect and then the Change Speed Menu.
Select from 45 to 33 1/3 and your vinyl will be adjusted to the
correct speed as shown in Figure 9.
Figure 9: Change Speed
19
DIVIDING YOUR ALBUM INTO TRACKS
Note: You must finish all cleaning and
editing, including removing unwanted
silence before/after songs, before
dividing your album into tracks.
1.
2.
Select the Fit Project in Window
Figure 10: Fit Project in
tool as shown in Figure 10.
Window
After zooming out to see all of the
tracks, you can see the separation
between tracks by the gaps as shown with 1,2,3 below (Figure 11).
The next steps show how to split and label these tracks and export
them to WAV (CD quality) format.
Figure 11: Identifying Separate Audio Tracks
There are two ways to split your recording into separate tracks:
automatically, and manually. If your record is in good condition, and
has a distinct silence between the songs, automatically splitting the
tracks may be faster and easier. If your record is in poor condition or
does not have silence separating the songs, manually splitting the album
will work better for you.
Automatically Dividing Your Album (Windows Only):
1.
2.
3.
Select your entire recording by selecting Edit, then Select…, then
click All. You can also use Ctrl+A on a PC or APPLE+A on a
Macintosh to quickly select all. (See Figure 4)
Select the Analyze menu from the top of the screen and choose
Silence Finder.
The Silence Finder will attempt to detect the silence between each
song in the recording. With most recordings, you only need to set
the Silence Level field in Silence Finder’s window. Type 15 into
the Silence Level field and hit OK (Figure 12).
20
Figure 12: Silence Finder
4.
Your recording will then be analyzed, and a Label Track will appear
underneath your recording. It will contain markers representing the
beginning of each new song. (Figure 13). When you export your
recording (see: Exporting Your Tracks To Separate Files), these markers
will be used to create separate audio files for each song on your album.
Figure 13: Track Labels
5.
6.
7.
If you notice that the markers placed by the Silence Finder do not
match up with the songs correctly, or that there were too few or too
many markers added, you may undo the operation and try again with
different settings. If your markers appear to be correct, proceed to the
Exporting Your Tracks To Separate Files Section below.
To undo, select the Edit menu from the top of the screen and choose
Undo.
Repeat steps 1-3 above, and try a different setting in the Silence Level
field. If there were too few markers added in your previous attempt, use
a lower number in the Silence Level Field, such as 10. If there were
too many markers added in your previous attempt, try a higher number
in the Silence Level Field, such as 20. Certain records and types of
music may not work well automatic track separation. If you cannot get
good results with the Silence Finder you may need to manually devide
your album into tracks (see below).
21
Manually Dividing Your Album:
1.
2.
3.
4.
5.
6.
7.
8.
Press the Skip to Start button
to move to the beginning of the
recording.
Select the Project menu and then select
Add Label At Selection. This will set
the starting point of the first track.
Type in the name of the first track, the
text will show at the label marker. (See
14)
Select the space between tracks (where
there is no audio) by clicking once.
(vertical circle below)
You will see a line where you clicked.
Then repeat Step 4: Add Label At
Selection.
Note: you can add or edit any track name
(circled).
Repeat this process for adding labels for
all tracks. You may need to zoom in to
Figure 12: Adding Track Label
select the tracks and track separation.
You may also want
to hear the part of
the track before
you add a label for
the track. Use the
space bar to easily
start and stop
playback.
Note: the label is
Figure 14: Track Separation and Labels
placed at the START of
the track. For example, in 15, TRACK 1 is labeled at the beginning of audio
recording. Track 2 is the label between the first and second track. You can
also edit track names after they have been exported from Audacity.
In this three track example, the final break up is shown in Figure 15:
Figure 15: Completed Track Names Example
Additional Notes:
There are many different ways to edit your file. Dividing your file into separate
tracks by adding labels is one way to accomplish this. You can always undo any
mistakes in editing. Make sure to save your file regularly.
22
EXPORTING TRACKS TO SEPARATE FILES
This section explains how to export your separated files to WAV format to
burn to a CD. You may also choose to convert to MP3 requiring 3rd party
software downloaded from the Internet. Refer to the software help section
for more information.
1.
2.
3.
Now that you have divided up your tracks into labels from the master
recording file, you are going to export the files into separate files.
Select the File menu and then select
Export Multiple… as shown in Figure
16.
The Export Multiple window will come up
(see Figure 17).
a.
Select WAV as the export format
and choose the Export location.
b.
Select the Export Location. This is
where you will save your files. You
may want to create a special folder
on your Desktop with the Album
Name to store the files.
c.
Select Using Label/Track Name
as shown. Note: You may want to
export using consecutive
numbering and change the names
later. In this case you can select
the other option, Numbering
consecutively.
d.
Click Export.
Figure 16: Export Multiple
Figure 17: Export Options Menu
23
LISTENING AND EXPORTING TO WAV/MP3
To listen to your digitized audio, you will need a third party application that can play
WAV files. You can also use any standard audio CD burning software to burn your WAV
files to an audio CD.
If you would like to save your vinyl as an MP3 file after you have recorded it using
Audacity, you will need to obtain and install the optional "LAME MP3 Encoder" plug-in.
Once a file is in MP3 format it can be placed on any MP3 compatible mobile digital
device.
To download the LAME MP3 Encoder plug-in, please visit www.ionaudio.com/ttusb_audacity.php. There, you may also find additional information
about the Audacity software, as well as Frequently Asked Questions.
Click on the link to the LAME MP3 Encoder plug-in to transfer the file to your
computer.
Note: It is advised that you save the downloaded .zip file to your desktop
temporarily. You must then extract and save the LAME MP3 Encoder plug-in onto
your computer in a location where you WILL NOT DELETE IT. Saving these
individual plug-in files to your desktop is NOT recommended!!!
•
•
Windows users:
1.
2.
3.
4.
Create a new folder in [My Documents] called Lame MP3 Plugin.
Find the downloaded .zip file and open it.
Select ALL of the contents and copy them to the Lame MP3 Plugin folder you just
created in [My Documents].
Now...delete the DOWNLOADED .zip file which is still on your desktop.
Mac users:
1.
2.
3.
4.
Create a new folder in your [Home] directory called Lame MP3 Plugin.
Find the downloaded .sit or .zip file and double-click it...this will extract the
contents and create a new file on the desktop with the same name (it should show
without the .sit or .zip extension).
Copy or move this new file to the Lame MP3 Plugin folder you just created in your
[Home] directory.
Now...trash the DOWNLOADED .sit or .zip file which is still on your desktop.
In Audacity, when you attempt to Export As MP3… for the first time after
installing the LAME MP3 Encoder plug-in, you will be asked for the location of the
plug-in file. Browse to the Lame MP3 Plugin folder you copied the plug-in file to
and select the file. Subsequently, Audacity will remember the location of this file.
RECORDING 78RPM RECORDS
If you want to record a 78 RPM album, you can record it at 33.3 or 45 RPM and convert
it to 78 RPM in the Audacity software! After you have recorded the album, open the
Edit menu then click Select then click All. Next, open the Effect menu and choose
Change Speed. Then select the speed that you recorded at (33 or 45), as well as the
speed you would like it to be (78). Then press OK.
24
TROUBLESHOOTING
Please contact Ion Audio or your retailer before returning
this product. See the Safety Guide for more information.
•
NO SOUND:
•
If you are not getting any sound into the software application, go back to the
preferences as shown above and make sure you have selected the USB input
for the recording device.
•
If you can not hear the music but you do see the music on the screen, open
your preferences (Figure 2) and make sure that your Playback Device is set
to your internal computer soundcard.
•
Power Cycle: Close Audacity, turn off the turntable, unplug the USB Cable.
Then plug in the USB Cable, turn on the turntable, and reopen Audacity.
•
If you are not able to hear any audio
as you play the record, please click on
the microphone drop-down arrow and
select Monitor Input. This will
enable you to hear the audio from the
turntable, even if you have not
record-enabled the Audacity application.
Figure 19: Monitor Input
If you are not seeing the microphone slider, please go to the Preferences
menu in Audacity, click on the Interface tab and make sure that the Enable
Mixer Toolbar and Enable Meter Toolbar options are checked. If they are
not, please check them and then press OK.
•
Check the microphone slider to make sure
that it is at full volume, all the way to the
right as shown in Figure 20:
If you are not seeing the microphone slider,
please go to the Preferences menu in
Audacity, click on the Interface tab and
make sure that the Enable Mixer
Toolbar and Enable Meter Toolbar
options are checked. If they are
not, please check them and then
press OK.
25
Figure 20: Input Level
ƒ
POOR SOUND Quality:
•
If a recording sounds distorted or garbled during playback, you may
need to adjust the input volume from the turntable. Try moving the
Input Level slider in Audacity to the left to lower the input volume (See
Figure 17). You can use the Normalize effect, as described in the
Adjusting Your Audio Level section, to bring the volume back up to
normal after the recording.
•
Check your cartridge connection to make sure it is secured to the tone
arm. The cartridge must be connected to the tone arm whenever using
the turntable.
•
Make sure that your RCA plugs are plugged into a source or not touching
bare metal. If you are experiencing noise through the USB, you may
have interference from the RCA plugs. Ensure the USB cable is not
touching or near any other cables.
•
If you experience any odd sounds coming from the recording, try closing
all applications, restarting the computer, and only run Audacity while
recording.
•
If you are using the RCA plugs and your turntable is equipped with a
PHONO/LINE switch, make sure that you have the switch on the
bottom panel set to the correct position. Refer to the Quick Start guide
for more information.
•
Make sure that you have properly installed and calibrated the tone arm
of the turntable – please refer to the TONE ARM SETUP section of your
USB turntable’s Quick Start Guide.
For additional information, frequently asked
questions and troubleshooting, please visit
www.ion-audio.com/ttusb_audacity.php
For technical support, please contact
Ion-Audio at (401) 658-3743
Manual Version 5.3
26
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement