Cisco 3660 Router - PBX Interoperability: Ericsson MD110 V.BC11

Application Note
Cisco 3660 Router - PBX Interoperability: Ericsson MD110 v.
BC11 using BRI with H.323
Introduction
This note describes the interoperability of the Ericsson MD110 v.BC11 PBX and the Cisco 3660 using a 2BRI VIC.
Tandem trunking to an analog station connected to an FXS port on the router was also tested.
It is crucial that the dial peer configuration for the router pointing to the Ethernet H.323 link , include one of the G711 codec type.
Otherwise, the conferencing features will work in one direction only.
The network topology diagram shows the end-to-end interoperability.
Network Topology
Figure 1. Network Topology
Basic Call Setup
Signaling Type E1 BRI
PBX1: Ericsson MD110
Cisco 3660 Router
CISCO SYSTEMS
H.323 VoIP
PSTN
Limitations
Calling name is not supported.
Codec type (G711) must be specified for the dial peer pointing to the H323 link to support network
conferencing.
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 1 of 10
EDCS# 265712
System Components
Hardware Requirements
Cisco 3660 router with 2 BRI Interfaces
Ericsson MD110 v.BC11
Ericsson TLU79 R 70 BRI ISDN interface
Software Requirements
Cisco IOS Release 12.2 (10b)
PBX Software Release BC11
Features Not Supported
Calling name is not supported.
Call forwarding could not be made to work with the Net3 ISDN protocol on the Ericsson Switch.
Configuration
Configuring the Ericsson MD110 PBX
BRI trunks
ROUTE CATEGORY DATA
ROU SEL
TRM SERV
NODG DIST DISL TRAF
SIG
BCAP
40 211000000070001 5
0010000011 0
30
128 00151515 111110000031 001100
STATUS INFORMATION AT 15:30:19 29JAN03
ROU TRU
TYPE
TRAFFIC STATE/PTR
40
001-1
TL60
IDLE
#00D1
40
001-2
TL60
IDLE
#00D0
END
<RODAP:ROU=ALL;
ROUTE DATA
ROU
TYPE VARC
1
SL60 H'00001310
6
TL30
8
TL30 H'00000000
39
SL60 H'00000310
40
SL60 H'00000A14
41
SL60 H'00000A14
VARI
H'15440000
H'00000036
H'00002232
H'05400000
H'3A820000
H'3A820000
LINE STATE/PTR
FREE
#00C0
FREE
#00C1
VARO
H'06400010
H'00002016
H'00002016
H'06400000
H'46414000
H'46414000
ADD INFO
FILTER
NO
NO
NO
NO
NO
NO
END
ROUTE EQUIPMENT DATA
ROU
TRU
1
001-1
1
001-2
1
001-3
1
001-4
1
001-5
1
001-6
1
001-7
1
001-8
1
001-9
1
001-10
1
001-11
1
001-12
1
001-13
1
001-14
1
001-15
1
001-16
1
001-17
1
001-18
1
001-19
EQU
001-0-30-01
001-0-30-02
001-0-30-03
001-0-30-04
001-0-30-05
001-0-30-06
001-0-30-07
001-0-30-08
001-0-30-09
001-0-30-10
001-0-30-11
001-0-30-12
001-0-30-13
001-0-30-14
001-0-30-15
001-0-30-17
001-0-30-18
001-0-30-19
001-0-30-20
SQU
INDDAT
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
CNTRL
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 2 of 10
1
1
1
1
1
1
1
1
1
1
1
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
8
40
40
41
41
001-20
001-21
001-22
001-23
001-24
001-25
001-26
001-27
001-28
001-29
001-30
001-1
001-2
001-3
001-4
001-5
001-6
001-7
001-8
001-9
001-10
001-11
001-12
001-13
001-14
001-15
001-16
001-17
001-18
001-19
001-20
001-21
001-22
001-23
001-24
001-25
001-26
001-27
001-28
001-29
001-30
001-1
001-2
001-1
001-2
001-0-30-21
001-0-30-22
001-0-30-23
001-0-30-24
001-0-30-25
001-0-30-26
001-0-30-27
001-0-30-28
001-0-30-29
001-0-30-30
001-0-30-31
001-0-00-01
001-0-00-02
001-0-00-03
001-0-00-04
001-0-00-05
001-0-00-06
001-0-00-07
001-0-00-08
001-0-00-09
001-0-00-10
001-0-00-11
001-0-00-12
001-0-00-13
001-0-00-14
001-0-00-15
001-0-00-17
001-0-00-18
001-0-00-19
001-0-00-20
001-0-00-21
001-0-00-22
001-0-00-23
001-0-00-24
001-0-00-25
001-0-00-26
001-0-00-27
001-0-00-28
001-0-00-29
001-0-00-30
001-0-00-31
001-0-42-00
001-0-42-01
001-0-42-02
001-0-42-03
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
H'000000000000
END
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 3 of 10
Configuring the Cisco 3660 Router
The following sample output shows the router configuration for the interoperability with the PBX.
Router#sh running-config
Building configuration...
Current configuration : 4514 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3660-A
!
voice-card 4
!
voice-card 6
!
ip subnet-zero
!
no ip domain-lookup
!
isdn switch-type primary-qsig
call rsvp-sync
!
voice service voip
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 4/0
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-24
!
controller T1 4/1
framing esf
clock source internal
linecode b8zs
pri-group timeslots 1-24
!
controller E1 6/0
!
controller E1 6/1
!
interface FastEthernet0/0
ip address 10.1.1.205 255.255.255.0
ip accounting output-packets
duplex auto
speed auto
no cdp enable
!
interface Ethernet1/0
ip address 10.10.10.227 255.255.255.0
ip accounting output-packets
ip accounting precedence input
ip accounting precedence output
half-duplex
no cdp enable
!
interface Serial1/0
no ip address
shutdown
no fair-queue
no cdp enable
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 4 of 10
!
interface BRI5/0
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn tei-negotiation preserve
isdn layer1-emulate network
isdn incoming-voice voice
isdn skipsend-idverify
!
interface BRI5/1
no ip address
isdn switch-type basic-net3
isdn overlap-receiving
isdn protocol-emulate network
isdn tei-negotiation preserve
isdn layer1-emulate network
isdn incoming-voice voice
isdn skipsend-idverify
!
interface Group-Async1
physical-layer async
ip address negotiated
encapsulation ppp
dialer in-band
dialer string 2000X123456789012345678901234567
dialer-group 5
!
router eigrp 1
network 10.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
dialer-list 5 protocol ip permit
no cdp run
!
snmp-server manager
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 4/0:23
!
voice-port 4/1:23
!
voice-port 5/0/0
compand-type a-law
!
voice-port 5/0/1
compand-type a-law
!
dial-peer cor custom
!
dial-peer voice 7 voip
destination-pattern 3900
session target ipv4:10.1.1.204
!
dial-peer voice 4900 pots
destination-pattern 4900
port 2/0/0
forward-digits all
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 5 of 10
!
dial-peer voice 4901 pots
destination-pattern 4901
no digit-strip
port 2/0/1
forward-digits all
!
dial-peer voice 212 voip
destination-pattern 60.
session target ipv4:10.1.1.199
codec g711alaw
!
dial-peer voice 205 pots
destination-pattern 500.
direct-inward-dial
forward-digits all
!
dial-peer voice 305 voip
destination-pattern 500.
session target ipv4:10.1.1.227
!
dial-peer voice 110 voip
destination-pattern 4000
translate-outgoing called 10
session target ipv4:10.1.1.227
!
dial-peer voice 1002 pots
shutdown
destination-pattern 1025
direct-inward-dial
port 4/1:23
forward-digits all
!
dial-peer voice 111 voip
destination-pattern 4001
translate-outgoing called 10
session target ipv4:10.1.1.227
!
dial-peer voice 1001 pots
shutdown
destination-pattern 10.
direct-inward-dial
port 4/1:23
forward-digits all
!
dial-peer voice 605 pots
destination-pattern 1001
port 5/0/0
forward-digits all
!
dial-peer voice 606 pots
destination-pattern 1002
port 5/0/1
forward-digits all
!
dial-peer voice 610 voip
destination-pattern 200.
session target ipv4:10.10.10.10
codec g711ulaw
!
dial-peer voice 711 pots
destination-pattern 34....
port 5/0/0
forward-digits all
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
line aux 0
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 6 of 10
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
© 2003 Cisco Systems, Inc. All right reserved.
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 7 of 10
Important Information
THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE
WITHOUT NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE
ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL
RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.
IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR
INCIDENTAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT
OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.
Corporate Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 526-4100
European Headquarters
Cisco Systems International
BV
Haarlerbergpark
Haarlerbergweg 13-19
1101 CH Amsterdam
The Netherlands
www-europe.cisco.com
Tel: 31 0 20 357 1000
Fax: 31 0 20 357 1100
Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
www.cisco.com
Tel: 408 526-7660
Fax: 408 527-0883
Asia Pacific Headquarters
Cisco Systems, Inc.
Capital Tower
168 Robinson Road
#22-01 to #29-01
Singapore 068912
www.cisco.com
Tel: +65 317 7777
Fax: +65 317 7799
Cisco Systems has more than 200 offices in the following countries and regions. Addresses, phone numbers, and fax numbers are listed on
the Cisco Web site at www.cisco.com/go/offices.
Argentina • Australia • Austria • Belgium • Brazil • Bulgaria • Canada • Chile • China PRC • Colombia • Costa Rica • Croatia • Czech Republic
• Denmark • Dubai, UAE • Finland • France • Germany • Greece • Hong Kong SAR • Hungary • India • Indonesia • Ireland • Israel • Italy •
Japan • Korea • Luxembourg • Malaysia • Mexico• The Netherlands • New Zealand • Norway • Peru • Philippines • Poland • Portugal • Puerto
Rico • Romania • Russia • Saudi Arabia • Scotland • Singapore • Slovakia • Slovenia • South Africa • Spain • Sweden • Switzerland • Taiwan •
Thailand • Turkey Ukraine • United Kingdom • United States • Venezuela • Vietnam • Zimbabwe
Copyright 2003 Cisco Systems, Inc. All rights reserved. Cisco, Cisco Systems, and the Cisco Systems logo are registered trademarks or
trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and certain other countries. All other trademarks mentioned in this document
or Web site are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and
© 2003 Cisco Systems, Inc. All right reserved.
any other company. (0301R)
Printed in the USA
Important notices, privacy statements, and trademarks of Cisco Systems, Inc. can be found on cisco.com
Page 8 of 10
Download PDF