iGrafx Viewer Quick Reference Guide

Viewer
Quick Reference Guide
iGrafx® 2009 Viewer Quick Reference Guide
Table of Contents
iGrafx Viewer Quick Reference Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3
iGrafx Viewer Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
iGrafx Viewer Uses and Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
iGrafx Viewer Plus Uses and Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
iGrafx Viewer Quick Reference Guide
1
2
iGrafx Viewer Quick Reference Guide
iGrafx Viewer Quick Reference Guide
iGrafx Viewer simplifies sharing iGrafx files with users who do not have a licensed iGrafx file editor,
such as FlowCharter, Process, or Process for Six Sigma, installed.
iGrafx Viewer
The Viewer provides limited access to iGrafx documents (*.igx files) stored in a Process Central
repository or Microsoft Windows® file system.
In addition, if you install the optional Process Central client with iGrafx Viewer, you can:
•
Open and print Process Central repository items or iGrafx files shared outside of a repository
•
Add annotations to repository items
•
View file change history on repository items
•
Participate in review, annotation, and endorsement cycles for repository items
You can download the free iGrafx Viewer from the iGrafx web site or install iGrafx without a product
license key to use it in Viewer mode.
iGrafx Viewer Plus
iGrafx Viewer Plus extends the above Viewer functionality with ability to add, check-in, modify, and
check-out non-iGrafx (*.igx) files in a Process Central repository so that users without a licensed
iGrafx editor installed can manage non-iGrafx files in the repository. Contact iGrafx to purchase an
iGrafx Viewer Plus license.
Get Started
This quick reference guide helps you get started with some of the most common tasks in iGrafx
Viewer and iGrafx Viewer Plus.
3
iGrafx Viewer Interface
iGrafx Viewer has the same look and feel as iGrafx file editors such as FlowCharter, Process, and
Process for Six Sigma. Use shortcuts on the Standard toolbar and Toolbox toolbar to quickly open,
view, print, and navigate files inside and outside a Process Central repository.
Open
Print
Print Preview
Go Back
Go Forward
Standard toolbar
Toolbox toolbar
Explorer
Bar button
The Document Components window is shown on the left window pane on the screen above. Choose
Explorer Bar in the View menu and then click the Document Components tab to display components
or click the Explorer Bar button shown above.
When you are connected to a Process Central repository, the Process Central tab on the Explorer Bar
displays the Process Central repository window. To view the Process Central window, iGrafx Viewer
users must install the Process Central client. The Process Central client is automatically installed by
the iGrafx Viewer Plus installer.
4
iGrafx Viewer Quick Reference Guide
iGrafx Viewer Uses and Features
In iGrafx Viewer, you can open an iGrafx document, print or copy a document component such as a
diagram, descend (drill down into) shape hierarchy, and use the Document Components window for
various views of diagrams and diagram data.
By default, the iGrafx Viewer does not install the Process Central client. You may choose to install the
Process Central client as an option when you install the iGrafx Viewer, or modify your installation to
include it later. Your administrator can grant you the rights to work with repository items, including
rights to view and annotate files.
To view, copy, or print non-iGrafx files linked from an iGrafx diagram or added to a Process Central
repository, you must have the appropriate file editor or viewer installed. For example, to view or
modify a *.doc file, you would need to have Microsoft® Word installed on your system.
Following are some common file operations in iGrafx Viewer. For more information on working with
Process Central, see Process Central Procedures and Reference topics in the iGrafx Help system.
Open a File
1 Click the
button on the standard toolbar.
or
On the File menu, choose Open.
2 In the Open dialog box, navigate to the folder that contains the *.igx file you want to open.
3 Click the Open button.
iGrafx Viewer Uses and Features
5
Identify and Use the Link indicator
You can have two types of links on a shape: hyperlinks and hierarchy links.
Hyperlinks (known simply as “links”), link to external files, diagrams within the file, or documents
within a Process Central repository. By default, links display the link indicator like this:
Hierarchy links include information about the hierarchical relationship between diagrams. They are
always within the iGrafx file. By default, hierarchy links display a shadow on the shape:
The document author may choose a different symbol to represent either kind of link, or choose not to
display a link symbol.
6
iGrafx Viewer Quick Reference Guide
Drill Into Hierarchy
The easiest way to follow a link is to right-click the shape and select the link on the context (pop-up)
menu. When you follow a link and you have the Document Components window open, you can see
the focus change to the other process. For example:
1 Right-click the linked shape in Process1 and choose Process2
2 View the subprocess, Process2:
To return to the parent shape, click the
iGrafx Viewer Uses and Features
button on the standard toolbar.
7
Use the Document Components window
As discussed above, you can use the Document Components window to orient yourself to which
components are currently in view. You can also double-click components in the Document
Components window to view them in the diagram space to the right of the window.
Open a Process Central Repository
On the ProcessCentral menu, choose Open Repository and use the wizard to log in to a SQL-based or
Oracle-based server and open a specific repository.
Remember, Process Central client is an option when you install iGrafx Viewer. Your administrator can
grant you the rights to work with repository items, including rights to view and annotate files. For
more information, see Process Central Procedures and Reference topics in the iGrafx Help system.
View files in a Process Central Repository
The Process Central repository window comes into view when you click the Process Central tab on
the Explorer Bar:
Click the plus sign to view the structure and contents (the files and folders) of the repository.
View File Change History
You can view the change history of non-iGrafx files, iGrafx documents, and document components in
a repository.
8
iGrafx Viewer Quick Reference Guide
1 In the repository window, select a file, document, or component.
2 On the ProcessCentral menu, point to Item and choose History.
You can also right-click a repository item and choose History.
Get Multiple External Files for Offline Viewing
In the repository window, right-click a folder and choose Get Contents To and specify where to place a
copy of the folder and its contents.
Annotate an iGrafx File
Annotations on iGrafx diagrams document changes, updates, and messaging at a document or shape
level. You must be given Rights by your administrator to annotate documents or the annotation
commands will not be enabled.
1 In the repository window, right-click the document and choose View Current Version.
2 On the Insert menu, choose Annotation.
3 Click near a shape and enter text in the Annotation dialog box, and then click OK.
•
To attach the annotation to a shape, click-and-drag from the annotation into the shape
and back out again.
•
To detach an annotation from a shape, click-and-drag the annotation and, while still
holding down the left mouse button, press and release the Shift key.
Review, Approve, or Endorse a Document
You must be designated in a user group to participate in a review, approval, or endorsement cycle on
a nominated document. As part of a cycle, you may also annotate a document as described above.
iGrafx Viewer Uses and Features
9
To see what documents need your action, on the ProcessCentral menu, point to Cycles and choose
Review To-Do List, Approval To-Do List, or Endorsement To-Do List. Items appear in the query window
(below the repository window):
To review, approve, or endorse a nominated repository item, on the ProcessCentral menu, point to
Cycles and choose Review, Approval Vote, or Endorse.
10
iGrafx Viewer Quick Reference Guide
iGrafx Viewer Plus Uses and Features
The iGrafx Viewer Plus application is iGrafx Viewer with additional ability to add, check out, modify,
and check in non-iGrafx (*.igx) files to a Process Central repository. iGrafx Viewer Plus requires a
license key.
Process Central client installs by default with iGrafx Viewer Plus. When you are connected to a
repository, the Process Central repository window comes into view when you click the Process Central
tab on the Explorer Bar:
If the Explorer Bar is not visible, on the View menu, choose Explorer Bar.
Following are some common iGrafx Viewer Plus operations for managing files in a Process Central
repository. Your administrator can grant you the rights to work with repository items, including
rights to view and annotate files. For more information, see Process Central Procedures and Reference
topics in the iGrafx Help system.
Add a non-iGrafx File
1 In the Process Central repository window, right-click the repository and choose Add External File.
or
Select the repository in the repository window and, on the ProcessCentral menu, point to Add to
Repository and choose External File.
2 In the Add External File dialog box, navigate to the non-iGrafx file you want to add and select
the file.
3 If you want to check out the file for editing immediately after adding it so that no one else may
check it out, select the Check Out check box.
4 Click the Open button. The Open button will not work on iGrafx documents (.igx files). You
can only add non-iGrafx files with iGrafx Viewer Plus.
iGrafx Viewer Plus Uses and Features
11
Check Out a non-iGrafx File
1 In the Process Central repository window, select the non-iGrafx file you want to check out.
2 Right-click the file in the repository window and choose Check Out.
or
On the ProcessCentral menu, point to Item and choose Check Out.
Modify a non-iGrafx File
Non-iGrafx files open in their associated editor, such as an *.xls file in Microsoft® Excel®, when you
check them out of the repository. If the file is checked out but not open, double-click it in the Process
Central repository window.
You can only edit a repository item if it is checked out of the repository.
Check In a non-iGrafx File
Checking in a file creates a new version of it in the database and keeps older checked-in versions. You
do not need to check in the document until you are ready to share it with others. You can save the
document as you normally would and only check it back in when you are done with all of your edits.
1 In the Process Central repository window, select the non-iGrafx file you want to check in.
2 Right-click the non-iGrafx file in the repository window and choose Check In.
or
On the ProcessCentral menu, point to Item and choose Check In.
3 A comment may or may not be required by your administrator. We recommend a comment to
indicate or summarize what you changed.
Rename a non-iGrafx File
A non-iGrafx file must be checked in to the repository when you rename it.
1 In the Process Central repository window, select the non-iGrafx file you want to rename.
2 On the ProcessCentral menu, point to Item and choose Rename.
3 In the Rename dialog box, enter the new name and click OK. Note: if the document extension
(e.g. “.doc” for Microsoft Word documents) is shown, ensure that your new name has that
extension at the end. Otherwise your file may become unusable.
12
iGrafx Viewer Quick Reference Guide
Move a non-iGrafx File
A repository item must be checked in when you move it to another position in the repository window.
1 In the Process Central repository window, select the non-iGrafx file you want to move.
2 On the ProcessCentral menu, point to Item and choose Move.
3 In the Move dialog box, select a new location and click OK.
Delete a non-iGrafx File
Make sure you want to delete data before you confirm this action as it cannot be undone.
1 In the Process Central repository window, select the non-iGrafx file you want to remove from the
repository.
2 On the ProcessCentral menu, point to Item and choose Delete From Repository and confirm your
choice.
Create a Folder
In the Process Central repository window, right-click the repository and choose New Folder.
or
Select the repository and, on the ProcessCentral menu, point to Add to Repository and choose New Folder.
You can add folders within folders in the repository.
Rename a Folder
In the Process Central repository window, select the folder and, on the ProcessCentral menu, point to
Item and choose Rename.
iGrafx Viewer Plus Uses and Features
13
14
iGrafx Viewer Quick Reference Guide
Download PDF