Configuration Guide for Verizon LTE MPN/DMNR LTE Primary

Guide
Configuration Guide for Verizon LTE
MPN/DMNR LTE Primary Access
(LTE eHWIC)/GRWIC/819)
Mobile Router Configuration Guide
for
Primary Wireless Access
Revision 3.3
June 2013
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 1 of 13
Introduction
Verizon Wireless Dynamic Mobile Network Routing is a network-based, application-agnostic, mobile technology
capable of providing dynamic routing and support for mobile or stationary enterprise routers in primary wireless
access or automatic wireless backup configurations. It enables integration between wireless and wireline enterprise
services (4G Wireless WAN) by making use of the Mobile IPv4 Network Mobility (NEMO) protocol and without the
need for end to end overlay tunneling.
Dynamic Mobile Network Routing (DMNR) is part of the Verizon Wireless Mobile Private Network. In the current
release DMNR is compatible with the Cisco IOS Mobile IP Mobile Networks feature. Please note that not all Cisco
specific features are supported by the DMNR service. DMNR makes use of the Collocated-Care-of-Address
(CCOA) option and supports IP sub-net registration, routing and forwarding. DMNR does not support any other
Cisco Mobile IP Mobile Networks features such as "mobile networks multi-path" or "mobile networks multicast".
This configuration guide shows an example of using the Cisco Mobile IP Mobile Networks feature with Verizon
Wireless Dynamic Mobile Network Routing service to provide primary communications over Verizon Wireless Long
Term Evolution/evolved high-rate packet data (LTE/eHRPD) access and Mobile Private Networks (MPNs) between
an enterprise branch office and a data center connected to the Verizon Wireless Private IP Multiprotocol Label
Switching (MPLS)/VPN network.
There are two example configurations, for LTE eHWIC/GRWIC and C819(H)G-4G-V. There are important
differences regarding the C819(H)G-4G-V configuration. These are required for stable 819 LTE operation.
Notes
1.
Cisco Integrated Services Routers Generation 2 (ISR G2) and CGR routers with integrated 4G LTE cards are
supported (Cisco 819G-4G-V, 1900, 2900, 3900, and CGR2010 Series Integrated Services Routers).
2.
The minimum Cisco IOS software release depends on the LTE modem firmware level (seen via IOS command
“show cell 0/x/0 hardware” for LTE eHWIC/GRWIC, “show cell 0 hardware” for 819).
a. 819, 1900, 2900, 3900: For firmware 1.0.9.3 The IOS LTE Interim image is required (for access send an
email to interim_lte_image@cisco.com including your cisco.com user iD). For firmware release 3.5.10.6
(recommended), IOS 15.2(4)M3 or later is required. Firmware is available at:
http://software.cisco.com/download/release.html?i=!y&mdfid=284772061&softwareid=284285628&release=
3.5.10.6&os=
b. CGR-2010: For firmware 1.0.9.3, IOS 15.2(4)M2, and an immediate upgrade to firmware 3.5.10.6 is
required. Once at 3.5.10.6, IOS 15.3(1)T1 or later is required.
3.
No external LTE recovery script should be enabled with IOS 15.2(4)M3/15.3(1)T1 or later, nor with the IOS
LTE Interim Special Release. Remove the IOS EEM commands associated with the LTE recovery script.
4.
A Cisco IOS Software data license is required for use with MPN/DMNR. This can be ordered from Verizon
Enterprise Services or other authorized partner. A 60 day temporary data license can be immediately
generated using the following IOS config-modem command (requires an IOS reload to take effect): Example:
license boot module c1900 technology-package datak9. The keyword following "module" varies based on
the ISR/CGR model (e.g. c1900, c2900, c3900). The data license is already included with the 819.
5.
To connect a Network Mobility (NEMO) session to the Verizon Wireless Enterprise GateWay (EXGW), the
enterprise MPN must be provisioned for 4G, and the MPN associated with the subscriber mobile line.
(subscriber identity module [SIM]) used by the mobile router enhanced high-speed WAN interface card
(eHWIC or GRWIC) must have NEMO permission provisioned by Verizon Wireless.
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 2 of 13
The enterprise Access Point Name (APN) must be correctly provisioned in the Verizon Wireless network in
order to make a successful private network connection. In addition, the APN must be appropriately set on the
modem for LTE and eHRPD profiles, either automatically through Over-The-Air Device Management (OTADM)
or locally on the ISR. If OTA-DM does not update the APN, it can be set locally on the ISR (the APN must be
provided by a Verizon Wireless representative). The method of locally setting the APN depends on the IOS
version in use.
a. For 15.2(4)M3 or later on ISRs (15.3(T)1 or later on CGRs), an IOS enable-mode command is run one time.
example: cellular 0/0/0 lte profile create 1 acct.gw3.sampleAPN
b. For the IOS interim image a tcl script is run one time: (requires a cisco.com user ID):
http://www.cisco.com/cisco/software/release.html?mdfid=283733571&softwareid=284194160&release=LTE
_RECOVERY_1.0&relind=AVAILABLE&rellifecycle=&reltype=latest
6.
To connect a NEMO session to the EXGW, the mobile router must be configured with the correct Security
Parameter Index (SPI) and key information. For the current release of DMNR, the correct values are provided
in this guide.
7.
To connect a NEMO session to the EXGW, the mobile router must be configured with the correct IP address of
the NEMO High Availability (NEMO-HA) service. The address depends on the location of the EXGW:
a. Columbus/Westland1: 66.174.161.160
b. Charlotte/Nashville: 66.174.170.161
c. Lonestar2/Copperfield: 66.174.185.193
d. Plymouth/Wilmington: 66.174.252.2
e. Vegas/Tempe: 66.174.251.2
f. Lodge/Westland2: 66.174.250.1
8.
At least one ISR interface must be registered by the mobile router when the NEMO call is made to the EXGW.
The interface must be in UP/UP state (loopback interface is recommended).
9.
The EXGW will accept up to 8 subnets in the NEMO registration prefix list. Subnets in excess of 8 will be
silently ignored.
10. Only directly connected mobile network prefixes may be configured for registration by the mobile router. The
mobile networks are registered by specifying the connected interface name. If non-connected subnets are
required, please refer to an addendum configuration example “DMNR with Secondary IP and Nonconnected
Subnets” available from your Verizon Wireless representative.
11. It is not recommended to configure secondary IP addresses on the interfaces that are registered by the mobile
router unless it is intended by design. In Cisco IOS Software a secondary IP address is listed first under the
interface configuration, and its subnet will be the only one that is inserted into the NEMO prefix list from that
interface. If secondary IP addresses are required, please refer to an addendum configuration example “DMNR
with Secondary IP and Nonconnected Subnets”.
12. After a successful NEMO registration, the mobile router will automatically bring up a generic-routingencapsulation (GRE) tunnel interface (Tunnel0) and will install a dynamic Mobile Default route to that interface.
13. Ensure that no static routes pointing to the Cellular interface exist in the mobile router configuration.
14. The dynamic Tunnel0 interface will have the IP maximum transmission unit (MTU) of 1476 bytes. IP packets
whose lengths exceed 1440 bytes will require fragmentation. For TCP traffic the ip tcp adjust-mss command
may be used as shown in this guide to avoid fragmentation.
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 3 of 13
If the mobile router needs to handle large non-TCP packets that have the Don’t Fragment (DF) bit set, a routemap that clears the DF bit should be applied to the LAN interface of the mobile router.
15. Ensure that the ip virtual-reassembly command is not present on interface Cellular 0/x/0.
16. The Verizon Wireless Network will preserve the quality-of-service (QoS) markings (type of
service/differentiated services code point [ToS/DSCP]) that have been set in the original IP packet header.
However, no QoS treatment will be applied to the marked packets.
17. The changes to the subnet (prefix) list registered by the mobile router take effect on EXGW immediately while
the NEMO session is running. No coordination is needed to advertise new subnets beyond ISR configuration.
18. Please refer to the notes in the configuration syntax for an explanation of the commands.
Design Requirements and Recommendations
1.
For ISRs, the Cisco IOS 15.2(4)M3 or later, or Special Software Release mitigates the LTE eHWIC out-of-sync
condition with its on-board LTE modem. The ISR LTE auto-recovery script should NOT be used and should be
removed after installing and running IOS 15.2(4)M3 or later, or the IOS LTE Interim Special Software Release.
For CGR-2010, 15.3(T)1 or later mitigates this condition.
2.
If an LTE connection cannot be made, the APN value on the LTE eHWIC modem should be checked (ISR
command show cellular 0/x/0 profile). If it is not the enterprise APN, please refer to planning section above.
3.
Although this configuration guide should be used first, additional information is available at:
●
LTE eHWIC hardware overview, SIM installs, antenna connection, and module install:
http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/hardware/installation/guide/EHWIC-4GLTEHW.html.
●
LTE eHWIC Cisco IOS Software configuration monitoring and troubleshooting:
http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/EHWIC-4GLTESW.html.
●
The CGR-2010 LTE GRWIC is configured in the same manner as the LTE eHWIC.
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 4 of 13
Figure 1 shows the customer design scenario.
NEMO Router Configuration for ISR G2 and LTE eHWIC, CGR and LTE GRWIC
hostname c1941-NEMO
!
!### LTE eHWIC firmware should be upgraded to 3.5.10.6 & 15.2(4)M3 used ###
boot system flash:c1900-universalk9-mz.SSA.V152_4_M_LTE_LINK_REC
!
ip cef
!
!### CHAT Script to make a data call, name is case-sensitive ###
chat-script LTE "" "AT!CALL1" TIMEOUT 20 "OK"
!
!### This Loopback and IP are required to setup NEMO. This address is not
routable and is used as a placeholder “dummy” address. It may be the same on all
customer routers. Any interface number and any IP can be used. Please use 1.2.3.4
for consistency if possible. ###
!
interface Loopback1234
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 5 of 13
description ### NEMO Router Home Address – Dummy non-Routable IP ###
ip address 1.2.3.4 255.255.255.255
!
!### This Subnet will be routed by NEMO ###
!
interface Loopback255
ip address 10.0.255.1 255.255.255.255
!
!### This subnet is routed by NEMO. TCP MSS 1390 bytes, clear DF bits. ###
!
interface GigabitEthernet0/0
ip address 10.20.59.129 255.255.255.128
ip tcp adjust-mss 1390
ip policy route-map clear-df
!
!### This subnet is not routed by NEMO. ###
!
interface GigabitEthernet0/1
ip address 10.10.20.233 255.255.255.0
!
!### Interface Cellular – used to make a data call. Receives Pool/WAN IP (dynamic
or static) from EXGW. Acts as the NEMO Roaming Interface. The call will be
activated using the Dialer Watch group. Note that the “dialer idletimeout” is set
to never (0). ###
!
interface Cellular0/0/0
ip address negotiated
no ip unreachables
ip mobile router-service roam
ip mobile router-service collocated ccoa-only
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string LTE
dialer watch-group 1
async mode interactive
!### This turns on NEMO Routing. ###
!
router mobile
!
!### This command configures NEMO Authentication with EXGW. Use the appropriate
EXGW IP address based on the geographic location (page 3). Note that SPI and KEY
must match to what is set on the EXGW under the NEMO service. Note that the
algorithm must be set to “hmac-md5”. ###
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 6 of 13
!
ip mobile secure home-agent 66.174.X.Y spi decimal 256 key ascii VzWNeMo
algorithm hmac-md5
!
!### This section configures the NEMO Mobile Router parameters and defines what
router interfaces and their subnets to be included into the NEMO registration
with EXGW. Use the appropriate EXGW IP address as above. ###
!
ip mobile router
address 1.2.3.4 255.255.255.0
collocated single-tunnel
home-agent 66.174.X.Y
mobile-network Loopback255
mobile-network GigabitEthernet0/0
register extend expire 10 retry 3 interval 5
reverse-tunnel
tunnel mode gre
!
no cdp run
!
!### This route-map clears the DF-bit in packets from VLAN1 interface. ###
!
route-map clear-df permit 10
set ip df 0
!
!### This section defines wireless call activation triggers and timers. ###
!
!### The call will be triggered by this statement. The address “5.6.7.8” is a
“dummy” route. Any “dummy” value can be used. ###
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
!### ISR will wait 60 sec. to activate the call after the initial boot. ###
dialer watch-list 1 delay route-check initial 60
!### The router will wait 1 sec. before activating the call. ###
dialer watch-list 1 delay connect 1
!
line 0/0/0
script dialer LTE
modem InOut
no exec
transport input telnet
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 7 of 13
NEMO Router Configuration for ISR C819G-4G-LTE-V and C819HG-4G-V
!### IOS 15.2(4)M3 requires LTE modem firmware 3.5.10.6 ###
boot system flash: c800-universalk9-mz.SPA.152-4.M3.bin
!
ip cef
!
!### CHAT Script to make a data call, name is case-sensitive ###
chat-script LTE "" "AT!CALL1" TIMEOUT 20 "OK"
!
!### This stanza is currently required due to Bug ID: CSCud06180 ###
controller Cellular 0
lte modem link-recovery enable
lte modem link-recovery monitor-timer 60
!
!### This Loopback and IP are required to setup NEMO. This address is not
routable and is used as a placeholder “dummy” address. It may be the same on all
customer routers. Any interface number and any IP can be used. Please use 1.2.3.4
for consistency if possible. ###
!
interface Loopback1234
description ### NEMO Router Home Address – Dummy non-Routable IP ###
ip address 1.2.3.4 255.255.255.255
!
!### This Subnet will be routed by NEMO ###
!
interface Loopback255
ip address 10.0.255.1 255.255.255.255
!
!### This subnet is routed by NEMO. TCP MSS 1390 bytes, clear DF bits. ###
!
interface VLAN1
ip address 10.20.59.129 255.255.255.128
ip tcp adjust-mss 1390
ip policy route-map clear-df
!
!### This subnet is not routed by NEMO. ###
!
interface GigabitEthernet0
ip address 10.10.20.233 255.255.255.0
!
!### Interface Cellular – used to make a data call. Receives Pool/WAN IP from
EXGW. The call will be activated using the “dialer watch-group”. “Dialer enabletimeout 60” is currently needed due to Bug ID: CSCud06180
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 8 of 13
With this setting it will take 1 minute to bring up the LTE connection. ###
!
interface Cellular0
ip address negotiated
no ip unreachables
ip mobile router-service roam
ip mobile router-service collocated ccoa-only
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 60
dialer string LTE
dialer watch-group 1
async mode interactive
!### This turns on NEMO Routing. ###
!
router mobile
!
!### This command configures NEMO Authentication with EXGW. Use the appropriate
EXGW IP address based on the geographic location (page 3). Note that SPI and KEY
must match to what is set on the EXGW under the NEMO service. Note that the
algorithm must be set to “hmac-md5”. ###
!
ip mobile secure home-agent 66.174.X.Y spi decimal 256 key ascii VzWNeMo
algorithm hmac-md5
!
!### This section configures the NEMO Mobile Router parameters and defines what
router interfaces and their subnets to be included into the NEMO registration
with EXGW. ###
!
ip mobile router
address 1.2.3.4 255.255.255.0
collocated single-tunnel
home-agent 66.174.X.Y
mobile-network Loopback255
mobile-network VLAN1
register extend expire 10 retry 3 interval 5
reverse-tunnel
tunnel mode gre
!
no cdp run
!
!### Route-map clears the DF-bit in IP packets from the VLAN1 interface. ###
!
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 9 of 13
route-map clear-df permit 10
set ip df 0
!
!### This section defines the 4G call activation triggers and timers. ###
!
!### The call will be triggered by this statement. The address “5.6.7.8” is a
“dummy” route. Any “dummy” value can be used. ###
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
!### The router will wait for 60 sec. before activating the call after the
intitial boot. ###
dialer watch-list 1 delay route-check initial 60
!### The router will wait 1 sec. before activating the call. ###
dialer watch-list 1 delay connect 1
!
line 3
script dialer LTE
modem InOut
no exec
transport input telnet
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 10 of 13
Operation and Show Commands
NEMO Call Comes Up
*May 20 19:18:00.779: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
*May 20 19:18:00.803: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Cellular0/0/0, changed state to up
*May 20 19:18:01.967: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0,
changed state to up
c1941-NEMO#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
M*
0.0.0.0/0 is directly connected, Tunnel0
C
10.0.255.0/24 is directly connected, Loopback255
L
10.0.255.1/32 is directly connected, Loopback255
C
10.20.59.128/25 is directly connected, GigabitEthernet0/0
L
10.20.59.129/32 is directly connected, GigabitEthernet0/0
50.0.0.0/32 is subnetted, 1 subnets
C
50.243.0.1 is directly connected, Cellular0/0/0
66.0.0.0/32 is subnetted, 2 subnets
C
66.92.228.35 is directly connected, Cellular0/0/0
M
66.174.160.160 [3/1] via 0.0.0.0, 00:15:59, Cellular0/0/0
c1941-NEMO#show ip mobile router
Mobile Router
Enabled 05/20/10 19:17:28
Last redundancy state transition NEVER
Configuration:
Home Address 1.2.3.4 Mask 255.255.255.0
Home Agent 66.174.160.160 Priority 100 (best) (current)
Registration lifetime 65534 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 10, Retry 3, Interval 5
Reverse tunnel required
Request GRE tunnel
Mobile Networks: Loopback255 (10.0.255.0/255.255.255.0)
GigabitEthernet0/0 (10.20.59.128/255.255.255.128)
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Page 11 of 13
Monitor:
Mobile Router
Status -RegisteredUsing collocated care-of address 50.243.0.1
On interface Cellular0/0/0
Tunnel0 mode GRE/IP
c1941-NEMO#show ip mobile tunnel
Mobile Tunnels:
Total mobile ip tunnels 1
Tunnel0:
src 50.243.0.1, dest 66.174.160.160, key 0
encap GRE/IP, mode reverse-allowed, tunnel-users 1
Input ACL users 0, Output ACL users 0
IP MTU 1476 bytes
Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
outbound interface Cellular0/0/0
MR created, CEF switching enabled, ICMP unreachable enabled
5 minute input rate 0 bits/sec, 1 packets/sec
5 minute output rate 0 bits/sec, 1 packets/sec
1308 packets input, 113352 bytes, 0 drops
1614 packets output, 133239 bytes
c1941-NEMO#show dialer
Ce0/0/0 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect never
Current call connected 00:20:07
Connected to LTE
Dial String
LTE
Successes
1
Failures
0
Last DNIS
00:20:07
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
Last status
successful
Default
Page 12 of 13
c1941-NEMO#ping 11.11.11.11 source 10.20.59.129
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
Packet sent with a source address of 10.20.59.129
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/68/72 ms
Printed in USA
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public Information.
C07-720264-01
06/13
Page 13 of 13
Download PDF