Document
Sun Ethernet Fabric Operating System
RIP Administration Guide
Part No: E21705-04
July 2015
Part No: E21705-04
Copyright © 2010, 2015, Oracle and/or its affiliates. All rights reserved.
This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except
as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform,
publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is
prohibited.
The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.
If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, then the following notice is applicable:
U.S. GOVERNMENT END USERS. Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered
to U.S. Government end users are "commercial computer software" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As
such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or
documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.
This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous
applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all
appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this
software or hardware in dangerous applications.
Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.
Intel and Intel Xeon are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of
SPARC International, Inc. AMD, Opteron, the AMD logo, and the AMD Opteron logo are trademarks or registered trademarks of Advanced Micro Devices. UNIX is a registered
trademark of The Open Group.
This software or hardware and documentation may provide access to or information about content, products, and services from third parties. Oracle Corporation and its affiliates are
not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services unless otherwise set forth in an applicable agreement
between you and Oracle. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content,
products, or services, except as set forth in an applicable agreement between you and Oracle.
Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.
Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?
ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.
Référence: E21705-04
Copyright © 2010, 2015, Oracle et/ou ses affiliés. Tous droits réservés.
Ce logiciel et la documentation qui l’accompagne sont protégés par les lois sur la propriété intellectuelle. Ils sont concédés sous licence et soumis à des restrictions d’utilisation et
de divulgation. Sauf stipulation expresse de votre contrat de licence ou de la loi, vous ne pouvez pas copier, reproduire, traduire, diffuser, modifier, breveter, transmettre, distribuer,
exposer, exécuter, publier ou afficher le logiciel, même partiellement, sous quelque forme et par quelque procédé que ce soit. Par ailleurs, il est interdit de procéder à toute ingénierie
inverse du logiciel, de le désassembler ou de le décompiler, excepté à des fins d’interopérabilité avec des logiciels tiers ou tel que prescrit par la loi.
Les informations fournies dans ce document sont susceptibles de modification sans préavis. Par ailleurs, Oracle Corporation ne garantit pas qu’elles soient exemptes d’erreurs et vous
invite, le cas échéant, à lui en faire part par écrit.
Si ce logiciel, ou la documentation qui l’accompagne, est concédé sous licence au Gouvernement des Etats-Unis, ou à toute entité qui délivre la licence de ce logiciel ou l’utilise pour
le compte du Gouvernement des Etats-Unis, la notice suivante s’applique:
U.S. GOVERNMENT END USERS. Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered
to U.S. Government end users are "commercial computer software" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As
such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or
documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.
Ce logiciel ou matériel a été développé pour un usage général dans le cadre d’applications de gestion des informations. Ce logiciel ou matériel n’est pas conçu ni n’est destiné
à être utilisé dans des applications à risque, notamment dans des applications pouvant causer des dommages corporels. Si vous utilisez ce logiciel ou matériel dans le cadre d’
applications dangereuses, il est de votre responsabilité de prendre toutes les mesures de secours, de sauvegarde, de redondance et autres mesures nécessaires à son utilisation dans des
conditions optimales de sécurité. Oracle Corporation et ses affiliés déclinent toute responsabilité quant aux dommages causés par l’utilisation de ce logiciel ou matériel pour ce type
d’applications.
Oracle et Java sont des marques déposées d’Oracle Corporation et/ou de ses affiliés. Tout autre nom mentionné peut correspondre à des marques appartenant à d’autres propriétaires
qu’Oracle.
Intel et Intel Xeon sont des marques ou des marques déposées d’Intel Corporation. Toutes les marques SPARC sont utilisées sous licence et sont des marques ou des marques
déposées de SPARC International, Inc. AMD, Opteron, le logo AMD et le logo AMD Opteron sont des marques ou des marques déposées d’Advanced Micro Devices. UNIX est une
marque déposée d’The Open Group.
Ce logiciel ou matériel et la documentation qui l’accompagne peuvent fournir des informations ou des liens donnant accès à des contenus, des produits et des services émanant de
tiers. Oracle Corporation et ses affiliés déclinent toute responsabilité ou garantie expresse quant aux contenus, produits ou services émanant de tiers, sauf mention contraire stipulée
dans un contrat entre vous et Oracle. En aucun cas, Oracle Corporation et ses affiliés ne sauraient être tenus pour responsables des pertes subies, des coûts occasionnés ou des
dommages causés par l’accès à des contenus, produits ou services tiers, ou à leur utilisation, sauf mention contraire stipulée dans un contrat entre vous et Oracle.
Accessibilité de la documentation
Pour plus d’informations sur l’engagement d’Oracle pour l’accessibilité à la documentation, visitez le site Web Oracle Accessibility Program, à l'adresse http://www.oracle.com/
pls/topic/lookup?ctx=acc&id=docacc.
Accès au support électronique
Les clients Oracle qui ont souscrit un contrat de support ont accès au support électronique via My Oracle Support. Pour plus d'informations, visitez le site http://www.oracle.com/
pls/topic/lookup?ctx=acc&id=info ou le site http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs si vous êtes malentendant.
Contents
Using This Documentation ................................................................................. 7
Product Documentation Library ......................................................................... 7
Acronyms and Abbreviations ............................................................................ 7
CLI Command Modes ..................................................................................... 7
Feedback ....................................................................................................... 8
RIP Overview ...................................................................................................... 9
Protocol Description ........................................................................................ 9
Configuring the RIP Topology Example .............................................................. 9
RIP Topology 1 .................................................................................... 10
RIP Topology 2 .................................................................................... 10
▼ Configure Switch 1 .......................................................................... 11
▼ Configure Switch 2 .......................................................................... 11
▼ Configure Switch 3 .......................................................................... 12
General Configurations ..................................................................................... 15
Managing RIP .............................................................................................. 15
▼ Enable RIP ..................................................................................... 16
▼ Disable RIP ..................................................................................... 16
▼ Enabling RIP on an IP Network .......................................................... 16
Configuring RIP Security ................................................................................ 17
▼ Enable RIP Security ......................................................................... 17
▼ Disable RIP Security ........................................................................ 18
Configuring the RIP Packet Retransmission Interval and Retry Count ..................... 18
▼ Set the RIP Packet Retransmission Interval and Retry Count .................... 18
▼ Reset the Retransmission Interval and Retry Count ................................. 19
Configuring RIP Neighbors ............................................................................. 20
▼ Add a RIP Neighbor ......................................................................... 20
▼ Remove a RIP Neighbor .................................................................... 21
Configuring the RIP Passive Interface ............................................................... 21
5
Contents
▼ Enable the RIP Passive Interface ......................................................... 21
▼ Disable the RIP Passive Interface ........................................................ 22
Configuring the Output Delay ......................................................................... 23
▼ Enable the Output Delay ................................................................... 23
▼ Disable the Output Delay .................................................................. 24
Configuring Redistribution .............................................................................. 25
▼ Enable Redistribution ........................................................................ 25
▼ Test Redistribution ........................................................................... 25
▼ Disable Redistribution ....................................................................... 27
Configuring the Default Metric ........................................................................ 28
▼ Set the Default Metric ....................................................................... 28
▼ Test the Default Metric ..................................................................... 29
▼ Reset the Default Metric .................................................................... 31
Managing the auto-summary Option ................................................................. 31
▼ Disable the auto-summary Option ....................................................... 32
▼ Enable the auto-summary Option ........................................................ 33
Configuring Interface-Specific RIP Parameters ................................................... 33
Configuring Interface-Specific Authentication ............................................ 34
Configuring the RIP Default Route Propagation .......................................... 36
Configuring the Version for Receiving RIP Advertisement ............................ 40
Configuring the Summary Address ........................................................... 41
▼ Configure Basic Timers ..................................................................... 43
Configuring the split-horizon Option ..................................................... 44
Configuring the Debug Level for RIP ............................................................... 46
▼ Enable Debug .................................................................................. 46
▼ Disable Debug ................................................................................. 47
6
Sun Ethernet Fabric Operating System • July 2015
Using This Documentation
■
■
■
Overview – Describes RIP topologies and how to configure RIP software
Audience – Users implementing RIP protocol with other protocols in the router stack
Required Knowledge – Basic knowledge of the RIP protocol
Product Documentation Library
Documentation and resources for this product and related products are available at:
■
http://www.oracle.com/goto/es2-72_es2-64/docs
■
http://www.oracle.com/goto/ES1-24/docs
■
http://www.oracle.com/goto/sn-10gbE-72p/docs
■
http://www.oracle.com/goto/sb6k-24p-10gbe/docs
Acronyms and Abbreviations
Acronym or Abbreviation
Explanation
CLI
Command-line interface
IETF
Internet Engineering Task Force
IGP
Internet Gateway Protocol
Oracle ILOM
Oracle Integrated Lights Out Management
LAN
Local area network
NEM
Network Express Module
RIP
Routing Information Protocol
SEFOS
Sun Ethernet Fabric Operating System
CLI Command Modes
The following table lists the configuration modes used in this document with their access and
exit methods.
Using This Documentation
7
Feedback
Command Mode
Access Method
Prompt
Exit Method
User EXEC
Access SEFOS from Oracle ILOM with
read-only rights (privilege level 1).
SEFOS>
Use logout or exit to return to the
Oracle ILOM prompt.
Privileged EXEC
Access SEFOS from Oracle ILOM with
full administrative rights (privilege
level 15).
SEFOS#
Use the logout or exit command to
return to the Oracle ILOM prompt.
Global
Configuration
From Privileged EXEC mode, use the
configure terminal command.
SEFOS(config)#
Use the end command to return to
Privileged EXEC mode.
Interface
Configuration
From Global Configuration mode, use
the interface interface-type interfaceid command.
SEFOS(config-if)#
Use the exit command to return
to Global Configuration mode, or
use the end command to return to
Privileged EXEC mode.
Feedback
Provide feedback on this documentation at:
http://www.oracle.com/goto/docfeedback
8
Sun Ethernet Fabric Operating System • July 2015
RIP Overview
This section describes the RIP protocol and how to configure the example topology:
■
■
“Protocol Description” on page 9
“Configuring the RIP Topology Example” on page 9
Protocol Description
RIP is a widely-used protocol for managing router information within a self-contained network
such as a corporate local area network or an interconnected group of such LANs. RIP is
classified by the IETF as one of several IGPs.
RIP sends routing-update messages at regular intervals and when the network topology
changes. When a router receives a routing update that includes changes to an entry, the router
updates its routing table to reflect the new route. The metric value for the path is increased by
1, and the sender is indicated as the next hop. RIP routers maintain only the best route (the
route with the lowest metric value) to a destination. After updating its routing table, the router
immediately begins transmitting routing updates to inform other network routers of the change.
These updates are sent independently of the regularly scheduled updates that RIP routers send.
RIP uses a hop count as a way to determine network distance.
Configuring the RIP Topology Example
This section describes two RIP topology examples. These configurations are examples only.
Variables such as interfaces, IP addresses, and other ID numbers might be different based
on your site configuration. However, before you can configure the RIP software in your
environment, you must perform the basic configuration steps that are described in these
sections, as they apply to your environment.
■
■
■
■
“RIP Topology 1” on page 10
“RIP Topology 2” on page 10
“Configure Switch 1” on page 11
“Configure Switch 2” on page 11
RIP Overview
9
Configuring the RIP Topology Example
■
“Configure Switch 3” on page 12
RIP Topology 1
This illustration shows one RIP topology in which two switches are connected over a common
interface and share VLAN 1. Switch 1 also has VLAN 2 and VLAN 5 configured, and switch 2 has
VLAN 3 and VLAN 5 configured.
RIP Topology 2
This illustration shows a second RIP topology in which all three switches are connected over
a common interface in VLAN 1. Switch 1 also has VLAN 2 configured. Switch 3 has VLAN 4
configured, and switch 2 has VLAN 3 configured.
10
Sun Ethernet Fabric Operating System • July 2015
Configure Switch 1
Configure Switch 1
Use the following commands to configure VLAN 1 and VLAN 2 on switch 1 in the example
topologies.
Configure switch 1.
SEFOS# configure terminal
SEFOS(config)# set gvrp disable
SEFOS(config)# set gmrp disable
SEFOS(config)# interface vlan 1
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 10.0.0.1 255.255.0.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# vlan 1
SEFOS(config-vlan)# ports extreme-ethernet 0/1 untagged extreme-ethernet 0/1
SEFOS(config-vlan)# exit
SEFOS(config)# interface vlan 2
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 20.2.2.2 255.255.255.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# vlan 2
SEFOS(config-vlan)# ports extreme-ethernet 0/2 untagged extreme-ethernet 0/2
SEFOS(config-vlan)# exit
SEFOS(config)# interface extreme-ethernet 0/2
SEFOS(config-if)# switchport pvid 2
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
Configure Switch 2
Use the following commands to configure VLAN 1 and VLAN 3 on switch 2 in the example
topologies.
Configure switch 2.
SEFOS# configure terminal
SEFOS(config)# set gvrp disable
SEFOS(config)# set gmrp disable
SEFOS(config)# interface vlan 1
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 10.0.0.2 255.255.0.0
SEFOS(config-if)# no shutdown
RIP Overview
11
Configure Switch 3
SEFOS(config-if)# exit
SEFOS(config)# vlan 1
SEFOS(config-vlan)# ports extreme-ethernet 0/1 untagged extreme-ethernet 0/1
SEFOS(config-vlan)# exit
SEFOS(config)# interface vlan 3
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 30.2.2.2 255.255.255.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# vlan 3
SEFOS(config-vlan)# ports extreme-ethernet 0/3 untagged extreme-ethernet 0/3
SEFOS(config-vlan)# exit
SEFOS(config)# interface extreme-ethernet 0/3
SEFOS(config-if)# switchport pvid 3
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
Configure Switch 3
Use the following commands to configure VLAN 1 and VLAN 4 on switch 3 in the example
topologies.
Configure switch 3.
SEFOS# configure terminal
SEFOS(config)# set gvrp disable
SEFOS(config)# set gmrp disable
SEFOS(config)# interface vlan 1
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 10.0.0.3 255.255.0.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# vlan 1
SEFOS(config-vlan)# ports extreme-ethernet 0/1 untagged extreme-ethernet 0/1
SEFOS(config-vlan)# exit
SEFOS(config)# interface vlan 4
SEFOS(config-if)# shutdown
SEFOS(config-if)# ip address 40.2.2.2 255.255.255.0
SEFOS(config-if)# no shutdown
SEFOS(config-if)# exit
SEFOS(config)# vlan 4
SEFOS(config-vlan)# ports extreme-ethernet 0/4 untagged extreme-ethernet 0/4
SEFOS(config-vlan)# exit
SEFOS(config)# interface extreme-ethernet 0/4
SEFOS(config-if)# switchport pvid 4
SEFOS(config-if)# no shutdown
12
Sun Ethernet Fabric Operating System • July 2015
Configure Switch 3
SEFOS(config-if)# exit
RIP Overview
13
14
Sun Ethernet Fabric Operating System • July 2015
General Configurations
This section contains procedures for configuring RIP in SEFOS. See “Configuring the
RIP Topology Example” on page 9 for descriptions of the topologies that are referenced
in the procedures. Before you can configure RIP, you must configure the switches in your
environment. To configure switch 1, see “Configure Switch 1” on page 11. To configure switch
2, see “Configure Switch 2” on page 11, and to configure switch 3, see “Configure Switch
3” on page 12. RIP is disabled by default.
■
■
■
■
■
■
■
■
■
■
■
“Managing RIP” on page 15
“Configuring RIP Security” on page 17
“Configuring the RIP Packet Retransmission Interval and Retry Count” on page 18
“Configuring RIP Neighbors” on page 20
“Configuring the RIP Passive Interface” on page 21
“Configuring the Output Delay” on page 23
“Configuring Redistribution” on page 25
“Configuring the Default Metric” on page 28
“Managing the auto-summary Option” on page 31
“Configuring Interface-Specific RIP Parameters” on page 33
“Configuring the Debug Level for RIP” on page 46
Managing RIP
Before you can enable RIP, you must configure your environment. The procedures in this
section are based on “RIP Topology 1” on page 10. For instructions on how to configure switch
1, see “Configure Switch 1” on page 11. For instructions on how to configure switch 2, see
“Configure Switch 2” on page 11.
■
■
■
“Enable RIP” on page 16
“Disable RIP” on page 16
“Enabling RIP on an IP Network” on page 16
General Configurations
15
Enable RIP
Enable RIP
1.
On the switch, enter Global Configuration mode.
SEFOS# configure terminal
2.
Enable RIP.
SEFOS(config)# router rip
SEFOS(config-router)# exit
Disable RIP
1.
On the switch, enter Global Configuration mode.
SEFOS# configure terminal
2.
Disable RIP.
SEFOS(config)# no router rip
SEFOS(config)# exit
Enabling RIP on an IP Network
1.
Enter Global Configuration mode.
SEFOS# configure terminal
2.
On switch 1, enable RIP for the VLAN 1 interface.
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
Review the RIP interface.
SEFOS# show ip rip statistics
16
Sun Ethernet Fabric Operating System • July 2015
Configuring RIP Security
RIP Global Statistics:
---------------------Total number of route changes is 0
Total number of queries responded is
Total number of dropped packets is 0
RIP Interface Statistics:
------------------------Interface Periodic
BadRoutes
IP Address Updates Sent Received
----------- ------------ --------10.0.0.1
11
0
4.
0
Triggered
Updates Sent
-----------0
BadPackets Admin
Received
Status
---------- -----0
Enabled
Review the RIP route.
SEFOS# show ip rip database
10.0.0.0/8[1]
summary route
10.0.0.0/16
directly connected, vlan1
Configuring RIP Security
By default, RIP security is disabled. Before you can enable RIP security, you must configure
your environment. The procedures in this section are based on “RIP Topology 1” on page 10.
For instructions on how to configure switch 1, see “Configure Switch 1” on page 11. For
instructions on how to configure switch 2, see “Configure Switch 2” on page 11.
■
■
“Enable RIP Security” on page 17
“Disable RIP Security” on page 18
Enable RIP Security
1.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
2.
Enable RIP security in switch 1.
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# ip rip security minimum
SEFOS(config-router)# exit
General Configurations
17
Disable RIP Security
Disable RIP Security
1.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
2.
Disable RIP security.
SEFOS(config-router)# no ip rip security
SEFOS(config-router)# exit
Configuring the RIP Packet Retransmission Interval and
Retry Count
Before you can configure the retransmission level or retry count, you must configure your
environment. The procedures in this section are based on “RIP Topology 1” on page 10.
For instructions on how to configure switch 1, see “Configure Switch 1” on page 11. For
instructions on how to configure switch 2, see “Configure Switch 2” on page 11.
■
■
“Set the RIP Packet Retransmission Interval and Retry Count” on page 18
“Reset the Retransmission Interval and Retry Count” on page 19
Set the RIP Packet Retransmission Interval and
Retry Count
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Set the retransmission interval (10 seconds in this example).
SEFOS(config-router)# ip rip retransmission interval 10
3.
Set the retry count (20 in this example).
SEFOS(config-router)# ip rip retransmission retries 20
18
Sun Ethernet Fabric Operating System • July 2015
Reset the Retransmission Interval and Retry Count
4.
Review the configuration information.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Minimum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 10 seconds
Number of retransmission retries is 20
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Reset the Retransmission Interval and Retry
Count
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Reset the retransmission interval and retry count.
SEFOS(config-router)# no ip rip retransmission interval
SEFOS(config-router)# no ip rip retransmission retries
SEFOS(config-router)# end
3.
Review the configuration information.
General Configurations
19
Configuring RIP Neighbors
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Configuring RIP Neighbors
Before you can enable RIP neighbors, you must configure your environment. The procedures
in this section are based on “RIP Topology 2” on page 10. For instructions on how to
configure switch 1, see page 8. For instructions on how to configure switch 2, see “Configure
Switch 2” on page 11. For instructions on how to configure switch 3, see “Configure Switch
3” on page 12.
■
■
“Add a RIP Neighbor” on page 20
“Remove a RIP Neighbor” on page 21
Add a RIP Neighbor
In this example, switch 2 is added to switch 1.
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
20
Sun Ethernet Fabric Operating System • July 2015
Remove a RIP Neighbor
SEFOS(config-router)# network 10.0.0.1
2.
Add the switch 2 as a neighbor.
SEFOS(config-router)# neighbor 10.0.0.2
SEFOS(config-router)# end
In switch 1, you should be able to view only the routes that are sent as RIP updates from the
neighbor router (switch 2 at 10.0.0.2).
Remove a RIP Neighbor
In this example, switch 2 is removed from switch 1.
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Delete the configured RIP neighbor.
SEFOS(config-router)# no neighbor 10.0.0.2
SEFOS(config-router)# end
In switch 1, you should be able to view the routes that are sent as RIP updates from both of the
neighbor routers (switch 2 at 10.0.0.2 and switch 3 at 10.0.0.3).
Configuring the RIP Passive Interface
Before you can configure the passive interface, you must configure your environment. The
procedures in this section are based on “RIP Topology 1” on page 10. For instructions on
how to configure switch 1, see “Configure Switch 1” on page 11. For instructions on how to
configure switch 2, see “Configure Switch 2” on page 11.
■
■
“Enable the RIP Passive Interface” on page 21
“Disable the RIP Passive Interface” on page 22
Enable the RIP Passive Interface
1.
On switch 1, enter the configuration mode for the router.
General Configurations
21
Disable the RIP Passive Interface
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Enable the passive interface for VLAN 1.
SEFOS(config-router)# passive-interface vlan 1
SEFOS(config-router)# exit
3.
Review the passive interface configuration information.
SEFOS# show ip rip statistics
RIP Global Statistics:
---------------------Total number of route changes is 0
Total number of queries responded is
Total number of dropped packets is 0
RIP Interface Statistics:
------------------------Interface Periodic
BadRoutes
IP Address Updates Sent Received
----------- ------------ --------10.0.0.1
0
0
0
Triggered
Updates Sent
BadPackets
Received
Admin
Status
-----------0
---------0
-----Passive
No routing updates are sent over the passive interface (VLAN 1).
Disable the RIP Passive Interface
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Disable the passive interface status for VLAN 1.
SEFOS(config-router)# no passive-interface vlan 1
SEFOS(config-router)# exit
3.
22
Review the RIP interface for the periodic updates sent over the interface.
Sun Ethernet Fabric Operating System • July 2015
Configuring the Output Delay
SEFOS# show ip rip statistics
RIP Global Statistics:
---------------------Total number of route changes is 0
Total number of queries responded is
Total number of dropped packets is 0
RIP Interface Statistics:
------------------------Interface Periodic
BadRoutes
IP Address Updates Sent Received
----------- ------------ --------10.0.0.1
1
0
0
Triggered
Updates Sent
-----------0
BadPackets Admin
Received
Status
---------- -----0
Enabled
Configuring the Output Delay
Before you can configure the output delay, you must configure your environment. The
procedures in this section are based on “RIP Topology 1” on page 10. For instructions on
how to configure switch 1, see “Configure Switch 1” on page 11. For instructions on how to
configure switch 2, see “Configure Switch 2” on page 11.
■
■
“Enable the Output Delay” on page 23
“Disable the Output Delay” on page 24
Enable the Output Delay
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Enable the output delay feature.
SEFOS(config-router)# output-delay
SEFOS(config-router)# end
3.
Review the enabled output delay.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
General Configurations
23
Disable the Output Delay
RIP2 security level is Maximum
Redistributing : rip
Output Delay is enabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Disable the Output Delay
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
2.
Disable the output delay.
SEFOS(config-router)# no output-delay
SEFOS(config-router)# end
3.
Review the output delay.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
24
Sun Ethernet Fabric Operating System • July 2015
Configuring Redistribution
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Configuring Redistribution
Before you can configure redistribution, you must configure your environment. The procedures
in this section are based on “RIP Topology 1” on page 10. For instructions on how to configure
switch 1, see “Configure Switch 1” on page 11. For instructions on how to configure switch 2,
see “Configure Switch 2” on page 11.
■
■
■
“Enable Redistribution” on page 25
“Test Redistribution” on page 25
“Disable Redistribution” on page 27
Enable Redistribution
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Enable redistribution.
SEFOS(config-router)# redistribute static
SEFOS(config-router)# end
Test Redistribution
1.
On switch 1, enter the configuration mode for the router.
General Configurations
25
Test Redistribution
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Enable redistribution.
SEFOS(config-router)# redistribute static
SEFOS(config-router)# exit
3.
Add static routes.
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
4.
ip route
ip route
ip route
ip route
end
50.0.0.0
60.0.0.0
70.0.0.0
80.0.0.0
255.0.0.0
255.0.0.0
255.0.0.0
255.0.0.0
vlan
vlan
vlan
vlan
2
2
2
2
On switch 2, test the redistribution.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.2
SEFOS(config-router)# end
5.
Review the redistribution of static routes on switch 1.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip, static
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
26
Sun Ethernet Fabric Operating System • July 2015
Disable Redistribution
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
6.
On switch 2, review the RIP route entries for the static routes that were added in
switch 1.
In switch 1, static routes with the metric of 3 are redistributed into the RIP domain. The
following output shows the redistributed static routes with the metric of 4.
SEFOS# show
10.0.0.0/8
10.0.0.0/16
50.0.0.0/8
50.0.0.0/8
60.0.0.0/8
60.0.0.0/8
70.0.0.0/8
70.0.0.0/8
80.0.0.0/8
80.0.0.0/8
7.
ip rip database
[1]
[1]
[4]
[4]
[4]
[4]
[4]
[4]
[4]
[4]
auto-summary
directly connected, vlan1
auto-summary
via 10.0.0.1, vlan1
auto-summary
via 10.0.0.1, vlan1
auto-summary
via 10.0.0.1, vlan1
auto-summary
via 10.0.0.1, vlan1
Review the IP routing table on switch 2.
SEFOS# show ip route
C 10.0.0.0/16 is directly connected, vlan1
C 30.2.2.0/24 is directly connected, vlan3
R 50.0.0.0/8 [4] via 10.0.0.1
R 60.0.0.0/8 [4] via 10.0.0.1
R 70.0.0.0/8 [4] via 10.0.0.1
R 80.0.0.0/8 [4] via 10.0.0.1
Disable Redistribution
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
2.
Disable the output delay.
SEFOS(config-router)# no redistribute static
SEFOS(config-router)# end
General Configurations
27
Configuring the Default Metric
3.
On switch 2, review the RIP route entries for the static routes that were added in
switch 1.
The routes were made unreachable with a metric as infinity (16). The static routes are
redistributed into the RIP domain.
SEFOS# show
10.0.0.0/8
10.0.0.0/16
50.0.0.0/8
60.0.0.0/8
70.0.0.0/8
80.0.0.0/8
4.
ip rip database
[1]
[1]
[16]
[16]
[16]
[16]
auto-summary
directly connected, vlan1
via 10.0.0.1, vlan1
via 10.0.0.1, vlan1
via 10.0.0.1, vlan1
via 10.0.0.1, vlan1
On switch 2, review the RIP route entries for the redistributed static routes that
were deleted from the IP routing table.
SEFOS# show ip route
C 10.0.0.0/16 is directly connected, vlan1
C 30.2.2.0/24 is directly connected, vlan3
Configuring the Default Metric
Before you can configure the default metric, you must configure your environment. The
procedures in this section are based on “RIP Topology 1” on page 10. For instructions on
how to configure switch 1, see “Configure Switch 1” on page 11. For instructions on how to
configure switch 2, see “Configure Switch 2” on page 11.
■
■
■
“Set the Default Metric” on page 28
“Test the Default Metric” on page 29
“Reset the Default Metric” on page 31
Set the Default Metric
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
28
Set the default metric value (10 in this example).
Sun Ethernet Fabric Operating System • July 2015
Test the Default Metric
SEFOS(config-router)# default-metric 10
SEFOS(config-router)# redistribute static
SEFOS(config-router)# end
Test the Default Metric
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Set the default metric value (10 in this example).
SEFOS(config-router)# default-metric 10
3.
Configure the redistribution of static routes into the RIP domain.
SEFOS(config-router)# redistribute static
SEFOS(config-router)# exit
4.
Add static routes.
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
SEFOS(config)#
5.
ip route
ip route
ip route
ip route
end
50.0.0.0
60.0.0.0
70.0.0.0
80.0.0.0
255.0.0.0
255.0.0.0
255.0.0.0
255.0.0.0
vlan
vlan
vlan
vlan
2
2
2
2
On switch 2, test the default metric.
SEFOS# show ip rip database
10.0.0.0/8 [1] auto-summary
10.0.0.0/16 [1] directly connected, vlan1
50.0.0.0/8 [11] auto-summary
50.0.0.0/8 [11] via 10.0.0.1, vlan1
60.0.0.0/8 [11] auto-summary
60.0.0.0/8 [11] via 10.0.0.1, vlan1
70.0.0.0/8 [11] auto-summary
70.0.0.0/8 [11] via 10.0.0.1, vlan1
80.0.0.0/8 [11] auto-summary
80.0.0.0/8 [11] via 10.0.0.1, vlan1
General Configurations
29
Test the Default Metric
Review the IP routing table.
SEFOS# show ip route
C 10.0.0.0/16 is directly connected, vlan1
C 30.2.2.0/24 is directly connected, vlan3
R 50.0.0.0/8 [11] via 10.0.0.1
R 60.0.0.0/8 [11] via 10.0.0.1
R 70.0.0.0/8 [11] via 10.0.0.1
R 80.0.0.0/8 [11] via 10.0.0.1
6.
On switch 1, review the metric for the redistributed RIP route entries.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip, static
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 10
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
7.
On switch 1, review the RIP configuration information.
SEFOS# show
10.0.0.0/8
10.0.0.0/16
50.0.0.0/8
50.0.0.0/8
60.0.0.0/8
60.0.0.0/8
70.0.0.0/8
30
ip rip database
[1]
[1]
[10]
[10]
[10]
[10]
[10]
auto-summary
directly connected, vlan1
auto-summary
redistributed via 0.0.0.0
auto-summary
redistributed via 0.0.0.0
auto-summary
Sun Ethernet Fabric Operating System • July 2015
Reset the Default Metric
70.0.0.0/8 [10]
80.0.0.0/8 [10]
80.0.0.0/8 [10]
8.
redistributed via 0.0.0.0
auto-summary
redistributed via 0.0.0.0
On switch 1, disable redistribution.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# no redistribute static
SEFOS(config-router)# end
Reset the Default Metric
1.
Reset the default metric for the redistributed routes.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# no default-metric
2.
Enable static route redistribution.
SEFOS(config-router)# redistribute static
SEFOS(config-router)# end
3.
On switch 1, review the metric for redistributed RIP route entries.
SEFOS# show ip rip database
10.0.0.0/8 [1] auto-summary
10.0.0.0/16 [1] directly connected, vlan1
50.0.0.0/8 [3] auto-summary
50.0.0.0/8 [3] redistributed via 0.0.0.0
60.0.0.0/8 [3] auto-summary
60.0.0.0/8 [3] redistributed via 0.0.0.0
70.0.0.0/8 [3] auto-summary
70.0.0.0/8 [3] redistributed via 0.0.0.0
80.0.0.0/8 [3] auto-summary
80.0.0.0/8 [3] redistributed via 0.0.0.0
Managing the auto-summary Option
By default, the auto-summary option is enabled. Before you can manage the auto-summary
option, you must configure your environment. The procedures in this section are based on
General Configurations
31
Disable the auto-summary Option
“RIP Topology 1” on page 10. For instructions on how to configure switch 1, see “Configure
Switch 1” on page 11. For instructions on how to configure switch 2, see “Configure Switch
2” on page 11.
■
“Disable the auto-summary Option” on page 32
■
“Enable the auto-summary Option” on page 33
Disable the auto-summary Option
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
2.
Disable the auto-summary option for RIP routes.
SEFOS(config-router)# auto-summary disable
3.
Review the disabled option.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is disabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
32
Sun Ethernet Fabric Operating System • July 2015
Enable the auto-summary Option
Enable the auto-summary Option
1.
Enable the auto-summary option in switch 1.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# auto-summary enable
SEFOS(config-router)# end
2.
Review the configuration information to ensure that the option is enabled.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Configuring Interface-Specific RIP Parameters
You must use the interface mode to configure the parameters. However, before you can
configure RIP parameters, you must configure your environment. The procedures in this section
are based on “RIP Topology 1” on page 10. For instructions on how to configure switch 1,
see “Configure Switch 1” on page 11. For instructions on how to configure switch 2, see
“Configure Switch 2” on page 11.
■
“Configuring Interface-Specific Authentication” on page 34
General Configurations
33
Enable Interface-Specific Authentication
■
“Configuring the RIP Default Route Propagation” on page 36
“Configuring the Version for Receiving RIP Advertisement” on page 40
“Configuring the Summary Address” on page 41
“Configure Basic Timers” on page 43
■
“Configuring the split-horizon Option” on page 44
■
■
■
Configuring Interface-Specific Authentication
This section contains procedures that explain how to configure interface-specific authentication
and the command to disable interface-specific authentication.
■
■
■
“Enable Interface-Specific Authentication” on page 34
“Enable Authentication on Both Switches” on page 34
“Disable Interface-Specific Authentication” on page 36
Enable Interface-Specific Authentication
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
On switch 1, enable interface-specific authentication on the specific interface.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip authentication mode md5 key-chain 12345
Enable Authentication on Both Switches
This task tests the authentication.
1.
34
On switch 1, enter the configuration mode for the router.
Sun Ethernet Fabric Operating System • July 2015
Enable Authentication on Both Switches
SEFOS# config terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# redistribute all
SEFOS(config-router)# exit
2.
Enable md5 authentication.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip authentication mode md5 key-chain 12345
SEFOS(config-if)# end
3.
On switch 2, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.2
SEFOS(config-router)# exit
4.
Enable md5 authentication.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip authentication mode md5 key-chain 12345
SEFOS(config-if)# end
5.
Review the authentication type in switch 1.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
General Configurations
35
Disable Interface-Specific Authentication
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is md5
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
On switch 2, ensure that all of the RIP packets have authentication information.
Disable Interface-Specific Authentication
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# end
3.
Disable the authentication.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# no ip rip authentication
Configuring the RIP Default Route Propagation
This section contains four procedures that explain how to configure and test the default route
propagation.
■
■
■
■
“Set the Default Route Propagation” on page 36
“Install the Default Route” on page 37
“Test the Default Route Origination and Installation” on page 37
“Disable the Default Route” on page 40
Set the Default Route Propagation
1.
36
On switch 1, enter the configuration mode for the interface.
Sun Ethernet Fabric Operating System • July 2015
Install the Default Route
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
Set the default route.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip default route originate 10
Install the Default Route
1.
On switch 1, enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
Install the default route.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip default route install
Test the Default Route Origination and Installation
1.
On switch 1, configure the interface.
SEFOS# configure terminal
General Configurations
37
Test the Default Route Origination and Installation
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
SEFOS(config)# interface vlan 1
2.
Install the default route.
SEFOS(config-if)# ip rip default route install
SEFOS(config-if)# end
3.
On switch 2, configure the interface.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.2
SEFOS(config-router)# exit
SEFOS(config)# interface vlan 1
4.
Enable default route origination.
SEFOS(config-if)# ip rip default route originate 11
SEFOS(config-if)# end
5.
On switch 2, review the RIP response packet sent through the interface in switch
2.
The RIP response packets should have a default route.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
38
Sun Ethernet Fabric Operating System • July 2015
Test the Default Route Origination and Installation
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Originate default route
6.
On switch 1, review the default route with the next hop as 10.0.0.2 (the IP
address for switch 2) and a metric of 12 (11+1).
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Installs default route received
Originate default route
7.
Review the RIP database.
SEFOS# show ip rip database
0.0.0.0/0 [12]
via 10.0.0.2, vlan1
10.0.0.0/8 [1]
auto-summary
10.0.0.0/16 [1]
directly connected, vlan1
8.
Review the IP route.
SEFOS# show ip route
R 0.0.0.0/0 [12] via 10.0.0.2
C 10.0.0.0/16 is directly connected, vlan1
C 20.0.0.0/24 is directly connected, vlan2
General Configurations
39
Disable the Default Route
Disable the Default Route
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
2.
Disable the default route.
SEFOS(config-if)# no ip rip default route originate
Configuring the Version for Receiving RIP
Advertisement
This section contains two procedures that explain how to configure the version for receiving
RIP advertisements.
■
■
“Set the Version” on page 40
“Reset the Version” on page 41
Set the Version
1.
On switch 1, enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
Set the version for the VLAN interface (1 in this example).
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip receive version 1
4.
40
Review the IP protocol output to ensure that switch 1 receives only RIP version 1
packets over the interface.
Sun Ethernet Fabric Operating System • July 2015
Reset the Version
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is enabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
Trusted Neighors :
Interface vlan1
Sending updates every 30 seconds
Invalid after 180 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1
Authentication type is none
Split Horizon with poissoned reverse is enabled
Restrcts default route installation
Restricts default route origination
Reset the Version
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
2.
Reset the version.
SEFOS(config-if)# no ip rip send version
SEFOS(config-if)# no ip rip receive version
Configuring the Summary Address
This section includes procedures for configuring the summary address.
■
■
“Set the Summary Address” on page 42
“Test the Summary Address Configuration” on page 42
General Configurations
41
Set the Summary Address
Set the Summary Address
1.
On switch 1, enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Disable the auto-summary option for the interface in VLAN 1.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# auto-summary disable
SEFOS(config-router)# exit
3.
Set the version of the RIP packets to be sent over the VLAN 1 interface.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip summary-address 40.0.0.0 255.0.0.0
SEFOS(config-if)# end
Test the Summary Address Configuration
1.
On switch 1, configure the summary-address option.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# redistribute all
2.
Disable the auto-summary option.
SEFOS(config-router)# auto-summary disable
SEFOS(config-router)# exit
3.
Configure the static routes.
SEFOS(config-router)#
SEFOS(config-router)#
SEFOS(config-router)#
SEFOS(config-router)#
4.
42
ip
ip
ip
ip
route
route
route
route
40.1.0.0
40.2.0.0
40.3.0.0
40.4.0.0
255.255.0.0
255.255.0.0
255.255.0.0
255.255.0.0
vlan
vlan
vlan
vlan
2
2
2
2
Configure the summary address for the VLAN 1 interface (20.0.0.0/8).
Sun Ethernet Fabric Operating System • July 2015
Configure Basic Timers
SEFOS(config)# interface vlan 1
SEFOS(config-if)# ip rip summary-address 40.0.0.0 255.0.0.0
SEFOS(config-if)# end
5.
On switch 2, configure the interface for VLAN 1.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.2
SEFOS(config-router)# end
Configure Basic Timers
1.
On switch 1, enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
Set the timers.
SEFOS(config)# interface vlan 1
SEFOS(config-if)# timers basic 60 120 120
SEFOS(config-if)# end
4.
Review the RIP update packets that are sent after 60 seconds and the configured
timer values.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip, bgp, connected, ospf, static
Output Delay is disabled
General Configurations
43
Configure the split-horizon Option
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is disabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
40.0.0.0/8
for vlan1
Trusted Neighors :
Interface vlan1
Sending updates every 60 seconds
Invalid after 120 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon with poissoned reverse is enabled
Installs default route received
Restricts default route origination
Configuring the split-horizon Option
By default, the split-horizon option with poison reverse is enabled on all RIP interfaces.
■
“Configure the split-horizon Option” on page 44
■
“Enable the split-horizon Option With Poison Reverse” on page 45
■
“Disable the split-horizon Option” on page 46
Configure the split-horizon Option
1.
On switch 1, enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
SEFOS(config-if)# exit
2.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# exit
3.
44
Enter the configuration mode for VLAN 1.
Sun Ethernet Fabric Operating System • July 2015
Enable the split-horizon Option With Poison Reverse
SEFOS(config)# interface vlan 1
4.
Enable the split-horizon option.
SEFOS(config-if)# ip split-horizon
5.
Review the configuration information.
SEFOS# show ip protocols
Routing Protocol is rip
Vrf default
RIP2 security level is Maximum
Redistributing : rip, bgp, connected, ospf, static
Output Delay is disabled
Retransmission timeout interval is 5 seconds
Number of retransmission retries is 36
Default metric is 3
Auto-Summarisation of routes is disabled
Routing for Networks :
10.0.0.0
Routing Information Sources :
Interface Specific Address Summarization :
40.0.0.0/8
for vlan1
Trusted Neighors :
Interface vlan1
Sending updates every 60 seconds
Invalid after 120 seconds
Flushed after 120 seconds
Send version is 1 2, receive version is 1 2
Authentication type is none
Split Horizon is enabled
Installs default route received
Restricts default route origination
Enable the split-horizon Option With Poison Reverse
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
2.
Enable the split-horizon option with poison reverse.
SEFOS(config-if)# ip split-horizon poison
SEFOS(config-if)# end
General Configurations
45
Disable the split-horizon Option
Disable the split-horizon Option
1.
Enter the configuration mode for the interface.
SEFOS# configure terminal
SEFOS(config)# interface vlan 1
2.
Disable the split-horizon option.
SEFOS(config-if)# no ip split-horizon
SEFOS(config-if)# end
Configuring the Debug Level for RIP
For a description of the topology that is referenced in the procedures, see “RIP Topology
1” on page 10. Before you can configure the debug level, you must configure switch 1 and
switch 2. For instructions on how to configure switch 1, see “Configure Switch 1” on page 11.
For instructions on how to configure switch 2, see “Configure Switch 2” on page 11.
■
■
“Enable Debug” on page 46
“Disable Debug” on page 47
Enable Debug
1.
On switch 1, enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# end
2.
Enable the debug level.
SEFOS# debug ip rip all
RIP: Sending regular Update over this interface 0
RIP: Authentication not needed for this interface, So 25 routes can be composed
RIP: If Agg Rt added to update with metric : 3
RIP: Sending RIP update through Port 0
RIP: Sending regular Update over this interface 0
RIP: Authentication not needed for this interface, So 25 routes can be composed
RIP: If Agg Rt added to update with metric : 3
46
Sun Ethernet Fabric Operating System • July 2015
Disable Debug
RIP:
RIP:
RIP:
RIP:
Sending RIP update through Port 0
Sending regular Update over this interface 0
Authentication not needed for this interface, So 25 routes can be composed
If Agg Rt added to update with metric : 3
Disable Debug
1.
Enter the configuration mode for the router.
SEFOS# configure terminal
SEFOS(config)# router rip
SEFOS(config-router)# network 10.0.0.1
SEFOS(config-router)# end
2.
Disable the debug level.
SEFOS# no debug ip rip all
General Configurations
47
48
Sun Ethernet Fabric Operating System • July 2015
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising