Guide to Capturing Images from Cadence

Guide to Capturing Images from Cadence
Guide to Capturing Images from Cadence
A Cadence EDA Tools Help Document
Document Contents
Introduction
Screen Capture with Snapshot
Printing Cadence Images to Paper
Print-to-File Using Cadence
Working with Figures in Microsoft Word
Using Other Tools to Edit Cadence Images
Introduction
For your lab assignments you will be required to provide schematics, simulation waveform, and
other images from Cadence. These images can be printed by Cadence tools or saved using the
Unix Snapshot program. Instructions for both methods are described in this document. For saved
images, you are strongly encouraged to crop your image files so they only show the important
features of the image (crop is an image edit tool to remove unwanted data from the periphery of
an image, sort of like using scissors to crop a photo). For example, do not put a full-screen screen
capture into your report when all you need is a schematic within a small part of the image.
Print-to-File Using Cadence –The Recommended Method
The following steps show how to capture an image (schematic, layout, etc) from Cadence by
creating a bitmap (.bmp) file that you can insert into a word processor document.
o Printing a Schematic/Symbol/Layout to a File
(1) In the Schematic/Symbolic Editor window, select Design =>Plot =>Submit to invoke the
Submit Plot window. Click Plot Options button in the lower right corner of the Submit
Plot window.
(2) In the Plot Options window set the layout to be Portrait, check Center Plot and Fit to
page.
(3) To print the schematic/symbol to a file, check Send Plot Only To File, select EPS in
Plotter Name and select 8x10.5 in Paper Size. For the filename use the extension .eps,
and give an appropriate path to your file. For example if you want to save your file in
your root personal directory (your ‘m-drive’ on a PC) enter
/home/<username>/myfig.eps.
(4) Click OK to the Plot Options window and OK to Submit Plot window to save your file.
o Printing a Simulation Waveform to a File
(1) In the Waveform window goes to Window => Hardcopy.
(2) To print the waveform to a file, select Print Only To File and remove the checkmark in
the Include Header Option. Enter an appropriate path for the filename –see note above.
o Converting .eps Files to Bitmap (.bmp) Files
Guide to Capturing Images
1
The .eps file is a printer-formatted file and it is generally more useful to convert this into a
.bmp file that can be inserted in a Windows-based document. To convert .eps to .bmp file in
UNIX:
(1) In a command prompt window go to the folder where the .eps file is stored (for example
type cd /home/<username>/).
(2) Type convert figname.eps figname.bmp and hit Enter.
Screen Capture with Snapshot
(1) Right click the mouse on the screen. Go to Applications=>Snapshot, two windows will
pop up, a control window and an image viewer window.
(2) Select the Image Viewer - Snapshot window and check the Region box.
(3) Make sure you can clearly see the image you want to capture on your computer screen
(you might have to move some windows around) and click on Snap button.
(4) Now move your mouse to the image you want to capture and left-click and drag to select
the image area. When you release the mouse button, the image will appear in the Image
Viewer view window.
(5) Select the Image Viewer – Untitled view window. Go to File=>Save As to save the
image. The JFIF (JPEG) format is a good one to use. Be sure you use a file extension
(e.g., .jpg) if you want Windows applications to recognize the file.
Printing Cadence Images to Paper
o Printing a Schematic/Symbol/Layout
(1) In the Schematic/Symbolic/Layout Editor window, select Design =>Plot =>Submit to
invoke the Submit Plot window. Click Plot Options button in the lower right corner of
the Submit Plot window.
(2) In the Plot Options window set the layout to be Portrait, check Center Plot and Fit to
page.
(3) To print the schematic using a printer click OK to Plot Options and OK to Submit Plot
windows. The schematic will be printed to the default printer.
o Printing a Simulation Waveform to a File
(1) In the Waveform window goes to Window => Hardcopy and then say OK to the options.
Working with Figures in Microsoft Word
o Add a Figure to a Word Document
To add the figure file you saved to a Word document, place your cursor where you want the
figure and, from the top menu in Word, select Insert => Picture => From File and locate the
file you saved. When you click on Insert, the figure will be added to your document.
o Manipulating an Image in Word
Guide to Capturing Images
2
Word provides several tools for editing or modifying an image added to a word document. If
you right click on an image and select Show Picture Toolbar, a bar with several edit tools
will open. A particularly useful tool here is the Crop tool, near the middle of the bar. This
will allow you to trim unwanted portions of the figure from the edges. You can also
manipulate the colors significantly using many of the tools near the left of the Picture
Toolbar. Experiment to achieve the desired results. You can always use the Undo tool (Edit
menu) or delete the image and add it again if you destroy your image.
Using Other Tools to Edit your Cadence Images
You can use many commercial software programs, like Adobe Photoshop, to edit your images.
With these tools you can invert images (to convert the black background from a snapshot image
to white), add text (to add labels to schematics, layouts, or simulation waveforms), draw arrows
to highlight specific portions of the figure, etc. Feel free to do anything you can to your images
to improve the value of these figures in your reports.
Guide to Capturing Images
3
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising