Using The Akai MPC With Pro Tools - Look Inside - MPC

Using The Akai MPC With Pro Tools - Look Inside - MPC
Using The Akai MPC With Pro Tools
Written By Andy Avgousti (MPC-Tutor)
Copyright © Andy Avgousti 2011
Published by MPC-Samples.com 2011
All rights reserved. No part of this book, nor any of its associated tutorial files may
be reproduced, resold, or transmitted in any form or by any means without prior
written permission of the Publisher.
MPC-Samples.com has made every effort to ensure the accuracy of the information
herein. However, the information contained in this book is sold without warranty,
either express or implied. Neither the authors nor Publishers, nor its dealers or
distributors will be held liable for any damages to be caused either directly or
indirectly by the instructions contained in this book, or by the software or hardware
products described herein.
The author is not endorsed by, nor affiliated to Avid Technology, Inc. Pro Tools is a
trademark of Avid Technology, Inc.
MPC-Samples.com is a trading name of Beat Box Digital LTD, a company registered
in England & Wales, Company No. 6810062.
Introduction
This book has been written as a guide for Akai MPC owners who wish to utilise Pro
Tools when creating beats. Throughout this book I assume that you are already
familiar with the general usage of the MPC, so have a basic grasp of the main
sequencer functions, like sequence recording, STEP EDIT, and adjusting MAIN page
parameters like track program assignments etc. This book is not intended as a
complete beginners guide to using the MPC itself (we already have those at
http://www.mpc-samples.com/section.php/8/0/ ).
Similarly, this book is not intended to be a complete guide to using Pro Tools - that
would require much longer book! We’ve just concentrated only on the issues you
need to learn to successfully use Pro Tools as a sound module and for the MPC as
well as using it to record MPC MIDI and audio performances, keeping it clear and
jargon-free to help explain all the core principles and techniques.
We advise that you first locate the folder containing the MPC format project files for
your particular MPC model and transfer these sounds to your MPC’s disc (CF card,
zip, hard drive etc). This means you can quickly load up the relevant MPC files when
working through each tutorial. If you need help transferring files, please consult the
file transfer FAQ on our site here:
http://www.mpc-samples.com/transfer.php
Enjoy the book, and happy beat making!
Contents
01
Initial Hardware & Software Set Up
5
Basic Requirements
MIDI & Audio Basics
Setting up your Audio interface in Pro Tools
MIDI Hardware Configuration
Adding your MPC as a MIDI device in Pro Tools
02
Using Pro Tools As A Sound Module
29
Overview
Pro Tools Setup
Creating Your Instrument Tracks
Setting the receiving MIDI Channels
Essential Project Settings
MPC Sequence Settings
Recording your MIDI Performances
Performing a Rough Mix
Setting a session tempo
03
Syncing Your MPC With Pro Tools
49
Overview
MIDI Syncing Protocols
Syncing with MIDI Beat Clock (Pro Tools as Master)
Syncing with MTC (MPC as Master)
Syncing with MTC (Pro Tools as Master)
04
Transferring MPC Audio Performances into Pro Tools
63
Why track our drums as audio?
Recording audio – initial steps
Audio tracking – ‘manual’ method
Audio tracking using MIDI Clock
Audio tracking using MTC
Overcoming recording problems
Multi track audio recording
Importing Audio into Pro Tools
Resampling your MPC outputs
MPC Audio Tracks (JJ OS)
MPC5000 hard disk recording export
05
Transferring MPC MIDI Sequences into Pro Tools
91
MIDI Import
Assigning imported MIDI to your instruments
Recording MIDI in real time
Fixing problems
06
Final Word
102
005 Transferring MPC MIDI Sequences to Pro Tools
In chapter 4, we ‘tracked’ out our MPC drum performances into audio tracks within
Pro Tools. These performances used sounds assigned to MPC programs, and MPCspecific event data recorded to the MPC sequencer, but ended as pure audio within
Pro Tools.
To completely remove the MPC from the equation and instead continue mixing down
our entire beat only within Pro Tools, we also need to transfer the MIDI event data
we’ve recorded on tracks 4, 5 and 6 in sequence 2 of our MPC ‘Protools’ project –
these are the tracks that trigger the Pro Tools instrument sounds, as set up in
chapter 2 of this book.
So, rather than have the MIDI data played within your MPC, we’ll simply shift that
MIDI data directly to the relevant instrument track in Pro Tools; remember, a Pro
Tools instrument track is just a MIDI track that output via an instrument plug in.
In Pro Tools, load up the ‘MIDI Tracking.ptf’ session file from the ‘Pro Tools Session
Files’ folder; this is an 80 BPM session which contains three Pro Tools instrument
tracks; bass, piano, and fx, and an audio track containing the drums we tracked over
to Pro Tools as pure audio in chapter 4.
In your MPC, load up the ‘PROTOOLS’ project, and select sequence 2 – this sequence
has bass, piano and fx MIDI tracks already recorded on tracks 4, 5 and 6, with
drums provided on tracks 1-3 using an MPC drum sample program (PT-KIT.pgm).
MIDI Import
So how do we transfer this MIDI data directly to Pro Tools? Well it’s actually quite
easy. Pro Tools will let you import MIDI data from any sequencer as long as it is in
standard MIDI file format, and luckily, all MPCs give you the option to save individual
sequences in standard MIDI file format.
What is standard MIDI file format? Well, it’s an MPC sequence file with all the MPC –
specific stuff stripped out. So, no q-link events, no filter/attack/tuning/decay events,
no program or effect bank changes etc. Instead, you have just standard MIDI
events, such as note value, velocity, duration, etc.
For this part of the tutorial, we’ll create a standard MIDI file of sequence 2 of our
‘protools’ project – so load up that project and select sequence 2. Depending on your
MPC, now do the following:
MPC1000/2500 (Akai OS)
Go to SAVE (MODE and pad 3) and under ‘type’ select ‘SAVE A SEQUENCE’. Under
‘Item’ select ‘02-PT-FINAL’. Under ‘To:’, save to the folder you currently have all
your tutorial files for this book.
Hit DO IT (F6) to bring up the ‘Save A Sequence’ screen:
Use your jog wheel to change SEQ to MID. This will save your sequence as a
standard MIDI file. Hit DO IT (F5).
JJ OS
Go to SAVE (MODE and pad 3) and in the top left of the screen, select ‘Save: A
SEQUENCE’. From the list, select ‘Sq:02-PT-FINAL’.
Hit DO IT (F6) to bring up the ‘Save A Sequence’ screen:
Use your jog wheel to change SEQ to MID. This will save your sequence as a
standard MIDI file. Hit DO IT (F5).
MPC500
Go to SAVE (MODE and pad 3). Change ‘Save’ to ‘Sequence’, and ‘Item’ to ’02-PTFINAL’.
Press DO IT to show the ‘save a sequence screen’:
Select the save type as ‘Mid’, giving you a standard MIDI file. Press DO IT.
MPC5000
The MPC5000 only saves in standard MIDI file format. Go to DISK (MODE and pad
3), select SAVE (F2) and choose a location to save the file. Under ‘Type’, select
‘SAVE A SEQUENCE’ and under ‘Item’ select ’02-PT-FINAL’.
Hit DO IT and your MIDI file is saved.
MPC2000/XL
The MPC2000/XL saves all its files in standard MIDI format by default. Go to SAVE
(SHIFT and ENTER) and under ‘Type’ select ‘Save a Sequence’, under ‘File’ select 02PT-FINAL’.
Hit DO IT (F6) to bring up the ‘Save A Sequence’ screen:
Choose ‘MIDI FILE TYPE 1’ and hit SAVE (F5).
You’ll now have a single MIDI file containing all the tracks from your MPC sequence.
To import this file into Pro Tools, simply go to ‘File > Import > MIDI’
MPC3000/60
Press the DISK key, then 1 (‘A Sequence’).
Choose ‘MIDI FILE TYPE 1’ and hit <Do it>.
MPC4000
Go to [SAVE] > SAVE SEQUENCE. From the ‘Sequence List’, select sequence 2 (PTFINAL) and MIDI File Type: 1. Hit DO IT.
You’ll now have a single MIDI file containing all the tracks from your MPC sequence.
To import this file into Pro Tools, simply go to ‘File > Import > MIDI’
Now select the MIDI file you created (or use my version from the session folder ‘PTFINAL.MID’).
Leave the default settings as shown in the screenshot above, and hit OK. You should
see the following:
Pro Tools has now inserted all the used tracks from your MPC sequence and placed
them each as unique tracks in your Pro Tools session. We don’t need the drum
tracks, so go to the ‘Track’ block and ‘shift-click’ the kick, snare and hat tracks so
only they are selected.
Right click on that selection and select ‘Delete’ to remove them from the session.
What we want now is for the MIDI events on this newly imported ‘Bass’ track to play
the double bass on our original ‘Bass’ track. There are a few ways we can do this,
here’s two possibilities:
1) Copy and paste method
We can just copy and paste the imported events into our existing instrument track.
Go to the ‘selector’ tool and double click in the track view for the imported ‘Bass’
track, so all the imported events are selected. Hit CMD & C (or CTRL & C on a PC) so
those events are copied.
Now click in the original ‘bass’ instrument track, press the ‘Return to Zero’ transport
button, and paste those events into your instrument track.
Press ‘play’ in Pro Tools and you should hear your bass play back via your instrument
track. You can now delete the imported bass track.
2) Reassigning the MIDI track output
Instead of copying the imported events, we can keep the imported track and reroute its output via the existing bass instrument track. Go to ‘Window > Mix’ and
select the ‘MIDI Output Selector’ for the imported bass track.
Click and select the same output we assigned to the original instrument track, which
was the Xpand2 1 plug in, via MIDI channel 1:
Press PLAY and your bass should play back.
Obviously method one is the ‘cleanest’ as it uses just a single instrument track. With
the second method, you have two tracks to maintain, although in older versions of
Pro Tools (before instrument tracks were introduced), it was common to have MIDI
on one track routed via an instrument plug in an aux track (and it’s still used, for
example, to route several MIDI tracks through the same instrument). So it’s up to
you which method you prefer. Whichever method you choose, repeat for all three
imported tracks.
That’s the end of this free preview of the ‘Using the Akai MPC
With Pro Tools’ – you can purchase the full book at MPCTutor.com:
http://www.mpc-tutor.com/product/using-the-akai-mpc-with-protools/
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising