IEEE 802.1Q-in-Q VLAN Tag Termination

IEEE 802.1Q-in-Q VLAN Tag Termination
IEEE 802.1Q-in-Q VLAN Tag Termination
Encapsulating IEEE 802.1Q VLAN tags within 802.1Q enables service providers to use a single VLAN
to support customers who have multiple VLANs. The IEEE 802.1Q-in-Q VLAN Tag Termination feature
on the subinterface level preserves VLAN IDs and keeps traffic in different customer VLANs segregated.
Feature History for the IEEE 802.1Q-in-Q VLAN Tag Termination Feature
Release
Modification
12.3(7)T
This feature was introduced.
12.3(7)XI1
This feature was implemented on the Cisco 10000 series router.
Finding Support Information for Platforms and Cisco IOS Software Images
Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image
support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on
Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at
the login dialog box and follow the instructions that appear.
Contents
•
Prerequisites for IEEE 802.1Q-in-Q VLAN Tag Termination, page 2
•
Restrictions for IEEE 802.1Q-in-Q VLAN Tag Termination, page 2
•
Information About IEEE 802.1Q-in-Q VLAN Tag Termination, page 2
•
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination, page 6
•
Configuration Examples for IEEE 802.1Q-in-Q VLAN Tag Termination, page 11
•
Additional References, page 13
•
Command Reference, page 14
Americas Headquarters:
Cisco Systems, Inc., 170 West Tasman Drive, San Jose, CA 95134-1706 USA
IEEE 802.1Q-in-Q VLAN Tag Termination
Prerequisites for IEEE 802.1Q-in-Q VLAN Tag Termination
Prerequisites for IEEE 802.1Q-in-Q VLAN Tag Termination
•
You have checked Feature Navigator to verify that your Cisco device and software image support
this feature.
•
You must be connected to an Ethernet device which supports double VLAN tag
imposition/disposition or switching.
Restrictions for IEEE 802.1Q-in-Q VLAN Tag Termination
The following restrictions apply to the Cisco 10000 series router:
•
Supported on Ethernet, FastEthernet, or Gigabit Ethernet interfaces.
•
Supports only Point-to-Point Protocol over Ethernet (PPPoE) packets that are double-tagged for
Q-in-Q VLAN tag termination.
•
IP and Multiprotocol Label Switching (MPLS) packets are not supported.
•
Modular QoS can be applied to unambiguous subinterfaces only.
•
Limited ACL support.
Information About IEEE 802.1Q-in-Q VLAN Tag Termination
This section lists the concepts that the user should understand in order to perform the tasks in the “How
to Configure IEEE 802.1Q-in-Q VLAN Tag Termination” section on page 6. The following concepts are
described in this section:
•
IEEE 802.1Q-in-Q VLAN Tag Termination on Subinterfaces, page 2
•
Cisco 10000 Series Router Application, page 4
•
Unambiguous and Ambiguous Subinterfaces, page 5
IEEE 802.1Q-in-Q VLAN Tag Termination on Subinterfaces
IEEE 802.1Q-in-Q VLAN Tag Termination simply adds another layer of IEEE 802.1Q tag (called “metro
tag” or “PE-VLAN”) to the 802.1Q tagged packets that enter the network. The purpose is to expand the
VLAN space by tagging the tagged packets, thus producing a “double-tagged” frame. The expanded
VLAN space allows the service provider to provide certain services, such as Internet access on specific
VLANs for specific customers, and yet still allows the service provider to provide other types of services
for their other customers on other VLANs.
Generally the service provider’s customers require a range of VLANs to handle multiple applications.
Service providers can allow their customers to use this feature to safely assign their own VLAN IDs on
subinterfaces because these subinterface VLAN IDs are encapsulated within a service-provider
designated VLAN ID for that customer. Therefore there is no overlap of VLAN IDs among customers,
nor does traffic from different customers become mixed. The double-tagged frame is “terminated” or
assigned on a subinterface with an expanded encapsulation dot1q command that specifies the two
VLAN ID tags (outer VLAN ID and inner VLAN ID) terminated on the subinterface. See Figure 1 on
page 3.
2
IEEE 802.1Q-in-Q VLAN Tag Termination
Information About IEEE 802.1Q-in-Q VLAN Tag Termination
IEEE 802.1Q-in-Q VLAN Tag Termination is generally supported on whichever Cisco IOS features or
protocols are supported on the subinterface; the exception is that Cisco 10000 series router only supports
PPPoE. For example if you can run PPPoE on the subinterface, you can configure a double-tagged frame
for PPPoE. The only restriction is whether you assign ambiguous or unambiguous subinterfaces for the
inner VLAN ID. See the “Unambiguous and Ambiguous Subinterfaces” section on page 5.
Note
The Cisco 10000 series router only supports PPPoE over Q-in-Q (PPPoEQinQ).
The primary benefit for the service provider is reduced number of VLANs supported for the same
number of customers. Other benefits of this feature include:
•
PPPoE scalability. By expanding the available VLAN space from 4096 to approximately 16.8
million (4096 times 4096), the number of PPPoE sessions that can be terminated on a given interface
is multiplied.
•
When deploying Gigabyte Ethernet DSL Access Multiplexer (DSLAM) in wholesale model, you can
assign the inner VLAN ID to represent the end-customer virtual circuit (VC) and assign the outer
VLAN ID to represent the service provider ID.
The Q-in-Q VLAN tag termination feature is simpler than the IEEE 802.1Q tunneling feature deployed
for the Catalyst 6500 series switches or the Catalyst 3550 and Catalyst 3750 switches. Whereas switches
require IEEE 802.1Q tunnels on interfaces to carry double-tagged traffic, routers need only encapsulate
Q-in-Q VLAN tags within another level of 802.1Q tags in order for the packets to arrive at the correct
destination.
Untagged, 802.1Q-Tagged, and Double-Tagged Ethernet Frames
Source
address
Destination
Length/
address
EtherType
DA
SA
Len/Etype
DA
SA
Etype
DA
SA
Etype
Frame Check
Sequence
Data
Tag
Tag
FCS
Len/Etype
Etype
Tag
Original Ethernet frame
Data
FCS
Len/Etype
802.1Q frame from
customer network
Data
FCS
116115
Figure 1
Double-tagged
frame
3
IEEE 802.1Q-in-Q VLAN Tag Termination
Information About IEEE 802.1Q-in-Q VLAN Tag Termination
Cisco 10000 Series Router Application
For the emerging broadband Ethernet-based DSLAM market, the Cisco 10000 router supports Q-in-Q
encapsulation. With the Ethernet-based DSLAM model shown in Figure 2, customers typically get their
own VLAN and all these VLANs are aggregated on a DSLAM.
Figure 2
Broadband Ethernet-based DSLAM Model of Q-in-Q VLANs
VLAN aggregation on a DSLAM will result in a lot of aggregate VLANs that at some point need to be
terminated on the broadband remote access servers (BRAS). Although the model could connect the
DSLAMs directly to the BRAS, a more common model uses the existing Ethernet-switched network
where each DSLAM VLAN ID is tagged with a second tag (Q-in-Q) as it connects into the
Ethernet-switched network.
The only model that is supported is PPPoE over Q-in-Q (PPPoEoQinQ). This can either be a PPP
terminated session or as a L2TP LAC session. No IP over Q-in-Q is supported.
The Cisco 10000 series router already supports plain PPPoE and PPP over 802.1Q encapsulation.
Supporting PPP over Q-in-Q encapsulation is new. PPP over Q-in-Q encapsulation processing is an
extension to 802.1q encapsulation processing. A Q-in-Q frame looks like a VLAN 802.1Q frame, only
it has two 802.1Q tags instead of one. See Figure 1.
PPP over Q-in-Q encapsulation supports configurable outer tag Ethertype. The configurable Ethertype
field values are 0x8100 (default), 0x9100, and 0x9200. See Figure 3.
4
IEEE 802.1Q-in-Q VLAN Tag Termination
Information About IEEE 802.1Q-in-Q VLAN Tag Termination
Figure 3
DA
Supported Configurable Ethertype Field Values
SA
0x8100
0x9100
0x9200
Tag
0x8100
Tag
Len/Etype
Data
FCS
Security ACL Application on the Cisco 10000 Router
The IEEE 802.1Q-in-Q VLAN Tag Termination feature provides limited security access control list
(ACL) support for the Cisco 10000 series router.
If you apply an ACL to PPPoE traffic on a Q-in-Q subinterface in a VLAN, apply the ACL directly on
the PPPoE session, using virtual access interfaces (VAIs) or RADIUS attribute 11 or 242.
You can apply ACLs to virtual access interfaces by configuring them under virtual template interfaces.
You can also configure ACLs by using RADIUS attribute 11 or 242. When you use attribute 242, a
maximum of 30,000 sessions can have ACLs.
ACLs that are applied to the VLAN Q-in-Q subinterface have no effect and are silently ignored. In the
following example, ACL 1 that is applied to the VLAN Q-in-Q subinterface level will be ignored:
Router(config)# interface FastEthernet3/0/0.100
Router(config-subif)# encapsulation dot1q 100 second-dot1q 200
Router(config-subif)# ip access-group 1
Unambiguous and Ambiguous Subinterfaces
The encapsulation dot1q command is used to configure Q-in-Q termination on a subinterface. The
command accepts an Outer VLAN ID and one or more Inner VLAN IDs. The outer VLAN ID always
has a specific value, while inner VLAN ID can either be a specific value or a range of values.
A subinterface that is configured with a single Inner VLAN ID is called an unambiguous Q-in-Q
subinterface. In the following example, Q-in-Q traffic with an Outer VLAN ID of 101 and an Inner
VLAN ID of 1001 is mapped to the Gigabit Ethernet 1/0.100 subinterface:
Router(config)# interface gigabitEehernet1/0.100
Router(config-subif)# encapsulation dot1q 101 second-dot1q 1001
A subinterface that is configured with multiple Inner VLAN IDs is called an ambiguous Q-in-Q
subinterface. By allowing multiple Inner VLAN IDs to be grouped together, ambiguous Q-in-Q
subinterfaces allow for a smaller configuration, improved memory usage and better scalability.
In the following example, Q-in-Q traffic with an Outer VLAN ID of 101 and Inner VLAN IDs anywhere
in the 2001-2100 and 3001-3100 range is mapped to the Gigabit Ethernet 1/0.101 subinterface.:
Router(config)# interface gigabitethernet1/0.101
Router(config-subif)# encapsulation dot1q 101 second-dot1q 2001-2100,3001-3100
Ambiguous subinterfaces can also use the any keyword to specify the inner VLAN ID.
See the “Configuration Examples for IEEE 802.1Q-in-Q VLAN Tag Termination” section on page 11
for an example of how VLAN IDs are assigned to subinterfaces, and for a detailed example of how the
any keyword is used on ambiguous subinterfaces.
Only PPPoE is supported on ambiguous subinterfaces. Standard IP routing is not supported on
ambiguous subinterfaces.
5
IEEE 802.1Q-in-Q VLAN Tag Termination
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
Note
On the Cisco 10000 series router, Modular QoS services are only supported on unambiguous
subinterfaces.
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
This section contains the following tasks:
•
Configuring the Interfaces for IEEE 802.1Q-in-Q VLAN Tag Termination, page 6 (required)
•
Verifying the IEEE 802.1Q-in-Q VLAN Tag Termination, page 8 (optional)
Configuring the Interfaces for IEEE 802.1Q-in-Q VLAN Tag Termination
Perform this task to configure the main interface used for the Q-in-Q double tagging and to configure
the subinterfaces. An optional step in this task shows you how to configure the EtherType field to be
0x9100 for the outer VLAN tag, if that is required. After the subinterface is defined, the 802.1Q
encapsulation is configured to use the double tagging.
Prerequisites
For the Cisco 10000 series router:
•
PPPoE is already configured.
•
Virtual private dial-up network (VPDN) is enabled.
SUMMARY STEPS
Steps to configure EtherType field for outer VLAN tag (Optional):
1.
enable
2.
configure terminal
3.
interface type number
4.
dot1q tunneling ethertype ethertype
Steps to configure the Q-in-Q Subinterface (Required):
5.
interface type number.subinterface-number
6.
encapsulation dot1q vlan-id second-dot1q {any | vlan-id | vlan-id-vlan-id[,vlan-id-vlan-id]}
7.
pppoe enabled [group group-name]
8.
exit
9.
Repeat Step 5 to configure another subinterface.
10. Repeat Step 6 and Step 7 to specify the VLAN tags to be terminated on the subinterface and to
enable PPPoE sessions on the subinterface.
11. end
6
IEEE 802.1Q-in-Q VLAN Tag Termination
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
DETAILED STEPS
Step 1
Command or Action
Purpose
enable
Enables privileged EXEC mode.
•
Enter your password if prompted.
Example:
Router> enable
Step 2
configure terminal
Enters global configuration mode.
Example:
Router# configure terminal
Step 3
interface type number
Configures an interface and enters interface configuration
mode.
Example:
Router(config)# interface gigabitethernet 1/0/0
Step 4
dot1q tunneling ethertype ethertype
Example:
(Optional) Defines the Ethertype field type used by peer
devices when implementing Q-in-Q VLAN tagging.
•
Use this command if the Ethertype of peer devices is
0x9100 or 0x9200 (0x9200 is only supported on the
Cisco 10000 series router).
•
Cisco 10000 series router supports both the 0x9100 and
0x9200 Ethertype field types.
Router(config-if)# dot1q tunneling ethertype
0x9100
Step 5
interface type number.subinterface-number
Configures a subinterface and enters subinterface
configuration mode.
Example:
Router(config-if)# interface gigabitethernet
1/0/0.1
Step 6
encapsulation dot1q vlan-id second-dot1q {any |
vlan-id | vlan-id-vlan-id[,vlan-id-vlan-id]}
(Required) Enables the 802.1Q encapsulation of traffic on a
specified subinterface in a VLAN.
•
Use the second-dot1q keyword and the vlan-id
argument to specify the VLAN tags to be terminated on
the subinterface.
•
In this example, an unambiguous Q-in-Q subinterface
is configured because only one inner VLAN ID is
specified.
•
Q-in-Q frames with an outer VLAN ID of 100 and an
inner VLAN ID of 200 will be terminated.
Example:
Router(config-subif)# encapsulation dot1q 100
second-dot1q 200
Step 7
pppoe enable [group group-name]
Enables PPPoE sessions on a subinterface.
Example:
The example specifies that the PPPoE profile, vpn1, will be
used by PPPoE sessions on the subinterface.
Router(config-subif)# pppoe enable group vpn1
Step 8
exit
Example:
Router(config-subif)# exit
Exits subinterface configuration mode and returns to
interface configuration mode.
•
Repeat this step one more time to exit interface
configuration mode.
7
IEEE 802.1Q-in-Q VLAN Tag Termination
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
Step 9
Command or Action
Purpose
Repeat Step 5 to configure another subinterface.
(Optional) Configures a subinterface and enters
subinterface configuration mode.
Example:
Router(config-if)# interface gigabitethernet
1/0/0.2
Step 10
Repeat Step 6 and Step 7 to specify the VLAN tags to Step 6 enables the 802.1Q encapsulation of traffic on a
be terminated on the subinterface.
specified subinterface in a VLAN.
•
Use the second-dot1q keyword and the vlan-id
argument to specify the VLAN tags to be terminated on
the subinterface.
•
In the example, an ambiguous Q-in-Q subinterface is
configured because a range of inner VLAN IDs is
specified.
•
Q-in-Q frames with an outer VLAN ID of 100 and an
inner VLAN ID in the range of 100 to 199 or 201 to 600
will be terminated.
Example:
Router(config-subif)# encapsulation dot1q 100
second-dot1q 100-199,201-600
Example:
Router(config-subif)# pppoe enable group vpn1
Step 7 enables PPPoE sessions on the subinterface. The
example specifies that the PPPoE profile, vpn1, will be used
by PPPoE sessions on the subinterface.
Note
Step 11
Step 7 is required for the Cisco 10000 series router
because it only supports PPPoEoQinQ traffic.
Exits subinterface configuration mode and returns to
privileged EXEC mode.
end
Example:
Router(config-subif)# end
Verifying the IEEE 802.1Q-in-Q VLAN Tag Termination
Perform this optional task to verify the configuration of the IEEE 802.1Q-in-Q VLAN Tag Termination
feature.
SUMMARY STEPS
1.
enable
2.
show running-config
3.
show vlans dot1q [internal | interface-type interface-number.subinterface-number [detail] |
outer-id [interface-type interface-number | second-dot1q [inner-id | any]] [detail]]
DETAILED STEPS
Step 1
enable
Enables privileged EXEC mode. Enter your password if prompted.
Router> enable
8
IEEE 802.1Q-in-Q VLAN Tag Termination
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
Step 2
show running-config
Use this command to show the currently running configuration on the device. You can use delimiting
characters to display only the relevant parts of the configuration.
The following shows the currently running configuration on a Cisco 7300 series router:
Router# show running-config
.
.
.
interface FastEthernet0/0.201
encapsulation dot1Q 201
ip address 10.7.7.5 255.255.255.252
!
interface FastEthernet0/0.401
encapsulation dot1Q 401
ip address 10.7.7.13 255.255.255.252
!
interface FastEthernet0/0.201999
encapsulation dot1Q 201 second-dot1q
pppoe enable
!
interface FastEthernet0/0.2012001
encapsulation dot1Q 201 second-dot1q
ip address 10.8.8.9 255.255.255.252
!
interface FastEthernet0/0.2012002
encapsulation dot1Q 201 second-dot1q
ip address 10.8.8.13 255.255.255.252
!
interface FastEthernet0/0.4019999
encapsulation dot1Q 401 second-dot1q
pppoe enable
!
interface GigabitEthernet5/0.101
encapsulation dot1Q 101
ip address 10.7.7.1 255.255.255.252
!
interface GigabitEthernet5/0.301
encapsulation dot1Q 301
ip address 10.7.7.9 255.255.255.252
!
interface GigabitEthernet5/0.301999
encapsulation dot1Q 301 second-dot1q
pppoe enable
!
interface GigabitEthernet5/0.1011001
encapsulation dot1Q 101 second-dot1q
ip address 10.8.8.1 255.255.255.252
!
interface GigabitEthernet5/0.1011002
encapsulation dot1Q 101 second-dot1q
ip address 10.8.8.5 255.255.255.252
!
interface GigabitEthernet5/0.1019999
encapsulation dot1Q 101 second-dot1q
pppoe enable
any
2001
2002
100-900,1001-2000
any
1001
1002
1-1000,1003-2000
.
.
9
IEEE 802.1Q-in-Q VLAN Tag Termination
How to Configure IEEE 802.1Q-in-Q VLAN Tag Termination
.
The following shows the currently running configuration on a Cisco 10000 series router:
Router# show running-config
.
.
.
interface FastEthernet1/0/0.201
encapsulation dot1Q 201
ip address 10.7.7.5 255.255.255.252
!
interface FastEthernet1/0/0.401
encapsulation dot1Q 401
ip address 10.7.7.13 255.255.255.252
!
interface FastEthernet1/0/0.201999
encapsulation dot1Q 201 second-dot1q any
pppoe enable
!
interface FastEthernet1/0/0.4019999
encapsulation dot1Q 401 second-dot1q 100-900,1001-2000
pppoe enable
!
interface GigabitEthernet5/0/0.101
encapsulation dot1Q 101
ip address 10.7.7.1 255.255.255.252
!
interface GigabitEthernet5/0/0.301
encapsulation dot1Q 301
ip address 10.7.7.9 255.255.255.252
!
interface GigabitEthernet5/0/0.301999
encapsulation dot1Q 301 second-dot1q any
pppoe enable
!
interface GigabitEthernet5/0/0.1019999
encapsulation dot1Q 101 second-dot1q 1-1000,1003-2000
pppoe enable
.
.
.
Step 3
show vlans dot1q [internal | interface-type interface-number.subinterface-number [detail] | outer-id
[interface-type interface-number | second-dot1q [inner-id | any]] [detail]]
Use this command to show the statistics for all the 802.1Q VLAN IDs. In this example, only the outer
VLAN ID is displayed.
Note
The show vlans dot1q command is not supported on the Cisco 10000 series router.
Router# show vlans dot1q
Total statistics for 802.1Q VLAN 1:
441 packets, 85825 bytes input
1028 packets, 69082 bytes output
Total statistics for 802.1Q VLAN 101:
5173 packets, 510384 bytes input
3042 packets, 369567 bytes output
Total statistics for 802.1Q VLAN 201:
10
IEEE 802.1Q-in-Q VLAN Tag Termination
Configuration Examples for IEEE 802.1Q-in-Q VLAN Tag Termination
1012 packets,
1018 packets,
Total statistics
3163 packets,
1011 packets,
Total statistics
1012 packets,
1010 packets,
119254 bytes input
120393 bytes output
for 802.1Q VLAN 301:
265272 bytes input
120750 bytes output
for 802.1Q VLAN 401:
119254 bytes input
119108 bytes output
Configuration Examples for IEEE 802.1Q-in-Q VLAN Tag
Termination
This section contains the following example:
•
Configuring any Keyword on Subinterfaces for IEEE 802.1Q-in-Q VLAN Tag Termination:
Example, page 11
Configuring any Keyword on Subinterfaces for IEEE 802.1Q-in-Q VLAN Tag
Termination: Example
Some ambiguous subinterfaces can use the any keyword for the inner VLAN ID specification. The any
keyword represents any inner VLAN ID that is not explicitly configured on any other interface. In the
following example, seven subinterfaces are configured with various outer and inner VLAN IDs.
Note
The any keyword can be configured on only one subinterface of a specified physical interface and outer
VLAN ID.
interface GigabitEthernet1/0/0.1
encapsulation dot1q 100 second-dot1q 100
interface GigabitEthernet1/0/0.2
encapsulation dot1q 100 second-dot1q 200
interface GigabitEthernet1/0/0.3
encapsulation dot1q 100 second-dot1q 300-400,500-600
interface GigabitEthernet1/0/0.4
encapsulation dot1q 100 second-dot1q any
interface GigabitEthernet1/0/0.5
encapsulation dot1q 200 second-dot1q 50
interface GigabitEthernet1/0/0.6
encapsulation dot1q 200 second-dot1q 1000-2000,3000-4000
interface GigabitEthernet1/0/0.7
encapsulation dot1q 200 second-dot1q any
Table 1 shows which subinterfaces are mapped to different values of the outer and inner VLAN ID on
Q-in-Q frames that come in on Gigabit Ethernet interface 1/0/0.
11
IEEE 802.1Q-in-Q VLAN Tag Termination
Configuration Examples for IEEE 802.1Q-in-Q VLAN Tag Termination
Table 1
Subinterfaces Mapped to Outer and Inner VLAN IDs for GE Interface 1/0/0
Outer VLAN ID
Inner VLAN ID
Subinterface mapped to
100
1 through 99
GigabitEthernet1/0/0.4
100
100
GigabitEthernet1/0/0.1
100
101 through 199
GigabitEthernet1/0/0.4
100
200
GigabitEthernet1/0/0.2
100
201 through 299
GigabitEthernet1/0/0.4
100
300 through 400
GigabitEthernet1/0/0.3
100
401 through 499
GigabitEthernet1/0/0.4
100
500 through 600
GigabitEthernet1/0/0.3
100
601 through 4095
GigabitEthernet1/0/0.4
200
1 through 49
GigabitEthernet1/0/0.7
200
50
GigabitEthernet1/0/0.5
200
51 through 999
GigabitEthernet1/0/0.7
200
1000 through 2000
GigabitEthernet1/0/0.6
200
2001 through 2999
GigabitEthernet1/0/0.7
200
3000 through 4000
GigabitEthernet1/0/0.6
200
4001 through 4095
GigabitEthernet1/0/0.7
A new subinterface is now configured:
interface GigabitEthernet1/0/0.8
encapsulation dot1q 200 second-dot1q 200-600,900-999
Table 2 shows the changes made to the table for the outer VLAN ID of 200. Notice that subinterface
1/0/0.7 configured with the any keyword now has new inner VLAN ID mappings.
Table 2
12
Subinterfaces Mapped to Outer and Inner VLAN IDs for GE Interface 1/0/0—Changes
Resulting from Configuring GE Subinterface 1/0/0.8
Outer VLAN ID
Inner VLAN ID
Subinterface mapped to
200
1 through 49
GigabitEthernet1/0/0.7
200
50
GigabitEthernet1/0/0.5
200
51 through 199
GigabitEthernet1/0/0.7
200
200 through 600
GigabitEthernet1/0/0.8
200
601 through 899
GigabitEthernet1/0/0.7
200
900 through 999
GigabitEthernet1/0/0.8
200
1000 through 2000
GigabitEthernet1/0/0.6
200
2001 through 2999
GigabitEthernet1/0/0.7
200
3000 through 4000
GigabitEthernet1/0/0.6
200
4001 through 4095
GigabitEthernet1/0/0.7
IEEE 802.1Q-in-Q VLAN Tag Termination
Additional References
Additional References
The following sections provide references related to the IEEE 802.1Q-in-Q VLAN Tag Termination
feature.
13
IEEE 802.1Q-in-Q VLAN Tag Termination
Command Reference
Related Documents
Related Topic
Document Title
Interface commands: complete command syntax,
command mode, defaults, usage guidelines, and
examples
Cisco IOS Interface and Hardware Component Command
Reference, Release 12.3 T
Interface configuration examples
Cisco IOS Interface and Hardware Component Configuration Guide
Standards
Standards
Title
IEEE 802.1Q
—
MIBs
MIBs
MIBs Link
No new or modified MIBs are supported by this
feature, and support for existing MIBs has not been
modified by this feature.
To locate and download MIBs for selected platforms, Cisco IOS
releases, and feature sets, use Cisco MIB Locator found at the
following URL:
http://www.cisco.com/go/mibs
RFCs
RFCs
Title
No new or modified RFCs are supported by this
feature, and support for existing RFCs has not been
modified by this feature.
—
Technical Assistance
Description
Link
Technical Assistance Center (TAC) home page,
containing 30,000 pages of searchable technical
content, including links to products, technologies,
solutions, technical tips, and tools. Registered
Cisco.com users can log in from this page to access
even more content.
http://www.cisco.com/public/support/tac/home.shtml
Command Reference
The following commands are pertinent to this feature. To see the command pages for these commands
14
IEEE 802.1Q-in-Q VLAN Tag Termination
Command Reference
and other commands used with this feature, go to the Cisco IOS Master Commands List, Release 12.4,
at http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124mindx/
124index.htm.
•
dot1q tunneling ethertype
•
encapsulation dot1q
•
show vlans dot1q
CCDE, CCENT, Cisco Eos, Cisco Lumin, Cisco Nexus, Cisco StadiumVision, Cisco TelePresence, Cisco WebEx, the Cisco logo, DCE, and
Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn and Cisco Store are service marks; and Access
Registrar, Aironet, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the
Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity,
Collaboration Without Limitation, EtherFast, EtherSwitch, Event Center, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink,
Internet Quotient, IOS, iPhone, iQuick Study, IronPort, the IronPort logo, LightStream, Linksys, MediaTone, MeetingPlace, MeetingPlace Chime
Sound, MGX, Networkers, Networking Academy, Network Registrar, PCNow, PIX, PowerPanels, ProConnect, ScriptShare, SenderBase,
SMARTnet, Spectrum Expert, StackWise, The Fastest Way to Increase Your Internet Quotient, TransPath, WebEx, and the WebEx logo are
registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.
All other trademarks mentioned in this document or website are the property of their respective owners. The use of the word partner does not imply
a partnership relationship between Cisco and any other company. (0809R)
Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and
figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and
coincidental.
© 2008 Cisco Systems, Inc. All rights reserved.
15
IEEE 802.1Q-in-Q VLAN Tag Termination
Command Reference
16
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising